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S E C T I O N  1  

SmartPlant®  Instrumentation powered by INtools® is a Windows-based program that helps you 
to design and maintain every stage in the life-cycle of plant engineering systems, from 
construction, through maintenance and modernization, to de-commissioning. 
This guide provides instructional, procedural, and reference material to help you get the most from 
SmartPlant Instrumentation.  Use it to learn the basics and later as a reference to perform specific 
tasks. 
SmartPlant Instrumentation is a straightforward, menu-driven program whose functions and 
modules are readily accessible from the menu and toolbars. 
SmartPlant Instrumentation includes the following components: 
 The Administration module, which provides all of the options required to define the 

administrative and security functions of the software.  These options include defining access 
rights, managing preferences, creating the working environment, assigning managers, tag 
convention definitions, plant hierarchy item definitions, and so forth. 

 SmartPlant Instrumentation Domain Explorer, which allows you to organize instrumentation 
items, easily navigate to them, and perform appropriate actions. 

 The main SmartPlant Instrumentation Modules, which enable you to perform a wide variety of 
engineering activities. 

The following utilities enable the transfer of external data into the SmartPlant Instrumentation 
database: 
 The Import Utility provides the means to import data into SmartPlant Instrumentation from the 

most common database file formats such as Microsoft Access, DBF files, Oracle, SQL Server, 
Sybase Adaptive Server Anywhere, ASCII delimited files, and other ODBC compatible files. 

 The Merger Utility provides the means of merging the data of either two <units> or two 
<plants> for the purpose of creating one common database for either the two <units> or the 
two <plants>. 

 
 

 

SmartPlant Instrumentation user assistance supplies command information as you perform 
tasks.  You can access different kinds of information any time you are running the software.  This 
information could include reference topics, narrative descriptions or overviews. 
SmartPlant Instrumentation offers the following important user assistance features: 

Working with SmartPlant 
Instrumentation 

Getting Started with SmartPlant 
Instrumentation User Assistance 
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Installation Guide — This document provides you with step- by-step procedures for installing 
SmartPlant Instrumentation on Oracle or SQL Server database platforms, or on Sybase Adaptive 
Server Anywhere.  It also contains important configuration information, useful tips, and 
troubleshooting advice.  The Installation Guide is presented in the .pdf file format and can easily 
be printed out.  Adobe Reader, required for the .pdf files, is available for downloading from the 
Internet. 
User's Guide — This document provides you with detailed information on SmartPlant 
Instrumentation Explorer and each SmartPlant Instrumentation module, along with 
recommended settings, examples, and useful tips.  Also included in the User Guide are 
documents which deal with the usage of SmartSketch, AutoCAD, and MicroStation CAD 
interfaces and of InfoMaker and Microsoft Access report generators in SmartPlant 
Instrumentation. 
Tutorial — The tutorial helps novice users acquire the skills necessary to start using SmartPlant 
Instrumentation, create a minimal setup for your plant, and all the basic instrument engineering 
activities for each module.  You will acquire the fundamental understanding, skills, and practical 
experience that you need to use the software with confidence.  The tutorial is presented in the .pdf 
file format and can easily be printed out.  Adobe Reader, required for the .pdf files, is available for 
downloading from the Internet. 
Online Help — SmartPlant Instrumentation Online Help provides conceptual overviews and 
procedures to help you to work efficiently with the software, as well as context-sensitive help for all 
windows and dialog boxes.  Each context-sensitive help topic provides accurate reference 
information for the displayed window or dialog box. 
To access context-sensitive help for an open window, do one of the following: 
 On the Help menu of any SmartPlant Instrumentation module, click SmartPlant 

Instrumentation Help. 
 On the toolbar, click the Help icon . 

User Interface Features — The user interface provides you with several ways to see command 
descriptions: 
 ToolTips help you find command names.  When you pause the pointer on a toolbar icon, a 

yellow label displays the command name. 
 Microhelp messages that appear at the bottom of the window inform you about the command 

you are going to execute.  Pointing to a toolbar icon or selecting a menu option displays a brief 
message on the status bar. 

Technical Support — Intergraph provides extensive technical support all over the world.  To find 
out how to get technical support, click About SmartPlant Instrumentation on the Help menu and 
then click the Tech Support button. 
 

Online Help Text Conventions 
Special Displays 
The following displays are used for features designed to capture your attention, such as warnings, 
important notes, and useful tips. 

 Indicates a caution to which you should pay attention. 
 Important information which supplements the main text. 

 General information which supplements the main text. 
 Indicates a tip, pointing out a useful feature which makes life easier for the user. 
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Keyboard Conventions 
Common functions of some keys are described below: 

Keys Example / description 

Shortcut keys Combinations of keys can be used as shortcuts.  For example, 
Ctrl + F1 means hold down the Control key while pressing F1. 

Tab In windows and dialog boxes, pressing the Tab key activates 
the next field or command button.  To activate the previous 
item, hold down the Shift key while pressing the Tab key. 

Enter In most windows and dialog boxes, pressing this key is 
equivalent to clicking the OK or Save command buttons. 

Escape In most windows and dialog boxes, pressing this key is 
equivalent to clicking the Cancel command button. 

Arrow keys Use these keys to move between fields in data tables. 

Numeric keypad If you have an extended keyboard, you can type numbers with 
the numeric keypad if you press Num Lock key to turn the Num 
Lock indication on. 

Mouse Conventions 
The left mouse button is the one referred to, unless otherwise stated. 

To Do this 

Point Position the pointer on an item. 

Click Point to an item, then quickly press and release the mouse 
button. 

Double-click Point to an item, then quickly press and release the mouse 
button twice. 

Drag Point to an item, and while holding down the mouse button on 
the item, move the item to a new location.  When the pointer is 
at the desired location, release the mouse button. 

 
 

Getting Started Common Tasks 
The following general tasks are used when getting started: 

Start SmartPlant Instrumentation 
This procedure explains how to log on to SmartPlant Instrumentation, where to select the required 
domain and if the domain type is Owner operator, your project.  After this, you navigate to the 
<unit> you are going to work in.  Clicking OK on the Open dialog box brings you to the SmartPlant 
Instrumentation environment.  For more information, see Start SmartPlant Instrumentation (on 
page 18). 
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Open a Different Domain 
This procedure shows you how you can move from working in the current domain to a different 
one.  For more information, see Open a Different Domain (on page 19). 

Change the Logon Password 
This procedure allows you to change the password that you use when logging on to SmartPlant 
Instrumentation.  Changing SmartPlant Instrumentation logon passwords does not apply to users 
who log on to the software using Windows authentication logon method.  For more information, 
see Change the Logon Password (on page 19). 

Switch to a Different Unit 
This procedure makes it possible to switch from the current <unit> to another <unit>.  For more 
information, see Switch to a Different Unit (on page 20). 

Open a Module 
Use this procedure to open a specific SmartPlant Instrumentation module.  You can open any 
module whether or not other modules are already open.  Access to a particular module is subject 
to your having appropriate access rights.  For more information, see Open a Module (on 
page 20). 
 

Start SmartPlant Instrumentation 
When starting SmartPlant Instrumentation, a splash screen appears, showing the current version 
number, followed by the Logon Information dialog box, where you select the required database 
and enter your user name and password.  After logging on to SmartPlant Instrumentation, the 
software displays the Open dialog box, where you select the desired domain or project in an 
owner operator domain.  After this, you navigate to the <unit> you are going to work in.  Clicking 
OK on the Open dialog box brings you to the SmartPlant Instrumentation environment. 

 
 User names and passwords are not case-sensitive.  The software displays the password as 

asterisks. 
 If you purchased SmartPlant Instrumentation with an evaluation license, there is no limit of the 

number of times that you can log on to SmartPlant Instrumentation before the expiration date 
of the license, however after that date, you will be denied access to SmartPlant 
Instrumentation. 

 
 

Navigating in SmartPlant Instrumentation 
You access SmartPlant Instrumentation items using the SmartPlant Instrumentation Explorer. 
Also, you perform various action from SmartPlant Instrumentation modules using the menu items 
or clicking the appropriate toolbar icons in the main SmartPlant Instrumentation window.  A 
number of other options are available when you are in this window.  The window itself consists of 
the following areas: 
Menu bar — The menu bar contains access to all the actions you will perform in the module, and 
also to standard Windows features such as window layouts and Online Help. 
Toolbar — The application toolbar provides you with quick access to each module.  The module 
toolbars enable you to access the most common actions for the modules. 
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Application work area — The central region where the main module window appears. 
Status bar — The status bar provides you with quick access to information on the selected icon or 
menu item (Microhelp) or the status of a particular process (for example, exporting data).  In 
addition, it shows the plant hierarchy items and the current date and time. 
 
 

Open a Different Domain 
1. Close all SmartPlant Instrumentation modules that are open. 
2. Click File > Close. 
3. Click File > Open. 

4. On the Open dialog box, select a domain . 

5. If the project icon  appears (only when the domain type is Owner operator), double-click 
the icon to select the project you want to work with (As-Built or a project). 

6. Navigate to a desired <unit> by double-clicking the <plant>  and <area>  icons to 
expand the view and display the <units>. 

7. Select a <unit> by doing one of the following: 

 Double-click the <unit>  icon. 
 Click the <unit> once to highlight it, then click OK. 

 

Change the Logon Password 
 

 The System Administrator has rights to set logon passwords for SmartPlant Instrumentation 
users and is able to override any password changes made by other users.  Therefore, after 
changing the password, you must inform the System Administrator of such a change. 

 Changing SmartPlant Instrumentation logon passwords does not apply to users who log on to 
the software using Windows authentication logon method. 

1. Click File > Change Password. 
2. In the Current password field, type your current logon password. 

 Passwords appear masked. 
3. In the New password field, type the new password. 

 You can use alphanumeric values in either upper or lower case.  The maximum length of 
your password can be 15 characters. 

4. In the Confirm new password field, retype the new password. 
5. Click OK. 
 
 



Getting Started with SmartPlant Instrumentation User Assistance 
 

 
20 SmartPlant Instrumentation Basic Engineering User's Guide 

 

Switch to a Different Unit 
1. Close all SmartPlant Instrumentation modules that are open. 

2. On the main toolbar, click . 
3. On the Open dialog box, expand the <plant> and <area> hierarchies and navigate to the 

<unit> you require. 
4. Select a <unit> by doing one of the following: 

 Double-click the <unit>  icon. 
 Click the <unit> once to highlight it, and then click OK. 

 

Open a Module 
1. Start SmartPlant Instrumentation. 
2. Do one of the following: 

 Click the appropriate toolbar icon for the module you want to open. 
 On the Modules menu, click a desired module name. 
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S E C T I O N  2  

This section contains topics relating to the use and setting of the various SmartPlant 
Instrumentation preferences.  The preferences control the way the software displays items, 
stores data, interacts with different items and much more. Some of these preferences, such as 
temporary data paths, must be set for the software to function correctly. 
 

Display and Customize Preferences 
Use this procedure to display the default preferences or set your own preferences in SmartPlant 
Instrumentation.  Your preference settings do not affect the preferences that were defined by 
other users in the current domain or working in the current project, if the domain type is Owner 
operator 

 
 Domain Administrators have additional options that allow preferences management from the 

Administration module. 
 Certain interface options are governed by the Intools.ini file. 

1. Click File > Preferences. 
2. In the tree view, beside a desired module, click  to expand the hierarchy. 
3. Click an option to open a specific page where you can view or customize preferences. 

 The Domain Administrator can restrict the ability of other users to set their 
preferences.  Therefore, you may find that you can only view certain options but not change their 
values. 
 
 

Preferences Governed by the .INI File 
Use this topic discusses the various preference settings that you can make in the Intools.ini file. 

Intools.ini 
Document Number and Revision Level Segregation — In the Instrument Index Standard 
Browser, when you make a document revision in one <unit> and then log on to another <unit>, 
both <units> share the same document number and set of revisions.  To specify a separate 
document number and set of revisions for the current <unit>, open the Intools.ini file, and under 
the [Index] section, type the following line: 
DrawingPerLevel = Y 
This setting is needed if, for example, you are publishing documents from different <units>. 
Filter Setting — When you specify a filter setting such as a data range, and then restart the 
software, the software updates the date range in every SmartPlant Instrumentation module in 
which you use the same filter. 
ID of the <Unit> Selected Last — When you select a specific <unit> on the Open dialog box, the 
software records the <unit> ID in the Intools.ini file under the [Project] section.  The next time you 
start SmartPlant Instrumentation and display the Open dialog box, the software displays the 
<unit> you selected last. 

Preferences 
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Performance when Generating Enhanced Reports — Sometimes, the response time between 
the application server and the database server is very slow when generating enhanced 
reports.  To improve this performance, open the Intools.ini file, and under the [Loop] section, 
change the value of the DDETimeOut parameter to 20000.  This parameter has units of 
milliseconds. 
Suppression of Loop Equipment Propagation to Tag Numbers by Default — When you 
create a new loop, you can specify whether to apply the P&ID, service, and equipment to tag 
numbers.  By default, these options are selected; however, you can specify not to propagate 
these values to tag numbers that you subsequently associate with the loop.  To do so, open the 
Intools.ini file, and under the [Index] section, type the following line: 
LoopNoPropagateCheck = 1 
This setting prevents the software from removing the equipment reference from tag numbers that 
you associate with a loop that has no equipment reference. 
X and Y Positions of Certain Windows and Dialog Boxes — If you move a certain window or 
dialog box in the screen area, the software saves the X and Y positions of the window or dialog 
box in the Intools.ini file under the [Project] section.  This only applies to a small number of 
windows and dialog boxes. 

Smartloop.ini 
Hiding Macro Items when Generating Enhanced Reports — If, for a default macro such as a 
panel name, you define a filter that hides a particular macro, a dot appears in place of the 
macro.  The dot is needed to allow editing of the macro filter, adding new macros to the item 
associated with the hidden macro, or editing of the item.  If you want to hide the dots, for example 
when printing the report or saving it in a different format, you need to define the parameter 
HideItems = Y in the Smartloop.ini file. 
 
 

Preferences Dialog Box 
Customizing preferences allows you to automate a number of procedures.  Your preference 
settings do not affect the preferences that were defined by other SmartPlant Instrumentation 
users in the current domain or working in the current project, if the domain type is Owner 
operator. 
The Domain Administrator can restrict the ability of other users to set their 
preferences.  Therefore, you can find that certain options are disabled.  If you want to enable 
these options, contact your Domain Administrator, who can manage preferences from the 
Administration module. 
Tree view — Click  beside a desired module to expand the hierarchy, and then click an option 
to open a specific page where you can set your preferences. 
Pages — Using the options on the pages, you can view the default preferences set by the Domain 
Administrator.  Also, you can overwrite certain default preferences with you own settings, 
provided that the Domain Administrator has not disabled these preferences. 
Reset — Resets all the properties for the selected module to their default values.  This option 
appears when you select a module or some of the other categories such as Enhanced Reports, 
Interfaces, or SmartPlant, at the highest level of the tree view. 
Reset all — Resets all the properties in the Preferences dialog box to their default values. 
Import — Imports the domain/project preferences from the intools.ini file. 
Export — Saves the domain/project preferences to an external .dmp or .txt file. 
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The options on the General page of the Preferences dialog box enable you to customize the 
SmartPlant Instrumentation interface and set general application preferences.  These settings do 
not affect the preferences that were defined by other SmartPlant Instrumentation users in the 
current domain or working in the current project, if the domain type is Owner operator. 
When customizing the general preferences, you can: 
 Set the default locations of the main toolbar and the module toolbar. 
 Set the toolbar and icon display. 
 Automatically start SmartPlant Instrumentation with the unit and module you last worked in. 
 Set print preview options. 
 Overwrite the default logo. 

Note that the Domain Administrator can restrict your ability to set various preferences.  Therefore, 
you can find that certain options are disabled.  If you want to enable these options, contact your 
Domain Administrator, who can manage preferences from the Administration module. 
Select toolbar — Allows you to select the toolbar whose display options you want to define: Main 
Toolbar or Module Toolbar. 
Show toolbar — Makes the currently selected toolbar visible in the application.  Clear the check 
box to hide the toolbar. 
Toolbar position — The following options enable you to set the toolbar the position on your 
screen.  Click the desired option: 
 Top — Places the selected toolbar along the top of the screen right under the menu bar. 
 Bottom — Places the selected toolbar along the bottom of the screen. 
 Floating — Makes the selected toolbar float on your screen. 
 Right — Places the selected toolbar along the right edge of the screen. 
 Left — Places the selected toolbar along the left edge of the screen. 

Automatic start of the last module — Starts SmartPlant Instrumentation automatically in the 
lowest level plant hierarchy item in which you last worked.  After you select this check box, the 
software bypasses the Select Unit dialog box and automatically opens the last module that you 
worked in.  If several modules were open when closing SmartPlant Instrumentation, the software 
treats the active module as the last one. 
Overwrite logo — Retrieves automatically the current logo from the database and overwrites the 
projlogo.bmp file in the [SmartPlant Instrumentation home folder]\temp folder.  The projlogo.bmp 
file is from where SmartPlant Instrumentation takes the logo which is used in documents and 
reports.  If you clear the check box, the software retrieves the logo from the original bitmap file – in 
this way the projlogo.bmp file is not changed when switching to another domain, so that you use 
the same logo.  Clearing the check box also speeds up your work. 
Print preview options — The following options enable you to set a print preview option for report 
generation. 
 Always — Opens print previews automatically, without prompting you for confirmation. 
 Never — Automatically spools reports to the output device, without prompting you for 

confirmation. 
 Ask user (default) — Prompts you to open a report print preview before printing. 

Current report preview options — The following options enable you to compare a new report 
displayed in the Print Preview window with an existing archived report. 
 Mark changes only — Marks the changes in the print preview of a new report, if the currently 

previewed report is different from the archived report. 
 Generate changes report only — Generates a changes report after comparing a new report 

with an archived report. 
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 Mark changes and generate changes report — Generates a changes report after 
comparing a new report with an archived report and marks the changes in the print preview of 
the new report. 

Display license expiration reminder … days in advance — Allows you to specify the number 
of days (between 1 and 37) prior to license expiration that the software will display an advance 
warning. 
Temporary folder path — Allows you to specify the path to the SmartPlant Instrumentation 
temporary folder where the software stores the temporary logo and custom files.  Click Browse to 
navigate to the path. 
For example: 
C:\Program Files\SmartPlant\Instrumentation\TEMP 
In the temporary folder, the software creates temporary files during various activities that you 
perform in SmartPlant Instrumentation.  For example, when you create specifications, generate 
CAD drawings, hook-up drawings, or reports, and so forth. 

 
 In the Specifications module, when you generate the Spec Forms report, the software 

generates the report as the specprn.psr file and saves this file to the folder you specify in the 
Temporary folder path box.  If you leave this box blank, the software saves the specprn.psr 
file to the SmartPlant Instrumentation home folder and not to the PSR working folder path 
preference (on the Specifications > Export/Import page). 

 If your CAD application is MicroStation, make sure the path string does not exceed fifty two 
characters. A longer path prevents MicroStation from generating or displaying drawings or 
cells from SmartPlant Instrumentation. 

 If the System Administrator specified a global path in your domain, the global path does not 
apply to the temporary folder path. 

Output document folder — Enables you to specify the path to the folder where the software 
generates IDEAL report files.  Click Browse to navigate to the path. 
 

Copy File Locations Dialog Box 
This dialog box allows you to copy the file locations from one Enhanced Reports module to 
another, for example; from Enhanced Loop File Locations to Cable Layout File Locations. 
Copy from — Choose from the list the enhanced report that you want to copy the file locations 
from. 
Copy to — Choose from the list one or more enhanced reports that you want to copy the file 
locations to. 
Select all — Select this option when you want to copy the file locations from one enhanced report 
to all the enhanced reports. 
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Interfaces > DCS Vendors (Preferences) 
Use this option while preparing SmartPlant Instrumentation data that you want to publish for the 
DCS vendor (such as DeltaV, Yokogawa) 

DCS vendor options 
Fieldbus mode — Determines whether you can work with fieldbus devices you created in 
SmartPlant Instrumentation or with fieldbus devices you downloaded to SmartPlant 
Instrumentation.  Select this check box if you are preparing fieldbus data for publishing to the 
DCS vendor software.  When the check box is selected, on the Fieldbus tab of the Tag Number 
Properties dialog box, the contents of the fieldbus device revision list is limited according to the 
manufacturer that you select on the General tab.  Your selection of manufacturer and fieldbus 
device revision then determines function block association for a given instrument.  The software 
displays only those function blocks that belong to the downloaded fieldbus devices and makes the 
Function Blocks supporting table inaccessible. 
If you clear this check box, you can work with function blocks you create in SmartPlant 
Instrumentation.  The software hides function blocks belonging to fieldbus devices you previously 
downloaded. 
 

Claim and Merge Options (Preferences) 
The options on this page only apply in an owner operator domain.  These options allow you to set 
preferences for claiming As-Built items for a project from SmartPlant Instrumentation or merging 
project data with As-Built.  When working with As-Built data, you can either claim items directly or 
copy them to the Claim Buffer.  Then, your Project Administrator can claim these items in the 
Administration module.  When working in a project, you cannot merge items directly.  It is only 
possible to copy project data to the Administration module Merge Buffer for merging. 
These preferences determine how the software claims, merges, or copies to the Claim Buffer or 
Merge Buffer the sub-items and parent items associated with the items you select for claiming or 
merging from the Explorer windows.  Documentation dealing with claiming and merging data 
appears in the Administration module Help.  For common tasks associated with claiming data, 
see Scoping Data for Projects Common Tasks in the Administration User's Guide.  For common 
tasks associated with merging data, see Merging Project and As-Built Data Common Tasks in the 
Administration User's Guide. 
The following table shows the related data or items that the software can include in the Claim 
Buffer or Merge Buffer when you select a main item belonging to a specific item type. 

Main Item Related Items/Data Included with the Main Item 

Loop Tags with basic engineering data (process data, calculation, calibration, 
dimensional data for piping, and specification sheets, hook-up associations), 
wiring items that have a signal propagated to the loop or tag.  If you placed a 
device panel inside a cabinet or junction box, when claiming the loop, this device 
panel is not claimed or merged together with the cabinet or junction box because 
this device panel does not have a signal propagated to the loop.  You must claim 
or merge such a device panel manually. 

Instrument Basic engineering data, wiring items that have a signal propagated to the 
instrument. 
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Main Item Related Items/Data Included with the Main Item 

Wiring item (panel, 
rack, wiring 
equipment, and so 
forth 

All wiring sub-items and control system tags that appear in the appropriate wiring 
item folder in the Domain Explorer. 

Terminal strip Terminals 

Cable Cable sets, wires 

Wire Cables, cable sets 

 
 The Claim Buffer and Merge Buffer are only accessible from the Administration 

module.  For more information about the Claim Buffer, see the Administration module Help, 
Claim Buffer in the Administration User's Guide.  For more information about the Merge 
Buffer, see the Administration module Help, Merge Buffer in the Administration User's Guide. 

 Preferences that you set do not affect preferences the Project Administrator defines on the 
Preferences for Scoping and Merging Data dialog box of the Administration module. 

Include when claiming or merging items 
 No sub-items — Affects only items you selected in an Explorer window.  The associated 

sub-items are neither claimed nor copied to the buffer as dummy items. 
 Sub items — Allows you to claim, merge, or copy to the buffer the associated 

sub-items.  After you select this option, you can select any combination of the check boxes if 
you want the software to include wiring data when you perform a desired claim or merge 
operation using shortcut menu commands of an Explorer window. 
For example, if you do not select any check box, and then, in the Domain Explorer, select a 
loop or a tag, the software includes all the engineering data but does not include any wiring 
items that have a signal propagated to the loop or tag.  The engineering data that the 
software includes consists of process data, calculation, calibration, dimensional data for 
piping, and specification sheets, and hook-up associations.  To include these wiring items, 
you must select the Wiring data of tags and loops check box. 

 When you select a tag for claiming or merging, the basic engineering data is selected 
automatically.  You cannot claim or merge a specific instrument, process data sheet, and so 
forth. 
Wiring data of tags and loops — Allows you to claim, merge, or copy to the buffer all the 
wiring items that have a signal propagated to the tags and loops you select for claiming. 
Tags and loops with lowest level sub-items only — Only available after you select Wiring 
data of tags and loops.  Allows you to claim, merge, or copy to the buffer only the terminals 
and wires that have a signal propagated to the tags and loops you select for claiming.  The 
intermediate sub-items are processed as dummy. 
Wiring equipment sub-items — Only available after you select Wiring data of tags and 
loops.  Allows you to claim, merge, or copy to the buffer all the wiring items that are 
associated with wiring equipment.  For example, if you claim a tag associated with an 
apparatus, the software also claims all of the sub-items associated with the apparatus. 
Non-connected terminals and spare wires — Only available after you select Wiring data 
of tags and loops.  Allows you to claim, merge, or copy to the buffer the non-connected 
terminals and spare wires together with the other associated wiring items that have a signal. 
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Wires connected to terminals — Allows you to claim, merge, or copy to the buffer all the 
wires that are connected to terminals associated with the parent items.  For example, if you 
claim a panel, the software also claims the panel strips, the terminals, and the wires that are 
connected to the terminals. 

 If you selected a loop or tag, and also selected the Wiring data of tags and loops 
check box, the Wires connected to terminals check box does not apply to the wiring items 
associated with the loop or tag.  In this case, the software always claims, merges, or copies to 
the buffer all the wires that have signal propagated to the tag. 

When claiming items, include parent items as 
Specifies the way the software handles parent items when you claim items to a project. 
 Dummy items — Allows you to claim or copy to the Claim Buffer parent items as dummy 

items.  For example, if you claim an instrument, the source loop number appears in the project 
as a dummy item. 

 Fully-functional items — Allows you to claim or copy to the Claim Buffer parent items as 
fully-functional items.  For example, if you claim an instrument, the source loop number 
appears in the project as a fully-functional item. 

 When you claim instruments directly from the Instruments folder of the Domain Explorer, 
the source loop is always claimed as a dummy item, regardless of the value of this setting. 

When merging items, leave parent items in project as 
Specifies the way the software handles parent items when you merge items created in a project 
back to the As-Built. 
 Dummy items — When the Project Administrator merges back to the As-Built items that were 

created in the project, and this option is selected, the software removes the merged items from 
the project and leaves the parent items in the project as dummy items.  For example, when 
merging a terminal strip, the terminal strip is removed from the project and the parent panel 
remains in the project as a dummy panel.  However, if after merging the terminal strip, the 
panel has no other sub-items in the project, the software also removes the panel. 

 Fully-functional items — When the Project Administrator merges back to the As-Built items 
that were created in the project, and this option is selected, the software removes the merged 
items from the project and leaves the parent items in the project as fully-functional items. 

 If, in the project, you created a single item that has a parent item, and you merge that single 
item into the As-Built, the parent item remains in the project as a fully-functional item, regardless of 
the value of this setting. 
Copy revision data — Includes revision data of the documents associated with items that you 
claim. 
Reclaim items — Allows you to claim the same items again.  When an item exists in a project, 
reclaiming the item results in an automatic update of the project item properties, connections and 
associations.  If you deleted an item, this item reappears in the project after reclaiming. 
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Report Generator (Preferences) 
The options on the Report Generator page enable you to select whether to use the default report 
generator InfoMaker.  This setting does not affect the preferences that were defined by other 
SmartPlant Instrumentation users working in the current domain or, if the domain type is Owner 
operator, in the current project. 

Default report generator 
Report generator — Select an option: InfoMaker or None. 
Report generator program path — Type the full path and filename or click Browse to navigate 
to the InfoMaker executable file. 
 

SmartPlant Instrumentation Server (Preferences) 
These options enable you to specify preferences when using the SmartPlant Instrumentation 
Server. 
Enhanced report format — Enables you to specify the file type when generating enhanced 
reports using IDEAL.  Available options are: 
 SMA — Generates files in the native format of the Enhanced Report Utility. 
 PDF — Generates files as PDF output. 

Log file path — Enables you to specify the path to the folder where the software creates the log 
file output.  Click Browse to navigate to the path.  Note that if no path is defined or the path 
definition is invalid, the software generates the log file in the Temp folder defined in Windows. 
 

Module Icons (Preferences) 
These options enable you to customize the main toolbar by adding, removing, and rearranging the 
icons on the main toolbar in any sequence.  These settings do not affect the preferences that 
were defined by other SmartPlant Instrumentation users in the current domain or working in the 
current project, if the domain type is Owner operator. 
The Domain Administrator can restrict the ability of other users to set their 
preferences.  Therefore, you can find that certain options are disabled.  If you want to enable 
these options, contact your Domain Administrator, who can manage preferences from the 
Administration module. 

 
 An icon cannot appear on the main toolbar more than once. 
 You cannot change the original icon assignment. 
 You cannot modify the icon image. 

Placing an icon on the main toolbar 
Do one of the following: 
 Drag an icon from the Available icons pane and drop it in the Selected icons pane. 
 Double-click an icon or its name in the Available icons pane. 
 Select an icon and click Add. 
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Removing an icon from the main toolbar 
Do one of the following: 
 Drag an icon from the Selected icons pane and drop it in the Available icons pane. 
 Double-click an icon or its name in the Selected icons pane. 
 Select an icon and click Remove. 

 

This section contains information about various general topics that are used when working in 
SmartPlant Instrumentation. 
 

SmartPlant Instrumentation Data Model 
The data model is the persistent storage structure for data manipulated by SmartPlant 
Instrumentation. 
The SmartPlant Instrumentation Data Model Excel spreadsheet is a two-dimensional 
representation of the SmartPlant Instrumentation data model.  This spreadsheet lists item types, 
item properties, and data types, as well as all the constructed item attributions that apply to 
Instrumentation objects.  This list is alphabetical according to item type. The file can be found in 
the home folder where you have installed SmartPlant Instrumentation. 
 

Searching for Tag and Loop Numbers 
SmartPlant Instrumentation provides you with several options to find the tag and loop numbers 
that you require to work with. 
You can look for your tag and loop numbers in the SmartPlant Instrumentation Explorer or you 
can use the search facilities provided in the pertinent modules.  For more information, see Search 
for Items in SmartPlant Instrumentation Explorer (on page 542). 
While working in a module, you can search for tag or loop numbers in different ways.  You can 
enter search parameters and find tag or loop numbers that match the search parameters that you 
specified.  If you do not specify any search parameters, the software finds all the existing tag or 
loop numbers in the current <unit>.  In the Process Data and Calibrations modules, you can 
search for tag numbers either in the current <unit>, or in all the <units> of the current 
<plant>.  You can also look for typical tags created in the current domain. 
You search for tag numbers in the Find Tag dialog box.  There are many cases where the 
software opens the Find Tag dialog box.  You can look for tag numbers after clicking Find in 
dialog boxes that prompt you to enter a tag number.  Also, you can look for tag numbers when 
opening a process data sheet, when editing, duplicating, or deleting a tag number, or when 
calculating or calibrating tag numbers, and so forth. 
You search for loop numbers in the Find Loop dialog box.  The software opens the Find Loop 
dialog box whenever you need to search for a loop number.  There are many cases where the 
Find Loop dialog box opens: clicking Find in a dialog box that prompts you to enter a loop 
number opens the Find Loop dialog box.  For example, you can click Find when you want to edit 
or duplicate one or more loop numbers in the Instrument Index module. 
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Search for All Tag Numbers 
This topic explains how to find all the existing tag numbers in the current <unit>.  In the Calibration 
and Process Data modules, you can search for tag numbers in all the <units> of the current 
<plant>.  In the Process Data module, you can find tag numbers in all units when searching for tag 
numbers to generate instrument reports. 
1. In the Find Tag dialog box, do not enter any other values in the Search parameter fields. 

 In the Calibration or Process Data module, select Look in the entire current plant if 
you want to find tags in all the <units> of the current <plant>. 

2. Click Find. 
 Select the Show more search results check box to hide the search parameter fields 

and enlarge the Search results data window to display more tag rows.  Clear this check box 
to return to normal view. 

3. Select the required tag numbers in the Search results data window and click OK. 
 

Use Search Parameters to Find Tag Numbers 
This help topic explains how to find tag numbers by entering search parameters. 
Entering search parameters in the Find Tag dialog box enables you to narrow down your 
search.  You can narrow your search to the maximum by entering all the search parameters.  It is 
up to you what search parameters to specify.  You can use wildcards in the fields where you type 
values. 
Leaving some of the Search parameter fields empty widens the search.  If you do not specify any 
search parameters, the software finds all the existing tag numbers. 
After the search is complete, the software displays the tag numbers that match your search 
parameters in the Search results data window. 
1. In the Find Tag dialog box, from the Tag class list, select the desired tag class. 

 A conventional tag is an instrument that does not belong to the Fieldbus, Telecom, 
Typical, or Electrical classes. 

2. Use the following fields and lists in the Search parameters group box for search parameters 
that narrow your search: 

Search Parameter Explanation  Example 

Tag Number Type the whole tag number you are 
looking for.  Include any prefix, suffix, 
and separator characters.  You can 
use wildcards if needed. 

101-FT–2225/1 

Or use a wildcard 101- FT% 

Process function Select a process function to narrow 
your search to tags belonging to the 
selected process function.  This 
parameter is available in the 
Instrument Index and Process Data 
modules only. 

Flow 
Pressure 

Instrument type Select an instrument type to narrow 
your search to tags belonging to the 
selected instrument type. 

D/P Type Flow Element (FE), 
Mass Flow Transmitter (FT) 
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Search Parameter Explanation  Example 

Status Select a tag status to narrow your 
search to tags associated with the 
selected status. 

An existing device, a new 
instrument, a relocated device 

Location Select a tag location, for example, 
Field, to narrow your search to tags 
for which you have defined this 
location. 

Equipment room, junction box 

I/O type Select a I/O type to narrow your 
search to tags for which you have 
defined this I/O type. 

AO (analog output) 
DI (Digital input) 

Prefix Type the tag number prefix to find all 
the tag numbers that have this prefix 
in their names.  Do not include the 
separator characters.  The <unit> 
number segment in the tag number 
name is usually the tag number 
prefix.  You can also use wildcards if 
needed. 

101 

Number Type the numeric segment of a tag 
number to find all the tag numbers 
that have this numeric segment.  You 
can also use wildcards if needed. 

2315 

Suffix Type the suffix segment of the tag 
number to find all the tags that 
contain this suffix.  Do not type the 
slash (/) character.  You can also use 
wildcards if needed. 

1 (the number following the 
slash (/) in tag number 
101–FT–2225/1) 

Equipment Select equipment to narrow your 
search to tags for which you have 
defined this equipment. 

 

Line Select a line to narrow your search to 
tags with which you have associated 
this line.  This parameter is not 
available in the Process Data and 
Specifications modules. 

 

Form number Select a specification form number to 
narrow your search to tags for which 
you have defined this form 
number.  This parameter is available 
in the Specifications module only. 

 

Date range Type dates or use spinners to narrow 
your search to a given date 
range.  This parameter is available in 
the Specifications module only. 

 

3. To broaden the search to include all of the <units> in a given <plant>, select Look in the 
entire <plant>. 
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 This field is available in the Calibration module, and in the course of various procedures 
in the Process Data and Specifications modules. 

4. Click Find. 
 Select the Show more search results check box to hide the search parameter fields 

and enlarge the Search results data window to display more tag rows.  Clear this check box 
to return to normal view. 

5. In the Search results data window, do one of the following: 
 Select the desired tag number. 
 Press and hold down Ctrl to select multiple tag numbers. 

Multi-selection is available in the Calculation module when you select tags for batch 
calculation, in the Process Data module for instrument report generation, and in the 
Specifications module.  You can also select the Select all check box to select all the 
displayed tag numbers. 

6. Click OK. 
 To specify search parameters in the Calibration module, you need to perform a separate 

procedure.  For details, see Searching for Tag Numbers in the Calibration Module. 
 

Search for Typical Tags 
This help topic explains how to find all the existing typical tag numbers in the current domain. You 
perform the search in the Instrument Index module. 

 It is possible to search for typical tags only in the Instrument Index module. 
1. When editing, deleting, duplicating or moving tags in the Instrument Index module, in the 

Enter Tag Number dialog box, click Find. 
2. In the Find Tag dialog box, select Typical tag from the Tag class list. 
3. Do not enter any other values in the Search parameter fields. 
4. Click Find. 

 Select the Show more search results check box to hide the search parameter fields 
and enlarge the Search results data window to display more tag rows.  Clear this check box 
to return to normal view. 

5. Select the desired tag numbers in the Search results data window and click OK. 
 
 

Search for All Loop Numbers 
This topic explains how to find all the existing loop numbers in the current <unit>. 
1. In the Find Loop dialog box, do not enter any other values in the Search parameter fields. 
2. Click Find. 

 Select the Display more results check box to enlarge the Search results data window 
and display more rows.  Clear this check box to return to normal view. 

3. Select the required loop numbers in the Search results data window and click OK. 
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Use Search Parameters to Find Loop Numbers 
This help topic explains how to find loop numbers by entering search parameters. 
Entering search parameters in the Find Loop dialog box enables you to narrow down your 
search.  You can narrow your search to the maximum by entering all the search 
parameters.  Leaving some of the Search parameter fields empty widens the search.  It is up to 
you which search parameters to specify.  If you do not specify any search parameters, the 
software finds all the existing tag numbers in the current <unit>.  Note that you can use wildcards 
in the fields where you type values. 
After the search is complete, the loop numbers that match your search parameters are displayed 
in the Results data window. 
Use the fields and lists in the Search parameters group box to enter your search parameters to 
narrow your search.  The following search parameters are available: 

Search 
Parameter 

Explanation  Example 

Loop name Type the whole loop number you are looking 
for.  Include any suffix, and separator 
characters.  You can use wildcards if 
needed.  The Search Results data window will 
display this loop number if it exists. 

101F –2225\A 

101F–% 

Loop number Type the numeric segment of the loop number 
to find all the loop numbers that have this 
numeric segment.  You can also use wildcards 
if needed. 

2225 

Loop suffix Type the suffix segment of the loop number to 
find all the loops that have this suffix.  You can 
also use wildcards if needed. 

A 

Measured variable This search parameter is used to find all the 
existing loop numbers that have the measured 
variable that you select from this list. 

Density (D) 

Pressure (DP) 

Loop type This search parameter is used to find all the 
existing loop numbers that have the loop type 
that you select from this list. 

Electrical Loop (Electrical) 

Open Loop (Open) 

Loop function This search parameter is used to find all the 
existing loop numbers that have the loop 
function that you select from this list. 

Indication and Alarm (IA) 

Control (C) 

Generation type This search parameter is used to find all the 
existing loop numbers that used a specific type 
of loop drawing generation. 

CAD (a loop drawing generated 
by an external CAD engine) 

Manual (a loop drawing 
generated by using the manual 
method 

1. If required, select the Fieldbus check box to narrow your search to the loop numbers that 
contain tags with a fieldbus I/O type. 

2. Click Find. 
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3. Select one or more loop numbers in the Search results data window. 

 
 The Select all option is not available when duplicating an existing loop number. 
 Select the Show more search results check box to hide the search parameter fields and 

enlarge the Search results data window to display more loop rows.  Clear this check box 
to return to normal view. 

4. Click OK. 
 

Search for Typical Loops 
This help topic explains how to find all the existing typical loops in the current unit. 
Using the Typical Loop Management dialog box: 
1. Click Edit > Typical Loop Management. 
2. In the Find typical loop field, type the name of the typical loop you want to find.  As you type 

the software highlights the typical loop names in the data window. 
Using the Batch Loop Creation dialog box: 
1. Click Edit > Batch Loop Creation. 
2. Click Find. 
3. In the Find Typical Loop dialog box, do one of the following: 

 Enter the required search parameters, and click Find. 
 Click Find, and from the Search results data window, select the required typical loop. 

 
 

Supporting Tables 
Supporting tables are dialog boxes that allow you to manage the contents of select lists in 
SmartPlant Instrumentation.  For example, when creating or editing a panel, the values that you 
select from the lists are held in the relevant supporting tables. 

To access a supporting table, click  next to the list arrow in the relevant dialog box, or when in 
the Wiring Module or Instrument Index Module window, click Tables and then the relevant 
menu command. 
Note that in a multi-user installation, SmartPlant Instrumentation allows only one user at a time to 
edit a given supporting table record. 
For a detailed list and description of all the supporting tables in the SmartPlant Instrumentation, 
see Supporting Tables in SmartPlant Instrumentation (on page 35). 
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Supporting Tables in SmartPlant Instrumentation 
The following table lists all the available supporting tables and the description of their 

functions.  You can access these supporting tables by clicking  next to a list arrow or by 
clicking an appropriate command on the Tables menu in the Instrument Index and Wiring 
modules. 

Supporting Table Description 

General Process Function 
Sub-Categories 

Allows you to define a sub- category for the General process 
function in the Instrument Types dialog box. 

Instrument Statuses Allows you to maintain the contents of the Status select list on the 
Tag Number Properties dialog box. 

I/O Types Allows you to maintain the contents of the System I/O type list on 
the Tag Number Properties dialog box. 

Instrument Locations Allows you to specify general or specific instrument locations within 
the <plant>. 

Equipment Allows you to categorize the equipment that your instruments are 
installed on.  Equipment is also categorized according to different 
types, for example, you can specify the equipment type as: pumps, 
compressors, burners, silos, and so forth. 

Equipment Types Allows you to add new equipment types to the Equipment type 
select list in the Equipment dialog box.  You can categorize the 
equipment that your instruments are installed on according to 
different types, such as pumps, compressors, burners, silos, and so 
forth. 

P&ID Drawing References Allows you to store P&ID drawing references used for making 
associations with tag numbers in the Instrument Index and Loop 
Drawings modules. 

Lines Allows you to categorize and modify line data in your <plant>.  This 
dialog box also enables you to access the Line Properties dialog 
box where you can create a new line or edit the properties of an 
existing line. 

Line Types Allows you to create, view, edit, and delete line types. 

Instrument Criticality Allows you to customize instrument criticality data.  Then, you can 
define criticality for a particular tag in the Associate Categories 
and Criticality dialog box that you access from an Instrument Index 
Standard Browser view. 

Instrument Certification This supporting table holds certification information for instruments 
that are certified for hazardous environment. 
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Supporting Table Description 

Instrument Manufacturers Allows you to control the content of the Manufacturer lists in the 
Tag Number Properties and Find Tag dialog boxes as well as the 
Manufacturer column in an Instrument Index Standard Browser 
view.  The URL feature on the Instrument Manufacturer dialog 
box allows you to enter a desired URL that can be double-clicked to 
automatically launch the Internet Explorer and go to the pertinent 
Web site if you are connected to the Internet. 

Instrument Models Allows you to store instrument model data in the current 
domain.  All instrument models are categorized by instrument 
manufacturer. 

Function Blocks Allows you to add new user- defined function blocks to your 
instrument index, delete the redundant ones, or modify the 
definition of existing user- defined function blocks. 

Intrinsically Safe Circuit 
Types 

Allows you to create and manage intrinsically safe circuit types 
which you can associate with tag numbers while editing tag number 
properties.  The intrinsically safe circuit types that are held in this 
supporting table then become available in the Wiring module where 
you can carry out the intrinsic safety calculation. 

Loop Measured Variables Allows you to enter or modify the loop process variable identifier 
which is used in the loop naming conventions.  

Loop Types Allows you to maintain the contents of the Loop type select list on 
the Loop Number Properties, Typical Loop Properties, and Find 
Loop dialog boxes. 

Loop Functions Allows you to enter or modify the loop function identifier which is 
used in loop naming conventions.  The loop function identifier is 
used to identify the succeeding letters that follow the loop measured 
variable identifier in the loop name. 

Associated Electrical 
Equipment 

Allows you to view equipment tags that are associated with signals 
that are defined in SmartPlant Electrical and the equipment type to 
which each signal belongs. 

Associated Electrical 
Equipment Types 

This supporting table holds all the available associated electrical 
equipment types to which SmartPlant Electrical signals can belong.

Circuits This supporting table holds circuit values that appear in the Circuit 
list on the Electrical tab of the Tag Number Properties dialog box.

Rated Voltage This supporting table holds rated voltage values that you can use in 
the Rated voltage list on the Power Supply tab of the Tag 
Number Properties dialog box. 

Frequency This supporting table holds frequency values that you can use in the 
Frequency list on the Power Supply tab of the Tag Number 
Properties dialog box. 

Number of Phases This supporting table holds number of phases values that you can 
use in the Number of phases list on the Power Supply tab of the 
Tag Number Properties dialog box. 
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Supporting Table Description 

Operating Modes This supporting table holds operating mode values that you can use 
in the Operating mode list on the Power Supply tab of the Tag 
Number Properties dialog box and the properties dialog boxes of 
panels that support power supply.  SmartPlant Instrumentation 
provides you with pre-defined operating modes (Continuous, 
Intermittent, Spare, and Standby), which are the only values that 
are recognized by SmartPlant Electrical.  You cannot delete or 
modify these values. 

Signal Types This supporting table holds signal type values that are used to 
define HART instrument properties.  To fill this table, you need to 
download DeltaV definitions. 

Linearity Types This supporting table holds linearity type values that are used to 
define HART instrument properties.  To fill this table, you need to 
download DeltaV definitions. 

Panel Types Allows you to maintain the contents of the Panel type list when 
editing the properties of a panel. 

Panel Manufacturers Allows you to customize the options on the Manufacturer list on the 
Properties dialog boxes listed below.  The URL field on the Panel 
Manufacturer dialog box allows you to enter a desired URL.  You 
can then double-click this URL to automatically start the Internet 
Explorer and go to the pertinent Web site if you are connected to the 
Internet.  This supporting table also allows you to define field 
headers that use manufacturer-specific terminology. 

Panel Models Allows you to manage the contents of the Model list when creating 
or editing a panel.  SmartPlant Instrumentation classifies panel 
models according to manufacturer.  You can find the data used in 
the other columns in the manufacturer's catalog.  Note that 
selecting a different model does not change any other data. 

Panel Area Classifications Allows you to manage the data contained in the Area classification 
list on any of the panel properties dialog boxes. 

Terminal Strip Types Allows you to manage the data contained in the Type list on the 
Terminal Strip Properties dialog box.  You can use this dialog box 
to categorize a terminal strip where the terminal strip represents a 
hardware device or a DCS/PLC I/O termination. 

Terminal Strip 
Manufacturers 

Allows you to manage the contents of the Manufacturer list on the 
Terminal Strip Properties dialog box. 

Terminal Strip Models Allows you to manage the contents of the Model select list on the 
Terminal Strip Properties dialog box.  SmartPlant 
Instrumentation classifies terminal strip models according to 
manufacturer.  You can classify a terminal strip model/MFG for 
control si/s cards and hardware devices. 
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Supporting Table Description 

Terminal Types Allows you to manage the contents of the Type select list on the 
Terminal Properties dialog box.  Also, you can classify the 
terminals whenever their type needs to be defined.  You can 
replace the default graphic image of terminal sides that appear in 
the Connection window and the appropriate reports. 

Terminal Manufacturers Allows you to manage the contents of the Manufacturer select list 
on the Terminal Properties dialog box. 

Terminal Models Allows you to manage the contents of the Model select list on the 
Terminal Properties dialog box.  Terminal models are classified 
according to manufacturer. 

Terminal Colors Allows you to manage the contents of the Color select list on the 
Terminal Properties dialog box.  You can also select and 
customize the graphical representation of the color names defined 
in this supporting table.  This sets the precise colors for the bar 
connecting terminals in the Connection and Cross-Wiring 
windows. 

Wiring Equipment Types Allows you to manage the contents of the Wiring equipment types 
select list.  Wiring equipment type is one of the properties used to 
define wiring equipment items, such as I/O cards, I/O terminations, 
fieldbus bricks, safety barriers, relays, amplifiers, and so forth. 

Wiring Equipment 
Manufacturers 

Allows you to manage the contents of the Manufacturers select 
list.  Wiring equipment manufacturer is one of the properties used 
to define wiring equipment items, such as I/O cards, I/O 
terminations, fieldbus bricks, safety barriers, relays, amplifiers, and 
so forth. 

Wiring Equipment Models Allows you to manage the contents of the Models select 
list.  Wiring equipment model is one of the properties used to define 
wiring equipment items, such as I/O cards, I/O terminations, 
fieldbus bricks, safety barriers, relays, amplifiers, and so forth. 

Wiring Equipment Category This supporting table holds wiring equipment category values.  The 
categories that exist in this supporting table are available for 
selection in the Categories select list of the New Wiring 
Equipment dialog box.  You can add your own categories and then 
set their properties as you require.  However, you cannot modify or 
delete the categories that are supplied to you with the software. 

Cable Types Enables you to manage cable type data that appears on the Cable 
Properties dialog box, Type select list.  The Cable Types dialog 
box holds all the data that pertains to the cable types in the current 
<plant>.  Users can view the data or delete it as needed.  This 
dialog box provides access to the Cable Type Properties dialog 
box, where you can create a new cable type or edit the properties of 
an existing cable type. 

Cable Manufacturers Enables you to manage the data in the Cable Manufacturers 
supporting table, which contains all the items of the Manufacturer 
select list on the Cable Properties dialog box. 
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Supporting Table Description 

Cable Models Allows you to manage the data in the Cable Models supporting 
table, which contains all the items of the Model select list on the 
Cable Properties dialog box.  SmartPlant Instrumentation 
classifies cable models according to manufacturer. 

Cable Colors Allows you to manage the contents of the Color select list on the 
Cable Properties dialog box. 

Cable Glands Enables you to manage the data in the Cable Glands supporting 
table, which contains all the items of the End 1 and End 2 select 
lists in the Glands group box of the Cable Properties dialog 
box.  This way, you can assign cable glands to selected cable 
types.  Once assigned to a cable type, the gland attributes 
automatically propagate to all the cables of that type. 

Cable Harnesses Allows you to define and maintain the contents of the Cable 
harness select list on the Cable Properties dialog box. 

Conductor Cross- Sections Enables you to manage the conductor cross-section data for the 
cables in the current <plant>.  The values that appear in this dialog 
box are available in the Cross-section select list on the Cable 
Properties dialog box. 

Wire Types Allows you to manage the contents of the Type list on the Wire 
Properties dialog box. 

Wire Colors Allows you to manage the contents of the Color list on the Wire 
Properties dialog box. 

Connector Types A connector type defines pin configuration and other 
properties.  When you define connectors for a cable, selecting a 
connector type copies these properties for the cable 
connector.  This supporting table allows you to create and manage 
the connector types required for your plug-and- socket boxes and 
for cables that require connectors. 

Connector Manufacturers Allows you to manage the contents of the Manufacturer select list 
on the Connector Types dialog box. 

Connector Models Allows you to manage the contents of the Model select list on the 
Connector Types dialog box.  Connector models are classified 
according to the Manufacturer column.  The information used in 
the other columns can be found in the manufacturer's catalog. 

Controllers The controller is the processing hardware that controls and 
supervises I/O cards.  This supporting table allows you to define 
and manage your I/O card controllers.  You can define new 
controllers, edit the properties of existing controllers, and delete 
controllers. 

Channel Types Allows you to manage the contents of the Channel Type select list 
on the Channels dialog box. 

Segment-Wide Parameter 
Profiles 

Allows you to define default settings that serve as design rules for 
the various Fieldbus segments. 
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Supporting Table Description 

Standard Widths Each routing trunk that you define consists of positions.  Instead of 
defining new positions for each additional trunk, you select the 
positions from the list of standard positions.  Instead of defining the 
width for each standard position that you can add to a trunk, you 
select it from the standard width list that you set in this supporting 
table.  You use the widths that you add in this supporting table to 
define the positions in a routing trunk.  The width that you define 
here is a standard unit and therefore can be used several times to 
characterize different positions. 

Standard Routing Positions Each routing section of type trunk that you define consists of 
positions.  (Building sections do not have positions.)  Instead of 
defining new positions for each additional trunk, you select the 
positions from the list of standard positions that you define in this 
supporting table. 

Maximum Number of 
Cables 

The maximum number of cables limits the number of cables that a 
position can contain.  After you have defined widths and created 
positions, you need to set the maximum number of cables per 
defined-width position that you want to associate with a routing 
trunk. 

Routing Sections Defining routing sections is the last step in creating the <plant> 
cable routing before associating routing with cables.  The cable 
routing sections contain the positions that convey the cables 
between the instruments.  Using this supporting table, you can add 
or edit a routing section and select positions to be included in a 
trunk section.  The positions that you can select are those for which 
you have already defined the maximum number of cables. 

Cable Drums Allows you to define and manage the cable drums in your 
<plant>.  Note that cable drums are categorized according to cable 
type. 

Pulling Areas Allows you to define the pulling areas in your <plant>.  The pulling 
area in the <plant> is the area allocated to cables and the cable 
drums they are wound on.  The purpose of allocating pulling areas 
is both to organize the <plant> drums in designated areas and to 
regularly use the cables from these areas. 

DCS Block Types Allows you to manage the block type data for control system 
tags.  The values that appear on this dialog box are available in the 
Block Type select list on the Control System Tag Properties 
dialog box. 

DCS Function Block I/O 
Termination 

Enables you to manage the DCS function block I/O termination data 
for control system tags.  The values that appear on this dialog box 
are available in the Function block I/O termination select list on 
the Control System Tag Properties dialog box. 

 
 For the explanation of instrument types and their functionalities, see Working with Instrument 

Types. 
 For the supporting tables used in Telecom, see Supporting Tables for Telecom (on page 41). 
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Supporting Tables for Telecom 
The following table lists all the available Telecom supporting tables and the description of their 

functions.  You can access these supporting tables by clicking  next to a list arrow or by 
clicking Tables > Telecom and then an appropriate command in the Instrument Index and Wiring 
modules. 

Supporting Table Description 

Telecom Device Types Allows you to create and manage telecom device types.  You define the 
required telecom device type profile for your telecom tag numbers so that 
new tags that you create can acquire the necessary 
properties.  SmartPlant Instrumentation provides a number of 
predefined telecom device types, such as AL (alarm), CAM (camera), 
and so forth.  You can add new telecom device types and modify the 
shipped ones as desired.  You can also delete a telecom device type 
that is not in use, but the software does not let you delete a telecom 
device type that you already used to create a tag number. 

Telecom Line Numbers Allows you to maintain the contents of the Telecom line list when 
creating a telecom field device in the Plug-and-Socket Box wizard and 
the Line number list on the Tag Number Properties dialog box. 

Telecom Field 
Equipment 

Allows you to maintain the contents of the Field equipment select list on 
the Tag Number Properties dialog box. 

Telecom Signal Levels Allows you to maintain the contents of the Signal level select list on the 
Tag Number Properties dialog box. 

Panel Sub-Systems Allows you to maintain the contents of the Sub-system select list on the 
Equipment Panel Properties dialog box. 

Telephone Numbers Allows you to define new telephone numbers that you can associate with 
existing switch channels in PABX cabinets. 

Telephone Number 
Statuses 

Allows you to manage the contents of the Telephone number status 
select list on the Telephone Number Properties dialog box. 

Telephone Number 
Usages 

Allows you to manage the contents of the Telephone number usages 
select list on the Telephone Number Properties dialog box. 

Intercom Numbers Allows you to define new intercom numbers that you can later associate 
with amplifiers. 

PA Zones Allows you to manage the PA zone definitions which are available for 
selection on the Category Properties tab of the Wiring Equipment 
Properties (Amplifier) dialog box. 

Alarm Zones Allows you to manage the alarm zone definitions which are available for 
selection on the Category Properties tab of the Wiring Equipment 
Properties (Amplifier) dialog box. 

PABX Categories Allows you to manage the contents of the PABX categories select list on 
the PABX Cabinet Properties dialog box. 

 For the various actions that you can perform with supporting tables, see Supporting Tables 
(on page 34). 
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Add a New Value to a Select List 
This option shows you how to add a new value to a select list.  All values are stored in the 
supporting tables that you can access from various windows and dialog boxes.  You can access a 
supporting table from a menu by selecting the appropriate item from the Tables menu or by 

clicking  in a dialog box.  

1. Open the appropriate supporting table by clicking  in the appropriate dialog box or by 
selecting the appropriate menu item on the Tables menu. 

2. In the appropriate supporting table dialog box, click New. 
3. Type the required value in the fields provided, and press Tab to move to the next field. 
4. Click New to enter another new value, if desired. 
5. Click OK to accept the new values and close the dialog box. 
 
 

Manage a Custom Table 
This option shows you how to use custom tables, as defined by the Domain Administrator, to 
contain supporting data for instruments.  After you enter your data in a Custom Table dialog box, 
you can use this data as additional tag attributes when setting a profile in the Instrument Type 
Profile dialog box, and when editing tag number properties in the Tag Number Properties dialog 
box. 
1. In the Instrument Index Module menu, click Tables > Custom Tables,  and then select the 

custom table you want to open. 
2. To add a new record, click New, and then type a unique name and an optional description. 
3. To edit an existing record, click a value that you want to edit, and modify as needed. 
4. To delete a record, select the row that you want to delete, and click Delete. 
5. Click OK. 

 The Domain Administrator has rights to create the required custom tables for each 
<plant>.  If the Domain Administrator does not create any custom tables, the Custom Tables 
menu option is not available. 
 
 

Customize Manufacturer-Specific Field Headers 
This feature allows you to customize field headers, to fit panel manufacturer terminology, on panel 
dialog boxes, such as DCS, PLC, I/O Cards and so forth. The customized field headers and labels 
replace the default headers and labels according to the selected manufacturer when editing panel 
properties.  The default headers are the same as the Data Dictionary display names.  After 
customizing panel manufacturer-specific headers, the custom headers appear not only on the 
relevant panel properties dialog box but also on all child items dialog boxes and appropriate 
reports. 
1. Do one of the following to open the Panel Manufacturers dialog box: 

 In the Wiring module, click Tables > Panel > Manufacturers. 

 Click  next to the Manufacturer select list on the appropriate panel dialog box. 
2. On the Panel Manufacturers dialog box, click Headers. 
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3. From the Wiring item list, select the item type for which you want to customize the field 
headers. 

4. Under Custom item name, type a custom item name for the selected item type. 
5. Under Custom Field Header, type the text you require next to the appropriate value that 

appears under Field Header in Data Dictionary. 
6. Repeat steps 3 to 5 as many times as you require. 
7. Click OK. 
 

Revision Management 
When managing revisions, you can add revisions to documents in SmartPlant Instrumentation, 
update them as needed, archive and compare new and existing document revisions, and delete 
obsolete revisions.  A document is a report or drawing that has a document number.  Also, you 
can add a document number when adding a revision to an item . 
The software allows you to add a revision to a specific report, drawing, or item , for example, to a 
specific I/O card in the Wiring module.  You add revisions to reports in the report print preview and 
to items in the dialog boxes where you can edit the item properties.  Also, you can create global 
revisions. 
In the Administration module, in the Report Management dialog box, the Domain Administrator 
has rights to define revision management settings individually for each report that you can 
generate in SmartPlant Instrumentation. 
In the database, each report is assigned to the report type, which can be a list or a non-list type 
report.  The report type determines how you can manage revisions created for a specific report, 
for an item , or a group of items.  For list-type reports, the Domain Administrator can enable 
SmartPlant Instrumentation users to manage revisions either per document or per item . 
In accordance with the revision management setting, you can either create a revision whose 
document number and revision number become shared for a specific item and for reports 
generated for that item (when the setting is per-item ), or create a unique revision for a particular 
report (when the setting is per-document). 
Regardless of the revision management setting, any document numbers and revisions that you 
create in the software are shared with the document numbers and revisions created for the same 
items in the Enhanced Report Utility.  For example, a drawing created in the Enhanced Report 
Utility automatically inherits the same document number and revision that you assigned to an 
Enhanced SmartLoop report generated in SmartPlant Instrumentation. 
When working in an integrated environment, you can specify whether to use SmartPlant 
Instrumentation revisions or external revisions created when working in an integrated 
environment.  For more information about using revisions in an integrated environment, see 
Revising Documents in an Integrated Environment (on page 487). 
To place issue data on title blocks for enhanced reports, use the Place Drawing Property Label 
command in the Enhanced Report Utility.  For more information, see Place Property Labels on a 
Drawing Sheet in the Enhanced Report Utility User's Guide, under Working with Templates and 
Title Blocks. 

 When generating more than one revision report, toggle between them by selecting the 
report to be viewed from the Window menu in SmartPlant Instrumentation. 
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Global Revisions 
Global revisions enable you to perform a revision activity in batch mode. 
At the first stage of applying global revisions, you select a revision activity, and define the default 
revision settings, such as revision values, numbering method, and revision details.  At the second 
stage, you select the required items in a specific module, and apply the defined revision settings. 
Revision activities include: 
 Add revision — select the required numbering method and add a new revision. 
 Update revision — change the existing revision value without changing the numbering 

method.  For example, you can update a revision from A1 to A2. 
 Upgrade revision — involves changing the revision numbering method.  For example, you 

can upgrade a revision from P0 to A. 
 Delete revisions — delete all revisions for the selected items. 
 Delete last revision — delete only the last revision. 

You can add global revisions to non-list-type reports for which the Domain Administrator selected 
the Per Document revision management setting in the Report Management dialog box. 
An exception is Enhanced Report Utility reports, which are always assigned to the Per Item 
revision management setting.  The document number and global revision that you create in 
SmartPlant Instrumentation are shared with the document number and revision created in the 
Enhanced Report Utility. 

 Items that have archive options defined as Save to database; any revisions are only saved 
to the archive after closing the Global Revisions dialog box.  Adding a revision and then deleting 
the revision, before closing the dialog box, results in the revision not being archived. 
  
 

Filter Items for Global Revisions 
You can filter the items in the data window of the Global Revisions dialog box when adding, 
updating, upgrading, or deleting revisions in batch mode.  On the Wiring tab of the Global 
Revisions dialog box, you can also filter the Wiring module items per report. 
1. In the Global Revisions dialog box, click one of the following tabs: Specifications, Process 

Data, Calculations, Loops, Hook-Ups, Wiring, or Dimensional Data. 

 
 If you accessed the Global Revisions dialog box from the main SmartPlant 

Instrumentation window, tabs for multiple modules are available; if you accessed the 
dialog box from a particular module, then only the Settings tab and the tab for that 
module are available. 

 If you are working in an integrated environment, then regardless of where you access this 
dialog box from, the following tabs are disabled: Specifications, Process Data, Loops, 
and Dimensional Data. 

2. If you selected the Wiring tab, do the following: 
 Under Filter parameters, from the Report for list, select the item for which you want to 

apply revisions: Panels, Cables, or DCS/PLC. 
 From the Report type list, select a report type appropriate for the item you selected in the 

previous step. 
 To set new filter parameters, first click Clear. 

3. For all tabs, under Filter parameters, type values in one or more of the text boxes to specify 
the parameters that you want to use for filtering the data. 
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4. Select the Display current <unit> data only check box to display the data in the current 
<unit>.  Clear this check box to display all data at the level of the current <plant>. 

 On the Hook-Ups tab, data is filtered at the <plant> level only. 
5. Select Activate filter to apply the filter parameters on the items. 

 If you select the Activate filter check box first, the software filters the data as you select 
or type the filter parameters. 

6. Select Enable wildcard search to use a wildcard, if required, in your search. 

 
 The Enable wildcard search is enabled only when Activate filter has been selected. 
 The % character is used as the wildcard symbol in your filter. 

7. Click Refresh to update the data window as needed. 
8. Click Apply. 
 
 

Add Global Revisions 
This option enables you to add a global revision to items that belong to any of the following 
modules: Specifications, Process Data, Calculation, Loop Drawings, Hook-Ups, Wiring, and 
Dimensional Data. 
1. In the main window of any SmartPlant Instrumentation module, click Tools > Global 

Revisions. 
2. On the Settings tab of the Global Revisions dialog box, from the Activity list, select Add 

revision. 
3. In the Revision field, enter the desired revision value. 
4. Do the following to enter the revision details: 

 In the Revised by field, enter the initials of the person performing the revision.  The 
default is the current user's initials, if previously defined by the System Administrator. 

 In the Date field, enter the date of revision, if required. 
 Fill out the other fields as needed. 

5. Click one of the following tabs: Specifications, Process Data, Calculations, Loops, 
Hook-Ups, Wiring, or Dimensional Data. 

 
 If you accessed the Global Revisions dialog box from the main SmartPlant 

Instrumentation window, tabs for multiple modules are available; if you accessed the 
dialog box from a particular module, then only the Settings tab and the tab for that 
module are available. 

 If you are working in an integrated environment, then regardless of where you access this 
dialog box from, the following tabs are disabled: Specifications, Process Data, Loops, 
and Dimensional Data. 

6. In the data window, filter the items as needed.  For details, see Filter Items for Global 
Revisions (on page 44). 

7. In the data window, select the items for which you want to add a global revision defined on the 
Settings tab by doing one of the following: 
 Select the desired tag numbers (hold down Ctrl or Shift to make multiple selections). 
 Select the Select all check box to select all the tag numbers in the data window. 

8. Click Apply to add a revision to each of the selected items. 
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If you want to add revisions for other modules, repeat the appropriate steps for each module. 
 Items that have archive options defined as Save to database; any revisions are only saved 

to the archive after closing the Global Revisions dialog box.  Adding a revision and then deleting 
the revision, before closing the dialog box, results in the revision not being archived. 
 
 

Define Settings for Upgrading Revisions 
This option enables you to define default settings for upgrading revisions globally.  These settings 
include revision numbering method, and revision details. 
1. With any main window open, click Tools > Global Revisions. 
2. On the Settings tab, from the Activity list, select Upgrade revision. 
3. To change the numbering method for items that do not currently have revisions, from the 

Initial revision numbering method list, select one of the following numbering methods you 
want to start with: 
 P0 — for preliminary number sequence P0, P1, P2,... 
 0 — for number sequence 0, 1, 2,... 
 A — for number sequence A, B, C,... 

 The initial revision numbering method only affects items that do not have revisions.  For 
items that already have revisions, the software adds a new revision line using the existing 
revision numbering method. 

4. To change the numbering method for items that currently use the preliminary revision 
numbering method (P0, P1, P2,...), select Switch to another numbering method, and from 
the Continue using numbering list, select one of the following new revision numbering 
methods: 
 0 — for number sequence 0, 1, 2,... 
 A — for number sequence A, B, C,... 

5. Do the following to enter the revision details: 
 In the Revised by field, enter the initials of the person performing the revision.  The 

default is the current user's initials, if previously defined by the System Administrator. 
 In the Date field, enter the date of revision, if required. 
 Fill out the other fields as needed. 

6. Click the appropriate module tab to apply the defined settings.  For details, see Upgrade 
Revisions Globally (on page 47). 

 
 If you accessed the Global Revisions dialog box from the main SmartPlant Instrumentation 

window, tabs for multiple modules are available; if you accessed the dialog box from a 
particular module, then only the Settings tab and the tab for that module are available. 

 If you are working in an integrated environment, then regardless of where you access this 
dialog box from, the following tabs are disabled: Specifications, Process Data, Loops, and 
Dimensional Data. 

See Also 
Revision Upgrade Example (on page 48) 
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Update Revisions Globally 
You can update the existing revision values globally for the items used in the following modules: 
Specifications, Process Data, Calculation, Loop Drawings, Hook-Ups, Wiring, and Dimensional 
Data. 
1. With any main window open, click Tools > Global Revisions. 
2. On the Settings tab, from the Activity list, select Update revision. 
3. In the Revision field, enter the desired revision value. 
4. Do the following to enter the revision details: 

 In the Revised by field, enter the initials of the person performing the revision.  The 
default is the current user's initials, if previously defined by the System Administrator. 

 In the Date field, enter the date of revision, if required. 
 Fill out the other fields as needed. 

5. Click one of the following tabs: Specifications, Process Data, Calculations, Loops, 
Hook-Ups, Wiring, or Dimensional Data. 

 
 If you accessed the Global Revisions dialog box from the main SmartPlant 

Instrumentation window, tabs for multiple modules are available; if you accessed the 
dialog box from a particular module, then only the Settings tab and the tab for that 
module are available. 

 If you are working in an integrated environment, then regardless of where you access this 
dialog box from, the following tabs are disabled: Specifications, Process Data, Loops, 
and Dimensional Data. 

6. In the data window, filter the items as needed.  For details, see Filter Items for Global 
Revisions (on page 44). 

7. In the data window, do one of the following to select the items whose revisions you want to 
update: 
 Select the desired tag numbers (hold down Ctrl or Shift to make multiple selections). 
 Select the Select all check box to select all the tag numbers in the data window. 

8. Click Apply to apply the new revision value to all the selected items in batch mode. 
9. If you want to update revisions for other modules, repeat the appropriate steps for each 

module. 
 
 

Upgrade Revisions Globally 
After defining the default settings for upgrading revisions, you use this option to apply these 
settings to the selected items in batch mode. 
1. Define the settings for upgrading revisions globally.  For details, see Define Settings for 

Upgrading Revisions (on page 46). 
2. Select the desired module tab and filter the items as needed.  For details, see Filter Items for 

Global Revisions (on page 44). 
3. To change the numbering method for items that do not currently have revisions, from the 

Initial revision numbering method list, select one of the following numbering methods you 
want to start with: 
 P0 — for preliminary number sequence P0, P1, P2,... 
 0 — for number sequence 0, 1, 2,... 
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 A — for number sequence A, B, C,... 
4. In the data window, do one of the following to select the items for which you want to upgrade 

revisions: 
 Select the desired tag numbers (hold down Ctrl or Shift to make multiple selections). 
 Select the Select all check box to select all the tag numbers in the data window. 

5. Click Apply to apply the new revision value to all the selected items in batch mode. 
6. If you want to upgrade revisions for other modules, repeat the appropriate steps for each 

module. 
 
 

Revision Upgrade Example 
This example is based on the following parameters: 
 Initial numbering method: P0 
 Switch to numbering method for preliminary revisions: A 

With the above parameters, the following results are obtained for subsequent revisions (on 
clicking Apply in the module sub folders of the Global Revisions dialog box): 

Previous 1 2 2 Comments 

None P0 A B First revision uses initial numbering method (P0); 
subsequent revisions use switch to numbering 
method (A, B, and so forth.) 

P2 A B C First and subsequent revisions use switch to 
numbering method (A, B, and so forth.) 

A B C D Incremented by one step each time from the previous 
revision 

B C D E Incremented by one step each time from the previous 
revision 

1 2 3 4 Incremented by one step each time from the previous 
revision 

2 3 4 5 Incremented by one step each time from the previous 
revision 

 
 

Delete Global Revisions 
You can perform batch deletion of revisions if you have the appropriate access rights.  You have 
the option to delete all revisions for the selected items in the specified module, or delete only the 
last revisions. 
1. In the main window of any SmartPlant Instrumentation module, click Tools > Global 

Revisions. 
2. On the Settings tab of the Global Revisions dialog box, from the Activity list, select one of 

the following: 
 Delete revisions — select to delete all revisions for the selected items. 
 Delete last revision — select to delete the last saved revision for each selected item. 
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3. Click one of the following tabs: Specifications, Process Data, Calculations, Loops, 
Hook-Ups, Wiring, or Dimensional Data. 

 
 If you accessed the Global Revisions dialog box from the main SmartPlant 

Instrumentation window, tabs for multiple modules are available; if you accessed the 
dialog box from a particular module, then only the Settings tab and the tab for that 
module are available. 

 If you are working in an integrated environment, then regardless of where you access this 
dialog box from, the following tabs are disabled: Specifications, Process Data, Loops, 
and Dimensional Data. 

4. In the data window, filter the items as needed.  For details, see Filter Items for Global 
Revisions (on page 44). 

5. In the data window, do one of the following to select the required items: 
 Select the desired tag numbers (hold down Ctrl or Shift to make multiple selections). 
 Select the Select all check box to select all the tag numbers in the data window. 

6. Click Apply to delete the revisions for the selected items. 
7. If you want to delete revisions for other modules, repeat the appropriate steps for each 

module. 
 
 

Add Local Revisions 
You can add revisions locally to a specific SmartPlant Instrumentation document or item , 
depending on revision management settings defined by the Domain Administrator.  For all 
list-type reports, the revision management setting is always Per Document.  For certain 
non-list-type reports, the Domain Administrator has rights to define the setting as either Per 
document or Per Item . 
1. In the Revisions dialog box, select one of the revision numbering methods from the Revision 

method list (use P0, P1, P2... for preliminary revisions or 0, 1, 2 / A, B, C, and so forth for 
normal serial revisions). 

 If you select a revision numbering method other than preliminary revisions (P0, P1, 
P2...), you will not be able to return to the preliminary revision method and this option will be 
disabled. 

2. If needed, in the Drawing number field, type the number of the document associated with the 
item for which you create the revision.  In drawings and reports, this number appears in the 
title block. 

3. Click New to add a new revision. 

 
 If you are working in an integrated environment in a module that supports publishing and 

retrieving of documents, clicking New opens the Revise dialog box for the integrated 
environment instead of the SmartPlant Instrumentation Revisions dialog box. 

 The software automatically increments the revision number according to the selected 
revision method.  You can overwrite SmartPlant Instrumentation revisions if desired. 

4. Add or edit the revision data as needed. 
 If the document for which you are making a revision contains a custom-title block, the 

User-defined fields data window becomes available for you.  In this data window, you can view 
the user- defined fields that you added to the custom title block that you created.  To learn more 
about custom title blocks, see Customizing Title Blocks for Reports (on page 635). 
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Edit Local Revisions 
Use this procedure to edit existing local revisions. 
1. In the Revisions dialog box, select the revision that you want to edit. 
2. Make the desired changes according to the revision table: 

Field Description  

No The revision number.  This is incremented 
automatically according to the revision 
method selected, you can overwrite it if 
required. 

By Type the initials of the person performing the 
revision.  The default is the current logged-in 
user initials, if previously defined by the 
System Administrator. 

Date The default is today's date, you can modify it if 
required. 

Description Description of the changes made or the 
purpose of the revision. 

Checked By Type the name of the person checking the 
revision, if required. 

Approved By Type the name of the person approving the 
revision, if required. 

3. Make changes for other revisions as desired. 
4. Click OK to apply your changes. 
 
 

Delete Local Revisions 
Use this procedure to delete existing local revisions. 
1. On the Revisions dialog box, select the revision that you want to delete. 
2. Click Delete. 
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View an Archived Revision 
1. In the Administration module, select the desired archiving option.  For details, see Set 

Archiving Options for Report Comparison in the Administration User's Guide, under Domain 
and Project Administration, Report Management. 

2. In SmartPlant Instrumentation application, save a revision for the desired document. 

 
 For enhanced reports, you must perform revisions from the Enhanced Report Utility if you 

want them to be archived for performing report comparison or viewing a changes report. 
 The software archives revisions for browser view reports separately for each view 

regardless of any existing filter or sort sequence. 

3. On the Print Preview toolbar, click  to open the Document Revision Archive dialog box 
where you view the revision. 

4. Double-click the desired revision or revisions to open the print preview. 
 
 

Report Comparison 
Report comparison is available if you have saved revisions for a particular report.  For every 
saved report revision, there is an archived report, stored according to the archiving option.  The 
Domain Administrator defines an archiving option for each report. 
When comparing reports, you can generate a comparison report to view the report fields in which 
the values are different. 

 
 Report comparison is only available if the System Administrator has selected Audit trail 

options in the Domain Definition window for the current domain, and if the Domain 
Administrator has selected one of the options for saving revisions of the specified report in the 
Report Management dialog box in the Administration module. 

 Report comparison of an entity in a claimed project with the same entity in As-Built is only 
available if the Domain Administrator has selected one of the options for Archiving option 
under Activities, Report Management in the Administration module for both As-Built and the 
project for the desired report. 

 For enhanced reports, you must perform revisions from the Enhanced Report Utility if you 
want them to be archived for performing report comparison. 

 You cannot perform report comparison for PowerSoft browsers. 
Using report comparison, you can do the following: 
 Compare the currently previewed report with an archived report.  For details, see Comparing 

the Current Report with an Archived Report (see "Compare the Current Report with an 
Archived Report" on page 53). 

 Compare two archived reports.  For details, see Comparing Archived Reports (see "Compare 
Archived Reports" on page 52). 
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Set Font and Color for Report Comparison 
This option enables you to set a comparison color and font style prior to comparing reports.  The 
preset color and font style appear in a previewed report after comparing this report with an existing 
archived report.  You can also set the grayscale and font style to appear in a printed report after 
report comparison.  In a previewed report, the comparison color and font style indicate the 
differences between the previewed report and an archived report selected for comparison. 
1. On the Tools menu of any SmartPlant Instrumentation module, click Data Comparison 

Display Options. 

2. Beside the Highlight color for display field, click . 
3. In the Color dialog box, choose the color that you require. 
4. Click OK to return to the Data Comparison Display Options dialog box. 

 The highlight color you have set appears after report comparison in any report print 
preview to indicate the differences between the current and the archived report. 

5. Beside the Grayscale field, click . 
6. In the Grayscale dialog box, move the slider to the required position. 
7. Click OK to close the Grayscale dialog box. 

 The grayscale you have set appears after report comparison in a printed report to 
indicate the differences between the current and the archived report. 

8. Under Font style, do the following if required: 
9. Select Bold to mark the differences between the current and the archived report in bold. 
10. Select Italic to mark the differences between the current and the archived report in italic. 
 
 

Compare Archived Reports 
This option enables you to compare between two archived reports. 
1. Open the report that you want to compare reports. 
2. In the Print Preview window, do one of the following: 

 On the Print Preview window toolbar, click  
 On the View menu, click Compare Reports. 

3. In the Report Comparison Options dialog box, click Compare two archived reports. 
4. Click OK. 
5. In the Select Archived Revisions for Report Comparison dialog box, do the following: 

a. From the Compare data window, select the revision corresponding to the source archived 
report. 

b. From the With data window, select the revision corresponding to the target archived 
report that you want to compare with the source report. 

 If there is a long list of revisions in either of the data windows, type the desired revision 
number in the Revision filter box and select Activate. 

 If the archived and the currently previewed reports are different, in the previewed report the 
software marks the differences in color.  If required, you can set your own comparison highlight 
color and font style to indicate the differences for report display.  You can also set a grayscale and 
font style to indicate the differences in a printed report. 
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Compare the Current Report with an Archived Report 
The option enables you to compare the currently previewed report with an archived report. 
1. In the Print Preview window, do one of the following: 

 On the Print Preview window toolbar, click . 
 On the View menu, click Compare. 

2. In the Report Comparison Options dialog box, click Compare the current report with an 
archived report. 

3. Click OK. 
4. In the Report Revision Archive dialog box, select the revision corresponding to the archived 

report that you require. 
 If there is a long list of revisions in the data window, type the required revision number in 

the Revision filter box and select Activate. 
5. Click OK to reopen the Print Preview window. 

 If the archived and the currently previewed reports are different, in the previewed report the 
software marks the differences in color.  If required, you can set your own comparison highlight 
color and font style to indicate the differences for report display.  You can also set a grayscale and 
font style to indicate the differences in a printed report. 
 
 

View Archived Reports 
This option enables you to open a report preview of any archived report.  The software 
automatically archives reports when saving report revisions for the currently previewed 
report.  The Domain Administrator defines an archiving option for each report. 
1. In the Print Preview window, do one of the following: 

 On the Print Preview window toolbar, click  
 On the View menu, click Report Revision Archive. 

2. In the Report Revision Archive dialog box, select the revision which corresponds to the 
archived report you want to view. 

 If there is a long list of revisions in the data window, type the required revision number in 
the Revision filter list, and select Apply. 

3. Click OK to open the archived report in the Print Preview window. 
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Display a List of Changed Documents 
This option enables you to display a list of documents for which data modifications have been 
made.  To use this option, the Domain Administrator must first select the Save Document Data 
option in the Report Management dialog box for each report that you want to include in the 
list.  The software does not include in changes reports any modifications that you make to title 
block macros or external symbols such as DCS data or non- wiring tag lists in enhanced reports. 
The software does not display data changes in the following cases: 
 If you add a new item such as a panel or gland in list reports, because the software cannot 

determine whether the item is part of the document. 
 If you remove or assign tags or items in the Hook-ups module 
 For the Instrument Index Drawing Summary Browser.  Changes that you make in the 

Instrument Index Standard Browser are included in the Browse – Instrument Index Report 
item, and not in the Instrument Index under the list of browser 

1. On the Tools menu, click Changed Documents. 
2. In the Changed Documents dialog box, do one of the following: 

 Under Document types, highlight the desired document types.  For multiple selection, 
hold down Ctrl or Shift while making your selection. 

 Select the Select All check box. 
3. Under Filter by, select an option to specify the method of filtering.  The available options are: 

 Documents changed since last revision — select to filter documents for which data 
was changed since the last revision of the document.  If there is no revision, the software 
does not display that document. 

 Documents changed between specified dates — select to filter documents for which 
data was changed during the date range specified by the From date and To date fields. 

4. Click Find to retrieve the list of changed documents according to the document types and filter 
options that you specified. 

5. Click Changes Report if you want to display a report of the changed documents. 
 

Workflow 
The Workflow option enables instrument engineers to control the data entry process for 
instrument tags by specifying if and when process data should be entered for a particular 
tag.  Workflow defines an additional level of access rights for individual instrument tags, 
determined by the Workflow status of the tags.  In this way, an instrument engineer, while working 
on instrument data for a particular tag, can lock out process engineers from making changes to 
process data until all the instrument data has been entered. 

Example Scenario 
The following stages describe a typical Workflow scenario: 
1. An instrument engineer creates a new instrument tag and determines whether or not the tag 

requires process data.  In the event that the instrument tag does require process data, the 
process data fields of the tag become available to the process engineers for editing. 

2. The process engineer, after first accessing the instrument tag for editing of process data, can 
lock the process data fields against any changes wherever the instrument engineers have 
access rights. 
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3. On being released by the process engineer, the instrument engineer can now enter 
instrument data as required.  The instrument engineer can lock the tag against any changes 
wherever the process engineers have access rights. 

 
 

Workflow Prerequisites 
Before you can implement Workflow in a given <unit>, the System Administrator and Domain 
Administrator need to perform the following tasks: 
 The System Administrator enables Workflow in your domain.  For more information, see the 

Administration module Online Help, System Administration > Domain Management > Enable 
Workflow. 

 The Domain Administrator defines two groups that will be responsible for working in the areas 
of process engineering and instrument engineering.  For more information, see Creating a 
New Group Profile in Online Help for the Administration module. 

 The Domain Administrator does one of the following: 
 Associates Windows groups with the SmartPlant Instrumentation process engineering 

and instrument engineering groups.  For more information, see the Administration 
module Online Help, Users, Departments, and Groups > Create a Group for Windows 
Authentication Logon Method. 

 Assigns users individually to the process engineering and instrument engineering 
groups.  For more information, see the Administration module Online Help, Users, 
Departments, and Groups > Assign Users to Groups. 

 The Domain Administrator defines Workflow access rights for the process engineering and 
instrument engineering groups.  For more information, see the Administration module Online 
Help, Domain And Project Administration > Access Rights > Workflow Access Rights. 

 After initialization of a domain from a source or after a version upgrade, it is essential to 
regenerate the library forms to enable the Workflow options to be used in the Specifications 
Browser.  For details, see Regenerate Library Forms (on page 229). 
 
 

Create a Workflow Browser 
 

 Workflow needs to be set up by an instrument engineer. 
 Make sure that the System Administrator and the Domain Administrator have prepared 

SmartPlant Instrumentation for Workflow. 
1. Open the Browser Manager. 
2. Under Browser groups, double- click Workflow to expand the hierarchy. 
3. Select the Instrumentation/Process Data Browser and create a new view. 
4. Double-click the view to expand the hierarchy. 

5. Click , and in the Style settings section, click Edit. 
6. Select the check boxes in the View column to specify the fields to be displayed in the view. 

 You must include the Process Data Status field among the fields selected for 
displaying in the view. 

7. Click Save. 
8. Select the View level in the tree, and then click Actions > Open View. 
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 The Browser View opens showing the process data statuses for all the instrument tags in 
the database.  For details, see Process Data Statuses (on page 57). 
 
 

Implementing Workflow 
Workflow implementation begins when the instrument engineer who is going to work on particular 
instrument tags determines whether those tags require process data.  Next, those tags that do 
require process data are assigned to a process engineer for process data input.  On completion of 
the data input, the tags are reassigned to the instrument engineer for instrument data input. 

Enter Initial Instrument Data 
1. Log on to SmartPlant Instrumentation as a user in the Instrument group. 
2. In the Instrument Index module, create the instrument tags as you require and enter 

appropriate data. 
3. In the Browser Manager, under Browser groups, double-click Workflow to expand the 

hierarchy. 

4. Refresh the screen by clicking . 
 Any new instrument tags should be visible, with default status: Process Data not 

Required. 
5. In the Process Data Status field, select the required status of each instrument tag you will be 

editing as follows: 
a. For instrument tags that require process data, select status: Process Data 

Required.  These tags will be available for the process engineer in the Process Data and 
Calculation modules. 

b. For instrument tags that do not require process data, select status: Process Data not 
Required. 

Enter Process Data for Instrument Tags 
1. Log on to SmartPlant Instrumentation as a user in the Process group. 
2. In the Process Data module, for each tag that requires the addition of process data, do the 

following: 
a. Find and open the tag. 
b. In the Process Data window, enter process data as you require. 
c. On the Actions menu, click Save Process Data. 

3. In the Select a New Process Data Status dialog box, select Release to Instrument, and 
click OK. 
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Enter Additional Instrument Data 
1. Log on to SmartPlant Instrumentation as a user in the Instrument group. 
2. In the Browser Groups list, Workflow, select the Instrumentation/Process Data Browser 

and open the view you created for it. 
3. For each tag for which you want to edit instrument data, make sure that the value under 

Process Data Status is Lock out from Process. 
4. In the Instrument Index module, do one of the following: 

 Open each tag individually and enter the required instrument data. 
 Create an appropriate Instrument Index browser view from which to enter the data. 

 
 

Process Data Statuses 
There are five statuses that relate to tags under Workflow.  The following table provides a 
description of each status and which groups (instrument engineers or process engineers) are 
allowed to set and change the status in the Workflow > Instrumentation / Process Data Browser 
and in the Process Data module: 

Status Description Set / Changed by 

Process Data 
not Required 

Tags that do not require process data 
and therefore are not available to the 
process engineering group. 

Set and changed by instrument 
engineers. 

Process Data 
Required 

Tags available for process data entry by 
the process engineering group (in the 
Process Data module or Browser). 

Set by instrument engineers.  Can 
be changed by process engineers. 

Lock out from 
Instrument 

Tags marked for editing by the process 
engineering group and not available to 
the instrument group. 

Set and changed by process 
engineers. 

Release to 
Instrument 

Tags available to the instrument 
engineering group following release 
from the process group. 

Set by process engineers.  Can be 
changed by instrument engineers. 

Lock out from 
Process 

Tags not available to the process 
engineering group. 

Set and changed by instrument 
engineers 
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Printing and Saving Documents 
You can print or save documents containing essential data from every module. Documents that 
can be printed include all reports, and some visual presentations of data such as point- to-point 
wiring diagrams.  Selecting to preview a document ensures that it will be printed the way you want 
and enables you to specify the file format if you want to save the document. 

 The page size of specification and wiring reports is hard-coded to A4, therefore only this 
setting will apply when printing these reports. 
 

Preview Documents 
The option to preview a document is available whenever you select a report, a point-to point wiring 
diagram for printing, or if you select the Print Preview option from a browser view. 

 The Print Preview dialog box appears only after you select Always or Ask user in the 
General tab of the Preferences dialog box. 
1. Select the report you want to display and when prompted to preview the report, click Yes. 

2. Click  to adjust the currently displayed report's magnification level. 
3. In the Zoom dialog box, do one of the following: 

 In the Magnification section, select a predefined magnification level: 200%, 100% (the 
default level), 65%, or 30%. 

 Type the required magnification level in the field next to the Custom option button. 
4. Click OK to return to the Print Preview window at the selected magnification. 
5. In the case of reports consisting of several pages or multiple reports, navigate using the 

following options: 

Icon View Menu Command Description 

 First Page Browses to the first page of a multi-page 
report.  You can also move through the pages of 
a report using the vertical scroll box.  Clicking the 
scroll box displays the current page number. 

 Previous Page Browses to the previous page of a multi-page 
report 

 Next Page Browses to the following page of a multi-page 
report  

 Last Page Browses to the last page of a multi-page report 

 First Report Browses to the first report (available with multiple 
report selection only). 

 Previous Report Browses to the previous report (available with 
multiple report selection only). 

 Next Report Browses to the following report (available with 
multiple report selection only). 

 Last Report Browses to the last report (available with multiple 
report selection only). 
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Print Documents 
Depending on the options you selected, printing is available directly when you select a document 
for printing, or you can print a document from a print preview.  This procedure refers to general 
printing. 

 The Enhanced Report Utility prints PDFs using SmartPlant PDF Converter 401 and 
publishes them to the output folder specified in File > Preferences > Enhanced Reports > 
<Report Type> >Viewer Output Folder field for the specific report type. If no path is present then 
SmartPlant PDF Converter 401 publishes the PDF to the Temp folder as specified in File > 
Preferences > General. 
1. Select the desired items from which you can print reports, and on the appropriate main menu 

or, if available, on a shortcut menu, click the report that you want to print. 
2. If a print preview prompt appears, do one of the following: 

 Click Yes to display a print preview of one or more reports. 
 Click No to print the reports directly to a printer or a file. 

3. To print a report from a print preview to a printer or a file, do one of the following: 

 In the Print Preview window, click  to print the currently selected report. 

 In the Print Preview window, click  to print all the retrieved reports or documents in 
batch mode. 

 
 If you choose to directly print a report without previewing it, and the particular report usually 

includes printing parameters when viewed in the Print Preview window (for example, 
selection of a group separator), a dialog box opens to enable you to select those same 
parameters prior to printing. 

 The page size of specification and wiring reports is hard-coded to A4, therefore only this 
setting will apply when printing these reports. 

 
 

Batch Printing Documents to PDF Files 
SmartPlant Instrumentation supports batch printing of the following documents to .pdf files: 
 Enhanced reports 
 Specification sheets 
 Binder packages from the Document Binder module (for details, see Print from a Binder 

Package to a PDF File (on page 337)) 

 
 SmartPlant PDF Converter 401 publishes Enhanced Report PDFs to the output folder 

specified in File > Preferences > Enhanced Reports > <Report Type>> Viewer Output 
Folder field for the specific report type. If no path is present then SmartPlant PDF Converter 
401 publishes the PDF to the Temp folder as specified in File > Preferences >General. 

 For Specification Sheets, set the path in the Print Specs to PDF Files dialog box. 
 For Document Binder packages, set the path in the Print to file dialog box.  
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Modify Printer Settings 
This option enables you to view and modify the current printer settings, if required.  You can 
select a standard paper size with predefined width, height, and orientation or customize these 
settings as required.  Furthermore, you can save your settings as default for future print 
sessions.  You can customize your own paper width, height, and orientation and include these 
values in the default settings.  Note, that some reports, specifications and wiring in particular, 
have their orientation/page size hard-coded, therefore only the hard-coded settings will apply. 

 
 All your page settings apply to all reports and documents that you print and they are true for all 

plant hierarchy levels (domain, <plant>, <area>, and <unit>). 
 All your page settings apply to your local machine only and do not affect other users of 

SmartPlant Instrumentation. 
 If you want to change the page setup for the current print session only, do not click Default, 

just make your changes and click OK. 
When saving your settings as default, the software stores the values in the Intools.ini file under the 
[PRINTER] section.  If you want the software to calculate the required paper size from the 
Windows printer driver settings, open the Intools.ini file and under the [PRINTER] section, remove 
the semi-colon before the following parameters: 
 LEFTMARGIN 
 RIGHTMARGIN 
 TOPMARGIN 
 WIDTH 
 HEIGHT 
 ORIENTATION 
 HRES 
 VRES 

Add a semi-colon before the PAPERSIZE parameter. 
For additional information about this option, click Help in the Page Setup dialog box. 
 
 

Save Documents 
When you display a document, you can choose to save it as a file.  This section describes the 
various methods available for saving documents. 

1. With the Print Preview window open, click . 
2. In the Save As dialog box, select one of the following data formats: 

 Original: Saves the report data in all the fields, including the ones that are not visible in 
the preview (for example, internal database ID numbers).  This option is recommended if 
you want to save the file in .psr or .xls format, or if you want to re-import the data into 
SmartPlant Instrumentation at a later stage. 

 Data Only: Saves only the report data that is visible in the preview.  This option is 
recommended for easier viewing of the data, and also enables you to manipulate the 
headers and select the columns you want to display. 

3. Click OK and navigate to the location where you want to save the file. 
4. Select the required file format and type the name of the file, then click Save. 
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Save in DXF Format 
1. If you use SmartSketch or AutoCAD, you can save any report in the .dxf format for insertion 

into a CAD drawing.  This option is available when you select to save a document as a file 
from a Print Preview window.  On selecting to save the file in a .dxf format, you can specify 
the report insertion parameters in the target CAD drawing, define certain display properties, 
and set the software to include the title block and frame, if needed. 

If a report has several pages, the software creates several .dxf files.  A .dxf file can only contain a 
single page of a report. 

 
 When saving a multi-page specification in .dxf format, the software only saves the active page 

of the spec print preview.  To save all pages of a spec in .dxf format, you must display a print 
preview of each page and save the pages one by one. 

 It is not possible to save the multi-tag (SEE LIST) page of a multi-tag spec in .dxf format. 
Save a Document in DXF Format 

1. With the Print Preview window open, click . 
2. In the Save As dialog box, select DXF File. 
3. In the Save AsDXF Options dialog box, select Include title block and frame with report to 

save the report with the title block (which includes the logo and generic report data) and the 
frame. 

 
 Clear the check box to exclude the title block and frame from the saved report if the CAD 

package has its own frame. 
 If you are working in batch mode to save a number of files that are to be opened in 

SmartSketch or AutoCAD, you can automate the process as far as possible. 
4. Define the report placement parameters and other options as follows: 

File Description  

Insertion point The X and Y coordinates for the insertion point of the report in the CAD file 
define the displacement from the lower-left corner of the CAD file.  The 
upper-left corner of the report is inserted at this location.  This means that if the 
insertion point is defined as X=0 and Y=0, the report appears outside the CAD 
drawing frame, under the lower frame line. 

Scale factor The scale factor determines the size of the report so that it will fit into the CAD 
drawing. 

Font height 
coefficient / 
Font width 
coefficient 

Font height and width coefficients for the text characters in the report.  This 
option is needed because the software calculates the font size independently of 
the size of the report, whereas a CAD application scales the font with the report 
as a whole. 

Change black 
report color to 

Type the value of the color to be used as a substitute for black.  All reports are 
displayed in black-and- white.  If viewing the report in a CAD application with a 
black background, an alternative foreground color needs to be used.  The 
recommended value is 7. 

5. Browse to the target folder and click OK. 
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Edit Document Headers 
When you select to save a document as a file from the Print Preview dialog box and you choose 
to save it as data only, you have the option of saving the data with or without 
headers.  Furthermore, if you select to include the headers with the data, you can also edit 
them.  This includes the possibility of exporting the headers to a separate text file. 

1. With the Print Preview window open, click . 
2. In the Save As dialog box, select Data Only. 
3. Select the Allow Headers check box. 
4. Select the Edit Headers check box and click OK. 
5. Select the required file format and file path and click Save. 
6. In the Edit Column Headers dialog box, select the Incl. check box for the columns you want 

to include in the output file. 
7. Under the Header Text column, edit the text as required. 
8. Under the Width column, change the maximum text width (number of characters allowed) as 

required. 
9. If you want to save the header settings in this screen to a text file: 

a. Click Export Headers. 
b. In the Export to File dialog box, navigate to the required location and enter a file name. 
c. Click Save. 

 If an external header text file exists, you can click Import Headers to load the data into 
the Export to File dialog box. 

 
 

Scale a Report to Fit Printer Paper Size 
When printing a report, the size of the printed report is taken from the template selected in the 
Enhanced Reports > File Locations (Preferences). For example, if you have selected 
A4tall.sma as the template file for your reports, all your reports are printed to fit A4 size paper. If 
you try to print to A3 size paper the report is still printed as if the paper is A4 size. To scale to fit a 
different sized paper from the one selected in the File Locations preferences, you must do the 
following: 
1. In SmartPlant Instrumentation, click File > Preferences > Enhanced Reports. 
2. Click  to expand the required report, for example Enhanced Smart Loop. 
3. Click Page and Revisions Options. 
4. In the Page and scaling options group box, from the Scale to page size list, select the size 

of the paper for printing, for example A3. 
5. Click OK. 
6. Generate the report. 
7. At the Report Preview prompt, click No to send the report directly to the printer. The report is 

scaled to fit the size selected in the Page and scaling options and not printed according to 
the size in the report template. 

 
 If you preview the report in the Enhanced Report Utility, the paper size for printing is taken 

from the report template as selected in the File Locations (Preferences). 
 The following paper sizes are not supported by this function: 
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 A0 Tall 
 A0 Wide 
 A1 Tall 
 A1 Wide 
 A2 Tall 
 A2 Wide 
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S E C T I O N  3  

The Instrument Index module allows you to create, modify, and maintain a comprehensive 
database that contains all your instrumentation data. 
The module offers tools for adding, editing, duplicating, and deleting loop and instrument tag 
numbers.  Instrument types and their profiles are organized in a comprehensive fashion providing 
easy data entry.  Other data, such as model and manufacturer, P&ID drawing numbers, lines, 
locations, I/O types, equipment names are organized in supporting tables. 
The Instrument Index module also provides other functions that include item-oriented (tag, loop, 
and so forth), filtered, sorted and customizable database viewing options.  You can generate 
reports in several formats, attaching remarks to items, creating specific summaries, and viewing 
and managing history. 
Before working with the Instrument Index module make sure the Domain Administrator has 
defined the Loop and Tag naming conventions in the Administration Module.   For more 
information, see Naming Conventions in the Administration User's Guide, under Domain and 
Project Administration, Naming Conventions. 

See Also 
Associating Instrument Tags with Loop Numbers (on page 107) 
Working with Typical Loops and Tags (on page 111) 
Generating Documents (on page 133) 
 

Instrument Index Module Window 
The Instrument Index Module window is the main entry point to all your instrument index activities. 
The window consists of the following sections: 
 Menu bar — Provides access to all the Instrument Index Commands (on page 65). 
 Application work area — The area where other Instrument Index module windows and 

dialog boxes open. 
 Toolbar — Provides access to the most common Instrument Index module commands. 
 Status bar — Shows the current status or the pertinent Microhelp message, plant hierarchy 

items, and the current date and time. 
 

Instrument Index Commands 
The following commands are used when working in the Instrument Index module. 

Icon Commands Explanation 

 Edit > Tag Numbers > New Tag Number Adds a new tag to the current domain 

 Edit > Tag Numbers > Tag Number 
Properties 

Edits the properties of a tag number that you 
select in the Enter Tag Number dialog box.

 Edit > Tag Numbers > Duplicate Tag 
Numbers  

Duplicates a tag number that you select in 
the Enter Tag Number dialog box. 

Instrument Index Module 
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Icon Commands Explanation 

None Edit > Tag Numbers > Delete Tag 
Numbers 

Deletes a tag number that you select in the 
Enter Tag Number dialog box. 

None Edit > Tag Numbers > Move Tag 
Number 

Moves a tag number that you select in the 
Enter Tag Number dialog box to another 
<unit> <area> or <plant>. 

 Edit > Loop Numbers > New Loop 
Number 

Creates a new loop number. 

 Edit > Loop Numbers > Loop Number 
Properties 

Edits the properties of a loop that you select 
in the Enter Loop Number dialog box. 

 Edit > Loop Numbers > Duplicate Loop 
Number 

Creates a new loop by duplicating the 
properties of an existing loop. 

None Edit > Loop Numbers > Delete Loop 
Number 

Deletes a loop number that you enter in the 
Enter Loop Number dialog box. 

None Edit > Loop Numbers > Move Loop 
Number 

Moves a loop number that you select in the 
Enter Loop Number dialog box to another 
<unit> <area> or <plant>. 

 Edit > Loop Numbers > Rename 
Multiple Loop Numbers 

Renames a loop number. 

None Edit > Typical Loop Management Opens the Typical Loop Management 
dialog box. 

None Edit > Batch Loop Creation Opens the Batch Loop Creation dialog box.

None Reports > All Tag Numbers Opens the Report Selection Options dialog 
box for creating a tag summary report. 

None Reports > Available Tag Numeric 
Segments 

Opens the Available Tag Numeric 
Segments dialog box to create a report of all 
the unused numeric segments of tag 
numbers in the current <unit> or <plant>. 

None Reports > Available Loop Numeric 
Segments 

Opens the Available Loop Numeric 
Segments dialog box to create a report of all 
the unused numeric segments of loop 
numbers in the current <unit> or <plant>. 

None Reports > Loop Tag Numbers Creates a report of loop numbers and their 
associated tags. 

None Reports > Loop Summary Opens the Report Selection Options dialog 
box for creating a loop summary report. 

None Reports > Tables > Standard 
Instrument Type List 

Creates an Instrument Type Report. 

None Reports > Tables > Detailed Instrument 
Type List 

Creates a Detailed Instrument List Type 
Report. 

None Reports > Tables > Instrument Statuses Creates an Instrument Status Report. 

None Reports > Tables > I/O Types Creates an I/O Types Report. 
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Icon Commands Explanation 

None Reports > Tables > Equipment Type Creates an Equipment Type Report. 

None Reports > Tables > Equipment Creates an Equipment Report. 

None Reports > Tables > P&ID Drawing 
References 

Creates a P&ID Drawing References Report.

None Reports > Tables > Line Type Creates a Line Type Report. 

None Reports > Tables > Lines Creates a Lines Report. 

None Reports > Tables > Instrument 
Criticality 

Creates an Instrument Criticality Report. 

None Reports > Tables > Instrument 
Manufacturers 

Creates an Instrument Manufacturers 
Report. 

None Reports > Tables > Instrument Models Creates an Instrument Models Report. 

None Reports > Tables > Loop Measured 
Variables 

Creates a Loop Measured Variables report. 

None Reports > Tables > Function Blocks Creates a Function Blocks Report. 

None Reports > Electrical Equipment Tables 
> Associated Electrical Equipment 

Creates an Associated Electrical Equipment 
Report. 

None Reports > Electrical Equipment Tables 
> Associated Electrical Equipment & 
Types 

Creates an Associated Electrical Equipment 
and Types Report. 

None Reports > Electrical Equipment Tables 
> Circuits 

Creates a Circuits Report. 

None Reports > Telecom Devices Creates a Telecom Devices Report. 

None Reports > Telecom Tables > Standard 
Telecom Type List 

Creates a Telecom Type Report. 

None Reports > Telecom Tables > Detailed 
Telecom Type List 

Creates a Telecom Type List Report. 

None Reports > Telecom Tables > Telecom 
Line Numbers 

Creates a Telecom Line Numbers Report. 

None Reports > Telecom Tables > Telecom 
Field Equipment 

Creates a Telecom Field Equipment Report.

None Reports > Telecom Tables > Telecom 
Signal Levels 

Creates a Telecom Signal Levels Report. 

None Reports > Power Supply Tables > Rated 
Voltage 

Creates a Rated Voltage Report. 

None Reports > Power Supply Tables > 
Frequency 

Creates a Frequency Report. 

None Reports > Power Supply Tables > 
Number of Phases 

Creates a Number of Phases Report. 
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Icon Commands Explanation 

None Reports > Power Supply Tables > 
Operating Modes 

Creates an Operating Modes Report. 

 Actions > Browse Index Opens an Instrument Index Standard 
Browser view. 

 Actions > Associate Opens the Associate Tag Number dialog 
box to associate a selected loop with tag 
numbers. 

None Tables > Instrument Types Opens the Instrument Types dialog box. 

None Tables > General Process Function 
Sub-Categories 

Opens the General Process Function 
Sub-Categories dialog box for defining a 
sub-category for the general process 
function. 

None Tables > Instrument Statuses Opens the Instrument Statuses dialog box 
for maintaining the Status drop-down list. 

None Tables > I/O Types Opens the I/O Types dialog box for 
maintaining the contents of the I/O Types 
list. 

None Tables > Instrument Locations Opens the Instrument Locations dialog box 
for specifying general or specific instrument 
locations within the <plant>. 

None Tables > Equipment Opens the Equipment dialog box for 
categorizing equipment that your 
instruments are installed on. 

None Tables > P&ID Drawing References Opens the P&ID Drawing References 
dialog box. 

None Tables > Lines Opens the Lines dialog box for categorizing 
and modifying line data. 

None Tables > Instrument Criticality Opens the Instrument Criticality dialog box 
enabling you to customize instrument 
criticality data. 

None Tables > Instrument Certification Opens the Instrument Certification 
supporting table that holds certification for 
instruments that are certified for hazardous 
environments. 

None Tables > Instrument Manufacturers Opens the Instrument Manufacturers 
supporting table. 

None Tables > Instrument Models Opens the Instrument Models dialog box 
where you store instrument model data. 

None Tables > Function blocks Opens the Function blocks dialog box 
where you can add, delete, and modify 
user-defined function blocks. 
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Icon Commands Explanation 

None Tables > Intrinsically Safe Circuit 
Types 

Opens the Intrinsically Safe Circuit Types 
dialog box. 

None Tables > Loop Measured Variables Opens the Loop Measured Variables 
dialog box allowing you to enter or modify the 
loop process variable identifier which is used 
in the loop naming conventions. 

None Tables > Loop Types Opens the Loop Types supporting table. 

None Tables > Loop Functions Opens the Loop Functions dialog box 
allowing you to enter or modify the loop 
function identifier which is used in loop 
naming conventions. 

None Tables > Electrical Equipment > 
Associated Electrical Equipment 

Opens the Associated Electrical 
Equipment Types dialog box.  This allows 
you to view equipment tags that are 
associated with signals that are defined in 
SmartPlant Electrical and the equipment 
type to which each signal belongs. 

None Tables > Electrical Equipment > 
Associated Electrical Equipment Types

Opens the Associated Electrical 
Equipment Types dialog box.  This shows 
all the available associated electrical 
equipment types to which SmartPlant 
Electrical signals can belong. 

None Tables > Electrical Equipment > 
Circuits 

Opens the Electrical Equipment supporting 
table.  This supporting table holds circuit 
values that appear in the Circuit list on the 
Electrical tab of the Tag Number 
Properties dialog box. 

None Tables > Telecom > Telecom Device 
Types 

Opens the Telecom Device Types dialog 
box.  You use this dialog box to create and 
manage telecom device types. 

None Tables > Telecom > Telecom Line 
Numbers 

Opens the Telecom Line Numbers dialog 
box.  You use this dialog box to maintain the 
contents of the Telecom line list when 
creating a telecom field device. 

None Tables > Telecom > Telecom Field 
Equipment 

Opens the Telecom Field Equipment 
dialog box.  You use this dialog box to 
maintain the contents of the Field 
Equipment drop-down list in the Tag 
Number Properties dialog box. 

None Tables > Telecom > Telecom Signal 
Levels 

Opens the Telecom Signal Levels dialog 
box.  You use this dialog box to maintain the 
contents of the Signal Level drop- down list 
in the Tag Number Properties dialog box. 



Instrument Index Module 
 

 
70 SmartPlant Instrumentation Basic Engineering User's Guide 

 

Icon Commands Explanation 

None Tables > Power Supply > Rated Voltage Opens the Rated Voltage supporting 
table.  This shows the rated voltage values 
that you can use in the Rated voltage list on 
the Power Supply tab of the Tag Number 
Properties dialog box. 

None Tables > Power Supply > Frequency Opens the Frequency supporting 
table.  This shows the frequency values that 
you can use in the Frequency list on the 
Power Supply tab of the Tag Number 
Properties dialog box. 

None Tables > Power Supply > Number of 
Phases 

Opens the Number of Phases supporting 
table.  This shows the number of phase 
values that you can use in the Number of 
phases list on the Power Supply tab of the 
Tag Number Properties dialog box. 

None Tables > Power Supply > Operating 
Modes 

Opens the Operating Modes supporting 
table.  This shows the operating mode 
values that you can use in the Operating 
mode list on the Power Supply tab of the 
Tag Number Properties dialog box and the 
properties dialog boxes of panels that 
support power supply. 

None Tables > Signal Type Opens the Signal Type dialog box that holds 
signal type values that are used to define 
HART instrument properties. 

None Tables > Linearity Types Opens the Linearity Types dialog box that 
holds linearity type values that are used to 
define HART instrument properties. 
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S E C T I O N  4  

Managing Loop Numbers 
SmartPlant Instrumentation allows you to easily create and manage loops throughout your 
<plant>.  You can create unique numbered loops for each <unit> in your <plant>.  Duplicate, 
rename, and move loops about your <plant> without losing critical information.  Edit loop number 
information, change loop numbers, create new numbers, simply and quickly without creating a 
duplicate loop number within a <unit>, or losing any information.  SmartPlant Instrumentation 
keeps track of all your loops making the necessary adjustments automatically. 
 

Create a New Individual Loop Number 
This option shows you how to create a new single loop number, in the Domain Explorer or in the 
Instrument Index module, and add it to your database. 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Loops folder. 
2. Right-click the Loops folder and on the shortcut menu, click New > Loop. 
3. On the New Loop Number dialog box, type the name of the new loop number.  For an 

explanation of the segments of a loop number see Loop Number Naming Convention (on 
page 72). 

4. Click OK and, when prompted to create a new tag number, and associate it with the current 
loop, click Yes. 
 Click No if you only want to create a loop number.  Then, following the current procedure 

from Step 7. 
 Click Yes if you want to create a tag number at this stage and associate it with the new 

loop. 
5. If you clicked Yes, do the following: 

a. The New Tag Number dialog box opens. 
b. Type the tag number and click OK. 

6. On the Select Instrument Type dialog box, select your instrument type and click OK. 
7. The Tag Number Properties dialog box opens where you can define the general properties 

for your tag number.  For details of the options available click the Help button in the New Tag 
Properties dialog box. 

8. When you have finished click OK to open the Loop Number Properties dialog box. 
9. On the Loop Number Properties dialog box, define the properties you want to associate with 

the loop number.  For details of the options available click the Help button in the Loop 
Number Properties dialog box. 

10. Click OK to close the Loop Number Properties dialog box. 

 
 The data field in the New Loop Number dialog box displays the loop name template which is 

based on the loop naming convention defined by the Domain Administrator.  In the 
alphanumeric and the numeric parts of the name, you can type any character (letters, digits, 
spaces, and so forth).  You can customize the loop name template but only the Domain 
Administrator can change the naming conventions.  For more details see Customize New 
Loop Numbers. 

 You can define a functional requirement while creating a new loop.  For details, see Define a 
Functional Requirement for a Loop (on page 81). 
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Loop Number Naming Convention 
When renaming existing loop numbers or creating new ones, make sure that the loop number 
names comply with the naming conventions set for the current <unit> by the Domain Administrator 
for the current <unit>.  In the alphanumeric and the numeric parts of the name, you can type any 
character (letters, digits, spaces, and so forth). 
Example Loop Number: 101- FIC - 2225/E 

Segment  Description 

100 — first segment of the loop number, derived from the 
loop naming convention defined by the Domain 
Administrator 

F — measured variable 

IC — loop function 

2225 — loop number 

E — suffix 
 
 

Duplicate a Loop Number 
This option shows you how to create a new loop number by duplicating an existing 
one.  SmartPlant Instrumentation creates a new loop number based on the properties of a source 
loop that you select.  This feature is useful when you want to create a loop number similar to an 
existing one.  You duplicate a loop number and then edit its properties as needed.  

 You can duplicate a loop number in the same <unit> as the source loop number or in any 
other <unit> of the current domain. 
1. In the Domain Explorer, expand your current <plant> hierarchy to display the Loops folder. 
2. Double-click the Loops folder to display the existing loops. 
3. Right-click the loop you want to duplicate, and on the shortcut menu, click Duplicate. 
4. On the Duplicate Loop Number dialog box, type the new loop number. 

 The data field on the Duplicate Loop Number dialog box displays the loop name 
template based on the loop naming convention defined by the Domain Administrator.  In the 
alphanumeric and the numeric parts of the name, you can type any character (letters, digits, 
spaces, and so forth). 

5. If required, do the following to create the duplicated loop number in a different <unit> in the 
current domain: 
a. On the Duplicated Loop Number dialog box, check the Create in another unit check 

box. 
b. On the Select Target Unit dialog box, select the target unit. 
c. Click OK to return to the Duplicated Loop Number dialog box. 
d. Click OK in the Duplicated Loop Number dialog box. 

 One of the following dialog boxes opens, depending on the defined Instrument 
naming convention:  
 Create Loop Tags (7 or fewer segments). 
 Duplicated Tag Number (8 or more segments). 
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Duplicating Loop Tags for 7 or Fewer Segments (Create Loop 
Tags Dialog Box) 
To duplicate tags associated with the duplicated loop: 
1. On the Create Loop Tags dialog box, select the appropriate check boxes beside the tag 

numbers that you want to create.  The software duplicates the tags associated with the 
source loop and associates the new tags with the new loop number.  

 If you have more than one type of tag associated with the loop, for example; 
Conventional tags and Functional requirement tags, a Create Loop Tags dialog box will open 
for each tag type, one after the other. 

2. Modify the names of the new tag numbers as needed.  
 You cannot change the separator. 

3. Select Copy the instrument type from the source tag numbers to keep the instrument 
type of the source tags. 

4. Click Next to move to the next tag type Create Loop Tags dialog box.  
 If you click Next after editing all the loop tag types a prompt will appear, click Yes to 

return to the first Create Loop Tags dialog box, or No to close the prompt. 
5. Click OK, and when prompted, click either Yes to edit the tag properties for the tag you have 

duplicated, or No to duplicate the tag numbers with their existing parameter values. 
6. On the Loop Number Properties dialog box, define the properties you want to associate with 

the loop number.  For details of the options available click the Help button in the Loop 
Number Properties dialog box. 

7. Define a functional requirement if needed.  For details, see Define a Functional Requirement 
for a Loop (on page 81). 

8. Click OK. 

 
 You can change the measured variable of the new loop number or keep it the same as the 

source one.  New tag numbers associated with the new loop number will be affected 
accordingly, that is, the measured variable of the new tag numbers will change if the measured 
variable of the new duplicated loop is changed.  For example, if you are duplicating Loop 
101-F-102 and you change the measured variable of the new loop to T, the new tag numbers 
associated with the new loop number will change their instrument type in accordance with the 
new measured variable: source Tag Number 101-FE-102 will change to 101-TE- 102. 

 You can also duplicate a loop number from the Instrument Index module.  On the Instrument 
Index Module window, click  or on the menu bar, click Edit > Loop Numbers > Duplicate 
Loop Number. 
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Duplicating Loop Tags for 8 and Above Segments (Duplicated 
Tag Number Dialog Box) 
To duplicate tags associated with the duplicated loop: 
1. On the Duplicated Tag Number dialog box, modify the name of the new tag number as 

needed.  
 You cannot change the separator. 

2. Click OK. 
The software duplicates the tag associated with the source loop and associates the new tag 
with the new loop number.  

 If you have more than one tag associated with the loop, a Duplicated Tag Number 
dialog box will open for each tag, one after the other. 

3. When prompted, click Yes to edit the tag properties for the tag you have duplicated, or No to 
duplicate the tag numbers with their existing parameter values. 

4. On the Loop Number Properties dialog box, define the properties you want to associate with 
the loop number.  

 For details of the options available click the Help button in the Loop Number Properties 
dialog box. 

5. Define a functional requirement if required.  For details, see Define a Functional Requirement 
for a Loop (on page 81). 

6. Click OK. 

 
 You can change the measured variable of the new loop number or keep it the same as the 

source one.  New tag numbers associated with the new loop number will be affected 
accordingly, that is, the measured variable of the new tag numbers will change if the measured 
variable of the new duplicated loop is changed.  For example, if you are duplicating Loop 
101-F-102 and you change the measured variable of the new loop to T, the new tag numbers 
associated with the new loop number will change their instrument type in accordance with the 
new measured variable: source Tag Number 101-FE-102 will change to 101-TE- 102. 

 You can also duplicate a loop number from the Instrument Index module.  On the Instrument 
Index Module window, click  or on the menu bar, click Edit > Loop Numbers > Duplicate 
Loop Number. 

 

Move Loop Numbers 
This option shows you to select one loop number or a group of loop numbers and move them to 
another <unit> in the current <plant>. 
1. Start the Instrument Index Module by doing one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. On the Instrument Index menu bar click Edit > Loop Numbers > Move Number. 
3. On the Enter Loop Number dialog box, do one of the following: 

 To move one loop number, type the required loop number. 
 To move a group of loop numbers, click Find. 
 In the Find Loop dialog box click Find again .  
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 In the Search results data window, hold down Ctrl and highlight the required loop 
numbers, or select the Select all check box to move all the displayed loop numbers. 

4. Click OK. 
5. On the Select Target <Unit> dialog box, select the <unit> to which you what to move the 

selected loop numbers. 
6. Click OK. 
 

Edit Loop Number Properties from the Domain Explorer 
This option allows you to modify the properties of an existing loop number from the Domain 
Explorer.  You can also edit the target loop number when duplicating an existing loop number. 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Loops folder 
2. Double-click the Loops folder to display the existing loops. 
3. Right-click a loop, then click Properties. 
4. On the Loop Number Properties dialog box, edit the loop properties by entering values or 

selecting values from the lists. 

 If needed, click the  button beside an appropriate list arrow to open the pertinent 
supporting table where you can rename a loop number, add, edit, or delete an item on the list. 

5. Select Display old loop number automatically under Preferences > Instrument Index > 
Rename, for the Old loop number field to automatically display the old loop number when 
renaming a loop. 

6. You can define a functional requirement while creating a new loop.  For details, see Define a 
Functional Requirement for a Loop (on page 81). 

7. Select Apply P&ID drawing to tags to apply the P&ID drawing number data to any new tag 
numbers that will be subsequently associated with this loop.  Then, in the Loop Browser 
View window (in the Browser module), you can select a different drawing number (if available) 
and propagate it to all tag numbers associated with this loop.  If you are editing an existing 
loop which is already associated with a P&ID drawing number, selecting this option replaces 
the existing drawing number values with the new drawing number that you enter in the P&ID 
drawing field. 

8. Select the Apply service to tags check box to download the loop service to any new tag 
numbers that will be subsequently associated with the current loop.  If you are editing an 
existing loop which is already associated with tag numbers, selecting this option replaces the 
existing tag service values with the new loop service that you type in the Loop service field. 

9. Select Apply equipment to tags to apply the equipment data to any new tag numbers to be 
subsequently associated with this loop. 

 
 If you clear the Apply P&ID drawing to tags check box, you will still be able to define a 

P&ID drawing reference for subsequently associated new tag numbers by selecting a 
required drawing number from the P&ID list in the Tag Number Properties dialog box. 

 If the loop you are editing already contains associated equipment, selecting this option 
replaces the existing equipment values with the new equipment that you type in the Loop 
equipment field. 

10. Select the Update document number check box to update the document number of the 
associated loop drawing. 
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 A document number naming convention can contain segments that represent loop 
number properties.   Therefore, if you select this check box, changing a loop number property 
that is used in the document number segment also changes the document numbers in 
accordance with this change.  After you select this check box, the software updates numbers 
of all documents containing the current loop number.  For the current loop number, the 
software overrides the default or user-defined numbers of all the documents that appear in the 
Loop Drawing List dialog box of the Loop Drawings module.  For details on document number 
naming conventions, see the Administration module Help, Document Number Naming 
Convention Examples. 

11. Click OK. 
12. At the prompt, do one of the following: 

 Click Yes to edit the tag numbers associated with the current loop. 
 Click No to close the Loop Number Properties dialog box and save new loop number 

values without editing the associated tag numbers. 
 

Edit Loop Properties from the Instrument Index Module 
This option allows you to modify the properties of an existing loop number from the Instrument 
Index module.  You can also edit the target loop number when duplicating an existing loop 
number. 
1. To start the Instrument Index Module do one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. In the Instrument Index Module window, do one of the following: 

 Click . 
 Click Edit > Loop Numbers > Loop Number Properties. 

3. In the Enter Loop Name dialog box, do one of the following: 
 Type the loop number that you want to edit and click OK. 
 Click Find without entering any loop number and in the Find Loop dialog box click 

Find.  Select the loop number whose properties you want to edit in the Search results 
data window, and click OK. 

4. In the Loop Number Properties dialog box, edit the loop properties by entering values or 
selecting values from the lists. 

 

 If needed, click the  button beside an appropriate list arrow to open the pertinent 
supporting table where you can rename a loop number, add, edit, or delete an item on the 
list. 

 Select Display old loop number automatically under Preferences > Instrument Index 
> Rename, for the Old loop number field to automatically display the old loop number 
when renaming a loop. 

 You can define a functional requirement while creating a new loop.  For details, see 
Define a Functional Requirement for a Loop (on page 81). 
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5. Select Apply P&ID drawing to tags to apply the P&ID drawing number data to any new tag 
numbers that will be subsequently associated with this loop.  Then, in the Loop Browser 
View window (in the Browser module), you can select a different drawing number (if available) 
and propagate it to all tag numbers associated with this loop.  If you are editing an existing 
loop which is already associated with a P&ID drawing number, selecting this option replaces 
the existing drawing number values with the new drawing number that you enter in the P&ID 
drawing field. 

6. Select the Apply service to tags check box to download the loop service to any new tag 
numbers that will be subsequently associated with the current loop.  If you are editing an 
existing loop which is already associated with tag numbers, selecting this option replaces the 
existing tag service values with the new loop service that you type in the Loop service field. 

7. Select Apply equipment to tags to apply the equipment data to any new tag numbers to be 
subsequently associated with this loop. 

 
 If you clear the Apply P&ID drawing to tags check box, you will still be able to define a 

P&ID drawing reference for subsequently associated new tag numbers by selecting a 
required drawing number from the P&ID list in the Tag Number Properties dialog box. 

 If the loop you are editing already contains associated equipment, selecting this option 
replaces the existing equipment values with the new equipment that you type in the Loop 
equipment field. 

8. Select the Update document number check box to update the document number of the 
associated loop drawing. 

 A document number naming convention can contain segments that represent loop 
number properties.   Therefore, if you select this check box, changing a loop number property 
that is used in the document number segment also changes the document numbers in 
accordance with this change.  After you select this check box, the software updates numbers 
of all documents containing the current loop number.  For the current loop number, the 
software overrides the default or user-defined numbers of all the documents that appear in the 
Loop Drawing List dialog box of the Loop Drawings module.  For details on document number 
naming conventions, see the Administration module Help, Document Number Naming 
Convention Examples. 

9. Click OK. 
10. At the prompt, do one of the following: 

 Click Yes to edit the tag numbers associated with the current loop. 
 Click No to close the Loop Number Properties dialog box and save new loop number 

values without editing the associated tag numbers. 
 

Edit Multiple Loop Numbers 
This option shows you how to select a group of loop numbers and modify the profile of these loop 
numbers.  This option is especially effective if you do not want to edit the tag numbers associated 
with the loops you are editing. 
1. Start the Instrument Index Module by doing one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. In the Instrument Index Module window, do one of the following: 

 Click . 
 Click Edit > Loop Numbers > Loop Number Properties. 
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3. On the Enter Loop Number dialog box, click Find without typing any loop number. 
4. On the Find Loop dialog box, click Find. 
5. On the Search results data window, select the loop numbers you require.  You can hold 

down the Ctrl key and select a group of loop numbers or check the Select all check box. 
6. Click OK. 
7. On the Loop Number Properties dialog box, edit the loop properties by entering values or 

selecting values from the lists. 

 If needed, click the  button beside an appropriate list arrow to open the supporting 
table where you can rename a loop number, add, edit, or delete an item on the list. 

8. Select Apply service to tags to apply the loop service of the current loop number to the 
associated tag numbers. 

9. Select Apply P&ID to tags to propagate the P&ID drawing number data to all the tag 
numbers associated with the current loop number. 

10. Select Apply equipment to tags to propagate the equipment data to all the tag numbers 
associated with the current loop number. 

11. Click Next to edit the properties of another loop. 
 When you save the new loop number values, the software does not update the 

properties of the tags associated with the loop numbers you are editing.  When editing 
multiple loop numbers, the software does not prompt you to edit the associated tag 
numbers.  For more details on editing tags see Edit Instrument Tags from the Instrument 
Index (on page 93). 

12. Click OK to close the Loop Number dialog box and save new loop number values. 
 

Create a Loop Number When Editing a Tag 
This option shows you how to create a new loop number on the fly while editing a tag 
number.  You can then associate the current tag number with that new loop you are creating. 
1. From the Domain Explorer select the tag you want to edit. 
2. Right click the tag and select Properties. 
3. On the Tag Number Properties dialog box, click New Loop. 
4. On the New Loop Number dialog box, type the name of the new loop number and click 

OK.  For an explanation of the segments of a loop number see Loop Number Naming 
Convention (on page 72). 

5. Edit the properties of the new loop number as required In the Loop Number Properties 
dialog box and click OK. 

6. On the Tag Number Properties dialog box, click OK. 
 

Delete Loop Numbers 
This option shows you how to delete loop numbers that are no longer required.  You can delete a 
single loop number or several ones as needed.  When deleting a loop number, several batch 
deletion options are possible depending on your loop number deletion preference settings.  You 
can delete several loop numbers in batch mode (without being prompted to confirm each deletion) 
or delete several loop numbers one by one, confirming the deletion of each loop number. 

 If you are deleting a loop number associated with wiring, SmartPlant Instrumentation 
automatically disconnects all the required instruments. 
1. On the Instrument Index module menu bar, click Edit > Loop Numbers > Delete Loop 

Number. 
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2. On the Enter Loop Name dialog box, do one of the following: 
 Type the loop number that you want to delete. 
 Click Find without typing a loop number, so that you can select several loop numbers for 

deletion in the Find Loop dialog box. 
3. On the Find Loop dialog box, if required, click the Find loops with one or more fieldbus 

tags check box to narrow your search results to loops that contain tags with a fieldbus system 
I/O type. 

4. Click Find. 
 You can view more loop number rows, select Show more search results. 

5. On the Search results data window, select the loop numbers that you want to delete and click 
OK. 

6. On the Delete Loop Number dialog box, click Delete. 
 If there are any tag numbers associated with the Loop Number a prompt box will ask you 

if you want to delete all associated tag numbers.  Click Yes to delete, or No to save the tag 
numbers 

 
 If you are deleting several loop numbers and you have selected the Skip deletion 

confirmation option in your loop deletion preferences, all the loop numbers you have 
highlighted in the Search results data window will be deleted on the fly without prompting to 
confirm each deletion. 

 You can also delete one or more loop numbers using the Domain Explorer without opening 
the Instrument Index module.  In the tree view of the Domain Explorer, click the Loops 
folder.  Then, in the Items pane, select the loops you want to delete.  Right-click the selected 
loop numbers and then click Delete.  For more information about the Domain Explorer, see 
SmartPlant Instrumentation Explorer (on page 517). 

 

Rename a Single Loop Number 
This option shows you how to rename a single loop number. 
1. Start the Instrument Index Module by doing one of the following: 

 Click  
 Click Modules > Instrument Index. 

2. On the Instrument Index Module, do one of the following: 

 Click  
 Click Edit > Loop Numbers > Loop Number Properties. 

3. On the Enter Loop Number dialog box type the name of the loop that you want to rename 
and click OK or do the following: 
 On the Enter Loop Number dialog box, click Find without typing any loop number. 
 On the Find Loop dialog box click Find. 
 Select the loop number from the Search results dialog box and click OK. 

4. On the Loop Number Properties dialog box, click  next to the Loop number field. 
5. On the Rename Loop Number dialog box, type the new loop number name. 
6. Click OK. 
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7. On the Loop Number Properties dialog box click OK. 

 
 If you set the preferences to open the Rename Loop Drawing File dialog box after renaming 

a loop number, do the following to rename the file name of the associated CAD drawing.  In 
the Rename Loop Drawing File dialog box, select a check box beside a desired file 
name.  Type a new name over the name displayed in the New Drawing File column. 

 If more than one file appears in the data window, the drawing type is multi-drawing. 

 
 You can rename the drawing file name if the loop number that you are renaming is associated 

with a CAD loop drawing.  To do this, set a preference on the Rename page of the 
Preferences Dialog box before performing this procedure.  For more details see Set 
Preference for Renaming A CAD File from A Loop Number (on page 80). 

 Make sure that your new loop number name complies with the naming conventions for the 
current <unit>. 

 All loop numbers must have unique names in the current <unit>. 
 

Set Preference for Renaming A CAD File from A Loop 
Number 

1. Click File > Preferences. 
2. In the Tree View pane, double click the Instrument Index icon. 
3. Click the Rename icon. 
4. Select the Rename drawing file name when renaming the loop check box. 
5. Click OK. 
 

Rename Multiple Loop Numbers 
This option shows you how to rename multiple loop numbers in the current <unit>.  You can also 
modify the loop number service and edit associated tag numbers if required. 
1. Start the Instrument Index Module by doing one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. On the Instrument Index Module, do one of the following: 

 Click . 
 Click Edit > Loop Numbers > Rename Multiple Loop Numbers. 

3. On the Enter Loop Number dialog box, click Find. 
4. On the Find Loop dialog box, click Find again. 
5. On the Search results data window, select the loop numbers you require.  You can hold 

down the Ctrl key and select a group of loop numbers or check the Select all check box. 
6. Click OK. 
7. On the Rename Multiple Loop Numbers dialog box, do the following: 

a. Select the Select check box next to each loop number that you want to rename, or select 
the Select all check box to rename all the loops in the Rename Multiple Loop Numbers 
dialog box. 

b. On the New Loop Number field, type the new loop number name. 
c. Click the Loop Service field and modify the value if needed. 
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d. Select the Edit tag numbers check box to edit the properties of the tag numbers 
associated with the selected loop numbers after you rename these loop numbers 

e. Click Rename. 
f. On the Tag Number Properties dialog box, edit the properties of the tag numbers you 

have chosen. 
g. Click OK. 
h. The Rename Multiple Loop Numbers dialog box reopens. 

 If after clicking Rename some of the selected loop numbers have not been renamed, the 
Result field of the Rename Multiple Loop Numbers dialog box displays the reason why you 
could not rename these loop numbers. 
i. Click Close. 

 Make sure that your new loop number names comply with the naming conventions of 
the current <unit>.  All loop numbers must have unique names in the current <unit>. 

 

Define a Functional Requirement for a Loop 
This option shows you to define a functional requirement for a selected loop number.  Functional 
requirement is the combination of loop function and process function data for a specific loop.  For 
example, for Loop FIC-100, F refers to process function and IC to process function.  C can be 
interpreted as measuring and control.  During the early stages of a project, the loop functional 
requirements are known.  However, the functional requirements for the project devices are not 
known yet.  To make cost estimations during the early stages of your project, you need loop 
functional requirements that contain process data, such as loop number, DN, pipe specifications, 
and so forth.  Later on in your project, you can copy these functional requirements to the real 
devices. 

 You can define multiple functional requirements for a specific loop number.  Also, you can 
generate a specification for a loop that has a functional requirement. 
1. Create or edit a loop number. 
2. On the Loop Number Properties dialog box, click Func. Req.. 
3. On the New Tag Number dialog box, under Tag number type the new tag number name and 

click OK. 
4. On the Select Process Function dialog box, select the process function that you need and 

click OK. 
5. On the Tag Number Properties dialog box, define the properties of the new tag number as 

you require. 
6. Click OK. 
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S E C T I O N  5  

Working with Instrument Types 
You use instrument type to identify and classify instruments in SmartPlant 
Instrumentation.  SmartPlant Instrumentation provides a number of predefined instrument types, 
such as FE, PT, and so forth.  You can add new instrument types and modify the shipped 
instrument types as required.  You can also delete an instrument type that is not in use, but the 
software does not let you delete an instrument type that you already used to create a tag number. 
SmartPlant Instrumentation uses standard function identifier acronyms to identify instrument 
types.  However, some function identifier acronyms are not unique and are used for more than 
one instrument type.  For instance, FE can refer to D/P Type Flow Element or a Mass Flow 
Sensor.  As a result, when creating a new tag number with such an acronym, the software opens 
the Select Instrument Type dialog box where you select the appropriate instrument type. 
You classify all instrument types in SmartPlant Instrumentation according to process 
function.  You use process function to associate an instrument with a specific type of 
specification, process data, and calculation sheet.  For example, if you need to associate a tag 
number with a specification that contains flow information, this tag number must have an 
instrument type that belongs to the Flow process function. 
For each instrument type that you define, you also set a profile definition that allows you to 
automate the creation of tag numbers with a number of predefined properties. 
When defining an instrument type, you also define its profile.  Instrument type profile allows you to 
automate the creation of tag numbers with a number of predefined properties.  When you create a 
tag number whose instrument type includes a profile, the software automatically creates and 
associates a number of items that you chose in the instrument type profile that serves as a basis 
for the new tag number. 
 

Define an Instrument Type 
Use this procedure to define a new instrument type, or edit the properties of an existing instrument 
type. 
1. On the Instrument Index module menu bar, click Tables > Instrument Types. 
2. In the Instrument Types dialog box, from the Process function list, select the process 

function that you require. 
3. Do one of the following: 

 Click New to append a new data row in the data window. 
 Click a selected row to edit the values of an existing instrument type. 

4. Under Instrument Type, type an instrument type acronym.  You can have duplicate 
acronyms if needed. 

 If you have duplicate instrument type acronyms, when creating new tags based on such 
an instrument type, SmartPlant Instrumentation opens the Select Instrument Type dialog 
box and lets you select the exact instrument type that you require for the new instrument. 

5. Under Description, type a brief description as desired. 
6. Under CS Tag Instrument Type Alias, type an alias for a control system tag instrument 

type.  Do this only if you want to create control system tags that will have an alias instrument 
type associated with the current instrument type.  Leave this field blank if you are not going to 
create CS tags based on the current instrument type or if you want the CS tags to have the 
same instrument type as the tag number. 
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7. If you selected the General process function, under General Process Function 
Sub-Category, select a value that you predefined in the General Process Function 
Sub-Category supporting table.  For details, see Define a General Process Function (on 
page 84). 

 

Define a General Process Function 
Use this procedure to create a sub-category for the General process function.  You can then 
select one of the sub-category values for any General process function in the data window of the 
Instrument Types dialog box. 
1. On the Instrument Index module menu bar, click Tables > General Process Function 

Sub-Category. 
2. Click New to append a new data row. 
3. Type the new sub-category name, for example, Mechanical, Electrical, and a description, as 

you require. 
 

Define an Instrument Type Profile 
Use this procedure to define a profile for each instrument type that you use.  An instrument type 
profile is a group of default settings that allow you to create new instruments with certain 
predefined properties, associations, documents, and wiring items.  For example, when creating 
an instrument, you can automatically create the instrument specification, reference device panel 
and cable, associate the instrument with a specific hook-up, and so forth. 
1. On the Instrument Index Module window menu bar, click Tables > Instrument Types. 
2. From the Process function list, select the process function that you require. 
3. In the data window, select the instrument type for which you want to define profile options. 
4. Click Profile. 
5. Make your definitions as you require. 

 
 Make sure that your preferences on the Instrument Index > Profile page of the Preferences 

dialog box are set to activate the options that you require.  These preferences only apply 
when you create new instruments.  For example, if you clear the Specifications check box, 
when creating a tag number, the software ignores specification creation options defined on the 
General tab of the Instrument Type Profile dialog box and creates the tag without any 
specification.  If you then manually generate a specification for the created tag, the software 
applies the existing instrument type profile options. 

 Preferences on the Instrument Index > Profile page of the Preferences dialog box do not 
apply to the settings on the Calibration tab of the Instrument Type Profile dialog box. 
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Define a Wiring and Controls System Instrument Type Profile 
Use this procedure to set the wiring and control system default settings allowing you to create new 
tag numbers with the settings that you defined for the instrument type.  For example, you can 
automatically define new instruments as control-system-enabled so that new tag numbers with the 
current instrument type profile will be part of a control system and be able to send and receive 
signals.  You can also include automatic creation of control system (CS) tags, selection of 
reference panels and cables, and connector definitions. 
1. On the Instrument Index Module menu bar, click Tables > Instrument Types. 
2. On the Instrument Types dialog box, from the Process function list, select the process 

function type. 
3. Do one of the following: 

 Create a new instrument type. 
 On the data window, select an existing instrument type. 

4. Click Profile. 
5. On the Instrument Type Profile dialog box, on the General tab, you can edit fields as 

needed. 
6. On the Wiring and Control System tab, select the Include wiring check box. 
7. To define new instrument tags as control-system-enabled, select the Control system check 

box.  This enables the corresponding tag numbers for tag assignment. 
8. To enable automated creation of coupled control system tags, select Automatic CS tags. 
9. From the Reference device panel list, select an appropriate reference panel for this 

instrument type.  These are device panels that were created in Reference Explorer. 
10. If your reference device panel settings enable the Conventional connections group box, do 

one of the following for each connection that you need for the current instrument type: 
 Click New, to add a connection. 
 Click Properties, to edit the properties of an existing convention, and on the 

Conventional Connection Properties dialog box, define the settings that you require, 
and click OK. 

11. If your reference device panel settings enable the Plug-and-socket connections group box, 
do one of the following for each connection that you need for the current instrument type: 
 Click New, to add a connection. 
 Click Properties, to edit the properties of an existing convention, and on the 

Plug-and-Socket Connection Properties dialog box, define the settings that you 
require, and click OK. 

 
 SmartPlant Instrumentation creates the wiring items according to an instrument type profile, it 

always connects the created cable to the right side of the panel that it creates.  Therefore, you 
are not allowed to select a left-oriented terminal from the Starting terminal list on the 
Conventional Connection Properties dialog box.  You can check the configuration of a 
terminal by right-clicking it in the Domain Explorer and selecting Properties on the shortcut 
menu. 

 SmartPlant Instrumentation does not allow you to define a wiring instrument type profile that 
enables connections on the left side of a device panel. 
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Copy Instrument Type Profile Data 
Use this procedure to copy instrument type profile data from one instrument type to another.  This 
procedure is useful when you want to define instrument types with similar profile properties.  This 
way you do not need to define all the profile data for a new instrument type from scratch.  After 
completing this procedure, you can access the profile associated with the target instrument type 
and change the required properties. 
1. On the Instrument Index module menu bar, select Tables > Instrument Types. 
2. From the Process function list, select the process function that you require. 
3. Click Profile. 
4. On the Instrument Type Profile dialog box, click Copy From to open the Copy Instrument 

Type Profile Data dialog box. 
5. From the Process function list, select the required process function. 
6. In the data window, select the instrument type whose profile data you want to copy. 
7. Click OK to reopen the Instrument Type Profile dialog box, where you can view the new 

profile properties. 
8. Define the instrument type profile as you require. 

 
 If you want to copy the specification profile properties, note that both the source and the target 

instrument type must belong to the same process function.  When the source and the target 
instrument type belong to different process functions, the system copies the data without the 
specification profile properties. 

 When copying instrument type profile settings, the software ignores the definitions on the 
Calibration profile tab. 

 

Set an Alias Control System Tag 
Use this procedure to create an alias for automatically created CS tags.  When creating CS tags 
automatically, you can instruct SmartPlant Instrumentation to use CS tag naming conventions or 
use the shipped predefined naming convention for CS tags.  SmartPlant Instrumentation will 
name new CS tags according to the rules you set only after the Domain Administrator has set the 
control system tag naming conventions for the current <unit>.  If the CS tag naming conventions 
have not been set, the software uses the following predefined rule for all automatically created CS 
tags: 
 INSTRUMENT TYPE + NUMBER + \SUFFIX After the Domain Administrator defines the control 
system tag naming conventions for the current <unit>, you can decide whether to use the tag 
number's instrument type for the CS tag or set an alias for the new CS tags.  If you do not set an 
alias for these CS tags, SmartPlant Instrumentation names them according to the instrument type 
of the tag numbers with which they are created.  Note that the length of the alias text should not 
exceed the length of the instrument type alias string defined by the Domain Administrator on the 
Naming Conventions dialog box. 
1. Check that your Domain Administrator has set the naming conventions for control system tags 

that you create in the current <unit> . 
2. Define the instrument type profile for the required tag numbers and enable the automatic 

creation of CS tags.  For more details, see Define an Instrument Type (on page 83). 
3. In the Instrument Types dialog box, highlight the required instrument type. 
4. Click in the CS Tag Instrument Type Alias field for the selected instrument type and enter 

the CS alias by overtyping the displayed value. 
5. Click OK to accept your settings and close the Instrument Types dialog box. 
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 The CS tag alias will be enabled only if the Domain Administrator has selected INST. TYPE 
ALIAS from the Description list on the Naming Conventions dialog box when setting the control 
system tag naming conventions. 
 

Apply All Existing Profiles 
Use this procedure to create the following items specified in the for selected instruments in an 
Instrument Index Standard Browser view:  instrument specifications, control system tags, and 
device panels and cables. 
1. Open an Instrument Index Standard Browser view. 
2. Select the desired tag numbers. 
3. Do one of the following: 

 Right-click, and on the shortcut menu, click Apply Profile > Apply All Profile Options. 
 Click Actions > Apply Profile > Apply All Profile Options. 

4. In the Results dialog box, view the results for each set of items, and then click Close. 

 
 To make this feature work, you must select the appropriate check boxes and options in the 

instrument type profile of the selected tag number.  For more details, see Define an 
Instrument Type Profile (on page 84). 

 This option applies all the instrument type profile options to the selected tag numbers, 
regardless of the settings defined on the Instrument Index > Profile page of the Preferences 
dialog box. 

 This option does not affect instrument profile options for items other than specifications, 
control system tags, and device panels and cables. 

 If you are applying a profile that has custom table definitions, the software creates the custom 
tables and overwrites the data of the previously created custom tables for the current tag 
numbers. 

 
  



Instrument Index Module 
 

 
88 SmartPlant Instrumentation Basic Engineering User's Guide 

 

 



 

 

SmartPlant Instrumentation Basic Engineering User's Guide 89 
 

S E C T I O N  6  

Managing Instrument Tags 
SmartPlant Instrumentation allows you to easily create and manage instrument tags throughout 
your <plant>.  You can create unique numbered tags for each <unit> in your <plant>.  Duplicate, 
rename, and move tags about your <plant> without losing critical information.  Define each 
instrument tag simply.  Easily add or remove instrument tags from loops, without creating a 
duplicate instrument tag, or losing any information.  SmartPlant Instrumentation keeps track of all 
your instrument tags, automatically making the necessary adjustments as you work. 
 

Instrument Tag Naming Convention 
The data field displays the instrument tag name template which is based on the tag naming 
convention defined by the Domain Administrator for the current <unit>.  In the alphanumeric and 
the numeric parts of the name, you can type any character (letters, digits, spaces, and so 
forth).  You can customize the tag name template to set a default, but only the Domain 
Administrator can change the naming conventions.  For more details see Customize Tag Name 
(on page 93). 
Example: 101- FE - 2225/E 

Segment Description 

100 Prefix derived from the tag naming convention defined by the Domain 
Administrator 

FE Measured variable 

2225 Loop number that the tag is associated with 

E Suffix 

 
 Though the naming conventions do not apply to tags classed as electrical, you cannot create 

an electrical tag until the naming convention for conventional instruments has been defined. 
 In order to trim extra spaces in a tag name, enable the Trim Instrument Tag Names rule. In 

SmartPlant Instrumentation Rule Manager, expand the Instrument Index > Consistency 
hierarchy. Double-click the Trim Instrument Tag Names rule and then clear the Disable rule 
check box on the General tab of the Rule Properties dialog box. Note that this rule is 
provided to you as part of the shipped data. 
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Create an Instrument in the Domain Explorer 
This option shows you how to create an instrument in the Domain Explorer.  When you define 
new instruments, the software creates them according to the instrument type profiles that you 
defined in the Instrument Type Profile dialog box for a selected instrument type.  Defining a 
profile allows you to set instrument type default settings for new instrument tags and thus create 
them with certain predefined properties based on the instrument type you select for the new 
instrument.  You set profiles for every instrument type that you use.  Consequently, make sure 
that you set and activate all the required instrument type profiles before you start creating new 
instruments. 
1. Press F7 to open the Domain Explorer. 
2. Expand the plant hierarchy to display the Instruments and Loops folders. 
3. Do one of the following: 

 To create an instrument that is not associated with any loop number, right-click the 
Instruments folder and on the shortcut menu click New > Instrument. 

 To create an instrument that is associated with a specific loop number, expand the Loops 
folder, right click the required loop, and click New > Instrument. 

4. On the New Tag Number dialog box, do the following: 
a. From the Tag class list, select the desired tag class according to whether you want to 

create a conventional, Foundation Fieldbus, HART instrument, soft tags, Telecom tag, 
and so forth. 

b. Type the name of the new tag.  For details on instrument tag naming conventions see 
Instrument Tag Naming Convention (on page 89). 

c. Click OK. 
d. If the Select Instrument Type dialog box opens (because there is more than one record 

for a given instrument type acronym), select the required instrument type and click OK. 

 
 If the tag name does not correspond to an existing loop name, you are prompted to enter 

a loop name based on the tag you have entered.  If the loop identifier already matches an 
existing loop, then the new tag name will automatically be associated with the loop. 

 If the loop convention includes the loop function parameter, the prompt will always 
appear. In this case, you have to complete the loop name.  If a profile exists for the 
selected instrument type, any new tags for that instrument type will be created with the 
selected default settings. 

5. On the Loop Name dialog box, do one of the following: 
 Type the loop number that the new tag is to be associated with. 
 Accept the displayed loop number. 
 Click Cancel to create the tag number without a loop association. 

6. Click OK. 
7. On the Loop Number Properties dialog box, accept the loop number properties or modify 

them as required and then click OK. 
 The Loop Number Properties dialog box only opens if the tag number is associated 

with a loop number. 
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8. On the Tag Properties dialog box enter the properties as required, and click OK.  For details 
on entering power supply data (not available if the selected Tag Class is electrical), see Enter 
Power Supply Data for Panels and Instrument Tags (on page 94) 

 
 You can also create a new instrument tag in the Instrument Index module.  For more details, 

see Create an Instrument Tag in the Instrument Index Module (on page 91). 
 When creating a new tag, you can determine whether or not process data is required for it, and 

if so, at what stage the information should be entered by a process engineer.  For more details 
of workflow implementation, see Workflow (on page 54). 

 In order to trim extra spaces in a tag name, enable the Trim Instrument Tag Names rule. In 
SmartPlant Instrumentation Rule Manager, expand the Instrument Index > Consistency 
hierarchy. Double-click the Trim Instrument Tag Names rule and then clear the Disable rule 
check box on the General tab of the Rule Properties dialog box. Note that this rule is 
provided to you as part of the shipped data. 

 

Create an Instrument Tag in the Instrument Index Module 
This option shows you how to create an instrument in the Instrument Index module.  When you 
define new instruments, the software creates them according to the instrument type profiles that 
you defined in the Instrument Type Profile dialog box for a selected instrument type.  Defining a 
profile allows you to set instrument type default settings for new instrument tags and thus create 
them with certain predefined properties based on the instrument type you select for the new 
instrument.  You set profiles for every instrument type that you use.  Consequently, make sure 
that you set and activate all the required instrument type profiles before you start creating new 
instruments. 
1. To start the Instrument Index module do one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. Do one of the following: 
 Click Edit > Tag Numbers > New Tag Number. 

 Click New Tag . 
3. On the New Tag Number dialog box, do the following: 

a. From the Tag class list, select the desired tag class according to what you want to create 
(For example: conventional, Foundation Fieldbus, HART instrument, soft tags or Telecom 
tag). 

b. Type the name of the new instrument tag.  For details on instrument tag naming 
conventions, see Instrument Tag Naming Convention (on page 89). 

c. Click OK. 
d. If the Select Instrument Type dialog box opens (because there is more than one record 

for a given instrument type acronym), select the required instrument type and click OK. 

 
 If the instrument tag name does not correspond to an existing loop name, you are 

prompted to enter a loop name based on the instrument tag name you have entered.  If 
the loop identifier already matches an existing loop, then the new tag name will 
automatically be associated with the loop. 

 If the loop convention includes the loop function parameter, the prompt will always 
appear. In this case, you have to complete the loop number.  If a profile exists for the 
selected instrument type, any new tags for that instrument type will be created with the 
selected default settings. 
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4. On the Loop Name dialog box, do one of the following: 
 Type the loop number that the new tag is to be associated with. 
 Accept the displayed loop number. 
 Click Cancel to create the tag name without a loop association. 

5. Click OK. 
6. On the Loop Number Properties dialog box, accept the loop number properties or modify 

them as required and then click OK. 
 The Loop Number Properties dialog box only opens if the tag number is associated 

with a loop number. 
7. On the Tag Properties dialog box enter the properties as required and click OK.  For details 

on entering power supply data (not available if the selected Tag Class is electrical), see Enter 
Power Supply Data for Panels and Instrument Tags (on page 94). 

 
 You can also create a new instrument tag in the Domain Explorer without opening the 

Instrument Index module.  For more details, see Create an Instrument in the Domain Explorer 
(on page 90). 

 When creating a new instrument tag, you can determine whether or not process data is 
required for it, and if so, at what stage the information should be entered by a process 
engineer.  For more details of workflow implementation, see Workflow (on page 54). 

 In order to trim extra spaces in a tag name, enable the Trim Instrument Tag Names rule. In 
SmartPlant Instrumentation Rule Manager, expand the Instrument Index > Consistency 
hierarchy. Double-click the Trim Instrument Tag Names rule and then clear the Disable rule 
check box on the General tab of the Rule Properties dialog box. Note that this rule is 
provided to you as part of the shipped data. 

 

Edit an Instrument Tag from the Domain Explorer 
This option enables you to edit individual instrument tags.  If you want to edit the tags associated 
with a particular loop, use the Loop Number Properties option.  You can edit individual 
instrument tags that you enter in the Enter Tag Number dialog box or select the required tags 
from the Search results data window in the Find Tag dialog box. 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Instruments 

folder. 
2. Double-click the Instruments folder to display the existing tag numbers. 
3. Right-click the required tag, and from the shortcut menu select Properties . 
4. On the Tag Properties dialog box enter the properties as required.  For details on entering 

power supply data (not available if the selected Tag Class is electrical), see Enter Power 
Supply Data for Panels and Instrument Tags (on page 94). 

5. Click OK. 

 
 Editing the properties of an existing tag does not affect its existing association with a 

loop.  For more details, see Change an Instrument Tag Loop Association in the Domain 
Explorer (on page 107). 

 The data that appears in the Prefix, Number, and Suffix fields is derived from the tag number 
itself. 

 You can also edit the properties of an instrument tag from the Instrument Index module.  For 
more details see, Edit Instrument Tags from the Instrument Index (on page 93). 
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Edit Instrument Tags from the Instrument Index 
This option enables you to edit single and multiple instrument tags.  If you want to edit the 
instrument tag associated with a particular loop, use the Loop Number Properties option.  You 
can edit individual tags that you enter in the Enter Tag Number dialog box or select the required 
tags from the Search results data window in the Find Tag dialog box. 
1. To start the Instrument Index module do one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. Do one of the following: 

 Click . 
 Click Edit > Tag Numbers > Tag Number Properties. 

3. On the Enter Tag Number dialog box, do one of the following: 
 To edit a single tag , type the tag number in the box. 
 To edit multiple tags, click Find to open the Find Tag dialog box.  Click and select the 

tags to be edited. 
4. Click OK. 
5. On the Tag Properties dialog box enter the properties as required.  For details on entering 

power supply data (not available if the selected Tag Class is electrical), see Enter Power 
Supply Data for Panels and Instrument Tags (on page 94). 

6. After modifying the data, do one of the following: 
 For multiple tags, click Apply > Next to continue editing.  Click OK when you have 

finished editing. 
 For a single tag click OK. 

 
 Editing the properties of an existing instrument tag does not affect its existing association with 

a loop.  For more details, see Change a Tag Loop Association (see "Change an Instrument 
Tag Loop Association in the Domain Explorer" on page 107). 

 The data that appears in the Prefix, Number, and Suffix fields is derived from the instrument 
tag itself. 

 

Customize Tag Name 
These options allow you to customize the default tag number name template that appears in the 
New Tag Number dialog box. 
Define new tag name template — These options determine how SmartPlant Instrumentation 
displays new tag number names in the New Tag Number dialog box in relation to the previously 
created tag number.  The options are: 
 No default — The data field in the New Tag Number dialog box will not display any default 

tag, letting you enter the number you need. 
 Same as the last created tag — The data field in the New Tag Number dialog box displays 

the last created tag.  You can accept the displayed number, modify it, or enter the number you 
need. 
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 Same as the last created tag + 1 — The data field in the New Tag Number dialog box 
displays the last created tag plus 1 (one).  You can accept the displayed number, modify it, or 
enter the number you need.  This option is available for numeric tag names only.  If your tag 
number names are not numeric, the data field in the New Tag Number dialog box will display 
the last created tag. 

Ignore loop creation when creating new virtual tag — Allows you to create a virtual tag without 
being prompted to create a loop associated with the new virtual tag. 
Use loop suffix in tag number name — Allows you to include the loop suffix in the name of a 
newly-created tag number. 

 In order to trim extra spaces in a tag name, enable the Trim Instrument Tag Names rule. 
In SmartPlant Instrumentation Rule Manager, expand the Instrument Index > Consistency 
hierarchy. Double-click the Trim Instrument Tag Names rule and then clear the Disable rule 
check box on the General tab of the Rule Properties dialog box. Note that this rule is provided to 
you as part of the shipped data. 
 

Change the Tag Class of an Instrument 
This procedure explains how to change the tag class of an existing instrument. 
1. In the Domain Explorer, right-click an appropriate instrument. 
2. On the shortcut menu, click Properties. 

3. On the Tag Number Properties dialog box, click the ellipsis button  next to the Number 
box. 

4. On the Rename Tag Number dialog box, select the tag class that you require. 
 

Enter Power Supply Data for Panels and Instrument Tags 
This procedure explains how to enter power supply data for various panels that require power 
supply.  Although power supply data is not essential for SmartPlant Instrumentation functionality, 
it is indicated for the interface with the SmartPlant Electrical application.  SmartPlant 
Instrumentation allows you to enter power supply data in all panels except for junction boxes and 
device panels. 
1. Do one of the following to open the Properties dialog box of a panel or tag number: 

 In the Domain Explorer or Reference Explorer, right-click a desired panel and then click 
Properties. 

 In the Domain Explorer or Reference Explorer, right-click a desired instrument and then 
click Properties. 

2. On the General tab, select the Requires power supply check box. 
3. Click the Power Supply tab. 
4. Under Criticality, select the criticality, which is used in SmartPlant Electrical to determine 

whether the current instrument requires UPS power or regular power. 
5. Under Rated voltage, select a value that indicates the voltage at which the instrument is 

designed to operate. 
6. If the instrument is running on alternating current, under Power supply type click AC and do 

the following: 
a. Under Frequency, select the operating frequency of the instrument. 
b. Under Number of phases, select the number of phases in the power supply to the 

instrument. 
c. Under Power factor full load, enter a value between 0 and 1 for the ratio of active to 

apparent power at 100% of the rated power. 
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7. If the instrument runs on direct current, under Power supply type, click DC. 
8. Under Rated active load, type the full load power consumption in kilowatts. 
9. Type the following values in amperes: 

a. Full load current. 
b. Starting current. 

10. In the Coincidence factors group box, do one of the following: 
 Under Operating mode, select Continuous, and under X — continuous, type a value 

between 0 and 1. 
 Under Operating mode, select Intermittent, and under Y — intermittent, type a value 

between 0 and 1. 
 Under Operating mode, select Spare, and under ZZ — spare, type a value between 0 

and 1 
 Under Operating mode, select Standby, and under Z — stand by, type a value between 

0 and 1. 
 The fields under Power distribution board data group box display data that is determined 

within SmartPlant Electrical.  On the Power Supply tab, click Help for more information. 
 

Enter an Instrument Tag Remark 
You use this option to enter a short remark to instrument tag properties in the Instrument Index 
Standard Browser view.  You add your tag remarks in the Rem column.  The browser view 
displays  in the Rem column for the tags that contain remarks. 

1. On the main menu bar, click . 
2. On the Browser Manager window,  expand the Instrument Index on the Browser Groups 

pane and select Instrument Index Standard Browser group. 
3. Ensure that the Rem. column is selected for displaying in the browser view by doing the 

following: 

a. Expand the Instrument Index Standard Browser group, and click . 
b. Under Style settings, click Edit. 
c. Scroll down the Data Field Header column to the Rem. field header and select the View 

check box. 
d. Click Save. 

4. Close the Browser Manager window. 
5. From the Instrument Index module, open the browser view, select the instrument tag that you 

require, and do one of the following: 
 Double-click the Rem. field. 

 Click . 
 Click Actions > Remarks. 
 On the selected tag, right-click and on the shortcut menu click Tag Number Activities > 

Remarks. 
6. On the Remarks dialog box, type the required text in the fields provided. 
7. On the Notes box, type a short note if needed. 

 The text that you type in the Notes box also appears in the Tag Number Notes dialog box. 
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 If necessary, define a custom browser view that you want to use for displaying the 
remarks.  For details, see Define a Standard Browser View for the Instrument Index (on 
page 123). 
 

Duplicate an Instrument Tag in the Domain Explorer 
This option enables you to create a new instrument tag in the Domain Explorer by duplicating the 
properties of an existing one and then editing the new tag properties as required.  You can create 
the new duplicated instrument tag in the same <unit> as the original tag or any other <unit> in the 
current domain. 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Instruments 

folder of the <unit> you are working on. 
2. Double-click the Instruments folder to display the existing instrument tags. 
3. Right-click the instrument tag you want to duplicate, and on the shortcut menu click 

Duplicate. 
4. Type the new instrument tag on the Duplicated Tag Number dialog box, and then click OK. 
5. If you want to duplicate the instrument tag in another <unit> of the same domain, do the 

following: 
a. Select the Create in another unit check box. 
b. Click OK. 

6. The Select Target <Unit> dialog box opens, select the target <unit> for the new tag, and 
then, click OK. 

7. On the Select Instrument Type dialog box, select the instrument you want to associate with 
the current tag number, and then, click OK. 

8. On the Loop Name dialog box, do one of the following: 
 Type the loop number that you want to associate the new instrument tag with, click OK, 

and then on the Loop Properties dialog box, enter the desired data and click OK. 
 Click OK to accept the displayed loop number and then on the Loop Properties dialog 

box, enter the desired data and click OK. 
 Click Cancel not to associate the new instrument tag with any loop.  You can associate 

the new tag with a loop later.  For more details, see Change an Instrument Tag Loop 
Association in the Domain Explorer (on page 107). 

9. On the Tag Properties dialog box enter the required data or select the appropriate values 
from the lists.  For details about entering power supply data (not applicable to electrical tags), 
see Enter Power Supply Data for Panels and Instrument Tags (on page 94). 

10. Click OK. 

 
 You can also duplicate an instrument tag from the Instrument Index module.  For more 

details, see Duplicate an Instrument Tag in the Instrument Index (on page 97). 
 The software does not duplicate existing calibration settings of the source tag.  If you want to 

define calibration settings for the duplicated tag, the calibration profile definitions 
apply.  These definitions exist at the level of the instrument type. 

 The software does not duplicate associated downstream lines, i.e., if more than one line is 
associated with the tag, only the first (upstream) line is duplicated. 
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Duplicate an Instrument Tag in the Instrument Index 
This option enables you to create a new instrument tag in the Instrument Index module by 
duplicating the properties of an existing one and then editing the new tag properties as 
required.  You can create the new duplicated instrument tag in the same <unit> as the original tag 
or any other <unit> in the current domain. 
1. In the Instrument Index Module window, do one of the following: 

 Click . 
 Click Edit > Tag Numbers > Duplicate Tag Number. 

2. On the Enter Tag Number dialog box, type the instrument tag number you want to duplicate, 
and then click OK. 

3. To find a tag that you want to duplicate do the following: 
a. On the Enter Tag Number dialog box, click Find. 
b. On the Find Tag dialog box, click Find. 
c. Select the instrument tag you want to duplicate, and then click OK. 

4. Type the new instrument tag on the Duplicated Tag Number dialog box, and then click OK. 
5. If you want to duplicate the instrument tag in another <unit> of the same domain, do the 

following: 
a. Select the Create in another unit check box. 
b. Click OK. 

6. On the Select Target <Unit> dialog box, select the target <unit> for the new tag and then click 
OK. 

7. On the Select Instrument Type dialog box, select the instrument type you want to associate 
with the current tag number, and then, click OK. 

8. On the Loop Name dialog box, and do one of the following: 
 Type the loop number that you want to associate the new instrument tag with, and click 

OK. 
 On the Loop Properties dialog box, type the desired data and click OK. 
 Click OK, to accept the displayed loop number. 
 Click Cancel, not to associate the new instrument tag with any loop.  You can associate 

the new tag with a loop later.  For more details, see Change a Tag Loop Association (see 
"Change an Instrument Tag Loop Association in the Domain Explorer" on page 107). 

9. On the Tag Properties dialog box enter the desired data or select appropriate values from the 
lists.  For details on entering power supply data (not applicable for electrical tags), see Enter 
Power Supply Data for Panels and Instrument Tags (on page 94). 

10. Click OK. 

 
 You can also duplicate an instrument tag from the Domain Explorer.  For more details, see 

Duplicate an Instrument Tag in the Domain Explorer (on page 96) 
 The software does not duplicate existing calibration settings of the source tag.  If you want to 

define calibration settings for the duplicated tag, the calibration profile definitions 
apply.  These definitions exist at the level of the instrument type. 

 The software does not duplicate associated downstream lines, i.e., if more than one line is 
associated with the tag, only the first (upstream) line is duplicated. 
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Delete Instrument Tags 
This option enables you to delete one or more instrument tags that are no longer in use. 
1. In the Domain Explorer, click the Instruments folder of the <unit> you are working on. 
2. On the Items pane, select the items you want to delete. 
3. Right-click the selected items, and click Delete. 
4. When prompted, click Yes to confirm deletion. 
 

Delete Instrument Tags in the Instrument Index Module 
1. On the Instrument Index module menu bar, click Edit > Tag Numbers > Delete Tag 

Numbers. 
2. On the Enter Tag Number dialog box, type the instrument tag number you want to delete, or 

click Find to select one or more instrument tags. 
3. On the Find Tag dialog box ,click Find and select the instrument tags you want to delete. 
4. Click OK. 
5. When prompted, click Yes to confirm deletion. 
 

Delete Instrument Tags in the Browse Window 
This option allows you to delete more than one instrument tag at the same time in batch mode. 
1. In the Instrument Index module, open the Instrument Index Standard Browser view by doing 

one of the following: 
 Click Actions > Browse Index. 

 Click  
2. On the Browser View window, select the instrument tags you want to delete. 
3. Do one of the following: 

 On the lower toolbar, click . 
 Right-click the selected Instrument tags, and on the shortcut menu click Tag Number 

Activities > Delete Tag number. 
 Click Actions > Delete Tag Number. 

4. When prompted, click Yes to confirm deletion. 
 

Move an Instrument Tag to Another Plant Group 
This option allows you to move an instrument tag to another <unit> in the same <plant> or to a 
<unit> in a different <plant> in the domain. 
1. On the Instrument Index module menu bar, click Edit > Tag Numbers > Move Tag Number. 
2. On the Enter Tag Number dialog box, type the instrument tag number you want to duplicate, 

and then click OK. 
3. To find a tag that you want to duplicate do the following: 

a. On the Enter Tag Number dialog box, click Find. 
b. On the Find Tag dialog box, click Find. 
c. Select the instrument tag you want to duplicate, and then click OK. 

4. On the Select Target dialog box, select the <unit> to which you want to move the current tag. 
5. Click OK. 
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 If you move an instrument tag to a target <unit> whose tag naming conventions are 
different from the naming conventions of the <unit> where the source tag is, the software applies 
the target <unit> naming conventions to the duplicated tag number. 
 

Move Multiple Instrument Tags in the Browser Window 
This option allows you to move one or more instrument tags in the Browser View window.  You 
can move a tag to another <unit> in the same <plant> or to a <unit> in a different <plant> in the 
domain. 
1. Open the Instrument Index module, by doing one of the following: 

 Click Modules > Instrument Index. 

 Click  
2. Open an Instrument Index Standard Browser view, by doing one of the following: 

 Click Actions > Browse Index. 

 Click  
3. Select the instrument tags you want to move. 
4. Do one of the following: 

 Click Actions > Move Tag Number. 
 Right-click the selected tags, and from the shortcut menu click Tag Number Activities > 

Move tag Number. 
5. On the Select Target <Unit> dialog box, select the <unit> you want to move the instrument 

tags to. 
6. Click OK. 

 If you move an instrument tag to a target <unit> whose tag naming conventions are 
different from the naming conventions of the <unit> where the source tag is, the software applies 
the target <unit> naming conventions to the duplicated tag number. 
 

Rename an Instrument Tag 
1. From the Instrument index module, do one of the following: 

 Click Edit > Tag Numbers > Tag Number Properties. 

 Click  
2. On the Enter Tag Number dialog box, do one of the following: 

 Type the tag number you want to rename. 
 Click Find, to open the Find Tag dialog box.  In the Find Tag dialog box, click Find and 

select the tags you want to rename. 
3. If needed, on the Tag Number Properties dialog box, change the instrument type of the tag 

you want to rename. 
4. If you want to update the numbers of the documents associated with the current instrument 

tag (specification, process data, calculation, and dimensional data sheets), select the Update 
document numbers check box. 
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 Make sure that the document number naming conventions includes instrument 
naming convention segments the current tag contains.  The software does not update 
document numbers for which the default naming convention is used.  Suppose you want to 
rename a tag number FT-100 to FT-101 and the source tag has a spec FT-100-SP.  After 
renaming, the default document number of the renamed instrument specification remains as 
FT-100-SP, even though this number contains the 100 segment, which was renamed for the 
instrument. 

5. Beside to the Number field, click . 
6. On the Rename Tag Number dialog box, change the tag class, edit the tag instrument type, 

number, or suffix as required. 
7. Click OK. 
8. If the instrument type acronym is not unique, select the required instrument type from the 

Select Instrument Type dialog box and click OK to open the Tag Number Renaming 
Options dialog box. 

9. If you want to rename the associated control system tags, do the following: 
a. Select the Rename CS tag check box. 
b. In the New Control System Tag data field, modify the control system tag name as 

required. 
c. Click OK. 

10. Click OK, to close the Tag Number Properties dialog box. 

 
 If you have connected several CS tags to the current tag number, the system automatically 

assigns the same new name to all the CS tags.  You must rename the new CS tags manually 
to make the names unique. 

 Before clicking OK, note that all the wiring items that were associated with the old CS tag will 
be renamed according to the new control system tag name, and the associated specification 
will be deleted.  Verify whether the appropriate loop blocks and hook-ups are associated with 
the new tag number. 

 Make sure that the new name complies with the naming conventions for the current 
<unit>.  Naming conventions do not apply to tags classed as electrical.  For more details, see 
Instrument Tag Naming Convention (on page 89). 

 For more information about instrument tag renaming options, see Instrument Tag Renaming 
Options (on page 100). 

 

Instrument Tag Renaming Options 
When you rename a tag, two situations are possible for changing the process function and the 
instrument type of that tag: 
 The Process Function has not changed — for example: renaming 108-PT-2212 to 

108-PI-2212.   Renaming a tag number this way does not change the process which the tag 
describes.  Therefore, all the process data information that has been associated with the old 
tag will be automatically associated with the new tag.  You can also delete the old process 
data if required. 
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 The Process Function has changed — for example: renaming 108-PT-2212 to 
108-FT-2212.  If you rename a tag number this way, only general process data properties, 
such as pressure, temperature, and density will be propagated from the old tag number to the 
new one.  Process data properties specifically associated with the tag's process function, for 
example, range, alarm trip settings, upper level, and so forth, will either not be propagated to 
the renamed tag or only be propagated partially.  In this case, the old tag's additional 
properties and calculation results will not propagate to the new tag either. 

 

Changing the Measured Variable 
You can change the measured variable of the new loop number or keep it the same as the source 
one.  New tag numbers associated with the new loop number will be affected accordingly, that is, 
the measured variable of the new tag numbers will change if the measured variable of the new 
duplicated loop is changed.  For example, if you are duplicating Loop 101-F-102 and you change 
the measured variable of the new loop to T, the new tag numbers associated with the new loop 
number will take a new instrument type in accordance with the new measured variable: source 
Tag Number 101-FE-102 will change to 101- TE-102. 
 

Change an Instrument Type 
This option allows you to change the instrument type and process function of an instrument 
tag.   You make this change when editing instrument tag number, this can be done in single or 
multi-mode. 
1. Open the Tag Number Properties dialog box. 
2. On the Tag Number Properties dialog box, do one of the following: 

 From the Instrument type list, select the instrument type that you require. 

 Click  to open the Instrument Type dialog box, where you can modify the existing 
instrument types or add a new instrument type to the list. 

3. On the Tag Number Properties dialog box, click Apply. 
 Instead of clicking Apply, you can click Rename to rename the current tag number as 

required. 
4. If the selected instrument type belongs to a different process function, in the Tag Number 

Renaming Options dialog box do one of the following: 
 Select Keep general process data to delete only specific process data associated with 

the tag whose instrument type you are changing. 
 Select Delete process data to delete all the process data associated with the tag whose 

instrument type you are changing. 
5. If you want to rename the associated control system tags, do the following: 

a. Select the Rename CS tag check box. 
b. On the New Control System Tag data field, modify the control system tag name as 

required. 
c. Click OK, to return to the Tag Number Properties dialog box. 

6. On the Tag Number Properties dialog box, click OK. 

 
 If you have connected several CS tags to the current tag number, the system automatically 

assigns the same new name to all the CS tags.  You must rename the new CS tags manually 
to make the names unique. 
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 Before clicking OK, note that all the wiring items that were associated with the old CS tag will 
be renamed according to the new control system tag name, and the associated specification 
will be deleted.  Verify whether the appropriate loop blocks and hook-ups are associated with 
the new tag number. 
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Associating Tag Category and Criticality 
You can associate a selected instrument with several tag categories and one instrument 
criticality.  You can also associate instruments that require preventive maintenance with either 
Process Safety Systems or Quality Systems.  For example, if an instrument is used for custody 
purposes, it can be defined as a Quality System. 
 

Add and Edit Criticality Values 
This option allows you to create and customize instrument criticality values that appear on the 
Criticality list in the Associate Categories and Criticality dialog box.  Tag criticality is a 
user-defined process classification of instruments, for example process safety system, 
environmentally vital system, quality system, and so forth.  Tag categories help you select 
groups of tags when performing Maintenance module procedures. 
1. To open the Criticality Values dialog box, do one of the following: 

 On the Instrument Index Module window menu bar, click Tables > Instrument 
Criticality. 

 On the Instrument Index Standard Browser view, right-click a tag number and on the 
shortcut menu, click Tag Number Activities > Associate Categories and 

Criticality.  Then, in the Associate Categories and Criticality dialog box, click  
beside the Criticality list arrow. 

2. In the Instrument Criticality dialog box, do one of the following: 
 Click New to append a new row to list of existing options and type a criticality name and 

description. 
 Highlight a row and edit the Criticality and Description fields. 
 Highlight a row and click Delete to delete this criticality option. 

3. Click OK to save the settings and close the dialog box. 

 
 If the criticality list is long, start typing a criticality name in the Find criticality box.  In the data 

window, SmartPlant Instrumentation highlights the required name as you type. 
 After you delete a row, the criticality dissociates from all tags for which it was defined.  The 

criticality option will no longer be available in the Associate Categories dialog box. 
 

Add and Edit Instrument Tag Categories 
This option enables you to edit the name and the description of the available instrument tag 
categories.  Using this option, you can also add new categories which you will be able to 
associate with instrument tags. 
1. Open an Instrument Index Standard Browser view. 
2. Click Actions > Tag Categories. 
3. Click New to add a new tag category row. 
4. Type the desired tag category name and description. 
5. To edit an existing tag category, double-click a field and type the new value. 
6. To delete an existing tag category: 

a. Select a tag category in the data window. 
b. Click Delete to delete the highlighted category. 
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c. When prompted, click Yes to confirm the deletion, or click No to keep the selected 
category. 

7. Click OK to save the changes you made to the tag categories. 
 

Associate Tag Category and Criticality 
1. Open an Instrument Index Standard Browser view. 
2. In the browser view, right-click an instrument, and on the shortcut menu, click Tag Number 

Activities > Associate Categories and Criticality. 
 You must select a single tag (not multiple tags) to associate tag categories and criticality. 

3. To associate the desired categories with the selected tag, do one of the following: 
 Drag a category from the Unassociated Categories pane to the Associated Categories 

pane. 

 Select a category under the Unassociated Categories pane and click . 
 You can associate the selected tag number with as many categories as you desire.  For 

details of how to add new categories, see Add and Edit Instrument Tag Categories (on 
page 103). 

4. From the Criticality list, select a value to associate the current instrument with a criticality 
setting. 

5. Select the Quality System (ISO) check box to associate the currently selected tag with an 
ISO quality system. 

 

Generate a Process Data Sheet in a Browser Window 
Use this option to generate a process data sheet for a selected instrument in an Instrument Index 
Standard Browser view, where a process data sheet was not previously defined for the 
instrument. 
1. In the browser view, select the tag numbers that you require. 
2. Do one of the following: 

 Right-click, and on the shortcut menu, click Generate Process Data Sheet. 
 Click, Actions > Generate Process Data Sheet. 

3. In the Results dialog box, view the process data sheet creation results, and then click Close. 
 

Incorporating Soft Tags Within an Enhanced Loop Drawing 
The Enhanced Report Utility allows you to generate loop drawings for loops that include soft 
tags.  For example, a loop that contains an air-conditioning system with temperature gauges, 
lines, engines, compressors, and so forth.  The temperature gauges send signals to a DCS panel 
and from there to a computer.  A software code that functions as a thermostat, interprets the 
signal and sends a command to start the engine.  The compressor, connected to the engine, 
compresses more gas through the lines to lower the room temperature (closed loop). 
To generate an Enhanced Report Utility drawing that includes a soft tag you need to create a 
symbol representing the tag using the Symbol Editor.  Then you associate the symbol with the tag 
in SmartPlant instrumentation, associate the tag with a loop and generate the appropriate 
drawing. 
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Flow of Activities for Managing Soft Tags 
The following flow of activities allows you to create soft tags their related instrument type, 
associate soft tags with loops, generate a loop drawing in Enhanced Report utility, and edit the 
drawing to display the soft tags properly. 
1. In the Domain Explorer, create a new loop or select an existing one, see Create a New 

Individual Loop Number (on page 71). 
2. In the Symbol Editor create a symbol with a macro.  For details, see Create a Custom Symbol 

and Add a Macro to a Symbol in the Symbol Editor help. You will later associate this symbol 
with a soft tag. 

3. Define a new instrument type for soft tags for example, ST.  For details, see Define 
Instrument Type (see "Define an Instrument Type" on page 83). 

4. Create a new soft tag.  For details, see Create an Instrument in the Domain Explorer (on 
page 90). 

5. Set the new soft tag instrument type to ST.  For details, see Instrument Type Common Tasks. 
6. To associate the custom symbol with the soft tag do one of the following: 

 Associate the custom symbol with the tag instrument type, see Set a Default Custom 
Symbol for Items Associated with an Instrument Type (on page 105). 

 Associate a custom symbol with the specific soft tag. 
7. Set the loop generation method to Custom By Loop or Custom by Signal to allow the 

software to use custom symbols when generating an Enhanced Report Utility drawing, see 
Loop Drawing Generation Method. 

8. Generate an Enhanced Report Utility drawing for this loop, see Generate a Report Using the 
Domain Explorer (see "Generate a Report for an Instrument" on page 542). 

9. In the Enhanced Report Utility environment, press F7 to open the Domain explorer. 
10. Find the loop in the Domain Explorer, see Find an Item in the Domain Explorer (see "Find an 

Item in the Tree View of an Explorer Window" on page 543). 
11. Drag the soft tag from the Domain explorer to the drawing. 

 
 The selected tag can also be from a different loop. 
 The software automatically saves the position of the tag after you place it. 

12. Connect the soft tag to a conventional loop tag, see SmartPlant Instrumentation Enhanced 
Report Utility User's Guide > Attach Redlining to Drawing Items. 

13. Click File > Save Custom Changes. 
 

Set a Default Custom Symbol for Items Associated with an 
Instrument Type 

1. On the Instrument Index module menu bar, click Tables > Instrument Types. 
2. On the Instrument Type dialog box, click Profile. 
3. In the General tab, on the Enhanced Report Utility Symbol group box, in the Symbol file 

name and path data field, type the appropriate symbol path (or browse to find it), and Click 
OK. 
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S E C T I O N  7  

Associating Instrument Tags with Loop Numbers 
This section shows you how to associate instrument tags with loops.  There are several different 
ways that you can associate an instrument tag with a loop.  You can select a particular loop 
number and make a batch instrument tag association or dissociate any tags from the selected 
loop as needed.  Another way is to select an instrument tag and change its loop association if it 
exists.  You can also create a new loop with which you want to associate a selected instrument 
tag and associate it with this loop on the fly. 
 

Associate Multiple Tag Numbers with a Loop 
This option shows you how to select an existing loop number and associate it with the required 
instrument tag.  You make the association using the Associate Tag Number dialog box which 
displays the selected loop numbers and all the tags that are already associated with it.  You can 
also associate numerous instrument tags with the selected loop. 
1. Start the Instrument Index module. 
2. Do one of the following: 

 Click Actions > Associate. 

 Click . 
3. On the Enter Loop Number dialog box, do one of the following: 

 Type the name of the required loop number on the Enter Loop Number data field, and 
click OK. 

 Click Find, to open the Find Loop dialog box.  Search for a desired loop, select it, and 
then click OK. 

4. On the Associate Tag Number dialog box, click Find to open the Find Tag dialog box. 
5. On the Find Tag dialog box, click Find and select the tag numbers that you want to associate 

with the current loop. 
6. Click OK. 
7. On the Associate Tag Number dialog box, under Available tag numbers, select a tag 

number and click Associate.  Repeat this step for every tag number that you want to 
associate with the current loop. 

8. Click OK, to make the association. 
 

Change an Instrument Tag Loop Association in the Domain 
Explorer 

This option shows you how to move a selected instrument tag that is associated with a specific 
loop number to another existing loop number.  You change this association when editing an 
instrument tag. 
1. In the Domain Explorer, expand your current <plant> hierarchy to display the Instruments 

folder. 
2. Double-click the Instruments folder to display the existing tag numbers. 
3. Right-click the required tag, and from the shortcut menu select Properties. 
4. On the Tag Number Properties dialog box, click Associate. 
5. On the Find Loop dialog box, type the required search parameters as needed and click Find. 
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6. Select the loop you require in the Search results data window and click OK. 
7. On the Tag Number Properties dialog box, click OK. 
 

Change Instrument Tag Loop Associations in the Instrument 
Index Standard Browser View 

This option shows you how to move multiple instrument tags that are associated with a specific 
loop number to another existing loop number.  You change this association when editing an 
instrument tag. 
1. To start the Instrument Index module do one of the following: 

 Click . 
 Click Modules > Instrument Index. 

2. Do one of the following: 

 Click . 
 Click Edit > Tag Numbers > Tag Number Properties. 

3. On the Enter Tag Number dialog box, do one of the following: 
 To choose a single tag, type the tag number in the box. 
 To choose multiple tags, click Find to open the Find Tag dialog box, and then click and 

select the desired tags. 
4. Click OK, to open the Tag Number Properties box. 
5. Click Associate. 
6. On the Find Loop dialog box, type the desired search parameters as needed and click Find. 
7. Select the loop you require in the Search results data window and click OK. 
8. If you chose one instrument tag, on the Tag Number Properties dialog box, click OK. 
9. If you chose more than one instrument tag, on the Tag Number Properties dialog box: 

a. Click Apply to save the changes. 
b. Click Next to find the next tag. 
c. Click Associate to associate a tag with a loop. 
d. Click OK to finish. 

 

Associate an Instrument Tag with a New Loop 
This option shows you how to create a new loop number on the fly while editing an instrument 
tag.  You can then move the current instrument tag and associate it with the new loop you 
created. 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Instruments 

folder. 
2. Double-click the Instruments folder to display the existing tag numbers. 
3. Right-click the required tag, and from the shortcut menu select Properties. 
4. On the Tag Number Properties dialog box, click New Loop. 
5. On the New Loop Number dialog box, type the new loop number and click OK. 
6. Edit the properties of the new loop number on the New Loop Number dialog box and click 

OK. 
7. On the Tag Number Properties dialog box, click Associate. 
8. On the Find Loop dialog box, type the required search parameters as needed and click Find. 
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9. Select the loop you have just created in the Search results data window and click OK. 
10. On the Tag Number Properties dialog box, click OK. 
 

Dissociate an Instrument Tag from Loops 
This option shows you how to dissociate instrument tags from a selected loop. 
1. Start the Instrument Index module. 
2. Do one of the following: 

 Click Actions > Associate. 

 Click . 
3. On the Enter Loop Number dialog box, do one of the following: 

 Type the name of the required loop number on the Enter Loop Number data field, and 
click OK. 

 Click Find to open the Find Loop dialog box.  Search for a desired loop, select it, and 
then click OK. 

4. On the Associate Tag Number dialog box, under Associated Tags select the tag number 
you want to dissociate from the current loop. 

5. Click Dissociate.  Repeat steps four and five for every tag number that you want to associate 
with the current loop. 

6. When you have finished, Click OK. 
 

Associate Tag Numbers Dialog Box 
This dialog box enables you to make associations between tags and loops.  You can associate 
existing tags and/or newly created tags with a selected loop number. 
Loop number — Displays the selected loop. 
Available tag numbers — Lists the tags that have been selected for association with the current 
loop.  To add tags to this list, click Find.  Highlight a tag and click Associate.  The software 
makes the association after you click OK. 
Associated tag numbers — Lists the tag numbers that are already associated with the current 
loop. 
Associate — Associates the tags you selected in the Available tag numbers pane.  The 
software moves the selected tags to the Associated tag numbers pane and makes the 
association with the current loop after you click OK. 
Dissociate — Dissociate the tags you selected in the Associated tag numbers pane.  The 
software moves the selected tags to the Available tag numbers pane and dissociates them from 
the current loop after you click OK. 
Find — Open the Find Tag dialog box, where you can find the required tags to be associated with 
the current loop.  The software displays the tags that you find in the Available tag numbers pane 
and makes them available for association. 
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S E C T I O N  8  

Working with Typical Loops and Tags 
A typical loop is a combination of user-defined loop properties that you can use as a template for 
creating loops and tags in batch mode.  These properties include a loop measured variable, loop 
type, loop function and so forth.  This template must contain at least one typical tag. 
A typical tag is a virtual tag that is used for the creation of instrument tag numbers in your 
plant.  Each typical tag must be associated with a specific instrument type and 
description.  Furthermore, you can set instrument tag number properties for a virtual tag.  For 
example, you can define service, location, I/O type, and so forth.  You must define at least one 
typical tag for each typical loop you create. 
You can create as many typical loops as required and use them to create loops in batch 
mode.  Typical loops with associated typical tags can be very useful when you need to create 
numerous loops based on the same loop template. 
You can view all the typical loops you have created in the current domain.  The list of typical loops 
is automatically updated after you create a new typical loop, or if you edit or duplicate existing 
loops. 
 

Create a Typical Loop 
This procedure shows you how to create a new typical loop and the associated tag.  Typical loops 
with associated typical tags can be very useful when you need to create numerous loops based on 
the same loop template. 
Creating a new typical loop is the first stage in batch loop creation procedure.  This is when you 
make all the required typical loop definitions including the typical loop name, measured variable, 
and so forth.  At this stage, you also select the appropriate instrument types for the typical tags 
you associate with this typical loop. 
1. Start the Instrument Index module. 
2. On the Instrument Index menu bar, click Edit > Typical Loop Management. 
3. On the Typical Loop Management dialog box, click New. 
4. On the Typical Loop Properties (New) dialog box, in the Loop name field, type a unique 

name for the new typical loop. 
5. In the Loop service field, type an appropriate loop service if needed. 
6. In the Loop suffix field, type a suffix if required. 

 Use a suffix if you want to have numerous typical loops with the same names.  This is 
useful when you have numerous typical loops that perform the same or similar function. 

7. From the Measured variable list, select the required measured variable for the new typical 

loop.  If the required value is not available, click  next to the list arrow to open the Loop 
Measured Variables dialog box where you can add a new loop process variable identifier or 
edit an existing one. 

8. From the Loop type list, select the required loop type for the new typical loop.  If the required 

value is not available, click  next to the list arrow to open the Loop Types dialog box 
where you can add a new loop type or edit an existing one. 

9. From the Loop function list, select the required loop function for the new typical loop.  If the 

required value is not available, click  next to the list arrow to open the Loop Functions 
dialog box where you can add a new loop function identifier or edit an existing one. 
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10. In the Note field, type a short note if needed. 
11. Select the Apply service to tags check box, to propagate the loop service you entered for 

this typical loop to all typical tags that are associated with it. 
12. Click Add, to append a new typical tag row in the Associated typical tags data window. 
13. In the data window, do the following: 

a. From the Instrument Type list, select the instrument type that you require. 
b. In the Number field, type the required typical tag number. 
c. In the Suffix field, enter the required typical tag suffix to ensure tag name uniqueness. 
d. Click Add, to add as many typical tags as required, and then click OK, to create the typical 

loop with the associated tags. 
 On clicking OK, you are prompted to edit the newly-created typical tag. 

 
 Typical tags do not have any profile data associated with the instrument type that you specify 

for typical tags.  However, if you set your preferences for tag creation to the profile options, 
the SmartPlant Instrumentation creates the new tag numbers based on the instrument type 
profiles defined for the typical tags that are associated with the current typical loop. 

 Make sure that you define the instrument type profiles prior to creating a typical loop. 
 SmartPlant Instrumentation allows you to select instrument types from the Conventional, 

Fieldbus, Hart, Profibus DP, Profibus PA, and Hart tag classes. 
 Ensure that the typical tag naming conventions comply with the required naming convention 

rules.  For more details, see Typical Tag Naming Conventions (on page 117). 
 The New Tag Name field automatically displays the name of the new typical tag after defining 

the typical tag instrument type, number, and suffix. 
 

Duplicate a Typical Loop 
This option enables you to duplicate an existing typical loop. Duplicating a typical loop involves 
defining a new typical loop name and new typical tag names to ensure name uniqueness. 
1. Start the Instrument Index module. 
2. Click Edit > Typical Loop Management. 
3. Select a typical loop to duplicate. 
4. On the Typical Loop Management dialog box, click Duplicate. 

 The changes you make to the source typical loop affect the properties of the target 
typical loop only. 

5. In the Loop name field, type a unique name for the new typical loop. 
6. In the Loop service field, enter an appropriate loop service if required. 
7. In the Loop suffix field, type a suffix if required. 

 Use a suffix if you want to have numerous typical loops with the same names.  This is 
useful when you have numerous typical loops that perform the same or similar function. 

8. From the Measured variable list, select the required measured variable for the new typical 

loop.  If the required value is not available, click  next to the list arrow to open the Loop 
Measured Variables dialog box where you can add a new loop process variable identifier or 
edit an existing one. 

9. From the Loop type list, select the required loop type for the new typical loop.  If the required 

value is not available, click  next to the list arrow to open the Loop Types dialog box 
where you can add a new loop type or edit an existing one. 
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10. From the Loop function list, select the required loop function for the new typical loop.  If the 

required value is not available, click  next to the list arrow to open the Loop Functions 
dialog box where you can add a new loop function identifier or edit an existing one. 

11. In the Note field, type a short note if needed. 
12. Select the Apply service to tags check box, to propagate the loop service you entered for 

this typical loop to all typical tags that are associated with it. 
13. Click Add, to append a new typical tag row in the Associated typical tags data window. 
14. On the data window, do the following: 

a. From the Instrument Type list, select the instrument type that you require.  SmartPlant 
instrumentation retrieves profile data associated with this instrument type and applies this 
data to new tag numbers only when performing batch loop creation.  For more details, 
see Batch Loop Creation from Typical Loops (on page 113). 

b. On the Number field, type the required typical tag number. 
c. On the Suffix field, enter the required typical tag suffix to ensure tag name uniqueness. 
d. Click Add, to add as many typical tags as required, and then click OK, to create the typical 

loop with the associated tags. 
 On clicking OK, you are prompted to edit the newly-created typical tag. 

 
 Ensure that the typical tag naming conventions comply with the required naming convention 

rules.  For more details, see Typical Tag Naming Conventions (on page 117). 
 The New Tag Name field automatically displays the name of the new typical tag after defining 

the typical tag instrument type, number, and suffix. 
 
 

Batch Loop Creation from Typical Loops 
This option shows you how to create numerous loop numbers based on existing typical 
loops.  SmartPlant Instrumentation creates these loop numbers in batch mode.  The software 
also lets you verify that the data you selected and entered will not stop the loop creation 
process.  When creating numerous loop numbers based on existing typical loops, the software 
also creates new tag numbers and associates them with the newly created loops.  The software 
creates these tag numbers according to your settings on the Duplicate page of the Preferences 
dialog box. 
1. Start the Instrument Index module. 
2. Click Edit > Batch Loop Creation. 
3. On the Batch Loop Creation dialog box, select an existing typical loop from the Typical 

Loop list.  SmartPlant Instrumentation will base the new loops on this typical loop. 
4. To find a typical loop from a long list of typical loops, do the following: 

a. Click Find. 
b. In the Find Typical Loop dialog box, enter the required search parameters and click 

Find. 
c. Select the required typical loop in the Search results data window and then click 

OK.  The selected typical loop will automatically appear in the Typical Loop field of the 
Batch Loop Creation dialog box. 
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d. In the New Loop Numbers field, enter the range of numbers for the new loops that will be 
created based on the selected typical loop. 

 
 You can create as many loops based on the selected typical loop as you require.  To 

create more than one loop, simply enter the required new loop number names in the New 
Loop Number field.  You can enter a range of loop names or a list as needed. 

 For noncontiguous alphanumeric or numeric loop numbers, type the loop numbers with 
commas between them.  For a range of numeric loop numbers, type the range of loop 
numbers with a hyphen between them.  For example, to create loops 1000, 1001, 1002, 
1003, 1057, FT10, F11,and F12 type: 1000-1003, 1057, FT10, F11, F12. 

5. Click Add to add a new data row to create another set of loops.  You can add as many sets of 
loops as you require for batch creation. 

 You should verify the correctness of the data if you are creating a large number of 
loops.  The creation process may stop if SmartPlant Instrumentation encounters a problem 
with one of the loops.  To avoid this situation, click Verify to correct some possible data 
problems before you proceed with loop creation.  For more details, see Verify New Loop 
Numbers (on page 114). 

6. Click Create to start the loop creation. 
 If for some reason the loop creation process fails, the software displays an appropriate 

message informing you that a particular set in a specified row has not been 
created.  Moreover, the Done check box for that row remains cleared. 

7. Click Close. 
 To avoid duplicate loop numbers in your <plant>, check which tag number numeric 

segments are available before starting batch loop creation.  For more details, see Create a List of 
Available Tags (on page 134). 
 

Verify New Loop Numbers 
This option shows you how to verify new loop numbers that you want to create from typical loop 
numbers in batch mode, are correct and will not cause problems during their creation. 
When creating numerous loops and tag numbers from typical loops in batch mode, some data 
problems might cut short the creation process.  If, during batch loop creation, SmartPlant 
Instrumentation encounters a data problem with one loop, the creation process cannot proceed 
with the rest of the typical loops.  To avoid this problem, SmartPlant Instrumentation helps you 
verify that you selected and entered data that will not stop the creation process. 
SmartPlant Instrumentation verifies the following: 
 Loop number uniqueness. 
 Loop and instrument naming conventions. 
 Loops and tags reserved for other projects. 

The verification procedure takes much less time than the actual creation; therefore, you should do 
it before you start creating new loops and tag numbers. 
1. In the Batch Loop Creation dialog box, select the required typical loops and enter the new 

loop numbers in the Loop creation set data window.  For more details, see Batch Loop 
Creation from Typical Loops (on page 113). 

2. Click Verify. 
3. If a data problem is encountered, follow the instructions given by the software to correct the 

problem. 
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Edit a Typical Loop 
This option enables you to edit the properties of an existing typical loop.  You can modify the 
existing typical loop properties and associate new typical tags with the current loop. 
1. On the Instrument Index menu bar, click Edit > Typical Loop Management. 
2. On the Typical Loop Management dialog box, select the required typical loop and click 

Properties. 
3. On the Typical Loop Properties dialog box, edit the fields as needed. 

 The Loop name and the Measured variable fields are required fields. 
4. On the Associated typical tags data window, select an existing typical tag that has been 

already associated with the current loop and do one of the following: 
 Click Properties to open the Typical Tag Number Properties dialog box to edit the 

typical tag properties.  For more details, see Edit a Typical Tag (on page 116). 
 Click Delete to delete the selected tag. 

5. Click Add to append a typical tag row in the Associated typical tags data window. 
6. On the data window, do the following: 

a. In the Instrument Type column, select the required instrument type from the list.  The 
selected instrument type serves as a typical tag associated with the current typical loop. 

b. In the Number field, type the required typical tag number. 
c. In the Suffix field, type the required typical tag suffix to ensure tag name uniqueness. 
d. Add as many typical tags as required and click OK to associate the newly added typical 

tags with the current loop. 

 
 Ensure that the typical tag naming conventions comply with the required naming convention 

rules.  For more details, see Typical Tag Naming Conventions (on page 117). 
 The New Tag Name field automatically displays the name of the new typical tag after defining 

the typical tag instrument type, number, and suffix. 
 

Delete a Typical Loop 
This option shows you how to delete the required typical loop with or without the associated typical 
tags. 
1. On the Instrument Index menu bar, click Edit > Typical Loop Management. 
2. On the Typical Loop Management dialog box, select the required typical loop and click 

Delete. 
3. On the Delete Typical Loop dialog box, review the typical loop properties and click Delete. 
4. If prompted, click Yes to delete the typical loop and associated tags.  Click No to delete the 

typical loop only. 
5. On the Typical Loop Management dialog box, click Close. 
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Edit a Typical Tag 
This option shows you how to edit the properties of an existing typical tag, including renaming a 
typical tag if needed.  You might want to edit the properties of the typical tags if you plan to 
perform batch loop creation according to specific tag data you define in the Typical Tag Number 
Properties dialog box.  Depending on your preference options, when creating loops in batch 
mode, the software creates conventional tag numbers using the profile data of the source 
instrument type, or creates typical tags using specific source tag data you define in the Typical 
Tag Number Properties dialog box. 
1. Start the Instrument Index module. 
2. Do one of the following: 

 Click Edit > Tag Numbers > Tag Numbers Properties. 

 Click . 
3. On the Enter Tag Number dialog box, Click Find to open the Find Tag dialog box. 
4. On the Find Tag dialog box, from the Tag class list select Typical, enter the required search 

parameters if needed and click Find. 
5. In the Search results data window, select the typical tag that you want to edit and click OK. 
6. In the Typical Tag Number Properties dialog box, modify the typical tag properties as you 

require. 
7. Click OK. 

 You can also edit a typical tag when editing a typical loop.  For more details, see Edit a 
Typical Loop (on page 115). 
 

Edit a Typical Tag in a Browser View 
Use the following procedure to edit the properties of one or more typical tags in an Instrument 
Index Standard Browser view.  You can select typical tags, edit the properties of each typical tag 
separately and associate these typical tags with other existing typical loops. 
1. Open the Browser Manager by doing one of the following: 

 From an Instrument Index Standard Browser view, click . 

 Click . 
 Click File > Browser Manager. 

2. Select the browser (Instrument Index Standard Browser or a PowerSoft Browser that 
supports tag number data, if available) that has the default view that you want to open. 

3. Select the appropriate browser view. 
4. Click Edit. 
5. On the View profile display, from the Display data at level list, select Typical. 
6. Click Save. 
7. Open the browser view and use the Shift or Ctrl key to select the typical tags that you require. 
8. Do one of the following: 

 Click Edit > Properties. 

 Click . 
 Right-click the selected tag numbers, on the shortcut menu, click Tag Number Activities 

> Properties. 
9. In the Typical Tag Number Properties dialog box, edit the typical tag properties as required. 
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10. Click Apply > Next, to edit the next selected tag. 
11. Click OK. 
 

Typical Tag Naming Conventions 
You can use any naming convention for your typical tags as long as it contains the typical tag 
number segment.  The name segment of a typical tag can be the same length or shorter than the 
name segment of a tag.  You defined tag name segments in the naming conventions for the 
current <unit>. 
The naming conventions for typical tags are as follows: 
 Instrument type — up to 4 characters in the name segment, (the typical tag name segment is 

automatically truncated to 4 characters when the instrument type name contains more than 4 
characters). 

 Typical tag number — up to 8 characters in the typical tag number segment. 
Typical tag suffix — up to 3 characters in the typical tag suffix segment. 
 Example of a typical tag name: FT-FLOW_CTLR/2. 

The naming convention for typical loops is as follows: 
 Typical loop name — up to 50 characters.  When using a loop suffix the maximum loop name 

length is shortened to 48 characters.  The typical loop suffix can contain up to 3 
characters.  In addition, there must be a slash ("/") separator between the number and the 
suffix. 
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S E C T I O N  9  

Managing Lines 
You can create, modify, and delete lines in the Instrument Index module.  The Lines dialog box 
holds all the line data in your <plant>.  Lines are categorized according to line types.  You can 
create new line types and then add new lines to these types as required.  You can also change 
the type of an existing line if needed and copy line data from a selected line to several target lines. 
 

Create a New Line 
This option shows you how to create a new line in the Instrument Index module. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 
3. On the Line type list, select the required line type. 

 If the required line type does not exist, click  next to the Line type list arrow to open 
the Line Types and create a new line type.  For more details, see Create or Edit a Line Type 
(on page 120). 

4. Click New to open the Line Properties dialog box. 
5. Define the line properties as you require and click OK. 
 

Edit Line Data 
This option shows you how to edit the data of an existing line.  Line data comprises such 
properties as the line number, pipe material and standard, line size, its internal diameter, and wall 
thickness. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 
3. From the Line type list, select the required line type or select the Show all line types check 

box. 
4. Select the required line in the data window. 
5. Click Properties to open the Line Properties dialog box. 
6. Define the line properties as you require and click OK. 
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Create or Edit a Line Type 
Line types are used for categorizing the lines in your <plant>.  Each line must belong to a 
particular line type, for example, Process or Utilities.  You can create as many line types as 
required and move the existing lines from one type to another. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 

3. Click  next to the Line type list arrow. 
4. In the Line Type dialog box, click New to append a new data line. 
5. Type the line type name and description in the appropriate fields. 
6. To modify a line type, highlight the required line type and click in the desired field. 

 To quickly find a line type in a long list of line types, type the line type name in the Find Line 
Type box.  SmartPlant Instrumentation will automatically highlight the line type you are looking 
for. 
 

Change Type of Line 
This option shows you how to change the line type of an existing line. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 
3. From the Line type list, select the required line type. 
4. Select the required line in the data window. 
5. Click Change Type. 
6. In the Change Type dialog box, highlight the required line type and click OK. 

 If the required line type does not exist, click Cancel to close the Change Type dialog box, 

then click  next to the Line type list arrow, to create or modify a line type.  For more details, 
see Create or Edit a Line Type (on page 120). 
 

Copy Line Data 
You use this option to copy line process data from a selected line to one or more target lines. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 
3. From the Line type list, select the required line type. 
4. Select the source line from which you want to copy process data. 
5. Click Copy Line. 
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6. On the Copy Line Data dialog box, from the Line Type list, select the required line type of the 
target line. 

7. In the Target lines data window, highlight the target lines to which you want to copy the 
source line data. 

 You can use the filter facility to display only the required lines in the Target lines data 
window. 

8. Click OK to start the copying process. 
 You can also copy line process data while working in the Process Data module.  The 

Process Data module allows you to select a source line in the Copy Line Data dialog box different 
from the one you highlighted in the Lines dialog box. 
 

Delete a Line 
This option shows you how to delete a line that is no longer in use.  Note that you cannot delete a 
line that is associated with a tag number. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 
3. From the Line type list, select the required line type or select the Show all line types check 

box. 
4. Highlight the required line in the data window. 
5. Click Delete. 
 

Define or Modify Pipe Specifications 
Pipe spec is a specification that defines various process conditions for a specific pipe.  You use 
this procedure to define a pipe spec to the Pipe Specs supporting table from the Instrument Index 
module, or to modify properties of an existing pipe spec. 
1. Start the Instrument Index module. 
2. To open the Lines dialog box, do one of the following: 

 Click Tables > Lines. 

 Open the Tag Number Properties dialog box, click  next to the Line list arrow. 

3. On the Lines dialog box, under Line type, select a line type, or click  to create a new line 
type. 

4. Click New to open the Line Properties (New) dialog box. 

5. Beside the Pipe spec list, click  to open the Pipe Specs dialog box. 
6. Do one of the following: 

 To create a new pipe spec, click New and type entries in the Pipe Spec and Description 
boxes. 

 To edit an existing pipe spec, click a field in a highlighted row and modify the existing entry 
as needed. 

 
  



Instrument Index Module 
 

 
122 SmartPlant Instrumentation Basic Engineering User's Guide 

 

 



 

 

SmartPlant Instrumentation Basic Engineering User's Guide 123 
 

S E C T I O N  1 0  

Editing and Viewing Data in a Browser View 
You can edit the data fields in a browser view by either selecting one row or by selecting multiple 
rows.  The single- edit mode is useful when you need to edit one row or a few rows.  The 
multi-edit mode is a more powerful tool.  In addition to being able to edit multiple rows, you can 
also carry out certain editing operations that are not available in the single-edit mode. 
You can view, organize, and edit your instrument index data by opening an Instrument Index 
Standard Browser view in the Browser module.  You can also add a PowerSoft browser that 
supports the display of tag data and define a view for it to use with the Instrument Index module. 
In the selected browser view, you can access numerous commands to manage your instrument 
index data.  You can edit the tag number properties in the multi-edit or single-edit mode, create 
new loop and tag numbers, associate an instrument with a tag category, associate and open 
external documents, generate process data sheets and specifications for tags, and so forth. 
 

Define a Standard Browser View for the Instrument Index 
This procedure shows you how to create and define a designated custom browser view in the 
Instrument Index Standard Browser.  When you view and edit tags from the Instrument Index 
browser using a browser view the Browse command opens this designated custom browser. 
1. Open the Browser Manager by doing one of the following: 

 From an existing Instrument Index Standard Browser view, click . 

 On the main SmartPlant Instrumentation tool bar, click . 
 Click File > Browser Manager. 

2. On the Browser Manager, on the Browser groups pane, expand the hierarchy Instrument 
Index > Instrument Index Standard Browser. 

3. Do one of the following: 
 Open an existing view for this browser. 

 Click . 
 Right-click and on the shortcut menu click Add View. 

4. On the View profile pane, select Set as default view and Set as Instrument Index browse 
view (per user) boxes. 

5. Click Save. 
6. Expand the Instrument Index Standard view. 
7. Click Style, and on the Style pane click Edit. 
8. Select the fields you want to see in the browser and click Save. 
9. Right-click Instrument Index Standard Browser, and on the shortcut menu, click Set as 

Default. 
10. Close the Browser Manager. 
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Edit a Single Row 
This option shows you how single-row editing allows you to modify the data for one tag number at 
a time from a browser view.  You edit the data by typing or selecting values from the available 
lists.  You can also use the buffer to copy data from one row and then paste in multiple rows as 
needed. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Highlight the required tag number. 
3. Click in a required field to edit the data, and do one of the following: 

 Type over the displayed value. 
 Select an item from a list.  If the item you need is not on the list you just opened or if it is a 

long list and you need to scroll down to find your value, click  to open the appropriate 
supporting table where you can find the required item on the fly.  For more details, see 
Open a Specific Supporting Table (on page 124). 

4. Press Tab to move to the next field. 

 
 Fields that hold tag number data ( Name, Prefix, Number, and Suffix) cannot be edited. 
 Changes you make to a record are automatically saved to the database when you proceed to 

another record or when you close the browser view. 
 

Open a Specific Supporting Table 
This option shows you how to open the supporting table dialog box for an active column in an 
Instrument Index Standard Browser view.  There are two main uses of this feature: 

 Adding, editing, duplicating or deleting items in a supporting table.  For more details, see 
Supporting Tables: Overview (see "Supporting Tables" on page 34). 

 Finding a select list item in an active column of the browser view on the fly.  This option is 
especially useful when you have a long list of items in a select list and you need to scroll 
up or down to find the item you need.  Opening a supporting table for that select list 
enables you to quickly find the required item which will automatically be selected for you 
after closing the supporting table dialog box. 

1. Open an Instrument Index Standard Browser view by doing one of the following: 
 Click Actions > Browse Index. 

 Click . 
2. Highlight a tag number row. 
3. Click a specific supporting table cell in the highlighted row and do one of the following: 

 Click Actions > Open Supporting Table. 

 Click . 
4. In the supporting table dialog box that opens, type the item you are looking for in the Find box. 

 
 Clicking OK closes the supporting table and displays the selected item in the list 
 If the item you are looking for does not exist in the supporting table, click New and add an 

item.  Clicking OK after adding the new item automatically selects this item in the active select 
list in the browser view. 
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Find a Record in a Browser View Column 
This option shows you how to search the displayed instrument index data for a specific 
record.  You can search for any record that exists in any of the browser view columns.  For 
example, you can find a specific tag number, an instrument type, or an I/O type, and so forth.  The 
following search options are available: 

 Find a record by entering the whole value, for example, 101-FV 100 (the full tag number 
name) or CONTROL VALVE (the full instrument type value). 

 Find a record by entering a string which is a part of a value, for example, FV (or just V) or 
CONTROL VALVE (the full instrument type value). 

 Search for a record as you type in the value. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Click a column header to select the column you want to search.  Note that all the fields in the 

column become highlighted. 
3. Do one of the following: 

 Click Edit > Find. 

 Click . 
4. Select Case sensitive if you want to distinguish between uppercase and lowercase 

characters.  When selected, SmartPlant Instrumentation finds only those instances in which 
capitalization matches the text you typed in the data field. 

5. Select the required Match option: 
 Whole value — searches for occurrences that are whole values and not part of a larger 

value. 
 String — searches for a particular string that you type in the data field. 
 As typed — searches for a value as you type it in the data field. 

6. Click Find. 
7. Click Find again to find the next occurrence. 
8. Close the Find dialog box when done. 
 

Sort Tag Rows in a Browser View 
This option show you how to sort the tag number rows in an Instrument Index Standard Browser 
view by a selected column for the current work session.  You can set a default sorting sequence 
for the browser view that takes effect every time you open the browser view.  You use the 
following procedure to override the default sorting sequence for the current session.  After closing 
the browser view, the sorting sequence you set now will be lost and the default one will be applied 
when you reopen the browser view.  You can sort the rows in ascending or descending order as 
needed. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Double-click the column header by which you want to sort the tag numbers. 

 The first time you double-click a header, the software sorts the data in ascending order – 
an arrow pointing down appears next to the header. 
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3. To sort the data in descending order, double-click the same header again.  An arrow pointing 
up appears next to the header according to which the data is sorted. 

 After closing the browser view, the sorting sequence you set now will be lost and the default 
one will be applied when you reopen the browser view. 
 

Edit Instrument Tag Data in Multi-Row Mode 
This option shows you how to use the multi-row mode to select several rows of tag number data 
that you can edit.  You select the required tag numbers by highlighting multiple tag rows in the 
browser view.  The editing is done in the Tag Number Properties dialog box, from which you 
also have access to the appropriate supporting tables if you need to update the available options 
in the lists. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Select the desired tag numbers using the Shift and Ctrl keys. 
3. Do one of the following: 

 Click Edit > Properties. 

 Click . 
 Right-click the selected tag numbers, and then on the shortcut menu, click Tag Number 

Activities >Properties. 
4. In the Tag Number Properties dialog box, edit the data for each tag as you require.  You can 

also do the following: 
 Click New Loop to create a new loop number and then associate it with the current tag 

number. 
 Click New to create a new tag number. 

5. When you have edited data for a particular tag number, click Apply. 
6. Click Next or Previous to move from one tag number to another. 
 

Count Instrument Tag Rows in a Browser View 
This option shows you how to count the total number of tag number rows currently displayed in an 
Instrument Index Standard Browser view, where each tag number row represents one record in 
the database.  When selecting several tag number rows, you can count both the total and the 
selected number of records.  Also, when the list of records is long, you can count the total number 
of tag number rows before the software finishes retrieving the records from the database. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 On the Instrument Index menu bar, click Actions > Browse Index. 

 Click . 
2. Select as many tag number rows as required. 
3. Do one of the following: 

 Right-click the highlighted row or rows, and on the shortcut menu, click Count Records. 
 Click Actions > Count Records. 

 Click . 
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View Point-to-Point Wiring Diagrams 
This option shows you how with a tag that contains wiring information, you can open the 
point-to-point wiring diagram directly from an Instrument Index Standard Browser view. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Do one of the following: 

 Click Actions > Documents. 

 Click . 
3. In the Documents pop-up window, select Tag Signal Diagram. 
 

View Data History in a Browser View 
SmartPlant Instrumentation can indicate changes to the data currently displayed in an Instrument 
Index Standard Browser view with the data stored in the audit trail repository for the date range 
that you specify.  You can choose any or all of the following modes of emphasis: 
 Set a color to emphasize changes on the screen. 
 Set a shade of gray to emphasize the changed data in printed reports and their previews. 
 Set bold and italic font style for emphasis on the screen and in print. 

History indication is available only if the System Administrator has activated the audit trail 
functionality.  When the audit trail functionality is activated, each time that you save data after 
making changes, the data is recorded in the audit trial repository. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. On the menu bar, click Options > History Options. 
3. Select the date range for data history comparison, by doing one of the following: 

 In the From and To data fields, type the appropriate dates.  To set the To data field value 
as today's date, click Today. 

 Select the appropriate dates using the spinners. 
4. To set a font style to emphasize changes on the screen and in print, do one or both of the 

following: 
 Select Bold. 
 Select Italic. 

5. To change the color used to display changes on the screen: 

a. Beside the Highlight color for display box, click . 
b. In the Color dialog box, choose the color that you require. 
c. Click OK to save your new color settings and return to the History Options dialog box. 

6. To change the shade of gray used to emphasize the changed data in printed reports and their 
previews: 

a. Beside the Grayscale for printing box, click . 
b. In the Grayscale dialog box, slide the bar to the required position. 
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c. Click OK to save your new grayscale settings and return to the History Options dialog 
box. 

7. Click OK to save your current history options and close the History Options dialog box. 
8. On the menu bar, click; Options> Mark Changes to mark changes in the data currently 

displayed in the browser view for the dates that you specified in the History Options dialog 
box. 

 To clear all history indications in the browser view, cancel the Mark Changes selection on 
the Options menu. 
 

Set a Date Range for Field Value Changes 
This option shows you how to define a period within which you can track changes made to a 
specific value in an Instrument Index Standard Browser view. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Click Options > Date Range for Changes. 
3. In the From field, select or enter the date from where you want to start displaying the changes 

using the DD/MM/YYYY format. 
4. In the To field, select or enter the date until where you want to display the changes using the 

DD/MM/YYYY format.  Click Today to display the current date in the To field. 
5. Click OK to accept your settings and close the dialog box. 
 

Track Field Value Changes 
This option shows you how you can view the changes you have made to a value in any field, in an 
Instrument Index Standard Browser view.  Each field can display one specific instrumentation 
value.  You can view both the new and the old values, and generate a report that displays these 
changes. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Select the tag numbers that you require. 
3. Right-click, and from the shortcut menu, select Field Value Changes. 
4. Click Print to generate and print out a value changes report. 

 
 To shorten the period within which you want to track field changes, set a date range. 
 The system records field value changes in the audit trail repository.  Before using this option 

on Sybase Adaptive Server Anywhere, make a revision in the Document Binder module to add 
records to the audit trail repository.  This operation is required because on Sybase Adaptive 
Server Anywhere, if you want to track field value changes, the audit trail repository must not be 
empty. 

 Under Previous values in the Field Value Changes dialog box, for the value you have 
selected in the browser view, you can view the previous values, the date of the value change, 
the user name of the user who changed the value, and the change status. 
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Open a Process Data Sheet from the Browser Window 
This option shows you how you can quickly access a process data sheet from the Browser 
window.  You can open an existing process data sheet directly from an Instrument Index 
Standard Browser view and then perform the appropriate action in the module that opens. 
1. On the main SmartPlant Instrumentation menu, click File > Preferences. 
2. In the tree view pane, click  beside Process Data to expand the tree. 
3. Click General. 
4. In the Browser view options group box, select Always from the Open process data sheet 

list. 
5. Click OK to close the Preferences dialog box. 
6. In an Instrument Index Standard Browser view, select the instrument tags you require and 

click  on the main toolbar to access the process data sheets. 
 

Open a Specification Sheet from the Browser Window 
This option shows you how you can quickly access specifications for selected instruments from 
the Browser window.  You can open an existing specification directly from an Instrument Index 
Standard Browser view and then perform the appropriate action in the module that opens. 
1. On the main SmartPlant Instrumentation menu, click File > Preferences. 
2. In the tree view pane, click  beside Specifications to expand the tree. 
3. Click General. 
4. In the Browser view options group box, select Always from the Open specification sheet 

list. 
5. Click OK to close the Preferences dialog box. 
6. In an Instrument Index Standard Browser view, select the instrument tags you require and 

click  on the main toolbar to access the specification sheets. 
 

Open a Calculation Sheet from the Browser Window 
This option shows you how you can quickly access a calculation sheet from the Browser 
window.  You can open an existing calculation sheet directly from an Instrument Index Standard 
Browser view and then perform the appropriate action in the module that opens. 
1. On the main SmartPlant Instrumentation menu, click File > Preferences. 
2. In the tree view pane, click  beside Calculation to expand the tree. 
3. Click General. 
4. In the Browser view options group box, select Always from the Open calculation sheet 

list. 
5. Click OK to close the Preferences dialog box. 
6. In an Instrument Index Standard Browser view, select the instrument tags you require and 

click  on the main toolbar to access the calculation sheets. 
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Display Existing Wiring Connections 
This option shows you how to display existing wiring connections for selected instrument tags in 
an Instrument Index Standard Browser view, where you can then modify them if required. 
1. On the Instrument Index Browser view, highlight the tags you require. 
2. Right-click the highlighted tags and on the shortcut menu click Device Panel Connection. 
 

Open I/O Assignment from a Browser View 
This option shows you how to access the I/O Assignment window for an instrument you selected 
in the Instrument Index Standard Browser view.  This way you can implement the input/output 
assignment for the selected tags on the fly, by- passing the Wiring Module window. 
1. On the Instrument Index Browser view, highlight the tag you require. 
2. Right-click the highlighted tag and on the shortcut menu click I/O Assignment. 
 

Change the Process Function and Instrument Type in Batch 
Mode 

It is possible to change the process function and the instrument type of multiple tag numbers in 
batch mode.  You can choose whether to change both the process function and the instrument 
type or only the instrument type. 
1. On an Instrument Index Standard Browser view, select the required tag numbers. 
2. Right-click the selected tag numbers and on the shortcut menu, click Tag Number Activities 

> Change Instrument Type. 
3. In the Select New Process Function and Instrument Type dialog box, do one of the 

following: 
 To change both the process function and the instrument type in batch mode, from the 

Process function list, select the required process function, and on the data window 
highlight the required instrument type. 

 To change only the instrument type in batch mode, on the data window, select a different 
instrument type. 

4. Click OK. 
 When changing the process function, clicking OK opens the Tag Number Renaming 

Options dialog box; when changing the instrument type only, clicking OK completes the 
procedure. 

5. On the Tag Number Renaming Options dialog box, do one of the following: 
 Select the Keep general process data option to delete only process data that is specific 

for each tag number. 
 Select the Delete process data option to delete all the process data associated with the 

tag numbers. 
6. Select Change all so that SmartPlant Instrumentation does not prompt you to change the 

process function and the instrument type for each tag number. 
 Before clicking OK, note that all the wiring items that were associated with the old CS tag 

will be renamed according to the new control system tag name, and all the specifications 
associated with the tags will be deleted.  Verify that the appropriate loop blocks and hook-ups 
are associated with the new tag number. 
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7. Click OK when done. 

 
 If among the tags whose process function and instrument type you are changing there are 

control system tags, SmartPlant Instrumentation reopens the Tag Number Renaming 
Options dialog box, so that you can rename the CS tags if you want to. 

 To find and select the instrument type that you require quickly, start typing in the Find 
instrument type field, and the software highlights the record in the data window as you 
type.  If the instrument type is not available, you can create a new one.  For more details, see 
Working with Instrument Types. 
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Generating Documents 
SmartPlant Instrumentation enables you to generate various reports and documentation to help 
you keep track of your <<plant>> and the items in it.  For example, the Loop Summary report, 
gives you an exact picture of all the loop numbers in use within your <<plant>>,  including those 
that do not have instrument tags associated with them.  All the reports are easily accessible from 
the Standard Index Browser and include: 
 Specification sheets 
 Process Data sheets 
 Drawing and Revision reports 
 Available tag lists 
 Loop Summary 

 

Generate a Specification Sheet for an Instrument 
This option shows you how to generate specifications for the instruments you select in an 
Instrument Index Standard Browser view.  This option is useful when you need to create a 
specification for a tag number for which a specification profile was defined after the tag number 
had been created.  Note that this option is applicable only to instruments for which you have not 
generated specifications yet and if the tag has a specification data profile. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Select the required tag numbers and do one of the following: 

 Click Actions > Apply Profile > Generate a Specification Sheet. 
 Right-click the selected tag numbers and on the shortcut menu click Apply Profile > 

Generate a Specification Sheet. 
3. In the Results dialog box, take note of the generation results and then click Close. 
4. Access the new specification sheet by doing one of the following: 

 Select the required tag numbers in the browser view and click . 
 Select the required tag numbers in the browser view, click Actions > Documents. 

 

Generate a Process Data Sheet for an Instrument 
This option shows you how to generate process data sheets for the instruments you select in an 
Instrument Index Standard Browser view.  This option is useful when you need to create a 
process sheet for a tag number for which a process data profile was defined after the tag number 
had been created.  Note that this option is applicable only to instruments for which no process 
data sheets have been generated yet, and has an appropriate instrument type. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Select the required tag numbers and do one of the following: 

 Click Actions > Generate a Process Data Sheet. 
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 Right-click the selected tag numbers and on the shortcut menu click Generate a Process 
Data Sheet. 

3. In the Results dialog box, take note of the generation results and then click Close. 
4. Access the new specification sheet by doing one of the following: 

 Select the required tag numbers in the browser view and click . 
 Select the required tag numbers in the browser view, click Actions > Documents. 

 

Generate a Drawing and Revision Report 
This option shows you how to view and print out a report listing the drawings (documents) and the 
drawing revision data for the tag numbers currently displayed in an Instrument Index Standard 
Browser view.  The report displays all the appropriate tags according to the filtering and sorting 
conditions that you defined for the browser view. You can display any of the following drawings: 
 Specification 
 Process data sheet 
 Calculation sheet 
 Loop drawing 
 Hook-up drawing 
 P&ID drawing 

You can also display revision data for all of the above drawings, except P&ID drawings. 
1. Open an Instrument Index Standard Browser view by doing one of the following: 

 Click Actions > Browse Index. 

 Click . 
2. Click Actions > Drawing Report. 
3. In the Select Drawings and Revisions dialog box, do one of the following: 

 Under Drawings, select the check boxes beside the drawings you want to include in the 
drawing report or check the Select all drawings check box. 

 Under Revisions, select the check boxes beside the revisions you want to include in the 
report or check the Select all revisions check box.  

4. Click OK to generate the report. 
 If revisions are available they can only be selected after the appropriate drawings have 

been selected. 
 

Create a List of Available Tags 
This option shows you how to generate a report that lists all the available numeric segments of tag 
numbers in the current <unit> or <plant>. 
1. On the Instrument Index Module window, click Reports > Available Tag Numeric 

Segments. 
2. On the Generate Available Tags List dialog box, do the following to set your report criteria: 
3. In the Numeric segment range group box, type the range of numbers that will be included in 

the report. 
4. Select Current <unit> or <plant> to specify the plant hierarchy level for the tag numbers that 

will be included in the report. 
5. For one process function, in the Process function selection group box, select Process 

function and then the required process function from the list. 
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6. For all the existing process functions, select the Select all option.  You can also select the 
Include process functions with available numbers check box if you want to include the 
process functions available with the loop numbers numeric segments. 

7. If the domain type is Owner operator, select the Exclude tag number ranges reserved for 
other projects check box to compare the numeric tag number segments of your project 
against those of other projects, and exclude those numeric tag number segments that have 
been reserved in other projects. 

8. Click OK. 
 

Generate Loop Summary Reports 
This option shows you to how generate a summary report of the existing loop numbers in the 
current <unit> or in all the <units> in the <plant>. You can generate the following summary reports: 

 Summary of all loop numbers. 
 Summary of loop numbers with no associated tags. 

1. On the Instrument Index Module window, click Reports > Loop Summary. 
2. In the Report Selection Options dialog box, do one of the following: 

 Select Current <unit>, so that you can generate a loop summary report of the loop 
numbers in the <unit> you are working. 

 Select Current <plant>, so that you can generate a loop summary report of the existing 
loop numbers in all the <units> in the current <area>. 

 Select All <units> in the <plant>, so that you can generate a loop summary report of the 
existing loop numbers in all the <units> in the current <plant>. 

3. Click OK. 
4. In the Loop Selection dialog box, do one of the following: 

 Select All loops to generate the Summary of All Loop Numbers report. 
 Select Loops with no associated tags to generate Summary of Loop Numbers with no 

Associated Tags report. 
5. Click OK. 
6. When prompted select Yes to preview the report before printing, select No to print the report 

without previewing first. 
 

Generate Custom Table Reports 
This option shows you how to generate a report that displays the values used in one or more 
custom tables.  Custom tables hold user-defined information for instrument tags.  You can only 
use custom tables after the Domain Administrator creates the custom tables and names them as 
appropriate. 
1. On the Instrument Index Module window, click Reports > Tables > Custom Tables. 
2. On the Select Custom Tables for Report dialog box,  select a check box from the Include 

column, beside every custom table that you want to include in the report. 
 Select the Include all check box, to include all of the available custom tables into the report. 
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Working with External Documents 
External documents, that are associated with instrument tags, serve as an additional document for 
the storage of information that cannot be directly entered into SmartPlant Instrumentation.  These 
documents can be viewed and modified from SmartPlant Instrumentation.  Each document can 
be associated with a number of Instrument tags and can be in any format supported by your 
Windows environment, such as .doc, .txt, .bmp, .wav, and so forth. 
 

Associate an External Document with Instrument Tags 
This option shows you how to associate an external document to existing instrument tags. 
1. Open an Instrument Index Standard Browser view. 
2. Highlight the instrument tags you want to associate with an external file. 
3. Click Actions > Associate Documents. 
4. On the Associated Documents dialog box, click Associate. 
5. On the Associate External Document dialog box, navigate to the required file and click 

Open. 
6. Click the Description field and type a brief description as needed. 
7. Click OK. 
 

Open an External Document Associated with an Instrument 
Tag 

This option shows you how to open an external file associated with an instrument.  You can do 
this on the fly while associating files with an instrument.  SmartPlant Instrumentation starts the 
appropriate application that is associated with the file you want to open. 
1. Open an Instrument Index Standard Browser view. 
2. Highlight the required tag numbers. 
3. Click Actions > Associate Documents. 
4. On the Associated Documents dialog box, highlight the file you want to open. 
5. Do one of the following: 

 Click Open. 
 Double click the highlighted file. 
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Dissociate an External Document from an Instrument Tag 
This option shows you how to dissociate an external document from the instrument tags. 
1. Open an Instrument Index Standard Browser view. 
2. Highlight the required instrument tags. 
3. Click Actions > Associate Documents. 
4. On the Associated Documents dialog box, highlight the external file you want to dissociate. 
5. Click OK. 
 

View Associated Documents 
Tag numbers in SmartPlant Instrumentation are associated with various documents whether 
these are documents generated by the software or external documents that can be opened with 
another application.  SmartPlant Instrumentation displays the type of document that is associated 
with a selected tag number in the Documents pop-up window from which you can open the 
appropriate document on the fly. 
Using this option, you can view the following documents associated with a tag number: 

 Various reports generated in other modules: Specifications, Process Data, Calculation, 
and so forth. 

 Enhanced SmartLoop drawings. 
 Loop drawings generated using your CAD application (SmartSketch, AutoCAD or 

MicroStation). 
 Hook-Up drawings. 
 External documents created using other applications. 

1. Open an Instrument Index Standard Browser view. 
2. Select the required tag numbers and then do one of the following: 

 Click Actions > Documents. 

 Click . 
3. On the Documents pop-up window, click one of the available options to display the print 

preview of the available documents.  The disabled options represent unavailable document 
types. 

4. To view external documents, on the Documents pop-up window: 
a. Click Other. 
b. On the Associated Documents dialog box, select a document. 
c. Click Open. 

5. To view associated CAD drawings, on the Documents pop-up window: 
a. Click CAD Loop Drawings. 
b. On the View Drawing File pop-up window, open the CAD drawing. 

6. To view associated hook-up drawings, on the Documents pop-up window: 
a. Click Hook-Up Drawing. 
b. On the Associated Hook-Up Drawings dialog box, select the required drawing. 
c. Click View. 

 You can generate a report showing all the tags in the browser view and their related 
documents.  To generate a report, click Actions > Related Documents Report. 
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The Process Data module enables you to efficiently define process conditions for a particular 
instrument or line.  These process conditions then become the reference point for the 
system.  Process data for instruments relates to seven process functions: Flow, Temperature, 
Pressure, Level, Analyzer, Control Valve, and Relief Valve.  The data - including the process units 
of measure - can be modified at any time when desired. 
Batch creation of process data sheets can be done by adapting existing instruments and lines 
using an interface that allows process characteristics to be simultaneously assigned to several 
instrument groups, thus ensuring system-wide integrity. 
The Process Data module shares data with loop components that are associated with a given 
process.  Data is also shared with the Specifications, Calculations, and Instrument Index 
modules, allowing all the data from these modules to be incorporated into generated reports. 
 

Process Data Principles 
SmartPlant Instrumentation enables you to store and manage process data for lines and 
instruments. 
To view process data for instruments, enter the tag number directly when prompted, or use the 
search parameters.  To view line process data, select a line on the Select Line dialog box. 
If instruments or lines have none or partial process data attached, you can do either enter new 
data or modify existing data, including automatic conversion of units as desired. 

 
 When the Workflow option is activated, only instrument tags with status Process Data 

Required are visible in process data sheets.  For details regarding workflow implementation, 
see Workflow (on page 54). 

 Saving process data modifications makes them accessible to other modules.  When you 
generate a report that includes process data, you can set SmartPlant Instrumentation to 
prompt you that the relevant process data has been changed. 

 You cannot generate process data sheets for virtual tags. 

See Also 
Adding a New Line Type (see "Add a Line Type" on page 147) 
Modifying Line Properties (see "Modify Line Properties" on page 150) 
 

Process Data Module 
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Working With Instrument Tags in the Process Data 
Module 

These procedures explain how work with instrument tags in the Process Data module.  Although 
you usually create tags in the Instrument Index module, the ability to create tags in the Process 
Data module allows for efficient creation of complex analyzers, for example, stream and 
component tags. 
 

Create an Instrument Tag in the Process Data Module 
This procedure explains how to create an instrument tag in the Process Data module.  Although 
you usually create tags in the Instrument Index module, the ability to create tags in the Process 
Data module allows for efficient creation of complex analyzers, for example, stream and 
component tags. 

1. In the Process Data window, on the module toolbar, click Instrument . 
2. In the Enter Tag Number dialog box, type the name of the new tag number, and click OK. 
3. If the Select Instrument Type dialog box opens (because there is more than one record for a 

given instrument type acronym), select the desired instrument type and click OK. 
4. In the Loop Name dialog box, do one of the following: 

 Accept the displayed loop number and click OK. 
 Type the loop number that you need and click OK. 
 To create the tag number without a loop association, click Cancel. 

5. In the Tag Number Properties dialog box, on the General tab, enter the appropriate values. 

 
 If you are creating a complex analyzer, do NOT at this point select a line from the Line list. 
 For details of how to enter power supply properties, see Enter Power Supply Data for 

Panels and Instrument Tags (on page 94). 
6. Click OK. 
 
 

Open an Instrument Tag in the Process Data Module 
This procedure explains how to open an instrument tag in the Process Data module.  Although 
you usually create tags in the Instrument Index module, the ability to create tags in the Process 
Data module allows for efficient creation of complex analyzers, for example, stream and 
component tags. 

1. On the module toolbar, click Instrument . 
2. In the Enter Tag Number dialog box, do one of the following: 

 Type the desired tag number. 
 Click Find to open the Find Tag dialog box and find a desired tag number. 

3. Click OK. 
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Define Basic Process Data for an Instrument Tag 
This procedure explains how to define basic process data for an instrument tag in the Process 
Data module.  Although you usually create tags in the Instrument Index module, the ability to 
create tags in the Process Data module allows for efficient creation of complex analyzers, for 
example, stream and component tags. 
1. Do one of the following to open a tag in the Process Data module: 

 Create a tag. 
 Open a tag that you created previously. 

2. In the Process Data dialog box, do the following: 
a. Select a fluid state. 

 If you select N/A or Other, all fields under the General, Properties, Additional 
Properties and Base Conditions will open for editing, other than Fluid phase and Fluid 
name source, which will be disabled. 

b. If you are creating an analyzer, do one of the following from the Analyzer type list: 
 To create a simple analyzer, select Simple. 
 To create a complex analyzer, select Complex. 

c. Click OK. 
 Simple analyzers belong to the Conventional Tag Class. 

3. If the Complex Analyzer Tag Manager dialog box opens, define the complex analyzer.  For 
details, see Defining a Complex Analyzer (see "Define a Complex Analyzer" on page 165). 

4. In the process data sheet for the tag that you opened, under Line number, select the line 
number to which the tag is connected. 

 
 If you confirm the prompt to copy the line data, all relevant line properties and data are 

copied to the tag process data sheet that you are editing. 
 If you selected a line that you configured for a complex analyzer, SmartPlant 

Instrumentation copies the data from the Line Component table for that line into the 
ANALYZER / COMPONENT PROPERTIES section of the data sheet. 

5. Enter the remaining process data as needed. 
6. If you are defining a complex analyzer, link analyzer stream component tags with line 

components, see Linking Analyzer Stream Components with Line Components (see "Link 
Analyzer Stream Components with Line Components" on page 166). 

7. If you are defining a simple or a complex analyzer, in the ANALYZER COMPONENT / 
PROPERTY section, enter values and units of measure in the Repeatability, Accuracy, 
Minimum detection limit, and Range fields as needed. 

8. On the module toolbar, click . 
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Edit Instrument Process Data 
This procedure explains how to edit the process data associated with an instrument tag.  You can 
edit instrument process data from the Process Data module or from the Calculation module. 
1. Open the process data sheet for an instrument tag from the Process Data module or the 

Calculation module. 
2. In the Process Data window, modify the process data values as desired. 

 
 If you are creating a multi- case tag, you can enter values for each case that you create 

(for details, see Multiple Process Data Cases (on page 153)). 
 If the Domain Administrator enabled the use of process data custom fields, the above 

sections can display such fields. 

3. On the module toolbar, click  to save the values. 
 If you select N/A or Other, all fields under the General, Properties, Additional 

Properties and Base Conditions will open for editing, other than Fluid phase and Fluid name 
source, which will be disabled. 
 

Modify Instrument Base Conditions 
Use this procedure to modify base condition values when entering data for Control Valve, Relief 
Valve, or Flowmeter calculations, from the Process Data or Calculation modules. 
1. Open the process data sheet for an instrument tag from the Process Data module or the 

Calculation module. 
2. Scroll to the BASE CONDITIONS section. 
3. Select a base pressure unit of measure, and beside Pressure type the base pressure. 
4. Select a temperature scale, and beside Temperature, type the base temperature. 
5. According to the state that you selected under Fluid, select the desired basic property as 

follows: 
a. If the state is solid/powder, do one of the following: 

 Select Density @base, select a unit of measure, and type the density value. 
 Select Specific Gravity @base, and type the specific gravity value. 

b. If the state is liquid, do one of the following: 
 Select Density @base, select a unit of measure, and type the density value. 
 Select Specific Gravity @base, and type the specific gravity value. 

c. If the state is water, do one of the following: 
 Select Density @base, select a unit of measure, and type the density value. 
 Select Specific Gravity @base, and type the specific gravity value. 

d. If the state is gas/vapor, do one of the following: 
 Select Density @base, select a unit of measure, and type the density value. 
 Select Compressibility @base, and type the compressibility value. 

e. If the state is steam, beside Compressibility @base, type the desired value. 

6. To save your changes, on the module toolbar, click . 
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Copy Instrument Process Data from Another Instrument 
This option allows you to copy instrument process data from any existing instrument to the 
currently selected instrument. 
1. Open the target process data sheet. 
2. In the Process Data window, on the Edit menu, point to Copy and click From Instrument. 
3. In the Enter Tag Number dialog box, do one of the following: 

 In the text box, type the source tag number. 
 To search for the source tag, click Find. 

 You can only copy data from a tag number of the same instrument type. 

 
 Downstream data (if defined) is not copied. 
 You cannot copy data from an analyzer tag. 

4. To select a source case other than the governing case, do the following: 
a. Click Change. 
b. In the Select Case dialog box, from the Available cases list, select the source case. 
c. Click OK. 

5. In the Enter Tag Number dialog box, click OK. 
 

Propagating Line Process Data to an Instrument Tag 
These procedures allow you to propagate relevant process data from a line to the current 
tag.  Before you perform either of these procedures, you can set a filter that limits the fields that 
you propagate (for details, see Setting the Line-to-Tag Filter (see "Select Line Properties" on 
page 145). 

 
 The current procedures propagate line process data to a single tag.  For details of how to 

propagate line data to more than one tag, see Batch Propagation of Line Data to Instrument 
Tags (see "Propagate Line Data to a Batch of Instrument Tags" on page 144).  Preventive 
Maintenance technician options include filling out test results. 

 Use the current procedures to propagate multi-case process data from a line to a tag, since 
the batch procedure propagates process data from the governing case only. 

Propagate Process Data From the Current Line to the Current 
Instrument 

1. Open and edit the process data sheet for the instrument to which you want to propagate 
process data from a line. 

2. On the Edit menu, point to Copy and then click From Line. 
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Propagate Process Data From Any Line to the Current 
Instrument 

1. Open and edit the process data sheet for the instrument to which you want to propagate 
process data from a line. 

2. In the GENERAL section of process data sheet, from the Line number list, select the line 
from which you want to propagate the process data to the current tag. 
 SmartPlant Instrumentation automatically propagates the relevant process data from the line 

that you select to the current tag. 
 
 

Propagate Line Data to a Batch of Instrument Tags 
This procedure allows you to propagate process data from a particular line to tags that you 
select.  Before you perform this procedure, you can set a filter that limits the fields that you 
propagate (for details, see Setting the Line-to-Tag Filter (see "Select Line Properties" on 
page 145).). 

 This procedure propagates the governing case only.  For details of how to propagate all 
cases from a given line to a given tag, see Propagating Line Process Data to an Instrument Tag 
(on page 143). 
1. Do one of the following: 

 Open the Process Data Module window. 
 Open a process data sheet for a line. 

2. On the Actions menu, click Propagate Line Data. 
3. In the Propagate Line Data dialog box, from the Line number list, select the source line from 

which you want to propagate the data to the tags. 
4. To select a group of target tags, select one of the following options from the Propagation 

method list: 
 Include all tags 
 Include all tag numbers with process data 
 Include all tag numbers without process data 

To select target tags individually, click Find to open the Find Tag dialog box, where you 
select the specific target tags. 

5. In the Propagate Line Data dialog box, click Propagate. 
 The propagated results are shown in the Processed tags data window (a selected box 

in the Done column signifies successful processing of data). 
6. Click Close. 
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Select Line Properties 
This procedure enables you to set a process data line-to-tag filter.  When you propagate process 
data from lines to instruments, only the selected properties are propagated.  The current filter 
settings affect both of the following procedures: 
 Propagating Line Process Data to an Instrument Tag (on page 143) 
 Batch Propagation of Line Data to Instrument Tags (see "Propagate Line Data to a Batch of 

Instrument Tags" on page 144) 
1. In the Process Data Module window, on the Edit menu, click Select Line Properties for 

Copying. 
2. In the data window, clear the selection of fields that you do not want to copy from lines to tags. 

 If you want to select a few fields only for copying, select and then clear the Select all 
check box to clear all the fields first. 

3. Click OK. 
 
 

Define Process Data for Differential Pressure Instruments 
 After setting the default units of measure for the current unit in the Units of Measure and 

Accuracy dialog box, you can select the desired default unit of measure for Differential Pressure 
(DP instrument). 
1. Open the desired pressure instrument process data sheet. 
2. From the Pressure type list, select Differential Pressure. 

 
 The Pressure property label changes to Differential pressure. 
 From the unit of measure flag lists throughout the process data sheet, you can select the 

Differential unit of measure flag. 
3. Under PROPERTIES and ADDITIONAL PROPERTIES, enter the appropriate process data 

values. 
4. Under ALARM, define the alarm and trip settings as needed. 
 

Delete Instrument Process Data 
This option enables you to delete instrument process data.  Note that you cannot delete any tags 
in the Process Data module.  Tag numbers are deleted in the Instrument Index module. 

 The deletion process is irreversible. Once you have deleted the process data, you 
cannot restore it! 
1. With the Process DataModule window open, on the Edit menu point to Delete Process 

Data and click Instrument. 
2. In the Enter Tag Number for Deletion dialog box, do one of the following: 

 In the text box, type tag for which you want to delete process data. 
 To search for the tag, click Find. 

3. Click OK. 
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Calculate the Properties of a Selected Material 
The Fluid Properties Database allows you to calculate the properties of the chosen material 
according to its pressure and temperature. 
The calculated properties are: 

For Liquid For Gas 

Density and Specific Gravity Density and Specific Gravity 

Vapor pressure Compressibility 

Viscosity Viscosity 

Liquid Heat Capacity Specific Heat Ratio 
 This option is not available for materials where the Fluid state is Solid/Powder or N/A or 

other nor for 2-phase Fluid phase. 
1. Open the desired process data sheet. 
2. In the Process Data window, from the Fluid name source list, select Database. 
3. From the Fluid list, select the desired fluid. 
4. In the PROPERTIES section, enter the appropriate pressure and temperature values. 

 
 SmartPlant Instrumentation calculates and displays changed values. 
 SmartPlant Instrumentation uses the AIChE databank to calculate physical properties; 

therefore your values must comply with the AIChE temperature limits.  AIChE data does not 
provide accurate calculation of density, compressibility, and specific gravity for ethylene and 
propylene at critical pressure and temperature.  For this reason, the software implements the 
procedure described in William C. Reynolds, SI, Department of Mechanical Engineering, 
Stanford University. 

 To calculate liquid density, on the Options menu, click Calculate Liquid Compressibility. 
 To calculate the steam properties, on the Options menu, click Saturated Steam. 
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S E C T I O N  1 3  

Managing Lines and Line Types 
This section deals with creating and managing line types and lines. 

In This Section 
Add a Line Type ............................................................................. 147 
Edit a Line Type ............................................................................. 147 
Change the Line Type ................................................................... 148 
Delete a Line Type ......................................................................... 148 
Add a New Line ............................................................................. 148 
Duplicate a Line ............................................................................. 149 
Line Fluid Velocity .......................................................................... 149 
View Line Process Data ................................................................. 150 
Modify Line Properties ................................................................... 150 
Define Line Process Data .............................................................. 150 
Edit Pipe Data Library .................................................................... 151 
Edit Line Process Data - Selecting Pipe Standards ...................... 151 
Edit Line Process Data - Fluid ....................................................... 152 
Copy Line Data from One Line to Another .................................... 152 
Delete Line Process Data .............................................................. 153 
 
 

Add a Line Type 
This option enables you to add a new line type to the Line Type list in the Select Line dialog box. 

1. In the Process Data Module window, on the module toolbar, click . 

2. In the Select Line dialog box, next to the Line Type list, click . 
3. In the Line Types dialog box, click New. 
4. Type the new line type name and description in the appropriate fields. 
5. Click OK. 
 
 

Edit a Line Type 
This procedure explains how to edit a line type. 

1. In the Process Data Module window, on the module toolbar, click . 

2. In the Select Line dialog box, beside the Line type list, click . 
3. In the Line Type dialog box, make the necessary changes. 
4. Click OK. 
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Change the Line Type 
This procedure explains how to change the line type for a specific line. 

1. In the Process Data Module window, on the module toolbar, click . 
2. In the Select Line dialog box, do one of the following: 

 To display lines of all line types, select Show all line types. 
 From the Line type list, select the current line type of the desired line. 

3. In the data window, select the desired line, and click Change Type. 
4. Select the new line type and click OK. 
 
 

Delete a Line Type 
This option enables you to delete a line type.  You cannot delete a line type if it includes a record, 
i.e., if it is associated with a line. 

1. In the Process Data Module window, on the module toolbar, click . 

2. In the Select Line dialog box, next to the Line Type list, click . 
3. In the data window, select the line type that you want to delete, and click Delete. 
4. Click OK. 

 Line numbers cannot be deleted in the Process Data module — only process data.  You 
can delete a line only in the Instrument Index module. 
 
 

Add a New Line 
Use this procedure to add a new line from the Process Data module. 
1. In the Process Data Module window, do one of the following: 

 On the process data toolbar, click . 
 Click Edit > Open Process Data > Line. 

2. On the Select Line dialog box, from the Line type list, select a line type. 

 To create a new line type, click  beside the Line type list. 
3. Click New. 
4. On the Line Properties (New) dialog box, complete the data fields of the left column as 

follows: 
a. In the Line number box, type the desired value. 
b. From the P&ID list, select the drawing associated with this line. 
c. In the Stream name box, type the optional stream name. 
d. From the Pipe material list, select the desired pipe material. 

e. From the Pipe spec list, select the pipe spec, or click  to open a dialog box where you 
manage pipe specs. 

5. To complete the data fields of the right column, do one of the following: 
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 From the Pipe standard list, select ANSI, DIN, or ASME DN.  This opens the Pipe Data 
Library dialog box.  Select one of the default sets of pipe data, or click New to define a 
custom library item and enter your own pipe data values. 

 From the Pipe standard list, select Other and enter the remaining right column values 
manually. 

6. On the Line Properties dialog box, click OK. 
7. On the Select Line dialog box, click OK. 
8. If the Process Data dialog box opens, select a fluid state and click OK. 
9. In the Line Process Data window, enter process data for the new line. 
10. Click Actions > Save Process Data. 

See Also 
Managing Line Component Tables (on page 164) 
 

Duplicate a Line 
1. On the Domain Explorer, expand your current <plant> hierarchy to display the Lines folder. 
2. Double-click the Lines folder to display the existing lines. 
3. Right-click the loop you want to duplicate, and on the shortcut menu, click Duplicate. 
4. On the Line Properties dialog box, type the new line number. 

 The data field on the Line Properties dialog box displays the line name template which 
is based on the line naming convention defined by the Domain Administrator.  In the 
alphanumeric and the numeric parts of the name, you can type any character (letters, digits, 
spaces, and so forth). 

5. If required, do the following to create the duplicated line in a different <unit> in the current 
domain: 

6. On the Line Properties dialog box, click OK. 
7. The duplicated line has the same piping data as the line it was duplicated from, however, you 

can change the pipe associated with the line as follows: 
8. On the Line Properties dialog box, click Pipe Data. 
9. Select the appropriate line and click OK. 
 

Line Fluid Velocity 
SmartPlant Instrumentation calculates the line fluid velocity according to the line internal diameter 
and volumetric fluid flow at flow conditions. 
If you enter fluid flow as mass or volumetric flow at standard / normal / base conditions, 
SmartPlant Instrumentation will calculate volumetric flow at flow conditions first (using density 
values) and then the line fluid velocity. 

 For flowmeters, fluid velocity at operating conditions is calculated automatically according 
to fluid flow and line internal diameter.  If the mass flow value has been entered, density is 
required for fluid velocity calculation. 
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View Line Process Data 
This procedure allows you to view a line process data before editing it. 

1. In the Process Data Module window, on the module toolbar, click . 
2. In the Select Line dialog box, select the desired line type from the Line type list to filter the 

data screen.  Select All Line Types check box to display all available lines. 
3. Highlight the desired line number and click OK. 
4. If the Process Data dialog box opens, select a fluid state and click OK. 

5. In the Line Process Data window, click . 
 
 

Modify Line Properties 
You can edit line data in either the Process Data or the Instrument Index modules.  This 
procedure applies to the Process Data module. 
1. In the Process Data Module window, do one of the following: 

 On the process data toolbar, click . 
 On the Edit menu, point to Open Process Data and click Line. 

2. In the Select Line dialog box, select the row containing the line data you want to edit. 
3. Click Properties to open the Line Properties dialog box. 
4. Modify the appropriate values in the Line Properties dialog box as follows: 

 Edit the line number name. 
 Select another pipe material. 
 Select another pipe standard. 
 Select another pipe spec. 

5. When done, click OK to return to the Select Line dialog box. 
 

Define Line Process Data 
Use this procedure to define process data for a line using the Process Data module options.  It not 
possible to define line process data in batch mode. 
1. In the Process Data Module window, do one of the following: 

 On the process data toolbar, click . 
 On the Edit menu, point to Open Process Data, and click Line. 

2. On the Select Line dialog box, do the following: 
a. From the Line type list, select a line type. 
b. In the data window displaying the lines that belong to the selected line type, select a line 

with the No value in the PD Exists column. 
c. Click OK. 

3. On the Process Data dialog box, select a fluid state and click OK. 
4. In the Line Process Data window, enter process data for the new line. 
5. On the Actions menu, click Save Process Data. 
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Edit Pipe Data Library 
Use this procedure to add new pipes to the Pipe Data Library. 
1. In the Process Data Module window, do one of the following: 

 On the process data toolbar, click . 
 Click Edit > Open Process Data > Line. 

2. On the Select Line dialog box, from the Line type list, select a line type. 
3. Click Properties. 
4. On the Line Properties dialog box, from the Pipe standard list, select ANSI, DIN, or ASME 

DN.  This opens the Pipe Data Library dialog box. 
 In the Default column, Yes indicates a default library item, and No indicates that the 

item is user-defined. 
5. On the Pipe Data Library dialog box, click New.  

 If you want to view details of an item which exists in the Pipe Data Library, highlight that 
item and click Properties. 

6. On the Library Item Properties (New) dialog box, type the desired pipe data values and click 
OK. 

7. On the Pipe Data Library dialog box, click OK. 
8. On the Line Properties dialog box, click OK. 
9. On the Select Line dialog box, click OK. 
 
 

Edit Line Process Data - Selecting Pipe Standards 
This topic summarizes the behavior of the pipe parameters under the GENERAL section of the 
Line Process Data window.  There are parameters that you set directly, and others that you set 
from the Pipe Data Library dialog box.  
For all pipe standard options — ANSI, DIN, ASME DN, and Other — you can edit the Pipe 
material and Pipe spec parameters directly. 
The following table summarizes the behavior of the software and availability of parameters for 
editing according to the pipe standard you select. 

Pipe Standard Parameters Set from Pipe 
Data Library 

Editable Parameters 

ANSI Line size, Line schedule, Line 
internal diameter, Wall 
thickness

 

ASME DN Line size, Line schedule, Line 
internal diameter, Wall 
thickness 

 

DIN Line size, Nominal pressure, 
Line internal diameter 

Wall thickness 

Other  Line size and its unit of measure, Line 
internal diameter, Wall thickness 
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 If you change your Pipe standard selection from any different value to ANSI, DIN, or ASME 

DN, the Pipe Data Library dialog box opens. 
 For the pipe standards ANSI, DIN, or ASME DN, to open the Pipe Data Library dialog box 

without changing the pipe standard, click Actions > Pipe Data. 
 

Edit Line Process Data - Fluid 
A fluid is a material characterized according to state, name, and phase. 
 Fluid state: Indicates whether the fluid is Liquid, Water, Gas/Vapor, Steam, Solid/Powder 

or N/A or Other.  Selecting the fluid opens the properties section with the appropriate 
parameters for selection. 

 Fluid name source: When the User- defined option is selected from the list, you can type the 
name of the fluid in the text box. 

 Fluid phase: The phase indicates whether the fluid is single or 2-phase.  This selection is for 
information only. 

 If you select N/A or other in Fluid state, Fluid name source and Fluid phase are 
disabled. 
 

Copy Line Data from One Line to Another 
This option allows to copy line data from a selected line to another line or to a group of lines.  If 
you are creating a complex analyzer with multi-stream analysis for a given physical line, you need 
to create multiple virtual lines, each representing a stream.  You can use this procedure to copy 
settings from one instance of such a line to the others. 
1. In the Process Data Module window, on the Actions menu, click Copy Line Data. 
2. Under Source lines, do one of the following from the Line types list: 

 Select All Line Types. 
 Select a specific line type. 

3. Under Line number, select the source line. 
4. Under Target lines, do one of the following from the Line types list: 

 Select All Line Types. 
 Select a specific line type. 

5. In the data window, select the target lines. 

 
 You can use the filter data field to locate a specific line.  Type the name of the desired line 

/ P&ID / stream in the respective field and click the Apply Filter button.  SmartPlant 
Instrumentation highlights the line you were looking for.  Another possibility is to select 
the As typed check box and then type the line/P&ID/Stream name in the respective 
field.  The data is filtered as you type. 

 You can sort the rows according to a column by double clicking the column's header. 
6. Click Copy to copy the data to the selected target lines. 
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Delete Line Process Data 
This procedure enables you to delete process data for a given line. 

 Before deleting process data, note that deleted process data cannot be restored. 
1. With the Process Data Module window open, on the Edit menu, point to Delete Process 

Data and select Line. 
2. In the Select Line to Delete Process Data dialog box, do one of the following to display in the 

data window those lines whose process data has been defined: 
 From the Line type list, select the desired line type. 
 Select the Show all line types check box to display all the existing lines with process 

data. 
3. Highlight the desired line in the data window. 
4. Click OK. 
 

Multiple Process Data Cases 
A given instrument or line is often used for more than one operating service.  For example, a 
dual-fuel control system might use a single supply line and control valve to carry various fuels, gas 
or liquid.  Each group of process data settings that you enter for a given instrument or line is called 
a case. 

 Each case has a separate drawing with its own revisions.  Each drawing includes the case 
name as part of the drawing name. 
 
 

Create Process Data Cases 
Use these procedures to do the following: 
 Enable cases for a tag or a line by assigning a case name to the current process data 
 Add additional cases to the tag or the line, thus creating multiple cases. 

 Case names that you assign to a given line or tag can be duplicates of names that you 
assign to cases in other lines and tags. 
For either of these procedures, do one of the following: 
 Open the process data sheet for an instrument tag from the Process Data module or the 

Calculation module. 
 Open a process data sheet for a line. 
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Enable Cases for the Current Tag Or Line 
On the Actions menu, click Enable Case. 
1. In the Enable Case dialog box, do one of the following to select a case name for the current 

data: 
 Select an existing case name from the Available cases list. 

 To create a new case name, click  to open a dialog box where you can create new 
case names. 

2. Click OK. 

Add a Case for the Current Tag Or Line 
1. On the Actions menu, click Add Case. 
2. In the Add Case dialog box, do one of the following to select a name for the new case: 

 Select an existing case name from the Available cases list. 

 To create a new case name, click  to open a dialog box where you can create new 
case names. 

3. Click OK. 
4. Enter and save process data for the case that you created. 

 The Design Temperature and Design Pressure fields in the Additional Properties 
section of a process data sheet, are common to all cases associated with the data sheet.  Any 
action (data entry, editing, or deletion of data) in these fields is reflected in all the cases, 
irrespective of which case the action was carried out on. 
 
 

Set a Governing Case 
A governing case is the set of process data values for a line or a tag that you select as the active 
case.  If for a given line or a tag you create more than one case, SmartPlant Instrumentation 
requires that you select a governing case.  If you define a single case, the software automatically 
sets it as the governing case. 
Use this procedure to select a governing case for a line or a tag. 

 Once you have enabled cases for line or a tag, if there is only one case, SmartPlant 
Instrumentation automatically defines it as the governing case.  If you subsequently enable 
additional cases, the first case still remains the governing case until you set a new governing case. 
1. Do one of the following: 

 Open the process data sheet for an instrument tag from the Process Data module, 
Calculation module, or Domain Explorer. 

 Open a process data sheet for a line. 
2. In the GENERAL section of the process data sheet, from the Case list, select the case that 

you want to be the governing case. 
3. On the Actions menu, click Set as Governing. 

 The Design Temperature and Design Pressure fields in the Additional Properties 
section of a process data sheet, are common to all cases associated with the data sheet.  Any 
action (data entry, editing, or deletion of data) in these fields is reflected in all the cases, 
irrespective of which case the action was carried out on. 
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Manage the Cases Supporting Table 
You use cases to enable multiple sets of process data for a given instrument or line.  Use these 
procedures to create, edit and delete case names and their descriptions.  You can manage the 
Cases supporting table from the Process Data module or the Calculation module. 

 Case names that you assign to a set of process data for a given line or tag can be 
duplicates of names that you assign to cases in other lines and tags. 
1. To open the Cases supporting table do one of the following: 

 In the Process Data Module window menu bar, click Edit > Cases. 
 In the Calculation module, create a case for a tag and do one of the following: 

 In the Enable Case dialog box, click . 

 In the Add Case dialog box, click . 
2. To add a new case name, click New, and then type a unique case name and an optional 

description. 
3. To edit an existing case name, click a value that you want to edit, and modify values as 

needed. 
4. To delete a case name, select the record that you want to delete, and click Delete. 

 SmartPlant Instrumentation does not allow you to delete a case name that is currently used 
on any process data sheet. 

 The Design Temperature and Design Pressure fields in the Additional Properties 
section of a process data sheet, are common to all cases associated with the data sheet.  Any 
action (data entry, editing, or deletion of data) in these fields is reflected in all the cases, 
irrespective of which case the action was carried out on. 
 
 

Delete a Process Data Case 
Use this procedure to delete a process data case that you created for a line or a tag. 

 Deletion of a case is irreversible. 
1. Do one of the following: 

 Open the process data sheet for an instrument tag from the Process Data module or the 
Calculation module. 

 Open a process data sheet for a line. 
2. Click Actions > Delete Case. 
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Process Analyzers 
Process analyzers measure physical or chemical properties of a process flow.  SmartPlant 
Instrumentation supports two types of process analyzers — simple and complex. 

Simple Analyzers 
A simple analyzer measures one physical or chemical property of a process fluid at the point of 
measurement or fluid sampling. 

 Simple analyzers belong to the Conventional Tag Class. 

Complex Analyzers 
A complex analyzer also measures physical and chemical properties of a process flow at the point 
of measurement or fluid sampling.  However, you have the following elements of flexibility in a 
complex analyzer: 
 You can create multiple stream tags. 
 For each stream tag, you can create multiple component/property tags. 

You can use the complex analyzer methodology even where only a single component / property is 
measured, if the data sheet information requires specifying the complete process fluid 
composition for all components. 
Although the application determines whether you define some analyzers as simple or complex, 
gas chromatographs are by their nature complex.  Even if you consider one stream only, in 
general you will want to utilize the ability of a gas chromatograph to analyze various 
components/properties in the stream. 
 
 

Flow of Activities for Complex Analyzers 
This topic describes the flow of activities for defining a complex analyzer, for example a gas 
chromatograph. 
1. Define the required fluid components in the Fluid Components supporting table. 

a. In the Process Data module, click Edit > Fluid Components. 
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b. Click New and define your fluid components as you require. For example: 

 
2. Open a process data sheet for a new line and define it as you require. 

For details, see Define Line Process Data (on page 150). 
3. For each line that you associate with a complex analyzer, define a line components table. This 

table lists the fluid components of this line, together with their minimum, normal, and 
maximum concentrations. 
a. Open an appropriate process data sheet for a line. 
b. Click Edit > Line Components. 
c. On the Line Components dialog box, click New. 
d. Under Fluid Component, select an available fluid component. 
e. Under Concentration Units, accept the default % or select the unit of measure that you 

need. 
f. Type values for minimum, normal, and maximum concentration. 
g. Repeat steps c through f for all the lines that you require and click OK. For example: 

 
4. In the Process Data module, create a complex analyzer tag. 

a. Click Instrument . 
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b. On the Enter Tag Number dialog box, define a tag number that has an Analyzer process 
function. 

 
c. On the Process Data dialog box, from the Analyzer type list, select Complex. 

 
d. Click OK to open the Complex Analyzer Tag Manager. 

 
5. Do the following for each stream tag that you want to define: 

a. To the right of the Analyzer stream list, click Add. 
b. On the Add Tag Number dialog box, type the name of the stream tag that you want to 

create. 

 
c. On the dialog boxes that open, define properties as needed. 
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d. Add as many streams as you require. 

 
6. For each stream that you added to the analyzer stream list, do the following to create 

component tags that correspond to every stream: 
a. In the Complex Analyzer Manager, click Add to the right of the Analyzer 

component/property list. 
b. On the Add Tag Number dialog box, type the name of the component tag that you want to 

create. 

 
c. On the dialog boxes that open, define properties as needed. 
d. Add as many components as you require. After adding all the required streams, the 

Complex Analyzer Manager should look like so: 

 
7. Click OK on the Complex Analyzer Tag Manager dialog box. 
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8. In the Process Data sheet that opens, from the Line number list, select an appropriate line. 

 
9. Click Yes to copy the line data to the current process data sheet or click No and enter the data 

yourself. 
10. In the GENERAL section of the process data sheet, select the analyzer stream that you want 

to define. 

 
11. In the ANALYZER COMPONENT / PROPERTY section, do the following for each tag in the 

Analyzer/component list: 
a. Select the analyzer component tag. 
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b. From the Line component list, select the fluid component that you want to link with the 
analyzer component tag. 

 
 After selecting the line component, the software displays the concentrations that 

you specified. 
c. Enter values and units of measure in the Repeatability, Accuracy, Minimum detection 

limit, and Range fields as needed. 

 
d. Repeat steps a through c to define each analyzer component. Note that you need to save 

the data when switching to another analyzer component. 

12. When done, click  and then close the process data sheet. 
13. Do the following to create a complex analyzer specification: 

a. In the Specifications module, click . 
b. On the Open Specification dialog box, enter the required tag and form number for the 

main analyzer equipment and then click OK. 

 
 Form 77 is a shipped form for main analyzer equipment. This form is supplied with 

SmartPlant Instrumentation as part of the shipped data. 
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c. In the specification that opens, enter the required data and click . For example: 

 
d. Close the specification. 

e. In the Specifications module, on the lower toolbar, click . 
f. On the Open Specification dialog box, enter the required tag and form number for the 

analyzer stream and click OK. 

 
 Form 78 is a shipped form for analyzer streams. This form is supplied with 

SmartPlant Instrumentation as part of the shipped data. 
g. Click OK to open the New Specification dialog box. 
h. Select the Create multi-tag specification option. 
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i. From the Format list. select an appropriate multi-tag format. Make sure that you have 
defined the required multi-tag format.  

 
j. Click OK to open the multi-tag specification that includes the following data: 

 Analyzer equipment data is displayed in the GENERAL section: 

 
 The CHARACTERISTICS section points to the Multi-Tag List page (SEE LIST), 

which contains the data of the analyzer components. If, instead of the SEE LIST text, 
you want to display the name of the master tag for the Stream property, on the 
Specifications Preferences, select the Show master tag check box and delete the 
text under Customize the SEE LIST label. 
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 The stream process data is displayed in the OPERATING CONDITIONS section: 

 
k. Enter the required data on page 1 and page 2 of the specification sheet. 
l. Click the Multi-Tag List tab to define the associated analyzer components. 
m. On the menu bar, click Actions > Add Tags. 
n. On the Add Tag dialog box, type the name of the associated component or click Find to 

find the required tag. 

 
o. Repeat steps f through n for each stream. 

 

Managing Line Component Tables 
For each line that you defined for a complex analyzer tag, you need to create a line components 
table.  This table lists the fluid components of this line, together with their minimum, normal, and 
maximum concentrations. 
The Line Components table that you create individually for each line is based on a Fluid 
Components supporting table — which you also manage — that is available for all lines. 
For both procedures, open a process data sheet for the line for which you want to create a Line 
Components table. 

Manage the Fluid Components Supporting Table 
 You can also perform this procedure from the Process Data window. 

1. On the Edit menu, click Fluid Components. 
2. To create a new fluid component, click New. 
3. Click a value that you want to edit and modify the value as needed. 
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Create A Line Components Table For The Current Line 
1. Click Edit > Line Components. 
2. For each fluid component that you want to enable for the current line, do the following: 

a. Click New to add a new row. 
b. Under Fluid Component, select an available fluid component. 
c. Under Concentration Units, accept the default % or select the unit of measure that you 

need. 
d. Type values for minimum, normal, and maximum concentration. 

3. Click OK. 
 
 

Define a Complex Analyzer 
You use this procedure in the course of creating a complex analyzer tag.  Before you perform this 
procedure, do the following: 
 Adding a New Line (see "Add a New Line" on page 148) 
 Managing Line Component Tables (on page 164) for each line 
 Defining an Instrument Type (see "Define an Instrument Type" on page 83) of process 

function Analyzer for your complex analyzer 
1. In the Process Data module, create a complex analyzer tag. 
2. In the Complex Analyzer Tag Manager dialog box, do the following for each stream tag that 

you want to define: 
a. To the right of the Analyzer stream list, click Add. 
b. In the Add Tag Number dialog box, type the number of the stream tag that you want to 

create. 
c. In the dialog boxes that open, define properties as needed. 

 Associate a line with the stream tag either in the Tag Number Properties dialog box or 
in the process data sheet for the given stream tag. 

3. For each stream that you added to the Analyzer stream list, do the following to create 
component tags that correspond to every component of the stream: 
a. To the right of Analyzer component/property, click Add. 
b. In the Add Tag Number dialog box, type the number of the component tag that you want 

to create. 
c. In the dialog boxes that open, define properties as needed. 

4. In the Complex Analyzer Tag Manager dialog box, click OK. 
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Link Analyzer Stream Components with Line Components 
Use this procedure to link analyzer component tags with line components.  You must perform this 
procedure for every stream of a complex analyzer. 
1. In the Process Data module, open the stream tag. 
2. In the GENERAL section, from the Line number list, select the desired line. 
3. In response to the prompt, click Yes to copy data from the line to the process data sheet. 
4. In the ANALYZER COMPONENT / PROPERTY section, do the following for each tag in the 

Analyzer/component list: 
a. Select the analyzer component tag. 
b. From the Line component list, select the fluid component that you want to link with the 

analyzer component tag. 
c. Enter values and units of measure in the Repeatability, Accuracy, Minimum detection 

limit, and Range fields as needed. 
5. On the Actions menu, click Save Process Data. 
 
 

Supplementary Service Operations 
This section contains various topics on supplementary services used in the Process data module. 
 

Add an Insulation Type 
You can add a new insulation type if the desired one is not available in the Insulation list of the 
ADDITIONAL LINE PROPERTIES section of the Line Process Data window. 
1. In the Process Data Module window, on the Edit menu, click Insulation Types. 
2. In the Insulation Types dialog box, click New to add a new data line, where you type the new 

insulation type name and description. 
3. Click OK. 
 

Edit/Enter a Pipe or Orifice Material 
This option enables you to enter additional pipe and orifice materials as well as modify the existing 
ones.  You can select the desired ANSI group and enter or modify the linear expansion 
coefficients.  It is possible to define linear expansion coefficients in different ways: 
 One linear expansion coefficient for all temperatures. 
 One linear expansion coefficient with a limitation on the minimum temperature (Tmin) or 

maximum temperature (Tmax). 
 Two linear expansion coefficients and border temperature.  This option allows you to use the 

first linear expansion coefficient for temperatures lower than the border temperature and the 
second linear expansion coefficient for temperatures higher than the border temperature. 

 Two linear expansion coefficients, border temperature, and minimum/maximum 
temperature.  This option allows you to use the first linear expansion coefficient for 
temperatures between minimum and border temperature and the second linear expansion 
coefficient for temperature between border and maximum temperature. 

 This option is also available in the Calculation module. 
1. In any Process Data module window, on the Edit menu, click Pipe/Orifice Material. 
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2. In the data window, click fields that you want to edit, and type or select the desired values from 
the lists. 

3. To enter a new material, click New, and then type or select the desired value from the 
respective lists. 

4. To delete a material, select the desired data row and click Delete. 
5. Click OK to apply changes and close this dialog box. 
 

Define/Modify Pipe Specs 
Pipe spec is a specification that defines various process conditions for a specific pipe. 
Use this procedure to define a pipe spec to the Pipe Specs supporting table from the Process 
Data module, or to modify properties of an existing pipe spec. 

1. In the Process Data Module window, click  to open the Select Line dialog box. 
2. From the Line type list, select a line type. 
3. Click New to open the Line Properties dialog box. 

4. Beside the Pipe spec list, click  to open the Pipe Specs dialog box. 
5. Do one of the following: 

 To create a new pipe spec, click New and type entries in the Pipe Spec and Description 
boxes. 

 To edit an existing pipe spec, click a field in a highlighted row and modify the existing entry 
as needed. 

 

Delete a Pipe Spec 
Use this procedure to delete a pipe spec from the Pipe Specs supporting table. 

 You cannot delete a pipe spec that is currently assigned to lines.  First edit the lines to 
which the pipes spec that you want to delete is assigned. 

1. In the Process Data Module window, click  to open the Select Line dialog box. 
2. From the Line type list, select a line type. 
3. Click New to open the Line Properties dialog box. 

4. Beside the Pipe spec list, click  to open the Pipe Specs dialog box. 
5. Select the pipe spec that you want to delete, and click Delete. 
6. Repeat the previous step for each pipe spec that you want to delete. 
 

Set the Default Units of Measure 
This option enables you to set the desired default units of measure for the currently active 
<unit>.  The units of measure and accuracy will appear on the process data or calculation sheets 
and the specification forms of the selected tags.  Remember that you have to set default units of 
measure and accuracy separately for each <unit> in the <plant>. 
1. In the main Process Data window, on the File menu, click Units of Measure and Accuracy. 
2. For each desired parameter, select from the appropriate lists: 

a. The level of accuracy. 
b. The unit of measure, if applicable. 
c. Type the appropriate default values for Ambient Temperature, Base Temperature, 

Barometric Pressure, and Base Pressure. 
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3. Click OK. 
 

Calculate Liquid Density According to the API 2540 Standard 
This feature enables you to calculate liquid density at operating and base conditions in 
accordance with the API 2540 standard.  You can select one of the five product groups: 
 Crude Oils and JP 4. 
 Jet Fuels, Kerosene, and Solvents. 
 Gasoline and Naphthenes. 
 Lubricating Oils. 
 Diesel Oil, Heating Oils, and Fuel Oils. 

1. Open the process data sheet for an instrument tag from the Process Data module or the 
Calculation module. 

2. In the process data sheet, make sure that the Liquid fluid state is selected. 
3. Select the API 2540 option from the Fluid name source list. 
4. Select the desired product group from the Fluid name list. 
5. In the API 2540 STANDARD section, select one of the following: 

 Density at reference temperature. 
 Specific gravity at reference temperature. 
 API settings for: minimum / normal / maximum 

6. Enter the desired values in the appropriate fields according to the selected option. 
7. If you selected Density at reference temperature or Specific gravity at reference 

temperature, do one of the following: 
 Type the reference temperature value in the Reference temperature field. 
 Click Default to enter the default reference temperature. 

8. Click Calculate Density to calculate the density. 
 The calculated values for density and specific gravity are entered in the properties 

@Minimum, @Normal, and @Maximum fields. 
 

Convert Engineering Units Automatically 
Three steps convert one engineering unit to another: first, click the designated Units field 
drop-down list.  Then, select the new unit of measure.  Finish by choosing the new unit of 
measure.  After the calculations are over, the results are displayed in the property record item 
fields. 

 When converting from one engineering unit to another, the data value changes in 
accordance with the new engineering unit. 
1. With a process data sheet open, on the Options menu, click Automatic Unit Conversion. 
2. Click in the Units field of the engineering units you want to convert and select the new 

engineering unit of measure. 
 If you convert to Volumetric Flow engineering units, a dialog box opens where you 

specify the measuring condition. 
3. Select a condition, and click OK to display the results. 

 If you convert to engineering units other than Volumetric Flow, results are directly 
displayed in the property record item fields. 

4. When finished, click  to save the changes. 
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Copy Default Units of Measure from Another <Unit> 
You can define the default units of measure and accuracy by copying the definitions from another 
existing unit.  You can then make any modification.  This shortens the process of setting new 
default units of measure. 
1. In the Units of Measure and Accuracy dialog box, click Copy From. 
2. In the Open dialog box, navigate to the source <unit> from which you want to copy the default 

data. 
3. Click OK to copy the default unit of measure settings. 
 

Import Process Data Files 
You can import process data sheets for lines or instruments in .ipd (SmartPlant Instrumentation 
process data) format after editing in the Process Data Editor, provided the line or instrument exists 
in the SmartPlant Instrumentation database.  The .ipd format allows you to include multiple tags in 
a single file. 

 Use this procedure to import back into SmartPlant Instrumentation process data for a tag 
that already exists in your SmartPlant Instrumentation database. 

Import Instrument Process Data Files 
1. In the Process Data Module window, on the Actions menu, click External Process Data. 
2. Under Item type, select Instrument. 
3. Under Action, select Import. 
4. Click Open. 
5. In the dialog box that opens, navigate to the folder from which you want to import the file. 
6. Select the desired file and click Open. 

 The software only accepts .ipd files that contain instrument data. 
7. Under Search results, select the Select check box beside the instruments that you want to 

import. 
 The software only displays instruments that already exist in your SmartPlant 

Instrumentation database. 
8. Click Apply or OK. 

Import Line Process Data Files 
1. In the Process Data Module window, on the Actions menu, click External Process Data. 
2. Under Item type, select Line. 
3. Under Action, select Import. 
4. Click Open. 
5. In the dialog box that opens, navigate to the folder from which you want to import the file. 
6. Select the desired file and click Open. 

 The software only accepts .ipd files that contain line data. 
7. Under Search results, select the Select check box beside the lines that you want to import. 

 The software only displays lines that already exist in your SmartPlant Instrumentation 
database. 

8. Click Apply or OK. 
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Export Process Data Files 
You can export process data sheets for lines or instruments in .ipd (SmartPlant Instrumentation 
process data) format for use with the Process Data Editor.  In this way, you can allow an external 
party (contractor, engineering company, and so forth) to modify your process data outside of 
SmartPlant Instrumentation.  The .ipd format allows you to include multiple tags in a single file. 

Export Instrument Process Data Files 
1. In the Process Data Module window, on the Actions menu, click External Process Data. 
2. Under Item type, select Instrument. 
3. Under Action, select Export. 
4. Click Find, and in the Find Tag dialog box, under Search parameters, from the Process 

function list, select a process function other than General, and then click Find. 
5. Select one or more of the tag numbers displayed, or click Select all. 
6. Click OK. 
7. In the External Process Data dialog box, under Search results, select the Select check box 

beside the instruments that you want to export, and click Apply or OK. 
8. In the dialog box that opens, navigate to the folder to which you want to export, type a 

filename, and click OK. 

Export Line Process Data Files 
1. In the Process Data Module window, on the Actions menu, click External Process Data. 
2. Under Item type, select Line. 
3. Under Action, select Export. 
4. Click Find, and in the Select Line for Export dialog box, do one of the following: 

 From the Line Type list, select a line type. 
 Select the Show all line types check box. 

5. Select one or more of the lines displayed, or click Select all. 
6. Click OK. 
7. In the External Process Data dialog box, under Search results, select the Select check box 

beside the lines that you want to export, and click Apply or OK. 
8. In the dialog box that opens, navigate to the folder to which you want to export, type a 

filename, and click OK. 
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Process Data Reports and Revisions 
SmartPlant Instrumentation generates process data reports by utilizing eight pre-defined report 
templates with which the data of a SmartPlant Instrumentation item is associated (one for line, and 
seven for instruments).  A SmartPlant Instrumentation item may be an Instrument or a Line.  This 
is done through the association of a SmartPlant Instrumentation item, (and its process function - if 
it is an instrument) to its pre-defined template. 
Each report is made up of a number of sections depending on the process function.  For example: 
General, Quality of Fluid, Operating Data, Instrument Data, Properties Flow, Alarm and Trip 
Settings (for example, pressure & temperature instruments), a Notes field, and Internal and 
External Revision fields. 
 
 

Generate a Process Data Report for One Instrument or Line 
You can generate a process data report from an open process data sheet for the current 
instrument or line only. 

 If you are generating a report for a multi-case instrument tag, this option prints the current 
case. 
1. Do one of the following: 

 Open a process data sheet for an instrument. 
 Open a process data sheet for a line. 

2. On the Actions menu, click Report. 
3. If you open a print preview, do any of the following: 

 Click  to select a pre- set magnification, or enter a customized one to fit your needs. 

 Click  to print the report, or  to print all available reports.  Selecting the Printer 
Setup option from the File menu will allow you to select the default printer. 

 Click  to save the report as an external file. 

 Click  to create or edit local revisions and drawing numbers. 
 If the selected instrument (tag) has multiple lines associated with it, the data of the 

downstream line selected (in the tag process data from which the report was generated) will 
appear in the report. If none are selected, the report will look like a single-line tag report. 
 

Generate Line Reports 
This option allows you to generate process data reports for more than one line and case. 
1. In the Process Data Module window, on the Reports menu, point to Line, and do one of the 

following: 
 To print one process line per page, click Single Line. 
 To print three process lines per page, click Three Lines. 

 For lines that are multi- case, this option prints the governing case. 
2. In the Select Line for Report dialog box, do one of the following: 

 From the Line Type list, select a line type. 
 Select the Show all line types check box. 

3. Select the lines you want to include in the report. 
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4. Click OK. 
 

Generate Instrument Reports 
This option allows you to generate process data reports for more than one instrument and case. 
1. Start the Process Data module. 
2. In the Process DataModule window, on the Reports menu, point to Instrument, and do one 

of the following: 
 To print one tag per page, click Single Tag. 
 To print three tags per page, click Three Tag. 

 For tags that are multi-case, this option prints the governing case. 
3. In the Find Tag dialog box search for the tag number according to the criteria you specify, or 

click Find for a list that you can choose from. 
4. Select the tags to include in the report. 

 For multi-case tags, select each case that you want to include in the report. 
5. Click OK. 
 
 

View and Edit Process Data Revisions 
You use revisions to keep track of the changes made to your process data.  It is important and 
useful to have a chronological description of the changes, dates of change, and a list of persons 
who approved them.  You can add, edit, and delete revisions.  The Process Data module shares 
the following two types of revisions with the rest of SmartPlant Instrumentation: local revisions and 
global revisions.  There is an additional type of revision available only in the Process Data 
module, which is an external revision. 

 If the process data workflow control has been enabled, only users with access rights are 
able to edit the Process Data Revisions.  For more details, see Workflow (on page 54). 
 

Work with External Process Data Revisions 
Use this procedure to add, edit, or delete external revisions in the Process Data module. 
1. In the Process Data Module window, do one of the following: 

 Click . 
 On the Actions menu, click External Revisions. 

2. In the Revisions dialog box, select one of the revision numbering methods (use P0, P1, 
P2...  for preliminary revisions or 0, 1, 2 /A, B, C, and so forth for normal serial revisions). 

 When you first select a revision numbering method, several options are available to you, 
including preliminary revisions (designated by P0, P1, P2…).  Once you select one of the 
other revision methods, you will not be able to return to the preliminary revision method and 
this option will be disabled. 

3. Click New to add a new revision or click in a data field to update existing revision data in that 
field. 

4. Add or edit the revision data in the appropriate data fields. 
 The By data field contains the current user's initials by default, if previously defined by 

the SmartPlant Instrumentation System Administrator.  You can also edit this field if desired. 
5. To delete revisions, do the following: 
6. Select the revision you want to delete. 
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7. Click Delete. 
 As a time saver and a forget-me-not precaution, take advantage of using a default 

Revision method.  The software automatically adds a new line with the next logical character 
and date each time you click New after you select the initial method. 

8. When done, click OK. 
 If the process data workflow control has been enabled, only users with access rights are 

able to edit the Process Data Revisions.  For more details, see Workflow (on page 54). 
 

View Process Data History 
SmartPlant Instrumentation can indicate process data changes by comparing current data with 
the data stored in the audit trail repository for the date range that you specify.  You can choose 
any or all of the following modes of emphasis: 
 You can set a color to emphasize changes on the screen. 
 You can set a shade of gray to emphasize the changed data in printed reports and their 

previews. 
 You can set bold and italic font style for emphasis on the screen and in print. 

 History indication is available only if the System Administrator has activated the audit trail 
functionality.  When the audit trail functionality is activated, each time that you save data after 
making changes, the data is recorded in the audit trail repository. 
1. In the Process Data module, open the desired tag. 
2. On the Options menu, click History Options. 
3. Select the date range for data history comparison, by doing one of the following: 

 In the From and To data fields, type the appropriate dates. 
 Select the appropriate dates using the spinner. 

 To set the To data field value as today's date, click Today. 
4. To set a font style to emphasize changes on the screen and in print, do one or both of the 

following: 
 Select Bold. 
 Select Italic. 

5. To change the color used to display changes on the screen: 

a. Beside the Highlight color for display box, click . 
b. In the Color dialog box, choose the color that you require. 
c. Click OK to save your new color settings and return to the History Options dialog box. 

6. To change the shade of gray used to emphasize the changed data in printed reports and their 
previews: 

a. Beside the Grayscale for printing box, click . 
b. In the Grayscale dialog box, slide the bar to the desired position. 
c. Click OK to save your new grayscale setting and return to the History Options dialog 

box. 
7. Click OK to save your current history options and close the History Options dialog box. 
8. On the Options menu, click Mark Changes to mark changes in the current process data 

sheet for the dates that you specified in the History Options dialog box.  Clear the check box 
to clear all history indications in the current process data sheet. 
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 To refresh the history indication in an open process data sheet, on the Options menu, 
clear Mark Changes and then select the option again. 
 

Calculation data originates mainly from the Process Data module, but also from the Instrument 
Index module.  You can open the relevant dialog box for the specified instrument type (control 
valve, flowmeter, relief valve, or thermowell), enter all the parameters required for calculation, and 
initiate the calculation.  After performing the calculation, the relevant data may then be 
incorporated into generated reports and specifications. 
The Calculation module allows you to quickly perform calculations for Cv, noise, orifice diameter, 
required discharge area, and other parameters for control valves, flowmeters, relief valves, and 
thermowells. 
The Calculation module employs the major international standards (ISA, ANSI, API, ISO, and IEC 
60534-2-1 (1998)), to perform complex calculations quickly and effortlessly. 

 
 The software does not support calculations for materials for which the state is solid/powder, 

nor for 2-phase flow. 
 If you need to add or modify process data, you can do this in the Calculation module (for 

details, see Editing Instrument Process Data (see "Edit Instrument Process Data" on 
page 142)). 

 

Start the Calculation Module 
This procedure explains how to start the calculation module. 

 Before starting this module, check with the Domain Administrator to ensure that you have 
been granted appropriate access rights for the tasks you will carry out. 

Start the Calculation Module 
 In any SmartPlant Instrumentation window, do one of the following: 

 On the SmartPlant Instrumentation toolbar, click . 
 Click Module > Calculation. 

 

Preparing Process Data Calculation 
Before running a calculation, use the Process Data Sheet to prepare a calculation item.  When 
opening a tag in a process data sheet, you are required to define the fluid for which a calculation 
will be carried out.  You define the fluid by selecting the fluid state, entering the fluid name or 
selecting it from one of the two property databases, and setting the fluid phase. 

 
 You can also select a batch of instruments of a given process function for calculation (for 

details, see Multiple Process Data Cases (see "Perform a Batch Calculation" on page 185)). 
 If this is a new tag that you just created in the Calculation module, the PROPERTIES section 

of the window will be blank until you select the required Fluid state. 
 The software does not support calculations for materials for which the state is Solid/Powder, 

N/A or other nor for 2-phase flow. 
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Open a Process Data Sheet for Calculation 
Use this procedure to open individual control valve, flowmeter, relief valve, and thermowell 
process data sheets for calculation. 
1. In the Calculation Module window, click Edit > Calculation, and then click one of the 

following: 
 Flowmeter 
 Thermowell 
 Control Valve 
 Relief Valve 

2. On the Enter Tag Number dialog box, do one of the following: 
 Type the tag number that you want to calculate. 
 Click Find to open the Find Tag dialog box, where you search for the tag that you want to 

calculate. 
3. Click OK to display the calculation Process Data window for the instrument that you selected. 
4. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
 

Define the Fluid (Calculation module) 
This procedure is used to define the fluid for which a calculation will be carried out 
1. Open the process data sheet for an instrument tag from the Process Data module or the 

Calculation module. 
2. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
3. In the GENERAL section of the process data sheet, from the Fluid state list, do one of the 

following: 
 Accept the fluid state that you set when you first opened the tag in the Process Data or 

Calculation module. 
 Select a different fluid state. 

 If you select N/A or other, the Calculate, Report and Highlight options are all 
disabled. 

4. From the Fluid name source list, select one of the following options, which the software uses 
to calculate the item properties: 
 Database — Activates the Fluid Properties database after selecting the required fluid 

from the Name list (for details, see Calculating Physical Properties (see "Calculate the 
Properties of a Selected Material" on page 146)). 

 API2540 — Calculates liquid density at operating and base conditions in accordance with 
the API2540 standard.  To learn how to use the API 2540 Standard Properties 
database, see API 2540 Standard for Liquid Density Calculation (see "Calculate Liquid 
Density According to the API 2540 Standard" on page 168)). 

 User-defined — Allows you to define the fluid properties according to your own 
standards. 
 If you selected Solid/Powder as the material state, the Select from list does not appear. 

5. In the Fluid name box, enter the fluid name. 
6. From the Fluid phase list, select the required fluid phase. 
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Performing Standard Calculations 
The calculation dialog boxes comprise the essence of the Calculation module.  The values that 
you enter in these dialog boxes together with the data in the process data sheets serve as the 
basis of the calculations displayed on the screen.  Calculation item reports provide information 
that is more comprehensive. 

 When you open a Calculation Item window and some of the process data values are not 
filled in, you can click Highlight Process Data on the Options menu to highlight all the fields that 
you must fill in to carry out the calculation. 
 
 

Prepare for Flowmeter Calculation 
Use this procedure to enter the values common to all three types of flowmeter calculation. 
When you reach the last step of the current procedure, click the link to the procedure that you 
require to complete the calculation. 

 
 By default, SmartPlant Instrumentation updates tag values from the current unit of measure to 

their value in a new unit of measure that you set.  If on the Options menu you clear 
Automatic Unit Conversion, the software changes the unit of measure without recalculating 
the values.  Therefore, to protect the integrity of your values, on the Options menu, click 
Automatic Unit Conversion. 

 To highlight the fields that are required for a calculation, on the Options menu, click Highlight 
Process Data. 

1. Open a calculation data sheet for the flowmeter tag that you want to calculate. 
2. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
3. Make sure that you enter process data in all of the fields in the data sheet that are required for 

calculation. 

4. On the module toolbar, click . 
5. Do one of the following: 

 On the module toolbar, click . 
 Click Actions > Calculate. 

6. In the Flowmeter Calculation dialog box, continue with one of the following procedures: 
 Orifice flowmeter calculation 
 Tube flowmeter calculation 
 Restriction device calculation 
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Calculate Orifice Flowmeter Parameters 
This option enables you to calculate orifice flowmeter parameters based on the fluid state values 
of the flowmeter and values retrieved from the Process Data module.  In a calculation data sheet 
for a flowmeter item, you can accept or modify these values, or enter additional values.  Then, in 
the Flowmeter Calculation dialog box, you calculate orifice flowmeter parameters for a selected 
orifice flowmeter and view the calculation results. 
1. Open the Flowmeter Calculation dialog box for the orifice flowmeter that you want to 

calculate. 
2. From the Flowmeter type list, select the required orifice flowmeter. 

 The Quarter of Circle Orifice (also known as Quadrant Edge Orifice) sizing is in 
accordance with the new edition of British Standard (BS 1042: Section 1.2; 1989). 

3. From the Sub type list, select the required sub type for the current orifice flowmeter. 
4. Type the required values in the fields next to the other two calculation options that you have 

not selected.  SmartPlant Instrumentation will then use these values to calculate the tube 
flowmeter parameters for the selected option. 

5. Under Pipe, view the data in the Material field and the Linear expansion coefficient field.  

 
 The data in the Pipe material field is retrieved from the Process Data module. 
 The linear expansion coefficient value for the displayed pipe is the standard value taken 

from SmartPlant Instrumentation database. 
 From the Linear expansion coefficient list of units of measure, you can select a required 

unit of measure for the current linear expansion coefficient. 
6. Under Orifice, from the Orifice material list, select the orifice material. 

 
 The Orifice material list contains standard options provided with SmartPlant 

Instrumentation.  If the required orifice material is not in the list, select from the list the 
MATERIAL NOT LISTED option and in the Linear expansion coefficient field type the 
required linear expansion coefficient. 

 If you select a standard option from the Orifice material list, you cannot change the linear 
expansion coefficient value for the displayed orifice material because this is the standard 
value taken from SmartPlant Instrumentation database.  

7. In the Diameter of bleed/vent hole field, type the required diameter of the bleed/vent hole or 
accept the given value. 

 
 When calculating the orifice flowmeter parameters for the Steam fluid state, in the Water 

in steam, %wt field, type the percentage of water in steam. 

 If the value in the Full scale flow field has been changed, you can click  to get the 
values from the Process Data module. 

8. Under Select calculate field, select one of the following options to calculate the orifice 
flowmeter parameters: 
 Orifice diameter 
 Full scale flow 
 Differential range 

9. Click Calculate. 
 Calculation is disabled for N/A or other fluid state. 
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10. Examine the calculation results and possible calibration error messages.  

 
 The units of pressure loss derive from the default units for Differential Range (Flow) set in 

the Units of Measure and Accuracy dialog box. 
 When sizing flowmeters for Liquids and Water, SmartPlant Instrumentation checks 

whether Downstream pressure is greater than Vapor pressure.  If it is, the program 
continues sizing.  If it is not, critical flow takes place, and the program advises you to 
check the input data. 

11. To recalculate the orifice flowmeter parameters, enter the new data and click the Calculate 
command button. 

12. Click Close to return to the calculation data sheet. 
 

Calculate Tube Flowmeter Parameters 
This option enables you to calculate tube flowmeter parameters based on the fluid state values of 
the flowmeter and the values retrieved from the Process Data module.  In a calculation data sheet 
for a flowmeter item, you can accept or modify these values, or enter additional values.  Then, in 
the Flowmeter Calculation dialog box, you calculate the tube flowmeter parameters for a 
selected tube flowmeter, view and print out the calculation results. 
1. Open the Flowmeter Calculation dialog box for the tube flowmeter that you want to 

calculate. 
2. From the Flowmeter type list, select the tube flowmeter type. 
3. From the Sub type list, select the tube flowmeter sub-type, if available. 
4. Type the required values in the fields next to the other two calculation options that you have 

not selected.  SmartPlant Instrumentation will then use these values to calculate the tube 
flowmeter parameters for the selected option. 

5. In the Tube group box, view the data in the Material field and the corresponding linear 
expansion coefficient value in the Linear expansion coefficient field. 

 
 The data in the Material field is retrieved from the Process Data module.  
 The linear expansion coefficient value for the displayed pipe is the standard value taken 

from the SmartPlant Instrumentation database. 
 From the Linear expansion coefficient list of units of measure, you can select a required 

unit of measure for the current linear expansion coefficient.  
6. In the Throat group box, select the required throat material. 

 
 The Material list contains standard options provided with SmartPlant Instrumentation.  If 

the required throat material is not in the list, select from the list the MATERIAL NOT 
LISTED option and in the Linear expansion coefficient field type the required linear 
expansion coefficient. 

 If you select a standard option from the Material list, you cannot change the linear 
expansion coefficient value for the displayed throat material because this is the standard 
value taken from the SmartPlant Instrumentation database.  

 When calculating the tube flowmeter parameters for the steam fluid state, in the Water in 
steam, %wt field, type the percentage of water in steam. 
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 If the value in the Full scale flow field has been changed, you can click  to retrieve the 
values from the Process Data module. 

7. Under Select calculate field, select one of the following options to calculate the tube 
flowmeter parameters: 
 Throat diameter 
 Full scale flow 
 Differential range 

8. Click OK to carry out and display the calculation results. 
9. Examine the calculation results and possible calibration error messages.  

 
 The values of pressure loss in the results comes from the default values for differential 

range flow set in the Units of Measure and Accuracy dialog box. 
 When sizing flowmeters for Liquids and Water, the software checks whether 

Downstream pressure is greater than Vapor pressure.  If it is, the program continues 
sizing.  If it is not, critical flow takes place, and the program advises you to check the input 
data. 

10. To recalculate the tube flowmeter parameters, enter the new data and then click Calculate. 

11. Click Close to return to the calculation data sheet, where you can click  to generate a 
report for the current calculation result.  Error messages also appear in a calculation report. 

 

Calculate the Restriction Device Parameters 
This option enables you to calculate the restriction device parameters based on the fluid state 
values of a flowmeter and values retrieved from the Process Data module.  In a calculation data 
sheet for a flowmeter item, you can accept or modify these values, or enter additional 
values.  Then, in the Flowmeter Calculation dialog box, you calculate the restriction device 
parameters and view the calculation results. 
1. Open the Flowmeter Calculation dialog box for the restriction device that you want to 

calculate. 
2. From the Flowmeter type list, select Restriction Device. 
3. From the Sub type list, select the restriction device sub type. 
4. Type the appropriate values in the fields next to the other two calculation options that you 

have not selected.  SmartPlant Instrumentation will then use these values to calculate the 
tube flowmeter parameters for the selected option. 

5. In the Pipe group box, view the data in the Material field and the corresponding linear 
expansion coefficient value in the Linear expansion coefficient field.  

 
 The data in the Pipe material field is retrieved from the Process Data module.  
 The linear expansion coefficient value for the displayed pipe is the standard value taken 

from the SmartPlant Instrumentation database. 
 From the Linear expansion coefficient list of units of measure, you can select a required 

unit of measure for the current linear expansion coefficient. 
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6. In the Orifice group box, from the Material list, select the orifice material of the restriction 
device. 

 
 The Orifice material list contains standard options provided with SmartPlant 

Instrumentation.  If the required orifice material is not in the list, select from the list the 
MATERIAL NOT LISTED option and in the Linear expansion coefficient field type the 
required linear expansion coefficient. 

 If you select a standard option from the Material list, you cannot change the linear 
expansion coefficient value for the displayed orifice material because this is the standard 
value taken from the SmartPlant Instrumentation database.  

7. In the Diameter of the bleed/vent hole field, accept the displayed value, or type the diameter 
of the bleed/vent hole. 

8. If needed, clear the Calculate discharge coefficient check box to enable you to type the 
discharge coefficient. 

 
 If you leave the Calculate discharge coefficient check box selected, the software 

automatically calculates the discharge coefficient according to the preset values. 
 When calculating the restriction device parameters for the Steam fluid state, in the Water 

in steam, %wt field, type the percentage of water in steam. 

 If the value in the Full scale flow field has been changed, you can click  to get the 
values from the Process Data module. 

9. Under Select calculate field, select one of the following options to calculate the restriction 
device parameters: 
 Orifice diameter 
 Full scale flow 
 Pressure loss 

 Do not type any values in the field next to the selected calculation option. 
10. Click OK to carry out and display the calculation results. 
11. Examine the calculation results and possible calibration error messages.  

 
 The values of pressure loss in the results comes from the default values for differential 

range flow set in the Units of Measure and Accuracy dialog box. 
 When sizing flowmeters for Liquids and Water, SmartPlant Instrumentation checks 

whether Downstream pressure is greater than Vapor pressure.  If it is, the program 
continues sizing.  If it is not, critical flow takes place, and the program advises you to 
check the input data. 

12. To recalculate the restriction device parameters, enter the new data and then click Calculate. 

13. Click Close to return to the calculation data sheet, where you can click  to generate a 
report for the current calculation result.  Error messages also appear in a calculation report. 



 Calculations 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 181 
 

 

Calculate the Sizing of a Relief Valve 
Use this procedure to calculate the size of a relief valve.  This option works for single phase fluids 
only and for all fluid states, with the exception of Solid/Powder and N/A or other. 

 
 By default, SmartPlant Instrumentation updates tag values from the current unit of measure to 

their value in a new unit of measure that you set.  If on the Options menu you clear 
Automatic Unit Conversion, the software changes the unit of measure without recalculating 
the values! Therefore, to protect the integrity of your values, on the Options menu, click 
Automatic Unit Conversion. 

 To highlight the fields that are required for a calculation, on the Options menu, click Highlight 
Process Data. 

 
1. Open a calculation window for a relief valve item. 
2. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
3. Make sure that you enter process data in all of the fields in the data sheet that are required for 

calculation. 
 Although from the Pressure/Vacuum list, you can select Vacuum only or Pressure 

and vacuum, SmartPlant Instrumentation calculates pressure relief valves only, and not 
vacuum relief valves or dual mode pressure/vacuum relief valves.  The vacuum service set 
point value that you enter beside Valve Set Vacuum is displayed in the process data report 
for this instrument, but not in the calculation report. 

4. Click . 

5. Click  to display the Relief Valve Calculation dialog box. 
 The default selection for Use Rupture Disk at the inlet? is No.  Selecting Yes enables 

the Combination Capacity factor(Kc) field below. 
6. Select user-defined conditions for the relief valve: 

 ASME Capacity Certification requirement. 
 Sizing basis. 
 Rupture Disk at the inlet use. 

7. If you are using the Bellows valve style in liquid or water applications, you can also let 
SmartPlant Instrumentation calculate the correction factor for back pressure (Kw) by checking 
the Calculate check box. 

8. Type the required value for Effective coefficient of discharge (Kd) or click Default to use 
the SmartPlant Instrumentation default value. 

9. If available, type the required value for Combination capacity factor (Kc) or click Default to 
use the SmartPlant Instrumentation default value. 

10. Click the Calculate command button. 
11. Click Close to return to the calculation data sheet. 
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Calculate Sizing of a Relief Valve in Case of Fire 
Use this procedure to calculate the size of a relief valve in case of fire. 

 
 By default, SmartPlant Instrumentation updates tag values from the current unit of measure to 

their value in a new unit of measure that you set.  If on the Options menu you clear 
Automatic Unit Conversion, the software changes the unit of measure without recalculating 
the values.  Therefore, to protect the integrity of your values, on the Options menu, click 
Automatic Unit Conversion. 

 To highlight the fields that are required for a calculation, on the Options menu, click Highlight 
Process Data. 

1. With a calculation data sheet open for a relief valve item, scroll to the SIZING DATA section. 
2. From the Case (fire/non-fire) list, select Fire. 
3. Enter all the required values, especially the Area and Properties @relieving condition 

values.  Some properties vary for the Liquid and Gas fluid states. 
4. Complete the Relief Valve Calculation dialog box, and click the Calculate command button 

to get the calculation results. 
 Calculation is disabled for N/A or other fluid state. 

 The Sizing basis and other calculation results (the Calculated area, Selected area, and 
Orifice designation) appear on specifications based on SmartPlant Instrumentation library form # 
7. 
 

Calculate a Control Valve 
This procedure enables you to enter various values for calculating a control valve.  First, you 
define a CV calculation method and a flow coefficient standard (US or Europe) of CV sizing, then 
you select a noise calculation method and a CV body type.  Next, you enter values, perform the 
calculation, and view the results. 

 
 By default, SmartPlant Instrumentation updates tag values from the current unit of measure to 

their value in a new unit of measure that you set.  If on the Options menu you clear 
Automatic Unit Conversion, the software changes the unit of measure without recalculating 
the values.  Therefore, to protect the integrity of your values, on the Options menu, click 
Automatic Unit Conversion. 

 To highlight the fields that are required for a calculation, on the Options menu, click Highlight 
Process Data. 

1. Open a control valve calculation item. 
2. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
3. Make sure that you enter process data in all of the fields in the data sheet that are required for 

calculation. 

4. Click  to save the values. 
5. Do one of the following: 

 On the module toolbar, click . 
 Click Actions > Calculate. 

 Calculation is disabled for N/A or other fluid state. 
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6. In the Control Valve Calculation dialog box, from the Calculation method list, select the 
required calculation method, that is, ISA or IEC. 

 The IEC standard is 60534- 2-1 (1998) 
7. From the Flow coefficient list, select the required flow coefficient standard of CV sizing (Cv 

or Kv). 
 Kv is a European standard flow coefficient available for an IEC CV calculation method.   

Kv = Cv * 0.865 
8. Based on the value that you selected from the Fluid state list on the process data sheet, do 

one of the following: 
 If you set Liquid or Water, select Masoneilan or IEC from the Noise calculation 

method list. 
 If you set Gas/Vapor or Steam, select ISA or IEC from the Noise calculation method 

list. 
9. Enter hydrodynamic noise data as necessary. 

 This option is available only If under State you selected Liquid or Water, and under 
Noise Calculation Method you selected IEC. 

10. From the Body type list, select the required body type. 
11. Enter the required critical flow factor values (Fl, Cf) at minimum, normal, and maximum control 

valve coefficients. 
12. To define the required pressure drop ratio factor values (Xt) at minimum, normal, and 

maximum control valve coefficients, do one of the following: 
 To calculate the values automatically, as a function of critical flow, select Calculate 

pressure drop ratio factor. 
 Type the required values in the @Minimum, @Normal, and @Maximum fields. 

13. Type the Valve style modifier (Fd) value. 
14. To set the Relative capacity value, do one of the following: 

 Accept the value that SmartPlant Instrumentation calculates based on the calculation 
method and on the standard that you selected from the Flow coefficient list. 

 Type the value that you require. 
15. Type the required Number of flow passages. 
16. Enter the appropriate Valve size and select its unit of measure. 
17. To set the outlet pipe diameter, do one of the following under Outlet pipe diameter: 

 Manually type the value required. 
 Copy the internal pipe diameter value from either the Upstream line or Downstream line 

by selecting the correlating radio button and clicking Copy from. 
18. Click Calculate to carry out and display the calculation results. 
19. Examine the figures for results that may have to be re-calculated. 
20. To recalculate the control valve parameters, enter the new data and click the Calculate 

command button. 
21. Click Close to return to the calculation data sheet. 

 You can calculate a control valve and the relevant parameters even if the pipe wall thickness 
is not defined.  In this case, Noise is not calculated and a line of text in Notes section of the 
calculation sheet informs you that Noise will not be calculated because Pipe wall thickness is not 
defined. 
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Calculate the Maximum Permissible Thermowell Length 
A thermowell, inserted into a pipe, enables you to calculate tag temperature.  This procedure 
shows you how SmartPlant Instrumentation calculates the maximum permissible length of a 
thermowell.  The calculation is based on the maximum frequency that the thermowell can 
withstand.  The calculation complies with ASME PTC 19.3 Standard. 

 
 By default, SmartPlant Instrumentation updates tag values from the current unit of measure to 

their value in a new unit of measure that you set.  If on the Options menu you clear 
Automatic Unit Conversion, the software changes the unit of measure without recalculating 
the values.  Therefore, to protect the integrity of your values, on the Options menu, click 
Automatic Unit Conversion. 

 To highlight the fields that are required for a calculation, on the Options menu, click Highlight 
Process Data. 

1. Open a thermowell calculation item. 
2. If you defined multiple process cases, from the Case list, select the case that you want to 

calculate. 
3. Make sure that you enter process data in all of the fields in the data sheet that are required for 

calculation. 

4. Click  to save the values. 

5. Click  to open the Thermowell Calculation window. 
6. Select the appropriate velocity: minimum, normal, or maximum. 
7. Select the required values from the Nominal size of sensing element list. 
8. Enter additional values as need, and click Calculate. 
9. When done, click Cancel to return to the main calculation window for a temperature item. 
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S E C T I O N  1 4  

Special Calculations 
This section contains topics about making calculations that are different from the regular 
calculations already described in the help. 

In This Section 
Perform a Batch Calculation .......................................................... 185 
Calculate Multiple Cases ............................................................... 186 
Create a Hybrid Case .................................................................... 186 
 
 

Perform a Batch Calculation 
This option enables you to perform a calculation for a group of tags, all belonging to one of the 
following types: Control Valve, Flowmeter, Relief Valve, or Thermowell. 

 
 You must define process data before calculation. 
 After calculating tags, you can change parameters and then use this procedure to recalculate. 

1. On the Edit menu, point to Batch Calculation, and click the required instrument 
type.  SmartPlant Instrumentation opens the Batch Calculation window for instruments of 
that type. 

2. On the Actions menu, click Find Tag. 
3. In the Find Tag dialog box, under Search parameters, do one of the following: 

 Type and select filter parameters. 
 To display all tags, leave the boxes blank. 

4. Click Find. 

 
 For tags for which you defined multiple cases, each case is displayed in a separate row, 

which allows you to select one or more cases of a given tag for calculation. 
 To utilize the entire dialog box to display the results, click Show more search results. 

5. Select the tags that you want to calculate, and click OK. 
6. In the Batch Calculation window, for each tag for which you want to display or edit 

calculation parameters, select the tag and do the following: 
a. Click Actions > Type Data. 
b. Type and select data you want to change for the calculation, and click OK to return to the 

Batch Calculation window. 
7. Select the tags that you want to calculate, and do one of the following: 

 Click Actions > Calculate. 

 On the module toolbar, click . 
 If one of the selected tags has N/A or other set as Fluid state, calculation for that tag 

will fail with the following status: Cannot calculate N/A. 
Additional available actions: 
 For information on items with status Failed, on the Reports menu, click Batch Calculation 

Messages. 
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 To display process data for a specific tag in the Batch Calculation window, select a tag, and 
on the Reports menu click Process Data Report. 

 To display calculation data for a specific tag in the Batch Calculation window, select a tag, 
and on the Reports menu click Calculation Report. 

 If the selected tag has N/A or other set as Fluid state, the calculation report does not 
open, and a the following message is displayed: There is no report data. 

 To launch the calculation window for a specific tag  in the Batch Calculation window, select 
a tag, and on the Edit menu click Calculation Data. 

 If the selected tag has N/A or other set as Fluid state, the calculation window does 
not open, and a the following message is displayed: Cannot open calculation data for N/A 
or Other fluid state. 

 

Calculate Multiple Cases 
A given instrument or line is often used for more than one operating service.  For example, a 
dual-fuel control system might use a single supply line and control valve to carry various fuels, gas 
or liquid.  Each group of process data settings that you enter for a given instrument or line is called 
a case.  For more information, see Multiple Process Data Cases (on page 153). 
Use this procedure to calculate multiple cases of a given tag. 
1. In the Calculation module, create multiple cases for the tag that you want to calculate.  For 

details, see Creating Process Data Cases (see "Create Process Data Cases" on page 153). 
 You can create multiple cases in the Process Data module, and later open the tag in the 

Calculation module. 
2. For each case that you want to calculate, do the following: 

a. In the GENERAL section of the calculation data sheet, from the Case list, select the 
required case. 

b. Calculate the case. 
3. To generate a calculation report for the current case, on the Actions menu, click Reports. 
 

Create a Hybrid Case 
For a control valve for which you defined multiple cases, you can create a hybrid case from the 
minimum, normal, and maximum flow coefficient values (Cv/Kv) that you calculated for the various 
cases.  Use this procedure to create such a hybrid case. 
1. In the Process Data module or in the Calculation module, create multiple cases for the control 

valve for which you want to create a hybrid case.  For details, see Creating Process Data 
Cases (see "Create Process Data Cases" on page 153). 

2. Do one of the following to calculate every one of the cases: 
 In a Control Valve Calculation window for the given tag, calculate every one of the 

cases individually. 
 Perform a batch calculation procedure to select and calculate all of the cases of the given 

control valve tag. 
3. In the main window of the Calculation module, click Edit > Hybrid Case. 
4. On the Select Tag dialog box, click Find, and then select the tag for which you want to create 

a hybrid case. 
5. On the Hybrid Case dialog box, do the following to set values for the hybrid case: 

a. In the Case selection data window, select the value that you want to copy for the hybrid 
flow coefficient at minimum, and then click Add Minimum. 
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b. In the Case selection data window, select the value that you want to copy for the hybrid 
normal flow coefficient, and then click Add Normal. 

c. In the Case selection data window, select the value that you want to copy for the hybrid 
flow coefficient at maximum and then click Add Maximum. 

 
 Flow coefficients are displayed dynamically as Cv or Kv, depending on the method of 

calculation that you set for a given control valve in the Control Valve Calculation dialog box. 
 The software offers you the flexibility to select any value of a case for any level of the hybrid 

case — minimum, normal, or maximum. 
 

Calculation Reports 
These procedures are used for generating Calculation Reports. 
 

Principles of Generating Calculation Item Reports 
SmartPlant Instrumentation generates Calculation item reports by utilizing two predefined report 
templates: Liquid and Gas, with which the data of an instrument is associated.  An instrument 
may be a Control Valve, Flowmeter, Relief Valve, or Thermowell.  This is done through the 
association of an instrument, and its process function to its predefined template defined in the 
Process Data module. 
Each report is made up of a number of sections depending on the process function.  For example: 
the heading, information gathered from the Process Data module, data entered via the Body 
Type dialog box of the Calculation module, the Results and Coefficients section, and an area 
provided for Notes and Revisions. 

 When generating a report, only those items that include the saved calculation results 
appear on the list in the Find Tag dialog box. 
 

Generating Calculation Item Reports 
Use this procedure to do the following: 
 Generate calculation reports for instrument tags. 
 Add, edit, and delete calculation report revisions. 
 Assign, edit, and delete external drawing numbers assigned to the calculation reports. 

Generate a Calculation Item Report 
1. In the Calculation Module window, on the Reports menu, click the report that you require. 

 You can also generate a calculation item report when a calculation item window is 
open.  On the module toolbar click , or on the Actions menu, click Report. 

2. In the Find Tag dialog box, under Search parameters, do one of the following: 
 Type and select filter parameters.  For details, see Use Search Parameters to Find Tag 

Numbers (on page 30). 
 Leave the boxes blank to display all tags.  

3. Click Find. 
4. Select the tags for which you want to generate a report, and click OK. 
5. At the prompt, click Yes to display the calculation item report print preview.  You can do any 

of the following: 
 Adjust the zoom level. 
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 Save this report as an external file. 
 Perform, edit, or delete a revision on the calculation report. 
 Assign, edit or delete an external drawing number for the calculation report. 

6. On the module toolbar, click . 
 

Calculation Revisions 
The revision feature is used to keep track of the changes made to SmartPlant Instrumentation 
reports and items, including calculations.  It is important and useful to have a chronological 
description of the changes, dates of change, and a list of persons who approved them.  Use this 
procedure to add, edit, and delete revisions. 

Maintain Calculation Revisions 
1. Generate a report preview for the calculation (for details, see Generating Calculation Item 

Reports (on page 187)). 

2. In the Print Preview: Calculation Report window, on the print preview toolbar, click . 
3. In the Revisions dialog box, select one of the revision numbering methods (use P0, P1, 

P2...  for preliminary revisions or 0, 1, 2 / A, B, C etc.  for normal serial revisions). 

 
 When you first select a revision numbering method, several options are available to you, 

including preliminary revisions (designated by P0, P1, P2…).  Once you select one of the 
other revision methods, you will not be able to return to the preliminary revision method 
and this option will be disabled. 

 If you select any revision method besides Other, SmartPlant Instrumentation 
successively numbers each new revision. 

4. Click New to add a new revision data or click Edit to update an existing revision data line. 
5. Add or edit the revision data in the appropriate data fields. 

 The By data field contains the current user's initials by default, if the System 
Administrator has defined it as such. 

6. Under Drawing number, accept the default drawing number, or edit as required. 
7. To delete revisions do the following: 

a. Select the revision you want to delete. 
b. Click Delete. 

8. Click OK. 
 You can also maintain revisions in batch mode using global revisions (for more information, 

see Global Revisions (on page 44). 
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Create a New Tag in the Calculation Module 
You can create new tag numbers directly in the Calculation module, without having to open the 
Instrument Index module. 
1. In the Calculation Module window, on the Edit menu, point to Calculate, and then click one 

of the following: 
 Flowmeter 
 Thermowell 
 Control Valve 
 Relief Valve 

2. On the Enter Tag Number dialog box, type the name of the new tag number, and click OK. 
3. If the Select Instrument Type dialog box opens (because there is more than one record for a 

given instrument type acronym), select the required instrument type and click OK. 
4. On the Loop Name dialog box, do one of the following: 

 Accept the displayed loop number and click OK. 
 Type the loop number that you need and click OK. 
 To create the tag number without a loop association, click Cancel. 

5. On the Tag Number Properties dialog box, on the General tab, enter the appropriate values. 
6. Enter power supply values.  For details, see Enter Power Supply Data for Panels and 

Instrument Tags (on page 94). 
7. If the Process Data dialog box opens, select a fluid state and then click OK. 
8. In the process data sheet, enter and save the relevant process data values. 
 

Recommended Control Valve Characteristic 
This feature allows you to calculate the recommended control valve characteristic.  You can 
determine whether Linear or Equal Percentage valve is more suitable for a specific valve 
application. 

 Make sure that you enter the required pressure drop, pump drop, and system loss values in 
the process data sheet before performing this procedure. 

Calculate the Recommended Control Valve Characteristic 
1. Open the required calculation item sheet for a control valve calculation. 
2. On the Actions menu, click the Recommended Valve Characteristic option. 
3. Enter the required Critical value or click Default to utilize the default value. 
4. Click Calculate. 

 SmartPlant Instrumentation calculates the recommended valve characteristic and displays 
the result ( Linear or Equal %) both in this dialog box and the Notes window. 
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Entering Built-Up Back Pressure – Relief Valve 
The option enables you to enter a built-up back pressure value, which is taken into account for 
calculation when sizing the relief valves.  The result is displayed in the NOTES section of the 
calculation data sheet, under General Notes. 
1. With a calculation data sheet open for a relief valve item, on the Actions menu, click Enter 

Built-up Back Pressure. 
2. In the Built-up Back Pressure dialog box, type the required value, select the unit of measure 

and click OK. 
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The Specifications module provides the means to efficiently generate detailed specification 
documents (often referred to as Specs).  This is helpful for engineering and ordering procedures 
and provides a useful permanent record for checking installed instruments.  The Specifications 
module also incorporates data from the Instrument Index, Process Data, and Calculation modules 
into generated documents. 
You can generate any type of specification (that is, single-tag instrument spec, composite spec, 
multi-tag spec, and so forth) in the Specifications module.  Also, it is possible to generate 
single-tag instrument specs in the Domain Explorer.  Note, however, that if you want to generate 
a spec in the Domain Explorer, you must first assign a specific spec form to the instrument type 
profile.  A generated specification automatically appears in the Domain Explorer, under the 
items for which you generated the specification.  You can open an existing spec either from the 
Domain Explorer, Specifications module, or Instrument Index Standard Browser view. 
When printing a specification, we recommend that the print sheet size be either A4 or 
Letter.  Note, however, that if the title block assignment method in the current domain is defined 
as Standard (used in all modules), you need to adjust your title block before printing specs 
using the Letter size.  For details, see Spec Title Blocks (on page 265). 
 

Specifications Module Window 
The Specifications Module window is the main window of the Specifications module, provides 
the means to efficiently generate detailed specifications for various item types.  It opens when you 
click  on the toolbar or on the Module menu, click Specifications.  You can have multiple 
open modules.  The number of open modules depends on your computer resources. 
Using the toolbar options and menu commands available in the Specifications Module window, 
you open other windows and dialog boxes where you perform various operations to define and 
manage you specifications. 
The window consists of the following sections: 
 Menu bar — Provides access to all the Specifications Module Commands (see 

"Specifications Module Window Commands" on page 192). 
 Application work area — The area where other Specifications module windows and dialog 

boxes open. 
 Toolbar — Provides access to the most common Specifications module commands. 
 Status bar — Shows the current status or the pertinent Microhelp message, plant hierarchy 

items, and the current date and time. 
 

Specifications 
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Specifications Module Window Commands 
This topic lists and describes menus and commands that are available in the Specifications 
Module window. 

 The Reports menu commands are available in Specifications Module, <Item> 
Specification, Composite Specification, and Multi- Tag Instrument Specification 
windows.  For details of the available reports and their descriptions, see Specification Report List 
(on page 303). 

Icon Edit Menu Command Description 

 Page Editor Allows you to edit existing pages or create new pages on the 
basis of existing pages.  You can then associate spec 
pages with forms. 

 Section Editor Allows you to edit composite page sections you created in 
InfoMaker.  You can then integrate sections with spec 
pages to define pages as composite. 

 Form Editor Allows you to create a new specification form or edit an 
existing one. 

 Format Editor Allows you to create or edit multi-tag specification formats. 

 Spec Data Dictionary Allows you to assign user-defined headers for Spec Form 
Field reports.  Also, you can assign names to the data fields 
used in a form browser, select fields for a form browser, 
protect field headers from editing in the form data template, 
and so forth. 

None Form Data Template 
Editor 

Allows you to manage form data templates. 

 

Icon Actions Menu 
Command 

Description 

 Open Specification Allows you to open an existing specification or create a new 
specification for a specific item type that you select. 

None Save as Files Opens a dialog box where you specify a target folder for 
saving instrument specifications in either .isf or .psr format, 
and then save one or more instrument specifications to the 
specified folder (only available when the specification item 
type is Instrument). 

None Save as Excel Saves a batch of specifications in Excel format (only 
available when the specification item type is Instrument). 

None Import Data Opens a dialog box where you import data from .isf files to 
instrument specifications in batch mode. 

None Title Block Styles Adds a new customized title block to a specification 
form.  This option is not available if the System 
Administrator, when making or modifying domain definitions, 
selected the Standard title block assignment method. 



 Specifications 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 193 
 

Icon Actions Menu 
Command 

Description 

None Associate Title Block Associates a customized title block with a specification 
form.  This option is not available if the System 
Administrator, when making or modifying domain definitions, 
selected the Standard title block assignment method. 

None Change Spec Forms Changes the form associated with the selected 
specifications. 

None Change Master Tags Redefines the master tag number of multi-tag specification.
None Retrieve Custom 

Pages as PSR Files 
Allows you to retrieve custom pages from the database and 
save them in a specified folder as .psr files. 

None Regenerate Library 
Forms 

Allows you to rebuild all specification forms of the 
SmartPlant Instrumentation default library. 

None Regenerate Formats Allows you to rebuild all multi-tag specification formats. 
None Spec Revisions Opens a dialog box you use for viewing and printing 

revisions. 
None Manage Spec 

Revisions 
Opens a dialog box where you save revisions to the 
database, in .psr format, or in .zip format. 

None Specification Views Opens a dialog box where you associate specification views 
with the SmartPlant Instrumentation database. 

None Delete Form Data 
Template 

Opens a dialog box where you delete a form data template.

None Delete Specifications Opens a dialog box where you delete specifications in batch 
mode. 

 

Icon Options Menu 
Command 

Description 

None History Options Opens a dialog box where you set specification history 
indication.  History indication is only possible if the System 
Administrator has enabled the use of audit trail options in 
your domain.  Enabling this option disables the Compare 
function available in the print preview. 

None Mark Changes Marks the changes in the current specification for the dates 
you selected in the History Options dialog box.  This 
option is available only if the System Administrator has 
enabled the use of audit trail options in the current 
domain.  Enabling this option disables the Compare 
function available in the print preview. 
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Principles of Generating Specifications 
SmartPlant Instrumentation generates a specification based on a pre-defined spec form that you 
associate with the source item.  Each form consists of one or more spec pages, which, in turn can 
contain one or more sections.  A spec page that does not include sections you define in the 
Section Editor is considered a single-section page.  A spec page that contains sections you 
define in the Section Editor is referred to as composite. 
When you first create a specification for an item, you have to specify the form number to create the 
item-form association.  On subsequent occasions, you only need to specify the item number to 
display the specification.  It is only possible to generate a spec in the Specifications module.  On 
generating a spec, the software automatically creates a unique document number for the spec. 
Each specification is made up of data portions.  For example: general data, process data, 
construction data, purchase data, a note field, and a specification header, which is the title 
block.  The General Data portion of the spec includes details that were entered in the Instrument 
Index module.  The Process Conditions portion values are derived from the Process Data 
module (if available) along with calculation results from the Calculation module (if available).  If 
you defined multiple cases for a given tag, the specification displays the process data from the 
governing case. 
You can generate the following types of specifications: 
 Single-item specification — a document with details about a single item, or a specific process 

data case of an instrument.  The source form for such a document can only contain 
single-section pages. 

 Multi-tag instrument specification — a document with details about two or more 
instruments.  A multi-tag instrument specification includes common pages with fields that are 
identical for all of the instruments, and a SEE LIST page with values that differ from instrument 
to instrument.  A multi-tag specification is only available when the item type is 
instrument.  The source form for such a document can only contain single-section pages. 

 Loop composite specification — a document with details about a loop and its instrument 
tags.  The source form for such a document must contain sections you define in the Section 
Editor: one loop section and one or more instrument sections. 

 Instrument composite specification — a document that integrates data about several 
instruments or process data cases of an instrument.  In contrast to multi-tag instrument 
specifications, an instrument composite specification does not have common pages and can 
include tags whose process functions are not identical.  The source form for such a document 
must contain sections you define in the Section Editor.  Each section in a composite spec 
page contains data pertinent to a specific instrument tag or process data case. 

It is possible to generate specs either in the Specifications module, or in the Domain 
Explorer.  In the Specifications module, you can generate one spec at a time, and open this spec 
on completing the generation.  In the Domain Explorer, you can only generate instrument specs 
but you can generate specs in batch mode, provided that you defined specification options in the 
instrument type profile of the instruments you select in the Domain Explorer.  For details, see 
Define Specification Options in an Instrument Type Profile (on page 197). 

 
 If you want to generate a non-instrument spec (for example, a panel spec or a hook-up item 

spec), you must first restore the appropriate library forms. 
 You cannot generate specifications for virtual tags. 
 It is only possible to generate one spec at a time. 
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Specification General Operations Common Tasks 
The following tasks deal with such operations as batch generation and deletion of specs, 
describes the ways of defining spec document numbers and opening existing specs, and also 
addresses other miscellaneous operations you can perform with specs in SmartPlant 
Instrumentation. 

Define Specification Options in an Instrument Type Profile 
Use this procedure to associate a specification form, multi- tag list format and form data template 
with a particular instrument type profile.  This way you set the software to apply the defined profile 
options when generating instruments belonging to this instrument type.  For more information, 
see Define Specification Options in an Instrument Type Profile (on page 197). 

Generate Instrument Specs in Batch Mode 
Use this procedure to generate specs for instruments you select in the Domain Explorer, or 
Instrument Index Standard Browser view.  For more information, see Generate Instrument Specs 
in Batch Mode (on page 198). 

Open a Spec from the Instrument Index Standard Browser View 
Use this procedure to open an existing specification from an Instrument Index Standard Browser 
view.  To open a spec, you must make sure that on the Preferences dialog box, under Browser 
view, the Open specification sheet setting is either Always or Ask User.  For more information, 
see Open a Spec from the Instrument Index Standard Browser View (on page 198). 

Open a Spec from the Specifications Module 
Use this procedure to find an item and the form number on which the item specification is based 
and open it the Specifications module.  For details, see Open a Spec from the Specifications 
Module (on page 199). 

Create a Tag Number in the Specifications Module 
Use this procedure to create an instrument tag in the Specifications module.  This allows you to 
generate an instrument specification without having to create a new instrument tag first in the 
Instrument Index module or the Domain Explorer.  For more information, see Create a Tag 
Number in the Specifications Module (on page 199). 

Delete Specs in Batch Mode 
Use this procedure to delete a batch of specifications.  You can use the same procedure if you 
need to delete only one specification.  Using this procedure, you can delete single- tag specs and 
multi-tag specs.  It is only possible to delete specs from the Specifications module.  The software 
does not allow you to delete a spec that is currently assigned to a Specification Binder package or 
revised in the Document Binder module.  For more information, see Delete Specs in Batch Mode 
(on page 200). 

Add Expanded Notes and Remarks 
Use this procedure to add text in the Note tab of a specification if the space in the note box in the 
specification data sheet is insufficient to enter all the text string.  For more information, see Add 
Expanded Notes and Remarks (on page 200). 
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Ways of Defining a Spec Document Number 
This topics lists the Specifications module options that allow you to define a document number for 
a spec.  If the Domain Administrator has set the document number naming convention for specs, 
the software automatically creates a default document number on generating a 
specification.  You can either accept this number or modify it as you require.  For more 
information, see Ways of Defining a Spec Document Number (on page 201). 
 
 

Define Specification Options in an Instrument Type Profile 
1. In the Instrument Index module, open the Instrument Type Profile dialog box for an 

instrument type for which you want to define specification options.  For details, see Define an 
Instrument Type Profile (on page 84). 

2. On the General tab, select Include instrument specification. 
3. From the Specification form list, select a form you want to set as the default form for all 

instrument that belong to the current instrument type. 

 
 The list contains specification forms that are assigned to the process function specified on 

the Instrument Types dialog box. 
 If the specified form is defined as a multi-tag form, you can then select a specific format 

from the Multi-tag list format dialog box. 
4. If you selected a multi-tag spec form from the Specification list, from the Multi-tag list 

format list, select a specific format for the multi-spec form. 

 
 The software creates the specification as a master tag in a multi-tag specification.  In this 

case, since you cannot move a master tag to a different multi-tag specification or redefine 
it as a single tag specification, the only way to change the specification for this tag is to 
delete the specification and then reassign a new specification to the tag. 

 If you do not select any format, the software creates the spec as a single-tag spec even if 
the source form is defined as a multi- tag form.  Afterwards, you can move this spec it to a 
new multi-tag spec or an existing one. 

5. If you defined a form data template for the selected spec form in the Specifications module, 
from the Copy data from template list, select a template from which you want to copy the 
default data to a generated spec. 

6. On the Instrument Type Profile dialog box, click OK. 
7. On the Instrument Types dialog box, click OK. 
8. On the menu bar, click File > Preferences. 
9. On the Preferences dialog box, click Instrument Index > Profile page, do one of the 

following: 
 Select Specifications and maintenance events if you want to use the defined profile 

options automatically when creating tag numbers. 
 Clear Specifications and maintenance events if you want to create tag numbers 

without any specifications.  If you then manually generate a specification for the created 
tag, the software applies the existing instrument type profile options. 
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Generate Instrument Specs in Batch Mode 
1. Do one of the following: 

 In the Instrument Index module, open the Instrument Index Standard Browser view, and 
then, select one or more instruments. 

 Press F7 to open the Domain Explorer and then, in the Items pane, select the 
instruments you require. 

2. Right-click the selected instruments, and then, on the shortcut menu, click Actions > 
Generate a Specification. 

 The software generates specs according to the profile settings defined for the instrument 
type to which the selected instrument tags belong.  For example, if you want to add certain 
instruments to a see list of a multi-tag spec, make sure that on the Instrument Type Profile 
dialog box, you specified both the spec form number and the see list format.  For details, see 
Define Specification Options in an Instrument Type Profile (on page 197). 

3. On the Results dialog box, view the spec generation results, and then click Close. 
 The software does not open the generated specs automatically because you cannot 

open several specs at a time.  If you want to open a spec, select a specific instrument and 
then, on the shortcut menu, click Reports > Specification. 

 

Open a Spec from the Instrument Index Standard Browser View 

Prerequisite 
You can only perform this procedure if you have already generated a spec for the selected tag in 
the Specifications module.  Also, to open a spec, you must make sure that on the Preferences 
dialog box, under Specifications > General > Browser view options, the Open specification 
sheet setting is either Always or Ask User. 
1. In the Instrument Index Standard Browser View, select an instrument. 

2. On the main toolbar, click . 

See Also 
Composite Specifications (on page 259) 
Multi-Tag Specs (see "Multi-Tag (See List) Specifications" on page 245) 
Non-Instrument Specs (see "Non-Instrument Specifications" on page 257) 
Pipe Specs (on page 309) 
Save, Export, and Import Options (on page 281) 
Single-Tag Specs (see "Single-Tag Specifications" on page 235) 
Process Data Case Specs (on page 241) 
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Open a Spec from the Specifications Module 
1. Do one of the following: 

 On the Modules menu, click Specifications. 

 On the toolbar, click . 
2. On the Actions menu, click Open Specification. 
3. On the Open Specification dialog box, from the Item type list select the type of the item 

whose spec you want to open. 
4. If the item type is Instrument, from the Tag class list, select the appropriate tag class. 
5. With the mouse pointer in the Item number box, do the following: 

a. Click Find to open the Find Items dialog box. 
b. In the boxes in the upper part of the dialog box, type or select the parameters for the 

properties that you want to find. 
c. Click Find to display a list of items according to the search parameters that you have 

selected. 
d. Select the required item from the retrieved list. 
e. Click OK to accept your choice and return to the Open Specification dialog box. 

6. With the mouse pointer in the Form number box, do the following: 
a. Click Find to open the Select Specification Form dialog box. 
b. Select the required form and click OK. 

7. On the Open Specification dialog box, click OK to open the spec associated with the item 
that you selected. 

See Also 
Composite Specifications (on page 259) 
Multi-Tag Specs (see "Multi-Tag (See List) Specifications" on page 245) 
Non-Instrument Specs (see "Non-Instrument Specifications" on page 257) 
Pipe Specs (on page 309) 
Save, Export, and Import Options (on page 281) 
Single-Tag Specs (see "Single-Tag Specifications" on page 235) 
Process Data Case Specs (on page 241) 
Open a Spec from the Instrument Index Standard Browser View (on page 198) 
 

Create a Tag Number in the Specifications Module 
1. Click File > Preferences > Specifications, and on the General tab, under Tag creation, 

select Allowed. 
2. On the Specifications Module window menu bar, click Actions > Open Specification. 
3. On the Open Specification dialog box, from the Item type list, select Instrument. 
4. On the Item number box, type the number of the instrument that you want to create and click 

Yes when prompted to create a new tag number. 
5. If the Select Instrument Type dialog box opens, select the appropriate instrument type and 

click OK. 
6. On the Loop Number dialog box, accept the displayed loop number or type a new one as 

required, and then click OK. 
7. On the Tag Number Properties dialog box, define the tag properties as you require, and then 

click OK. 
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 At this stage, you can define the spec form number and generate a specification for the 
instrument tag that you have created. 
 
 

Add Expanded Notes and Remarks 
 In a given specification, do the one of the following: 

 Click Actions > Expand Notes. 
 Click the Notes tab in the specification. 

 
 On SQL Server, the Note sheet can accept up to 255 characters; on Oracle or Sybase 

Adaptive Server Anywhere, you can type up to 2000 characters. 
 Non-English, special character ASCII code, used in a note, is not displayed correctly in print 

preview. 

See Also 
Composite Specifications (on page 259) 
Multi-Tag Specs (see "Multi-Tag (See List) Specifications" on page 245) 
Non-Instrument Specs (see "Non-Instrument Specifications" on page 257) 
Pipe Specs (on page 309) 
Save, Export, and Import Options (on page 281) 
Single-Tag Specs (see "Single-Tag Specifications" on page 235) 
Process Data Case Specs (on page 241) 
 

Delete Specs in Batch Mode 
1. With the Specifications window open, on the Actions menu, click Delete Specifications. 
2. In the Select Items dialog box, find and select the items whose specs you want to delete. 

 
 If you created instrument specifications per tag case, you can delete specifications on a 

per-case basis.  For example, if you applied three process data cases to a tag, three 
records appear in the Search results data window.  The Case column values indicate 
whether instrument tags have tag process data cases. 

 If the tag number selection includes a master tag, the software prompts whether you want 
to perform or cancel the deletion of the specifications.  You have an option to cancel the 
deletion because when you delete a master tag, the software dissociates all the other tags 
from the multi- tag specification to which the master tag belongs. 

3. In the Delete Specifications dialog box, click Run. 

 
 If the software could not delete a specification, the source item appears in the Items skipped 

during deletion data window.  You can print out the item list, if needed.  These records are 
not saved after you close the Delete Specifications dialog box. 

 When you delete a specification, the software automatically deletes all the associated 
revisions as well, whether you saved them to the database, or as files.  The software removes 
revisions that were saved as files from the Manage Spec Revisions dialog box, and also from 
the folders to which they have been saved. 
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  Deleting a spec does not affect process data.  The software only deletes the specification 
document, together with the document number and associated revisions, whether you saved 
them to the database, or as files.  The software removes revisions that were saved as files from 
the Manage Spec Revisions dialog box, and also from the folders to which they have been 
saved. 
 
 

Ways of Defining a Spec Document Number 
In the Specifications module, you have the following ways of defining a spec document number: 
 When generating a new spec — On the New Specification dialog box, in the Document 

number box, you can modify the default document number as you require.  The software 
always generates automatically a document number for a specification, regardless of whether 
the document number naming convention exists.   If the domain Administrator has not defined 
a naming convention for spec document numbers, the software creates the document number 
using the item tag name as a source, and append the -SP suffix. 

 In the spec title block — You can open a spec and define the document number in the Doc No. 
field of the title block. 

 In the Revisions dialog box — With a spec displayed, you open the Revisions dialog box 
and, in the Document number box, define the document number. 

 
 The document number string can contain up to 50 alpha-numeric characters, including 

spaces. 
 The document number must be unique. 
 If you remove the document number, the current spec document does not appear in the 

Document Explorer. 
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Specification Pages 
Specification pages are the primary templates for spec forms, on which you base specs.  Spec 
pages enable you to categorize data within a specification form.  For example, a specification 
form can contain a thermowell specification page, a control valve specification page, and a large 
note page. 
SmartPlant Instrumentation provides a default library of spec pages you can use in spec forms.  A 
spec is always associated with a specific process function.  If needed, you can select a different 
process function for a page, provided that this page is not in use in specs.  A spec page contains 
a number of data fields, which correspond to table columns in the database, and also contains 
field headers, which correspond to column headers in the database.  You can customize the data 
fields and fields headers to fit specific requirements.  You cannot, however, create new pages in 
SmartPlant Instrumentation. 
All spec pages are based on the A4 print sheet size.  It is also possible to use the Letter print 
sheet size when printing specs.  Note, however, that if the title block assignment method in the 
current domain is defined as Standard (used in all modules), you need to adjust your title block 
before printing specs using the Letter size.  For details, see Spec Title Blocks (on page 265). 
You open and manage spec pages in the Page Editor of the Specifications module.  Then you 
can use the Edit Fields and Headers floating toolbar options to modify the spec page field layout 
without having to use a third-party interface, such as InfoMaker.  Note, however, that if you want 
to assign new select lists or drop-down data window to spec page fields, you must use InfoMaker. 
 
 

Open a Page 
Use this procedure to open a spec page in the Page Editor. 

 If you want to open a page that is based on a spec form that was imported in the 
Administrations module, you must first regenerate this page. You can regenerate a single page or 
multiple pages in batch mode. For more details, see Regenerate a Specification Page (on 
page 205) or Regenerate Pages in Batch Mode (on page 205). For information about importing 
specification forms, see SmartPlant Administration Help, Domain and Project Administration > 
Add-Ins >Import Spec Forms. 
1. In the Specifications Module window, do one of the following to open the Page Editor: 

 Click Edit > Page Editor. 

 On the toolbar, click . 
2. Do one of the following: 

 On the menu bar, click Actions > Open Page. 

 On the toolbar, click . 
3. On the Select Specification Page dialog box, select a page. 

 
 On the Select Specification Page dialog box, selected Custom check boxes indicate 

pages that you have customized. 
 You can click Properties to change the name and description of the page you want to 

open. 
4. Click OK to open the page in the Page Editor. 
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Open a Page from an External File 
Use this procedure to open in the Page Editor a spec page from a .psr file. 

 If you want to open a page that is based on a spec form that was imported in the 
Administrations module, you must first regenerate this page. You can regenerate a single page or 
multiple pages in batch mode. For more details, see Regenerate a Specification Page (on 
page 205) or Regenerate Pages in Batch Mode (on page 205). For information about importing 
specification forms, see SmartPlant Administration Help, Domain and Project Administration > 
Add-Ins >Import Spec Forms. 
1. In the Specifications Module window, do one of the following to open the Page Editor: 

 Click Edit > Page Editor. 

 On the toolbar, click . 
2. Do one of the following: 

 Click Actions > Open File. 

 On the toolbar, click . 
3. On the Open File dialog box, navigate to the folder where your .psr file is located and select 

the file. 
4. Click OK.  After clicking OK, one of the following scenarios is possible: 

 The software automatically opens the .psr file as a page in the Page Editor. 
 The software prompts you to regenerate the page first because some required columns 

are missing in the page.  In this case, click Yes to regenerate the page automatically and 
then open it in the Page Editor. 

 If the spec item type is not defined in the source .psr file, the software displays the Select 
Item Type dialog box, where you must select the target item type and assign it to the .psr 
file.  Clicking OK on the Select Item Type dialog box opens the page in the Page Editor. 

 

Display Data Field Names 
Use this procedure to display the names of the data fields that a particular page contains. 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click  to display in the Field Selection area all 
the field names which are used in the currently open page. 

4. Click  again to hide the display of the field names. 
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Display a List of Forms that Include the Current Page 
You can use this procedure to check whether there are any spec forms that already include a 
specific page that you open in the Page Editor.  If you make any changes in this page and save it, 
the software automatically updates all the forms that include this page. 
1. In the Specifications Module window, do one of the following: 

 Click Edit > Page Editor. 

 On the toolbar, click . 
2. On the Page Editor menu bar, click Actions > Form List. 
 

Regenerate a Specification Page 
This procedure enables you to correct discrepancies that can occur on a specific single-section 
spec page, and to influence the display of various tables and table columns in the Table Column 
List pop-up window in the Page Editor.  When you implement this procedure, SmartPlant 
Instrumentation automatically eliminates duplicate data fields on the current page and updates the 
definition of the data fields included in the current page according to their current table column 
definitions in the database. 

 You can only use this procedure to regenerate a single-section page.  If you need to 
regenerate a composite page, you must regenerate specific sections in the Section Editor. 
1. Open a spec page in the Page Editor. 
2. On the menu bar, click Actions > Regenerate Page. 
3. On the Regenerate Page dialog box, under Select tables and views, select a check box for 

each table or view from which you want to display additional columns in the Table Column 
List pop-up window. 

  Some tables, such as Component and Flow, do not appear in the list. These tables 
contain mandatory fields and are also regenerated.  The fields will appear in the Table 
Column List window when you open Edit > Column List. 

4. Under Show Columns, click Show for each required table or view. 
5. Under Select columns, do one of the following: 

 Select the Select all check box to select all the columns in the table. 
 Hold down the Ctrl key and select or clear specific columns as desired. 
 Click OK. 

 

Regenerate Pages in Batch Mode 
This procedure enables you to select several single-section spec pages and automatically 
eliminate duplicate data fields on the selected pages and update the definition of the data fields 
included in the pages according to their current table column definitions in the database. 

 Usually, batch regeneration of spec pages is required only once, after a version 
upgrade.  Therefore, we recommend that your Domain Administrator perform this operation after 
upgrading SmartPlant Instrumentation. 
1. In the Specifications Module window, do one of the following to open the Page Editor: 

 Click Edit > Page Editor. 

 On the toolbar, click . 
2. On the menu bar, click Actions > Regenerate Pages in Batch Mode. 
3. Select one or more pages. 
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 In the Page Editor, you can only regenerate single-section pages; therefore, the 
Regenerate Pages in Batch Mode does not display any pages that have multiple sections 
(composite pages).  If you need to regenerate composite pages, you must regenerate 
specific sections in the Section Editor. 

4. Click Run to start the regeneration process and view the regeneration results in the Result 
column on the Regenerate Pages in Batch Mode dialog box. 

 

Save a Page to the Database 
Use this procedure to save a page to the SmartPlant Instrumentation database.  You can save 
any page to the database, whether this is a page you open from an external file, or a library page 
you modified. 
To save the page to the database under a new name, or to save a page opened from an external 
file to the database: 
1. Open a spec page in the Page Editor. 
2. Click Actions > Save as Page. 
3. On Save as Page dialog box opens, do one of the following: 

 To create a new page, click New. On the dialog box that opens, type a unique name and 
an optional description, and then click OK. 

 To overwrite an existing page, highlight the page you wish to replace on the 
Specification Page column and then click OK. When asked to confirm overwriting the 
existing page, click Yes. 

 
 Clicking Actions > Save also saves the page to the database (under the same name as the 

currently open page).  You cannot use the Actions > Save option to save a page opened 
from an external file. 

 After you save a library page whose data fields you modified, the software treats it as a custom 
page. 

 

Save a Page as an External File 
Use this procedure if you need to save a page as an external file so that it can be used with a 
third-party application, such as InfoMaker.  You can save a page either as a .psr (PowerSoft 
Report) file or a .wmf (Windows METAFILE) graphic. 
1. Open a spec page in the Page Editor. 
2. Do one of the following: 

 Click Actions > Save as File. 

 On the Page Editor toolbar, click . 
3. On the Save As dialog box, navigate to the required folder and type the target file name. 

 You can save the page as a .psr (PowerSoft Report) file or a .wmf (Windows METAFILE) 
graphic. 

4. Click OK to save the file. 
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Delete a Page 
Use this procedure to delete a specific spec page that is not associated with forms, that is, a page 
you opened from a file, or a new page that you created on the basis of an existing page.  Also, you 
can delete a page that was previously associated with a library form but you decided to retain this 
page after deleting the form.  After deleting such a page, you can restore it automatically by 
restoring the library form that the page is based on.  If you want delete a page you saved to the 
database from an external file, we recommend that you first save this page as a file.  After 
deleting such a page, you can restore it by opening it from the external file. 
1. On the Page Editor menu bar, click Actions > Delete Page. 
2. On the Select Specification Page dialog box, select the page you want to delete and click 

OK. 
 In the Page Editor, you can only delete a specific page, provided that it is not in use in a 

spec form.  If you want to delete all pages included in a particular form, you need to delete the 
entire form.  If this form is a library form, you can restore the deleted pages automatically 
when restoring this form.  Note, however, that when restoring the form, the software only 
restores the library pages, not pages you opened from an external file and then included in 
this form. 

 

Create a Large Note Page 
Use this procedure to create a large note page on the basis of any existing page.  A large note 
page is a page that consists of a text area and a title block.  A large note can appear on a separate 
page.  To create a large note on a separate page, you must use only the spec_note_large column 
of the add_spec9 table.  When creating or modifying a specification form, you can add a large 
note page to display large note text in the appropriate specifications.  You create a new large note 
page on the basis of any existing page. 
In a print preview for a specification that contains a large note, the software displays a large note 
on a separate page in which you can scroll up and down to view the note text.  When printing a 
specification with a large note page, the software automatically counts the total number of sheets 
and divides the large note page into separate sheets, depending on the note text length. 
1. In the Specifications Module window, do one of the following to open the Page Editor: 

 Click Edit > Page Editor. 

 On the toolbar, click . 
2. Do one of the following: 

 On the menu bar, click Actions > Open Page. 

 On the toolbar, click . 
 We recommend that you use a page with the General process function.  You need to 

perform a separate procedure to change the page process function to General.  For details, 
see Select a Different Process Function for a Page (on page 208). 

3. Do one of the following: 
 On the menu bar, click Actions > Regenerate Page. 

 On the toolbar, click . 
4. On the Regenerate Page dialog box, under Select tables, views, and columns, select the 

check box for the add_spec9 table. 
5. In the cell adjacent to the add_spec9 table cell, click Show to display the spec_note_large 

column in the Column Name data window. 
6. Click OK to regenerate the page. 
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7. Do one of the following to display the Edit Fields and Headers floating toolbar: 
 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
 Before adding the spec_note_large column to the current page as a data field, 

make sure that the page does not contain any other data fields apart from the title block.  If 
the page is not empty, you must delete all of the data fields.  For details, see Delete Data 
Fields (on page 223). 

8. On the Edit Fields and Headers floating toolbar, click . 
9. In the Table Column List pop- up window, select spec_note_large. 
10. Drag the spec_note_large column from the Table Column List pop-up window and drop it 

anywhere on the page. 

11. Click  to close the Table Column List pop-up window. 
12. For your convenience, if needed, resize the spec_note_large data field as follows: 

a. Point to the spec_note_large field border so that the cursor changes to a double- headed 
arrow. 

b. Resize the spec_note_large field by dragging the field borders to either side so that the 
field occupies the entire page area, apart from the title block 
 You do not have to resize the spec_note_large data field exactly.  When printing a form 

that with a large note page the software resizes the spec_note_large data field automatically 
so that the spec_note_large data field occupies the entire area of the printed specifications. 

13. On the Actions menu, click Edit Fields and Headers to close the floating toolbar. 
14. Save the large note page to the database. 

 If required, you can use the spec_note_large field on a data page.  By default, a data page 
in SmartPlant Instrumentation is the first page in a specification form and contains various field 
values. 

See Also 
Regenerate a Specification Page (on page 205) 
Save a Page to the Database (on page 206) 
 

Select a Different Process Function for a Page 
You can select a different process function for an existing page.  In this way you can use the same 
page for instrument tags with different process function types.  You cannot change the process 
function of a page that is already in use in specs. 
1. Open a spec page in the Page Editor. 
2. Click Actions > Change Process Function. 
3. Select the target process function and click OK. 

 
 You cannot change the process function of a page that is already in use in specs.  In this 

case you are prompted to save the page under a different name. 
 When changing the page process function, the software automatically eliminates 

duplicate data field names in the current page, and also updates the definition of the data 
fields included in the current page according to their current table column definition in the 
database. 

 Changing the page process function may prompt a warning, preceded by SQL command 
error messages.  These messages inform you that the page for which you are changing 
the process function contains undefined values, for example, specification custom fields. 
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 The data fields that caused SQL statement errors are not available in the page after the 
process function change takes effect. 

4. On the Regenerate Page dialog box, select a check box for each table or view from which you 
want to change the display of table columns in the Table Column List pop-up window. 

 When you changed the process function, the software automatically updated the table 
columns available to you in the Table Column List pop-up window. 

5. Under Show Columns, click Show for each required table or view. 
6. Under Select columns, do one of the following: 

 Select the Select all check box to select all the columns in the table. 
 Hold down the Ctrl key and select or clear specific columns as desired. 

7. Click OK. 
 

Set the Tab Order of the Fields on a Page 
You can set the sequence in which you move the cursor in the page you are editing.  This way you 
determine which fields the cursor moves to when you press the Tab key. 
1. Open a spec page in the Page Editor. 
2. Click Actions > Tab Order to display the tab numbers on the page. 
3. Set the field order by typing in sequence numbers (20, 30, 40, and so forth) in the fields that 

you want to sequence. 

 
 Assigning a zero (0) to a field means that this field becomes non-editable in a generated 

spec.  Some fields are read-only by default and not available for editing even if you 
assign a tab sequence to them. 

 The zero number applies to all fields you added in the page using InfoMaker.  Therefore, 
in a spec page containing fields added in InfoMaker, after defining the tab order, you must 
switch to the default tab order.  For details, see Switch to the Default Tab Order (on 
page 209). 

4. When done, click Actions > Tab Order once again, to clear the tab number display. 
 

Switch to the Default Tab Order 
You can switch from the tab order in the page you are currently editing to the default tab 
order.  This procedure is necessary if you imported a spec page you edited in InfoMaker and this 
page contains fields added in InfoMaker.  After you set the tab order of the fields on such a page, 
the fields added in InfoMaker are not editable because the zero tab order number is assigned to 
them.  Switching to the default tab order enables you to remove the zeros automatically and 
assign sequence numbers for editing the fields. 

 This action overwrites the tab order in the currently open page with the default tab 
order.  After performing this procedure and saving the page, it is not possible to revert to the 
original tab order. 
1. With the specification page open for editing, click Actions > Tab Order to display the tab 

numbers on the page according to the current tab order. 
2. Click Actions > Default Tab Order. 
3. Click Actions > Tab Order to clear the tab number display. 
4. Save the spec page. 
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Retrieve Custom Pages as PSR Files 
Use this procedure to retrieve one or more custom pages from the database as .psr files.  In the 
target folder that you specify, the software saves each page as a separate .psr file with the name 
PAGE<page ID number>.psr.  You can use this procedure if you need to back up pages before 
editing them in the Page Editor, or if you need to share pages with users outside of a given 
SmartPlant Instrumentation network. 
1. On the Specifications Module window menu bar, click Actions > Retrieve Custom Pages 

as PSR Files. 
2. Select one or more custom pages. 
3. Under Target folder, accept the displayed folder path, or click Browse do specify a target 

folder for saving the selected custom pages as .psr files. 
 The path displayed in the Target folder box is the path set for the PSR working folder 

option on the Specifications > General page of the Preferences dialog box. 
4. Click OK. 
 

Requirements for Creating User-Defined Views 
When creating a view in InfoMaker or Internal Setup Utility, you run the CREATE VIEW SQL 
command.  We recommend that you create a new view on the basis of an existing view shipped 
with SmartPlant Instrumentation and modify the column selection in the new view as you 
require.  When creating a new view, make sure the following requirements are met: 
 The view must contain the CMPNT_ID column. 
 The CMPNT_ID value must be unique. 
 The number of rows in the created view must match the number of rows in the COMPONENT 

table of SmartPlant Instrumentation.  The COMPONENT table contains the appropriate 
instrument tags that must appear in the view. 

 When creating a view for a specific project in an owner operator domain, you must create the 
same view in the Domain schema, As-Built schema, Project schema of the target project, 
target Combined Project schema. 
 For details on establishing a connection to a database schema available in SmartPlant 

Instrumentation, see refer to the appropriate topics in the Internal Setup Utility Online Help, 
Connecting to the SmartPlant Instrumentation Database set of topics. 
 
 

Associate User-Defined Views 
This option enables you to associate a SmartPlant Instrumentation database view that you 
created in an external application such as InfoMaker.  After associating an appropriate database 
view, you can use the data it contains in specifications.  When creating a user-defined database 
view, you can include in this view any combination of SmartPlant Instrumentation table columns, 
with each column belonging to a different SmartPlant Instrumentation table.  Using database 
views, you can retrieve data from the required tables and display this data in specification 
documents.  For example, a certain instrument is assembled on a line.  You use your database 
view to automatically retrieve data related to that line, for example, line process data, pipe related 
material, and so forth. 
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 Before using this procedure, make backups of all your user-defined views.  When 
upgrading your SmartPlant Instrumentation version, note that in the new version, some tables or 
columns might have been modified.  If you have upgraded your database after associating 
user-defined views, you cannot use the views in which the table records do not match the new 
table records of the new database.  To enable the use of these views, you must run a set of SQL 
statements to re-create the user-defined views. 
1. On the Specifications Module window menu bar, click Actions > Specification Views. 
2. On the Specification Views dialog box, click New. 
3. In the new row, type the appropriate view name. 

 The name of the new view must be exactly the same as the name defined in your 
external application (the name is not case- sensitive).  The software validates the name and 
checks whether the view complies with the SmartPlant Instrumentation-specific conditions. 

4. Under Item Type, from the list, select the item type you want to associate with the current 
view. 

 For a user-defined view, you can select an item type from a list.  For the default views, 
the item type is fixed.  The displayed item type indicates that you can only use the current 
view in a specific item specification.  For example, you can only use the default view 
cable_type in a cable specification. 

5. Click OK. 
 The associated view becomes available for selection on the Regenerate Page dialog 

box in the Page Editor. 
 

Working with Page Graphics Common Tasks 
These tasks deal with adding graphic objects in a spec page and modifying their 
properties.   These graphic objects include data fields, text boxes, computed fields, grid lines, 
and so forth. 

Add a Line to a Page 
Use this procedure to add a graphic line to a specification page.  For more information, see Add a 
Line to a Page (on page 212). 

Modify Line Position and Length Using Arrow Keys 
Use this procedure to modify the position and length of a single line on a page using the arrow 
keys on the keyboard.  For more information, see Modify Line Position and Length Using Arrow 
Keys (on page 213). 

Modify Line Position and Length Using the Mouse 
Use this procedure to modify the position and length of a single line on a page using the 
mouse.  For more information, see Modify Line Position and Length Using the Mouse (on 
page 213). 

Set Precise Position and Length of a Line 
Use this procedure to set the X and Y coordinates of a single line.  For more information, see Set 
Precise Position and Length of a Line (on page 213). 

Change Line Properties 
Use this procedure to change color, style, and thickness properties of a single line you select in a 
spec page.  For more information, see Change Line Properties (on page 214). 
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Duplicate Page Lines 
This procedure enables you to duplicate a graphic line on a page.  For more information, see 
Duplicate Page Lines (on page 214). 

Add Graphics to a Page 
Use this procedure to add graphic images to your specification pages.  The graphic files that you 
include in your pages must be in .bmp format.  For more information, see Add Graphics to a Page 
(on page 215). 

Set Precise Position and Size of Page Objects 
Use this procedure to set the X and Y coordinates of a page object.  You can set precise size and 
position of data fields, text boxes, computed fields, and graphic elements, for example, lines.  For 
more information, see Set Precise Position and Size of Page Objects (on page 216). 

Modify Position and Size of Page Objects Using Arrow Keys 
Use this procedure to modify the position and size of a page object using the arrow keys on the 
keyboard.  You can modify size and position of data fields, text boxes, computed fields, and 
graphic elements, for example, lines.  For more information, see Modify Position and Size of Page 
Objects Using Arrow Keys (on page 216). 

Modify Position and Size of Page Objects Using the Mouse 
Use this procedure to modify the position and size of a page object using the mouse.  You can 
modify size and position of data fields, text boxes, computed fields, and graphic elements, for 
example, lines.  For more information, see Modify Position and Size of Page Objects Using the 
Mouse (on page 216). 
 

Add a Line to a Page 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click . 
4. In the Page Editor working area, do one of the following: 

 For a horizontal line, click the location of the left end of the line that you want to create. 
 To prepare for a vertical line, click to the left of the location. 

5. On the Line dialog box, under Line ID, accept the default ID or type a different unique line ID 
number. 

6. Accept the displayed line end coordinates or enter new coordinates as you require. 
7. Under Line color, select the color that you need. 
8. Under Line style, select the line display style that you need. 
9. Under Line thickness, type the new value or use the spinners to set a value using 

PowerBuilder units from one to five. 
10. Click OK to display the new line on the page (the software displays small white dots at the 

ends of the line that you just created). 
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Set Precise Position and Length of a Line 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. In the Page Editor working area, double-click a line to open the Line dialog box. 
4. Under Line end coordinates, enter type the appropriate values or use the spinners. 

 You enter the X and Y values using PowerBuilder units. 
5. Click OK. 
 
 

Modify Line Position and Length Using Arrow Keys 
1. Open a spec page in the Page Editor. 
2. In the Page Editor working area, click the line that you want to modify. 

 The software displays small white dots at the ends of the line that you select. 
3. Using the keyboard arrows, move the line until you place it correctly. 
4. Size the line as follows: 

 To make the line shorter, press Shift + Left Arrow. 
 To make the line longer, press Shift + Right Arrow. 
 To change the line position from horizontal to diagonal or vertical, press Shift + Up Arrow 

until you position the line correctly. 
 
 

Modify Line Position and Length Using the Mouse 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. In the Page Editor working area, select a line. 

 The software displays small white dots at the ends of the line that you selected. 
4. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 To move the line, place the cursor over a line end so that the cursor changes to 
cross-hairs, and then drag this end to a new location.  The other end of the line remains 
anchored. 

 To move the line from one location to another, without changing orientation or length, drag 
the line from the middle. 
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Change Line Properties 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click . 
4. In the Page Editor working area, click the line whose properties you want to change. 

 The software displays small white dots at the ends of the line that you selected. 
5. Double-click the selected line to open the Line dialog box. 
6. Under Line ID, accept or modify the line ID as you require. 

 You need to define the line ID if you intend to save the current page in .psr format and 
then customize it in InfoMaker.  The line ID must be unique. 

7. Under Line color, select the color that you need. 
8. Under Line style, select the option that you need. 
9. Under Line thickness, type the new value or use the spinners to set a value using 

PowerBuilder units from one to five. 
10. Click OK to update the line properties on the page. 
 
 

Duplicate Page Lines 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click . 
4. In the Page Editor working area, click the line that you want to duplicate. 

 The software displays small white dots at the ends of the line that you selected. 

5. On the Edit Fields and Headers toolbar, click . 
 The software displays the duplicated field a bit lower and towards the right of the original 

line. 
6. Select the duplicate line, and drag it to the location that you need. 
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Add Graphics to a Page 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click . 
4. In the Page Editor working area, do one of the following: 

 Click a free area of the page. 
 Click a specific location on the page where you want to insert the graphic. 

5. On the Picture dialog box that opens, under Picture ID, accept the default value or type a 
different unique picture ID number. 

6. Under File name, do one of the following: 
 Type the path and name of the .bmp file that you want to use for the picture. 

 Click  and navigate to the .bmp file that you want to insert. 
 You can only insert graphic files with the .bmp extension. 

7. Click OK. 
8. To move the graphic within the page, click the graphic and do one of the following: 

 Use the arrow keys. 
 Drag the graphic using the cursor. 

9. To resize the selected graphic, do the following: 
a. Move the cursor to the edge or to the corner that you want to resize, until a two- headed 

arrow appears. 
b. Drag the corner or the edge of the graphic to its new location. 

10. To delete the selected graphic, on the Edit Fields and Headers toolbar, click . 
11. When you are satisfied with the appearance of the graphic, on the Actions menu, click Edit 

Fields and Headers to close this toolbar. 
12. On the Actions menu, click the Save option that you require. 

 You can save the page under the current or different name, or as an external file.  For more 
details, see Save a Page to the Database (on page 206), and Save a Page as an External File (on 
page 206). 
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Set Precise Position and Size of Page Objects 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. In the Page Editor working area, click the object whose X and Y coordinates you want to set. 
4. Do one of the following: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

5. On the Edit Fields and Headers toolbar, click . 
6. In the Field or Header Position pop-up window, enter the X and Y values as you require. 

 The X and Y values are PowerBuilder unit coordinates of the upper left corner of the 
object. 

7. In the Width and Height boxes, enter the appropriate values. 
 
 

Modify Position and Size of Page Objects Using the Mouse 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. In the Page Editor working area, click the object whose X and Y coordinates you want to set. 
4. To move the object, place the cursor in the center of the object so that the cursor changes to 

cross-hairs, and then drag the object to its new location. 
5. To resize the object, place the cursor in an object edge or corner so that the cursor changes to 

a double-headed resize arrow, and then drag the edge or corner to its new location. 
 
 

Modify Position and Size of Page Objects Using Arrow Keys 
1. Open a spec page in the Page Editor. 
2. In the Page Editor working area, click the object that you want to modify. 
3. Using the keyboard arrows, move the page object until the upper left corner is correctly 

placed. 
4. Size the object as follows: 

 To make the object narrower, press Shift + Left Arrow. 
 To make the object wider, press Shift + Right Arrow. 
 To make the object shorter, press Shift + Up Arrow. 
 To make the object taller, press Shirt + Down Arrow. 
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Specification Page Customization 
Specification pages customization is possible either in the Page Editor of the Specifications 
module or in InfoMaker.  In the Page Editor, you use the Edit Fields and Headers floating 
toolbar options to add or remove data fields, modify field headers, and define field layout of a spec 
page.  Changes that you make on the page automatically take effect in all existing specs that 
include this page, and also in the spec printout.  These changes do not take effect in specs saved 
as .psr files.  For example, if you change thickness of a specific line on a page, and then save the 
page to the database, the software updates the line display in all specs based on the form 
containing this page. 

 You must use InfoMaker if you want to assign new select lists or drop-down data window to 
spec page fields or if you need to customize calibration form pages.  For details, see Customizing 
Form Pages in InfoMaker Common Tasks (see "Form Page Customization Procedures" on 
page 620). 
 
 

Customizing Pages in the Page Editor Common Tasks 
These tasks deal with customizing the display of the spec page data fields and their headers using 
the Page Editor options of the Specifications module.  On a spec page, you cannot select more 
than one field or header at a time for customization. 

Edit Field Headers 
Use this procedure to modify the text that appears in the field headers.  You can change the text 
itself, change the font characteristics: bold or not bold, italic, rotated (determine angle), text box 
size, text alignment, text color, and background color.  For more information, see Edit Field 
Headers (on page 219). 

Display Invisible Fields 
This procedure enables you to display fields whose table column status in the database is set as 
invisible.  You can then modify these table columns using a PowerSoft editor, such as 
InfoMaker.  For more information, see Display Invisible Fields (on page 219). 

Define Fields with Computed Values 
This procedure allows you to define and modify an InfoMaker eligible expression for a data field in 
the current form.  Such an expression is referred to as a computed value.  The field containing 
such an expression is referred to as a computed field.  For more information, see Define Fields 
with Computed Values (on page 220). 

Display Revision Changes for Spec Properties 
When you create a new revision for a specification sheet, you can show the revision number next 
to properties for which the values were changed at the last revision.  To do this, you add a 
computed field for the property for which you want to indicate the change.  For more information, 
see Display Revision Changes for Spec Properties (on page 221). 
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Format Field Values 
Use this procedure to format values of data fields.  The format that you set for the data field 
names is used by SmartPlant Instrumentation to display the field values in the specs based on a 
form containing this page.  To differentiate among various data fields, you set left, center or right 
alignment, set font style and size, and set combinations of text and background colors.  For more 
information, see Format Field Values (on page 221). 

Add Data Fields to a Page 
Use this procedure to add data fields to a specification page that you open in the Page 
Editor.  The fields that you can add belong to one of the following types: 
 Standard (non-custom) fields appropriate to the process function of the open page (displayed 

by default in the Table Column List pop-up window) 
 Process data custom fields (displayed in the Table Column List pop-up window after you 

regenerate the page) 
 Specification custom fields (some displayed by default in the Table Column List pop-up 

window, with option to select additional fields from the Regenerate Page dialog box) 
 Standard fields available for all process functions (displayed on the Regenerate Page dialog 

box, with option to select additional fields for display in the Table Column List pop-up 
window) 

For more information, see Add Data Fields to a Page (on page 222). 

Duplicate Data Fields in a Page 
This procedure enables you to duplicate a data field in a spec page.  This way you need enter 
data only once for several identical fields in a page.  For more information, see Duplicate Data 
Fields in a Page (on page 222). 

Delete Data Fields 
Use this procedure to delete an existing data field from a particular page.  You can delete one 
data field at a time.  Data fields that you delete reappear in the Table Column List pop-up 
window.  For more information, see Delete Data Fields (on page 223). 

Add Custom Fields of Wiring Equipment Items 
This procedure allows you to add custom fields of wiring equipment items in a spec 
page.  Custom fields of wiring equipment items appear in the table APPARATUS.  You can use 
up to 30 fields in a specification.  The custom fields in the APPARATUS table are designated by 
column names from APPAR_UDF_C01 to APPAR_UDF_C30.  The custom fields that you add in 
a specification page hold view-only values in an item specification that you create using this page 
as a source.  Each custom field holds a user-defined property value of a customized wiring 
equipment category.  For more information, see Add Custom Fields of Wiring Equipment Items 
(on page 223). 
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Add Function Block Custom Fields to a Fieldbus Spec 
Use this procedure to add function blocks in spec pages of the forms that you can use as a basis 
for fieldbus spec generation.  Three specification forms are available for fieldbus data: form 72 for 
instrument with the General process function, 73 for flow instruments, and 74 for pressure 
instruments.  These forms contain a fieldbus page that includes data for shipped function 
blocks.  In addition to these function blocks, you can create your own function blocks and add 
data for them to the form page.  Before adding custom function blocks in the specification page, 
you have to define them in the Instrument Index module.  The order in which you define them 
determines the sequence number that they are mapped to when dragging the table columns onto 
the specification page.  The shipped function blocks correspond to sequence numbers 1 to 
21.  Sequence numbers 22 to 40 are available for custom function block parameters.  For more 
information, see Add Function Block Custom Fields to a Fieldbus Spec (on page 223). 
 
 

Edit Field Headers 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. In the Page Editor working area, double-click a field header to open the Edit Text dialog box. 
4. On the Edit Text dialog box, do the following: 

a. In the Name box, edit the field header text. 
b. Select the text alignment option within the field text box. 

5. Select Transparent if you want to display the current Windows background color in the text 
box, or clear Transparent and then select the background color that you need. 

6. From the Text color list, select the text color that you need. 
7. Under Font style, select Bold or Italic. 
8. From the Rotate list, select an angle to rotate the text inside the text box. 

 If you want to display an ampersand character & in the field header text, in the Name 
box, enter &&.  For example, to display the P&ID header on the spec page, in the Name box, 
type P&&ID. 

9. Click OK. 
 
 

Display Invisible Fields 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click  to display the invisible data fields of the 
current page. 
 If several data fields are positioned at the same spot (one on top of the other), you can only 

see the top data field.  You can display the data fields underneath the top field simply by moving 
the fields aside. 
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Define Fields with Computed Values 
You can enter any of the following data types, provided that they comply with the conventions 
used in InfoMaker: 

Data Type Example 

Number 2210 

String of characters 'AA' or "AA" 

Field name cmpnt_name 

Function upper(cmpnt_name) 

Conditional if expression (pd_fluid_phase='S','Steam','Water') 
1. Open a page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. With the Edit Fields and Headers toolbar displayed, do one of the following to open the 

Computed Field dialog box: 

 On the Edit Fields and Headers toolbar, click  and then click a field in the Page 
Editor. 

 In the Page Editor, select and double-click a field to open the Computed Field dialog 
box showing the current computed value of that field. 

4. In the Name box, do one of the following: 
 Type a new name to add a field with this name to the current page 
 Type a field name which already exists in the current page or leave the current value if you 

selected this field in the current page. 
5. In the Expression box, type a value, function, or any other appropriate expression. 
6. Click Verify to verify that the expression you entered is a valid InfoMaker expression. 
7. Click OK. 

 
 If you make changes to a field in the currently opened page, the software displays the 

computed results automatically, using the settings you entered on the Computed Field. 
 See your InfoMaker User Guide for additional information about the data types you can use as 

valid expressions for this procedure. 
 
 



 Specifications 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 221 
 

Display Revision Changes for Spec Properties 
1. Open a page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click  and then click the page at the position 
where you want to place the computed field. 

4. On the Computed Field dialog box, type a name for the computed field. 
5. In the Expression box, type the following expression: 

f_changevalue(cmpnt_id,rev_id,dwg_id,"<field name>") 
 For example, to show changes for the maximum pressure, the expression is written as 

follows: 
f_changevalue(cmpnt_id,rev_id,dwg_id,"pd_press_max") 

6. Click Verify to verify that the expression you entered is a valid InfoMaker expression. 
7. Click OK. 
8. To show the change in the specification, do the following: 
9. Modify an existing value of a property for which you added a computed field to display 

changes for the last revision. 
10. Close the specification sheet and re-open it the following day. 
11. Add a revision to the specification sheet and refresh the display. 

 
 The indication appears only after the day advances on your computer's clock. 
 The indication appears only for existing values that were changed at the last revision.  If you 

enter a new value for a property that previously did not have a value, no change is indicated. 
 
 

Format Field Values 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Fields and Headers toolbar, click  to display the data field names in the page. 
4. In the page, double-click a field name to open the Edit Field dialog box. 
5. Under Alignment, accept the default alignment (left), or select the appropriate alignment 

option. 
6. Under Font style, select the font style (the available styles are bold and italic). 
7. Under Font size, enter a font size between 3 and 24. 
8. Select Transparent if you want to display the current Windows background color in the text 

box, or clear Transparent and then select the background color that you need. 
9. Click OK. 
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Add Data Fields to a Page 
1. Open a spec page in the Page Editor. 
2. On the menu bar, click Actions > Regenerate Page. 
3. On the Regenerate Page dialog box, under Select tables and views, select a check box for 

each table or view whose columns you want to display table in the Table Column List pop-up 
window, from which you can then add data fields to your page. 

 If you want to add a user- defined view to a spec page, you must first add this view in the 
Specification Views dialog box. 

4. Under Show Columns, click Show for each required table or view. 
5. Under Select columns, do one of the following: 

 Select the Select all check box to select all the columns in the table. 
 Hold down the Ctrl key and select or clear specific columns as desired. 

6. Click OK to return to the Page Editor. 
7. On the menu bar, click Actions > Edit Fields and Headers. 

8. On the Edit Fields and Headers toolbar, click  to open the Table Column List pop-up 
window. 

9. From the Table Column List pop-up window, drag table columns to the appropriate location 
on the page. 

10. Click  to close the Table Column List pop-up window. 
11. Do one of the following: 

 To save the page under the current name, on the menu bar, click Actions > Save. 
 To save the page under a different name, on the menu bar, click Actions > Save as 

Page. 
 
 

Duplicate Data Fields in a Page 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

3. On the Edit Headers and Fields toolbar, click  to display the data field names in the page. 
4. In the Page Editor working area, click the data field that you want to duplicate. 

5. On the Edit Fields and Headers toolbar, click . 
 The software displays the duplicated data field as superimposed on the original field and 

skewed downwards to the right. 
6. Drag the new field to the location that you need. 
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Delete Data Fields 
1. Open a spec page in the Page Editor. 
2. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 
3. With the Edit Fields and Headers toolbar displayed, in the page, click the data field that you 

want to delete. 

4. On the Edit Fields and Headers toolbar, click . 
5. Repeat this procedure top delete another data field. 
 
 

Add Custom Fields of Wiring Equipment Items 
1. Create a wiring equipment item in the Reference Explorer. 
2. In the Specifications module, restore a form associated with the Wiring Equipment item type. 
3. In the Page Editor, open a spec page based on the form that you restored. 
4. Regenerate the page, and from the APPARATUS table, add the appropriate APPAR_UDF 

columns as data fields in the page. 
5. In the page, name the column headers to match the headers that you defined for wiring 

equipment properties in the Wiring module. 

 
 To display a list of headers, you need to open an external .psr file 

WIRING_EQUIPMENT_UDF.PSR, which is located in the path <SmartPlant Instrumentation 
home folder> \PSR.  You can open the file WIRING_EQUIPMENT_UDF.PSR using 
InfoMaker, or from the Browser module. 

 After adding custom fields in a spec page, you have to change the column headers in the page 
so that they match the user- defined property names in the Wiring Equipment Category 
Properties dialog box, which you access for the Wiring module (with the Wiring module main 
window open, click Tables > Wiring Equipment > Categories). 

See Also 
Restore Library Forms (on page 228) 
Regenerate a Specification Page (on page 205) 
 

Add Function Block Custom Fields to a Fieldbus Spec 
1. In the Instrument Index module, create a new function block. 
2. In the Specifications module, open the Page Editor. 

3. On the Page Editor toolbar, click . 
4. On the Select Specification Page dialog box, select Fieldbus Page. 
5. Do one of the following to display the Edit Fields and Headers floating toolbar: 

 Click Actions > Edit Fields and Headers. 

 On the Page Editor toolbar, click . 

6. On the Edit Fields and Headers floating toolbar, click  to view the names of the data field 
on the specification page. 
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7. On the Edit Fields and Headers floating toolbar, click . 
8. In the Table Column List pop- up window, select a table column starting with the string fb 

and containing a value between 22 and 40, for example, fb22_exists.  For each custom 
function block, the following column types are available: 
 fb<number>_name — Displays the text string used for the function block label as defined 

in the Function Blocks supporting table. 
 fb<number>_count — Allows you to specify the number of function blocks of the 

particular type that are used in the instrument if the Multiple check box is selected in the 
Function Blocks dialog box. 

 fb<number>_ex_time — Allows you to specify the execution time for the function block 
type if the Execution time check box is selected in the Function Blocks dialog box. 

 fb<number>_exists — Displays a text box that you can select to indicate that the 
function block is required for the instrument. 
 The <number> value corresponds to the order in which you add custom function blocks 

in the Function Blocks supporting table, and not their alphabetic sequence. 
9. Drag the table column value that you selected from the Table Column List pop-up window to 

the desired location on the currently open page. 
10. Drag other custom function block values onto the page as desired. 

11. Click  to close the Table Column List pop-up window. 
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Spec Forms 
Forms serve the basis for creating specifications.  Forms can consist of one or more data pages 
and always contain a note page.  A form must contain at least one data page.  You might design 
a form based on more than one page, for example, for a field device that has both electrical and 
mechanical connections, requiring separate pages for wiring connections and line-related 
fields.  SmartPlant Instrumentation is delivered with a library of predefined forms bearing the 
names of their default pages. 
You can manage spec forms in the Specifications module, using the Form Editor options.  You 
can change form properties, such as name, description, and number, save a form either as a new 
form or as a spec page to fit your own conventions. 
After defining the form pages, you can create specs on the basis of this form.  If you want to 
generate a multi-tag spec containing a page where you can display values of individual 
instruments. You must first create a multi-tag spec format on the basis of a particular form.  You 
can create other types of specs by assigning a SmartPlant Instrumentation item directly to the 
number of the appropriate spec form.  When you assign a form to an item and generate a spec, 
the software creates the spec pages according to the pages that the source form contains.  You 
cannot modify the data fields in the form itself, only in the form pages, which you can open in the 
Page Editor. 
It is possible to create multiple templates for a specific form and then, when generating a spec, 
assign the item to the form data template rather than to the form.  You can then copy data from 
any other template based on the same form to the current spec, and even copy data from the spec 
to any of these templates. 
  
 

Create a Form 
Use this procedure to create a form comprising one spec page.  You can only create and manage 
spec forms in the Specifications module. 
1. In the Specifications Module window, do one of the following: 

 Click Edit > Form Editor. 

 On the toolbar, click . 

2. In the Form Editor, click . 
3. Select a page for the new form. 

 A form must contain at least one page.  You can add other pages in the form after 
creating the form. 

4. On the toolbar, click  to save the form to the database. 
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Edit Form Properties 
Use this procedure to create a form comprising one spec page.  You can only create and manage 
spec forms in the Specifications module. 

 Before performing this procedure, make sure that you have closed all the specifications 
that are assigned to the form whose properties you want to edit. 
1. In the Specifications Module window, do one of the following: 

 Click Edit > Form Editor. 

 On the toolbar, click . 
2. In the Form Editor, do one of the following: 

 Click Actions > Open Form. 

 Click . 
3. On the Select Specification Form dialog box, select the form whose properties you want to 

edit. 
4. Click Properties and modify the form number, name, or note as you require. 
5. Click OK and then save the form. 
 

Add Pages to an Existing Form 
Use the following procedure to add pages to existing forms and create a multi-page form that you 
can associate with an item.  By adding pages to a form, you can achieve greater flexibility and 
accuracy in specifications based on that form. 

 
 If you want to use large notes in a form, you need to add a large note page to this form.  Since 

it is possible to scroll the large note page area, you do not need to add more than one large 
note page to a form.  When printing forms containing a large note page, the software divides 
the page into separate sheets automatically, depending on the note text length. 

 A form that contains a composite page cannot contain any other pages because you can only 
include one composite page in a form. 

1. In the Form Editor, do one of the following: 
 On the menu bar, click Actions > Open Form. 

 On the toolbar, click . 
2. On the Select Specification Form dialog box, select the form to which you want to add 

pages, and click OK. 
3. In the Form Editor, do one of the following to add a page: 

 On the menu bar, click Actions > New Page. 

 On the toolbar, click . 
4. On the Select Specification Page dialog box, select the page that you want to include in the 

form. 

 
 To edit the page name and description, click Properties and type the required 

modifications. 
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 The process function of the form is determined by the pages in the form.  If the process 
function of all the pages within a form is General, the form process function is also 
General.  If an added page has a different process function, the form process function 
changes to the new page process function.  In this case, adding a new page is available 
only for pages with General or the same process function as the form. 

5. Click OK. 
6. Sort the pages within the form as you require. 
7. Do one of the following: 

 To save the changes that you made, on the menu bar, click Actions > Save. 
 To save the form under a new name, on the menu bar, click Actions > Save as Form. 

 
 If you are building a form incorporating pages with identical custom field names, (for example, 

Page 1 and Page 2) the following scenario can occur: 
On Page 1, the spec_udf_c13 field value is A, whereas, on Page 2, the value is B.  When 
adding Page 2 to the form, the software changes the spec_udf_c13 value to B on Page 1, 
according to the value on Page 2. 

 In a multi-page form, you should use a given specification custom field name on more than 
one page only for a field that you design for constancy across all of the form pages. 

See Also 
Create a Large Note Page (on page 207) 
Specification Page Customization (on page 217) 
Specification Pages (on page 203) 
 

Remove a Page from a Form 
You can remove a page from an existing multi-page form.  This procedure only applies to the 
current form and does not remove the page from the list of pages available as templates for other 
forms.  If you need to permanently delete a particular page, you can do so in the Page Editor. 
1. In the Form Editor, open a form that has more than one page. 
2. Click a tab of a specific page. 
3. Do one of the following: 

 On the menu bar, click Actions > Remove Page. 

 On the toolbar, click . 
4. Do one of the following: 

 To save the form under the existing name, click Actions > Save. 
 To save the form under a new name, click Actions > Save as Form. 

 

Sort Pages Within Forms 
Use this procedure to open a specific form and sort the pages included in the form.  This way you 
set the print preview and print order of the pages in a spec that you generate on the basis of this 
form. 
1. In the Form Editor, open a form that has more than one page. 
2. Do one of the following: 

 On the menu bar, click Actions > Sort Pages. 

 On the toolbar, click . 
3. Select a page and click Move Up or Move Down to change the page order within the form. 
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4. Click OK to set the new page order and update the form. 
 
 

Display a List of Pages Included in a Form 
Use this procedure to open a form and display a list of spec pages that this form includes.  You 
might need to display a list of pages of you want to modify fields in a specific form page (you 
cannot modify fields on the form itself). 
1. In the Specifications Module window, do one of the following: 

 Click Edit > Form Editor. 

 On the toolbar, click . 
2. On the Form Editor menu bar, do one of the following: 

 Click Actions > Page List to view the page list. 
 Click Reports > Spec Pages per Form to generate an d print a report of the form pages. 

 

Delete a Form 
This procedure enables you to delete a form that is not in use in any spec.  You can either delete 
the form together with all of the pages included in the form, or just the form itself, and then delete 
the pages manually, from the Page Editor.  If the form that you are about to delete is a library 
form, you can restore this form at any stage, together with the library pages. 
1. On the Form Editor menu bar, click Actions > Delete Form. 

 
 You can only delete a form that is not in use in any specs. 
 You can delete one form at a time. 
 If the form has pages, and it is not in use in any spec, you are prompted to delete all of the 

form pages as well.  If the form that you are about to delete is a library form, you can 
restore this form at any stage, together with the library pages.  However, you cannot 
restore custom pages included in the form.  Therefore, before deleting the form, we 
recommend that you save the appropriate pages as external files.  You can save pages 
as files in the Page Editor. 

2. On the Select Specification Form dialog box, select the form you want to delete and click 
OK. 

 

Restore Library Forms 
Use this procedure if you need to perform any of the following activities: 
 Activate a library form that is not available in the Select Specification Form dialog box.  After 

you restore a form, this form becomes available in the Select Specification Form dialog box, 
and you can associate this form with items that belong to a specific item type.  You must 
restore all forms whose item type is not Instrument if you want to create specifications using 
these forms.  For example, to create hook-up specifications, you must restore a form 
assigned to the hook-up item type. 

 Restore a library form after deleting it.  You can only restore library forms provided with 
SmartPlant Instrumentation.  You can only restore a library form that was saved as an .isf file. 

1. In the Specifications Module window, do one of the following: 
 Click Edit > Form Editor. 

 On the toolbar, click . 
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2. On the Form Editor menu bar, click Actions > Restore Form. 
3. Select the form you want to restore and click OK. 

 If the form with the same name you are restoring already exists, the software displays the 
Restore Options dialog box, where you can overwrite the existing form or re-create the library 
form as a new form. 
 

Regenerate Library Forms 
You might need to use this procedure after your System Administrator has initialized a new 
domain from a source, or after upgrading your SmartPlant Instrumentation database.  Some form 
data may not be copied correctly to the target domain.  For this reason, it is recommended that 
you regenerate the library forms to avoid any problems at a later stage.  If you are using the 
workflow options in the Instrument Specifications Browser, regeneration is essential after 
initialization or upgrade. 
1. In the Specifications Module window, click Actions > Regenerate Library Forms. 
2. On the Regenerate Library Forms dialog box, click Run. 
3. On completion of the process, click Close. 
 

Change the Form Assignment of a Spec 
Use this procedure to change the form assignment for a group of specs that share a common 
form.  The new form must have the same process function as the currently assigned form or 
belong to the General process function. 
1. In the Specifications module open a specification. 
2. On the menu bar, click Actions > Change Spec Form. 
3. Select the new form for your specification and click OK. 
4. When prompted to change the form assignment and close the current spec, click Yes, and 

then reopen the spec, which is now assigned to the new form. 

 
 SmartPlant Instrumentation does not allow you to change the form assignment of a spec 

assigned to a Specification Binder package, unless you first remove the specification from the 
Specification Binder package. 

 SmartPlant Instrumentation does not allow you to change the form assignment of a multi-tag 
spec. 

 

Change Form Assignment for a Batch of Specs 
Use this procedure to change the form assignment for a particular spec.  The new form must have 
the same process function as the currently assigned form.  When the spec item type is 
Instrument, you can also select a form whose process function is defined as General. 
1. In the Specifications Module window, on the menu bar, click Actions > Change Spec 

Form. 
2. Under Search parameters, from the Current form list, select the form type of the 

specifications that you want to change. 
3. Click Find. 

 
 Select Find typical tags only to limit your search to specifications of typical tags. 
 Select Find telecom tags only to limit your search to specifications of telecom tags. 

4. Under Search results, select the specifications for which you want to change the form. 
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5. Under Change parameters, from the New form box, select the new form type, and click 
Apply. 

 
 In the New form box, the software displays forms of the same process function as the 

current form.  When the spec item type is Instrument, the software also displays forms 
whose process function is defined as General. 

 Specifications for which forms were successfully changed no longer appear among the 
search results. 

 The software does not allow you to change the form assignment of an instrument 
specification assigned to a Specification Binder package, unless you first remove the 
specification from the Specification Binder package. 

 SmartPlant Instrumentation does not allow you to change the form assignment of 
multi-tag specs. 

6. Repeat the procedure for other specification forms if required, or click Close to return to the 
Specifications Module window. 

 

Define Form Browser Fields 
Use this procedure to define fields for a single-form browser or multi-form browser you can add in 
the Browser module.  The fields that you select in the Spec Data Dictionary become available 
for inclusion in the browser view in the Style settings section of the Browser Manager.  You can 
edit the field headers only in the Spec Data Dictionary.  This procedure does not affect the 
on-screen display of specifications based on a form that you edit in the Spec Data Dictionary, nor 
does it influence printed specifications. 

 
 This procedure is a prerequisite for adding a single-form browser using the Browser module 

options. 
 This procedure is a prerequisite for defining a multi-form browser using the Specifications 

module options. 
1. On the Specifications Module window menu bar, click Edit > Spec Data Dictionary. 
2. On the Select Specification Form dialog box, select a form and click OK. 

3. On the toolbar, click . 
4. To edit the headers for the form browser, if you need, do one of the following: 

 On the Field Properties tab, change individual field headers by typing a text string 
instead of the displayed header. 

 Change field headers in batch mode using another form as a source.  To do so, click 
Copy From, and then, select a source form.. 

5. To apply existing headers of the current form, do the following: 
6. In the form or on the Field Properties tab, under Header, move the cursor to the field header. 

7. After the cursor changes its shape to , click the header. 
8. In the form, double-click the header to display it on the Field Properties tab. 

 
 When you apply existing headers of the current form, in the form display, the form fields 

are marked with the cyan background color.  The background color of the currently 
selected field, for which you are editing the header, changes to magenta. 
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 The  icon on the Field Properties tab points to the corresponding field header, which 
is now available for editing. 

9. To define the fields for the form browser, do one of the following: 
 To make all of the fields from one or more tables available for the form browser, click the 

Tables tab, and then, under Browser Fields, click All for the tables that you require. 
 To define individual fields, on the Field Properties tab, select the appropriate check 

boxes in the Browser column. 

10. On the toolbar, click  ( Generate) to generate a form browser format. 
 When defining fields for a multi-form browser, you do not need to generate any browser 

format.  It is sufficient to save the definitions you made. 

11. On the toolbar, click  to save the form browser field definitions. 
 

Define a Multi-Form Browser 
Use this procedure to define a multi-form browser after you specified fields for the browser in the 
Spec Data Dictionary. 

Prerequisite 
Before defining a multi-form browser, you must define form browser fields in the Spec Data 
Dictionary.  For details, see Define Form Browser Fields (on page 230). 

 
 If you need to redefine fields for an existing multi-form browser that already has browser 

created views created in the Browser module, note that on re-creating the browser, the 
software automatically deletes all the existing views. 

 On a multi-user database platform, before re-creating a multi-form browser, you must first 
make sure that other users have no views open for this browser.  Re-creation of an existing 
browser when its view is open on another machine results in unstable software behavior and 
the software might close unexpectedly on the machine where the browser view is open. 

1. In the Specifications Module window menu bar, click Define Multi-Form Browser to open 
the Define Multi-Form Browser Wizard. 

2. On the Welcome page, click Next. 
3. On the Browser Name Definition and Selection page, do the following: 

a. Beside browser, click the ellipsis button . 
b. On the Multi-Form Browsers dialog box, click New and then type a unique browser 

name and an optional description. 
c. Click OK to close the Multi- Form Browsers dialog box and return to the Browser Name 

Definition and Selection page. 
d. Make sure the browser name appears in the Browser box and then click Next. 
e. On the Item Type Selection page, select the specification form item type and then click 

Next. 
 At this stage, the software assigns the browser name to the form item type. 

4. On the Specification Form Selection page, select check boxes for those spec forms whose 
fields want to include in the current browser. 

5. Click Next. 
6. On the Field Header Selection page, do the following: 
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a. If needed, click Filter and then specify the filter for displaying the field headers that you 
require. 

b. Under Field headers, select the field headers you want to display in the browser view as 
column names. 

7. Click Next. 
8. On the Multi-Form Browser Creation page, click Finish. 
9. Test the multi-form browser in the Browser module.  For details, see Test a Multi-Form 

Browser (on page 587). 
 

Form Data Templates 
Form data template allows you to store data that you can copy to existing specs.  Using a form 
data template eliminates the need to repeat data entry for similar specs.  Also, you can set the 
software to copy data from a template when generating a new instrument spec.  This is possible 
after you assign an existing form data template to the profile of a specific instrument type.  You 
manage form data templates only in the Specifications module, in the Form Data Template 
Editor. 
You base form data templates on a specific spec form.  You can create multiple templates for 
each form.  The form data template name does not have to be unique and can contain up to 50 
alpha-numeric characters.  After generating a spec based on the form for which you defined data 
templates, you can select a template and copy its data to the spec.  Also, you can copy data to a 
form data template from a spec based on the same form. 
 
 

Create and Modify a Form Data Template 
Use this procedure to create and modify form data templates, from which you can copy a batch of 
data to your new or existing specifications. 
1. With the Specifications Module window open, click Edit > Form Data Template Editor. 
2. On the Select Specification Form dialog box, select the form for which you want to create or 

modify a form data template, and then click OK. 
3. On the Select Form Data Template dialog box, do one of the following: 

 If this is the first form data template for the current form, type a meaningful name instead 
of UNDEFINED. 

 To add an additional form data template for the current form, click New and type a name. 
 To modify an existing form data template, select the template from the list. 

4. Click OK to open the template in the Form Data Template Editor. 
5. Do one of the following to enter data in the form template: 

 Enter data manually in the fields that are available for editing. 
 Copy data from a spec based on the same form as your form data template.  For details, 

see Copy Data to a Form Data Template from a Spec (on page 272). 
 If the form data template has fields that are not accessible, these fields are protected in 

the Spec Data Dictionary.  You cannot enter values in protected fields.  When copying data, 
the software ignores protected fields.  For details, see Protect Fields from Overwriting When 
Copying Data (see "Protect Fields from Being Overwritten When Copying Data" on page 272). 

6. On the toolbar, click  to save the changes. 
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7. If needed, on the toolbar, click  to define and open another form data template in the Form 
Data Template Editor. 

 
 If you opened several templates in the Form Data Template Editor, you can display the 

template that you require by selecting it on the Window menu. 
 We recommend that you define unique and meaningful names for your form data 

templates.  The software does not check whether the template names are unique. 
 

Delete a Form Data Template 
Use this procedure to delete one or more form data templates if they are no longer required as 
data sources for specs. 
1. In the Specifications module, click Actions > Delete Form Data Template. 
2. In the Select Specification Form dialog box, select the form for which you want to delete a 

form data template and click OK. 
 The Select Specification Form dialog box only displays those forms for which you have 

defined data templates. 
3. In the Select Form Data Template dialog box, select one or more data templates that you want 

to delete. 
 To select multiple records, use the mouse while holding down the Ctrl or Shift key, or 

select the Select all check box. 
4. Click OK 
5. Click Yes when prompted to confirm the deletion. 

 
 Deleting a form a data template does not affect the source spec form or specs to which you 

copied data from the template. 
 Deletion of a form data template is irreversible. 
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Single-Tag Specifications 
A single-tag spec is a specification you can generate for a single instrument.  A single-tag can 
only contain data defined for one specific instrument.  If you want to use this tag in a multi-tag 
spec, you need to delete the single-tag spec first.  A single tag spec consists of a note page, and 
one or more data pages, depending on the form on which you base the spec. 
In the specification, you can edit some of the fields by clicking inside the field and typing the 
required data.  Other fields, such as Tag Number or Process Conditions receive their data from 
the Instrument Index, Process Data or Calculation modules and thus do not allow a direct 
editing.  However, you can edit the process data and calculation fields if you have been granted 
the appropriate access rights to do so.  The unit of measure fields allow you to select values from 
a predefined list of units.  All tag number property changes that are made not in the spec itself 
automatically take effect in the spec generated for this tag. 
It is possible to export single-tag specs to External Editor, where other users can edit the 
appropriate data settings, and then import the edited data back to SmartPlant Instrumentation. 

 If a single-tag spec has fieldbus columns, you can set preferences to allow you to edit the 
fieldbus column values in the spec.  However, you can only make the fieldbus columns editable if 
the instrument type of the spec tag number is Fieldbus. 
 
 

Generate a Single-Tag Spec 
This procedure describes how to generate a single-tag spec for an existing instrument using the 
Specifications module options. 
1. In the Specifications Module window, click Actions > Open Specification 
2. From the Item type list, select Instrument. 
3. From the Tag class list, select a tag class. 
4. In the Item number box, enter the exact instrument tag number. 

 
 If you do not remember the instrument tag number, leave the Item number box empty 

and click Find. 
 If you are creating a specification for a specific process data case of an instrument, the 

value in the Form number box might be view-only.  If the value is view only, you have 
already created previously a specification for a different case of the same 
instrument.  After creating a spec for a process data case, the software assigns the same 
spec form to all other cases of the same instrument. 

 If the instrument process function is General, the available forms are only those whose 
process function is also General.  However, if the instrument process function is not 
General, both General forms and forms that have the same process function as the tag 
has are available for association with the instrument. 

5. In the Form number box, enter the spec form number. 
 If you do not remember the form number, leave the Form number box empty and click 

Find. 
6. In the Open Specification box, click OK. 
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 If you receive a message that the specified instrument tag does not exist, you can create 
a new instrument tag on the fly, provided that you set preferences accordingly.  To be able to 
create instrument tags in the Specifications module, on the Preferences dialog box, on the 
Specifications > General page, under Tag creation, select Allowed. 

7. In the New Specification dialog box, do one of the following: 
a. Select Create single-item specification. 
b. In the Document number box, accept the default document number or modify it as you 

require. 
 You do not have to define the document number at this stage.  If you leave the 

Document number box empty, you can define the document number in the spec title block of 
the spec, after you open the spec. 

8. Click OK to generate and open the specification. 

See Also 
Generate Instrument Specs in Batch Mode (on page 198) 
Principles of Generating Specifications (on page 195) 
 

Notes for Editing a Single-Tag Spec 
This topic provides information about the editing options you can use if you need to update or 
define data in the columns of a given single-tag spec. 

Field Values 
Some field values can be edited by clicking inside the field and typing the required data.  Some of 
the fields require that you select a value from a list.  Other fields, such as Tag Number or 
Process Conditions receive their data from the Instrument Index, Process Data, or Calculation 
modules and thus do not allow a direct editing.  You can only edit process data and calculation 
values if you the appropriate access rights to do so. 

Units of Measure 
The Units of Measure (UOM) fields allow you to select a unit from a predefined list of units.  After 
selecting a pressure unit, you are prompted to choose the pressure reading method.  When you 
select volumetric flow units, you are prompted to select the measurement conditions (at flow or at 
base). 

Spec Sheet Number 
At the foot of the specification, you can enter the sheet number and total number of sheets 
manually.  You can leave these fields blank to complete them automatically when you print the 
sheets. 

Document Binder Status 
When you edit and save an instrument specification that is part of a Specification Binder package 
in the Document Binder module, you are prompted to define its Document Binder status. 
 
 



 Specifications 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 237 
 

Edit Manufacturers and Models in a Spec 
Use this procedure to edit the instrument manufacturer and model in a spec.  With a spec open, 
you can display the instrument manufacturer supporting table and define the manufacturers and 
models as you require. 
1. Open a spec. 
2. Do one of the following: 

 Click Actions > Instrument Models. 

 On the toolbar, click . 
3. To add or change a manufacturer, in the Instrument Manufacturers dialog box, under 

Manufacturer, select a manufacturer from the list or click  to add a new manufacturer. 
4. To change the instrument model, in the data window of the dialog box, select the new model. 
5. To add a new model for the current manufacturer, do the following: 

a. In the Instrument Manufacturers dialog box, click New to add a new data row. 
b. Type the instrument model values in the appropriate boxes, and also select the process 

function. 
c. Click OK. 

 The software automatically copies the defined instrument manufacturer and model to 
the appropriate fields in the current spec. 

6. Save the specification. 
 
 

Move a Single-Tag Spec to a Multi-Tag Spec 
 When moving a single-tag spec to a multi-tag spec, the software only copies the data 

that appear in the current see list.  If the single-tag spec contains data that appears on the main 
pages of the current multi-tag spec (not in the see list), the software ignores these values, and 
automatically deletes the single-tag spec and its document number. 
1. Open a multi-tag spec. 
2. Click the Multi-Tag List tab. 
3. Click Actions > Move from Single. 
4. In the Add Tag dialog box, click Find. 
5. In the Find Items dialog box, search for the tags whose spec form is the same as the form in 

the current multi-tag spec. 
6. Under Search results, select one or more tags, and then click OK. 

 
 In the Find Items dialog box, the Process function and Form number boxes are view-only 

because all the target single-tag specs must be based on the same form as the format of the 
current multi-tag spec and share the same process function. 

 If you know the target spec tag number, you can type it in the Add Tag dialog box, and click 
OK to add this tag in the current see list. 

 All the target single-tag specs must be based on the same form as the format of the current 
multi-tag spec. 

See Also 
Move a Tag to Another See List (on page 249) 
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Generate a Spec for a Complex Analyzer 
Use this procedure to generate a specification for a complex analyzer. 
1. Make sure that you have a specification form appropriate for an analyzer. 

 
 The library form #77 is an example of a form designed for an analyzer.  If this form is not 

displayed in the Select Specification Form dialog box, restore the supplied library forms. 
 You can also generate a multi-tag spec for each stream of a complex analyzer. 
 You can also use this procedure to generate a spec for a simple analyzer. 

2. Generate a single-tag spec based on the analyzer form. 

See Also 
Generate a Single-Tag Spec (on page 235) 
Generate a Spec for an Analyzer Stream (on page 251) 
 

Associate an Instrument Tag with Several Specification 
Forms 

You can associate an instrument tag with several specification forms and set an active 
specification for that tag number. Note that each specification is based on a particular document 
(drawing) that is defined for the form of the specification you select. The specification can be a 
single-tag or a composite specification but not a multi-tag specification. 

 
 For this feature to work, you must first enable it in the Specification Preferences. Click 

File >Preferences. On the Preferences dialog box, click Specifications > General. 
Under Instrument specification association, select the Associate with multiple spec 
forms option. 

 The software does not allow you to associate a specification form that is based on a 
document included in a Document Binder package. 

 The software does not allow you to associate a specification form that is used in a 
multi-tag specification. 

1. In the Specifications module, click Actions > Associate Instrument Specification Forms. 
2. On the Enter Specification Tag Number dialog box, select an appropriate tag class. 
3. With the mouse pointer in the Tag number box, type in the tag number that you require or do 

the following: 
a. Click Find to open the Find Items dialog box. 
b. In the boxes in the upper part of the dialog box, type or select the parameters for the 

properties that you want to find. 
c. Click Find to display a list of items according to the search parameters that you have 

selected. 
d. Select the required item from the retrieved list. 
e. Click OK to accept your choice. and return to the Enter Specification Tag Number 

dialog box. 
4. On the Enter Specification Tag Number dialog box, click OK. 
5. On the Associate Instrument Specification Forms dialog box, click Add Form. 
6. On the Select Specification Form dialog box, highlight a form and click OK. 
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 The software adds the form you selected to the Additional associated forms list on 
the Associate Instrument Specification Forms dialog box. 

7. If the current instrument tag has several process data cases, select the required case from the 
list and then repeat steps 5 and 6 as needed. 

 The software will prompt you to save the association data if you do not click Apply 
before changing the case.  

8. To change the active specification for the current instrument tag, select a form in the 
Additional associated forms list and click Set Active Form. 

 
 Click Dissociate if you want the current instrument tag not to be associated with any 

specification form. After clicking this button, software clears values in the Active 
specification details box and moves the form to the Additional associated forms list. You 
can set another active specification by selecting an appropriate form in the Additional 
associated forms list and clicking Set Active Form. 

 To remove an associated form from the list, select a form in the Additional associated forms 
list and click Remove. 
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Process Data Case Specs 
A process data case specification is a single-section specification generated for a particular 
process data case of an instrument tag.  You can create an individual specification for each case 
of an instrument tag, including the governing case.  Each process data case spec has its own 
revisions.  Process data case specifications do not have to share the same document number (as 
for other specifications). 
You create process data case specifications in the same way that you create specifications for 
other items.  Since all process data case specifications share the same tag number, creation of a 
process data case specification involves an additional step, that is selecting the desired tag 
case.  After you specify a tag number for creating a new spec, the software automatically detects 
whether this tag number has multiple cases and prompts you to select one of those cases. 
Since all process data case specifications for a given instrument share the same spec form, after 
creating the first specification for a particular case, you need to use the same spec form for all 
subsequent process data case specifications that you create for the instrument. 

 It is possible to generate a composite (multi-section) specification that displays more than 
one process data case of an instrument.  For details, see Composite Spec for Instrument with 
Cases: Generation Workflow (on page 261). 
 
 

Process Data Case Specifications Common Tasks 
The following tasks deal with generating single-section specs for a particular process data case, 
or generate a hybrid case spec. 

Generate a Spec for Multiple Process Data Cases 
Use this procedure to generate a spec for a specific process data case defined for an instrument 
that contains case.  For more information, see Generate a Spec for Multiple Process Data Cases 
(on page 242). 

Generate a Hybrid Case Spec 
For a control valve for which you defined multiple process data cases, you can create a hybrid 
case from the minimum, normal, and maximum flow coefficient values (Cv/Kv) that you calculated 
for the various cases.  Use this procedure to generate a specification for this tag based on its 
hybrid case.  Make sure that you have a form designed for the control valve hybrid case.  For 
more information, see Generate a Hybrid Case Spec (on page 242). 
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Generate a Spec for Multiple Process Data Cases 
1. In the Specifications module, click Actions > Open Specification. 
2. On the Open Specification dialog box, from the Item type list select Instrument. 
3. With the mouse pointer in the Item number box, do the following: 
4. Click Find to open the Find Items dialog box. 

a. In the boxes in the upper part of the dialog box, type or select the parameters for the 
properties that you want to find. 

b. Click Find to display a list of instruments according to the search parameters that you 
have selected. 

5. Select the instrument tag for which you have calculated a hybrid case in the Calculation 
module. 

 Under Search parameters, the Case list displays all the available cases defined in the 
Process Data module. 

6. On the Find Items dialog box, click OK to accept your selection and return to the Open 
Specification dialog box. 

7. With the mouse pointer in the Form number box, do the following: 
a. Click Find to open the Select Specification Form dialog box. 
b. Select the appropriate form (not form #76, which designed for the control valve hybrid 

case), and then click OK. 
 If the value in the Form number box is view-only, this means that you have already 

created previously a specification for a different case of the same tag.  After creating a spec 
for a tag case, the software assigns the same spec form to all other cases of the same tag. 

8. On the Open Specification dialog box, click OK to open the New Specification dialog box, 
and then proceed with spec creation. 

 
 

Generate a Hybrid Case Spec 
1. In the Specifications module, click Actions > Open Specification. 
2. On the Open Specification dialog box, from the Item type list select Instrument. 
3. With the mouse pointer in the Item number box, do the following: 

a. Click Find to open the Find Items dialog box. 
b. In the boxes in the upper part of the dialog box, type or select the parameters for the 

properties that you want to find. 
c. Click Find to display a list of instruments according to the search parameters that you 

have selected. 
4. Select the instrument tag for which you have calculated a hybrid case in the Calculation 

module. 
 Under Search parameters, the Case list displays all the available cases defined in the 

Process Data module.  However, the software does not indicate in the interface those 
instruments for which you calculated a hybrid case. 

5. On the Find Items dialog box, click OK to accept your selection and return to the Open 
Specification dialog box. 

6. With the mouse pointer in the Form number box, do the following: 
a. Click Find to open the Select Specification Form dialog box. 
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b. Select the form #76, which designed for the control valve hybrid case, and then click OK. 
 The library form #76 is the library form supplied with SmartPlant Instrumentation.  This 

form contains columns that display minimum, normal, and maximum flow coefficient values 
(Cv/Kv) you calculated for the various cases in the Calculation module.  If this form is not 
displayed in the Select Specification Form dialog box, restore the supplied library forms. 

7. On the Open Specification dialog box, click OK to open the New Specification dialog box, 
and then proceed with spec creation. 

See Also 
Restore Library Forms (on page 228) 
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Multi-Tag (See List) Specifications 
A multi-tag specification is a specification you can generate for a group of instruments.  Multi-tag 
specifications are frequently required because instruments of the same type have many identical 
parameters.  A multi-tag specification contains a group of instrument tags that you can add, one 
by one, to the same spec sheet.  A multi-tag specification is based on a specification format, 
which is, in turn, is based on the form that you set for assigning with multiple tags.  Such a form 
can comprise one or more spec pages. 
Instrument tags in a multi-tag spec must have identical process functions except for the following 
case: if the spec form process function is General but the form pages do not include any data 
fields from the PD_NOT_ASSIGN or PD_GENERAL tables, such a spec can contain instruments 
whose process functions are not identical, for example, such a spec can contain both Flow and 
Temperature instruments. 
A multi-tag specification always contains one Notes page, one Multi-Tag List page, and one or 
more common pages with fields that are identical for all of the tags.  The Tag Number field, and 
other specification fields that appear on the Multi-Tag List page, show the words SEE LIST 
instead of data.  The SEE LIST label indicates that the values in the fields appear on the 
Multi-Tag List tab of the spec.  The Multi-Tag List page contains fields whose values can differ 
from tag to tag.  You can change the SEE LIST label to any other text using the appropriate option 
on the Multi-Tag Specifications page of the Preferences dialog box. 
It is possible to export multi-tag specs to External Editor, where other users can edit the 
appropriate data settings, and then import the edited data back to SmartPlant 
Instrumentation.  Also, you can move tags to another multi-tag spec (to another see list), or, on 
removing a tag, automatically generate a single-tag spec for this tag.  You cannot remove the 
master tag. 

 
 You can include fieldbus instruments in a multi-tag spec.  However, the software does not 

support editing of fieldbus data fields in a multi-tag spec. 
 You cannot include composite pages in a multi-tag spec.  For details of composite specs, see 

Composite Specifications (on page 259). 
 
 

Generate a Multi-Tag Spec 
Use this procedure to generate and open a multi-tag spec in the Specifications module.  To 
generate such a spec, you need to select a specific instrument and a form for which you created a 
multi-tag spec format.  After generating the spec, you can add other instrument tags to the spec 
see list. 

 Before you can perform this procedure, make sure you created a multi-tag spec format for 
a spec form you need to associate with the instrument for which you want to create the spec. 
1. In the Specifications Module window, click Actions > Open Specification. 
2. From the Item type list, select Instrument. 
3. In the Item number box, enter the exact instrument tag number that you want to define as the 

master tag in your multi-tag spec. 

 
 If you do not remember the instrument tag number, leave the Item number box empty 

and click Find. 
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 If you are creating a specification for a specific process data case of an instrument, the 
value in the Form number box might be view-only.  If the value is view only, you have 
already created previously a specification for a different case of the same 
instrument.  After creating a spec for a process data case, the software assigns the same 
spec form to all other cases of the same instrument. 

 If the instrument process function is General, the available forms are only those whose 
process function is also General.  However, if the instrument process function is not 
General, both General forms and forms that have the same process function as the tag 
has are available for association with the instrument. 

4. In the Form number box, enter the spec form number of the form for which you created a 
multi-tag list format. 

 If you do not remember the form number, leave the Form number box empty and click 
Find. 

5. In the Open Specification box, click OK. 
6. In the New Specification dialog box, do one of the following: 
7. Select Create multi-tag specification. 
8. In the Document number box, accept the default document number or modify it as you 

require. 
 The document number that you define applies to the entire multi-tag specification, 

regardless of the number of instruments you subsequently add in the current spec see list. 
9. Click OK to generate and open the specification. 

 After generating the multi- tag spec, you can add other instrument tags to the spec directly 
from the spec see list, without having to perform the current procedure again. 

See Also 
Multi-Tag Spec Formats (on page 251) 
Generate Instrument Specs in Batch Mode (on page 198) 
Principles of Generating Specifications (on page 195) 
 

Add a Single Instrument Tag to a Multi-Tag Spec 
Use this procedure to add an instrument tag to the see list of an existing multi-tag spec without 
opening the spec. 
1. In the Specifications Module window, the menu bar, click Actions > Open Specification. 
2. Select an instrument tag that is not yet associated with a specification by doing one of the 

following: 
 In the Item number box, type the tag number. 
 Click Find to search for the tag number that you require. 

3. Select the spec form by doing one of the following: 
 In the Form number box, type the form number. 
 Click Find to search for the form that you require. 

4. Click OK. 
5. In the New Specification dialog box, select Add tag to existing multi-tag specification. 
6. In the Document numbers pane, select the document number of the target multi- tag spec, 

with which you want to associate the current instrument tag. 

 
 To display the selected multi-tag specification, click View. 
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 All the documents in all of the existing lowest level plant groups are displayed in the 
Document numbers pane.  Therefore, you can select a document to add the instrument 
tag to a multi-tag spec belonging to any of the existing plant groups. 

7. Click OK to open the specification. 

8. On the toolbar, click  to save the specification. 

See Also 
Multi-Tag Spec Formats (on page 251) 
 

Add Instrument Tags to a Multi-Tag Spec in Batch Mode 
Use this procedure to add one or more instrument tags to the see list of an existing multi-tag spec.  
To add instrument tags in batch mode, you must first open the target spec. 
1. Open a multi-tag spec. 
2. Click the Multi-Tag List tab to display the instrument tags that exist in the current see list. 
3. Do one of the following: 

 To add instrument tags that currently are not associated with any spec, on the menu bar, 
click Actions > Add Tag. 

 To move instrument tags from existing single-tag specs, on the menu bar, click Actions > 
Move from Single. 

4. On the Add Tag Number dialog box, click Find and then, search for the instrument tags that 
you can add to the current spec. 

5. Under Search results, select the tags that you require, and then, click OK to return to the 
Add Tag Number dialog box. 

6. On the Add Tag Number dialog box, click OK. 

7. On the toolbar, click  to save the specification. 

See Also 
Multi-Tag Spec Formats (on page 251) 
 

Edit See List Data in a Multi-Tag Spec 
Use this procedure to edit data in the see list of a multi-tag spec. 
1. Open a multi-tag spec. 
2. Click the cell in which you want to add or edit data. 
3. Modify the existing value or define a new value. 
4. Save the spec. 

 
 You can only edit or define the see list values per specific cell. 
 On main data pages of a multi-tag spec, you can edit spec fields that are common to all the 

tags, in the same way that you edit a single-tag spec. 

See Also 
Notes for Editing a Single-Tag Spec (on page 236) 
Multi-Tag Spec Formats (on page 251) 
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Change the Master Tag Definition 
In a multi-tag specification, several instrument tags have one common master page, which is 
generated according to one of the instrument tags sharing this specification.  The master page is 
associated with a master tag which links to the information common to all instrument tags that 
belong to the multi-tag specification.  You can change the master tag definition by selecting a 
different instrument tag to serve as the master tag.  The master tag definition also changes if you 
delete the current master tag.  In this case, the instrument tag that appears first in the see list 
becomes the master tag. 
1. In the Specifications module, click Actions > Change Master Tags. 
2. In the Change Master Tags dialog box, under Document numbers, select a document 

number. 
3. In the Tag numbers pane, beside the tag number you want to set as the muster tag, select 

the Master check box. 
4. Click Apply to set the selected tag as the new master tag. 

 
 If you cannot find the document number in the Change Master Tags dialog box, this means 

that the spec you are looking for does not contain a document number.  You need to open the 
target spec and define the document number in the spec title block. 

 The master tag definition also changes if you delete the current master tag.  In this case, the 
instrument tag that appears first in the see list becomes the master tag. 

See Also 
Ways of Defining a Spec Document Number (on page 201) 
Multi-Tag Spec Formats (on page 251) 
 

Search for a Specific Tag in a Multi-Tag Spec 
Use this procedure to find a specific instrument tag within a multi-tag specification. 
1. In a multi-tag spec, click the Multi-Tag List tab to display the see list. 
2. Accept the default sort order or define a new ascending sort order by double-clicking the 

header on any column in the see list to set a new ascending. 

 
 The default sort order is by tag number in ascending direction.  When you double-click a 

column heading, the arrow indicates the sort key and direction.  You can click the same 
column already change the sorting direction. 

 The master tag definition also changes if you delete the current master tag.  In this case, 
the instrument tag that appears first in the see list becomes the master tag. 

3. If you have not yet found your tag, on the toolbar, click  and do one of the following: 
 Type the target tag number. 
 Click Find to open a dialog box where you search for the tag. 

See Also 
Multi-Tag Spec Formats (on page 251) 
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Change the Font Size of See List Column Headers 
This procedure allows you to modify the font size and height of the see list column headers used in 
all multi-tag specs based on a specific format.  You can customize the column header font size 
and height, and also the column name font size and height. 
1. With the Specifications module window open, do one of the following: 

 On the toolbar, click . 
 On the Edit menu, click Format Editor. 

2. Click Actions > Customize Format. 
3. In each of the spin boxes, set the values as appropriate. 

 
 The Sample header font size and Sample header height boxes allow you to add values 

in PowerBuilder units (1 PowerBuilder unit is equivalent to 1/32 of the current system font 
height used in Windows). 

 The Sample field font size and Sample field height boxes allow you to add values in 
pixels. 

4. Click OK. 
 The changes you made in the font size will take effect only after you reopen the multi-tag list 

format you are currently editing. 

See Also 
Multi-Tag Spec Formats (on page 251) 
 

Move a Tag to Another See List 
Use this procedure to move instrument tags from the see list page of the currently spec to a see 
list in another spec.  You can either create a new multi-tag spec on the fly and move instrument 
tags from the currently open see list to the target see list in another specification, or move tags to 
the see list of an existing multi-tag specification. 
1. Open a multi-tag spec. 
2. Click the Multi-Tag List tab to display the see list. 
3. Select the instrument tags you want to move to another multi-tag spec. 
4. On the menu bar, click Actions > Move to Another Multi-Tag List. 
5. On the dialog box that opens, under Select target format, select a format. 

 
 The Select target format displays all the formats that you can use to create multi-tag 

specs.  You can select either the format of the currently open specification and then 
create a new specification, or select a different format. 

 If a format appears without the  icon, this means that there are no multi- tag specs 
assigned to this format, or that this is the format of the current spec.  In this case, you can 
only create a new multi-tag spec, and move the instrument tags from the current see list to 
the see list of the new spec. 

 If you want to move instrument tags to an existing spec, select a format that already has a 
multi-tag spec (that is, a format that has a  icon to the left of the format name). 

6. Depending on the format that you selected, do one of the following: 
 If the selected format is different from the current format, and already has a multi-tag 

spec, select either Move to new multi-tag instrument specification or Move to 
existing multi-tag instrument specification. 
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 If you selected the current format or a format that does not have multi-tag specs, select 
Move to new multi-tag instrument specification, enter a document number for the new 
spec, and also, from the Master tag list, select a tag number which you want to set as the 
master tag in the new spec. 

See Also 
Multi-Tag Spec Formats (on page 251) 
 

Move a Tag from See List to a Single-Tag Spec 
Use this procedure to remove an instrument tag from a multi- tag spec and create a single-tag 
spec for this instrument. 
1. Open a multi-tag spec. 
2. Click the Multi-Tag List tab. 
3. Select one or more tags and click Actions > Move to Single. 

 
 If you selected multiple tags, on the Specifications > Multi-Tag Specifications page of the 

Preferences dialog box, you can select Skip individual confirmation. 
 You cannot move the master tag. 
 The form number of the created single-tag specs is the same as the form number of the 

current multi-tag spec. 
 The software automatically creates individual document numbers for each single-tag 

spec.  The created tag numbers depend on whether the spec document number naming 
convention exists.  If it does not exist, the software creates spec document numbers as 
follows: <<item tag>>-SP. 

See Also 
Multi-Tag Spec Formats (on page 251) 
 

Remove a Tag from a Multi-Tag Spec 
Use this procedure to remove instrument tags from a multi- tag (see list) specification.  When 
removing a tag, it is possible to retain in the database or delete the tag spec data defined in the 
see list. 
1. In a multi-tag specification, on the Multi-Tag List tab, select the instrument tags that you want 

to remove from the see list. 
2. On the Actions menu, click Remove Tag. 
3. In the message that opens, click Yes when prompted to remove the tags. 
4. When prompted to clear the specification data, do one of the following: 

 Click Yes to delete from the database the see list values defined for the tag. 
 Click No to preserve the tag see list values in the database. 

 If you clicked No, and then generate a specification for the tag that you removed, the 
software retrieves the see list values from the database and displays them in the generated 
spec.  To display the values, it is only crucial that the spec form on which you base the new 
spec contains the columns that appeared in the see list of the tag that you removed.  This 
means that the form of the new spec does not have to be the same as the form of the spec 
from which you removed the tag, and that the type of the new spec can be either single-tag or 
multi-tag. 

5. On the toolbar, click  to save the changes. 
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 You cannot remove the master tag unless you redefine it as a standard tag. 
 The software does not allow you to remove tags that are currently assigned to a Specification 

Binder package or that were revised in the Document Binder module. 

See Also 
Change the Master Tag Definition (on page 248) 
Multi-Tag Spec Formats (on page 251) 
 

Generate a Spec for an Analyzer Stream 
To generate a specification for an analyzer stream, you need a special type of multi-tag 
specification, which functions as follows: 
 You generate a multi-tag specification, with the stream tag as the more master tag. 
 You then add the instrument tags associated with this stream to the multi-tag specification. 
 Fields that relate to the stream are displayed on the common page or pages (not in the see 

list). 
 The fields that vary — the tag names and tag-specific values — are displayed in the in the see 

list on the Multi-Tag List tab. 
1. Make sure that you have created a multi-tag format based on an analyzer stream form. 

 The library form #78 is an example of a form designed for an analyzer stream.  If this 
form is not displayed in the Select Specification Form dialog box, restore the supplied library 
forms.  You can then create a multi- tag spec format for the form #78. 

2. Based on such a format, generate a multi-tag spec for the stream tag that you want to set as 
the master tag. 

3. In the Multi-Tag List of the generated spec, add other tags belonging to the current analyzer 
stream. 

4. Click Actions > Save. 

See Also 
Restore Library Forms (on page 228) 
Create a Format (on page 252) 
Add Instrument Tags to a Multi-Tag Spec in Batch Mode (on page 247) 
Generate a Spec for a Complex Analyzer (on page 238) 
 

Multi-Tag Spec Formats 
A multi-tag spec format is a template that contains see list columns where you can define 
instrument-specific values on the Multi-Tag List tab of a multi-tag spec.  You create a 
specification format using a specification form as a source, and can build an unlimited number of 
formats based on a single form. 
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Create a Format 
Use this procedure to create a formats for multi-tag specs.  You create a format based on a spec 
form, which in turn is based on a spec page.  You can build an unlimited number of formats based 
on a given form.  When creating a format, you can edit the headers of the columns that appear in 
the spec see list, and also fine-tune the order and width of columns. 
1. On the Specifications Window module menu bar, click Edit > Format Editor. 
2. On the Format Editor menu bar, click Actions > Open Format. 
3. On the Select Specification Form dialog box, select a form and click OK. 
4. On the Select Format dialog box, under Format, type the name of the new format and click 

OK. 
 If the form that you selected on the Select Specification Form dialog box has existing 

formats, click New before typing the new format name. 
5. Do the following for each field that you want to appear on the spec see list: 

a. In the field selection area of the form (usually on the right), double-click the field. 
b. To display the original form header in the active row of the Edit Headers pop-up window, 

click the form header after the cursor changes its shape to . 
c. In the Edit Headers pop-up window, edit the header as necessary. 
d. The background color of the active field changes to magenta. 
e. Fields already added to the Edit Headers pop-up window are highlighted in cyan. 

f. The  icon in the left column of the Edit Headers pop-up window points to the header 
input box for the active field.  If you are working from a library form, the form header was 
automatically copied to this field. 

6. On the Format Editor toolbar, click  to generate the format. 
7. To change the see list column position of a header and its field, do the following in the Edit 

Headers pop-up window: 
a. Select the header for which you want to change the column position. 
b. Click Move Up or Move Down as necessary. 

 The order of the headers in the Edit Headers pop-up window determines the left-to-right 
column order on the Multi-Tag List tab the spec. 

8. To change the width of columns as they appear in the spec see list, do the following on the 
Format dialog box: 
a. Select portrait or landscape print preview. 
b. Set the cursor on the border between two headers. 
c. Drag the border to the left or to the right as necessary. 

d. Click  to save the new format. 
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Modify a Format 
You can modify an existing format so that it fits the needs of your multi-tag specs.  The 
modification process is similar to creating a new format.  Changes that you make to a 
specification format affect multi-tag specs that are already associated with that format.  You 
modify formats in the Format Editor, in the Specifications module. 
1. On the Specifications Window module menu bar, click Edit > Format Editor. 
2. On the Format Editor module menu bar, click Actions > Open Format. 
3. On the Select Specification Form dialog box, select a form and click OK. 
4. Select a format that you want to modify, and click OK. 
5. To edit headers that currently appear in the Edit Headers pop-up window, do the following: 

a. In the field selection area of the form (usually on the right), double-click the field for which 
you want to edit the header. 

b. In the Edit Headers pop-up window, edit the header as necessary. 

 
 When you double click the field, the background color of the field changes to magenta. 

 The  icon in the left column of the Edit Headers pop-up window points to the Header 
input box for the active field. 

 To copy the original form header into the active Header input box, click the form header 

after the cursor changes its shape to . 
6. To remove a field and its header from the multi-tag list, do the following: 

a. In the field selection area of the form, double-click the field that you want to delete. 
b. In the Edit Headers pop-up window, click Remove. 
c. To add a field and header to the multi-tag list, do the following: 
d. In the field selection area of the form, double-click the field that you want to add. 
e. To display the original form header in the active row of the Edit Headers pop-up window, 

click the form header after the cursor changes its shape to . 
f. In the Edit Headers pop-up window, edit the header as necessary. 

7. To change column position of a header and its field, do the following in the Edit Headers 
pop-up window: 
a. Select the header for which you want to change the column position. 
b. Click Move Up or Move Down as necessary. 

 The order of the headers in the Edit Headers pop-up window determines the left-to-right 
column order on the Multi-Tag List tab the spec. 

8. To change the width of columns as they appear in the spec see list, do the following on the 
Format dialog box: 
a. Select portrait or landscape print preview. 
b. Set the cursor on the border between two headers. 
c. Drag the border to the left or to the right as necessary. 

d. Click  to regenerate and save the modified format 
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Delete a Format 
This procedure enables you to select a specific form, display its format, and then delete a format 
that is not in use in multi- tag specs. 
1. With the Specifications module window open, do one of the following: 

 On the toolbar, click . 
 On the Edit menu, click Format Editor. 

2. Click Actions > Delete Formats. 
3. On the Select Specification Form dialog box, select a form whose format you want to delete, 

and then click OK. 
4. On the Select Format dialog box, select the required format from the list. 

 
 You can only select and delete one format at a time. 
 The software prevents you from deleting a format that is in use in specs. 

5. Click OK to delete the selected format. 
 

Regenerate Formats 
Use this procedure if you encounter problems with opening or printing a multi-tag spec after 
upgrading your SmartPlant Instrumentation version.  These problems occur because certain 
format properties are not applied to a form.  Format regeneration can fix these problems. 
1. In the Specifications Module window, click Actions > Regenerate Formats. 
2. On the Regenerate Formats dialog box, click Run. 
3. On completion of the process, click Close. 
 

Change the Format for a Multi-Tag Spec 
You use this procedure if more than one format exists for a form. 
1. Open a multi-tag spec. 
2. Click Actions > Change Format. 
3. On the Select Format dialog box, select the required format from the list. 

 After changing the format, the software only shows see list columns that appear in the 
format that you selected.  As a result, if the current see list columns do not appear in the 
selected format, the software retains the column values in the database but does not display 
them in the spec after you change the format. 

4. Click OK to change the format. 
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Define Multi-Tag Spec Print Layout 
You use this procedure to define a custom print layout for a specific format.  This feature is useful 
if the default print layout causes data display problems in the printout. 
1. In the Specifications module, click Edit > Format Editor. 
2. On the Format Editor menu bar, click Actions > Open Format. 
3. Select the target spec form and click OK. 
4. Select the target format or create a new one and click OK. 
5. On the form that opens, add field headers to the Edit Headers dialog box.  For details, see 

Create a Format (on page 252). 

6. On the toolbar, click  to save the format. 
7. On the menu bar, click Actions > Define Print Layout. 
8. From the Column Header pop-up window, drag the field headers to the Define Print Layout 

dialog box. 
 The number of the columns on the Define Print Layout dialog box corresponds to the 

number of the headers in Column Header pop-up window.  You can drag up to five headers 
under the same column on the Define Print Layout dialog box. 

9. Click Generate. 
10. On the Generate Print Layout dialog box, select the appropriate printout orientation and click 

OK. 
11. Test the defined print layout as follows: 
12. Click File > Preferences > Specifications > Multi-Tag Specifications and clear the Use 

default print layout check box. 
13. Open a multi-tag spec assigned to the format for which you defined the print layout. 
14. Print the spec. 

 
 You can define a printout size for a multi-tag specification. For details, see Define a 

Printout Size for a Multi-Tag List (on page 255). 
 If you want modify the print layout, for example by adding more column headers, you must 

regenerate the print layout and then save it. 
 The defined print layout applies to all existing and new multi-tag specs assigned to the 

form that uses the current format. 
 

Define a Printout Size for a Multi-Tag List 
This option allows you to define a printout size for the multi-tag list in a multi-item specification. 
1. In the Specifications module, click Edit > Format Editor. 
2. Do one of the following: 

 On the menu bar, click Actions >Open Format  

 On the lower toolbar, click . 
3. On the Select Specification Form dialog box, select a form with available multiple tags. 
4. Click OK to open the Select Format dialog box. 
5. Select an appropriate format and click OK. 
6. In the Format Editor, click Actions > Define Multi-Item List Printout size. 
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7. Select an appropriate printout size and click OK. 
8. In the Format Editor, save the format. 

 The printout size definition is valid for a specific format that has a multi-item list. 
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S E C T I O N  2 3  

Non-Instrument Specifications 
A non-instrument specification is a specification whose item type is not Instrument.  A spec page 
associated with a non- instrument spec form contains various properties of the source item.  If 
needed, you can regenerate the spec page and add more columns from the tables <item type>, 
udf_<item type>, spec_sheet_data, and add_spec1..9.  For example, in a cable specification, you 
can add columns from the tables CABLE, UDF_CABLE, and so forth.  SmartPlant 
Instrumentation allows you to generate the non-instrument specifications for the following item 
types: 
 Cable — Allows you to create a specification for a single reference cable defined in the 

Reference Explorer. 
 Panel — Allows you to create a specification for a single reference panel in the Reference 

Explorer. 
 Wiring Equipment — Allows you to create a specification for a single reference wiring 

equipment item.  A wiring equipment item can be an I/O card, I/O termination, fieldbus brick, 
or any other user-defined wiring equipment in the Reference Explorer. 

 Hook-Up Item — Allows you to create a specification for a single hook-up item defined in the 
Reference Explorer. 

 Loop — Allows you to create a single-section loop specification.  This specification consists of 
the main page with the loop number data and the note page, which is created automatically 
and refers to the loop number only.  The form associated with the loop number page is the 
form that you defined for the Loop item type. 

 If you need to create a specification for a loop and its tags, we recommend that you create 
a loop composite spec with multiple sections.  For details, see Loop Composite Spec: Generation 
Workflow (on page 262). 
SmartPlant Instrumentation does not support saving non- instrument specifications as .isf 
files.  Therefore, you cannot use the export or import options to work with these specifications in 
External Editor.  Saving non-instrument specifications in Excel format is not supported either. 
 
 

Prerequisites for Generating a Non-Instrument Spec 
This topic lists the prerequisites for generating a non-instrument spec. 

General Prerequisites 
In the Form Editor, you must restore a form for the item type you want to assign with the 
specification.  For example, to generate a specification for a specific cable, you must first restore 
the library form 80. 

Cable Spec Generation Prerequisite 
In the Reference Explorer, create a reference cable. 

Panel Spec Generation Prerequisite 
In the Reference Explorer, create a reference panel. 
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Wiring Equipment Generation Prerequisite 
In the Reference Explorer, create an I/O card, I/O termination, fieldbus brick, or any other 
user-defined wiring equipment. 

Hook-Up Item Spec Generation Prerequisite 
In the Reference Explorer, create a hook-up item and assign it to an item library. 
 
 

Generate a Non-Instrument Spec 
Use this procedure to create a specification for a hook-up item, reference cable, reference panel, 
or reference wiring equipment.  In this procedure, cable spec generation steps are shown as an 
example.  Procedures of creating other non- instrument specifications follow the same pattern. 

 Before you perform this procedure, restore the appropriate library forms. 
1. In the Specifications module, click Actions > Open Specification. 
2. On the Open Specification dialog box, from the Item type list, select Cable. 
3. Enter a name of a reference cable, or click Find to find the required reference cable or form. 
4. After specifying the cable name and the form number, on the Open Specification dialog box, 

click OK. 
5. On the New Specification dialog box, accept or modify the document number associated 

with the new specification. 

 
 The software automatically creates the document number using the cable name as a 

source, and append the -SP suffix.  There is no naming convention for a non-instrument 
spec document number. 

 You can leave the Document number box empty if you want to specify the document 
number manually, after opening the specification.  In the specification, you can enter the 
document number in the title block. 

 You can only create a single-cable specification.  The software does not support a see list 
for non-instrument specs. 

6. Click OK to generate a specification. 

 
 If you want to save the cable specification as a .psr file, click Actions > Save As, and select 

Original. 
 You can edit various cable properties in the cable spec in two ways: in the cable spec itself, or 

on the Properties dialog box, which you can open for the cable in the Reference Explorer. 

See Also 
Restore Library Forms (on page 228) 
Principles of Generating Specifications (on page 195) 
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S E C T I O N  2 4  

Composite Specifications 
A composite specification is a specification that contains more than one section.  You can either 
define loop composite specs or instrument composite specs.  A loop composite spec includes a 
loop and its instrument tags.  A composite instrument spec can include tags belonging to the 
same or different loops.  In contrast to multi-tag instrument specifications, which contain pages of 
common properties in addition to the SEE LIST page, such composite specs do not have common 
pages and can include tags whose process functions are not identical.  Each section in a 
composite spec page contains data pertinent to a specific instrument tag.  Also, it is possible to 
create a composite spec that includes process data cases of a particular instrument.  Unlike other 
specs you create in SmartPlant Instrumentation, a composite spec does not have a Notes 
page.  If you want to use notes, you must manually add a note box in the appropriate section. 
In the Domain Explorer, document numbers of loop composite specs appear under loop 
numbers and document numbers of instrument composite specs appear under each instrument 
included in the spec.  When duplicating an instrument tag associated with a composite spec, the 
software never duplicates the composite spec.  When duplicating a loop, the software always 
duplicates the loop composite spec. 

Generating and Printing Composite Specs 
When generating a composite spec, if you assigned more than one instrument to a particular 
section, the software multiplies this section on the spec as many times as the number of assigned 
instruments.  You can set the software to multiply sections from left to right or from top to 
bottom.  When more than one instrument is assigned to the same section, the instruments are 
sorted automatically in ascending order according to tag number.  In a composite spec that 
contains process data cases of an instrument, the cases are sorted in ascending order according 
to case sequence defined in the Process Data module (governing case is always the left-most 
section). 
When printing a composite specification, we recommend that the print sheet size be either A4 or 
Letter.  Note, however, that if the title block assignment method in the current domain is defined 
as Standard (used in all modules), you need to adjust your title block before printing specs 
using the Letter size.  For details, see Spec Title Blocks (on page 265). 

Managing Composite Spec Sections 
SmartPlant Instrumentation comes shipped with several spec forms that already include 
composite pages with predefined sections (for example, forms 88, 89, 90).  You must restore 
these forms before you start working with the sections included in the composite pages of these 
forms.  A form with a composite page cannot include any other pages.  In SmartPlant 
Instrumentation, you can create new sections on the basis of existing ones but it is not possible to 
create a section from scratch. 
You manage spec sections in the Sections Editor.  Spec section editing options are the same as 
for spec pages, which you manage in the Page Editor.  Therefore, before modifying data fields in 
a spec section, it is recommended that you familiarize yourself with spec page management 
options.  For details, see Specification Pages (on page 203) and the related topics.  The Section 
Editor has a limited number of editing options.  It is possible, however, to export spec sections to 
InfoMaker, edit them as you require, and then import them back to SmartPlant Instrumentation. 

Features not Supported for Composite Specs 
The following features of SmartPlant Instrumentation are not supported for composite specs: 
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Exporting data to External Editor (IEE) 
 Save as Excel options 
 Claim or merge options (only relevant in an owner operator domain) 
 Copying data from a form data template or another spec 
 Multi-tag list format options or inclusion of composite pages in a multi-tag spec 
 Spec Data Dictionary options 
 Browser options 
 Data comparison and history options 
 Changing the section process function 
 Custom title block assignment options available in the Specifications module (you must use 

the Standard custom title block assignment method if you want to display a custom title block 
in composites specs) 

 Using InfoMaker with composite specs saved as .psr files. 

 
 

Composite Spec for Multiple Instruments: Generation 
Workflow 

In this scenario, you create an instrument composite spec containing two sections: one for a 
control valve and the other for an I/P transducer.  Such a spec can include multiple control valves 
and I/P transducers belonging to different loops.  You use the library form Control Valve/I/P 
Transducer as a source for creating a new form and assigning a new composite spec page to this 
form. 
1. In the Instrument Index module, or using the Domain Explorer, create a control valve and I/P 

transducer. 
2. On the Specifications Module window menu bar, click Edit > Form Editor. 
3. On the Form Editor menu bar, click Actions > Restore Form and then restore form Control 

Valve/I/P Transducer (form number 90). 
 When restoring the form, the software restores its page and enables you to work with 

sections that this page includes. 
4. On the Specifications Module window menu bar, click Edit > Section Editor and modify the 

fields of the following sections as you require: 
 Control Valve Style3 (item type Instrument) 
 I/P Transducer Style3 (item type Instrument) 

5. On the Specifications Module window menu bar, click Edit > Page Editor. 
6. On the Page Editor menu bar, click Actions > New Composite Page. 
7. On the New Composite Page dialog box, select Data sections with headers. 
8. On the Select Sections for Composite Page dialog box, under Multiply sections in 

generated spec, select From top to bottom, and then select the following sections: 
 Control Valve Style3 
 I/P Transducer Style3 

 When you select a section multiplying option, you determine how the software multiplies 
sections in a generated composite spec.  In a generated spec, if you assigned more than one 
instrument to a section, the software multiplies this section on the spec as many times as the 
number of assigned instruments.  You set a section multiplying option only once and cannot 
change it after you open and save the current spec page in the Page Editor.  This setting 
applies to all the sections you add in the current spec page. 
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9. In the Page Editor working area, position the sections one under the other, within the page 
borders. 

10. Save the page with the name CV/I/P Transducer Test. 
11. Open the Form Editor and click Actions > New Form, select the Control Valve/I/P 

Transducer page for the form, and then name the new form as CV/I/P Transducer Test and 
specify a form number. 

12. On the Specifications Module window menu bar, click Actions > Open Specification and 
do the following: 
a. From the Item type list, select Instrument. 
b. In the Item number box, enter the tag number of the control valve you created. 
c. In the Form number box, enter the number of the CV/I/P Transducer Test form and click 

OK. 
d. On the New Composite Specification dialog box, beside I/P Transducer Style1, click 

Assign and assign your I/P transducer to the I/P Transducer Style1 section. 
e. Click OK to generate and open an instrument composite specification. 

See Also 
Principles of Generating Specifications (on page 195) 
 

Composite Spec for Instrument with Cases: Generation 
Workflow 

In this scenario, you create an instrument composite spec containing three process data cases of 
an instrument with the Flow process function.  You use the library form Orifice Plate Composite 
as a source for creating a new form and assigning a new composite spec page to this form. 
1. In the Instrument Index module, or using the Domain Explorer, create a flow instrument. 
2. In the Process Data module, create three cases for the instrument and define process data 

for each case. 
3. On the Specifications Module window menu bar, click Edit > Form Editor. 
4. On the Form Editor menu bar, click Actions > Restore Form and then restore form Orifice 

Plate Composite (form number 88). 
 When restoring the form, the software restores its page and enables you to work with 

sections that this page includes. 
5. On the Specifications Module window menu bar, click Edit > Section Editor and modify the 

fields of the following sections as you require: 
 Flow Orifice Header (header section) 
 Flow Orifice Data (data section) 

6. On the Specifications Module window menu bar, click Edit > Page Editor. 
7. On the Page Editor menu bar, click Actions > New Composite Page. 
8. On the New Composite Page dialog box, select Header section and data section. 
9. On the Select Sections for Composite Page dialog box, select the following sections: 

 Flow Orifice Header 
 Flow Orifice Data 

10. In the Page Editor working area, position the sections one under the other. 
11. Save the page with the name Orifice Plate Composite Test. 
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12. Open the Form Editor and click Actions > New Form, select the Orifice Plate Composite 
page for the form, and then name the new form as Orifice Plate Composite Test and specify 
a form number. 

13. On the Specifications Module window menu bar, click Actions > Open Specification and 
do the following: 
a. From the Item type list, select Instrument. 
b. In the Item number box, enter the tag number of the flow instrument that has cases. 
c. In the Form number box, enter the number of the Orifice Plate Composite Test form 

and click OK. 
d. Select a case to assign it to the instrument composite spec you are creating and click OK. 
e. On the New Composite Specification dialog box, beside Flow Orifice Data, click 

Assign and assign the two remaining cases to the Flow Orifice Data section. 
f. Click OK to generate and open an instrument composite specification. 

 In the composite spec, the sections that show case data appear from left to right.  The 
sections are sorted in ascending order according to case sequence defined in the Process 
Data module (governing case is always the left-most section). 

See Also 
Principles of Generating Specifications (on page 195) 
 

Loop Composite Spec: Generation Workflow 
In this scenario, you create a loop composite spec containing three sections: a loop section and 
two instrument sections.  The two instrument sections include one for a control valve and the 
other for an I/P transducer.  You use the library form Flow Loop Composite Style1 as a source 
for creating a new form and assigning a new composite spec page to this form. 
1. In the Instrument Index module, or using the Domain Explorer, create a loop with a control 

valve and I/P transducer. 
2. On the Specifications Module window menu bar, click Edit > Form Editor. 
3. On the Form Editor menu bar, click Actions > Restore Form and then restore form Flow 

Loop Composite Style1 (form number 91). 
 When restoring the form, the software restores its page and the seven sections that this 

page includes.  In this scenario, you need three of these sections to generate the current 
composite loop spec. 

4. On the Specifications Module window menu bar, click Edit > Section Editor and modify the 
fields of the following sections as you require: 
 Flow Loop Composite Style1 (item type Loop) 
 Control Valve Style1 (item type Instrument) 
 I/P Transducer Style1 (item type Instrument) 

5. On the Specifications Module window menu bar, click Edit > Page Editor. 
6. On the Page Editor menu bar, click Actions > New Composite Page. 
7. On the New Composite Page dialog box, select Loop composite page. 
8. On the Select Sections for Composite Page dialog box, under Multiply sections in 

generated spec, select From top to bottom, and then select the following sections: 
 Flow Loop Composite Style1 
 Control Valve Style1 
 I/P Transducer Style1 
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 When you select a section multiplying option, you determine how the software multiplies 
sections in a generated composite spec.  In a generated spec, if you assigned more than one 
instrument to a section, the software multiplies this section on the spec as many times as the 
number of assigned instruments. You set a section multiplying option only once and cannot 
change it after you open and save the current spec page in the Page Editor.  This setting 
applies to all instrument sections you add in the current spec page. 

9. In the Page Editor working area, position the sections one under the other, with the loop 
section placed at the top. 

10. Save the page with the name Flow Loop Test. 
11. Open the Form Editor and click Actions > New Form, select the Flow Loop Test page for 

the form, and then name the new form as Flow Loop Test and specify a form number. 
12. On the Specifications Module window menu bar, click Actions > Open Specification and 

do the following: 
a. From the Item type list, select Loop. 
b. In the Item number box, enter the number of the loop you created. 
c. In the Form number box, enter the number of the Flow Loop Test form and click OK. 
d. On the New Composite Specification dialog box, beside Control Valve Style1, click 

Assign and assign the current loop control valve to the Control Valve Style1 section. 
e. Beside I/P Transducer Style1, click Assign and assign the current loop I/P transducer to 

the I/P Transducer Style1 section. 
f. Click OK to generate and open a loop composite specification. 

See Also 
Principles of Generating Specifications (on page 195) 
 

Remove an Instrument from a Composite Spec 
1. In a composite specification, do one of the following: 

 On the Actions menu, click Remove Tags from Composite Spec. 

 On the toolbar, click  
2. In the dialog box that opens, select one or more tags and click OK. 

3. On the toolbar, click  to refresh the spec. 

 
 When removing tags from a loop composite spec, you can remove all the instruments. 
 When removing tags from an instrument composite spec, you cannot remove the last 

remaining tag because such a spec must include at least one instrument tag. 
 After removing instruments, the sections remain displayed in the spec.  If you want to 

remove these sections from the spec, you must remove them in the Page Editor.  For 
details, see Remove a Section from a Composite Page (on page 264). 

4. On the toolbar, click  to save the changes. 
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Remove a Section from a Composite Page 
1. Open a composite spec in the Page Editor. 
2. In the working area, select and right-click a section you want to remove from the current page. 
3. On the shortcut menu, click Remove Current Section. 

 If a composite spec including the selected section already exists, the software does not allow 
you to remove the section.  You must first open such a spec and dissociate all the instruments 
that are assigned to the current section. 
 

Edit a Section in a Composite Spec 
Use this procedure to customize a section in SmartPlant Instrumentation. You can save any page 
to the database, whether this is a section you open from an external file, or a library section you 
modified. 
1. To save the section as a .psr file, do the following: 

a. Open the desired section in the Section Editor. 
b. Do one of the following: 

 Click Actions > Save as File. 

 On the Section Editor toolbar, click . 
c. On the Save As dialog box, navigate to the required folder and type the target file name. 
d. Click OK to save the file. 

2. Edit the page in InfoMaker - see PSR File Customization Using InfoMaker (on page 612). 
 Changing section coordinates (dimensions) may affect the appearance of the section in 

composite specs where it is used. 
3. To overwrite the section in SmartPlant Instrumentation, do the following: 

a. Open a spec section in the Section Editor. 
b. Click Actions > Save as Page. 
c. On the Save as Section dialog box, do one of the following: 

 To create a new section, click New. On the dialog box that opens, type a unique name 
and an optional description, and then click OK. 

 To overwrite an existing section, highlight the section you wish to replace on the 
Section column and then click OK. When asked to confirm overwriting the existing 
section, click Yes. 

 
 If the section you are overwriting is used in an existing composite spec, you will 

receive a warning regarding the possible effect of this on existing composite specs 
and asked to re-confirm overwriting the section. 

 If you modified section coordinates, verify that the modified section appears as it 
should in composite spec(s). 
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S E C T I O N  2 5  

Spec Title Blocks 
A specification title block is a shipped or custom .psr file that combines revision rows, database 
fields, and a logo.  You assign a title block to a spec form to display the relevant information in 
specifications based on that form.  If a form contains several pages, the title block is common to 
every page of the form.  In a generated single-section spec, the software displays the same title 
block on every spec page, including the Notes page.  In a generated composite (multi- section) 
spec, the software does not display the title block; you need to open a spec print preview to display 
the title block. 
The System Administrator, when making or modifying domain definitions in the Administration 
module, can select a custom title block assignment method.  The following title block assignment 
methods are available: 
Standard (used in all modules) 
This method allows you to associate one default title block with all the specs you generate.  When 
using this method, the software hides all the title block assignment options that are available in the 
Specifications module.  In this case, you need to associate your title block with SmartPlant 
Instrumentation on the Title Blocks dialog box.  The Domain Administrator, when managing 
reports, can then define your title block as the default title block that appears automatically in all 
specifications that you generate. 

 
 If you print specs using the A4 sheet size, we recommend that you use the Specs Default TB 

with PB Units.psr title block with specs, which is fully compatible with all the library forms and 
does not require any manual adjustments.  This is a template title block that is shipped with 
SmartPlant Instrumentation.  This title block is created using PowerBuilder units. 

 If you print specs using the Letter sheet size, you must first customize the Specs Default TB 
with PB Units.psr title block in InfoMaker by reducing the title block height.  Removing two 
revision rows from the title block is enough to make it appear correctly in a printout of any spec 
based on a library form. 

 If you want to use a custom title block, you need to place the title block correctly in a spec page 
layout.  To do so, on the Preferences dialog box,  Specifications > Custom page, under 
Parameter, enter TitleFooterHeight, and under Value, enter 798, which is the optimal value 
for specifications created using SmartPlant Instrumentation options.  For a spec page created 
in InfoMaker, you may need to enter a different value, depending on the page layout settings. 

Special (used in the Specifications module only) 
This method allows you to assign various title blocks to spec forms.  If this method is defined in 
the current domain, the Domain Administrator does not assign any default title block to your 
specs, so you need to make title block assignments by yourself, using the Specifications module 
options.  You can create multiple custom title blocks and associate then with SmartPlant 
Instrumentation using the Title Block Styles dialog box.  Depending on your database platform, 
you must only use one of the following title blocks as a source for creating custom title blocks: 
tb_mss.psr (when using SQL Server), tb_ora.psr (when using Oracle, or Tbsample.psr (when 
using Sybase Adaptive Server Anywhere). 

 When working with composite specs, you cannot use the title block assignment options 
that are available in the Specifications module.  Therefore, if the selected block assignment 
method is Special, the software automatically assigns the default title block to a composite spec 
even though the module- specific option are available in the Specifications module.  This title 
block is supplied with SmartPlant Instrumentation and is associated by default with all SmartPlant 
Instrumentation reports. 
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Title Block in a Multi-Tag Spec 
A multi-tag specification does not require any special procedure for associating a title block.  The 
software associates a title block with a multi-tag page through the spec form that it belongs 
to.  That is, when a multi-tag spec form has an associated title block, this title block appears 
automatically on all pages of the spec.  When you open a multi-tag spec, the Multi-Tag List (see 
list) page appears without a title block.  However, if you open a print preview or print the 
specification, the software displays the same title block on all of the spec pages. 
 
 

Spec Title Block Common Tasks 
The following tasks deal with customizing, assigning, and modifying spec title blocks if the System 
Administrator, when making the current domain definitions, defined the custom title block 
assignment method as Special.  If the method is defined as Standard, you only need to 
associate a title block with SmartPlant Instrumentation using the Title Blocks dialog box 
options.  Then, your Domain Administrator can define this title block as the title block that appears 
in any spec you generate, regardless of the spec form or spec type. 

Customize a Title Block in InfoMaker 
This procedure allows you to customize a title block using Sybase InfoMaker.  After performing 
this procedure, you can insert the customized report layout into SmartPlant Instrumentation so 
that it becomes a custom title block.  For more information, see Customize a Title Block in 
InfoMaker (on page 267). 

Assign a Title Block to a Form 
Use this procedure to assign a title block that you created or edited in InfoMaker to a spec 
form.  You then set the block position and size within the form.  For more information, see Assign 
a Title Block to a Form (on page 268). 

Modify a Custom Title Block 
Use this procedure to modify a custom title block that you have already imported into SmartPlant 
Instrumentation from a .psr file.  The software automatically updates the title block in all spec 
forms that use this title block.  For more information, see Modify a Custom Title Block (on 
page 268). 

Update Custom Title Blocks After Version Upgrade 
After upgrading SmartPlant Instrumentation, you must manually update all of your custom title 
blocks based on the title block files Tb_ora.psr, Tb_mss.psr, Tbsample.psr.  Then, you need to 
reassign the title blocks to your spec forms.  For more information, see Update Custom Title 
Blocks After Version Upgrade (on page 269). 
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Customize a Title Block in InfoMaker 
 If, in SmartPlant Instrumentation, a Standard title block assignment method is defined, and 

you use the A4 sheet size to print specifications, you do not have to perform this 
procedure.  Instead, you can use the title block Specs Default TB with PB Units.psr file, that is 
supplied with SmartPlant Instrumentation.  However, if you want to print specs using the Letter 
size, you still need to make some adjustments even to the Specs Default TB with PB Units.psr 
title block. 
1. Start InfoMaker and a .psr file created on the basis of one of the following files: Tb_ora.psr 

(for use on Oracle), Tb_mss.psr (for use on SQL Server), or Tbsample.psr (for use in 
Sybase Adaptive Server Anywhere 

2. When adding other design- related items, such as internal lines, text boxes, and so forth, to 
the title block, add the tb segment to the names of the new items.  For example, if you want to 
add a new line, name the line as <Line>_tb_<1>.  This is required to distinguish between 
items that belong to the title block and items that belong to the rest of the report outside the 
title block. 

3. Modify the report layout using the following guidelines: 
 When you edit the logo field, do not change the value logo under Name, on the General 

tab of the Properties dialog box.  This is crucial if you intend to use Save as Excel 
options of SmartPlant Instrumentation to save specifications based on a form that 
incorporates this title block. 

 All the objects in the report layout, such as lines, text, field, and so forth must be defined 
as the Background Layer.  If you are creating a new object, make sure you change it from 
the default band layer to the Background Layer. 

 Objects that appear in the report layout one below another, such as revision rows, must 
be defined as Detail Band Layer. 

 If you add revision rows, make sure you decrease the row height so that the title block 
height is not greater than the default height of the title block you customize.  A custom title 
block whose height is greater than the default height causes display problems on the 
Note page of a SmartPlant Instrumentation specification. 

 Do not make any changes to SQL statements. 
 Do not include left or right borders since the border of the page will be used for the title 

block. 
 If you move any report layout items while working on the report layout, make sure you 

reposition those items exactly in their original locations. 
 

 You cannot insert a new field in the report layout.  You can only modify existing fields. 
 If you want to use the Specs Default TB with PB Units.psr in your specs and print specs 

using the Letter size, we recommend that you remove two revision rows from this title 
block in InfoMaker to adjust the title block height for the Letter size. 

 The width of the title block should not be greater than 7.5" in portrait layout or 9.8" in 
landscape layout.  If the title block width is greater than specified, an extra blank sheet is 
added to your drawing.  

4. Save the report layout under a different name and close InfoMaker. 
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Assign a Title Block to a Form 
1. On the Specifications Module window menu bar, click Actions > Title Block Styles. 
2. On the Title Block Styles dialog box, click New. 
3. On the Title Block Definition dialog box, select the appropriate .psr file, and click OK. 

 You must select a file created on the basis of one of the following files: Tb_ora.psr (for 
use on Oracle), Tb_mss.psr (for use on SQL Server), or Tbsample.psr (for use in Sybase 
Adaptive Server Anywhere). 

4. Under Style name, type the new title block name. 
5. Under Number of revisions, accept the displayed number of revision lines. 
6. Set the new title block size by using the four-directional arrows. 

 
 The red line outlines the title block border. 
 Under Units per click, type a numeric value to set how far the jump will take the red line 

when clicking one of the four-directional arrows. 
7. Click OK, and on the Title Block Styles dialog box, click Close. 
8. Set the location of the title block in the specification as follows: 

a. On the Specifications Module window menu bar, click Actions > Associate Title 
Block. 

b. On the Select Specification Form dialog box, select a form, and click OK. 
c. On the Associate Title Block dialog box, under Style Name, select the title block that 

you imported. 
d. Under Choose location, select Detail. 
e. Drag the title block to the required location in the specification page and when done, click 

OK. 
 
 

Modify a Custom Title Block 
1. On the Specifications Module window menu bar, click Actions > Title Block Styles. 
2. On the Title Block Styles dialog box, select the title block that you want to edit, and click 

Properties to open the Title Block Definition dialog box. 
 If you have made any changes to the title block in InfoMaker, click Open File, and then, 

select the title block .psr file and click OK. 
3. Under Style name, type the new title block name if needed. 
4. Under Number of revisions, set the number of revision lines to be displayed in the title block 

according to the revision lines that the title block contains. 
 If the number of revisions that you set is greater than the number of the revision rows, 

you might have display problems in the title block. 
5. Set the new title block size by using the four-directional arrows. 

 
 The red line outlines the title block border. 
 Under Units per click, type a numeric value to set how far the jump will take the red line 

when clicking one of the four-directional arrows. 
6. Click OK, and on the Title Block Styles dialog box, click Close. 
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Update Custom Title Blocks After Version Upgrade 
1. On the Specifications Module window menu bar, click Actions > Title Block Styles. 
2. On the Title Block Styles dialog box, select a title block based on Tb_ora.psr, Tb_mss.psr, or 

Tbsample.psr file, and click Properties. 
3. On the Title Block Definition dialog box, click Export File, and then, save this file as a .psr 

file, for example, Update.psr. 
4. Close SmartPlant instrumentation, and then, in InfoMaker, open the source .psr file, on which 

the Update.psr is based.  For example, if the source title block file is Tbsample.psr, you must 
open this file in InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 

5. Redraw the title block in InfoMaker according to the Update.psr title block requirements. 
6. Save this file as Update.psr to overwrite the current Update.psr file. 
7. Reopen SmartPlant instrumentation, and then, on the Specifications Module window menu 

bar, click Actions > Title Block Styles. 
8. On the Title Block Styles dialog box, select a title block, and click Properties. 
9. On the Title Block Definition dialog box, click Open File, and then, select the Update.psr file 

and click OK. 
10. On the Title Block Definition dialog box, click OK, to update the title block definition in the 

database and re-assign the updated title block to all the spec forms that use it. 
11. On the Title Block Styles dialog box, click Close. 
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S E C T I O N  2 6  

Copying Specification Data 
The automated data copying options are useful when you need to create a number of 
specifications with similar data.  You can use the following sources for copying specification data: 
 Form data template — You can copy data to any spec whose form is the same as the template 

form. 
 Specification — You can copy data either to another spec or to a form data template, provided 

that the source and target form is the same.  When you copy data to a form data template, the 
software does not affect data of existing specs that are based on this template. 

Data copying options are only available in the Specifications module.  You cannot copy 
specification data in batch mode. 
You can protect all or certain fields from being overwritten when you copy specification data.  You 
can protect the appropriate fields in the Spec Data Dictionary.  Also, you can set preferences for 
copying specification data.  The following options are available on the Preferences dialog box ( 
File > Preferences > Specifications > General): 
 Copy without overwriting existing data — Copies data to empty fields only.  This option 

does not overwrite data that already exists in the target form data template or spec. 
 Copy excluding blank fields in source — Copies data from source fields except for those 

source fields that have no data. 
 Copy all fields — Overwrites all data fields in the target form data template or spec. 

 
 

Copying Specification Data Common Tasks 
The following tasks enable you to copy spec data from one spec to another, or to use form data 
templates. 

Protect Fields from Overwriting When Copying Data 
Use this procedure to protect fields from overwriting of data when you copy specification data or 
import data from an external spec to a spec that exists in SmartPlant Instrumentation.  You 
perform this procedure at the form level.  The fields that you protect for a given form apply to all 
new form data templates you create for this form.  For more information, see Protect Fields from 
Overwriting When Copying Data (see "Protect Fields from Being Overwritten When Copying Data" 
on page 272). 

Copy Data from One Spec to Another 
Use this procedure to copy data from one spec to another.  You can copy data from a spec 
belonging to any plant group of the current <plant>.  The source and target spec form number 
must be the same.  For more information, see Copy Data from One Spec to Another (on 
page 274). 

Copy Data to a Spec from a Form Data Template 
Use this procedure to automate entry of common data to your specification by using a form data 
template that you created for the form upon which the current spec is based.  For more 
information, see Copy Data to a Spec from a Form Data Template (on page 273). 
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Copy Data to a Form Data Template from a Spec 
Use this procedure to copy a batch of data to a form data template from a specification.  This can 
be an efficient way of building the template, which you can then use to transfer common data to 
other specs based on the same form.  When you copy data to a form data template, the software 
does not affect data of existing specs that are based on this template.  For more information, see 
Copy Data to a Form Data Template from a Spec (on page 272). 
 
 

Protect Fields from Being Overwritten When Copying Data 
1. On the Specifications Module window toolbar, click  to open the Spec Data Dictionary. 
2. On the Select Specification Form dialog box, select a form, and click OK. 

3. On the toolbar, click  (Properties). 
4. To protect the fields in the correct form, do one of the following: 

 To protect all of the fields from one or more tables, click the Tables tab, and then, under 
Template Fields, click All for the appropriate tables. 

 To protect individual fields, on the Field Properties tab, in the Template column, select 
the appropriate check boxes. 

5. On the toolbar, click  to save the changes. 

See Also 
Create and Modify a Form Data Template (on page 232) 
 

Copy Data to a Form Data Template from a Spec 
1. Click File > Preferences > Specifications > General. 
2. Under Data copying options, select one of the following: 

 Copy without overwriting existing data — Copies data to empty fields only.  This 
option does not overwrite data that already exists in the target form data template. 

 Copy excluding blank fields in source — Copies data from source spec fields except 
for those source spec fields that have no data.  This means that if a certain field in the 
source spec does not have any value or only has spaces, the software ignores this field 
when copying data. 

 Copy all fields — Overwrites all data fields in the form data template.  A source field that 
only has spaces is considered blank. 
 The Domain Administrator can restrict the ability of other users to set their 

preferences.  Therefore, you can find that the data copying options are disabled.  If you want 
to enable these options, contact your Domain Administrator, who can manage preferences 
from the Administration module. 

3. On the Specifications Module window menu bar, module, click Edit > Form Data Template 
Editor. 

4. On the Select Specification Form dialog box, select a form that has a data template, and 
click OK. 

5. On the Select Form Data Template dialog box, select a form data template from the list. 
6. Click OK to open the form data template. 
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 If the form data template has fields that are not accessible, these fields are protected in 
the Spec Data Dictionary.  When copying data, the software ignores protected fields.  For 
details, see Protect Fields from Overwriting When Copying Data (see "Protect Fields from 
Being Overwritten When Copying Data" on page 272). 

7. On the menu bar, click Actions > Copy From. 
8. On the Find Item dialog box, under Form number, select the form of the spec you want to 

use for copying data, and click Find. 
9. Under Search results, select the item whose spec you want to use as a source for copying 

data. 
10. Click OK to copy the spec data. 

11. On the toolbar, click  to save the changes. 

See Also 
Create and Modify a Form Data Template (on page 232) 
 

Copy Data to a Spec from a Form Data Template 
1. Click File > Preferences > Specifications > General. 
2. Under Data copying options, select one of the following: 

 Copy without overwriting existing data — Copies data to empty fields only.  This 
option does not overwrite data that already exists in the target spec. 

 Copy excluding blank fields in source — Copies data from template fields except for 
those template fields that have no data.  This means that if a certain field in the form data 
template fields does not have any value or only has spaces, the software ignores this field 
when copying data. 

 Copy all fields — Overwrites all data fields in the spec.  A source field that only has 
spaces is considered blank. 
 The Domain Administrator can restrict the ability of other users to set their 

preferences.  Therefore, you can find that the data copying options are disabled.  If you want 
to enable these options, contact your Domain Administrator, who can manage preferences 
from the Administration module. 

3. In the Specifications module, open the spec to which you want to copy data. 
4. On the menu bar, click Actions > Copy from Template. 
5. On the Select Form Data Template dialog box, select a form data template from the list. 
6. Click OK to copy the data from the selected form data template to the specification. 
7. Save the specification. 

See Also 
Create and Modify a Form Data Template (on page 232) 
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Copy Data from One Spec to Another 
1. Click File > Preferences > Specifications > General. 
2. Under Data copying options, select one of the following: 

 Copy without overwriting existing data — Copies data to empty fields only.  This 
option does not overwrite data that already exists in the target spec. 

 Copy excluding blank fields in source — Copies data from source spec fields except 
for those source spec fields that have no data.  This means that if a certain field in the 
source spec does not have any value or only has spaces, the software ignores this field 
when copying data. 

 Copy all fields — Overwrites all data fields in the target spec.  A source field that only 
has spaces is considered blank. 
 The Domain Administrator can restrict the ability of other users to set their 

preferences.  Therefore, you can find that the data copying options are disabled.  If you want 
to enable these options, contact your Domain Administrator, who can manage preferences 
from the Administration module. 

3. In the Specifications module, open the spec to which you want to copy data. 
4. On the menu bar, click Actions > Copy from Specification. 
5. On the Find Item the dialog, under Form number, select the form upon which your 

specification is based, and click Find. 
6. Under Search results, select the item whose specification you want to use as a source for 

copying data. 
 When you copy data to a spec, be careful when overwriting existing data.  In the Spec 

Data Dictionary, you can define fields that you do not want to overwrite.  For more details, 
see Protect Fields from Overwriting When Copying Data (see "Protect Fields from Being 
Overwritten When Copying Data" on page 272). 

7. Click OK to copy the data. 
8. Save the specification. 
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Spec Revisions and Data Comparison 
You use revisions to keep track of changes in your specifications.  If the Domain Administrator 
has set the software to archive revisions, you can view, print, and compare previous revisions of 
specifications with the current versions. 
You can manage spec revisions in the following ways: 
 Locally — managing revisions that belong to a currently open spec.  When managing 

revisions locally, you open a particular spec and then open the Revisions dialog box, where 
you can add, edit, or delete current spec revisions.  In this dialog box, when you first select a 
revision numbering method, several options are available to you, including preliminary 
revisions (designated by P0, P1, P2…).  After you select one of the other revision methods, 
you can no longer return to the preliminary revision method and this option becomes 
disabled.  When using SmartPlant Foundation revisions, the revision numbering methods are 
not available for selection.  Only the last five revisions appear in the Revisions dialog box or 
in the spec title block. 

 Globally — managing revisions that belong to any number of existing specs.  You do not need 
to open the Specifications module to manage revisions globally, only the Global Revisions 
dialog box.  Also, if you want to view all revisions belonging to all existing specs, in the 
Specifications module, you need to click Actions > Manage Spec Revisions.  If you want to 
print out revisions belonging to various specs, you can click Actions > Spec Revisions. 

In the Specifications module, you cannot revise instrument specifications that you assigned to a 
Specification Binder package in the Document Binder module.  Therefore, the software prevents 
you from adding new revisions to these specs, or delete these spec revisions. 
 
 

Revision and Data Comparison Common Tasks 
The following tasks deal with managing spec revisions and comparing spec data. 

Manage Spec Revisions Locally 
Use this procedure to add, edit, and delete specification revisions locally.  For more information, 
see Manage Spec Revisions Locally (on page 276). 

Manage Spec Revisions Globally 
Use this procedure to maintain specification revisions in batch mode, using global revision 
options.  For more information, see Manage Spec Revisions Globally (on page 277). 

View and Print Spec Revisions 
Use this procedure to view and print archived revisions belonging to existing specs.  By default, 
the dialog box displays all archived revisions in the more <plant>.  For more information, see View 
and Print Spec Revisions (on page 278). 

Compare Current Data with a Saved Revision 
Use this procedure to compare data in the current specification with a specification that was 
archived as a previous revision.  This option enables you to generate a report that shows the data 
changes.  You can also set fonts and color to display the changes.  For more information, see 
Compare Current Data with a Saved Revision (on page 278). 
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Compare Current Data with a Saved Spec 
Using this option you can compare data in the current specification with a specification that you 
saved as an .isf file.  This option enables you to generate a report that shows the data 
changes.  You can also set fonts and color to display the changes.  For more information, see 
Compare Current Data with a Saved Spec (on page 278). 

View Data History 
SmartPlant Instrumentation can indicate specification data changes by comparing current data 
with the data stored in the audit trail repository for the date range that you specify.  You can set a 
color to mark changes, set a shade of gray to emphasize the changed data in printed reports and 
their previews, and also set bold and italic font style for emphasis on the screen and in 
print.  History indication is available only if the System Administrator has activated the audit trail 
functionality.  When the audit trail functionality is activated, each time that you save data after 
making changes, the data is recorded in the audit trail repository.  For more information, see View 
Data History (on page 279). 

Change Storage Method of Specification Revisions 
Use this procedure to convert specification revisions from one storage format to another.  By 
default, the software stores spec revisions in the database and compresses the revision data 
automatically to save space.  You can save revisions to the SmartPlant Instrumentation database 
or as external .psr files, or compress them and save as a single .zip file.  You can only perform 
this procedure after the Domain Administrator, in the Report Management dialog box, specifies 
the folder for saving spec revisions as .psr or .zip files.  Saving revisions in .zip or .psr format is 
useful when you have made a large number of revisions, and want to reduce the size of your 
database.  For more information, see Change Storage Method of Specification Revisions (on 
page 280). 

Delete Spec Revisions 
Use this procedure to delete one or more spec revisions in batch mode.  You can select and 
delete revisions that belong to different specs.  For more information, see Delete Spec Revisions 
(on page 280). 
 
 

Manage Spec Revisions Locally 
1. Open a spec. 
2. Do one of the following: 

 Click Actions > Revisions. 

 On the toolbar, click . 
3. In the Revisions dialog box, select one of the revision numbering methods (use P0, P1, P2... 

for preliminary revisions or 0, 1, 2 / A, B, C, and so forth for normal serial revisions). 

 
 When you first select a revision numbering method, several options are available to you, 

including preliminary revisions (designated by P0, P1, P2…).  After you select one of the 
other revision methods, you can no longer return to the preliminary revision method and 
this option becomes disabled. 

 When working with revisions in an integrated environment, the revision numbering 
methods are not available for selection. 
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 Only the last five revisions appear in the Revisions dialog box, or in the revision title 
block.  To view all revisions of the current spec, click Actions > Compare with Revision. 

4. Click New to add new revision data or update the existing data as desired. 

 
 SmartPlant Instrumentation automatically adds a new line with the next logical character 

and date each time you click New after you select the initial method. 
 If you are working in an integrated environment in a module that supports publishing and 

retrieving of documents, clicking New opens the Revise dialog box for the integrated 
environment instead of the SmartPlant Instrumentation Revisions dialog box. 

5. Add or edit the revision data in the appropriate boxes. 
 The By box contains the current user's initials by default, if previously defined by the 

System Administrator in the Administration module.  You can also edit this setting if required. 
6. To delete revisions locally you no longer require, select the revisions and click Delete. 
 
 

Manage Spec Revisions Globally 
1. In the main SmartPlant Instrumentation window, click Tools > Global Revisions. 
2. On the Settings tab, under Activity, do one of the following: 

 Select Add Revision to add revisions to instrument tags without checking the current 
revision settings. 

 Select Upgrade Revision to add revisions to instrument tags according to defined 
criteria. 

3. Enter the required revision information. 
4. Click the Specifications tab. 
5. Select all or particular specs that you want to revise. 

 
 To select multiple specs, use the Shift or Ctrl key. 
 Multi-tag specs only appear at the end of the list when you select the Select all check 

box.  The Tag Number box displays the text SEE LIST with the number of the master tag 
enclosed in parentheses. 

6. Click Apply to add the revisions to the specs of the selected instrument tags. 

 
 If any of the specs selected for revision is assigned to a Specification Binder package, that 

spec does not undergo a revision and the software displays an appropriate 
message.  Afterwards, a list of the specs that were not revised is displayed, and the reason 
appears in the Comment field. 

 You can click Print to print the list of specs for which the revision failed, or click Save As to 
save the list to a file.  These buttons appear after the software could not revise certain specs. 
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View and Print Spec Revisions 
1. In the Specifications module, click Actions > Spec Revisions. 
2. Under Revision filter, define filter parameters as needed and then select Apply. 

 
 By default, the dialog box displays all archived revisions in the <plant>.  You can select a 

specific plant group to filter the revisions accordingly.  To revert to the default display, in 
the Plant group box, select the empty row.  Also, you can filter revisions by spec form 
number, or type a specific number in the Revision box. 

 You can also search for a revision by tag number or document number by entering the 
appropriate values under Find. 

3. In the data window, select one or more revisions that you want to view or print out, and click 
OK. 

 
 

Compare Current Data with a Saved Revision 
1. Open a spec. 
2. Click Tools > Data Comparison Display Options and set font and color settings for 

comparison as you require. 
3. On the Actions menu, click Compare with Revisions to open a dialog box with a list of 

available revisions for the current spec. 
4. Select a revision and click OK. 
5. In the dialog box that opens, click Yes to preview the report, or No to print the report without 

previewing. 

 
 If you clicked Yes to preview the report, close the preview window to see the specification with 

the changes indicated. 
 The report shows the names of the columns that were changed: Spec Report Value shows 

the current data, and External Spec Value shows external file data. 
 SmartPlant Instrumentation displays your specification with changed fields indicated 

according to your settings in the Data Comparison Display Options dialog box. 
 
 

Compare Current Data with a Saved Spec 
1. Open a spec. 
2. Click Tools > Data Comparison Display Options and set font and color settings for 

comparison as you require. 
3. On the Actions menu, click Compare with External. 
4. In the Select File for Comparison dialog box, navigate to the required .isf file and click OK. 
5. In the dialog box that opens, click Yes to preview the report, or No to print the report without 

previewing. 

 
 If you clicked Yes to preview the report, close the preview window to see the specification with 

the changes indicated. 
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 The report shows the names of the columns that were changed: Spec Report Value shows 
the current data, and External Spec Value shows external file data. 

 SmartPlant Instrumentation displays your specification with changed fields indicated 
according to your settings in the Data Comparison Display Options dialog box. 

 
 

View Data History 
 History indication is available only if the System Administrator has activated the audit trail 

functionality.  When the audit trail functionality is activated, each time that you save data after 
making changes, the data is recorded in the audit trail repository. 
1. Open a spec. 
2. Click Options > History Options. 
3. Do one of the following to select the date range for data history comparison: 

 In the From and To boxes, type the appropriate dates or use the spinners. 
 To set the To data field value as today's date, click Today. 

4. To set a font style to emphasize changes on the screen and in print, select Bold or Italic, or 
both check boxes. 

5. To change the color used to display changes on the screen, do the following: 

a. Beside the Highlight color for display box, click . 
b. On the Color dialog box, choose the color that you require. 
c. Click OK to save your new color settings and return to the History Options dialog box. 

6. To change the shade of gray used to emphasize the changed data in printed reports and their 
previews, do the following: 

a. Beside the Grayscale for printing box, click . 
b. On the Grayscale dialog box, slide the bar to the required position. 
c. Click OK to save your new grayscale settings and return to the History Options dialog 

box. 
7. Click OK to save your current history options and close the History Options dialog box. 
8. On the Options menu, click Mark Changes to mark changes in the current specification for 

the dates that you specified in the History Options dialog box. 

 
 To refresh the history indication in an open specification, on the Options menu, clear Mark 

Changes and then select this option again. 
 The software does not mark changes in a spec note, or in a large note page. 
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Change Storage Method of Specification Revisions 
1. Open the Specifications module. 
2. On the Actions menu, click Manage Spec Revisions. 

 To display specifications of one revision only, under Revision filter, type the revision 
number and click Apply. 

3. Under Select spec revisions, select one or more revisions whose storage method you want 
to change. 

4. Under Change storage method, do one of the following: 
 Select PSR files to save each revision as an external .psr file in the location specified in 

the Administration module.  This option is only available after the Domain Administrator, 
in the Report Management dialog box, specifies the folder for saving spec revisions as 
.psr or .zip files. 

 Select ZIP file to save all the selected revisions as a single external .zip file in the location 
specified in the Administration module.  This option is only available after the Domain 
Administrator, in the Report Management dialog box, specifies the folder for saving spec 
revisions as .psr or .zip files. 

 Select Database to save the revision to the SmartPlant Instrumentation database.  For 
this option, the data is automatically compressed to save disk space. 

5. Click Change method. 
 
 

Delete Spec Revisions 
1. In the Specifications module, click Actions > Manage Spec Revisions. 
2. Filter revisions as you require. 

 If you want to display revisions defined for all specs that exist in all of your plant groups, 
under Plant group, select the empty row. 

3. Select one or more revisions. 
4. Click Delete. 

 When you delete a revision, the software does not delete the spec itself.  Deleting a spec, 
however, always deletes all of the spec revisions automatically. 
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Save, Export, and Import Options 
SmartPlant Instrumentation supports saving spec data in the following formats: 
 .isf (only specs whose item type is Instrument) 
 .psr (any single-tag spec, multi- tag spec, or a non-instrument spec) 
 .xls (only specs whose item type is Instrument) 

To edit a specification in an external application, you need to save the specification in a format that 
the external application supports.  You can export specifications individually or in batch 
mode.  You can export specification data to the following specifications: 
 External Editor (supplied with the SmartPlant Instrumentation software package) — Supports 

working with spec data saved in .isf format, allows you to convert .psr files to .isf format, and 
import data from .isf files to SmartPlant Instrumentation. 

 InfoMaker — Supports working with spec data saved in .psr format, does not allow you to 
import data from .psr files.  You first need to convert .psr files to .isf format in External Editor. 

 Excel — Supports working with spec data saved in .xls format., does not allow you to import 
data from Excel files back to SmartPlant Instrumentation. 

 
 

Save, Export, and Import Options Common Tasks 
Use the following tasks to save specs in .isf, .psr, or .xls format one by one or in batch more.  Also, 
these tasks enable you to import data to specs using External Editor. 

Save a Spec in PSR Format 
Use this procedure to save a single specification in .psr format for opening in InfoMaker.  You 
cannot work with .psr files in External Editor.  However, in External Editor, you can then convert 
.psr files to .isf format, and edit the specification data as you require.  For more information, see 
Save a Spec in PSR Format (on page 282). 

Save an Instrument Spec in ISF Format 
Use this procedure to save an instrument specification document in .isf format so that you can 
open it in External Editor, which is supplied with SmartPlant Instrumentation.  You can use 
External Editor to view and edit specifications.  After editing, you can import the changed data 
back into your specs in SmartPlant Instrumentation.  For more information, see Save an 
Instrument Spec in ISF Format (on page 283). 

Save Instrument Specs in Batch Mode 
Use this procedure to save a group of selected instrument specifications.  You can save a batch 
of instrument specs either as .psr files or .isf files.  If you choose the .psr format, you can then 
open the .psr files in InfoMaker.  Saving specs in .isf format allows you to edit the specs in 
External Editor, which is supplied with SmartPlant Instrumentation.  For more information, see 
Save Instrument Specs in Batch Mode (on page 283). 

Save an Instrument Spec in Excel Format 
Use this procedure to save a currently open instrument specification in Excel format.  For more 
information, see Save an Instrument Spec in Excel Format (on page 283). 



Specifications 
 

 
282 SmartPlant Instrumentation Basic Engineering User's Guide 

 

Batch Save of Instrument Specs in Excel Format 
Use this procedure to select a group of instrument tags and save their specifications in Excel 
format.  For more information, see Batch Save of Instrument Specs in Excel Format (on 
page 284). 

Protect Fields Before Exporting Specs to External Editor 
Use this procedure to protect all or specific fields whose values you do not want to be available for 
editing in External Editor.  After you save the spec as an .isf file, and open it in External Editor, the 
fields that you protected appear as view- only.  For more information, see Protect Fields Before 
Exporting Specs to External Editor (on page 284). 

Import Data to a Specification from an External File 
Use this procedure to import data from an external specification file in .isf format to the current 
specification.  If the format of the external specification is .psr, you can use External Editor to 
convert the files to .isf format.  The external specification must be based on the same form as the 
target specification.  If you attempt to copy data from a specification based on a different form, the 
software displays an appropriate message.  For more information, see Import Data to a 
Specification from an External File (on page 285). 

Import Data to Instrument Specs in Batch Mode 
You can import data from external files to instrument specifications in batch mode.  You need to 
specify a source file folder and then select the .isf files from which you want to import data.  The 
software imports data to instrument specifications by matching the tag numbers in the source .isf 
files and target specifications that exist in SmartPlant Instrumentation.  SmartPlant 
Instrumentation does not support importing data in batch mode to multi-tag (see list) specs.  For 
more information, see Import Data to Instrument Specs in Batch Mode (on page 285). 
 
 

Save a Spec in PSR Format 
1. Open a specification. 
2. Click Actions > Save As. 
3. Select Original, and click OK. 
4. In the dialog box that opens, under Save as type, select PowerSoft Report (PSR) format 

(*.PSR). 
5. Select the folder where you want to save the files, type the name of the target .psr file, and 

click Save. 
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Save an Instrument Spec in ISF Format 
1. Open an instrument specification that you want to save in .isf format. 
2. Click Actions > Export Data. 
3. In the Save to File dialog box, select the folder where you want to save the files. 
4. Enter the target file name, and click Save. 

 SmartPlant Instrumentation does not support saving non-instrument specifications in .isf 
format. 
 
 

Save Instrument Specs in Batch Mode 
1. Open the Specifications module, and click Actions > Save as Files. 
2. In the Save as Files dialog box, under Select file format, do one of the following: 

 Select ISF to save the files in .isf format for opening in External Editor. 
 Select PSR to save the files in .psr format for opening in InfoMaker. 

3. Click Browse. 
4. In the Select Folder dialog box, specify a desired folder, and click Save. 
5. Click Find. 
6. In the Find Items dialog box, define search parameters as you require and click Find to 

display a list of tags according to the search parameters. 
7. Select one or more tags and click OK to return to the Save as Files dialog box. 
8. In the Save as Files dialog box, click OK. 

 Saving specifications as .psr or .isf files in batch mode is only available when the 
specification item type is Instrument. 

See Also 
Single-Tag Specs (see "Single-Tag Specifications" on page 235) 
 

Save an Instrument Spec in Excel Format 
1. Open an instrument specification. 
2. Click Actions > Save as Excel. 

 In the generated Excel files, graphic elements within title blocks display as 
designed.  SmartPlant Instrumentation does not support export of other graphic elements to 
Excel format. 

See Also 
Save as Excel (on page 287) 
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Batch Save of Instrument Specs in Excel Format 
1. In the main window of the Specifications module, click Actions > Save as Excel. 
2. In the dialog box that opens, find specs that you want to save in Excel format. 
3. In the Search results data window, select the instrument tags whose specs you want to save 

in Excel format. 

 
 After you install a new SmartPlant Instrumentation version or service pack, if you 

previously saved specifications in Excel format, rename the previous result files or move 
them from the target folder.  You can change the default settings for the target folder, on 
the Preferences > Specifications > Save as Excel tab. 

 If you previously saved specs in Excel format, and do not want to overwrite existing result 
files, you should rename the previous files or move them from the target folder. 

 If you previously saved multi-tag specifications in Excel format and then made changes to 
the format upon which these specifications are based, you should rename the previous 
result files or move them from the target folder before exporting further specifications 
based on that format. 

4. Click OK to start exporting the spec data to Excel. 

 
 In the generated Excel files, graphic elements within title blocks display as 

designed.  SmartPlant Instrumentation does not support export of other graphic elements to 
Excel format. 

 Specifications sharing a common form are saved in a common Excel file.  For example, specs 
based on form 11 might be saved in file T_Form11_0.xls.  To set the preferences to create an 
individual Excel file for each spec, on the Preferences > Specifications > Save as Excel tab, 
under Saving method, select Separate file for each tag. 

See Also 
Save as Excel (on page 287) 
 

Protect Fields Before Exporting Specs to External Editor 
1. On the Specifications module toolbar, click  to open the Spec Data Dictionary. 
2. In the Select Specification Form dialog box, select the form for which you want to set field 

protection, and click OK. 

3. On the Spec Data Dictionary toolbar, click  to open the Field Properties tab. 
4.  Do one of the following: 

 To protect individual fields, on the Column Headers tab, under Editable in IEE, clear the 
check boxes for the fields you want to protect. 

 To protect all of the fields belonging to a given database table, click the Tables tab, and 
then, under Editable in IEE, click No. 

5. On the toolbar, click  to save the changes. 
 You perform this procedure at the form level.  This means that the fields that the field 

protection applies to any instrument specification based on this form.  Field protection does not 
apply to existing specs saved as .isf files. 
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Import Data to a Specification from an External File 
 When importing data to an existing spec, the software can overwrite existing 

data.  To prevent all automated overwriting of existing specification data, in the Preferences 
dialog box, under Data copying options, select Copy without overwriting existing data.  Also, 
in the Spec Data Dictionary, you can set fields as unavailable for editing in the form data 
template or in specs based on the current form. 
1. Open a specification in the specifications module. 
2. Click Actions> Import Data. 
3. In the Open File dialog box, select the source .isf file. 
4. Click Open to import the data from the source file to the specification. 

 If the imported data includes manufacturers and models that do not appear in the 
Instrument Manufacturer or Instrument Model supporting tables, the software automatically 
adds them during the import process. 

5. Edit the specification as necessary and then click  to save the changes. 
 
 

Import Data to Instrument Specs in Batch Mode 
 SmartPlant Instrumentation does not support importing data in batch mode to multi- tag 

(see list) specs. 
1. In the Specifications module, click Actions > Import Data. 
2. Beside Source folder, click Browse to specify the folder where the source .isf files are 

located. 
 In the Log file name and path box, the software displays the default path of the log file 

IMPORT_ISF.LOG.  SmartPlant Instrumentation creates this file after importing data.  If you 
previously imported data, this log file already contains records of the previous import 
session.  If you do not change the log file path for the current import session, the software 
adds new records of the current import session in the same file.  To create a new file 
IMPORT_ISF.LOG, you can click Browse and specify a different log file path. 

3. Under Select source files, select the desired .isf files. 
 

 When importing data to an existing spec, the software can overwrite existing data.  To 
prevent all automated overwriting of existing specification data, in the Preferences dialog 
box, under Data copying options, select Copy without overwriting existing 
data.  Also, in the Spec Data Dictionary, you can set fields as unavailable for editing in 
the form data template or in specs based on the current form. 

 If you select Ignore form ID in database, the software imports data into specifications 
even when in the source and target specifications, the internal ID numbers of the 
specification form are different. 

4. Click Import. 
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Save as Excel 
You can use SmartPlant Instrumentation Save as Excel options to save specifications in Microsoft 
Excel format.  You can then use any of the Excel functionalities to edit the exported 
specifications.  The software allows you to save all specs that share a common spec form to a 
single Excel file.  For example, you can save specifications based on form 11 in file 
T_Form11_0.xls.  If needed, you can set the Save as Excel preferences so that you can create an 
individual Excel file for each specification.  The default target folder is the SPI_SaveAsExcel 
folder under the user's base folder.  

 To locate the user's base folder, click the Windows Start > Run > %userprofile%. 
You can specify a different path and folder by changing the Save as Excel preferences. 
The Excel workbook opens displaying the specification with the lowest tag number.  If the file that 
you opened contains multi-page specs, each page is displayed on a separate Excel worksheet.  If 
you exported multi-tag specifications, the multi-tag list is displayed on the Excel See List 
worksheet.  The notes are displayed on the Excel Notes worksheet. 

  
 In Excel 2003, you need to set macro security to Medium. 
 In Excel 2007, to turn pages, click the Add-Ins tab and then click the appropriate arrow.  

Supported Spec Types 
You can only use Save as Excel options with specs whose item type is Instrument (single-tag or 
multi-tag specs).  SmartPlant Instrumentation does not support Save as Excel options for specs 
whose item type is other than instrument, or whose form contains page sections. 

 If you previously saved multi- tag specifications in Excel format and then made changes to 
the format upon which these specifications are based, you should rename the previous result files 
or move them from the target folder before exporting further specifications based on that format. 

Font Style 
Regardless of the font of the original specification, the text font style in the target Excel file is Arial. 

Graphics and Other Embedded Objects 
Graphic elements, for example, the logo image, or other .bmp graphics are not shown in the target 
Excel file.  SmartPlant Instrumentation does not support export of embedded objects to Excel, for 
example, equations. 
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Customizing Specs for Save as Excel Common Tasks 
Before you save a specification in Excel format, you need to check the source spec for elements 
that can cause various display problems in Excel.  The following topics describe how to customize 
your spec page to avoid display some of possible displays problems in Excel. 

Guidelines for Customizing Pages for Save as Excel 
In general, specs based on SmartPlant Instrumentation library pages export accurately to 
Excel.  However, if you want to save specs in Excel format, you might need to familiarize yourself 
with the following guidelines, that enable you to fine- tune you spec pages and save specs 
accurately in Excel format.  After you create forms and specifications based on such pages, you 
can then save these specs accurately in Excel format.  For more information, see Guidelines for 
Customizing Pages for Save as Excel (on page 289). 

Guidelines for Customizing PSR Files for Save as Excel 
In general, specs based on SmartPlant Instrumentation library pages export accurately to 
Excel.  When you customize .psr pages in InfoMaker, use these guidelines for compatibility with 
Excel.  After you import such pages into SmartPlant Instrumentation, include them in a form, and 
generate specs based on this form, you can then save these specs accurately in Excel 
format.  For more information, see Guidelines for Customizing PSR Files for Save as Excel (on 
page 290). 

Create an Invisible Vertical Zero Line 
Use this procedure to Open a Form Page in InfoMaker and create an invisible vertical grid line for 
which the X values are 0.  If a form upon which specifications are based contains vertical fields, it 
must fulfill one of the following two conditions for correct export to Excel: 
 The X values of the left-hand vertical grid line must be 0. 
 You create an invisible line for which the X values are 0. 

Modifying a form to fulfill either of these conditions can also improve the display of other features, 
for example, select lists.  For more information, see Create an Invisible Vertical Zero Line (on 
page 291). 

Replace Double Lines with Thick Single Lines 
There are several situations in which a particular choice of line elements within a form yields 
non-standard Excel spreadsheets following a Save as Excel operation.  Use this procedure if your 
specification is based on a form that contains double grid lines.  Use of double lines instead of 
single thick lines can cause a display problem in Excel.  For more information, see Replace 
Double Lines with Thick Single Lines (on page 292). 

Correct a Line Discontinuity 
In general, a spec page is divided into three side-by-side components — parameter categories, 
field headers, and field values.  For correct translation to Excel, perform this procedure so that a 
horizontal row line that spans more than one vertical component becomes a continuous line rather 
than separate lines with imprecise continuity.  For more information, see Correct a Line 
Discontinuity (on page 292). 
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Correct Horizontal and Vertical Divergence of Grid Lines 
Use this procedure to correct horizontal and vertical divergence of grid lines.  Lines that are not 
exactly horizontal or lines that are not exactly vertical can be sources of display problems when 
you save SmartPlant Instrumentation specifications in Excel format.  For more information, see 
Correct Horizontal and Vertical Divergence of Grid Lines (on page 292). 

Set Value Display Precision for Save as Excel Globally 
Use this procedure to set the number of decimal digits that you want to display in the Excel cells 
after saving specs in Excel format.  The default global Save as Excel precision is two decimal 
places.  In general, process data and calculation values that SmartPlant Instrumentation stores in 
the database are of greater precision than the values that Excel displays in the cells of generated 
specs.  You perform this procedure in SmartPlant Instrumentation.  For more information, see 
Set Value Display Precision for Save as Excel Globally (on page 293). 

Set Value Display Precision for Individual Fields 
Use this procedure to override the global precision for individual fields in a particular spec 
page.  In general process data and calculation values that SmartPlant Instrumentation stores in 
the database are of greater precision than the values that Excel displays in the cells of generated 
specs.  When you save a specification as an Excel file, SmartPlant Instrumentation reformats the 
display precision for Excel.  The default global Save as Excel precision is two decimal 
places.  You perform this procedure in InfoMaker.  For more information, see Set Value Display 
Precision for Individual Fields (on page 293). 
 

Guidelines for Customizing Pages for Save as Excel 

Graphic Limitations of the Excel Environment 
The Page Editor of SmartPlant Instrumentation allows you freedom in designing specification 
pages, with few limitations on the layout of data fields, fields with computed values, text fields, and 
lines.  But when designing pages for Excel compatibility, it is important to keep in mind that an 
Excel worksheet is basically a grid of cells.  Although a standalone Excel spreadsheet supports 
random placement of text, value, and line objects, Save as Excel works best if you imagine an 
Excel grid underlying your page. 

Fine-Tuning the Grid and Lines 
Although you can use the mouse to create and place lines, you must fine-tune the grid by referring 
to the Line Position pop-up window for each line object.  After you set the major lines of the page 
grid, you can insert database fields, computed fields, text fields, and lines.  Verify the following: 
 All lines are either exactly vertical lines or exactly horizontal. 
 For every vertical line, BeginX = EndX. 
 For every horizontal line, BeginY = EndY. 
 Left/right external border lines share common BeginY (top) and EndY (bottom) values. 
 Top/bottom external border lines share common BeginX (left end) and EndY (right end) 

values. 
 When one line ends by running into another, make sure that they share an X value or a Y 

value.  This prevents overshooting and undershooting. 
 Create as much of the grid as possible before creating text and value objects. 
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 Although there is no requirement for every line to run the entire length or width of the page, 
imagine an Excel grid underlying your page.  For example, if you inserted a vertical line near 
the top of the page at X = 500 PBU, if your mouse placement of a vertical line near the bottom 
of the page ended up at X = 505, make the X values consistent for both lines. 

 Similarly, if you inserted a horizontal line towards the left of the page at Y = 700 PBU, if your 
mouse placement of a horizontal line towards the right of the page ended up at Y = 705, make 
the Y values consistent for both lines. 

Left-Aligning Fields to Lines 
During the process of export from SmartPlant Instrumentation to Excel, the software associates 
each field with a vertical line to the left of the field.  To display the lines accurately, make sure the 
BeginX value of a field should equal the X values of the line to its left. 

Fine-Tuning Adjacent Fields 
 To prevent text cut-off, leave at least 5 PBU between adjacent fields.  The requirement to 

left-align fields to lines also applies to fields to the right of other fields. 
 For multiple fields between horizontal lines, set constant BeginY and EndY values for all of the 

fields.  The BeginY value should be several PBU greater than the Y values of the line above, 
and the End2 value should be several PBU less than the Y values of the line below. 

 
 

Guidelines for Customizing PSR Files for Save as Excel 

Graphic Limitations of the Excel Environment 
InfoMaker allows you to modify existing SmartPlant Instrumentation spec pages, with few 
limitations on the layout of text, value, line, and other objects.  When designing InfoMaker pages 
for Excel compatibility, it is important to keep in mind that an Excel worksheet is basically a grid of 
cells.  Although a standalone Excel spreadsheet supports random placement of text, value, and 
line objects, Save as Excel works best if you imagine an Excel grid underlying your InfoMaker 
page.  You cannot create an entirely new page in InfoMaker. 

Fine-Tuning the Grid and Lines 
Although you can use the mouse to create and place lines, you must fine-tune the grid by referring 
to the Properties > Position tab for each line object.  Verify the following: 
 All lines are either exactly vertical lines or exactly horizontal. 
 For every vertical line, X1 = X2. 
 For every horizontal line, Y1 = Y2. 
 Left/right external border lines share common Y1 (top) and Y2 (bottom) values. 
 Top/bottom external border lines share common X1 (left end) and X2 (right end) values. 
 When one line ends by running into another, make sure that they share an X value or a Y 

value.  This prevents overshooting and undershooting. 
 Create as much of the grid as possible before creating text and value objects. 
 Although there is no requirement for every line to run the entire length or width of the page, 

imagine an Excel grid underlying your InfoMaker page.  For example, if you inserted a vertical 
line near the top of the page at X = 500 PBU, if your mouse placement of a vertical line near 
the bottom of the page ended up at X = 505, make the X values consistent for both lines. 

 Similarly, if you inserted a horizontal line towards the left of the page at Y = 700 PBU, if your 
mouse placement of a horizontal line towards the right of the page ended up at Y = 705, make 
the Y values consistent for both lines. 
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Left-Aligning Fields to Lines 
After you set the major lines of the page grid, you can insert data fields and field headers, 
computed fields, fields displayed as select lists, check boxes, or option buttons.  During the 
process of export from SmartPlant Instrumentation to Excel, the software associates each field 
with a vertical line to the left of the field.  To ensure accurate display, the X1 value of a field should 
equal the X values of the line to its left.  The following lines are acceptable: 
 A visible vertical line on the left edge of the field 
 A visible vertical line, with X value equal to the X1 value of the field, but on a higher or lower 

part of the page 
 A vertical grid line, with X value equal to the X1 value of the field, and on the Properties > 

General tab, the Visible check box is cleared.  Even for such an invisible line, imagine an 
Excel grid underlying your InfoMaker page.  For example, if you inserted an invisible vertical 
line in one part of the page at X = 500 PBU, if your field placement at another part of the page 
ended up at X1 = 505, make the X values consistent for both lines.  For each invisible line, 

make sure that the icon to the right of Visible is displayed as .  If the icon is displayed as 

, click it, and in the dialog box that opens, delete the contents of the Expression pane, and 
then click OK. 

Fine-Tuning Adjacent Fields 
 To prevent text cut-off, leave at least 5 PBU between adjacent fields.  The requirement to 

left-align fields to lines also applies to fields to the right of other fields. 
 For multiple fields between horizontal lines, set constant Y1 and Y2 values for all of the 

fields.  The Y1 value should be several PBU greater than the Y values of the line above, and 
the Y2 value should be several PBU less than the Y values of the line below. 

 
 

Create an Invisible Vertical Zero Line 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. On the menu bar, click Insert > Control > Line. 
3. On the General tab of the Properties dialog box, do the following: 

a. Under Name, type l_coordinator. 
b. Clear the Visible check box. 

c. Make sure that the icon to the right of Visible is displayed as .  If the icon is displayed 

as , click it, and in the dialog box that opens, delete the contents of the Expression 
pane, and then click OK. 

4. On the Position tab, type the following settings: 
a. X1: 0 
b. Y1: 0 
c. X2: 0 
d. Y2: Type a value equal to or greater than the highest Y2 value on the form. 

5. On the menu bar, click File > Save. 
6. Import the page back into SmartPlant Instrumentation. 
7. Regenerate the spec page and specification, and save the specification again in Excel format. 
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Replace Double Lines with Thick Single Lines 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. Click the duplicate line, and then press the Delete key. 
3. Right-click the remaining line, and on the shortcut menu click Properties. 
4. On the General tab of the Properties dialog box, under Pen Width, use the spinners to set 

the new width of the line. 
5. On the menu bar, click File > Save. 
6. Import the page back into SmartPlant Instrumentation. 
7. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Correct a Line Discontinuity 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. Right-click the right-most line segment, and on the shortcut menu, click Properties. 
3. On the Position tab, under X2, copy the value to the Clipboard, using a standard Microsoft 

shortcut (for example, Ctrl+C). 
4. For each line segment to the right of the left-most segment, click the line segment, and then 

press Delete. 
5. Right-click the left-most line segment, and on the shortcut menu, click Properties. 
6. On the Position tab, under X2, paste the Clipboard value, using a standard Microsoft shortcut 

(for example, Ctrl+V). 
7. On the menu bar, click File > Save. 
8. Import the page back into SmartPlant Instrumentation. 
9. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Correct Horizontal and Vertical Divergence of Grid Lines 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. To correct a horizontal divergence, do the following: 

a. Right-click the divergent line, and on the shortcut menu click Properties. 
b. On the Position tab of the Properties dialog box, set the value under X1 equal to the 

value under X2. 
3. To correct a vertical divergence, do the following: 

a. Right-click the divergent line, and on the shortcut menu click Properties. 
b. On the Position tab of the Properties dialog box, set the value under Y1 equal to the 

value under Y2. 
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c. On the menu bar, click File > Save. 
4. Import the page back into SmartPlant Instrumentation. 
5. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Set Value Display Precision for Save as Excel Globally 
1. In SmartPlant Instrumentation, click File > Preferences > Specifications > Save as Excel. 
2. Under Accuracy level, enter the number of decimal digits that you want to display in specs 

you save in Excel format. 
3. Regenerate the Excel files for specs that you require. 

 
 If you want to set value display precision for a specific field, you need to open the spec page in 

InfoMaker, and then reformat the appropriate field as needed.  For details, see Set Value 
Display Precision for Individual Fields (on page 293). 

 You can also reformat individual fields in the Excel sheet, setting the appropriate number of 
decimal places.  However, you need to reformat these fields each time after saving this 
SmartPlant Instrumentation specification in Excel format. 

 
 

Set Value Display Precision for Individual Fields 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. For each field that you want to format, do the following to set the number of decimal places 

that are displayed in SmartPlant Instrumentation and later in Excel: 
a. Click in the field. 
b. On the Format tab of the Properties dialog box, under Format, type 0. followed by pound 

signs ( #) to indicate the required number of decimal places.  For example, 0. indicates no 
decimal places, 0.# indicates one decimal place, 0.### indicates three decimal places, 
and so forth. 

3. On the menu bar, click File > Save as File. 
4. On the Select File Name dialog box, type the file name that you require. 
5. Import the page back into SmartPlant Instrumentation. 
6. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
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Save as Excel Troubleshooting 
After saving a specification in Excel format, scan the resulting file for display errors.  The following 
list describes how to troubleshoot some of the possible errors. 

Resolve Spec Accessing Problem in a Common Excel File 
Use this procedure to be able to access every spec successfully after saving multiple specs in a 
common Excel file.  The procedure deals with changing Excel macro security to Medium.  If you 
are running Excel XP, macro security is set to High by default.  For more information, see Resolve 
Spec Accessing Problem in a Common Excel File (on page 296). 

Remove the Protection from a Spec Saved as Excel 
Use this procedure to remove the protection from a spec; For more information, see Remove the 
Protection from a Spec Saved as Excel (on page 296). 

Resolve a Data Saving Problem 
Use this procedure if you receive an error message stating that you "cannot save data... incorrect 
syntax" when you try to save specs in Excel format.  This problem can occur if your specifications 
are based on pages arranged with the text headers above the fields, rather than in separate 
vertical groupings.  You can use a headers-above-fields style, and avoid the error message by 
editing the x-coordinates of either the text headers or the fields to creating microscopic 
misalignment.  This procedure deals with editing the text headers.  After editing in InfoMaker, 
your pages can support specifications that you save in Excel format.  For more information, see 
Resolve a Data Saving Problem (on page 296). 

Resolve Grid Line Overlap Problems 
This topic provides a solution you need to implement in InfoMaker when labels and values overlap 
lines above or below.  For more information, see Resolve Grid Line Overlap Problems (on 
page 297). 

Correct Undershooting and Overshooting of Grid Lines 
Use this procedure to correct grid line display problems caused by correcting imperfect meeting of 
the outermost grid lines in the source spec page.  You can use this procedure to correct 
undershooting, when the lines do not meet, and overshooting, when at least one of the lines 
extends beyond the meeting point.  For more information, see Correct Undershooting and 
Overshooting of Grid Lines (on page 297). 

Prevent Truncation of Labels and Values 
This topic provides a troubleshooting solution you need to implement in InfoMaker when the right 
end of labels and values is displayed cut off.  For more information, see Prevent Truncation of 
Labels and Values (on page 298). 
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Fix Displaced Labels 
When you save specifications in Excel format, you may find displaced labels in the categories 
column — by default at the left of the page — or in the title block.  This problem can be caused by 
lack of coordination between the SmartPlant Instrumentation spec page upon which the 
specification is based and the row division in the Excel spreadsheet.  You have two options to 
assign the displaced label to a row: extend an existing horizontal line to pass above or below the 
displaced label, or normalize label coordinates, which you do by assigning to the displaced label 
the Y-coordinate of a row that spans the rest of the form.  For more information, see Fix Displaced 
Labels (on page 298). 

Fix Text Display in Excel Cells 
Use this procedure to fix incomplete display of text in a spec saved as Excel.  You can perform 
this procedure either in Excel or InfoMaker.  Cell content can be improperly displayed due to the 
width of the Excel columns.  This can occur in the following situations: 
 If the text string in a cell is longer than the width of the cell, and the cell to the right is empty, the 

text extends into the adjacent cell. 
 If the text string in a cell is longer than the width of the cell, and the cell to the right is not empty, 

the overlapping text is cut off. 
 If the cell is very narrow, no data appears in the cell.  By inserting the mouse pointer in the 

cell, you can view the cell contents in the formula bar. 
For more information, see Fix Text Display in Excel Cells (on page 299). 

Fix Function Conversion Problems 
Use this procedure to convert manually those SmartPlant Instrumentation functions used in the 
spec into Excel functions if automatic conversion was not successful.  When you save a 
specification in Excel format, SmartPlant Instrumentation converts its functions into Excel 
functions.  Where the conversion does not succeed, SmartPlant Instrumentation enters the 
calculated result into the relevant cell of the Excel spreadsheet, and does not display a formula in 
the formula bar.  This problem is likely to occur if you created your own specification function in 
InfoMaker.  For more information, see Fix Function Conversion Problems (on page 299). 

Set Value Display Precision 
Use this procedure if you encounter problems in process data or calculation value display 
precision in the Excel cells after saving specs in Excel format.  In general, process data and 
calculation values that SmartPlant Instrumentation stores in the database are of greater precision 
than the values that Excel displays in the cells of generated specs.  The default global Save as 
Excel precision is two decimal places.  Therefore, if you need to display in Excel a precise 
SmartPlant Instrumentation value, you need to increase the number of decimal digits for Save as 
Excel.  You can either set values display precision globally, or for individual fields.  For more 
information, see Set Value Display Precision (on page 300). 

Fix Display of Vertical Fields 
Use this procedure if vertical fields are not displayed correctly the Excel file. If a spec page upon 
which specifications are based contains vertical fields, it must fulfill one of the following two 
conditions for correct export to Excel: 
 The X values of the left-hand vertical grid line must be 0. 
 You create an invisible line for which the X values are 0. 

If aligning the page grid lines to X = 0 does not solve the problem, you need to trim and center 
vertical form fields in InfoMaker.  For more information, see Fix Display of Vertical Fields (on 
page 300). 
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Fix Display of Select Lists 
Use this procedure if select lists are not displayed correctly the Excel file.  For more information, 
see Fix Display of Select Lists (on page 301). 

Prepare Problematic Excel Files for Intergraph Support 
Use this procedure if you encounter problems that you are unable to solve, and then contact 
Intergraph Support.  For more information, see Prepare Problematic Excel Files for Intergraph 
Support (on page 301). 
 
 

Resolve Spec Accessing Problem in a Common Excel File 
Use the following procedure for Excel 2003. 
1. In Excel, on the menu bar, click Tools > Options. 
2. On the Security tab, click Macro Security. 
3. On the Security Level tab, click Medium. 
4. Click OK to close the Security dialog box. 
5. Click OK to close the Options dialog box. 
Use the following procedure for Excel 2007: 
1. In Excel, click the Office button. 
2. Click the Excel Options button. 
3. Click Trust Center > Trust Center Settings > Macro Settings. 
4. Select the Disable all macros with notification option. 
5. Click OK. 
 

Remove the Protection from a Spec Saved as Excel 
For Excel 2003: 
 With a spec open in Excel, on the menu bar, click Tools > Protection > Unprotect sheet. 

For Excel 2007: 
With a spec open in Excel, click Office Button > Excel Options > Microsoft Office Excel Trust 
Center > Trust Center Settings > Macro Settings > Enable all macros. 
 
 

Resolve a Data Saving Problem 
1. Save the spec page upon which the specification is based in .psr format and then open the 

.psr file in InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. Right-click the required text header, and then, on the shortcut menu click Properties. 
3. On the Position tab, under X, increase the previous value by 0.1 
4. Repeat this step for every header that is located precisely above its field. 
5. Import the page back into SmartPlant Instrumentation. 
6. Regenerate the spec page and specification, and save the specification again in Excel format. 
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Resolve Grid Line Overlap Problems 
1. Open the appropriate spec page in InfoMaker.  For details, see Open a Form Page in 

InfoMaker (on page 622). 
2. In InfoMaker, make sure that lines that intersect near problematic fields do not 

overshoot.  Overshooting occurs when grid lines meet imperfectly, and at least one of the 
lines extends beyond the meeting point.  If overshooting occurs, see Correct Undershooting 
and Overshooting of Grid Lines (on page 297). 

3. If there is no overshooting, make sure that you set constant Y1 and Y2 values for all of the 
objects between the lines.  The Y1 value should be several PBUs (PowerBuilder units) 
greater than the Y values of the line above, and the Y2 value should be several PBUs less 
than the Y values of the line below. 

4. Import the page back into SmartPlant Instrumentation. 
5. Regenerate the spec page and specification, and save the specification again in Excel format. 
 
 

Correct Undershooting and Overshooting of Grid Lines 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. To correct undershooting or overshooting on the left border, do the following: 

a. Right-click the top line or on the bottom line, and on the shortcut menu click Properties. 
b. On the Position tab, under X1, copy the value to the Clipboard, using a standard 

Microsoft shortcut (for example, Ctrl+C). 
c. Right-click the required horizontal line, and on the shortcut menu, click Properties. 
d. On the Position tab, under X1, paste the Clipboard value, using a standard Microsoft 

shortcut (for example, Ctrl+V). 
3. To correct undershooting or overshooting on the right border, do the following: 

a. Right-click the top line or the bottom line, and on the shortcut menu click Properties. 
b. On the Position tab, under X2, copy the value to the Clipboard, using a standard 

Microsoft shortcut. 
c. Right-click the required horizontal line, and on the shortcut menu, click Properties. 
d. On the Position tab, under X2, paste the Clipboard value, using a standard Microsoft 

shortcut. 
4. To correct undershooting or overshooting on the top border, do the following: 

a. Right-click the left-most line or the right-most line, and on the shortcut menu click 
Properties. 

b. On the Position tab, under Y1, copy the value to the Clipboard, using a standard 
Microsoft shortcut. 

c. Right-click the required vertical line, and on the shortcut menu, click Properties. 
d. On the Position tab, under Y1, paste the Clipboard value, using a standard Microsoft 

shortcut. 
5. To correct undershooting or overshooting on the bottom border, do the following: 

a. Right-click the left-most line or the right-most line, and on the shortcut menu click 
Properties. 

b. On the Position tab, under Y2, copy the value to the Clipboard, using a standard 
Microsoft shortcut. 
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c. Right-click the required vertical line, and on the shortcut menu, click Properties. 
d. On the Position tab, under Y2, paste the Clipboard value, using a standard Microsoft 

shortcut. 
6. On the menu bar, click File > Save. 
7. Import the page back into SmartPlant Instrumentation. 
8. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Prevent Truncation of Labels and Values 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. For accurate export to Excel, fine-tune problematic areas of the page in InfoMaker according 

to plumb line principles: 
 The X positions of vertical lines and X1 and X2 object positions should not be used 

randomly. 
 For considerations of graphic design and for compatibility with Excel, set close values 

equal. 
3. Save the file. 
4. Import the page back into SmartPlant Instrumentation. 
5. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Fix Displaced Labels 
1. Open the problematic spec in the Page Editor in SmartPlant Instrumentation. 
2. Save the spec page as a .psr file and then open the .psr file in InfoMaker.  For details, see 

Open a Form Page in InfoMaker (on page 622). 
3. To normalize label coordinates, do the following: 

a. Right-click the field to the right of the displaced label, and on the shortcut menu, click 
Properties. 

b. On the Position tab, under Y, copy the value to the Clipboard, using a standard shortcut 
(for example, Ctrl+C). 

c. Right-click the displaced label, and on the shortcut menu, click Properties. 
d. On the Position tab, under Y, paste the Clipboard value, using a standard shortcut (for 

example, Ctrl+V). 
 The value of the Height field on the Position tab can also influence the appearance of 

the text in Excel.  You must enter a height value that is in proportion to the font size that you 
set in the Font tab folder. 

4. On the File menu, click Save. 
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 You only need to perform the following steps if you want to fix displaced labels by 
extending an existing horizontal line above or below the displaced label.  These steps deal 
with extending a line that runs through the right-hand and the middle column into the left-hand 
(categories) column.  You can adapt this procedure for other configurations as well. 

5. To extend an existing horizontal line above or below the displaced label, do the following: 
a. Right-click the left-most line (vertical), and on the shortcut menu click Properties. 
b. On the Position tab, under X1, copy the value to the Clipboard, using a standard shortcut 

(for example, Ctrl+C). 
c. Right-click the horizontal line that you want to extend, and on the shortcut menu, click 

Properties. 
d. On the Position tab, under X1, paste the Clipboard value, using a standard shortcut (for 

example, Ctrl+V). 
6. Click in the main window to view your changes. 
7. On the File menu, click Save. 
8. Import the page back into SmartPlant Instrumentation. 
9. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
 

Fix Text Display in Excel Cells 
1. If you want to fix text display directly in Excel, do one of the following: 

 In Excel, drag the column borders to accommodate the text. 
 In Excel, on the Excel Format Cells dialog box, on the Alignment tab, select Wrap text. 

2. If you want to fix text display directly in InfoMaker, do the following: 
3. Open the problematic spec in the Page Editor in SmartPlant Instrumentation. 
4. Save the spec page as a .psr file and then open the .psr file in InfoMaker.  For details, see 

Open a Form Page in InfoMaker (on page 622). 
5. and increase the width of this column as necessary. 
6. On the File menu, click Save. 
7. Import the page back into SmartPlant Instrumentation. 
8. Regenerate the spec page and specification, and save the specification again in Excel format. 
 
 

Fix Function Conversion Problems 
1. Open the problematic Excel file. 
2. Copy the value of the unknown function from the original cell to a temporary cell. 
3. Copy the unknown function from the log file to the original cell. 

 
 In Excel 2003, the log files are located in <SmartPlant Instrumentation home 

folder>\SaveAsExcel\ResultFiles\. 
 In Excel 2007, the log files are located in C:\Documents and Settings\ [user name]\ 

SPI_SaveAsExcel 
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 The file names are created according to the convention LogFileFormXXX_#.txt, where 
XXX is the form number and # relates to the internal change made to the form. 

4. In the original cell, modify the exported function to convert it into an Excel function. 
5. Move the mouse pointer outside the cell to display the value of the function. 
6. Compare the value displayed in the Excel cell with the value in the source specification.  If the 

values are identical, this is an indication (but not a proof) that you have accurately converted 
the formula. 

7. If you succeed in converting the function, delete the contents of the temporary cell. 

 
 If you re-save the same specification in Excel format, to prevent the software from overwriting 

your new function, you must rename the corrected Excel file.  You can then copy the formula 
to future Excel versions of this specification. 

 If the converted formula does not work, restore the original cell contents from the temporary 
cell, and then contact Intergraph Support. 

 
 

Set Value Display Precision 
 To set value display precision globally, see Set Value Display Precision for Save as Excel 

Globally (on page 293). 
 To set value display precision for individual fields and override the global value precision 

settings, see Set Value Display Precision for Individual Fields (on page 293). 
 
 

Fix Display of Vertical Fields 
1. In SmartPlant Instrumentation, save the spec page as a .psr file and then open the .psr file in 

InfoMaker.  For details, see Open a Form Page in InfoMaker (on page 622). 
2. Right-click a vertical field, and then, on the shortcut menu, click Properties. 
3. To verify that a given field diverges from the horizontal, on the Font tab, click the icon to the 

right of the Escapement box  or .  On the dialog box that opens, in the Expression 
box, a value of 900, for example, indicates a vertical field. 

4. On the General tab of the Properties dialog box, under Alignment, select Center. 
5. If the field is wider than the text, do one of the following to trim the field: 

 On the Position tab, under Width, change the value to the minimum value needed to 
display the actual text. 

 In the Design view, use the mouse to change the field width. 
6. On the File menu, click Save. 
7. Import the page back into SmartPlant Instrumentation. 
8. Regenerate the spec page and specification, and save the specification again in Excel format. 

See Also 
Save a Page as an External File (on page 206) 
Open a Page from an External File (on page 204) 
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Fix Display of Select Lists 
 To fix the display of select lists in Excel, you need to create an invisible vertical zero line in the 

problematic spec page.  For details, see, Create an Invisible Vertical Zero Line (on page 291). 
 
 

Prepare Problematic Excel Files for Intergraph Support 
1. In SmartPlant Instrumentation, click File > Preferences > Specifications > Save as Excel. 
2. Select Delete temporary Excel files, and click OK. 
3. Save the problematic specifications in Excel format. 
4. For each problematic specification, send the following files to Intergraph Support: 

 From the <SmartPlant\Instrumentation home folder>\SaveAsExcel\ResultFiles folder 
send T_Form*.xls and LogFileForm*.txt (or the <tag number>.xls) 

 From the <SmartPlant\Instrumentation home folder>\SaveAsExcel\DataFiles folder, send 
Data*.xls and Form*.xls. 
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Specification Report List 
The following table shows a description of each Specifications module report that is available for 
displaying and printing. 

Report Description Note 

Specifications by 
Item Type 

Allows you to print all specs 
belonging to items of a particular 
item type, or print specs according 
to your item selection.. 

For loop spec or instrument spec 
report generation, you can select the 
current plant group or all plant groups 
available in your plant structure. 

Specifications by 
Form 

Allows you to print specs 
according to specific forms on 
which the specifications are 
based. 

For loop spec or instrument spec 
report generation, you can select the 
current plant group or all plant groups 
available in your plant structure. 

Specifications by 
Document Number 

Allows you to print specifications 
according to specified document 
numbers. 

This option allows you print all existing 
spec belonging to any item type. 

Form Data 
Templates 

Allows you to select form data 
templates and print a report 
showing the form data template 
content. 

None 

Spec Forms Allows you to print specific forms. You can set the software to generate 
the report with or without field 
names.  The software generates the 
report as the specprn.psr file and 
saves this file to the folder you 
specified in the Temporary folder 
path box, on the General page of the 
Preferences dialog box.  If you leave 
this box blank, the software saves the 
specprn.psr file to the SmartPlant 
Instrumentation home folder. 

Specifications by 
Date 

Allows you to print specs 
belonging to items of a particular 
item type according to specified 
date range. 

For loop spec or instrument spec 
report generation, you can select the 
current plant group or all plant groups 
available in your plant structure. 

Spec Form Field 
Report – Per Form 

Displays the field names and their 
respective headers for the forms. 

The field headers are displayed as 
they appear in the Spec Data 
Dictionary.  You can select a specific 
form or all available forms. 

Spec Form Field 
Report – Per Field 

Contains spec form names where 
a selected field appears. 

You can select a specific field name or 
all available field names. 
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Report Description Note 

Spec Form Select 
List 

Contains a list of fields that 
appear as select lists in the form, 
with all the possible values for 
each field. 

None 

Spec Form Lists by 
Process Function 

Contains a list of specification 
forms and instrument types 
associated with the specified 
process functions. 

You can select one or more process 
functions.  Forms belonging to a 
particular process function appear on 
a separate sheet. 

Spec Pages by 
Form 

Contains a list of pages 
associated with the forms that you 
select. 

This report only shows a list of pages 
in the form, not the fields that are used 
in the page.  Pages used in a 
particular form appear on a separate 
sheet. 

Print Specs into 
PDF Files 

Allows you to print the 
specifications that you select into 
a common .pdf file. 

None 

 
 

Printing Specifications and Reports Common Tasks 
The following tasks enable you to generate and print various spec-related reports. 

Print a Specification Report 
Use this procedure to print a report of specifications that are based on the same spec form.  In the 
procedure topic, the report for specifications according to selected forms is shown as an 
example.  You need to have access to the Specifications module to print spec reports.  The steps 
involved in printing most of the Specifications module reports are similar.  For more information, 
see Print a Specification Report (on page 305). 

Generate Reports by Date 
Use this procedure to set a date range and then generate a report of all spec forms that underwent 
changes within this date range.  For more information, see Generate Reports by Date (on 
page 306). 

Generate a Report for a Selected Field Name 
Use this procedure to generate a Spec Form Field Report for a certain data field that is in use in 
spec forms.  This report indicates the forms that use this data field, and also indicates the headers 
that you assigned to this field in the Spec Data Dictionary for the various forms.  For field 
headers that you did not edit in the Spec Data Dictionary, this report prints the headers that 
appear in the pages that the form contains.  For more information, see Generate a Report for a 
Selected Field Name (on page 306). 
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Assign User-Defined Headers for Spec Form Field Reports 
Use this procedure to edit form headers or to assign user- defined headers to the data fields in a 
selected form.  The header changes affect Spec Form Fields reports and Form Browser views 
that you create in the Browser module.  This procedure does not affect the display of 
specifications based on a form that you edit in the Spec Data Dictionary, nor does this procedure 
influence printed specifications.  For more information, see Assign User-Defined Headers for 
Spec Form Field Reports (on page 306). 

Print the Currently Open Specification 
Use this procedure to print out the currently open specification.  The Specifications module 
preferences that you set on the Preferences dialog box determine how the software prints 
specification notes.  For more information, see Print the Currently Open Specification (on 
page 307). 

Print Specs into PDF Files 
Use this procedure to print specifications into a single .pdf file, or to individual .pdf files.  For more 
information, see Print Specs into PDF Files (on page 307). 
 
 

Print a Specification Report 
1. Click File > Preferences > General, and make sure you set the SmartPlant Instrumentation 

temporary folder path correctly, for example,  
C:\Program Files\SmartPlant\Instrumentation\TEMP. 

2. On the Specifications Module window menu bar, click Reports > By Forms. 
3. Do one of the following: 

 Click Current Plant Group if you want to print reports for specs belonging to the current 
<unit> plant group only. 

 Click All Plant Groups to be able to print reports for specs that exist in all of the available 
plant groups in the current plant structure. 

4. Select one or more forms and click OK. 
5. If prompted, click Yes to preview the report, or click No to print the report without opening the 

print preview. 

 
 By default, the software prompts you to open a print preview.  You can also change this 

setting on the Preferences dialog box, on the General page. 
 By default, the software prints specification notes on a separate sheet.  You can change this 

setting on the Preferences dialog box, on the Specifications > General page. 
 The page size of specification and wiring reports is hard-coded to A4, therefore only this 

setting will apply when printing these reports. 
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Generate Reports by Date 
1. On the Specifications Module window menu bar, click Reports > By Date. 
2. Do one of the following: 

 Click Current Plant Group if you want to print reports for specs belonging to the current 
<unit> plant group only. 

 Click All Plant Groups to be able to print reports for specs that exist in all of the available 
plant groups in the current plant structure. 

3. Type or select the required date range in the From and To boxes. 
 Click Today to display the current date in the To box. 

4. Click OK to save the date range settings for current report generation. 
5. If prompted, click Yes to preview the report, or click No to print the report without opening the 

print preview. 

 
 By default, the software prompts you to open a print preview.  You can also change this 

setting on the Preferences dialog box, on the General page. 
 By default, the software prints specification notes on a separate sheet.  You can change this 

setting on the Preferences dialog box, on the Specifications > General page. 
 
 

Generate a Report for a Selected Field Name 
1. On the Specifications Module window menu bar, click Reports > Spec Form Field Report 

- Per Field > Selected Field Name. 
2. On the Select Field Name dialog box, select the required data field and click OK. 

  If the list of data fields is long, start typing a field name in the Find box and the software 
selects the field name automatically as you type. 

3. Click OK and then, if prompted to preview the report, click Yes to open the report print 
preview, or No to print the report without opening the print preview. 

 
 

Assign User-Defined Headers for Spec Form Field Reports 
1. On the Specifications Module window menu bar, click Edit > Spec Data Dictionary. 
2. On the Select Specification Form dialog box, select a form and click OK. 

3. On the toolbar, click . 
4. To edit the field headers for Spec Form Field reports, do one of the following: 

 On the Field Properties tab, change individual headers by typing a text string instead of 
the displayed header. 

 Change headers in batch mode using another form as a source.  To do so, click Copy 
From, and then, select a source form. 

5. To apply existing headers of the current form, do the following: 
6. In the form, or on the Field Properties tab, under Header, move the cursor to the header, and 

after the cursor changes its shape to , click the header. 
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7. In the form, double-click the header to display it on the Field Properties tab. 

 
 If you apply existing headers of the current form, in the form display, the form fields are marked 

with a background the cyan background color.  The background color of the currently selected 
field, for which you are editing the header, changes to magenta. 

 The  icon in the Field Properties tab points to the corresponding header, which is now 
available for editing. 

 
 

Print the Currently Open Specification 
1. On the Specifications > General page of the Preferences dialog box, do one of the 

following: 
 Select Show notes to include spec notes on the first page of the spec. 
 Clear Show notes to omit spec notes from the first page of the spec. 

2. On the Specifications > General page of the Preferences dialog box, do one of the 
following: 
 Select Print notes on a separate sheet to print the spec notes section on a separate 

print sheet. 
 Clear Print notes on a separate sheet to print the spec notes section as displayed on 

the spec. 
3. Open a spec and, do one of the following: 

 Click Actions > Print. 

 On the toolbar, click . 
 
 

Print Specs into PDF Files 
The driver used for printing the PDF files, SmartPlant PDF Converter 401, is included in the 

SmartPlant  installation. 
1. On the Specifications Module window menu bar, click Reports > Print Specs into PDF 

Files. 
2. On the Print Specs into PDF Files dialog box, do one of the following: 

 Click Print all into one file and then specify the target file name and path.  This allows 
you to create one .pdf file shared for all specifications. 

 Click Print into individual files and then specify the target folder for the software to 
create an individual .pdf file for each specification. 
 When creating individual .pdf file names for item specifications, the software uses the 

names of the items as a source.  If the item name includes characters other than 
alphanumeric characters (that is, /(#) and so forth), the software converts them to 
underscores.  The software retains hyphens and spaces.  For example, if the item name is 
101-FT-100\B, the created .pdf file name is 101- FT-100_B.pdf.  If the item name is 12P#20 
TYPE E I/OAS (CUSTOM), the created .pdf file name is 12P_20 TYPE E I_OAS 
_CUSTOM_.pdf. 

3. Browse to define PDF file name and folder. 
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 If you selected Print all into one file, and the file name you define already exists in the 
target folder, you will be asked whether or not to overwrite the file. If you click No, the Select 
Folder dialog box will reopen, and a number suffix will be added to the file name. You can edit 
the new file name and click Save to proceed. If you click Yes, the original file is deleted. 

4. Click Find. 
5. On the Find Items dialog box, find items for which you want to print to specifications to a .pdf 

file. 
 On the Find Items dialog box, the software only displays items for which specifications 

already exist. 
6. Under Search results, select items whose specifications you want to print into one or several 

.pdf files, and then click OK. 
7. On the Print Specs into PDF Files dialog box, click OK. 
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Pipe Specs 
Pipe spec is a specification that defines pipe properties for various process conditions.  In 
SmartPlant Instrumentation, the term pipe spec denotes a set of requirements for materials and 
construction of the pipelines and their components.  You can include this information in a 
specification that defines various process conditions for a specific pipe.  In SmartPlant 
Instrumentation, pipe specs are used for references and as a guideline for design in the areas 
affected by direct contact with process.  These references include pipeline information in the 
Process Data module and installation item details you can display in hook- up drawings. 
In a hook-up drawing, you can display all instrument you associate with a particular pipe 
spec.  You make pipe spec definitions using the Pipe Specs supporting table, available either 
from the Instrument Index or Process Data module.  After making your pipe spec definitions, you 
can assign a pipe spec to one or more lines in the Process Data or Instrument Index 
module.  Also, you can assign a pipe spec to one or more instruments in the Browser or 
Instrument Index module.  You do not use the Specifications module options to generate or 
manage pipe specs. 
You then assign pipe specs to user-defined hook-up item sub-libraries and affect instrument - 
hook-up assignment.  After assigning a pipe spec to a user-defined sub-library, when making 
instrument - hook-up associations, you can only use instruments that have the source pipe spec 
data.  You cannot use the default sub-sub-library for pipe spec assignment. 
 
 

Pipe Specs Common Tasks 
The following tasks deal with pipe spec management.  Pipe spec is a specification that defines 
various process conditions for a specific pipe. 

Define or Modify Pipe Specs 
Use this procedure to define pipe specs in the Pipe Specs supporting table.  You can perform this 
procedure either in Instrument Index or process data module.  For more information, see Define 
or Modify Pipe Specs (on page 310). 

Assign Pipe Specs to Instruments 
You can assign pipe specs to instrument tag numbers in the Browser module or in the default view 
of the Instrument Index Standard Browser accessed from the Instrument Index module.  You 
have to assign pipe specs to tag numbers if you want to use pipe-spec sub-libraries in the 
Hook-Ups module and assign the tag numbers to hook-ups. Prior to assigning pipe specs to 
instrument tag numbers, you make pipe spec definitions in the Pipe Specs supporting table, which 
you can access either from the Instrument Index or from the Process Data module.  In these 
modules, you can also assign pipe specs to line numbers.   For more information, see Assign 
Pipe Specs to Instruments (on page 311). 

Assign Pipe Specs to Lines 
Use this procedure to can assign pipe specs to lines.  You can then display the pipe spec 
definition in the line process data sheet.  For more information, see Assign Pipe Specs to Lines 
(on page 311). 
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Associate Pipe Specs with Sub-Libraries 
Use this procedure to associate one or more pipe specs with user-defined sub-libraries.  After the 
association, when assigning instruments to hook-ups, you can only use instruments that have the 
source pipe spec data.  You cannot use the default sub-library for pipe spec assignment.  For 
more information, see Associate Pipe Specs with Sub- Libraries (see "Associate Pipe Specs with 
Sub-Libraries" on page 312). 

Display Pipe Specs Assigned to a Hook- Up Item Sub-Library 
Use this procedure to displays pipe specs associated with a specific user-defined hook-up item 
sub-library.  For more information, see Display Pipe Specs Assigned to a Hook-Up Item 
Sub-Library (on page 312). 

Dissociate a Pipe Spec from Lines 
Use this procedure to dissociate a pipe spec from a line.  You must perform this procedure if you 
need to delete this pipe spec from the Pipe Specs supporting table.  For more information, see 
Dissociate a Pipe Spec from Lines (on page 313). 

Delete Pipe Specs 
Use this procedure to delete a pipe spec from the Pipe Specs supporting table.  You can perform 
this procedure either in the Instrument Index or Process Data module.  For more information, see 
Delete Pipe Specs (on page 313). 
 
 

Define or Modify Pipe Specs 
1. Do one of the following: 

 On the Instrument Index Module window menu bar, click Tables > Lines. 

 On the Process Data Module window toolbar, click  to open the Select Line dialog 
box.. 

2. From the Line type list, select a line type. 
3. Click New to open the Line Properties dialog box. 

4. Beside the Pipe spec list, click  to open the Pipe Specs dialog box. 
5. Do one of the following: 

 To create a new pipe spec, click New and type the pipe spec name and description. 
 To edit an existing pipe spec, click a field in a selected row and modify the existing pipe 

spec name and description as needed. 
 
 



 Specifications 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 311 
 

Assign Pipe Specs to Instruments 
1. Open the Browser Manager, and then, for the Instrument Index Standard Browser, define a 

view that includes the Tag Number and Pipe Spec fields. 
2. In the Pipe Spec column, from the select list, select a pipe spec for association with the 

instrument whose tag number is displayed in the same row, in the Tag Number column. 

 
 You can assign the same pipe spec to more than one instrument but only one pipe spec per 

instrument. 
 To dissociate a pipe spec from an instrument, from the select list in Pipe Spec column, select 

a blank field. 
 After you assign tags to hook-ups in the Hook-Ups module, you can open a view for the 

Hook-Up Tag List browser.  This browser displays only those tags that are associated with 
hook-ups.  In this browser view, you can also change the pipe spec associations as you 
require. 

 
 

Assign Pipe Specs to Lines 
1. Do one of the following: 

 On the Instrument Index Module window menu bar, click Tables > Lines. 

 On the Process Data Module window toolbar, click  to open the Select Line dialog 
box.. 

2. From the Line type list, select a line type. 
3. Select a line and click Properties. 

4. On the Line Properties dialog box, beside the Pipe spec list, click  to open the Pipe 
Specs dialog box. 

5. Select a pipe spec and click OK to assign it to the line. 

 
 You can now open a process data sheet for this line to display the assigned pipe spec.  If you 

defined more than one pipe spec in the Pipe Specs supporting table, you can assign a 
different pipe spec to the line from the process data sheet. 

 The pipe spec becomes a property of the process data sheet.  This means that you can 
assign this pipe spec to other lines by copying line data to other lines.  Note, however, that 
when you copy line data to instruments, the software does not copy line pipe spec definition to 
the instruments. 
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Associate Pipe Specs with Sub-Libraries 
1. In the Hook-Up Item Libraries folder of the Reference Explorer, do one of the following: 

 In the tree view pane, expand the hierarchy of an item library and right-click a 
user-defined sub-library. 

 In the tree view pane, select an item library and then, in the Items pane, select one or 
more user-defined sub-libraries. 

2. On the shortcut menu, click Actions > Associate Pipe Specs with Sub- Libraries. 

 
 On the dialog box that opens, the software displays all the pipe specs defined in the Pipe 

Specs supporting table. 
 In the dialog box panes, you can double-click the Pipe Specs column header in the to sort 

the items in ascending order.  Double- click the header again to sort the items in 
descending order. 

3. Under Available pipe specs, select one or more pipe specs and do one of the following: 
 Click Associate. 
 Drag the selected items to the Associated pipe specs pane. 

4. If you selected more than one user-defined sub-library in the Reference Explorer, click Next 
to display another sub-library and associate pipe specs as you require. 
 You can associate the same pipe specs with more than one user-defined sub-library. 

 
 

Display Pipe Specs Assigned to a Hook-Up Item Sub-Library 
1. Press F7 to open the Domain Explorer, and expand the hierarchy to the hook-up type level in 

the Hook-Ups folder. 
2. Do one of the following: 

 In the tree view pane, select a specific hook-up. 
 In the tree view pane, select a hook-up type, and then, in the Items pane, select and 

right-click one or more hook-ups. 
3. On the shortcut menu, click Properties. 
4. On the Hook-Up Properties dialog box, from the Hook-up sub-library list, select a 

user-defined hook-up item sub-library. 
5. Click Pipe Specs to display pipe specs associated with the user-defined sub-library that you 

selected. 
 The Pipe Specs button is only available when the sub-library that you selected is 

user-defined. 
 
 



 Specifications 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 313 
 

Dissociate a Pipe Spec from Lines 
1. Do one of the following: 

 On the Instrument Index Module window menu bar, click Tables > Lines. 

 On the Process Data Module window toolbar, click  to open the Select Line dialog 
box.. 

2. From the Line type list, select a line type. 
3. Select a line and click Properties. 
4. On the Line Properties dialog box, in the Pipe Spec column of the data window, click the 

pipe spec definition and press the Delete key. 
5. Click OK to return to the Select Line dialog box. 

 
 This procedure only allows you do dissociate a pipe spec from one line at a time.  If you want 

dissociate this pipe spec from all lines, you can open the process data sheet for a specific line, 
make sure that the Pipe spec box is empty, and then copy line data to other lines. 

 You do not delete the pipe spec itself, only dissociate it from the line.  The dissociated pipe 
spec remains in the Pie Specs supporting table.  If you want to delete a pipe spec 
permanently, you must delete it from the supporting table. 

 Dissociating a pipe spec from a line does not dissociate this pipe spec from instruments. 
 
 

Delete Pipe Specs 
1. Do one of the following: 

 On the Instrument Index Module window menu bar, click Tables > Lines. 

 On the Process Data Module window toolbar, click  to open the Select Line dialog 
box. 

2. From the Line type list, select a line type. 
3. Click New to open the Line Properties dialog box. 

4. Beside the Pipe spec list, click  to open the Pipe Specs dialog box. 
5. Select the pipe spec that you want to delete, and click Delete. 
6. Repeat the previous step for each pipe spec that you want to delete. 

 You cannot delete a pipe spec that is currently assigned to lines.  First, dissociate the pipe 
spec from the lines. 
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 For the KKS naming convention to function the Rule Manager option must be 
selected in the Domain Definitions. You then, in Rule Manager using the KKS Cable Name rule, 
set the number of segments to be used in the calculation of the unique suffix number in the KKS 
name. 
SmartPlant Instrumentation supports KKS naming conventions for process-related identification 
of the following item types: 
 Instruments (including functional requirement tags and virtual tags) 
 Loops 
 Lines 
 Process equipment 
 Control system tags 
 Panels (plant panels only, belonging to panel categories available in the Convention list in the 

Naming Conventions dialog box) 
 Cables (plant cables only) 

For each of these item types, the following KKS segment properties are available: 

KKS Level Name Property Description 

Total Plant Total Plant Single character (numeric or alphabetic). 

System Code System Code Prefix 
(optional) 

Single digit. 

System Classification Three-character alphabetic key, selected 
from a standard list, that represents the type 
of system in use the plant. 

System Numbering Two-digit number with leading zeros. 

Equipment Unit Code Equipment Unit 
Classification 

Two-character alphabetic key, selected from 
a standard list, that represents the type of 
equipment within the system used for 
measuring or monitoring the system, or the 
type of measurement circuit (level, flow, and 
so forth). 

Equipment Unit 
Numbering 

Three-digit number with leading zeros. 

Equipment Unit 
Additional Code 

Optional character (alphabetic). 

Component Code Component 
Classification 

Two-character alphabetic key, selected from 
a standard list, that represents the type of 
component. 

Using KKS Naming Conventions in 
SmartPlant Instrumentation 
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KKS Level Name Property Description 

Component Numbering Two-digit number with leading zeros. 

Numbering Element (for 
cables only) 

Application Area Single digit (0-9) representing the application 
area of a cable (voltage levels). 

Cable Number (digits 2 
and 3) 

Two-digit number. 

Cable Suffix The fourth position of the cable number, a 
numeric character, mostly used for grouping 
purposes. 

 
 SmartPlant Instrumentation does not auto-increment the numbering of the various segments 

in the process identification. 
 The software does not automatically add leading zeros to imported items whose names 

include spaces. You must manually add the leading zeros to the source before importing KKS 
data. 

Process Identification Prefix and Notation Characters 
Process Identification usually uses the equal (=) character as a prefix.  Identification may include 
space (" ") or pipe (|) characters. 

Examples 
For a medium voltage panel (excluding device panels), only the System Code segments are 
required in most cases.  Thus a suitable KKS name would be 1 0BBA01, where the values are 
designated as follows: 

Property Value Description 

Total Plant 1  

System Code Prefix 0  

System Classification BBA MV distribution board 

System Numbering 01  

Equipment Unit Classification (Not used)  

Equipment Unit Numbering (Not used)  
For a flow transmitter, the KKS identification 1 0PAE01 CF013 –B01 could be used, where the 
values are designated as follows: 

Property Value Description 

Total Plant 1  

System Code Prefix 0  

System Classification PAE Circulating (main cooling) water pump system 

System Numbering 01  

Equipment Unit Classification CF Open flow loops 
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Property Value Description 

Equipment Unit Numbering 001  

Component Classification -B Transducer 

Component Numbering 01  

 
 When creating a new instrument, the associated loop inherits the relevant segments of the 

instrument names and vice versa.  Also, KKS naming is propagated to cables when you 
connect them to panels that already have KKS naming.  Cables inherit the KKS naming of the 
panel whose system code is first in alphabetic order. 

 Not all items use all the described segments.  For example, DCS and PLC panels do not use 
equipment unit code and component code segments.  Marshaling racks, junction boxes, 
process equipment, and lines do not use component code segments. 

 When editing a name using the KKS naming conventions, do not remove any segments from 
the name. Removing segments from the KKS name causes problems when creating new 
instruments. You can though add more segments to the KKS name created in SmartPlant 
Instrumentation. 

 You can change the terminology of a key on a project-specific basis provided that the contents 
remain unchanged.  Make sure that you do not select a code that is designated as Blocked. 
Blocked coding letters are reserved for future technologies and new systems engineering 
configurations.  They may only be allocated and released by the VGB Technical Committee 
on Technical Classification Systems. 

 

Requirements for Importing Line Data in KKS Mode 
When importing line data to the Instrument Index module or Process Data module, you need to 
perform the following procedure to enable the use of KKS segments in the import link. 
1. In the Import Utility, select the desired import link and open the Link Properties dialog box. 
2. Click the Style tab. 
3. Select the Display all fields check box. 
 
 

Propagation of KKS Names in SmartPlant 
Instrumentation 

When an item, such as a loop, has KKS naming, and you perform tag number association, the 
software automatically propagates the loop naming to the associated tags.  The software also 
propagates panel naming when you connect a cable to a panel. 

Target Item 
Type 

Inherited 
Components of 
Target Item Name 

Possible 
Source Item 
Type 

Example of 
Source Item 
Name 

Instrument All populated 
segments of the 
loop number 

Loop =1 LBA01 CF001
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Target Item 
Type 

Inherited 
Components of 
Target Item Name 

Possible 
Source Item 
Type 

Example of 
Source Item 
Name 

Cable All common and 
used process 
identification 
segments of the 
panel (the first 
system 
classification which 
comes in alphabetic 
order) 

Panel =1 LBA01 CF001 
4120 (4120 is the 
cable numbering, 
which is entered 
manually) 

For a specific example of loop naming propagation, see Example of KKS Naming Propagation (on 
page 318). 

 
 The software performs propagation according to hard-coded rules.  Name segments that are 

not included in a propagation rule remain blank. 
 On connecting a cable to a panel, the KKS naming is propagated to the cable.  On 

disconnection, the cable retains the name received by propagation until you reconnect it. 
 When editing a name using the KKS naming conventions, do not remove any segments from 

the name. Removing segments from the KKS name causes problems when creating new 
instruments. You can though add more segments to the KKS name created in SmartPlant 
Instrumentation. 

 
 

Example of KKS Naming Propagation 
This scenario shows how SmartPlant Instrumentation propagates loop naming to its tag when you 
create a loop in the Domain Explorer and associate a tag with this loop. 
1. In the Domain Explorer, create a new loop using the following KKS settings: 

 
2. Click OK to open the Instrument Number dialog box, where you can create a new instrument 

tag number.  At this stage, the software has already propagated all the loop naming settings. 
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3. Accept the propagated settings, and then define the component classification as shown (-B 
01): 

 
4. Click OK to display the Select Instrument Type dialog box, where the software displays the 

instrument type that matches the component classification key value in the instrument tag 
name: 

 
 To display the matching instrument types, you must first populate the Instrument Type 

supporting table with applicable KKS entries. 
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5. Select the instrument type and click OK to display the loop and its tag in the Domain 
Explorer: 

 
 When editing a name using the KKS naming conventions, do not remove any 

segments from the name. Removing segments from the KKS name causes problems when 
creating new instruments. You can though add more segments to the KKS name created in 
SmartPlant Instrumentation. 
 

Rename an Item in KKS Mode 
1. In the Domain Explorer, select an item such as an instrument and do one of the following: 

 On the item's Properties dialog box, beside Number (for an instrument), click the ellipsis 

button . 
 Right-click the item, and on the shortcut menu, click Rename. 

 The name of the field representing the item name varies according to the item type. 
2. Type appropriate values in each segment of the item tag. 

 When editing a name using the KKS naming conventions, do not remove any 
segments from the name. Removing segments from the KKS name causes problems when 
creating new instruments. You can though add more segments to the KKS name created in 
SmartPlant Instrumentation. 

 
 Press the Tab key to move from one segment box to another. 
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 Move the mouse pointer over a segment to display a Tool Tip indicating the name of the 
segment. 

 

 Click the ellipsis button  beside a Classification segment to display the appropriate 
Classification dialog box, from which you can select suitable values.  If you have already 
typed part of the key prior to clicking the ellipsis button, the Classification dialog box opens at 
the appropriate place in the list. 

 When a numeric segment accepts more than one digit, if you enter fewer digits than the 
maximum, the software automatically adds leading zeros to the value you typed.  You cannot 
remove the leading zeros from the segment. 

 
 

Scope of KKS Issues for the Current SmartPlant 
Instrumentation Version 

The current version of SmartPlant Instrumentation supports KKS naming conventions for 
process-related identification of most instrumentation items. 

Out of Scope Issues 
The following issues are not supported in the current development: 
 Configuration rules for KKS establishments 
 Grouping of items hierarchically by a common physical system classification or equipment unit 
 Point of installation and location identification 
 Signal identification (signal area, signal applications, and gated signals) 
 Typical loop management 
 Loop naming propagation to instruments when renaming the loop 
 Searching for items using KKS segments as search parameters.  You can, however, search 

for items using wild cards in the Find Items dialog box, in the box where you can enter the full 
item tag name. 

 Telecom options (partially supported, can create telecom tags). 
 Macro expansion when importing from SmartPlant P&ID 
 Management of KKS classification keys 

 
 The software does not automatically increment numbering properties of KKS segments. 
 The software does not automatically add leading zeros to imported items whose names 

include spaces. You must manually add the leading zeros to the source before importing KKS 
data. 
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 When creating multiple items, the names of all the items, other than the first one, appear in the 
interface as zeros, for example: '00000', even though KKS naming is actually applied to 
them.  In such cases, the user needs to rename the individual items by changing the 
appropriate numbering segment, after which the software displays the item names correctly. 

 The software does not reset cable names when you disconnect one of the cable sides from a 
panel that originally propagated its naming to the cable. 

 When renaming a panel, the software does not update the cable naming according to KKS 
rules. 

 If you change the naming convention, it only affects new items.  Existing items retain their 
names according to the previous naming convention. 

 The software does not make any validations between the item type and the KKS code. 
 The software does not validate imported data.  For this reason, you need to check the source 

data before importing it.  It is recommended to use the comparison list before importing line, 
equipment, or wiring data.  For instrument tags and loops, you can map the appropriate 
segments of the source data to the KKS data segments in SmartPlant Instrumentation. 

 Moving a loop to another plant group or associating an instrument or a loop with another loop 
does not affect the tag naming. 

 The software correlates instrument types by name using the KKS component 
classification.  The KKS seed database includes a representative list of instrument types, 
which you should review and update as needed prior to project execution. 

 
 

In SmartPlant Instrumentation you use the Document Binder module to gather specifications and 
other related documents that need to be maintained together.  Each collection of documents is 
known as a binder package.  You can specify two types of binder package: Specification Binder 
packages and General Document Binder packages.  For Specification Binder packages, you can 
perform a collective update for all the documents in a single binder package and assign them the 
same revision number. 

 The software does not allow you to perform revisions for Specification Binder 
packages when working in an integrated environment. 
You can group documents according to any criteria you require. However, for instrument 
specification sheets, a given instrument specification may only be assigned to one Specification 
Binder package or to any number of General Document Binder packages, but not to both types of 
binder packages. 
 
 

Specification Binder Packages 
You use Specification Binder packages to create groups of instrument specifications for whatever 
purpose you require; for example, when requesting a price quotation from a vendor for several 
instruments, you can group the instruments together in a Specification Binder package and 
include other relevant documents. 
The following folders are available: 
 Specification List — This is a cover sheet with instrument tag data for all the specifications 

included in the Specification Binder package.  
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 Form Notes — This contains user notes that apply to specific form numbers.  There must be 
at least one specification associated with a particular form number in the Specification Binder 
package in order for you to be able to add form notes. 

 General Notes — General notes provide a means of adding user comments that are 
associated with the Specification Binder package as a whole. 

 Specification Sheets — This category shows the specifications included in the Specification 
Binder package, and provides you with the options to access and edit individual sheets, to 
totally or partially revise the sheets in the list, and to print all or some of the sheets. 

 Change Summary Report — This shows details of the changes that were made to the 
specifications since the last revision. 

When the documents are created, each document type is numbered sequentially using the 
following method: 
 Specification Sheets: S-1, S- 2, S-3, and so forth.  The pages of a multi-tag specification are 

identified by a number with a different suffix for each page, for example, S-2.1, S-2.2, S-3.1, 
S-3.2, and so forth. 

 Form Notes — G-1, G-2, G-3, and so forth. 
 Change Summary Report — C-1, C-2, C-3, and so forth. 
 General Notes — N-1, N-2, N- 3, and so forth. 

Page numbers are calculated from the relative position of the document in the Specification Binder 
package.  To recalculate the page numbers after modifying specifications, click Actions > 
Repaginate. 
 
 

General Document Binder Packages 
You use General Document Binder packages to create groups of documents for whatever 
purpose you require; for example, when requesting a price quotation from a vendor for several 
items, you can group the items together in a General Document Binder package and include other 
relevant documents. 
The following folders are available: 
 Document List — This is a cover sheet with data for all the documents included in the 

General Document Binder package. 
 Document Notes — This contains user notes that apply to specific document 

numbers.  There must be at least one document associated with a particular document 
number in the General Document Binder package in order for you to be able to add document 
notes. 

 General Notes — General notes provide a means of adding user comments that are 
associated with the General Document Binder package as a whole. 

 Documents — This category shows the documents included in the General Document Binder 
package, and provides you with the options to access and edit individual documents, to totally 
or partially revise the documents in the list, and to print all or some of the documents. 

 
 

Document Management Common Tasks 
The following tasks are used when you work with a document binder package to gather 
specifications and other related SmartPlant Instrumentation documents that need to be 
maintained together.  
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Start the Document Binder Module 
This procedure shows how you open the Document Binder module where you work with 
document binder packages. 
For more information, see Start the Document Binder Module (on page 325). 

Create a New Binder Package 
This procedure shows you how to create a new binder package.  A binder package is a group of 
documents or instrument specifications, and may include additional general notes and form 
notes.  On creation of a new binder package, the software creates a complete set of folders.  The 
software updates these folders as you assign documents to the binder package. 
For more information, see Create a New Binder Package (on page 325). 

Assign an Instrument Specification to a Specification Binder Package 
This procedure shows you how after creating a Specification Binder package, you can assign 
instrument specifications to it.  On assigning a specification, the software automatically updates 
the Instrument Specification List.  Furthermore, in the browser view, the software sets the 
value in the Item Status column to Added for the instrument tags associated with the newly 
assigned specification. 
For more information, see Assign an Instrument Specification to a Specification Binder Package 
(on page 326). 

Edit Binder Package Properties 
This procedure shows how you can edit the properties of a binder package.  You can rename a 
binder package and edit its description until the first time you add a revision to it.  After that you 
can only edit the purchase order number and requisition number. 
For more information, see Edit Binder Package Properties (on page 326). 

Number Pages in a General Document Binder Package 
This procedure shows you how to add consecutive numbering to the documents in a General 
Binder package. 
For more information, see Number Pages in a General Document Binder Package (on page 326). 

Remove Selected Instrument Specifications From a Specification Binder Package 
This procedure show how to remove selected instrument specifications from a Specification 
Binder package when those specifications are no longer required. 
For more information, see Remove Selected Instrument Specifications From a Specification 
Binder Package (on page 327). 

Remove a Single Instrument Specification From a Specification Binder Package 
This option shows how you can remove a single instrument specification from a Specification 
Binder package when the specification is no longer required. 
For more information, see Remove a Single Instrument Specification From a Specification Binder 
Package (on page 328). 
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Remove All Instrument Specifications From a Specification Binder Package 
This option shows how you can remove all the instrument specifications from a Specification 
Binder package when the specifications are no longer required. 
For more information, see Remove All Instrument Specifications From a Specification Binder 
Package (on page 328). 

Delete a Binder Package 
This procedure shows you how to delete a binder package.  You can only delete a binder 
package if it has not yet been saved as a revision.  In this case, if the binder package includes 
specifications, these must be removed first. 
For more information, see Delete a Binder Package (on page 328). 

Associate External Files with a Binder Package 
These procedures show you how to manage external files that you associate with a binder 
package.  You can associate a new file with the binder package, dissociate a file, or open an 
associated file.  Associated files can be .doc, .txt, .bmp, .wav, .psr files, or any file formats that are 
supported by your Windows system. 
For more information, see Associate External Files with a Binder Package (see "Manage 
Association of External Files with a Binder Package" on page 330). 
 

Start the Document Binder Module 
 Before starting this module, confirm with the Domain Administrator that you have been 

granted appropriate access rights for the tasks you will carry out. 
To open the main Document Binder window, do one of the following: 

1. On the main toolbar, click . 
2. Click Modules > Document Binder. 
 
 

Create a New Binder Package 
1. Open the Document Binder module.  For details, see Start the Document Binder Module (on 

page 325). 

2. In the Document Binder window, at the top of the left frame, select Binder Packages. 
3. Click Actions > New Binder Package. 
4. On the New Binder Package dialog box, enter the following data: 

 The binder package type (required) 
 The binder package name (required) 
 Description (optional) 
 Purchase order number (optional) 
 Requisition number (optional) 

 For Specification Binder packages only, if you select Apply purchase order and 
requisition number to all tags, the software adds this data to all tags currently associated 
with the Specification Binder package.  As long as this checkbox is selected, the software 
adds this data to every tag that you associate with the Specification Binder package. 

5. Click OK. 
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Assign an Instrument Specification to a Specification Binder 
Package 

1. In a Specification Binder package, select the  Specification Sheets folder. 
2. Click Actions > Assign Specification.  The Find Items dialog box opens, from which you 

can retrieve tags. To filter the retrieved tags, enter values in the selection fields. 
3. Click Find to retrieve the list of tags. 
4. From the list, select tags to be included in the Specification Binder package and click 

OK.  The list of tags appears under the Specification Sheets folder for the Specification 
Binder package. 

5. To open a specification for viewing or editing, select a sheet from the list and do one of the 
following: 
 Click Actions > Open. 
 Double-click the sheet. 
 To view information in the right area of the window in greater detail, in the tree of the 

Preferences dialog box, expand the hierarchy Document Binder > Specification Binder and 
under Select instrument specification list display, select User-defined columns from 
Browser module.  When you display detailed data in the right area of the screen, the software 
determines the layout according to the default view in the Spec Binder Package Browser (under 
the Document Binder group).  You can customize this view in the Browser module. 
 
 

Edit Binder Package Properties 
1. In the Document Binder window, in the left frame, right-click the binder package that you 

want to edit. 
2. Right-click and from the shortcut menu select Properties. 
3. On the General tab, edit the following data as needed: 

 Binder package name — after you save at least one revision, this field is not available. 
 Description — after you save at least one revision, this field is not available. 
 Purchase order number. 
 Requisition number. 

 If you select Apply purchase order and requisition number to all tags, the software 
updates all tags currently associated with the binder package.  As long as this checkbox is 
selected, the software adds this data to every tag that you associate with the binder package. 

4. Click OK. 
 
 

Number Pages in a General Document Binder Package 
1. Select the General Document Binder package. 
2. Do one of the following: 

 Click Actions > General Document Binder Page Numbering. 
 Right-click and from the shortcut menu, select General Document Binder Page 

Numbering. 
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3. On the General Document Binder Page Numbering dialog box, select one of the following: 
 Original page numbering method — retains the page numbering of each document. 
 Consecutive page numbering for all documents — starting with page one, the 

documents are numbered consecutively. 
 Consecutive page numbering per document type — starting with page one, each 

document type is numbered consecutively but separately from other document types in 
the binder package. 

 The Definitions button is only enabled when either of the consecutive 
numbering options is chosen. 

4. Click Definitions, the Define Prefix and Suffix dialog box or the Define Prefix and Suffix 
per Document Type dialog box opens. 

5. On the Define Prefix and Suffix dialog box, type the prefix and suffix you want to apply to the 
pages of all the documents in the binder. 

6. On the Define Prefix and Suffix per Document Type dialog box, do the following: 
7. From the Document Type list, select the document type you want to apply a prefix and suffix 

to. 
8. In the Prefix column, next to the selected document type, type the prefix you want to apply. 
9. In the Suffix column, next to the selected document type, type the suffix you want to apply. 
10. Click Apply, to add another prefix and suffix to a different document type. 
11. Click OK to close the dialog box. 
 

Remove Selected Instrument Specifications From a 
Specification Binder Package 

1. In the Document Binder window, in the Binder Packages tree, do the following: 
2. Expand the Specification Binder package from which you want to remove a specification. 
3. Select Specification Sheets. 
4. Right-click the desired specification sheets, and from the shortcut menu select Remove 

Selected Items. 
5. On the Remove Selected Items dialog box, under Select, select the check box beside each 

specification that you want to remove. 
 You can select the Select all check box if you want to remove all the specifications. 

 
 You can choose whether SmartPlant Instrumentation keeps or deletes revisions that you 

saved while the specification was part of the Specification Binder package.  For details, see 
Document Binder > General (Preferences). 

 On removing a specification, the way in which the specification list is updated depends on the 
following: 

 If the specification was originally assigned prior to saving the last revision of the 
Specification Binder package, the instrument tag still appears in the specification list 
browser view, with the Tag Number column set to Deleted. 

 If the specification was originally assigned after saving the last revision of the 
Specification Binder package, its tag does not appear in the specification list. 
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Remove a Single Instrument Specification From a 
Specification Binder Package 

1. In the Document Binder window, in the Binder Packages tree, do the following: 
2. Expand the Specification Binder package from which you want to remove an instrument 

specification. 
3. Select Specification Sheets. 
4. In the right pane, select the specification that you want to remove. 
5. Click Actions > Remove. 

 
 You can choose whether SmartPlant Instrumentation keeps or deletes revisions that you 

saved while the specification was part of the Specification Binder package.  For details, see 
Document Binder > General (Preferences). 

 On removing a specification, the way in which the specification list is updated depends on the 
following: 

 If the specification was originally assigned prior to saving the last revision of the Specification 
Binder package, the instrument tag still appears in the specification list browser view, with the 
Tag Number column set to Deleted. 

 If the specification was originally assigned after saving the last revision of the Specification 
Binder package, its tag does not appear in the specification list. 

 
 

Remove All Instrument Specifications From a Specification 
Binder Package 

1. In the Document Binder window, in the Binder Packages tree, do the following: 
2. Expand the Specification Binder package from which you want to remove a specification. 
3. Select Specification Sheets. 
4. Click Actions > Remove All. 

 
 You can choose whether SmartPlant Instrumentation keeps or deletes revisions that you 

saved while the specification was part of the Specification Binder package.  For details, see 
Document Binder > General (Preferences). 

 On removing a specification, the way in which the specification list is updated depends on the 
following: 

 If the specification was originally assigned prior to saving the last revision of the Specification 
Binder package, the instrument tag still appears in the specification list browser view, with the 
Tag Number column set to Deleted. 

 If the specification was originally assigned after saving the last revision of the Specification 
Binder package, its tag does not appear in the specification list. 

 
 

Delete a Binder Package 
1. Remove any specifications from the binder package you want to delete. 

 If all specifications with a particular form number are deleted, the form note associated 
with that form is automatically deleted. 
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2. Delete the binder package by doing one of the following: 
 Click Actions > Delete. 
 Right-click the binder package and from the shortcut menu select Delete. 
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Manage Association of External Files with a Binder Package 
Associate External Files with a Binder Package 

For all of the procedures, do the following to open the Associated Documents dialog box: 
1. In the Document Binder window, select the binder package for which you want to manage 

external files. 
2. Click Actions > Associated Documents. 
From the Associated Documents dialog box, you can perform the following procedures: 

Associate an External File With a Binder Package 
1. In the Associated Documents dialog box, click Associate. 
2. In the Associate External Document dialog box, navigate to the file, and click Open. 
3. In the Associated Documents dialog box, under Description, type a short description for the 

associated file. 

Open an External File That You Associated With a Binder Package 
On the Associated Documents dialog box, select the file that you want to open, and click Open. 

Dissociate an External File From a Binder Package 
In the Associated Documents dialog box, select the file that you want to dissociate from the 
binder package, and then click Dissociate. 
 
 

Display Binder Package Properties 
You can display the properties of a particular binder package to show general details and a record 
of the revisions that were made. 
1. Select the desired binder package. 
2. Do one of the following: 

 Click Actions > Properties. 
 Right-click the binder package and from the shortcut menu select Properties. 

3. On the Binder Package Properties dialog box, click the General tab to show general details 
of the binder package. 

4. Click the Revisions tab to show details of revisions made to the binder package. 
5. When done, click Close. 
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Specification Binder Package Revisions 
You can revise a set of specifications and notes in a Specification Binder package (for example, 
before printing a request for quotation from a vendor).  Once you assign a specification to a 
Specification Binder package you may only create revisions to that specification as part of the 
Specification Binder package from the Document Binder module. 

 The software does not allow you to perform revisions for Specification Binder 
packages when working in an integrated environment (on the Revisions dialog box, the OK, New, 
and Delete commands are disabled). 
In general, the software allows you to save a revision only for documents that you have changed 
and saved.  You are also allowed to save a revision in the following situations: 
 If a specification has been newly-assigned to the binder package or if you have modified a 

specification for which a revision was already generated in the binder package. 
 If you manually modified the Changed status of a document from No to Yes.  For details, see 

Modify the Change Notification of a Specification (on page 336). 
 If you removed an instrument specification from a Specification Binder package. 

On creating a new revision for a Specification Binder package, documents in the binder package 
(Specification List, Form Notes, General Notes, and Change Summary report) are revised 
automatically, provided a change notification is set for at least one specification.  Other document 
revisions are displayed in the title block of a printed version of these documents. 

 
 To be able to generate revisions, a Specification Binder package must have at least one 

specification assigned to it (if the binder package contains only general notes, for example, 
you cannot generate a revision for it). 

 You cannot delete or rename a Specification Binder package once a revision has been 
performed on it. 

 Before performing a revision in the Document Binder module, verify that none of the 
designated documents are open for editing in any other SmartPlant Instrumentation modules. 

 When you perform a revision on a Specification Binder package, the specifications it contains 
may be assigned revision numbers that are actually lower than the number of any revisions 
that were performed for the individual specifications before they were assigned to the binder 
package. 

 The software does not include in the Document Binder module revisions or documents that 
you created from the Properties dialog box for an item, for example, in the Terminal Strip 
Properties dialog box. 

 You can set the preferences to allow for independent viewing of specification revisions made 
before and after incorporation into a Specification Binder package.  For details, see 
Document Binder > Specification Binder (Preferences. 

 Before saving a revision, you must first release all instrument tags associated with the 
designated specifications from any workflow assignments.  If the System Administrator 
selected to implement a workflow option, one of the following conditions applies: 

 If Full was selected (which includes workflow for the Document Binder module), all the 
specifications in the Specification Binder package must have the status Release to Spec. 

 If Without Document Binder was selected, only those specifications in the Specification 
Binder package whose status is PD not required or Locked from PD can be revised. 
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Change Summary Report 
The change summary report allows you to view all the changes that were made to binder 
packages since the last time a revision was made. To generate such a report, you double-click the 
Change Summary Report folder in the left area of the main Document Binder window. The report 
shows a list of the instrument tags that were modified and are associated with the specifications in 
the selected binder packages.  For example, in the case of a multi-tag specification, a tag may 
have been added to the specification, or deleted from it. 
If the tag data was modified, the report will display the following: 
 Tag number 
 The column where the change was made 
 The old and new values for the specific column 
 The person who made the change 
 The date of change 

 
 The Change Summary Report uses data stored in the Audit Trail repository, therefore to 

enable generation of this report, in the Administration module Domain Definition window, the 
Domain Administrator has to select the Audit trail options check box. 

 If changes were made to the main page of a multi-tag spec, each item in the list will be 
displayed separately in the report, along with its changes. 

 Before a revision is saved for the first time or if no changes were made to items in the binder 
package after a certain revision, a report will not be generated. 

 On SQL Server, the Note sheet can accept up to 255 characters; on Oracle or Sybase 
Adaptive Server Anywhere, you can type up to 2000 characters. 

 Non-English, special character ASCII code used in a note is not displayed correctly in print 
preview. 

 
 

Enable Specification Changes Notification 
When you edit a specification in the Specifications module after adding a revision, you can set 
whether to notify the changes in the Document Binder module. 
When a notification of the changes to a specification is enabled: 
 The revision number of the specification will be incremented the next time a revision is made 

to the Specification Binder package to which it is assigned. 
 Changes to the specification appear in the Change Summary Report. 

 The Change Summary Report uses data stored in the Audit Trail repository.  Therefore, to 
enable generation of this report, in the Administration module Domain Definition window, the 
Domain Administrator has to select the Audit trail options check box. 
After a Specification Binder package has undergone a revision, the changes notification is 
removed (on the Specification Change Notification dialog box, No appears under the Changed 
column for all the specifications), and any documents associated with it (Specifications, Form 
Notes, and General Notes) are saved. 
Following a revision in the Document Binder module, if you modify a specification in the 
Specifications module, when saving the changes, a prompt appears enabling you to decide 
whether to notify the changes in the Document Binder module (this prompt does not appear if the 
change is already notified for the specification). 
The available options are: 
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 Mark this item as changed — When this option is selected, the change you made in the 
Specifications module will also be indicated in the Document Binder module.  In the 
Specification Change Notification dialog box, the Changed column for the specification will 
display Yes.  Consequently, the specification revision number will be updated the next time 
you revise the Specification Binder package to which it is assigned. If any change was made 
to the specification, the instrument tags associated with the specification will appear in the 
Change Summary Report. 

 Do not change existing notification — When this option is selected, the change will not be 
notified in the Document Binder module.  In the Specification Change Notification dialog 
box, the Changed column for the specification will display No. It is recommended that you 
select this option only when the change is minor and you do not want it to be included in the 
next saved revision. 

 
 

Binder Package Revision Archive 
When you create a new revision for a binder package in the Document Binder module, a view-only 
archive copy is made of the information contained in the Specifications, Notes, and Change 
Summary Report. 
The revision archive data can be saved in the database or in a file, depending on the setting that 
the Domain Administrator selects in the Administration module. 
 

Revisions Common Tasks 
The following tasks are used when you make revisions to documents in the Document Binder 
module.  

Add a Revision to a Binder Package 
This option shows you how to revise the documents in a binder package.  There are a number of 
conditions restricting adding a new revision.  For details, see Specification Binder Package 
Revisions (on page 331). 
For more information, see Add a Revision to a Binder Package (on page 334). 

Delete a Revision From a Binder Package 
This procedure shows you how to delete revisions from a given binder package. 
For more information, see Delete a Revision From a Binder Package (on page 335). 

Convert Binder Package Revisions to .Zip Format Files 
This procedure describes how to remove binder package revisions from the database into .zip 
format files. 
When you save revisions to the database, the software compresses the data automatically to save 
space.  To further streamline your database, you can also remove specification, binder package, 
and construction revisions from the database by converting them to .psr or .psr-within-.zip format 
files, which you save in folders external to the database.  This feature is useful when you have 
made a large number of revisions, and want to reduce the size of the active and backup 
databases. 
For more information, see Convert Binder Package Revisions to .Zip Format Files (on page 335). 
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Modify the Change Notification of a Specification 
This procedure shows you how to modify the change notation of specifications in a Specification 
Binder package. 
For more information, see Modify the Change Notification of a Specification (on page 336). 
 

Add a Revision to a Binder Package 
 The software does not allow you to perform revisions for Specification Binder 

packages when working in an integrated environment (on the Revisions dialog box, the OK, New, 
and Delete commands are disabled). 
1. Select the desired binder package. 
2. Do one of the following: 

 Click Actions > Revisions. 
 Right-click and from the shortcut menu select Revisions. 

3. On the Revisions dialog box, select one of the revision numbering methods (use P0, P1, 
P2... for preliminary revisions or 0, 1, 2 / A, B, C, and so forth for normal serial revisions). 

 
 When you first select a revision numbering method, several options are available to you, 

including preliminary revisions (designated by P0, P1, P2...).  Once you select one of the 
other revision methods, you will not be able to return to the preliminary revision method 
and this option will be disabled. 

 Only the last five revisions appear in the Revisions dialog box. 
4. Click New to add new revision data. 
5. Add the revision data in the appropriate data fields. 

 The By field contains the current user's initials by default, if previously defined by the 
SmartPlant Instrumentation System Administrator.  You can also edit this field.  Today's date 
appears in the Revision Date field, by default, but you can change it if desired. 

6. Click OK to save the revision and close the dialog box. 
 After the revision is saved, the change notifications for all the specs are set to No.  In the 

browser view, the Tag Status column for instrument tags associated with specs assigned to or 
deleted from the binder package prior to the last revision is cleared. 

 
 An instrument specification that is added to a Specification Binder package becomes a part of 

that package and is revised according to the new Specification Binder package revision 
number, and not the previous revision number that applied to the individual instrument 
specification. 

 If you add a document to a General Document Binder package, and a revision is made for the 
package as a whole, you can still add revisions for the individual drawings in the package 
without any relation to the revision number of the package. 
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Delete a Revision From a Binder Package 
 The software does not allow you to perform revisions for Specification Binder 

packages when working in an integrated environment (on the Revisions dialog box, the OK, New, 
and Delete commands are disabled). 
1. In the Document Binder window, highlight the binder package from which you want to delete 

a revision. 
2. Do one of the following: 

 Click Actions > Revisions. 

 Click . 
3. On the Revisions dialog box, select the revision you want to delete, and click Delete. 

 Repeat steps 1 - 3 for each revision that you want to delete. 
4. Confirm the deletion by clicking Yes. 
  You can set the module preferences for automatic deletion of revisions when removing a 
specification from a binder package (for details, see Document Binder > General (Preferences).) 
 

Convert Binder Package Revisions to .Zip Format Files 
1. Click Actions > Manage Revisions. 
2. To display binder packages of one revision only, under Revisions filter, type the revision 

number and click Apply. 
3. Do one of the following: 

 In the data window, select the revisions that you want to convert. 
 To select all of the displayed revisions for conversion, click Select all. 

4. Under Convert revisions to, click ZIP files. 

 
 To convert revisions to uncompressed .psr format, click PSR files. 
 To restore .psr or .zip format files to the database, click Database. 

5. Click Convert. 
 

 The Domain Administrator sets the default revision storage method in the Administration 
module.  This gives you the option of storing binder package revisions directly to .zip files 
external to the database. 

 You can vary this procedure to convert binder package revisions back-and-forth among .psr, 
.zip, and SmartPlant Instrumentation database format. 
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Modify the Change Notification of a Specification 
1. Select a Specification Binder package. 
2. Click Actions > Spec Change Notification. 
3. On the Specification Change Notification dialog box, for the desired specifications, select 

the desired option in the Changed column: 
 Yes — Notify that the specification has changed. 
 No — Notify that the specification has not changed. 

  Where Yes is selected, the specification is revised when the Specification Binder 
package is next revised.  You can view the changes in the Change Summary Report. 

 

Print and Save Options (Binder Package) 
When printing documents from a binder package, you can choose between printing current 
documents or previous revisions, and then specify what to print: 
 All the specifications and associated documents of the binder package 
 Changed documents only 
 Only the documents that you select 

 
 

Printing from a Binder Package Common Tasks 
The following tasks are used when you print document from a Document Binder.  

Print Documents in a Binder Package 
This procedure shows you how to print documents in a binder package. 
For more information, see Print Documents in a Binder Package (on page 337). 

Print From a Binder Package to a PDF File 
This procedure shows you how to print a set of documents in a binder package as .pdf files.  After 
setting the path and file name, choose between current documents and previous revisions, then 
specify what to print: 
 All the specifications and associated documents of the binder package 
 Changed documents only 
 Only the documents that you select 

All the documents are saved together in a single .pdf file.  When you open the file — in Adobe® 
Reader for example — you can navigate easily from one document to the next. 
For more information, see Print From a Binder Package to a PDF File (on page 337). 

Save From a Binder Package to a .Zip File 
This procedure shows you how to save a set of documents from a binder package to a .zip 
(compressed) file.  The documents within the .zip file are in the .psr format that the software uses 
for saving reports. 
After setting the path and file name, choose between current documents and previous revisions, 
then specify what to save: 
 All the specifications and associated documents of the binder package 
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 Changed documents only 
 Only the documents that you select 

For more information, see Save From a Binder Package to a .Zip File. (see "Save From a Binder 
Package to a .Zip File" on page 338) 
 

Print Documents in a Binder Package 
1. Select the binder package for which you want to print documents. 
2. Do one of the following: 

 Click Actions > Print. 
 Right-click the binder package and from the shortcut menu select Print. 

3. On the Print dialog box, under Select revision, do one of the following: 
 Click Working issue for current files. 
 For a previous revision, click Formal issue and select the desired revision from the 

Revision list. 
4. Under Print what, do one of the following: 

 Click All documents in binder package to print all the documents of the revision you 
selected, or of the working issue. 

 Click Changed documents only to print documents associated with specifications 
marked as changed since the previous revision.  This option is available only if you 
selected Working issue above. 

 Click Selected documents to print the specifications and notes of your choice from the 
revision you selected, or from the working issue. 

5. Select Show print preview to view the documents prior to printing. 
6. Click OK. 
7. If you clicked Selected documents, the Select Documents dialog box opens. Highlight the 

documents that you want to print and click OK. 

 
 Your Specifications module preferences also determine preferences for specifications that 

you print within binder packages.  For more information, see Document Binder > General 
(Preferences). 

 You can set font and color for report comparison.  For more information, see Setting Font and 
Color for Report Comparison (see "Set Font and Color for Report Comparison" on page 52). 

 
 

Print From a Binder Package to a PDF File 
1. Select the binder package for which you want to print documents to a file. 
2. Click Actions > Print to File. 
3. On the Print to File dialog box, do one of the following: 

 Accept the file path displayed under Path. In this case, the software will create a unique 
file name in the currently displayed folder. 

 Click  and navigate to the folder where you want the software to save your .pdf 
files.  After selecting this folder, you have the following File name options: 
 Type a file name. 
 Select an existing file name from the current folder. 
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 You will be asked whether or not to overwrite the file. If you click No, the Print to File 
browse dialog box will reopen, and a number suffix will be added to the file name. You can edit 
the new file name and click Save to proceed,  

 Leave the File name box blank to let the software create a unique file name. 
 

4. On the Print to File dialog box, under Select revision, do one of the following: 
 Click Working issue for current files. 
 For a previous revision, click Formal issue and select the desired revision from the 

Revision name list. 
5. Under Print what, do one of the following: 

 Click All documents in binder package to print to file all the documents of the revision 
you selected, or of the working issue. 

 Click Changed documents only to print to file documents associated with specifications 
marked as changed since the previous revision.  This option is available only if you 
selected Working issue above. 

 Click Selected documents to print to file the specifications and notes of your choice from 
the revision you selected, or from the working issue. 

6. Click OK to print the documents to a .pdf file. 
7. If you clicked Selected documents, the Select Documents dialog box opens.  Highlight the 

documents that you want to print and click OK. 
 

Save From a Binder Package to a .Zip File 
1. Select the binder package for which you want to save documents into a .zip file. 
2. Click Actions > Save to File. 
3. On the Save to File dialog box, do one of the following: 

 Accept the file path displayed under Path. In this case, the software will create a unique 
file name in the currently displayed folder. 

 Click  to open the Save As dialog box.  Navigate to the folder where you want the 
software to save your .zip files.  After selecting this folder, you have the following File 
name options: 

 Type a file name. 
 Select an existing file name from the current folder. 
 Leave the File name box blank for the software to create a unique file name. 
 Click Save to return to the Save to File dialog box. 

4. Under Select revision, do one of the following: 
 Click Working issue for current files. 
 For a previous revision, click Formal issue and select the desired revision from the 

Revision name list. 
5. Under Save what, do one of the following: 

 Click All documents in binder package to save all the documents of the revision you 
selected, or of the working issue. 

 Click Changed documents only to save documents associated with specifications 
marked as changed since the previous revision.  This option is available only if you 
selected Working issue above. 
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 Click Selected documents to save the specifications and notes of your choice from the 
revision you selected, or from the working issue. 

6. Click OK to save the documents into a .zip file. 
7. If you clicked Selected documents, the Select Documents dialog box opens. Highlight the 

documents that you want to save and click OK. 
 
 

Document Binder Module Troubleshooting 
Errors may occur when you are working in the Document Binder module.  This section describes 
the common ones, with recommendations for solving the problems. 

Binder package problems 

Problem 
Description 

Suggested Reason Recommended 
Solution 

Cannot rename the 
binder package 

Binder package has 
already undergone a 
revision. 

 

Cannot delete the 
binder package 

Binder package has 
already undergone a 
revision or if not, it 
still has specs 
assigned to it. 

If binder package has 
not yet undergone a 
revision, remove all the 
specifications from the 
binder package. 

When selecting 
detailed view of 
specification list, a 
message appears: 
"Failed to retrieve 
Style Setting." 

Default View deleted 
or not defined in 
Document Binder 
Browser. 

Create a View in the 
Package Browser and 
define a style for 
it.  Ensure that the Set 
as default view check 
box is selected. 

No forms available 
for selection when 
you try to add a note 
to the Form Notes 
folder 

No specification has 
been assigned to the 
binder package. 

 

Revision problems 

Problem 
Description 

Suggested Reason Recommended Solution

Cannot revise the 
binder package 

One or more of the 
documents in the 
binder package are 
being edited. 

Close the edit location 
(specification or note 
editor). 
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 One or more of the 
instrument tags 
associated with the 
specification are 
locked for process 
data. 

Release all instrument 
tags from any workflow 
assignments. 

Cannot save 
revised 
documents 

Target is not defined 
for the revision. 

Your Domain 
Administrator needs to 
define the path or 
location. 

Printing problems 

Problem 
Description 

Suggested Reason Recommended 
Solution 

Cannot prepare 
pages for printing 

Open specifications or 
notes. 

Close all specifications 
and notes, then re-select 
the print option. 

The binder 
package includes 
blank reports 

One or more of the 
documents in the 
binder package is 
missing. 

Search for the missing 
reports according to the 
names displayed in the 
error messages, and 
move them to the 
appropriate document 
location. 

Cannot print 
binder package 

Binder package 
contains no 
documents. 

Assign a spec to the 
binder package, or add a 
General Note. 

Cannot repaginate 
before printing 

A problem exists with 
the specification, the 
form, or the format. 

Open the specification in 
the Specifications 
module and follow the 
instructions. 

 
 

In an owner operator domain, when working in a project with As-Built items displayed, you can 
claim As-Built items for this project directly in SmartPlant Instrumentation.  It is possible to claim 
As-Built items using one of the following modes: exclusive claim mode or non-exclusive claim 
mode.  The System Administrator sets the claim mode when making domain definitions in the 
Administration module.  After a Project Administrator creates the first project in the domain, the 
claim mode becomes set permanently for the current domain until the Project Administrator 
deletes all of the projects. 

Claiming As-Built Items for a Project 
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Claiming items is the final stage of defining the project scope.  Before claiming items, you can 
copy them to the Claim Buffer, which is only available in the Administration module.  Then, your 
Project Administrator can log on to the Administration module and claim the copied items for the 
project in batch mode.  Alternatively any user with full Project Definition access rights can claim 
the copied items using command line parameters. 
Any SmartPlant Instrumentation user can copy any number of items to the Claim Buffer, 
however, only users with full Claim Items for Project access rights can claim As-Built items 
directly from the project opened in SmartPlant Instrumentation, without copying them to the Claim 
Buffer first, provided that the Claim Buffer is empty.  Performing a batch claim of As-Built items 
directly from the project is not possible.  You can only claim a specific item that you select, with or 
without its child items, according to the preferences. 
When using non-exclusive claim mode, in SmartPlant Instrumentation, it is only possible to claim 
items from As- Built.  If you want to claim items from one project to another, you must use the 
Administration module options. 
When the As-Built item used as a source for claiming has child items, you can set preferences to 
include or exclude the child items when claiming the parent item.  For example, you can claim a 
cable with or without its associated cable sets or wires.  It is also possible to reclaim the same 
item to update the item properties with the As-Built item properties.  For details about the 
preferences for claiming, see Claim and Merge Options (Preferences) (on page 25). 
In a project, claiming options are available in the Instrument Index module, Browser module, and 
the Domain Explorer: 
 In the Instrument Index module, you can select instruments and claim them with the 

engineering data defined in other modules, for example, with the associated hook-ups. 
 In the Browser module, you can select instruments, lines, loop numbers, or equipment data for 

claiming. 
 In the Domain Explorer, you can select any item and copy it to the Claim Buffer for further 

processing by your Project Administrator, or claim the items according to the preferences set 
on the Claim and Merge Options page of the Preferences dialog box.  Note, however, that if 
you want to claim fieldbus tags, you only need to claim the associated fieldbus segments with 
their sub-items and the fieldbus tags are claimed automatically. 

 It is recommended that any cables in the As-Built, that have been assigned to cable 
drums, are un-assigned from their drums before you claim them to the project. Failure to do so, will 
result in inconsistencies in the As-Built drum data when merging the cables back to the As-Built. 
 

Preparing Project Items for Merging with As-Built 
In a project opened in an owner operator domain, in the Domain Explorer, you can select items 
you want to merge with As-Built and copy them to the Merge Buffer for further processing from 
the Administration module or for merging the copied items using command line parameters.  The 
Merge Buffer is only accessible from the Administration module.  It is not possible to merge items 
directly from a project. 
Before you copy items to the Merge Buffer, you can set preferences to include or exclude the 
child items when copying the parent item.  For example, you can copy a cable with or without its 
associated cable sets or wires.  For details about the preferences for copying items to the Merge 
Buffer, see Claim and Merge Options (Preferences) (on page 25). 
When copying items to the Merge Buffer, you select a merge action for all or selected items.  At 
this stage, the software applies the merge action to the items and also applies the preferences 
options that you have set.  The following actions are available per item: 
Merge now — Overwrites the data in As-Built with the modified data in the current project.  The 
results depend on the change made in the project: 
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 Items that SmartPlant Instrumentation users created in the project are also inserted in 
As-Built.  If an item that exists in the project was deleted in As-Built, that item is reinserted in 
As- Built. 

 Items that SmartPlant Instrumentation users deleted in the project are also deleted in As-Built. 
 Items that SmartPlant Instrumentation users updated in the project are also updated in 

As-Built.  Also, if you made any changes to As-Built data after claiming the item for the project, 
the software overwrites the As-Built data with the project data on merging. 

Release claim — Disregards changes and leaves the data in As-Built as it was before claiming it 
for the project.  When using the Release Claim action, the following rules apply to project data: 
 The Release Claim action does not apply to new items that you create in the project. 
 The Release Claim action does not apply to new sub-items you associated with a claimed 

item. 
 If a claimed item does not have new sub-items you created in the project, the software 

removes the claimed item from the project even if you changed its name and description in the 
project. 

 If a claimed item has new sub-items you created in the project, the software always leaves this 
claimed item as a dummy item in the project. 

 If a claimed item has both claimed sub-items and new sub-items you created in the project, the 
software only removes the claimed sub- items from the project.  The parent item appears in 
the project as a dummy item. 

 
 Your Project Administrator can merge items using one of the two modes set by System 

Administrator for the current domain: with deletion from the project or without deletion from the 
project.  Depending on the merge mode, on merging data, the software either deletes the 
merged items from the project or leaves view-only copies of the merged items in the 
project.  You cannot delete these copies or update their properties.  It is possible, however, to 
claim these items for another project even if you are working in exclusive claim mode. 

 If you want to merge fieldbus tags, you only need to copy to the Merge Buffer the associated 
fieldbus segments with their sub-items.  It is not possible to merge fieldbus tags manually. 

See Also 
Display As-Built and Project Data (on page 343) 
 

Claiming and Merging Items Common Tasks 
In an owner operator domain, the following tasks are used frequently when you claim or copy to 
the Claim Buffer items directly from a project opened in SmartPlant Instrumentation.  Also, it is 
possible to prepare project data for merging with As-Built by copying project items to the Merge 
Buffer.  After copying items to the Merge Buffer, your Project Administrator can either user the 
Administration module options to merge the items, or merge the items from the command 
line.  The Claim Buffer and Merge Buffer are only accessible from the Administration module. 

Display As-Built and Project Data 
If you open a project in an owner operator domain, you can either choose to display only the 
project items, or project items together with view-only As-Built items, which you can claim for the 
project.  It is only possible to claim items if you open a project together with As-Built items 
displayed.  For details, see Display As-Built and Project Data (on page 343). 
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Copy As-Built Items to the Claim Buffer 
This procedure allows you to copy items from the SmartPlant Instrumentation Domain Explorer to 
the Claim Buffer, which is only accessible from the Administration module.  After you copy the 
items, the Project Administrator can log on to the Administration module and claim all or specific 
the items that you copied in the Claim Buffer.  When you select items, the software automatically 
applies preferences that you set on the Preferences dialog box.  These preferences determine 
how the software copies to the Claim Buffer sub-items that are associated with the items you 
select.  For more information, see Copy As-Built Items to the Claim Buffer (on page 344). 

Claim As-Built Items from the Domain Explorer 
If the Claim Buffer does not contain any items, you can use this procedure to claim items directly 
from the Domain Explorer.  When you select items, the software automatically applies 
preferences that you set on the Preferences dialog box.  These preferences determine how the 
software claims sub-items that are associated with the items you select.  For more information, 
see Claim As-Built Items from the Domain Explorer (on page 345). 

Claim Instruments in the Browser or Instrument Index Module 
You can claim tag numbers in the Instrument Index module, or in the Browser module.  In an 
owner operator domain, use this procedure to claim the As-Built tags for the current project, with 
or without the engineering data associated with the tags.  For more information, see Claim 
Instruments in the Browser or Instrument Index Module (on page 345). 

Claim Loops, Lines, and Equipment in the Browser Module 
This procedure describes how to claim As-Built loops, lines, and equipment in the Browser 
module.  The software claims items without any engineering data that is associated with the 
items.  For example, when claiming a loop, the software does not claim the tag numbers 
associated with the loop.  For more information, see Claim Loops, Lines, and Equipment in the 
Browser Module (on page 346). 

Copy Items to the Merge Buffer as Merge Now 
Use this procedure to copy specific items from the Domain Explorer to the Merge Buffer and 
assign a Merge Now action to these items.  For more information, see Copy Items to the Merge 
Buffer as Merge Now (on page 346). 

Copy Items to the Merge Buffer as Release Claim 
Use this procedure to copy specific items from the Domain Explorer to the Merge Buffer and 
assign a Release Claim action to these items.  For more information, see Copy Items to the 
Merge Buffer as Release Claim (on page 347). 
 

Display As-Built and Project Data 
1. On the Open dialog box, select a domain of type Owner operator. 

2. Double-click the appropriate project icon  to select the project you want to work with 
(As-Built or a project). 
 To view As-Built data only, select As-Built from the list. 
 To view project data, select any project from the list (you can choose afterwards whether 

to display As-Built data with the project data - see steps 4 and 5 for details). 
3. Select the <unit> in which you want to work and click OK.  By default, SmartPlant 

Instrumentation opens with data visible only from the project you selected. 
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4. To display As-Built and project data together, do one of the following: 

 Click . 
 Click File > As-Built Data. 

5. To return to the display of project data only, do one of the following: 

 Click . 
 Click File > Project Data. 

 
 According to the data you select to display, the items will be formatted according to the 

settings made in the Administration module. 
 If you select to display both project and As-Built data, you can edit the project data only. 
 When working in a project with As-Built items displayed, As-Built items are view-only.  In the 

Domain Explorer, you can select an As-Built item and display its properties.  As-Built items 
are indicated with the  icon. 

 
 

Copy As-Built Items to the Claim Buffer 
1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 

and Project Data (see "Display As-Built and Project Data" on page 343). 
2. Press F7 to open the Domain Explorer. 
3. Expand the explorer hierarchy to display folders of item types. 
4. In the tree view pane, click an item type folder to display the items. 
5. Do one of the following: 

 In the tree view pane, right-click a specific item, and on the shortcut menu, click Project 
Activities > Copy to Claim Buffer. 

 In the Items pane, select and right-click one or more items, and on the shortcut menu, 
click Project Activities > Copy to Claim Buffer. 

 
 When you copy items to the Claim Buffer, in addition to the main items you select, the 

software can select the associated sub- items automatically, or you have the option to include 
the sub-items manually with the main item by setting preferences accordingly.  For details, 
see Claim and Merge Options (Preferences) (on page 25). 

 If you copied to the Claim Buffer a loop or instrument together with the wiring items, the 
software only copies those wiring items that have a signal propagated to the loop or 
instrument.  If you placed a device panel inside a cabinet or junction box, when claiming the 
loop, this device panel is not copied together with the cabinet or junction box because this 
device panel does not have a signal propagated to the loop.  You must select and copy such 
a device panel manually. 
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Claim As-Built Items from the Domain Explorer 
 Claiming items from the Domain Explorer is only possible if the Claim Buffer in the 

Administration module has no items. 
1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 

and Project Data (see "Display As-Built and Project Data" on page 343). 
2. Press F7 to open the Domain Explorer. 
3. Expand the explorer hierarchy to display folders of item types. 
4. In the tree view pane, click an item type folder to display the items. 
5. Do one of the following: 

 In the tree view pane, right-click a specific item, and on the shortcut menu, click Project 
Activities > Claim. 

 In the Items pane, select and right-click one or more items, and on the shortcut menu, 
click Project Activities > Claim. 

 
 When claiming instruments from the Domain Explorer, you cannot select basic engineering 

data manually or set the software to claim instruments without including the associated basic 
engineering data.  It is possible to claim instruments without the engineering data in the 
Browser or Instrument index module.  For details, see Claim Instruments in the Browser or 
Instrument Index Module (on page 345). 

 When you claim items, in addition to the main items you select, the software can select the 
associated sub-items automatically, or you have the option to include the sub-items manually 
with the main item by setting preferences accordingly.  For details, see Claim and Merge 
Options (Preferences) (on page 25). 

 If you claimed a loop or instrument together with the wiring items, the software only claims 
those wiring items that have a signal propagated to the loop or instrument.  If you placed a 
device panel inside a cabinet or junction box, when claiming the loop, this device panel is not 
claimed together with the cabinet or junction box because this device panel does not have a 
signal propagated to the loop.  You must select and claim such a device panel manually. 

  
 

Claim Instruments in the Browser or Instrument Index 
Module 

1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 
and Project Data (see "Display As-Built and Project Data" on page 343). 

2. Do one of the following: 
 Open an Instrument Index Standard Browser view. 
 In the Browser module, open a browser view for the Instrument Index browser. 

3. Select and right-click the As-Built tag numbers that you want to claim for the current project. 
 As-Built and project tag numbers have different color coding.  The Project Administrator 

selects which colors to use on the Project Activities dialog box in the Administration module. 
4. On the shortcut menu, click Claim. 
5. In the Tag Claiming Options dialog box, select Basic engineering data to claim associated 

data that was defined for the tags in the Instrument Index, Calculation, Specifications, Hook- 
Ups, Process Data, and Dimensional Data for Piping modules. 
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6. Select Wiring data to claim associated wiring data that was defined for the tags in the Wiring 
module. 

 It is possible to claim instruments either without the engineering data or without the 
wiring data.  You must select at least one check box. 

 

Claim Loops, Lines, and Equipment in the Browser 
Module 

1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 
and Project Data (see "Display As-Built and Project Data" on page 343). 

2. In the Browser module, expand the Instrument Index browser group and open a browser view 
for one of the following browsers: 
 Loop Browser. 
 Line Browser. 
 Equipment Browser. 

3. Select and right-click the As-Built items that you want to claim for the current project. 

 
 As-Built and project items have different color coding.  The Project Administrator selects 

which colors to use on the Project Activities dialog box in the Administration module. 
 In the Browser module, you can also claim instrument tag numbers.  For details, see 

Claim Instruments in the Browser or Instrument Index Module (on page 345). 
4. On the shortcut menu, click Claim. 
  
 

Copy Items to the Merge Buffer as Merge Now 
1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 

and Project Data (see "Display As-Built and Project Data" on page 343). 
2. Press F7 to open the Domain Explorer. 
3. Expand the explorer hierarchy to display folders of item types. 
4. In the tree view pane, click an item type folder to display the items. 
5. Do one of the following: 

 In the tree view pane, right-click a specific item, and on the shortcut menu, click Project 
Activities > Copy to Buffer as Merge Now. 

 In the Items pane, select and right-click one or more items, and on the shortcut menu, 
click Project Activities > Copy to Buffer as Merge Now. 

 
 If the items that you select already appear in the Merge Buffer, when copying the items, the 

software also changes the merge action to Merge Now for those items. 
 When you copy items to the Merge Buffer, in addition to the main items you select, the 

software can select the associated sub- items automatically, or you have the option to include 
the sub-items manually with the main item by setting preferences accordingly.  For details, 
see Claim and Merge Options (Preferences) (on page 25). 
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 If you copied to the Merge Buffer a loop or instrument together with the wiring items, the 
software only copies those wring items that have a signal propagated to the loop or 
instrument.  If you placed a device panel inside a cabinet or junction box, when merging the 
loop, this device panel is not copied together with the cabinet or junction box because this 
device panel does not have a signal propagated to the loop.  You must select and copy such 
a device panel manually. 

  
 

Copy Items to the Merge Buffer as Release Claim 
1. Open a project together with the As-Built data displayed.  For details, see Display As- Built 

and Project Data (see "Display As-Built and Project Data" on page 343). 
2. Press F7 to open the Domain Explorer. 
3. Expand the explorer hierarchy to display folders of item types. 
4. In the tree view pane, click an item type folder to display the items. 
5. Do one of the following: 

 In the tree view pane, right-click a specific item, and on the shortcut menu, click Project 
Activities > Copy to Buffer as Release Claim. 

 In the Items pane, select and right-click one or more items, and on the shortcut menu, 
click Project Activities > Copy to Buffer as Release Claim. 

 
 If the items that you select already appear in the Merge Buffer, when copying the items, the 

software also changes the merge action to Release Claim for those items. 
 When you copy items to the Merge Buffer, in addition to the main items you select, the 

software can select the associated sub- items automatically, or you have the option to include 
the sub-items manually with the main item by setting preferences accordingly.  For details, 
see Claim and Merge Options (Preferences) (on page 25). 

 If you copied to the Merge Buffer a loop or instrument together with the wiring items, the 
software only copies those wring items that have a signal propagated to the loop or 
instrument.  If you placed a device panel inside a cabinet or junction box, when merging the 
loop, this device panel is not copied together with the cabinet or junction box because this 
device panel does not have a signal propagated to the loop.  You must select and copy such 
a device panel manually. 

  
 

Working with Cable Routing in Projects 
There are a number of scenarios that influence the way you work with cable routing in As-Built and 
Projects. The actual procedures are the same as for working in an EPC plant. For more 
information on cable routing, see Cable Routing. 
These scenarios are based on an As-Built plant with at least 2 projects. 

 It is recommended that any cables in the As-Built, that have been assigned to cable 
drums, are un-assigned from their drums before you claim them to the project. Failure to do so, will 
result in inconsistencies in the As-Built drum data when merging the cables back to the As-Built. 
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Scenario 1 
The As-Built has no routing data 
When the As-Built contains no cables with routing data, you can add routing data to one of the 
plants projects. When you have finished adding the routing data to your project you must merge 
cables with the routing data back to the plant. If you want to work with the routing data in another 
project you must claim it from the As-Built after it has been merged back to the As-Built. 

 Routing data can only be added to one project at a time. To add routing data to 
another project, the cables with the routing data must be merged with the plant and then claimed 
by another project. 

Scenario 2 
The As-Built has routing data. 
When the As-Built has cables with routing data, the first project that these cables are claimed to, 
becomes the project that you can add and edit routing data in. Only one project at a time can claim 
routing data, claiming cables with routing data, to a second project, does not allow you working 
access to the routing data. If you want to work with the routing data in another project you must 
claim it from the As-Built after it has been merged back to the As-Built. 

 Though the routing data is only available for working with, from within one project, 
both the reports and validations collate all the routing data from the plant and all its projects, not 
just the project with the working access to the routing data. 
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S E C T I O N  3 3  

SmartPlant Instrumentation provides several interfaces that allow you to exchange data with the 
following products: 
 SmartPlant Electrical (see "SmartPlant Electrical Interface" on page 350) 
 * SmartPlant P&ID (see "SmartPlant P&ID Interface" on page 359) 
 * PDS (see "PDS Interface" on page 370) 
 * FirstVue (see "FirstVue Interface" on page 397) 
 * Masoneilan ValSpeQ (see "Masoneilan ValSpeQ Interface" on page 405) 
 * Flowserve Performance! (see "Flowserve Performance! Interface" on page 411) 
 DCS Vendor Interfaces (on page 377): 

 DeltaV 
 Yokogawa CENTUM CS 3000 
 ABB 
 Honeywell 
 For the systems marked with an asterisk(*), the import procedure must be carried out using 

the predefined import links for the interface.  To make the links available, you need to import the 
appropriate system interfaces into SmartPlant Instrumentation from the Administration module. 
 

Import System Interfaces 
1. Start the Administration module and log on as Domain Administrator. 
2. With the Domain Administration window open, click Add-Ins > Import System Interfaces. 
3. Under Source database, locate the database file in one of the following ways: 

 In the File name and path box, type the path and filename of the database file 
In_ctlog.db. 

 Click Browse to navigate to In_ctlog.db. 
4. Click Connect to connect to the source database file. 

 If you get a message stating that the connection has failed, make sure you typed 
in the correct path and filename of the database file (see step 3 of this procedure). 

5. Under the Select link group section, select one or more of the link groups to import. 
6. Locate the source path of all the links in the imported group in one of the following ways: 

 In the Source file path data field, type the source path. 
 Click Browse to navigate to the required source path. 

7. Clear the Import only source codes check box if it was selected. 
8. If you are importing the PDS/SmartPlant P&ID link, select or clear the Import typical 

instruments check box as desired. 
9. Click Import to add the selected link group to the database. 

Working with Interfaces 
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SmartPlant Electrical Interface 
The SmartPlant Electrical Interface allows you to exchange data between the two applications 
using the following document types: 
 Power elements — You initially define power supply requirements in SmartPlant 

Instrumentation for tag numbers and for any panel type except for junction boxes and device 
panels.  On publishing the data from SmartPlant Instrumentation, SmartPlant Electrical uses 
the published power supply data to create instruments from SmartPlant Instrumentation tag 
number data and cabinets from panel data in SmartPlant Instrumentation.  You can then 
publish the data and retrieve it back to SmartPlant Instrumentation with SmartPlant Electrical 
PDB information. 

 Signals — Signal data can originate in SmartPlant Electrical or in SmartPlant 
Instrumentation.  You can define signal data for generators, battery banks, converting 
equipment, loads, control stations, any type of circuit, and disconnect equipment.  On 
retrieving all SmartPlant Electrical signals, SmartPlant Instrumentation creates special 
electrical tags, for which you can perform wiring and I/O control system tag 
assignments.  After the wiring is complete, you can publish the data back to SmartPlant 
Electrical for further processing, and use it to display PLC or other host I/O data in SmartPlant 
Electrical schematics. 

 
 The documents published by the two applications do not contain the same properties.  For 

example, instrument and cabinet data includes power supply parameters such as rated 
voltage, full load current, and so forth, which originate in SmartPlant 
Instrumentation.  However, SmartPlant Electrical only publishes PDB/Cell/Circuit 
information.  Similarly, SmartPlant Instrumentation publishes host data for signals that 
originate in SmartPlant Electrical, but SmartPlant Electrical does not publish the host data 
back to SmartPlant Instrumentation.  For this reason, if, in SmartPlant Electrical, you change 
data values that originated from SmartPlant Instrumentation, you should update those values 
accordingly in SmartPlant Instrumentation, and vice versa. 

 If you publish signals in SmartPlant Electrical for circuits that feed items other than loads, 
converting equipment, generators, battery banks, instruments, or cabinets, then on retrieving 
the items in SmartPlant Instrumentation and running the tasks, SmartPlant Instrumentation 
does not display the associated items. 

 

Prerequisites for Working with the SmartPlant Electrical 
Interface 

Before you can work with the SmartPlant Electrical Interface, you must perform the following 
actions: 
1. Install the SmartPlant Schema Component from the SmartPlant Instrumentation CD Browser 

(click Add-In Software, and then click Schema Component Installation). 
 On the Select Optional Features page, clear the Schema Editor check box if you do 

not need to use the Schema Editor. 
2. Install the SmartPlant Client from the SmartPlant Instrumentation CD Browser (click Add- In 

Software, and then click SmartPlant Client Installation). 
 On the Select Features page, make sure that you clear the SmartPlant Automatic 

Retrieval check box. 
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3. In the Windows Registry, you need to specify the folder location of the .xml file containing the 
published data.  In the case where multiple users publish the data, all the users must define 
the same path.  The path is defined in the Registry location 
HKEY_CURRENT_USER\Software\INTERGRAPH\INTOOLS using the parameter 
OutputXMLFolder = <.xml file path>. 

4. The System Administrator must enable the item registry.  For details, see Enable Item 
Registry in the Administration User's Guide, under System Administration, Domain 
Management. 

5. The Domain Administrator must register the items.  For details, see Register Items in the 
Administration User's Guide, under Working in an Integrated Environment. 

6. Set up the plant hierarchy for which you are going to publish and retrieve data. 

 
 To ensure the smooth functioning of the SmartPlant Instrumentation backup and restore 

functions and to avoid duplicating data, each plant in SmartPlant Electrical must map to 
SmartPlant Instrumentation at the domain level.  For this reason, make sure that each 
SmartPlant Instrumentation domain that you map contains no more than one plant. 

 At this stage, the prerequisites for working with the interface must also be met on the 
SmartPlant Electrical side.  For details, refer to the SmartPlant Electrical Online Help 
topic: Prerequisites for Working with the SmartPlant Instrumentation Interface. 

7. In SmartPlant Instrumentation, retrieve the file Plant Groups.xml, (on the SmartPlant menu, 
click Retrieve, and then navigate to the file which is published in the folder of the current 
specified SmartPlant Electrical plant).  This file contains plant structure information to 
facilitate correlation of the plant structures between both applications. 

8. For each unit where data is to be published and retrieved, the Domain Administrator must 
open the Unit dialog box and enter a unit number corresponding to the unit code of the 
mapped SmartPlant Electrical unit. 

9. You are now ready to use the interface to publish and retrieve data. 
 
 

Flow of Activities for Creating Control Systems 
The following steps constitute the primary flow of activities when you use SmartPlant 
Instrumentation to create the detailed wiring and control system data for a SmartPlant Electrical 
item: 
1. In SmartPlant Electrical, create signals for the items you want to associate with control 

systems in SmartPlant Instrumentation and publish the data from SmartPlant Electrical.  For 
details, refer to SmartPlant Electrical Online Help. 

 SmartPlant Electrical publishes the data in an .xml file, which it creates in the plant 
structure path. 

2. Open SmartPlant Instrumentation and retrieve the data that originated in SmartPlant 
Electrical.  For details, see Retrieve SmartPlant Electrical Data (on page 353). 

3. Run the tasks that the software generates as a result of the retrieve.  For details, see Run 
Tasks from the To Do List (on page 504). 

 
 SmartPlant Instrumentation automatically creates tag numbers from the retrieved data 

and identifies them as SmartPlant Electrical tags. 
 As an alternative to creating signals in SmartPlant Electrical and then publishing them, 

you can create the Electrical tags directly in SmartPlant Instrumentation.  For details, see 
Create Electrical Tags (on page 353). 
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4. View the SmartPlant Electrical tags created in SmartPlant Instrumentation.  For details, see 
Viewing Electrical Tag Numbers (on page 353). 

5. Associate the SmartPlant Electrical tags with loop numbers where needed; the software 
populates the loop number data to SmartPlant Electrical later. 

6. Associate the SmartPlant Electrical tags with electrical equipment where needed.  For 
details, see Associate Electrical Signals with Equipment (on page 354). 

7. Create the necessary panels and cables and make the connections needed to propagate the 
signal to the DCS or PLC that is used to define the control system tag relationship.  For 
details, see Create Wiring Items for SmartPlant Electrical Signals (on page 355). 

 If a signal is associated with a circuit in SmartPlant Electrical, it inherits its power 
distribution board (PDB) item tag as an associated field and is considered as a pre-assigned 
signal for the PDB cabinet.  For circuit signals, SmartPlant Instrumentation automatically 
creates a cabinet with the name of the power distribution board to which the circuit was 
connected in SmartPlant Electrical.  For other signals, you need to create device panels 
manually in SmartPlant Instrumentation.  For details, see Create a Local Signal for Electrical 
Tags (on page 356). 

8. Publish the data to SmartPlant Electrical.  This creates an .xml document containing 
SmartPlant Instrumentation data such as the control system configuration, I/O assignment, 
PLC I/O card and channel, instrument tags, loop number, and so forth.  For details, see 
Publish Data for SmartPlant Electrical (on page 358). 

 The software creates the file in the path: <SmartPlant Instrumentation home 
folder>\XML\IO Assignment_data.xml. 

9. Retrieve (import) the configured data in SmartPlant Electrical. 
10. Display the I/O assignment data in a SmartPlant Electrical schematic by including in the 

schematic macros related to SmartPlant Electrical signal data.  For details, see SmartPlant 
Instrumentation Macro Structure. 
 In Enhanced Report Utility reports and CAD drawings for a signal that applies to a circuit, the 

loop macros cannot retrieve main or associated electrical equipment names and types because 
the signal is not directly linked with these items.  Furthermore, it is possible for a circuit to feed 
more than one item of equipment, and this is incompatible with the way that macros function, 
where each macro can retrieve only a single data value at a time.  Likewise, if a signal is linked to 
an item of electrical equipment, you cannot use macros to retrieve circuit data. 

 
 You can repeat this procedure as many times as you want to; SmartPlant Instrumentation 

recognizes new, modified, and deleted data that is published from SmartPlant Electrical. 
 The data is owned by the application that created it.  If you modify or delete the data in the 

application that does not own it, the next time you retrieve the data from the owner application, 
it overwrites any modified data, or reinserts data if it was deleted.  A specific data property 
usually belongs to one or other of the applications; however, the Sys I/O type property is 
owned by both applications and in this case the software overwrites the value in whichever 
application you retrieve the data. 
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Retrieve SmartPlant Electrical Data 
1. Click SmartPlant> Retrieve. 
2. On the Retrieve Document dialog box, type the path to the folder where the source .xml files 

containing the published data are located, or click Browse to navigate to the folder. 
3. From the Document list, select the document that you want to retrieve. 
4. Run the tasks that the software generates as a result of the retrieve.  For details, see Run 

Tasks from the To Do List (on page 504). 

 
 The software automatically retrieves the appropriate .xml files associated with the document 

that you select. 
 It is possible for SmartPlant Electrical users to delete items that originated from SmartPlant 

Instrumentation, such as cabinets.  In this case, when data is next published from SmartPlant 
Electrical and retrieved back into SmartPlant Instrumentation, the software creates Delete 
tasks for those items in the To Do List window.  If you do not want those items to be deleted 
from the SmartPlant Instrumentation database, you should click  to remove the task from 
the To Do List window. 

 

Create Electrical Tags 
1. In the Domain Explorer, expand the plant hierarchy to display the Electrical Tags folder and 

right-click the folder. 
2. On the New Tag Number dialog box, enter a tag number. 
3. On the Loop Name dialog box, if desired, enter a loop number or click Cancel to skip loop 

creation. 
4. On the Tag Number Properties dialog box, enter values as desired. 

 Values that you enter for the Service and I/O type properties appear in the Description and 
I/O type fields respectively for the signal properties after the data is retrieved in SmartPlant 
Electrical. 

See Also 
Prerequisites for Working with the SmartPlant Electrical Interface (on page 350) 
 

Viewing Electrical Tag Numbers 
On retrieving data from SmartPlant Electrical, SmartPlant Instrumentation creates corresponding 
electrical tags.  You can view these tags from the Domain Explorer or in the Browser module. 

 
 Some tag number properties apply to SmartPlant Electrical data only, and are read- 

only.  You can edit other properties such as Service, I/O type, and Notes. 
 When you retrieve a SmartPlant Electrical PDB (power distribution board) pre-assigned circuit 

signal, SmartPlant Instrumentation automatically creates a cabinet with the name of the power 
distribution board associated with the signal.  If you delete such a cabinet, its pre-assignment 
relationship with the signal is lost and you will no longer be able to find the tag for that signal 
when you select Pre-assigned signals only in the Signal Filter dialog box.  However, the 
next time you publish the signal from SmartPlant Electrical and retrieve it into SmartPlant 
Instrumentation, the cabinet is created afresh. 

 When you download electrical tags from SmartPlant Electrical, after making the I/O 
assignments, SmartPlant Instrumentation automatically assigns a control system tag to each 
electrical tag. 
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 There are three categories of electrical signals, for each of which the user interface differs 
slightly, as follows: 

 Signals related directly to PDB circuits that are associated with main equipment; for 
example, a signal created in a feeder circuit that feeds a motor. 

 Signals directly related to main equipment; for example, a signal created under a motor or 
a transformer. 

 Signals associated directly with control stations that are associated with main equipment 
such as motors. 

 In the Domain Explorer, electrical tag numbers can be viewed by expanding the Electrical 
Tags folder. 

 In the Browser module, you can view electrical tag numbers from one of the following 
browsers: 

 Electrical Tag Browser — Displays data for all tag numbers derived from SmartPlant 
Electrical signals for all items but does not retrieve data values of associated attributes for 
signals created under circuits.  The software displays data for the main item and also 
associated circuit data. 

 Circuit Related Electrical Tag Browser — Displays data for tag numbers derived from 
SmartPlant Electrical signals for circuits.  If a circuit relates to more than one electrical 
item, a separate data row appears for each item. 

 Electrical Power Element Browser — Displays electrical properties owned by 
SmartPlant Instrumentation and SmartPlant Electrical for instruments and cabinets. 

 

Associate Electrical Signals with Equipment 
1. In the Domain Explorer, expand the Electrical Equipment folder hierarchy and select the 

desired item of electrical equipment from one of the following sub-folders: 
 PDBs — for Power Distribution Boards and their associated circuits. 
 Main Equipment — for items such as motors, heaters, control stations that are 

associated with electrical equipment, and so forth. 
 Control Stations — for control stations without associations with electrical equipment. 

 
 The items that appear in these folders are retrieved from SmartPlant Electrical; you 

cannot create them in SmartPlant Instrumentation. 
 To associate an electrical signal with an electrical equipment item, that item must not 

have any existing associations. 
2. From the Electrical Tags folder, select an electrical signal tag and drag it to the desired item 

under the Electrical Equipment sub-folder. 
 You can only associate electrical tag signals that do not have existing associations with 

electrical equipment. 

See Also 
Prerequisites for Working with the SmartPlant Electrical Interface (on page 350) 
 



 Working with Interfaces 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 355 
 

Create Wiring Items for SmartPlant Electrical Signals 
1. If necessary, press F7 to open the Domain Explorer. 
2. Do one of the following: 

 Double-click the Panels by Location folder, right-click a location, and then on the 
shortcut menu, click New > PLC Panel. 

 Double-click the Panels by Category folder, right-click the PLC Panels folder, and then 
on the shortcut menu, click New > PLC Panel. 

3. Create an I/O card for the PLC panel.  For details, see Create an I/O Card. 
 When entering channel addresses for the I/O card, the values must be numeric only for 

publishing to SmartPlant Electrical. 
4. Create the cables needed to make the connections. 
5. Add terminal strips to the cabinets that SmartPlant Instrumentation created automatically from 

circuit signals that you downloaded from SmartPlant Electrical. 
6. Create device panels for tags that do not come from pre-assigned signals.  Such tags usually 

originate from SmartPlant Electrical control stations or from one of the types of electrical 
equipment (motors, heaters, transformers, generators, and so forth). 

7. Create tag signals.  For details, see Create a Local Signal for Electrical Tags (on page 356). 
8. Connect the PLC to the cabinet using the cable you created. 
9. Re-propagate the tag signal to the PLC.  For details, see Re-Propagate a Tag Signal. 

 You can use macros related to SmartPlant Electrical signal data to generate Enhanced 
Report Utility reports or CAD application-based drawings.  For details, see SmartPlant 
Instrumentation Macro Structure. 
 

Create a Device Panel for an Electrical Tag 
This procedure shows you how to create a device panel for a tag that was created from retrieved 
data originating in SmartPlant Electrical. 
1. Open the Wiring module. 
2. Do one of the following: 

 On the toolbar, click . 
 Click Actions > Device Panels. 
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3. On the toolbar, click . 
4. To display SmartPlant Electrical tags only, in the Filter dialog box, enter values as shown: 

 

 
5. Click OK to return to the Device Panels window. 
6. Select a tag number and do one of the following: 

 Click Actions > Create. 

 On the toolbar, click . 
7. On the Create Device Panel and Cable dialog box, select the required default panel, default 

cable, and connection type. 
8. To apply the values that you set to all of the tags with incomplete profiles that you selected in 

the Device Panels window, select Apply to all selected tags with incomplete profile. 
 

Create a Local Signal for Electrical Tags 
This procedure shows you how to create a local signal in SmartPlant Instrumentation for tags that 
were created from retrieved data originating in SmartPlant Electrical. 
1. If necessary, press F7 to open the Domain Explorer. 
2. Select one of the following: 

 A terminal strip that you created for an automatically generated cabinet (derived from the 
PDB in SmartPlant Electrical). 

 A field device panel. 
3. Right-click the selected item , and on the shortcut menu, click Actions > Connection. 
4. In the Connection window, do one of the following: 

 Right-click in the data window and on the shortcut menu, click Manage Local Signals. 

 On the module toolbar, click . 
5. On the Local Signal dialog box, click Filter. 
6. In the Filter dialog box, select SmartPlant Electrical tags only.  This option selects only 

tags related to SmartPlant Electrical that do not have any connections. 
7. Do one of the following: 

 Select Pre-assigned signals only to select only those electrical tags for which the 
SmartPlant Electrical signals have pre-assigned associations to a power distribution 
board. 
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 Clear Pre-assigned signals only to select all unconnected tags related to SmartPlant 
Electrical. 

8. Click OK to return to the Local Signal dialog box. 
9. Select a tag number and click Create to create and associate the local signal with the tag 

number.  Repeat this action for each tag number. 
 SmartPlant Instrumentation creates the local signal and its name appears next to the 

instrument tag with which it is associated in the Local Signal dialog box. 
10. Click Close. 
 

Flow of Activities for Defining Power Supplies 
The following steps constitute the primary flow of activities when you use SmartPlant 
Instrumentation to define power supply requirements for instruments and cabinets: 
1. In SmartPlant Instrumentation, press F7 to open the Domain Explorer. 
2. Expand the appropriate folder to display instruments or panels. 
3. Right-click the desired instrument or panel, and on the shortcut menu, click Properties. 
4. On the General tab of the dialog box for the selected item , select Requires power supply. 

 If the cabinet originated from PDB information in SmartPlant Electrical, the power 
supply data for that cabinet belongs to SmartPlant Electrical.  In this case, entering power 
supply data in SmartPlant Instrumentation results in the creation of a task in SmartPlant 
Electrical that generates an error when run.  To prevent publishing of power supply data in 
this case, make sure that you clear Requires power supply. 

5. Click the Power Supply tab and enter your electrical load data. 
6. Click OK to close the dialog box. 
7. Publish the data to SmartPlant Electrical.  This creates an .xml document containing all 

SmartPlant Instrumentation data in the current plant such as the control system configuration, 
I/O assignment, PLC I/O card and channel, instrument tags, loop number, and so forth. 

 The software creates the file in the path: <SmartPlant Instrumentation home 
folder>\XML\IO Assignment_data.xml. 

8. Retrieve the data in SmartPlant Electrical and run the tasks there to create instruments and 
cabinets. 

9. After assigning a PDB and circuit for each load, publish the data from SmartPlant Electrical. 
10. In SmartPlant Instrumentation, retrieve the SmartPlant Electrical data.  For details, see 

Retrieve SmartPlant Electrical Data (on page 353). 
11. Run the tasks that the software generates as a result of the retrieve.  For details, see Run 

Tasks from the To Do List (on page 504). 
12. View the tag numbers or cabinets in SmartPlant Instrumentation and note that power 

distribution board data appears on the Power Supply tab of the appropriate dialog box. 

 
 The power distribution board data is also available for displaying in loop drawings. 
 You can repeat this procedure as many times as you want to; SmartPlant Instrumentation 

recognizes new, modified, and deleted data that is published from SmartPlant Electrical. 
 The data is owned by the application that created it.  If you modify or delete the data in the 

application that does not own it, the next time you retrieve the data from the owner application, 
it overwrites any modified data, or reinserts data if it was deleted.  A specific data property 
usually belongs to one or other of the applications. 
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Publish Data for SmartPlant Electrical 
1. Open the Browser module. 
2. In the Browser Manager window, do one of the following: 

 To publish electrical signal data, expand the hierarchy Instrument Index > Electrical 
Tag Browser. 

 To publish power supply data, expand the hierarchy Instrument Index > Electrical 
Power Element Browser. 

3. Open the browser view, or create a new view. 

4. On the toolbar, click Print . 
5. At the prompt to preview the report, click Yes. 

6. On the Print Preview window toolbar, click Revisions . 
7. On the Publish SmartPlant Electrical Data dialog box, select Publish document and data. 

 You must always choose this option when revising data in the SmartPlant 
Electrical Interface. 

8. On the Revisions dialog box, click New. 
9. On the SmartPlant Foundation Revise dialog box, beside Revision Scheme, select a value 

from the list. 
10. Under Revise in Tool, beside Major, select a value from the list. 
11. Click OK to implement the revision. 

 When publishing in point-to- point mode, clicking New on the Revisions dialog box just 
adds a new line in which you can type the revision details. 

12. Click OK to close the Revisions dialog box. 
13. Click SmartPlant > Publish. 
14. On the Publish SmartPlant Electrical Data dialog box, select Publish document and data. 

 You must always choose this option when publishing in the SmartPlant Electrical 
Interface. 

15. On the Publish dialog box, from the Operation list, select Publish Now or Background 
Publish. 

16. Click OK to publish the data. 
17. From the Publish message box, click Close if the publish operation was successful, or View 

Log if there were errors. 
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SmartPlant P&ID Interface 
The SmartPlant P&ID interface allows you to import P&ID drawing data (for example; pipe runs, 
vessels and instruments) into your database from a SmartPlant P&ID database. 
You import the P&ID data first by connecting to the appropriate SmartPlant P&ID database from 
which the SmartPlant Instrumentation Import Utility will import the drawing data. 
After you connect to the SmartPlant P&ID database you select the source unit and source 
P&ID.  With the source data selected, you can perform the import setup process and import the 
selected P&ID data. 

 In the SmartPlant P&ID Interface, when you create a new link for importing data into a table 
while connected to a plant, the software automatically creates the correct connection in the link 
properties. 

 SmartPlant P&ID must be closed before starting the import session, to ensure that 
any modifications made to the drawings are properly imported to SmartPlant Instrumentation. 
 

Importing SmartPlant P&ID Component Data 
The Import Utility allows you to connect to a SmartPlant P&ID database, select a source plant, 
drawings, and item types and import P&ID components such as instrument tags, lines, or 
equipment into the SmartPlant Instrumentation database. 
After the Domain Administrator imports SmartPlant P&ID link groups from the In_ctlog.db file 
using the Administration module options, the link groups appear in the Link Explorer in the 
Import Utility.  The links in these groups have predefined mapping which you need to modify as 
you require.  You cannot change the import method or table/module assignment of these links.  It 
is possible to restore deleted SmartPlant P&ID links or link groups by re- importing the link groups 
from the In_ctlog.db file.  Note, however, that to restore deleted links or link groups, you must first 
rename all the existing link groups or delete all the groups. 
The following link groups are available in the In_ctlog.db file: 
 SmartPlant P&ID Equipment — Contains four SmartPlant P&ID links for importing process 

equipment types into the EQUIPMENT_TYPE table and four links for importing process 
equipment into the EQUIPMENT table.  You must first run the links that are used for importing 
equipment types. 

 SmartPlant P&ID Process Data — Contains links you can use to import process data from 
SmartPlant P&ID into various tables that hold instrument or line process data, for example 
FLOW, PRESSURE, CONTROL_VALVE, LINE, and so forth.  When importing data using 
SmartPlant P&ID Process Data group links, the software associates process data with 
instruments or lines automatically by importing relevant data into the PD_GENERAL table. 
You must redefine the mapping in these links according to your needs and SmartPlant P&ID 
source.  Furthermore, for each link used to import SmartPlant P&ID instruments, you also 
need to define a filter to associate the SmartPlant P&ID with an appropriate process function 
in SmartPlant Instrumentation.  For example, you can filter the source instruments according 
to their measures variable defined in SmartPlant P&ID and associate this measured variable 
with a specific process function.  For details about defining a filter for the import source, see 
Specify a Filtering Condition. 

 SmartPlant P&ID Process Data - Macros — Contains various links used to import 
SmartPlant P&ID items according to the item type. 

 SmartPlant P&ID Process Data + Macros — Not in use. 

See Also 
Select SmartPlant P&ID Data for Import (on page 361) 
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Prerequisites for Importing SmartPlant P&ID Data 
This topic lists and describes all the prerequisites you must meet before using SmartPlant P&ID to 
import data into SmartPlant Instrumentation. In addition to SmartPlant P&ID-specific 
prerequisites, make sure you have completed the general prerequisites (for details, see General 
Import Prerequisites). 

 
 Before being able to import data, the predefined import links for SmartPlant P&ID must be 

available.  To make the links available, you need to import the appropriate system interfaces 
into SmartPlant Instrumentation from the Administration module (for details, see Import 
System Interfaces (on page 349)). 

 SmartPlant P&ID must be closed before starting the import session, to ensure that any 
modifications made to the drawings are properly imported to SmartPlant Instrumentation.  

Setup and Database Platform Prerequisites 
The following prerequisites address installation, software version, and database and connection 
issues: 
 Install SmartPlant P&ID on the same machine where you want to perform the import using the 

Import Utility. 
 Make sure that both SmartPlant P&ID and SmartPlant Instrumentation are of the same 

version. 
 Make sure you have access rights for the .ini file associated with the site having the source 

SmartPlant P&ID plant. 

 
 If you want to connect to a SmartPlant P&ID database in Oracle, you must have an Oracle 

client installed on the machine where you run the Import Utility.  You have to define the alias 
to the Oracle instance in which the source SmartPlant P&ID plant resides. 

 If you want to connect to a SmartPlant P&ID database in SQL Server, you do not need to 
install an SQL Server client to access the source SmartPlant P&ID site in SQL Server if 
SmartPlant Instrumentation is not installed in SQL Server. 

SmartPlant P&ID Prerequisite 
To be able to import P&ID drawing names, make sure you have at least one item of type 
'Instrument' in your drawing in the source SmartPlant P&ID plant. 

 SmartPlant P&ID must be closed before starting the import session, to ensure that 
any modifications made to the drawings are properly imported to SmartPlant Instrumentation. 
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Select SmartPlant P&ID Data for Import 
Use this procedure to connect to a SmartPlant P&ID database and import P&ID components such 
as instrument tags, lines, or equipment into the SmartPlant Instrumentation database. 

 Before using this procedure, make sure you meet all the prerequisites.  For details, 
see Prerequisites for Importing SmartPlant P&ID Data (on page 360). 
1. Do one of the following: 

 On the Link Explorer menu bar, click . 
 Click Options > SmartPlant P&ID. 

2. On the SmartPlant P&ID dialog box, click Open Plant and select the .ini file associated with 
the plant containing the source data. 

3. In the Tree pane, select a folder representing the desired hierarchy level. 
 To select multiple drawings, in the Tree pane, select a plant hierarchy item at the lowest 

level (for example, a unit), and then in the Contents pane, hold down the Ctrl key while 
selecting the desired drawings. 

4. Under Item types, select at least one check box, or select All item types. 
 If you select multiple drawings and more than one item type, the software may take some 

time to retrieve the source data. 
5. If desired, select the other options using the check boxes. 

 
 When selecting item types that have 1000 or more attributes, you must specify a limited 

number of attributes for importing.  To do this, click Attributes and on the Attributes 
dialog box, select the check boxes only beside the attributes you want to import.  Then, 
on the SmartPlant P&ID dialog box, select Use attribute list. 

 You must only select those attributes that are split in the import source into two separate 
attributes: one holding a field numeric and the other holding the appropriate unit of 
measure.  For details, see P&ID Attributes Split into Numeric and UOM Fields for Import 
(see "P&ID Attributes Split for Import into Numeric and UOM Fields" on page 362). 

 Since the mapping of the SmartPlant P&ID links you imported from the In_ctlog.db file 
must be modified to fit the target naming conventions in SmartPlant Instrumentation, clear 
the Run link group automatically check box. 

6. Click OK to close the SmartPlant P&ID dialog box. 

See Also 
Importing SmartPlant P&ID Component Data (on page 359) 
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P&ID Attributes Split for Import into Numeric and UOM Fields 
In SmartPlant Instrumentation, values with units of measure are always represented by two 
separate fields in the database: one field holding a numeric value and the other field holding a unit 
of measure.  Therefore, when mapping source and target fields for importing P&ID data, you must 
only map those source fields (P&ID attributes) that are split in the import source. 
The following table lists the Instrument item type attributes in the P&ID source that are adapted 
for instrument index import.  In the P&ID import source, each of these attributes has a numeric 
field with the suffix 1 indicating that the field value is numeric and suffix 2 indicating the field value 
is a unit of measure.  You can check whether the attribute is split when opening the P&ID link in 
the Import Link window. 

Instrument Item Type Attributes 
t_cc_max_electcurrent 
t_cc_max_levelreference 
t_cc_max_vacuumpressure 
t_cc_min_levelreference 
t_cc_min_liquidlevel 
t_cc_min_vacuumpressure  
t_ipr_corrosionallowance 
t_ipr_htracemediumtemp 
t_ipr_pralternatedesign_max_flowrate 
t_ipr_pralternatedesign_max_pressure 
t_ipr_pralternatedesign_max_specificgravity 
t_ipr_pralternatedesign_max_temperature 
t_ipr_pralternatedesign_max_vaporpressure 
t_ipr_pralternatedesign_min_vaporpressure 
t_ipr_pralternatedesign_min_viscosity 
t_ipr_pralternateoperating_max_flowrate 
t_ipr_pralternateoperating_max_pressure 
t_ipr_pralternateoperating_max_specificgravityty 
t_ipr_pralternateoperating_max_vaporpressure 
t_ipr_pralternateoperating_max_viscosity 
t_ipr_pralternateoperating_min_flowrate 
t_ipr_pralternateoperating_min_pressure 
t_ipr_pralternateoperating_min_specificgravity 
t_ipr_pralternateoperating_min_vaporpressure 
t_ipr_pralternateoperating_min_viscosity 
t_ipr_prdesign_max_specificgravity 
t_ipr_prdesign_max_vaporpressure 
t_ipr_prdesign_max_viscosity 
t_ipr_prdesign_min_flowrate 
t_ipr_prdesign_min_pressure 
t_ipr_prdesign_min_specificgravity 
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t_ipr_prdesign_min_vaporpressure 
t_ipr_prdesign_min_viscosity 
t_ipr_properating_max_flowrate 
t_ipr_properating_max_pressure 
t_ipr_properating_max_specificgravity 
t_ipr_properating_max_vaporpressure 
t_ipr_properating_max_viscosity 
t_ipr_properating_min_flowrate 
t_ipr_properating_min_pressure 
t_ipr_properating_min_specificgravity 
t_ipr_steamouttemperature 
t_ipr_sp_jinsultemp 
t_ipr_sp_jhtracemediumtemp 
t_ipr_scheduleorthickness 
t_ipr_prtest_min_viscosity 
t_ipr_prtest_min_vaporpressure 
t_ipr_properating_min_temperature 
t_ipr_properating_min_vaporpressure 
t_ipr_properating_min_viscosity 
t_ipr_prtest_max_flowrate 
t_ipr_prtest_max_pressure 
t_ipr_prtest_max_specificgravity 
t_ipr_prtest_max_temperature 
t_ipr_prtest_max_vaporpressure 
t_ipr_prtest_max_viscosity 
t_ipr_prtest_min_flowrate 
t_ipr_prtest_min_pressure 
t_ipr_prtest_min_specificgravity 
t_ipr_prtest_min_temperature  
t_piperun_praltdesign_min_flowrate 
t_piperun_praltdesign_min_flowrate 
t_piperun_praltdesign_min_specificgravity 
t_piperun_praltdesign_min_temperature 
t_piperun_praltdesign_min_vaporpressure 
t_piperun_praltdesign_min_viscosity 
t_piperun_praltoperating_min_flowrate 
t_piperun_praltoperating_min_pressure 
t_piperun_praltoperating_min_specificgravity  
t_piperun_praltoperating_min_temperature 
t_piperun_praltoperating_min_vaporpressure 
t_piperun_praltoperating_min_viscosity 
t_piperun_prd_min_flowrate 
t_piperun_prd_min_pressure 
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t_piperun_prd_min_specificgravity 
t_piperun_prd_min_temperature 
t_piperun_prd_min_vaporpressure 
t_piperun_prd_min_viscosity 
t_piperun_pro_base_compressibility 
t_piperun_pro_base_massdensity 
t_piperun_pro_base_molecularweight 
t_piperun_pro_base_pressure 
t_piperun_pro_base_specificgravity 
t_piperun_pro_base_temperature 
t_piperun_pro_max_compressibility 
t_piperun_pro_max_cpcvratio 
t_piperun_pro_max_criticalpressure 
t_piperun_pro_max_massdensity 
t_piperun_pro_max_massflowrate 
t_piperun_pro_max_molecularweight 
t_piperun_pro_max_pourpointtemp 
t_piperun_pro_min_compressibility 
t_piperun_pro_min_criticalpressure 
t_piperun_pro_min_flowrate 
t_piperun_pro_min_massdensity 
t_piperun_pro_min_massflowrate 
t_piperun_pro_min_molecularweight 
t_piperun_pro_min_pourpointtemp 
t_piperun_pro_min_pressure 
t_piperun_pro_min_specificgravity 
t_piperun_pro_min_temperature 
t_piperun_pro_min_vaporpressure 
t_piperun_pro_min_viscosity 
t_piperun_pro_norm_compressibility 
t_piperun_pro_norm_cpcvratio 
t_piperun_pro_norm_criticalpressure 
t_piperun_pro_norm_flowrate 
t_piperun_pro_norm_massdensity 
t_piperun_pro_norm_massflowrate 
t_piperun_pro_norm_molecularweight 
t_piperun_pro_norm_pourpointtemp 
t_piperun_pro_norm_pressure 
t_piperun_pro_norm_specificgravity 
t_piperun_pro_norm_temperature 
t_piperun_pro_norm_vaporpressure 
t_piperun_pro_norm_viscosity 
t_piperun_prt_min_flowrate 
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t_piperun_prt_min_pressure 
t_piperun_prt_min_specificgravity 
t_piperun_prt_min_temperature 
t_piperun_prt_min_vaporpressure 
t_piperun_prt_min_viscosity 
t_piperun_sp_jaltdesignmaxflowrate 
t_piperun_sp_jaltdesignmaxpress 
t_piperun_sp_jaltdesignmaxtemp 
t_piperun_sp_jaltdesignmaxviscosity 
t_piperun_sp_jaltdesignminflowrate 
t_piperun_sp_jaltdesignminpress 
t_piperun_sp_jaltdesignmintemp 
t_piperun_sp_jaltdesignminviscosity 
t_piperun_sp_jaltopermaxflowrate 
t_piperun_sp_jaltopermaxpress 
t_piperun_sp_jaltopermaxtemp 
t_piperun_sp_jaltopermaxvaporpress 
t_piperun_sp_jaltopermaxviscosity 
t_piperun_sp_jaltoperminflowrate 
t_piperun_sp_jaltoperminflowrate 
t_piperun_sp_jaltopermintemp 
t_piperun_sp_jaltoperminvaporpress 
t_piperun_sp_jaltoperminviscosity 
t_piperun_sp_jdesignmaxflowrate 
t_piperun_sp_jdesignmaxpress 
t_piperun_sp_jdesignmaxspecificgrav 
t_piperun_sp_jdesignmaxtemp 
t_piperun_sp_jdesignmaxvaporpress 
t_piperun_sp_jdesignmaxviscosity 
t_piperun_sp_jdesignminflowrate 
t_piperun_sp_jdesignminpress 
t_piperun_sp_jdesignminspecificgrav 
t_piperun_sp_jdesignmintemp 
t_piperun_sp_jdesignminvaporpress 
t_piperun_sp_jdesignminviscosity 
t_piperun_sp_joperbasecompress 
t_piperun_sp_joperbasemassdensity 
t_piperun_sp_joperbasepress 
t_piperun_sp_joperbasespecificgrav 
t_piperun_sp_joperbasetemp 
t_piperun_sp_jopermaxcompress 
t_piperun_sp_jopermaxcpcvratio 
t_piperun_sp_jopermaxcriticalpress 
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t_piperun_sp_jopermaxflowrate 
t_piperun_sp_jopermaxmassdensity 
t_piperun_sp_jopermaxmassflowrate 
t_piperun_sp_jopermaxpourpointtemp 
t_piperun_sp_jopermaxpress 
t_piperun_sp_jopermaxspecificgrav 
t_piperun_sp_jopermaxtemp 
t_piperun_sp_jopermaxvaporpress 
t_piperun_sp_jopermaxviscosity 
t_piperun_sp_jopermincompress 
t_piperun_sp_jopermincpcvratio 
t_piperun_sp_jopermincriticalpress 
t_piperun_sp_joperminflowrate 
t_piperun_sp_joperminmassdensity 
t_piperun_sp_joperminmassflowrate 
t_piperun_sp_joperminpourpointtemp 
t_piperun_sp_joperminpress 
t_piperun_sp_joperminspecificgrav 
t_piperun_sp_jopermintemp 
t_piperun_sp_joperminvaporpress 
t_piperun_sp_joperminviscosity 
t_piperun_sp_jopernormcompress 
t_piperun_sp_jopernormcpcvratio 
t_piperun_sp_jopernormcriticalpress 
t_piperun_sp_jopernormflowrate 
t_piperun_sp_jopernormmassdensity 
t_piperun_sp_jopernormmassflowrate 
t_piperun_sp_jopernormpourpointtemp 
t_piperun_sp_jopernormpress 
t_piperun_sp_jopernormspecificgrav 
t_piperun_sp_jopernormtemp 
t_piperun_sp_jopernormvaporpress 
t_piperun_sp_jopernormviscosity 
t_piperun_sp_jtestmaxflowrate 
t_piperun_sp_jtestmaxpress 
t_piperun_sp_jtestmaxspecificgrav 
t_piperun_sp_jtestmaxtemp 
t_piperun_sp_jtestmaxvaporpress 
t_piperun_sp_jtestmaxviscosity 
t_piperun_sp_jtestminflowrate 
t_piperun_sp_jtestminpress 
t_piperun_sp_jtestminspecificgrav 
t_piperun_sp_jtestmintemp 
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t_piperun_sp_jtestminvaporpress 
t_piperun_sp_jtestminviscosity  
t_ie_corrosionallowance 
t_ie_htracemediumtemp 
t_ie_insuldensity 
t_ie_insultemp 
t_ie_insulthick 
t_ie_pralternatedesign_max_flowrate 
t_ie_pralternatedesign_max_pressure 
t_ie_pralternatedesign_max_specificgravity 
t_ie_pralternatedesign_max_temperature 
t_ie_pralternatedesign_max_vaporpressure 
t_ie_pralternatedesign_max_viscosity 
t_ie_pralternatedesign_min_flowrate 
t_ie_pralternatedesign_min_pressure 
t_ie_pralternatedesign_min_specificgravity 
t_ie_pralternatedesign_min_temperature 
t_ie_pralternatedesign_min_vaporpressure 
t_ie_pralternatedesign_min_viscosity 
t_ie_pralternateoperating_max_flowrate 
t_ie_pralternateoperating_max_pressure 
t_ie_pralternateoperating_max_specificgravity 
t_ie_pralternateoperating_max_temperature 
t_ie_pralternateoperating_max_vaporpressure 
t_ie_pralternateoperating_max_viscosity 
t_ie_pralternateoperating_min_flowrate 
t_ie_pralternateoperating_min_pressure 
t_ie_pralternateoperating_min_specificgravity 
t_ie_pralternateoperating_min_temperature 
t_ie_pralternateoperating_min_vaporpressure 
t_ie_pralternateoperating_min_viscosity 
t_ie_prdesign_max_flowrate 
t_ie_prdesign_max_pressure 
t_ie_prdesign_max_specificgravity 
t_ie_prdesign_max_temperature 
t_ie_prdesign_max_vaporpressure 
t_ie_prdesign_max_viscosity 
t_ie_prdesign_min_pressure 
t_ie_prdesign_min_flowrate 
t_ie_prdesign_min_specificgravity 
t_ie_prdesign_min_temperature 
t_ie_prdesign_min_vaporpressure 
t_ie_properating_max_flowrate 
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t_ie_prdesign_min_viscosity 
t_ie_properating_max_specificgravity 
t_ie_properating_max_pressure 
t_ie_properating_max_temperature 
t_ie_properating_max_vaporpressure 
t_ie_properating_max_viscosity 
t_ie_properating_min_pressure 
t_ie_properating_min_flowrate 
t_ie_properating_min_specificgravity 
t_ie_properating_min_temperature 
t_ie_properating_min_vaporpressure 
t_ie_properating_min_viscosity 
t_ie_prtest_max_flowrate 
t_ie_prtest_max_pressure 
t_ie_prtest_max_specificgravity 
t_ie_prtest_max_temperature 
t_ie_prtest_max_vaporpressure 
t_ie_prtest_max_viscosity 
t_ie_prtest_min_flowrate 
t_ie_prtest_min_pressure 
t_ie_prtest_min_specificgravity 
t_ie_prtest_min_temperature 
t_ie_prtest_min_vaporpressure 
t_ie_prtest_min_viscosity 
t_ie_slope 
t_ie_sloperise 
t_ie_sloperun 
t_ie_steamoutpressure 
t_ie_steamouttemperature  
t_pralternatedesign_max_flowrate 
t_pralternatedesign_max_pressure 
t_pralternatedesign_max_specificgravity 
t_pralternatedesign_max_temperature 
t_pralternatedesign_max_vaporpressure 
t_pralternatedesign_max_viscosity 
t_pralternateoperating_max_flowrate 
t_pralternateoperating_max_pressure 
t_pralternateoperating_max_specificgravity 
t_pralternateoperating_max_temperature 
t_pralternateoperating_max_vaporpressure 
t_pralternateoperating_max_viscosity  
t_prdesign_max_flowrate 
t_prdesign_max_pressure 
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t_prdesign_max_specificgravity 
t_prdesign_max_temperature 
t_prdesign_max_vaporpressure 
t_prdesign_max_viscosity  
t_properating_max_flowrate 
t_properating_max_pressure 
t_properating_max_specificgravity 
t_properating_max_temperature 
t_properating_max_vaporpressure 
t_properating_max_viscosity  
t_prtest_max_flowrate 
t_prtest_max_pressure 
t_prtest_max_specificgravity 
t_prtest_max_temperature 
t_prtest_max_vaporpressure 
t_prtest_max_viscosity  
t_sr_praltdesign_max_flowrate 
t_sr_praltdesign_max_pressure 
t_sr_praltdesign_max_specificgravity 
t_sr_praltdesign_max_temperature 
t_sr_praltdesign_max_vaporpressure 
t_sr_praltdesign_max_viscosity 
t_sr_praltdesign_min_flowrate 
t_sr_praltdesign_min_pressure 
t_sr_praltdesign_min_specificgravity 
t_sr_praltdesign_min_temperature 
t_sr_praltdesign_min_vaporpressure 
t_sr_praltdesign_min_viscosity 
t_sr_praltoperating_max_flowrate 
t_sr_praltoperating_max_pressure 
t_sr_praltoperating_max_specificgravity 
t_sr_praltoperating_max_temperature 
t_sr_praltoperating_max_vaporpressure 
t_sr_praltoperating_max_viscosity 
t_sr_praltoperating_min_flowrate 
t_sr_praltoperating_min_pressure 
t_sr_praltoperating_min_specificgravity 
t_sr_praltoperating_min_temperature 
t_sr_praltoperating_min_vaporpressure 
t_sr_praltoperating_min_viscosity  
t_sr_prd_max_flowrate 
t_sr_prd_max_pressure 
t_sr_prd_max_specificgravity 
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t_sr_prd_max_temperature 
t_sr_prd_max_vaporpressure 
t_sr_prd_max_viscosity 
t_sr_prd_min_flowrate 
t_sr_prd_min_pressure 
t_sr_prd_min_specificgravity 
t_sr_prd_min_vaporpressure 
t_sr_prd_min_temperature 
t_sr_prd_min_viscosity 
t_sr_pro_max_flowrate 
t_sr_pro_max_pressure 
t_sr_pro_max_specificgravity 
t_sr_pro_max_temperature 
t_sr_pro_max_vaporpressure 
t_sr_pro_max_viscosity 
t_sr_pro_min_flowrate 
t_sr_pro_min_pressure 
t_sr_pro_min_specificgravity 
t_sr_pro_min_temperature 
t_sr_pro_min_vaporpressure 
t_sr_pro_min_viscosity 
 
 

PDS Interface 
The PDS (Plant Design System) interface allows you to import P&ID components (for example, 
drawings, tags, and so forth) into your database from a PDS database. 
You import the P&ID data first by connecting to the appropriate PDS database from which the 
Import Utility will import the drawing data.  There are two PDS databases / schemas from which 
you need to import data: 
 Project Control Database — this database contains the unit data and it has the same 

functions as the SmartPlant Instrumentation Administration data. 
 P&ID Source Database — this database contains the actual P&ID drawing data. 

After you connect to the PDS database you select the source unit and source P&ID.  With the 
source data selected, you can perform the import setup process and import the selected P&ID 
data. 

See Also 
Importing PDS Data (on page 372) 
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Prerequisites for Importing PDS Data 
This topic lists and describes all the prerequisites you must meet before importing PDS data into 
SmartPlant Instrumentation.  In addition to PDS-specific prerequisites, make sure you have 
completed the general prerequisites (for details, see General Import Prerequisites). 

 Before being able to import data, the predefined import links for PDS must be 
available.  To make the links available, you need to import the appropriate system interfaces into 
SmartPlant Instrumentation from the Administration module (for details, see Import System 
Interfaces (on page 349)). 

 
 PDS and SmartPlant Instrumentation cannot work from the same SQL Server database 

server.  This is because the sort order is different for the two applications, and databases with 
different sort orders cannot be located on the same server. 

 The source text file profile is defined in the ODBC.ini registry folder. 

See Also 
Importing PDS Data (on page 372) 
 

PDS Code Translation 
The PDS interface supports a user-defined PDS code list.  The PDS database stores information 
as codes that are not recognized by SmartPlant Instrumentation.  When exporting data, the PDS 
application generates a set of files that are used to translate the PDS codes into data that 
SmartPlant Instrumentation can recognize.  By selecting the appropriate option during the import 
setup process, the Import utility automatically replaces reference codes with the user-defined data 
stored in PDS code list files. 
 

Code Translation Example 
A file named Attributes (or Attributes.txt) contains a list of the source tables where the PDS data is 
located, some examples of which are shown below. 

Table 
No. 

Name Data 
Type 

Default 
Value 

Units of 
Measure 

App 
Type(s)  

Description 

0 system_unique_
no 

I4 0 0 1 'Occurrence no'

1 propagation_no I2 0 0 1/1 'Propagation 
no' 

2 company_name A40 0 0 1 'Company 
name' 

3 plant_name A40 0 0 1 'Plant name' 

. . . . . . . 

. . . . . . . 

. . . . . . . 

109 instr_comp_type C510 1 0 2 'Instr comp 
type' 
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Each database table includes a data type code that refers to a file containing a list of fields that 
belong to the table together with their codes.  For example, the data type for table 109, 
instr_comp_type is C510.  This refers to the file LIST.0510, part of which is as follows: 
 MAX=999 
 ; 0510, Instrument Component Type (999) 
   1  ' ' 
 ; 
      16  'Instrument to Process line' 
      17  'Capillary tube' 
      18  'Mechanical link' 
      19  'Electric signal' 
      20  'Electric binary signal' 
  ; 
      72  'Control valve' 
      78  'Solenoid valve' 
This means that the PDS field with code no. 72 will be displayed in SmartPlant Instrumentation 
with the source name Control Valve. 
 

Importing PDS Data 
The PDS interface enables you to import drawing data.  After the Domain Administrator imports 
four PDS link groups from the in_ctlog.db file using the Administration module options, the 
groups appear in the Link Explorer in the Import Utility.  These links have predefined mapping 
which you may need to modify as you require.  You cannot change the import method or 
table/module assignment of these links.  It is possible to restore deleted PDS links by re-importing 
the link group from the in_ctlog.db file.  Note, however, that to restore deleted links, you must first 
rename the PDS links or group or delete the entire group. 
Also, when retrieving the PDS link group from the in_ctlog.db file, the software also retrieves the 
system codes and unit of measure codes.  These codes are already adapted to SmartPlant 
Instrumentation, that is, every source code value in PDS is associated with its appropriate target 
value in SmartPlant Instrumentation. 
It is possible to run all the PDS group links automatically in order of their appearance.  Advanced 
users can perform a manual import process which allows you to carry out a step- by-step 
procedure.  Importing data this way enables you to view and modify the default import parameters 
and link settings. 
The following links are available in the link PDS link groups retrieved from the in_ctlog.db file: 
 PDS SUPPORT — Allows you to import supporting table data into various tables such as 

COMPONENT FUNCTION TYPE PDS, LOOP PROC PDS, and EQUIPMENT TYPE. 
 PDS — Allows you to import PDS data into various tables such as EQUIPMENT PDS, LOOP 

PDS, and COMPONENT PDS. 
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Select PDS Data for Import 
Use this procedure to connect to a PDS database and select the desired data for import. 

 
 Before using this procedure, make sure you meet all the prerequisites.  For details, see 

Prerequisites for Importing PDS Data (on page 371). 
 When importing PDS data, you must always use the PDS interface to connect to the source 

data files before you can run the links from the Link Explorer.  You cannot create and run 
links outside of the interface. 

1. Do one of the following: 

 On the Link Explorer menu bar, click . 
 Click Options > PDS. 

2. On the PDS dialog box, from the DBMS list, select a database platform. 
3. In the Name box, do one of the following: 

 If you chose one of the Oracle database platforms, type a connection string. 
 If you chose an ODBC platform, select the profile name from the list. 

4. In the Project control database section, do the following: 
a. In the Name box, type the appropriate PDS Control Database Project name where the 

source unit and drawing number data is located (for example pds_control_db). 
b. In the Password box, type the password required to connect to the PDS Control 

Database Project. 
5. In the P&ID source database section, do the following: 

a. In the Name box, type the appropriate PDS P&ID source database name where the 
source loop, tag number, and wiring data is located (for example pds_source_db). 

b. In the Password box, type the password required to connect to the PDS P&ID source 
database. 

6. Use the PDS codes section for importing fields that are defined in PDS by code numbers 
only.  The PDS application generates the export files which are used to translate the PDS 
codes into data that can be recognized by SmartPlant Instrumentation. 

 
 The PDS export files must be located in two sub-folders: the first sub-folder, named Data, 

contains a file called Attributes (with or without a .txt extension) and the second 
sub-folder, named Codes, contains a set of list files with the field names referenced by the 
Attributes file.  (For an explanation of the contents of these files, see Code Translation 
Example (on page 371).) 

 Both of the sub-folders must be in the same parent folder. 
7. Under PDS codes, click Browse to navigate to the full path of the PDS code description file, 

for example: 
C:\SmartPlant\Instrumentation\Import\Code\Attributes.txt 

8. Select the Use code description check box to replace the PDS codes with their descriptions, 
after selecting the appropriate PDS code description file in the previous step. 

 
 If you choose to use the code description option and an equivalent for the code in 

SmartPlant Instrumentation is not found, the field code will be imported from the PDS 
database. 
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 If you know that SmartPlant Instrumentation will recognize all the source field names, 
clear the Use code description check box, so that the software will not check the 
Attribute and Codes files, thus speeding up the import process. 

9. Click Connect to connect to the database specified in the PDS dialog box. 
 If the connection fails, an appropriate message is displayed, in which case you need to 

correct the database logon information. 
10. On the Drawing Selection dialog box, select the desired drawings that contain PDS data to 

be imported as follows: 
a. From the Unit list, select the desired source PDS Unit.  This displays the P&ID drawings 

in this PDS unit in the Drawings pane. 
b. Do one of the following: 

 Select the Select all check box to select all the P&ID drawings so that all data in the 
PDS unit will be imported. 

 Select any P&ID drawings that you want to include in the import process.  Use Ctrl or 
Shift to make multiple selections. 

 SmartPlant Instrumentation will only import the data in the selected drawings. 
11. If desired, you can translate (expand) P&ID tags to instrument tags as follows: 

a. Click Macro to define associations between PDS macros and SmartPlant Instrumentation 
typical tags. 

b. Select Additional tags based on macros to use the macro association definitions to 
create new tags in SmartPlant Instrumentation based on the imported data.  On selecting 
this option, you can also select the Insert original PDS tag check box to include in the 
import the P&ID tags that were expanded (for details, see PDS Macro Expansion (on 
page 375)). 

c. Select Use measured variable to use the measured variable in the PDS database (in the 
instr_comp table) to modify the typical tag name when creating the instrument type in 
SmartPlant Instrumentation.  Clear the check box to use the typical tag name as is. 
 An instrument type will be created for the tag only if it has a unique description in the 

SmartPlant Instrumentation database. 
12. Do one of the following: 

 Clear Run link group automatically if you need to modify any of the links before 
importing the data. 

 Select Run link group automatically to select a particular link group and run all the links 
in it automatically. 

13. Click OK to continue the import process. 

 
 If you selected to run the link groups automatically, the Select Link Group dialog box opens 

for you to select the desired group of PDS links to import. 
 If you selected not to run the link groups automatically, the Drawing Selection dialog box is 

minimized and you can: 
 Open a link to modify it. 
 Run a single import link or a group of links. 

 You can select to execute a previously saved link group or link.  In these cases the Import 
Utility automatically selects all the required drawing data of the source PDS Unit. 

See Also 
Importing SmartPlant P&ID Component Data (on page 359) 
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PDS Macro Expansion 
Since P&ID information is sometimes more generalized than the information found in 
instrumentation drawings, it is possible to represent a single P&ID tag in an instrumentation 
drawing by several SmartPlant Instrumentation instrument tags.  If a P&ID tag has a macro, you 
can map it in SmartPlant Instrumentation to one or more typical instruments.  In this way, 
SmartPlant Instrumentation can use the macro to expand a single P&ID tag to several instrument 
tags when importing P&ID data from PDS. 
For example, suppose you have a P&ID drawing with a tag number V-999.  This tag actually 
consists of a positioner and an I/P transducer.  If the Additional tags based on macros check 
box is selected, the original tag will be translated (expanded) and two new tags, one representing 
the positioner and the other representing the I/P transducer, will be imported into SmartPlant 
Instrumentation.  If the Insert original PDS tag check box is selected, the original V-999 tag will 
also be imported into the SmartPlant Instrumentation database; if the check box is cleared, the 
V-999 tag will not be imported. 

 
 You can include custom fields in your typical tag definitions.  The information you include in 

these fields will then be copied to the tags that are created from the typical tags when 
expanding the P&ID tag data.  You can view the custom fields by defining a new style in an 
Instrument Index Standard Browser view that includes these fields.  For details of how to 
create typical loops and typical tags, see Working with Typical Loops and Tags. 

 Macro expansion will be performed only for the P&ID tags that are associated with the 
drawings you selected on the Drawing Selection dialog box and for which macros exist. 

 

Define PDS Macro Settings 
1. On the Drawing Selection dialog box, click Macro. 
2. On the Edit PDS\SP-P&ID Macro dialog box, click Insert to add a new line, and in the Macro 

name column, type the desired macro name. 

 
 Macro names can be found in the PDS P&ID schema in the name_txt column of the 

instr_comp table. 
 When defining a macro associated with more than one instrument type, remember to use 

the same macro name for each line as appropriate. 
3. Click Assign and use the Find Tag dialog box to select the desired typical instrument to 

assign to the macro. 
4. Repeat steps 2 and 3 for each typical instrument you want to assign to a macro. 
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Run PDS Import Links 
1. Select the desired data for import with the PDS interface.  For details, see Select PDS Data 

for Import (on page 373). 
2. In the Link Explorer, expand the group 1.PDS SUPPORT and select the link COMPONENT 

FUNCTION TYPE PDS. 

3. Click  to open the Parameter Settings dialog box for the link. 
4. Click the Source tab. 
5. Under Assign process function, click Define. 
6. If this is the first time you are running the link, on the Define Instrument Type Fields dialog 

box, do the following: 
a. From Source, drag the field instr_funct_id to Instrument type name. 
b. From Source, drag the field instr_comp_type to Instrument type description. 
c. Click OK. 

7. On the Process Function Mapping dialog box, for each instrument type in the left section, 
drag the appropriate process function from the right section to the Process function column. 

 
 After the first time you run the link, some of the instrument types will already have process 

functions defined by default - these are displayed with a gray background, and you cannot 
reassign the process functions.  Unassigned fields are shown with a light blue 
background, and assigned fields with a white background. 

 Whenever you run either of the import links: COMPONENT FUNCTION TYPE PDS or 
COMPONENT PDS (INSTRUMENT TYPE), you should check that the mapping is correct 
and update it if required (if running both links, you need only check the mapping once). 

8. When done, click OK to return to the Parameter Settings dialog box. 
9. Click OK to close the Parameter Settings dialog box. 

10. Click  to open the Import Link window for the selected link with the sources you selected 
(instr_comp_type and instr_funct_id) already assigned to database targets. 

11. If desired, you can display the source codes for this link (PDS instrument type code and 
instrument type functional ID) as follows: 

a. Click . 
b. Click File > Exit to return to the Import Link window. 

12. Click  to import the data. 
13. For each of the links in this group, and for all the links in the group 2.PDS, repeat the above 

steps of this procedure (if prompted to overwrite existing data, click Yes). 

 
 For certain links in the group 2.PDS, you are required to enter the source fields for 

defining naming conventions before running the link. 
 Some links import fields from more than one table.  In such cases, the field name 

(excluding the table prefix) appears in the Source Name column.  If you attempt to run 
the import process, an error message is displayed (Condition is not valid).  To correct 
this, delete the field name indicated in the message from the Source Name column, and 
drag the appropriate field name (which includes the table prefix) to the Source Name 
column. 
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14. Open SmartPlant Instrumentation and examine the imported data in the Browser or 
Instrument Index module. 

 

DCS Vendor Interfaces 
The DCS Vendor interfaces allow you to share data between SmartPlant Instrumentation and the 
appropriate DCS vendor software at the component/card level.  If, for example, you design a loop 
that needs to be controlled by a particular DCS system, you need to connect the loop wiring to I/O 
cards in the DCS for the vendor that you specify.  SmartPlant Instrumentation supports the 
following DCS vendors: 

DCS Product Name Vendor Available Activities 

DeltaV Emerson Bidirectional publish and 
retrieve 

Yokogawa - CENTUM 
CS 3000 

Yokogawa Bidirectional publish and 
retrieve 

ABB ABB Retrieve I/O card catalog 
definitions only 

Honeywell Honeywell Retrieve I/O card catalog 
definitions only 

 
 All DCS vendors support both conventional and Foundation Fieldbus instruments.  In 

addition, DeltaV supports HART, CHARM, and S-Series instruments. 
 You are allowed to specify only one DCS vendor per domain. 
 A number of shipped rules apply to SmartPlant Instrumentation items when used for specific 

DCS vendors.  You can view these rules in the Rule Manager under Interfaces. 
 

SmartPlant Instrumentation - DCS Vendors: Comparative 
Terminology 

Although the SmartPlant Instrumentation - DCS vendor interfaces effect automated transfer of 
definitions and data, it is important to understand some of the differences in terminology between 
SmartPlant Instrumentation and different DCS vendors.  The following is a partial list: 

SmartPlant 
Instrumentation 
Dialog Box 

SmartPlant 
Instrumentation 
Terminology 

DeltaV 
Terminology 

CENTUM CS 3000 
Terminology 

Distributed Control 
System (DCS) 
Properties;  
Racks 

Rack Carrier Node 

Racks Slot Position  
 Card  Module 

I/O Card Properties;  
Strip Type 

Strip Type I/O Card Type  
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SmartPlant 
Instrumentation 
Dialog Box 

SmartPlant 
Instrumentation 
Terminology 

DeltaV 
Terminology 

CENTUM CS 3000 
Terminology 

Channels;  
Channel Types 

Channel Type I/O Channel Type  

Channels; 
Terminal Properties 

Channel (conventional) Channel Terminal 
 

 Channel (fieldbus) Port  
 I/O Termination  Termination Board 

Fieldbus Instrument 
Tag Association 

Instrument Type + 
Description 

Device Type  

 
 

Prerequisites for Working with DCS Vendor Interfaces 
The DCS vendor interfaces function for any Oracle or SQL Server database that is approved for 
SmartPlant Instrumentation Version 2009.  For details, see SmartPlant Instrumentation 
Installation Guide, Installing SmartPlant Instrumentation on Oracle and Installing SmartPlant 
Instrumentation on SQL Server. 
Make sure that you have Internet access to the URL from which you download the particular DCS 
vendor definitions document. 
Before you can work with any DCS vendor interface, you must perform the following actions: 
1. Install the SmartPlant Schema Component from the SmartPlant Instrumentation CD Browser 

(click Add-In Software, and then click Schema Component Installation). 
 On the Select Optional Features page, clear the Schema Editor check box if you do 

not need to use the Schema Editor. 
2. Install the SmartPlant Client from the SmartPlant Instrumentation CD Browser (click Add- In 

Software, and then click SmartPlant Client Installation). 
 On the Select Features page, make sure that you clear the SmartPlant Automatic 

Retrieval check box. 
3. Configure SmartPlant Instrumentation to work in file mode.  For details, see Configure 

SmartPlant Instrumentation to Publish and Retrieve Data in File Mode (on page 379). 
4. The System Administrator must enable the item registry.  For details, see Enable Item 

Registry in the Administration User's Guide, under System Administration, Domain 
Management. 

5. The System Administrator must specify the XML path to the folder in which the 
IntoolsMap.xml and ContextMap.xml files are located; this must be done for each domain 
where you intend to publish DCS vendor data.  By default, these files are located in the path: 
<SmartPlant Instrumentation home folder>\XML\. 

6. The Domain Administrator must register the items.  For details, see Register Items in the 
Administration User's Guide, under Working in an Integrated Environment. 
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7. The Domain Administrator must ensure that he SmartPlant Instrumentation and DeltaV 
naming conventions are identical and that function blocks are defined using free segment 
naming conventions as shown. 

 
8. Create new instrument type definitions in SmartPlant Instrumentation as needed to match 

those in DeltaV. 
9. Optimize your SmartPlant Instrumentation preferences for the interface with your selected 

DCS vendor.  For details, see Interfaces > DCS Vendors (Preferences) (on page 25). 

See Also 
Flow of Activities for Configuring DeltaV (on page 380) 
Flow of Activities for Configuring Yokogawa CENTUM CS 3000 (on page 391) 
 

Configure SmartPlant Instrumentation to Publish and 
Retrieve Data in File Mode 

1. Close any programs that are currently running. 
2. On the Windows desktop, right-click the My Computer icon, and on the shortcut menu, click 

Properties. 
3. Click the Advanced tab. 
4. Click Environment Variables. 
5. Under System variables, click New. 
6. On the New System Variable dialog box, in the Variable name field, type 

EFCommonufilemode and in the Variable value field, type 1. 
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Flow of Activities for Configuring DeltaV 
This topic describes the primary flow of activities when you use SmartPlant Instrumentation to 
design a plant to be run and controlled using the Emerson DeltaV plant automation and control 
system. 

 
 Before publishing or retrieving DeltaV data for the first time, make sure that you perform the 

prerequisite activities indicated: retrieving DeltaV definitions, updating your plant design, and if 
appropriate, associating Foundation Fieldbus device types. 

 You may perform any of the stages of this flow of activities multiple times during the project life 
cycle. 

Retrieve DeltaV Definitions 
Retrieving DeltaV definitions is a prerequisite for both publishing and retrieving DeltaV data.  The 
DeltaV item definition documents that you download and retrieve in SmartPlant Instrumentation 
constitute the engineering library of DeltaV objects - the DeltaV DCS (Distributed Control System), 
Foundation Fieldbus, CHARM, S-Series, Conventional, and HART elements, and entries for 
supporting tables such as Manufacturer, Model, and so forth.  For more information, see 
Retrieve DeltaV Definitions (on page 385). 

Update Your Plant Design 
Prior to publishing or retrieving data, you must update your plant design using the 
DeltaV-compatible objects now available in the Reference Explorer and supporting tables of your 
SmartPlant Instrumentation database.  From the perspective of SmartPlant Instrumentation, the 
DeltaV DCS (Distributed Control System) panel is a DCS in the Reference Explorer from which 
you create a specific DeltaV DCS in the Domain Explorer.  You can then create appropriate 
sub-items and perform wiring connections as desired. 

 In the Reference Explorer, do not change any of the values in the items that you 
retrieved from the DCS vendor. 

Publish Data for DeltaV 
After you complete the process of designing your DeltaV- compatible plant in SmartPlant 
Instrumentation, use this procedure to publish (export) the required data for accurate and efficient 
DeltaV configuration.  The software publishes a partial set of the SmartPlant Instrumentation 
database, including data such as the DeltaV configuration, I/O assignment, instrument tags, and 
so forth (the process does not export specification data, for example).  For details of the 
procedure to publish data, see Publish Data for DeltaV (on page 390). 
After retrieving the published data in DeltaV, validate and, if necessary, reconcile the data with the 
DeltaV database. 

Retrieve DeltaV Data 
Use this procedure to retrieve (import) data from DeltaV.  The software retrieves controllers and 
slots and, if specified in the published .xml file, Foundation Fieldbus devices.  For details of the 
procedure to retrieve data, see Retrieve DeltaV Data (on page 386). 

 If using fieldbus tags, after retrieving the DeltaV data, but before running any To Do 
List tasks, you must make associations between device types for Foundation Fieldbus or HART 
instruments with instrument manufacturers, and SmartPlant Instrumentation instrument 
types.  For more information, see Associate Device Types for DCS Vendors (on page 396). 
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Data Limitations for the DeltaV Interface 
When you prepare a SmartPlant Instrumentation domain for publishing to DeltaV, you must be 
careful to enter values with limitations according to the table that follows.  In most cases, the 
software validates the data; however, it does not validate data that you merge in the database or 
data that you enter via a browser view; in these cases, it is up to you to check that the values 
comply with these limitations. 

 
 SmartPlant Instrumentation validates the data only if the DCS manufacturer name is Emerson 

Process. 
 If you intend to publish fieldbus data, set the relevant option on the Preferences dialog 

box.  For details, see Interfaces > DCS Vendors (Preferences) (on page 25). 
 Spaces are not allowed in DeltaV tags, therefore, when publishing data, SmartPlant 

Instrumentation removes spaces in instrument and Control System tags.  You can specify a 
substitute character, such as an underscore, to replace the spaces; to do so, you must add the 
following line in the Intools.ini file under the [API] section: 
NameSpacesReplacement = "_" 
It is recommended not to select any character that appears in the tag names as the substitute 
character because when retrieving data back from DeltaV, SmartPlant Instrumentation 
replaces that character with spaces again. 

Item Type Limitation 

I/O Card The DCS manufacturer name is Emerson Process 
and this must not be modified. 

I/O Card The card name must begin with an uppercase 'C' 
followed by a numeric value, for example C16. 

Rack The rack name must be a numeric value. 

Slot The slot name must be a numeric value between 1 
and 8 characters. 

Controller The controller name must be unique in the domain. 

Controller The controller name must be uppercase and 
between 1 and 16 characters. 

Units of Measure Limitations 
To avoid errors when publishing data, only those units of measure that are supported by DeltaV 
should be available for selection.  To set the available units of measure, click Tools > Units of 
Measure Codes, and clear the Enabled check boxes for all units of measure except for those 
that appear in the following table. 

Unit of Measure Code Unit of Measure Name Unit of Measure Type 

% Percent PT 

%V Percent of volume PT 

%W Percent of weight PT 

µF µF FA 

µH µH HE 
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Unit of Measure Code Unit of Measure Name Unit of Measure Type 

µm micrometer LN 

1/ºC 1/Degree C LE 

1/ºF 1/Degree F LE 

A A CU 

Btu IT/ft³ Btu IT/ft³ CV 

Btu IT/h Btu IT/h WT 

Btu IT/s Btu IT/s WT 

Btu_IT/(ft^2-h-degf)   

Btu_IT/lbm   

Btu_IT-in/(h-ft^2-degF)   

BtuIT/lbºF Btu(IT)/(lbºF) SH 

Btuth/lbºF Btu(th)/(lbºF) SH 

cal IT/m³ cal IT/m³ CV 

Cal_IT/g   

Cal_th/g   

cm² centimeter² AR 

cm²/s cm²/s VS 

cS centistokes VS 

D Days  

ft² foot² AR 

ft²/s ft²/sec. VS 

ft³ ft³ VM 

g gram ML 

G in/s² AC 

h hours TT 

HP Horse Power WT 

Hz Hz FQ 

in² inch² AR 

in²/s in²/sec. VS 

in³ in³ VM 

J/(kg·K) J/(kg·K) SH 

J/kg J/kg LH 
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Unit of Measure Code Unit of Measure Name Unit of Measure Type 

kg kilogram ML 

kg/m kg/m WL 

kgf kilogram-force FR 

kHz kilo Hertz FQ 

KJ/m³ Kilo Joule per cubic meter CV 

kj/(kg·K) kj/(kg·K) SH 

kJ/(kg·ºC) kJ/(kg·ºC) SH 

**kJ/kg kJ/kg LH 

km kilometer LN 

km² kilometer² AR 

Kohm Kohm OM 

kV kilo Volt VO 

kVA kiloVolt-ampere  

kVAr kiloVolt-ampere reactive WR 

kW kilo Watt WT 

L L VM 

lb pound ML 

Lbf lb-force FR 

Lbm/ft   

Lm lumen LI 

m² Square Meter AR 

m²/s m²/sec. VS 

m³ Cubic Meter VM 

mA mA CU 

Mg milligram ML 

mg/m³ milligram/cubic meter DN 

mH mH HE 

MHz Mega Hertz FQ 

Mi^2_int   

Micron micron LN 

Mile mile LN 

mile² mile² AR 
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Unit of Measure Code Unit of Measure Name Unit of Measure Type 

MILS 1/1000 inch LN 

Min minutes TT 

mm/s millimeter/sec. VL 

mm/s² mm/s² AC 

mm² millimeter² AR 

mm²/s mm²/s VS 

Mohm Mega Ohm OM 

mPa-s   

mV mV VO 

mW mW WT 

MW Mega Watt WT 

N newton FR 

nF nF FA 

º degree AN 

Ohm ohm OM 

Ohm/m Ohm/m RF 

oz ounce ML 

PPMV a millionth volume PT 

PPMW a millionth weight PT 

Rad radian AN 

Rpm revolutions per min FQ 

S seconds TT 

St stokes VS 

T metric ton ML 

US gal US gallon VM 

V V VO 

W W WT 

yd² yard² AR 

See Also 
Flow of Activities for Configuring Yokogawa CENTUM CS 3000 (on page 391) 
Publish Data for Yokogawa CENTUM CS 3000 (on page 394) 
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Retrieve DeltaV Definitions 
 

 Before you start this procedure, make sure that you have an Internet connection and a valid 
Intergraph customer user name and password. 

 SmartPlant Instrumentation is only capable of handling certain I/O types that DeltaV 
supports.  For this reason, not all of the I/O cards that you download in the DeltaV definitions 
are compatible with SmartPlant Instrumentation: for example, the interface does not handle SI 
and Serial cards. 

1. In SmartPlant Instrumentation, click Tools > Interfaces > DeltaV. 
2. Under Data transfer mode, select Retrieve DeltaV definitions and click OK. 
3. To download the DeltaV definitions files, do the following: 

a. On the Retrieve DeltaV Definitions dialog box, beside Default DeltaV definitions URL, 
click Download. 

b. On the Web page that opens, complete the form and click Submit. 
c. Follow the instructions for downloading the files. 
d. On the File Download dialog box, click Save. 
e. On the Save As dialog box, navigate to the desired folder and click Save. 
f. On the Download Complete dialog box, click Close. 

4. On the Retrieve DeltaV Definitions dialog box, click Browse and navigate to the folder 
where you downloaded the DeltaV definitions files. 

5. Under the Select column, select the documents that you want to retrieve in SmartPlant 
Instrumentation and click OK. 

 If retrieving the HART definition file in order to publish and retrieve HART 
instruments, you must first retrieve the fieldbus definition file. 

6. When done, click Cancel. 
 

 The DeltaV definitions are added to the DCS Panels folder of the Reference Explorer. The 3 
types of panel are: 

 DeltaV CHARM 
 DeltaV Conventional 
 DeltaV S-Series 

 Once you have retrieved Foundation Fieldbus or HART definitions, you can use them to make 
appropriate associations among Foundation Fieldbus device types, instrument 
manufacturers, and SmartPlant Instrumentation instrument types.  For details, see Associate 
Device Types for DCS Vendors (on page 396). 

 When retrieving DeltaV definitions, the software automatically adds new definitions and 
updates any modifications to definitions that already exist in the SmartPlant Instrumentation 
database.  However, you must delete any redundant definitions manually from the Reference 
Explorer. 

See Also 
View the Log File for a DCS Vendor (on page 397) 
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Retrieve DeltaV Data 
 Before retrieving data, you must configure SmartPlant Instrumentation to work in file 

mode.  For details, see Configure SmartPlant Instrumentation to Publish and Retrieve Data in File 
Mode (on page 379). 
1. In SmartPlant Instrumentation, click Tools > Interfaces > DeltaV. 
2. Under Data transfer mode, select Retrieve DeltaV data and click OK. 
3. In the Select Data XML File window, navigate to the .xml file that contains the DeltaV data 

and click Open. 
 After selecting the file, two more windows open: Select Meta-data XML File and Select 

Tombstones XML File.  Just click Cancel in both of these windows. 
4. On successful completion of the retrieval, click Close on the message box that appears, or if 

errors occurred, click View Log to troubleshoot them. 
5. Click SmartPlant > To Do List. 

 If using fieldbus tags, after retrieving the DeltaV data, but before running any 
tasks from the To Do List, you must make associations between Foundation Fieldbus device 
types, instrument manufacturers, and SmartPlant Instrumentation instrument types.  For 
more information, see Associate Device Types for DCS Vendors (on page 396). 

6. In the To Do List window, select all the Create tasks for the DeltaV items; however, do not 
select the Update task for the CS Tag. 

7. From the To Do List toolbar, click Run Task . 

 
 Performing this action creates the DeltaV controllers, slots, I/O cards, and so forth in the 

Domain Explorer under the Controllers folder. 
 For more details of available options when running tasks, see Run Tasks from the To Do 

List (on page 504). 
8. In the Domain Explorer, create a DCS and rack as needed, and then drag a DeltaV slot to the 

rack. 
9. In the To Do List window, run the Update task for the CS Tag. 

See Also 
View the Log File for a DCS Vendor (on page 397) 
 

Crucial Fields for the DeltaV Interface 
When you prepare a SmartPlant Instrumentation domain for publishing to DeltaV, you must be 
careful to enter values according to the table that follows. 

 
 If you diverge from the following table and its notes, the software does not validate the data; 

however, the DeltaV reconciliation program will reject data values that are incompatible.  For 
complete details of the exact DeltaV values to use, please refer to your DeltaV Hardware 
Manual. 

 If you intend to publish fieldbus data, set the relevant option on the Preferences dialog 
box.  For details, see Interfaces > DCS Vendors (Preferences) (on page 25). 

The entries in the Value column indicate you must act as follows: 
 A - Accept DeltaV Value — Do NOT change the value of this field. 
 E - Enter Valid Value — Accept the value retrieved from DeltaV, if one exists, or enter a 

different valid value. 
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 O - Optional Value — Accept the value retrieved from DeltaV, if one exists, or enter a different 
valid value, or enter no value. 

 Any other entry - the value must be as stated. 

Dialog Box Field Value Notes 

DCS Properties Type O   

DCS Properties Manufacture
r 

O   

Rack Properties Number of 
Slots 

E • In the Racks dialog box, under 
Rack position numbering, accept the 
default selection of Start from one.  

• In the data window, for each rack that 
you create, type the value 8 under 
Number of slots. 

Rack Properties Rack 
position 
numbering 

E • In the Racks dialog box, under Rack 
position numbering, accept the 
default selection of Start from one.  

• In the data window, for each rack that 
you create, type the value 8 under 
Number of slots. 

Slot Properties Controller E A controller name must be uppercase, and 
no more than 16 characters.  You must 
assign each controller to slots that share 
the associated I/O card. 

Controllers Controller E A controller name must be uppercase, and 
no more than 16 characters.  You must 
assign each controller to slots that share 
the associated I/O card. 

Controllers Redundant E   

Controllers Manufacture
r 

Emerson 
Process 

  

I/O Card 
Properties, 
General tab 

Series A   

I/O Card 
Properties, 
General tab 

Type A   

I/O Card 
Properties, 
General tab 

Manufacture
r 

A   

I/O Card 
Properties, 
Control System 
tab 

I/O type A   
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I/O Card 
Properties, 
Control System 
tab 

Rack/Carrie
r 

E   

I/O Card 
Properties, 
Control System 
tab 

Define a 
redundant 
I/O 

A If you are defining a DeltaV redundant I/O 
card for a DCS panel, make sure that  
• In the Primary location group box the 

value of Position is an odd number. 
• The value of Position for 

the Secondary location is an even 
number greater than the Position 
value for the Primary location. 

Terminal 
Properties 

Terminal E   

Terminal 
Properties 

Sequence A   

Terminal 
Properties 

Terminal 
color 

E   

Terminal 
Properties 

Channel A   

Channels Channel A   

Channels Enable E   

Channels Channel 
type 

E DeltaV redundant I/O cards are wide and 
therefore occupy two adjacent slots in their 
carriers.  The cards can only be placed in 
odd-numbered slots. 

DeltaV I/O cards have their terminations on 
the I/O cards themselves, so there is no 
need for separate termination cards to be 
connected to the I/O cards. 

On the Control System tab of the I/O 
Termination dialog box, you must select 
the Define a redundant I/O card check 
box.  On publishing the data, this indicates 
to DeltaV that the card is defined as a 
redundant double-width I/O card. 
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Channel Types Channel 
type 

A DeltaV redundant I/O cards are wide and 
therefore they occupy two adjacent slots in 
their carriers.  Note that the cards can only 
be placed in odd-numbered slots. 

DeltaV I/O cards have their terminations on 
the I/O cards themselves, and so there is 
no need for separate termination cards to 
be connected to the I/O cards. 

On the Control System tab of the I/O 
Termination dialog box, you must select 
the Define a redundant I/O card check 
box.  On publishing the data, this indicates 
to DeltaV that the card is defined as a 
redundant double-width I/O card. 

Tag Number 
Properties, 
General tab 

Manufacture
r 

E You can use only the following DeltaV 
cards as redundant I/O cards: 
• AI_8CH_HART_4-20_RED 
• AO_8CH_HART_4- 20_RED 
• RFIC 
• DI_8CH_24VDC_DCT_RED 
• DO_8CH_24VDC_HSS_RED 
• RED_PROG_SERIAL_32DS 
• RED_SERIAL_32DS 

Tag Number 
Properties, 
Fieldbus tab 

Field device 
address 

E After you retrieve DeltaV definitions, the 
Channel Types supporting table is 
populated with DeltaV-compatible channel 
types for DeltaV-compatible I/O strip 
types.  These are the only 
DeltaV-compatible values for the Channel 
Type field in the Channels dialog box. 

Tag Number 
Properties, 
Fieldbus tab 

Fieldbus 
device 
revision 

E • When you create a fieldbus tag based 
on a given instrument type, on the 
General tab of the Tag Number 
Properties dialog box, make sure that 
the value that you select from the 
Manufacturer list is among the 
acceptable values that you set for this 
instrument type during retrieval from 
DeltaV. 

• The values available on the Fieldbus 
tab of the Tag Number Properties 
dialog box under Fieldbus device 
revision are determined by the value 
that you select from the Manufacturer 
list on the General tab. 
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Tag Number 
Properties, 
Fieldbus tab 

Backup link 
master 

E • On the Fieldbus tab of the Tag 
Number Properties dialog box, select 
the Backup link master check box 
only for a device that you verified is 
capable of being a backup. 

• On the Fieldbus tab of the Tag 
Number Properties dialog box, under 
Field device address, you must type a 
value between 20 and 35 (inclusive).  If 
you selected the Backup link master 
check box, and enter 20 as a value for 
Field device address. 

•  
 

Publish Data for DeltaV 
 Spaces are not allowed in DeltaV tags, therefore, when publishing data, SmartPlant 

Instrumentation removes spaces in instrument and Control System tags.  You can specify a 
substitute character, such as an underscore, to replace the spaces; to do so, you must add the 
following line in the Intools.ini file under the [API] section: 
NameSpacesReplacement = "_". 
1. In any SmartPlant Instrumentation module, click Tools > Interfaces > DeltaV. 
2. On the DeltaV Interface dialog box, under Data transfer mode, click Publish SmartPlant 

Instrumentation data, and then click OK. 
 If prompted to enable the item registry (even though your System Administrator has 

already activated this option as required), contact SmartPlant Instrumentation support. 
3. On the Plant Controller Selection dialog box, do one of the following: 

 To publish all relevant database fields for DeltaV, select the Select all check box. 
 For publishing of data associated with a given controller, select the Select check box next 

to that controller. 
4. On the Publish to File dialog box, under Folder to save XML files, type the path for DeltaV 

publishing, and click OK to publish the .xml file for the first controller that you selected. 
5. For each additional controller that you selected in the SmartPlant Instrumentation Plant 

Controller Selection dialog box, when the Publish to File dialog box reopens, click OK. 

 
 SmartPlant Instrumentation publishes the data associated with each controller into a separate 

.xml file. 
 On publishing data other than for the first time, DeltaV identifies changes as follows: 

 The software identifies new items created in SmartPlant Instrumentation as new items to 
be created in DeltaV. 

 If you move items, cards, CS tags, or if you modify item fields in SmartPlant 
Instrumentation, the software identifies these as items to be updated in DeltaV. 

 The software identifies items deleted in SmartPlant Instrumentation as items to be deleted 
in DeltaV. 

See Also 
Prerequisites for Working with DCS Vendor Interfaces (on page 378) 
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Flow of Activities for Configuring Yokogawa CENTUM CS 
3000 

This topic describes the primary flow of activities when you use SmartPlant Instrumentation to 
design a plant to be run and controlled using the Yokogawa CENTUM CS 3000 plant automation 
and control system.  Note that the flow that follows may be performed multiple times during the 
project life cycle. 

1. Retrieve the Yokogawa CENTUM CS 3000 Definitions 
The Yokogawa CENTUM CS 3000 item definition documents that you download and retrieve in 
SmartPlant Instrumentation constitute the engineering library of Yokogawa CENTUM CS 3000 
objects - Yokogawa CENTUM CS 3000 I/O cards, Foundation Fieldbus elements, and entries for 
supporting tables such as Manufacturer, Model, and so forth.  For more information, see 
Retrieve Yokogawa CENTUM CS 3000 Definitions (on page 393). 

2. Retrieve Yokogawa CENTUM CS 3000 Data 
For more information, see Retrieve Yokogawa CENTUM CS 3000 Data (on page 394). 

3. Update Your Plant Design 
Using the Yokogawa CENTUM CS 3000-compatible objects now available in the Reference 
Explorer and supporting tables of your SmartPlant Instrumentation database, update your plant 
design.  From the perspective of SmartPlant Instrumentation, the Yokogawa CENTUM CS 3000 
panel is a DCS in the Reference Explorer from which you create a specific Yokogawa CENTUM 
CS 3000 DCS in the Domain Explorer. 

 In the Reference Explorer, do not change any of the values in the items that you 
retrieved from the DCS vendor. 
For information on how to make associations between Foundation Fieldbus device types, 
instrument manufacturers, and SmartPlant Instrumentation instrument types, see Associate 
Device Types for DCS Vendors (on page 396). 

4. Publish Data for Yokogawa CENTUM CS 3000 
The .xml document that you publish (export) is a partial set of the SmartPlant Instrumentation 
database, including data such as the Yokogawa CENTUM CS 3000 configuration, I/O 
assignment, conventional and fieldbus data, and so forth. 
After you complete the process of designing your Yokogawa CENTUM CS 3000-compatible plant 
in SmartPlant Instrumentation, use this procedure to publish (export) the required data for 
accurate and efficient Yokogawa CENTUM CS 3000 configuration.  You publish a partial set of 
the SmartPlant Instrumentation database, including data such as the Yokogawa CENTUM CS 
3000 configuration, I/O assignment, instrument tags, and so forth.  (The process does not export 
specification data, for example.)  For more information, see Publish Data for Yokogawa CENTUM 
CS 3000 (on page 394). 

5. Retrieve Data Published from SmartPlant Instrumentation into Yokogawa CENTUM CS 
3000 
Following the retrieval, validate and — if necessary — reconcile the data retrieved from 
SmartPlant Instrumentation with the Yokogawa CENTUM CS 3000 database. 
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Data Limitations for the Yokogawa CENTUM CS 3000 Interface 
When you prepare a SmartPlant Instrumentation domain for publishing to Yokogawa CENTUM 
CS 3000, you must be careful to enter values with limitations according to the table that 
follows.  In most cases, the software validates the data; however, it does not validate data that 
you merge in the database or data that you enter via a browser view; in these cases, it is up to you 
to check that the values comply with these limitations. 

 
 SmartPlant Instrumentation validates the data only if the DCS manufacturer name is CENTUM 

CS 3000. 
 If you intend to publish fieldbus data, set the relevant option on the Preferences dialog 

box.  For details, see Interfaces > DCS Vendors (Preferences) (on page 25). 
 Only ONE I/O card is allowed per slot. 
 Spaces are not allowed in Yokogawa CENTUM CS 3000 tags, therefore, when publishing 

data, SmartPlant Instrumentation removes spaces in instrument and Control System 
tags.  You can specify a substitute character, such as an underscore, to replace the spaces; 
to do so, you must add the following line in the Intools.ini file under the [API] section: 
NameSpacesReplacement = "_" 
It is recommended not to select any character that appears in the tag names as the substitute 
character because when retrieving data back from Yokogawa CENTUM CS 3000, SmartPlant 
Instrumentation replaces that character with spaces again. 

Item Type Limitation 

Panel The panel name is not allowed to exceed 7 
characters. 

Panel The Panel DCS naming must start with the 
string "FCS". 

Panel The Panel DCS naming must contain two 
2-digit numeric strings. 

Panel The first number in the panel DCS must be 
between 1 and 32. 

Panel The second number in the panel DCS must be 
between 1 and 64. 

Panel The Naming Convention for a default panel is 
read-only and must not be modified. 

I/O Card The DCS manufacturer name is CENTUM CS 
3000 and this must not be modified. 

I/O Card The following properties are read-only and 
must not be modified: card type, I/O type, 
model, module, controller. 

I/O Card The card name and type must be the same. 

I/O Card A card can only appear under a slot. 

I/O Card The Naming Convention for default Wiring 
Equipment is read-only and must not be 
modified. 
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Item Type Limitation 

I/O Card The controller or the module for a default card 
is read-only and must not be modified. 

I/O Card The series for I/O Wiring Equipment is 
read-only and must not be modified. 

Control System 
Tag 

The DCS function block name is not allowed to 
exceed 16 characters. 

Control System 
Tag 

The control strategy drawing number must be 
between 1 and 200. 

Control System 
Tag 

The control system tag description is not 
allowed to exceed 24 characters. 

Channel The channel name and sequence values must 
be the same. 

Channel The channel address is read-only and must not 
be modified. 

Rack The default rack name is read-only and must 
not be modified. 

Rack The cabinet rack name must be between 1 and 
15 characters. 

Slot The slot name must be between 1 and 8 
characters. 

Slot The controller for a default slot is read- only 
and must not be modified. 

See Also 
Publish Data for Yokogawa CENTUM CS 3000 (on page 394) 
 

Retrieve Yokogawa CENTUM CS 3000 Definitions 
 Before you start this procedure, make sure that you have an Internet connection and 

a valid Intergraph customer user name and password. 
1. In SmartPlant Instrumentation, click Tools > Interfaces > Yokogawa CENTUM CS 3000. 
2. Under Data transfer mode, select Retrieve Yokogawa CENTUM CS 3000 definitions and 

click OK. 
3. On the Retrieve Yokogawa CENTUM CS 3000 Definitions dialog box, click Browse, 

navigate to the folder that contains the Yokogawa files, and click OK. 
4. In the data window, under Select, select the documents that you want to retrieve in 

SmartPlant Instrumentation, and click OK. 
5. When done, click Close. 

 
 Once you have retrieved Foundation Fieldbus definitions, you can use them to make 

appropriate associations among Foundation Fieldbus device types, instrument 
manufacturers, and SmartPlant Instrumentation instrument types.  For details, see Associate 
Device Types for DCS Vendors (on page 396). 
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 When retrieving Yokogawa CENTUM CS 3000 definitions, the software automatically adds 
new definitions and updates any modifications to definitions that already exist in the 
SmartPlant Instrumentation database.  However, you must delete any redundant definitions 
manually from the Reference Explorer. 

See Also 
View the Log File for a DCS Vendor (on page 397) 
 

Retrieve Yokogawa CENTUM CS 3000 Data 
 Before retrieving data, you must configure SmartPlant Instrumentation to work in file 

mode.  For details, see Configure SmartPlant Instrumentation to Publish and Retrieve Data in File 
Mode (on page 379). 
1. In SmartPlant Instrumentation, click Tools > Interfaces > Yokogawa - CENTUM CS 3000. 
2. Under Data transfer mode, select Retrieve Yokogawa - CENTUM CS 3000 data and click 

OK. 
3. In the Select Data XML File window, navigate to the .xml file that contains the Yokogawa 

data and click Open. 
 After selecting the file, two more windows open: Select Meta-data XML File and Select 

Tombstones XML File.  Just click Cancel in both of these windows. 
4. On successful completion of the retrieval, click Close on the message box that appears, or if 

errors occurred, click View Log to troubleshoot them. 
5. Click SmartPlant > To Do List. 

 If using fieldbus tags, after retrieving the Yokogawa data, but before running any 
tasks from the To Do List, you must make associations between Foundation Fieldbus device 
types, instrument manufacturers, and SmartPlant Instrumentation instrument types.  For 
more information, see Associate Device Types for DCS Vendors (on page 396). 

6. In the To Do List window, select the tasks that you want to run. 
 For more details of available options when running tasks, see Run Tasks from the To Do 

List (on page 504). 

7. On the To Do List toolbar, click Run Task . 

See Also 
View the Log File for a DCS Vendor (on page 397) 
 

Publish Data for Yokogawa CENTUM CS 3000 
 Spaces are not allowed in Yokogawa CENTUM CS 3000 tags, therefore, when 

publishing data, SmartPlant Instrumentation removes spaces in instrument and Control System 
tags.  You can specify a substitute character, such as an underscore, to replace the spaces; to do 
so, you must add the following line in the Intools.ini file under the [API] section: 
NameSpacesReplacement = "_". 
1. In any SmartPlant Instrumentation module, click Tools > Interfaces > Yokogawa CENTUM 

CS 3000. 
2. On the Yokogawa CENTUM CS 3000 Interface dialog box, under Data transfer mode, click 

Publish SmartPlant Instrumentation data, and then click OK. 
 If prompted to enable item registry (even though your System Administrator has already 

activated this option as required), contact SmartPlant Instrumentation support. 
3. On the Plant Panel Selection dialog box, do one of the following: 
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 To publish all relevant database fields for Yokogawa CENTUM CS 3000, select the 
Select all check box. 

 For publishing of data associated with a given DCS panel, select the Select check box 
next to that panel. 

4. On the Publish to File dialog box, under Folder to save XML files, type the path for 
Yokogawa CENTUM CS 3000 publishing, and click OK to publish the .xml file for the first DCS 
panel that you selected. 

5. For each additional DCS panel that you selected in the SmartPlant Instrumentation Plant 
Panel Selection dialog box, when the Publish to File dialog box reopens, click OK. 

 SmartPlant Instrumentation publishes the data associated with each DCS panel into a 
separate .xml file. 

See Also 
Prerequisites for Working with DCS Vendor Interfaces (on page 378) 
 

Retrieve ABB Definitions 
 

 Before you start this procedure, make sure that you have an Internet connection and a valid 
Intergraph customer user name and password. 

 SmartPlant Instrumentation is only capable of handling certain I/O types that ABB 
supports.  For details of supported I/O card catalog definitions, contact Intergraph Support. 

1. In any SmartPlant Instrumentation module, click Tools > Interfaces > ABB. 
2. On the Retrieve ABB Definitions dialog box, click Browse, navigate to the folder that 

contains the ABB files, and click OK. 
3. In the data window, under Select, select the documents that you want to retrieve in 

SmartPlant Instrumentation, and click OK. 
4. When done, click Close. 

 When retrieving ABB definitions, the software automatically adds new definitions and 
updates any modifications to definitions that already exist in the SmartPlant Instrumentation 
database.  However, you must delete any redundant definitions manually from the Reference 
Explorer. 

See Also 
View the Log File for a DCS Vendor (on page 397) 
 

Retrieve Honeywell Definitions 
  

 Before you start this procedure, make sure that you have an Internet connection and a valid 
Intergraph customer user name and password. 

 SmartPlant Instrumentation is only capable of handling the following I/O types that Honeywell 
supports: 

 PMIO. 
 Series C IO. 
 Safety Manager IO (SM). 
 Fail Safe Controller IO (FSC). 

1. In any SmartPlant Instrumentation module, click Tools > Interfaces > Honeywell. 
2. On the Retrieve Honeywell Definitions dialog box, click Browse, navigate to the folder to 

which you unzipped the files that you downloaded, and click OK. 
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3. In the data window, under Select, select the documents that you want to retrieve in 
SmartPlant Instrumentation, and click OK. 

4. When done, click Close. 
 When retrieving Honeywell definitions, the software automatically adds new definitions and 

updates any modifications to definitions that already exist in the SmartPlant Instrumentation 
database.  However, you must delete any redundant definitions manually from the Reference 
Explorer. 

See Also 
View the Log File for a DCS Vendor (on page 397) 
 

General DCS Vendor Activities 
You can perform the following general activities after retrieving your DCS vendor data: 
 Associate Device Types for DCS Vendors (on page 396) 
 View the Log File for a DCS Vendor (on page 397) 

 

Associate Device Types for DCS Vendors 
Use this procedure to make associations between Foundation Fieldbus and HART device types, 
instrument manufacturers, and SmartPlant Instrumentation instrument types. 

 After you have retrieved data from your DCS vendor interface, you can determine the 
manufacturer and device type of each Foundation Fieldbus device that you need to associate with 
a SmartPlant Instrumentation instrument type.  To do so, display the To Do List window and 
double-click a fieldbus device.  On the Details tab, the value of the MFR COMPANY 
IDENTIFICATION property corresponds to the manufacturer's identification number.  This 
number appears in parentheses beside the name of the manufacturer in the Tree View pane of 
the Associate Foundation Fieldbus Device Types with Instrument Type dialog box.  The 
value of the FieldBus Device ID task property corresponds to the number in the Device Type 
column on the Details pane of the Associate Foundation Fieldbus Device Types with 
Instrument Type dialog box.  The adjacent Device Type Description column assists you in 
selecting the appropriate instrument type to associate. 
1. Click Tools > Interfaces > Associate Foundation Fieldbus Device Types. 
2. In the Tree View pane, click  to expand the Certified Fieldbus Instruments list and 

display the available manufacturers. 
3. Do one of the following: 

 Select a manufacturer to view details of all the device types available for that 
manufacturer. 

 For a particular manufacturer, click  and select a device type to view its details. 
4. In the Details pane, select the desired device type and click Associate. 
5. In the Instrument Types dialog box, do one of the following: 

 Select an existing fieldbus instrument type for which the I/O type value is Fieldbus, for 
association with the current device type.  You can check the I/O type by viewing the 
profile of the instrument type. 

 Create a new fieldbus instrument type or edit an existing one.  For details, see Define 
Foundation Fieldbus and Profibus Instrument Type Profiles. 

 When you create fieldbus tags that are compatible with the DCS vendor, the only 
acceptable values for instrument type are those that you associated with device types for that 
vendor during the downloading process. 
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6. Click OK to associate the selected instrument type with the current device type and close the 
Instrument Types dialog box. 

 
 When you create a fieldbus tag based on the displayed instrument type, the only 

acceptable values for the manufacturer are those displayed in this dialog box.  If you 
select other manufacturers, this will prevent validation in the DCS vendor's database. 

 You can associate only one function block for each device type with a particular 
instrument type. 

7. When done, click OK. 

 
 For general guidelines regarding fieldbus devices, see Foundation Fieldbus Design: An 

Overview and Profibus Design. 
 For details of how to create fieldbus devices, see Create Foundation Fieldbus and Profibus 

Instruments. 
 

View the Log File for a DCS Vendor 
 After you retrieve item definition documents from a DCS vendor into SmartPlant 

Instrumentation, you can use this procedure to view and save the log.  You can then open the .txt 
file in a word processor or text editor and print it. 
1. On the appropriate DCS vendor dialog box, for example, Retrieve Yokogawa - CENTUM CS 

3000 Definitions, click View Log. 
2. On the Log dialog box, view the log. 
3. To save the log as a .txt file, click Save. 
4. On the Select File dialog box, navigate to the desired folder and type a file name. 
5. Click Save. 
 

FirstVue Interface 
The FirstVue interface allows you to exchange control valve data between SmartPlant 
Instrumentation and the Fisher- Rosemount FirstVue application using ASCII delimited .csv 
files.  After exporting your control valve data from SmartPlant Instrumentation and performing all 
the desired calculations in FirstVue, you can import the calculation results back to SmartPlant 
Instrumentation where this data can be used in specification sheets, reports, and other 
SmartPlant Instrumentation features such as browsers.  You can also print out the information as 
a standard ISA specification, the same way as you do it in FirstVue. 
The FirstVue interface supports the Fisher-Rosemount FirstVue application fields and field order, 
so importing calculation results from FirstVue to SmartPlant Instrumentation automatically 
updates fields that you require. 
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Flow of Activities for Working with FirstVue 
1. Define a file or database with the data you want to import.  For details about supported data 

sources, see Database Platform Support. 
2. Export control valve data from SmartPlant Instrumentation to an ASCII file.  For details, see: 

 Prerequisites for Exporting Data to FirstVue (on page 399) 
 Exporting FirstVue Data (on page 400) 

3. Run FirstVue and do the following: 
a. Import the SmartPlant Instrumentation control valve data from the ASCII file. 
b. Calculate and select the appropriate control valve in FirstVue. 
c. Export the sizing data from FirstVue to an ASCII file. 
For details, see your FirstVue User's Guide. 

4. In the Import Utility, run the FirstVue import links to import FirstVue sizing data. 
 The import links are retrieved from the In_ctlog.db file and are used to import sizing data 

from the ASCII files to the SmartPlant Instrumentation database.  For details, see: 
 Prerequisites for Importing FirstVue Data (on page 401) 
 Importing FirstVue Data (on page 402) 

5. View and edit the imported sizing data, if required. 
 

FirstVue Field Conversion Conventions 
The following items describe the conversion conventions used by the SmartPlant Instrumentation 
FirstVue interface when transferring data from SmartPlant Instrumentation to FirstVue and back. 
1. For outlet line parameters, SmartPlant Instrumentation uses specification custom fields. 
2. When exporting line data to ASCII delimited files, SmartPlant Instrumentation uses the same 

values for outlet line parameters as for input line parameters if the following FirstVue fields 
contain a null value: 
 pipeoutletdiameter 
 outpipelinesize 
 outpipelinesched 

3. For the otherconditionname FirstVue field, SmartPlant Instrumentation automatically 
assigns the constant value: Shut-Off. 

4. When importing new line data, make sure the ansi_din SmartPlant Instrumentation field data 
complies with the following convention: 
 If the pipelineuom FirstVue field value is in (inches), set the ansi_din field to A. 
 If the pipelineuom field value is mm, set the ansi_din field to D. 

5. The following SmartPlant Instrumentation-to-FirstVue fluid phase relations apply: 

SmartPlant Instrumentation 
(pd_fluid_phase field) 

FirstVue (fluidstate field)  

L Liquid  

W Water 

G Gas  

S Vapor  



 Working with Interfaces 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 399 
 

 
 The source text file profile is defined in the odbc.ini registry folder. 
 When you install SmartPlant Instrumentation, you can also install the predefined ASCII file 

profile for use with FirstVue. 
 You must define your own Microsoft driver using the Windows ODBC Data Source 

Administrator. 
 When defining a profile for FirstVue data, make sure you use a comma delimiter and the 

Column Names option. 
 If you change an instrument type that was exported from SmartPlant Instrumentation in 

the FirstVue interface before re-importing it to SmartPlant Instrumentation, the new instrument 
type will be created in SmartPlant Instrumentation.  You can avoid this by modifying the 
appropriate FirstVue import links. 

See Also 
Prerequisites for Importing FirstVue Data (on page 401) 
 

Prerequisites for Exporting Data to FirstVue 
 Before being able to export data, the predefined import links for FirstVue must be 

available.  To make the links available, you need to import the appropriate system interfaces into 
SmartPlant Instrumentation from the Administration module (for details, see Import System 
Interfaces (on page 349)). 
Before you start exporting data, you need to enter the required process data (for example, Tag 
Name and Service) in the appropriate process data sheets.  Your choice of the process data 
parameter values will determine your subsequent selections of the valve sizing data such as Body 
Material and Bonnet. 
At this stage, you can also define process data parameters specific to the selected control valve 
(for example, Leakage).  (These parameters can be viewed in the Additional Properties window 
in the Process Data module.) 
Also, consider the following issues: 
 When exporting data to FirstVue, the SmartPlant Instrumentation export feature automatically 

converts the SmartPlant Instrumentation system and unit of measure codes to the appropriate 
system and unit of measure codes used in FirstVue, for example: °C in SmartPlant 
Instrumentation is converted to deg C in FirstVue.  However, since SmartPlant 
Instrumentation contains additional units of measure, some SmartPlant Instrumentation units 
of measure may not have parallel values in FirstVue and therefore will not be accessible in 
FirstVue for sizing calculations.  In this case an appropriate message is displayed and a note 
is added in the Error.log file (located in the same folder where you saved the ASCII file). 

 Fields in SmartPlant Instrumentation and in FirstVue differ in length and SmartPlant 
Instrumentation fields may be truncated if longer than the corresponding fields in 
FirstVue.  Therefore, you need to make sure that the truncated data does not contain sizing 
data which is required in FirstVue. 
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Exporting FirstVue Data 
You export SmartPlant Instrumentation process and calculation data to an ASCII command 
delimited file by using the SmartPlant Instrumentation export feature.  This ASCII file contains the 
following information: 
 Fields that are required for sizing calculations, including line data 
 ISA format specification fields 
 Fields that contain export-only data (for example, revision data) 
 Fields that allow insertion of new data, when you import data from the ASCII file back to 

SmartPlant Instrumentation 
 During the export process, the 'U' character is added to the FirstVue unitnumber field 

string. 
 

Export FirstVue Data 
 Before using this procedure, make sure you meet all the prerequisites.  For details, 

see Prerequisites for Exporting Data to FirstVue (on page 399). 
1. Open the SmartPlant Instrumentation Instrument Index module. 
2. Do one of the following to open an Instrument Index Standard Browser view: 

 Click . 
 Click Actions > Browse Index. 

3. In the browser view, select the tags whose control valve data you want to export to 
FirstVue.  To select more than one tag, hold down either the Ctrl key or the Shift key and 
click the desired fields. 

4. Click Tools > Interfaces > Fisher FirstVue. 
5. On the Export to FirstVue dialog box, enter data as follows: 

a. To select the appropriate FirstVue ASCII file with a .csv extension to which the SmartPlant 
Instrumentation control valve data will be exported, do one of the following: 

 In the File text box, type in the path and location of the FirstVue export file name. 
 Click Browse to navigate to the FirstVue file location. 

b. If you selected in the previous step to export to an existing ASCII file, do one of the 
following: 

 Select the Overwrite check box to overwrite the existing ASCII file. 
 Clear the Overwrite check box to keep the existing ASCII file.  In this case, if you 

enter an existing file in the File Name data field, you will be prompted to confirm the 
overwrite. 

c. To select the level on which you want to export the SmartPlant Instrumentation data to 
FirstVue, do one of the following: 

 Click Plant to export all the control valve tags and their data belonging to the current 
plant. 

 Click Unit to export all the control valve tags and their data belonging to the current 
unit. 

 Click Filter to export only the control valve tags and their data that comply with the 
filter parameters that you have set for the current Instrument Index Standard Browser 
view. 

 Click Selected tags to export only the tags and their data that you selected in the 
Instrument Index Standard Browser view (see step 3 in this procedure). 
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 If you select to export selected tags, make sure you select the appropriate tags 
before clicking OK on the Export to FirstVue dialog box. 

d. Under Use field length from, do one of the following: 
 Click SmartPlant Instrumentation to truncate the exported fields to match the 

lengths indicated in the SmartPlant Instrumentation database. 
 Click FirstVue to truncate the exported fields to match the lengths indicated in the 

FirstVue field table. 
6. Click OK to start the export process. 

 If the export process is successful, an appropriate message is displayed, notifying you 
that the Log file is empty. 

 Failing to convert units of measure will generate an error message.  This means 
that the associated data was exported without the required units of measure (that is, the unit 
of measure fields in FirstVue will be empty).  In this case, you should select the desired units 
of measure manually in FirstVue. 

7. On completion of the export process, click Log File to open the Export.log file, located in the 
same folder where you exported the ASCII file, where you can view any errors that occurred 
during the export process. 

8. Click Close to close the Export to FirstVue dialog box and return to the browser view. 
 

Prerequisites for Importing FirstVue Data 
This topic lists and describes all the prerequisites you must meet before importing FirstVue data 
into SmartPlant Instrumentation.  In addition to FirstVue-specific prerequisites, make sure you 
have configured your ODBC data source (see Configure ODBC Data Source for DBF Files)and 
that you have completed the general prerequisites (for details, see General Import Prerequisites). 

 Before being able to import data, the predefined import links for FirstVue must be 
available.  To make the links available, you need to import the appropriate system interfaces into 
SmartPlant Instrumentation from the Administration module (for details, see Import System 
Interfaces (on page 349)). 
 Prepare a source ASCII file with a .csv extension.  Make sure that the following requirements 

are met for this file: 
 FirstVue data fields (for example, actuatorsize, minbenchrange, maxbenchrange, and 

so forth) should not contain any periods ('.'). 
 In FirstVue, when using the User Overrides option for the ISA_PM spec form, the 

following fields must be numeric. 
 ISA line 10 - Maximum, Normal, and Minimum Travel 
 ISA line 11 - Maximum, Normal, and Minimum Predicted SPL 
 ISA line 18 - Maximum Pressure and Temperature 
 ISA line 36 - Trim Rated CV 

 The valvemfr FirstVue field must contain the appropriate manufacturer name (the 
FirstVue export process will set the value of this field to FISHER by default if it is empty). 

 Also note the following: 
 Make sure that your ODBC profile is named VUE1. For details on how to define a new ODBC 

profile, see Configure ODBC Data Source for Text Files. 
 Due to the Unicode technology, check the system codes and make sure that you have 

correctly adapted all the system codes and the units of measure. For details, see System 
Codes. 
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 Prior to running your import link, make sure that you have selected the appropriate source 
system. In Import Manager, click Code > Source System List and then select the source 
system that you require. 

 For all the import links that contain references to the Control Valve table, note that the Control 
Valve table has two fields that deal with similar data, CV_VALVE_TYPE and 
CV_VALVE_TYPE_ID. Both of these fields are supported by the Specifications module. 
However, only the CV_VALVE_TYPE_ID field is used in the Calculations module. Therefore, if 
you want the imported control valve data to be linked to calculations, make sure that you map 
the CV_VALVE_TYPE_ID field in the appropriate import links. Note that there is no system 
code adaptation for this field since this field is referenced from another table. 

 
 

Importing FirstVue Data 
You can import FirstVue sizing and specification data into SmartPlant Instrumentation from a 
source ASCII delimited file with a .csv extension.  After the Domain Administrator imports 
FirstVue link groups from the In_ctlog.db file using the Administration module options, this group 
appears in the Link Explorer in the Import Utility.  The links in the FirstVue group have 
predefined mapping which you may need to modify as you require.  You cannot change the 
import method or table/module assignment of these links.  It is possible to restore deleted 
FirstVue links by re-importing the link group from the In_ctlog.db file.  Note, however, that to 
restore deleted links, you must first rename the FirstVue group or delete the entire group. 
Also, when retrieving the FirstVue link group from the In_ctlog.db file, the software also retrieves 
the system codes and unit of measure codes.  These codes are already adapted to SmartPlant 
Instrumentation, that is, every source code value in FirstVue is associated with its appropriate 
target value in SmartPlant Instrumentation. 
It is possible to run all the FirstVue group links automatically in order of their 
appearance.  Advanced users can perform a manual import process which allows you to carry out 
a step- by-step procedure.  Importing data this way enables you to view and modify the default 
import parameters and link settings. 
The following links are available in the FirstVue link group the Domain Administrator imported 
from the In_ctlog.db file: 
 FirstVue - Index — Contains the appropriate sizing data for importing into the Instrument 

Index module, including the UDF_COMPONENT table columns. 
 FirstVue - PD/Calcs — Contains the appropriate sizing data for importing into the Process 

Data module. 
 Specification Data — Is used for specification data import into the SPEC_SHEET_DATA 

table. 
 Specification Data 0 — Is used for specification data import into the ADD_SPEC1 table. 

See Also 
Prerequisites for Importing FirstVue Data (on page 401) 
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Import FirstVue Data Automatically 
Use this procedure to import FirstVue data without updating the mapping in the import links. 

 
 Before using this procedure, make sure you meet all the prerequisites.  For details, see 

Prerequisites for Importing FirstVue Data (on page 401). 
 When importing FirstVue data, you must always use the FirstVue interface to connect to the 

source data files before you can run the links from the Link Explorer.  You cannot create and 
run links outside of the interface. 

1. Do one of the following: 

 On the Link Explorer menu bar, click . 
 Click Options > Fisher FirstVue. 

2. Beside the Source file box, click Browse and select a .csv ASCII file containing data 
exported from FirstVue. 

3. Click Open to display the file path in the Source file box. 
4. Do one of the following: 

 Select Insert new data if you are importing FirstVue data into SmartPlant Instrumentation 
for the very first time. 

 Clear Insert new data If you previously imported FirstVue data into SmartPlant 
Instrumentation and you only need to update the existing sizing data in the target 
database. 

5. Select Run link group automatically and click OK to minimize the Fisher FirstVue window. 
6. On the Select Link Group dialog box, select FirstVue and click OK to start the import. 
7. If notified that the link requires system codes, click OK in the message box, and then, do the 

following: 
a. On the Source System List dialog box, which opens automatically, select the FirstVue 

system codes, which the Domain Administrator imported from the In_ctlog.db file. 
b. Click OK to continue the import process. 

 When running the first import session, the software prompts you to select the source 
system codes because, for each FirstVue import link, on the Source tab of the Link 
Properties dialog box, the Use system codes check box is selected. 

8. Open SmartPlant Instrumentation and examine the imported data in the Browser, Process 
Data, or Instrument Index module. 

 

Import FirstVue Data Manually 
Use this procedure as an example if you need to modify the mapping in FirstVue links before 
importing FirstVue data. 

 
 Before using this procedure, make sure you meet all the prerequisites.  For details, see 

Prerequisites for Importing FirstVue Data (on page 401). 
 When importing FirstVue data, you must always use the FirstVue interface to connect to the 

source data files before you can run the links from the Link Explorer.  You cannot create and 
run links outside of the interface. 
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1. Do one of the following: 

 On the Link Explorer menu bar, click . 
 Click Options > Fisher FirstVue. 

2. Beside the Source file box, click Browse and select a .csv ASCII file containing data 
exported from FirstVue. 

3. Click Open to display the file path in the Source file box. 
4. Do one of the following: 

 Select Insert new data if you are importing FirstVue data into SmartPlant Instrumentation 
for the very first time. 

 Clear Insert new data If you previously imported FirstVue data into SmartPlant 
Instrumentation and you only need to update the existing sizing data in the target 
database. 

5. Clear Run link group automatically. 
6. Click OK to minimize the Fisher FirstVue window. 
7. In the Link Explorer, in the FirstVue group, select and  open the link FirstVue - PD/Calcs in 

the Import Link window. 
8. Modify the displayed mapping as follows: 

a. Map the source fluidstate field to the Fluid State field in the PD_GENERAL table. 
b. Select the Code check box next to the Fluid State field to use code adaptation when 

importing data to this field. 
c. Map the following source FirstVue fields with the appropriate target SmartPlant 

Instrumentation fields: 

Link Source Field  Target Field 

All plantname Change if required 

All areaname Change if required 

All unitnumber Change if required 

All itemtag Check whether the tag instrument 
convention in each target unit matches the 
source data 

Specification Data specformnumber SPEC_FORM_CNUM/SPEC_FORM_ID 
9. If the control valve in SmartPlant Instrumentation does not have a specification or if the control 

valve specification is not an ISA sheet, do one of the following: 
 If the tag does not have a specification, set the value of the specformnumber field to 70, 

which the form number of the library form ISA Control Valve. 
 If the control valve specification is not an ISA sheet, in the FirstVue - Index import link, 

replace the sources for the additional fields as required and in the Specification Data 
import link, set the value of the specformnumber field to the required form number. 

10. Start the import process by clicking  in the Import Link window. 
11. If notified that the link requires system codes, click OK in the message box, and then, do the 

following: 
a. On the Source System List dialog box, which opens automatically, select the FirstVue 

system codes, which the Domain Administrator imported from the In_ctlog.db file. 
b. Click OK to continue the import process. 
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 When running the first import session, the software prompts you to select the source 
system codes because, for each FirstVue import link, on the Source tab of the Link 
Properties dialog box, the Use system codes check box is selected. 

12. Open SmartPlant Instrumentation and examine the imported data in the Browser, Process 
Data, or Instrument Index module. 

See Also 
Importing FirstVue Data (on page 402) 
 

Fisher FIRSTVUE Dialog Box 
This dialog box allows you to update the SmartPlant Instrumentation database with data from 
FIRSTVUE ASCII files. 
Source file — Type the path and filename of the file where you saved the control valve data or 
click Browse to navigate to the required file. 
Insert new data — Select this check box to enable new data insertion during the import 
process.  Clearing the check box results in the rejection of all new source (FIRSTVUE) tags 
during the import process.  It is recommended that you select this check box if you want to import 
new FIRSTVUE sizing data that was not previously exported from SmartPlant Instrumentation. 
Run link group automatically — Select this option to run the links in the FIRSTVUE group 
automatically without displaying the links in the Import Link window after clicking OK. 
 

Masoneilan ValSpeQ Interface 
The Masoneilan ValSpeQ interface allows you to exchange control valve process and sizing data 
between SmartPlant Instrumentation and the Masoneilan ValSpeQ application using ASCII 
delimited .csv files.  After exporting your control valve data from SmartPlant Instrumentation and 
performing all the desired calculations in Masoneilan ValSpeQ, you can import the calculation 
results back to SmartPlant Instrumentation where this data can be used in process data and 
specification sheets, reports, and other SmartPlant Instrumentation features such as 
browsers.  You can also print out the information from SmartPlant Instrumentation as well as from 
Masoneilan ValSpeQ. 
 

Flow of Activities for Working with Masoneilan ValSpeQ 
1. Define a file or database with the data you want to import.  For details about supported data 

sources, see Database Platform Support. 
2. Export control valve data from SmartPlant Instrumentation to an ASCII file.  For details, see: 

 Prerequisites for Exporting Data to Masoneilan ValSpeQ (on page 406) 
 Exporting Masoneilan ValSpeQ Data (on page 406) 

3. Run Masoneilan ValSpeQ and do the following: 
a. Import the SmartPlant Instrumentation control valve data from the ASCII file 
b. Calculate and select the appropriate control valve in Masoneilan ValSpeQ 
c. Export the sizing data from Masoneilan ValSpeQ to an ASCII file 
For details, see your Masoneilan ValSpeQ User's Guide. 

4. In the Import Utility, run the Masoneilan ValSpeQ import links to import Masoneilan ValSpeQ 
sizing data. 

 The import links are retrieved from the In_ctlog.db file and are used to import sizing data 
from the ASCII files to the SmartPlant Instrumentation database.  For details, see: 
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 Prerequisites for Importing Masoneilan ValSpeQ Data (on page 408) 
 Importing Masoneilan ValSpeQ Data (on page 409) 

5. View and edit the imported sizing data, if required. 
 

Prerequisites for Exporting Data to Masoneilan ValSpeQ 
 Before being able to export data, the predefined import links for Masoneilan ValSpeQ 

must be available.  To make the links available, you need to import the appropriate system 
interfaces into SmartPlant Instrumentation from the Administration module (for details, see Import 
System Interfaces (on page 349)). 
Before you start exporting data, you need to enter the required process data (for example, Tag 
Name and Service) in the appropriate process data sheets.  Your choice of the process data 
parameter values will determine your subsequent selections of the valve sizing data such as Body 
Size and Rated Cv. 
At this stage, you can also define process data parameters specific to the selected control valve 
(for example, Leakage).  (These parameters can be viewed in the Additional Properties window 
in the Process Data module.) 
Also, consider the following issues: 
 When exporting data to Masoneilan ValSpeQ, the SmartPlant Instrumentation export feature 

automatically converts the SmartPlant Instrumentation system and unit of measure codes to 
the appropriate system and unit of measure codes used in Masoneilan ValSpeQ, for example: 
°C in SmartPlant Instrumentation is converted to deg C in Masoneilan ValSpeQ.  However, 
since SmartPlant Instrumentation contains additional units of measure, some SmartPlant 
Instrumentation units of measure may not have parallel values in Masoneilan ValSpeQ and 
therefore will not be accessible in Masoneilan ValSpeQ for sizing calculations.  In this case an 
appropriate message is displayed and a note is added in the Error.log file (located in the same 
folder where you saved the ASCII file). 

 Fields in SmartPlant Instrumentation and in Masoneilan ValSpeQ differ in length and 
SmartPlant Instrumentation fields may be truncated if longer than the corresponding fields in 
Masoneilan ValSpeQ.  Therefore, you need to make sure that the truncated data does not 
contain sizing data which is required in Masoneilan ValSpeQ. 

 When exporting vapor pressure or critical pressure values, you must specify the units of 
measure of these quantities as absolute (A) and not gage (G) in the specification sheet. 

 

Exporting Masoneilan ValSpeQ Data 
You export SmartPlant Instrumentation process and calculation data to an ASCII command 
delimited file by using the SmartPlant Instrumentation export feature.  This file can later be 
imported into Masoneilan ValSpeQ where the data it contains is used to make sizing calculations 
and to select the appropriate valves.  The ASCII file contains the following information: 
 Fields that are required for sizing calculations, including line data 
 ISA format specification fields 
 Fields that contain export-only data (for example, revision data) 
 Fields that allow insertion of new data, when you import data from the ASCII file back to 

SmartPlant Instrumentation 
 During the export process, the 'U' character is added to the Masoneilan ValSpeQ 

unitnumber field string. 
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Export Masoneilan ValSpeQ Data 
  Before using this procedure, make sure you meet all the prerequisites.  For details, 

see Prerequisites for Exporting Data to Masoneilan ValSpeQ (on page 406). 
1. Open the SmartPlant Instrumentation Instrument Index module. 
2. Do one of the following to open an Instrument Index Standard Browser view: 

 Click . 
 Click Actions > Browse Index. 

3. In the browser view, select the tags whose control valve data you want to export to 
Masoneilan ValSpeQ.  To select more than one tag, hold down either the Ctrl key or the Shift 
key and click the desired fields. 

4. Click Tools > Interfaces > Masoneilan ValSpeQ. 
5. On the Export to Masoneilan ValSpeQ dialog box, enter data as follows: 

a. To select the appropriate Masoneilan ValSpeQ ASCII file with a .csv extension to which 
the SmartPlant Instrumentation control valve data will be exported, do one of the 
following: 

 In the File text box, type in the path and location of the Masoneilan ValSpeQ export 
file name. 

 Click Browse to navigate to the Masoneilan ValSpeQ file location. 
b. If you selected in the previous step to export to an existing ASCII file, do one of the 

following: 
 Select the Overwrite check box to overwrite the existing ASCII file. 
 Clear the Overwrite check box to keep the existing ASCII file.  In this case, if you 

enter an existing file in the File Name data field, you will be prompted to confirm the 
overwrite. 

c. Under Export for, select the desired specification to be used for the exported data, from 
either: 

 Spec#1 
 Spec#75 

d. To select the level on which you want to export the SmartPlant Instrumentation data to 
Masoneilan ValSpeQ, do one of the following: 

 Click Plant to export all the control valve tags and their data belonging to the current 
plant. 

 Click Unit to export all the control valve tags and their data belonging to the current 
unit. 

 Click Filter to export only the control valve tags and their data that comply with the 
filter parameters that you have set for the current Instrument Index Standard Browser 
view. 

 Click Selected tags to export only the tags and their data that you selected in the 
Instrument Index Standard Browser view (see step 3 in this procedure). 

  If you select to export selected tags, make sure you select the appropriate 
tags before clicking OK on the Export to Masoneilan ValSpeQ dialog box. 

e. Under Use field length from, do one of the following: 
 Click SmartPlant Instrumentation to truncate the exported fields to match the 

lengths indicated in the SmartPlant Instrumentation database. 
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 Click Masoneilan to truncate the exported fields to match the lengths indicated in the 
Masoneilan field table. 

6. Click OK to start the export process. 
  If the export process is successful, an appropriate message is displayed, notifying you 

that the Log file is empty. 
  Failing to convert units of measure will generate an error message.  This means 

that the associated data was exported without the required units of measure (that is, the unit 
of measure fields in Masoneilan ValSpeQ will be empty).  In this case, you should select the 
desired units of measure manually in Masoneilan ValSpeQ. 

7. On completion of the export process, click Log File to open the Export.log file, located in the 
same folder where you exported the ASCII file, where you can view any errors that occurred 
during the export process. 

8. Click Close to close the Export to Masoneilan ValSpeQ dialog box and return to the browser 
view. 

 

Prerequisites for Importing Masoneilan ValSpeQ Data 
This topic lists and describes all the prerequisites you must meet before importing Masoneilan 
ValSpeQ data into SmartPlant Instrumentation.  In addition to Masoneilan-specific prerequisites, 
make sure you have configured your ODBC data source (see Configure ODBC Data Source for 
DBF Files)and that you have completed the general prerequisites (for details, see General Import 
Prerequisites). 

 Before being able to import data, the predefined import links for Masoneilan ValSpeQ 
must be available.  To make the links available, you need to import the appropriate system 
interfaces into SmartPlant Instrumentation from the Administration module (for details, see Import 
System Interfaces (on page 349)). 
Ensure that you have performed the following prerequisite actions: 
 Create target instruments with Control Valve as the instrument type, assign process data 

sheets to these instruments, and make sure you clear the process data in these sheets. 
 In the Specifications module, restore the library form 75 Masoneilan Control Valve.  For 

details see Restore Library Forms (on page 228).  Masoneilan data that you import will 
appear in control valve specifications based either on form 75 or form 1, which you do not 
need to restore. 

 For forms 1 and 75, prepare source ASCII files with .csv extensions and name them as 
desired.  The Import Utility uses these files to identify the Masoneilan import source for 
control valve specifications based on the appropriate forms. 

 Also note the following: 
 Make sure that your ODBC profile is named VUE1. For details on how to define a new ODBC 

profile, see Configure ODBC Data Source for Text Files. 
 Due to the Unicode technology, check the system codes and make sure that you have 

correctly adapted all the system codes and the units of measure. For details, see System 
Codes. 

 Prior to running your import link, make sure that you have selected the appropriate source 
system. In Import Manager, click Code > Source System List and then select the source 
system that you require. 
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 For all the import links that contain references to the Control Valve table, note that the Control 
Valve table has two fields that deal with similar data, CV_VALVE_TYPE and 
CV_VALVE_TYPE_ID. Both of these fields are supported by the Specifications module. 
However, only the CV_VALVE_TYPE_ID field is used in the Calculations module. Therefore, if 
you want the imported control valve data to be linked to calculations, make sure that you map 
the CV_VALVE_TYPE_ID field in the appropriate import links. Note that there is no system 
code adaptation for this field since this field is referenced from another table. 

 
 

Importing Masoneilan ValSpeQ Data 
The Masoneilan ValSpeQ interface enables you to import data for Masoneilan control 
valves.  After the Domain Administrator imports four Masoneilan ValSpeQ link groups from the 
In_ctlog.db file using the Administration module options, the groups appear in the Link Explorer 
in the Import Utility.  These links have predefined mapping which you may need to modify as you 
require.  You cannot change the import method or table/module assignment of these links.  It is 
possible to restore deleted Masoneilan links by re-importing the link group from the In_ctlog.db 
file.  Note, however, that to restore deleted links, you must first rename the Masoneilan links or 
group or delete the entire group. 
Also, when retrieving the Masoneilan link group from the In_ctlog.db file, the software also 
retrieves the system codes and unit of measure codes.  These codes are already adapted to 
SmartPlant Instrumentation, that is, every source code value in Masoneilan is associated with its 
appropriate target value in SmartPlant Instrumentation. 
SmartPlant Instrumentation features a standard ISA form which you can use to print out sizing 
data imported from Masoneilan ValSpeQ as an ISA specification.  This specification is based on 
library form 75.  The specification printout is identical to the one generated by Masoneilan 
ValSpeQ, yet retains the SmartPlant Instrumentation revision system.  Alternatively, you can use 
library form 1. 
It is possible to run all the Masoneilan group links automatically in order of their 
appearance.  Advanced users can perform a manual import process which allows you to carry out 
a step-by-step procedure.  Importing data this way enables you to view and modify the default 
import parameters and link settings. 
The following links are available in the link Masoneilan ValSpeQ link groups retrieved from the 
In_ctlog.db file: 
 Masoneilan1 or Masoneilan75 - per module - Index — Allows you to import data into the 

Instrument Index module, including the UDF_COMPONENT table, for specifications based on 
Form 1 or 75. 

 Masoneilan1 or Masoneilan75 - per table - Control Valve Specific Data — Allows you to 
import data into the CONTROL_VALVE table for specifications based on Form 1 or 71. 

 Masoneilan1 or Masoneilan75 - per table - Control Valve General Data — Allows you to 
import data into the PD_GENERAL table. 

 Masoneilan1 or Masoneilan75 - per table - Add Spec 1 — Allows you to import data into the 
ADD_SPEC1 table. 

See Also 
Prerequisites for Importing Masoneilan ValSpeQ Data (on page 408) 
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Import Masoneilan ValSpeQ Data 
Use this procedure to import Masoneilan ValSpeQ sizing and specification data from the ASCII file 
you previously exported from Masoneilan ValSpeQ.  You can use this procedure when importing 
Masoneilan ValSpeQ data whether for the first time or after a previous import. 

 
 Before using this procedure, make sure you meet all the prerequisites.  For details, see 

Prerequisites for Importing Masoneilan ValSpeQ Data (on page 408). 
 When importing Masoneilan ValSpeQ data, you must always use the Masoneilan interface to 

connect to the source data files before you can run the links from the Link Explorer.  You 
cannot create and run links outside of the interface. 

1. Do one of the following: 
 On the Link Explorer menu bar, click the Masoneilan button. 
 Click Options > Masoneilan. 

2. On the Masoneilan dialog box, do one of the following: 
 If you want to import data to control valve specifications based on standard form 1 only, 

beside Source file for Spec #1, click Browse and select the .csv ASCII file containing 
the appropriate data exported from Masoneilan. 

 If you want to import data to control valve specifications based on special form 75 
only,  Source file for Spec #75, click Browse and select the .csv ASCII file containing 
the appropriate data exported from Masoneilan. 

 If you want to import data to control valve specifications based on forms 1 and 75, specify 
both source files. 
 Spec form 75 is a SmartPlant Instrumentation library form designed for printing out 

control valve data imported from Masoneilan ValSpeQ as an ISA specification.  The 
specification printout is identical to the one generated by Masoneilan, yet retains the 
SmartPlant Instrumentation revision system. 

3. Click Open to display the file name and path on the Masoneilan dialog box. 
4. Do one of the following: 

 If you are importing Masoneilan ValSpeQ data into SmartPlant Instrumentation for the 
very first time, select Insert new data. 

 If you previously imported Masoneilan ValSpeQ data into SmartPlant Instrumentation and 
you only need to update the existing sizing data in the target database, clear Insert new 
data. 

5. Do one of the following: 
 Select Run link group automatically to select a particular link group and run all the links 

in it automatically. 
 Clear Run link group automatically if you need to modify any of the links before 

importing the data. 
6. On the Masoneilan dialog box, click OK. 
7. Do one of the following: 

 If you selected Run link group automatically, on the Select Link Group dialog box, 
which opens automatically, select the appropriate group of Masoneilan ValSpeQ links and 
click OK to start the import process. 
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 If you cleared Run link group automatically, after the Masoneilan dialog box 
minimizes, open the appropriate link in the Import Link window and then modify the field 

mapping as you require.  Then, start the import process by clicking  in the Import 
Link window. 

8. If notified that the link requires system codes, click OK in the message box, and then, do the 
following: 
a. On the Source System List dialog box, which opens automatically, select the 

Masoneilan system codes, which the Domain Administrator imported from the 
In_ctlog.db file. 

b. Click OK to continue the import process. 
  When running the first import session, the software prompts you to select the 

source system codes because, for each Masoneilan ValSpeQ import link, on the Source 
tab of the Link Properties dialog box, the Use system codes check box is selected. 

9. After performing the data import, open SmartPlant Instrumentation and examine the imported 
data in the Instrument Index, Process Data, and Specification modules. 

See Also 
Importing Masoneilan ValSpeQ Data (on page 409) 
 

Flowserve Performance! Interface 
The Flowserve Performance! interface allows you to exchange control valve process and sizing 
data between SmartPlant Instrumentation and the Flowserve Performance! application using 
ASCII delimited .csv files.  After exporting your control valve data from SmartPlant 
Instrumentation and performing all the desired calculations in Flowserve Performance!, you can 
import the calculation results back to SmartPlant Instrumentation where this data can be used in 
process data and specification sheets, reports, and other SmartPlant Instrumentation features 
such as browsers.  You can also print out the information as a standard ISA specification, the 
same way as you do it in Flowserve Performance!. 
 

Flow of Activities for Working with Flowserve Performance! 
1. Define a file or database with the data you want to import.  For details about supported data 

sources, see Database Platform Support. 
2. Export control valve data from SmartPlant Instrumentation to an ASCII file.  For details, see: 

 Prerequisites for Exporting Data to Flowserve Performance! (on page 412) 
 Exporting Flowserve Performance! Data (on page 412) 

3. Run Flowserve Performance! and do the following: 
a. Import the SmartPlant Instrumentation control valve data from the ASCII file 
b. Calculate and select the appropriate control valve in Flowserve Performance! 
c. Export the sizing data from Flowserve Performance! to an ASCII file 
For details, see your Flowserve Performance! User's Guide. 

4. In the Import Utility, run the Flowserve Performance! import links to import Flowserve 
Performance! sizing data. 

 The import links are retrieved from the In_ctlog.db file and are used to import sizing data 
from the ASCII files to the SmartPlant Instrumentation database.  For details, see: 
 Prerequisites for Importing Flowserve Performance! Data (on page 414) 
 Importing Flowserve Performance! Data (on page 415) 
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5. View and edit the imported sizing data, if required. 
 

Prerequisites for Exporting Data to Flowserve Performance! 
 Before being able to export data, the predefined import links for Flowserve 

Performance! must be available.  To make the links available, you need to import the appropriate 
system interfaces into SmartPlant Instrumentation from the Administration module (for details, see 
Import System Interfaces (on page 349)). 
Before you start exporting data, you need to enter the required process data (for example, Tag 
Name and Service) in the appropriate process data sheets.  Your choice of the process data 
parameter values will determine your subsequent selections of the valve sizing data such as Body 
Material and Bonnet. 
At this stage, you can also define process data parameters specific to the selected control valve 
(for example, Leakage).  (These parameters can be viewed in the Additional Properties window 
in the Process Data module.) 
Also, consider the following issues: 
 When exporting data to Flowserve Performance!, the SmartPlant Instrumentation export 

feature automatically converts the SmartPlant Instrumentation system and unit of measure 
codes to the appropriate system and unit of measure codes used in Flowserve Performance!, 
for example: °C in SmartPlant Instrumentation is converted to deg C in Flowserve 
Performance!.  However, since SmartPlant Instrumentation contains additional units of 
measure, some SmartPlant Instrumentation units of measure may not have parallel values in 
Flowserve Performance! and therefore will not be accessible in Flowserve Performance! for 
sizing calculations.  In this case an appropriate message is displayed and a note is added in 
the Error.log file (located in the same folder where you saved the ASCII file). 

 Fields in SmartPlant Instrumentation and in Flowserve Performance! differ in length and 
SmartPlant Instrumentation fields may be truncated if longer than the corresponding fields in 
Flowserve Performance!.  Therefore, you need to make sure that the truncated data does not 
contain sizing data which is required in Flowserve Performance!. 

 When exporting vapor pressure or critical pressure values, you must specify the units of 
measure of these quantities as absolute (A) and not gage (G) in the specification sheet. 

 

Exporting Flowserve Performance! Data 
You export SmartPlant Instrumentation process and calculation data to an ASCII command 
delimited file by using the SmartPlant Instrumentation export feature.  This file can later be 
imported into Flowserve Performance! where the data it contains is used to make sizing 
calculations and to select the appropriate valves.  The ASCII file contains the following 
information: 
 Fields that are required for sizing calculations, including line data 
 ISA format specification fields 
 Fields that contain export-only data (for example, revision data) 
 Fields that allow insertion of new data, when you import data from the ASCII file back to 

SmartPlant Instrumentation 
 During the export process, the 'U' character is added to the Flowserve Performance! 

unitnumber field string. 
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Export Flowserve Performance! Data 
  Before using this procedure, make sure you meet all the prerequisites.  For details, 

see Prerequisites for Exporting Data to Flowserve Performance! (on page 412). 
1. Open the SmartPlant Instrumentation Instrument Index module. 
2. Do one of the following to open an Instrument Index Standard Browser view: 

 Click . 
 Click Actions > Browse Index. 

3. In the browser view, select the tags whose control valve data you want to export to Flowserve 
Performance!.  To select more than one tag, hold down either the Ctrl key or the Shift key 
and click the desired fields. 

4. Click Tools > Interfaces > Flowserve Performance!. 
5. On the Export to Flowserve Performance! dialog box, enter data as follows: 

a. To select the appropriate Flowserve Performance! ASCII file with a .csv extension to 
which the SmartPlant Instrumentation control valve data will be exported, do one of the 
following: 

 In the File text box, type in the path and location of the Flowserve Performance! 
export file name. 

 Click Browse to navigate to the Flowserve Performance! file location. 
b. If you selected in the previous step to export to an existing ASCII file, do one of the 

following: 
 Select the Overwrite check box to overwrite the existing ASCII file. 
 Clear the Overwrite check box to keep the existing ASCII file.  In this case, if you 

enter an existing file in the File Name data field, you will be prompted to confirm the 
overwrite. 

c. Under Export for, select the desired specification to be used for the exported data, from 
either: 

 Spec#1 
 Spec#71 

d. To select the level on which you want to export the SmartPlant Instrumentation data to 
Flowserve Performance!, do one of the following: 

 Click Plant to export all the control valve tags and their data belonging to the current 
plant. 

 Click Unit to export all the control valve tags and their data belonging to the current 
unit. 

 Click Filter to export only the control valve tags and their data that comply with the 
filter parameters that you have set for the current Instrument Index Standard Browser 
view. 

 Click Selected tags to export only the tags and their data that you selected in the 
Instrument Index Standard Browser view (see step 3 in this procedure). 

  If you select to export selected tags, make sure you select the appropriate 
tags before clicking OK on the Export to Flowserve Performance! dialog box. 

e. Under Use field length from, do one of the following: 
 Click SmartPlant Instrumentation to truncate the exported fields to match the 

lengths indicated in the SmartPlant Instrumentation database. 
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 Click Performance to truncate the exported fields to match the lengths indicated in 
the Performance field table. 

6. Click OK to start the export process. 
  If the export process is successful, an appropriate message is displayed, notifying you 

that the Log file is empty. 
  Failing to convert units of measure will generate an error message.  This means 

that the associated data was exported without the required units of measure (that is, the unit 
of measure fields in Flowserve Performance! will be empty).  In this case, you should select 
the desired units of measure manually in Flowserve Performance!. 

7. On completion of the export process, click Log File to open the Export.log file, located in the 
same folder where you exported the ASCII file, where you can view any errors that occurred 
during the export process. 

8. Click Close to close the Export to Flowserve Performance! dialog box and return to the 
browser view. 

 

Prerequisites for Importing Flowserve Performance! Data 
This topic lists and describes all the prerequisites you must meet before importing Flowserve 
Performance! data into SmartPlant Instrumentation.  In addition to Flowserve 
Performance!-specific prerequisites, make sure you have configured your ODBC data source (see 
Configure ODBC Data Source for DBF Files)and that you have completed the general 
prerequisites (for details, see General Import Prerequisites). 

 Before being able to import data, the predefined import links for Flowserve 
Performance! must be available.  To make the links available, you need to import the appropriate 
system interfaces into SmartPlant Instrumentation from the Administration module (for details, see 
Import System Interfaces (on page 349)). 
Ensure that you have performed the following prerequisite actions: 
 Create target instruments with Control Valve as the instrument type, assign process data 

sheets to these instruments, and make sure you clear the process data in these sheets. 
 In the Specifications module, restore the library form 71 Flowserve Control Valve.  For 

details see Restore Library Forms (on page 228).  Flowserve Performance! data that you 
import will appear in control valve specifications based either on form 71 or form 1, which you 
do not need to restore. 

 For forms 1 and 71, prepare source ASCII files with .csv extensions and name them as 
desired.  The Import Utility uses these files to identify the Flowserve Performance! import 
source for control valve specifications based on the appropriate forms. 

 Clear process data in process data sheets associated with the target control valves. 
 Also note the following: 

 Make sure that your ODBC profile is named VUE1. For details on how to define a new ODBC 
profile, see Configure ODBC Data Source for Text Files. 

 Due to the Unicode technology, check the system codes and make sure that you have 
correctly adapted all the system codes and the units of measure. For details, see System 
Codes. 

 Prior to running your import link, make sure that you have selected the appropriate source 
system. In Import Manager, click Code > Source System List and then select the source 
system that you require. 
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 For all the import links that contain references to the Control Valve table, note that the Control 
Valve table has two fields that deal with similar data, CV_VALVE_TYPE and 
CV_VALVE_TYPE_ID. Both of these fields are supported by the Specifications module. 
However, only the CV_VALVE_TYPE_ID field is used in the Calculations module. Therefore, if 
you want the imported control valve data to be linked to calculations, make sure that you map 
the CV_VALVE_TYPE_ID field in the appropriate import links. Note that there is no system 
code adaptation for this field since this field is referenced from another table. 

 
 

Importing Flowserve Performance! Data 
The Flowserve Performance! interface enables you to import valve sizing data for 
Flowserve-Valtek, Flowserve-Kammer, and Flowserve-Sereg control valves.   After the Domain 
Administrator imports four Flowserve Performance! link groups from the In_ctlog.db file using the 
Administration module options, the groups appear in the Link Explorer in the Import 
Utility.  These links have predefined mapping which you may need to modify as you require.  You 
cannot change the import method or table/module assignment of these links.  It is possible to 
restore deleted Flowserve Performance! links by re-importing the link group from the In_ctlog.db 
file.  Note, however, that to restore deleted links, you must first rename the Flowserve 
Performance! links or group or delete the entire group. 
Also, when retrieving the Flowserve Performance! link group from the In_ctlog.db file, the software 
also retrieves the system codes and unit of measure codes.  These codes are already adapted to 
SmartPlant Instrumentation, that is, every source code value in Flowserve Performance! is 
associated with its appropriate target value in SmartPlant Instrumentation. 
SmartPlant Instrumentation features a standard ISA form which you can use to print out sizing 
data imported from Flowserve Performance! as an ISA specification.  This specification is based 
on library form 71.  The specification printout is identical to the one generated by Flowserve 
Performance!, yet retains the SmartPlant Instrumentation revision system.  Alternatively, you can 
use library form 1. 
It is possible to run all the Flowserve Performance! group links automatically in order of their 
appearance.  Advanced users can perform a manual import process which allows you to carry out 
a step-by-step procedure.  Importing data this way enables you to view and modify the default 
import parameters and link settings. 
The following links are available in the link Flowserve Performance! link groups retrieved from the 
In_ctlog.db file: 
 Performance1 or Performance71 - per module - Index — Allows you to import the 

appropriate sizing data into the Instrument Index module, including the UDF_COMPONENT 
table, for specifications based on Form 1 or 71. 

 Performance1 or Performance71 - per module - PD/Calcs — Allows you to import the 
appropriate sizing data into the Process Data module for specifications based on Form 1 or 
71. 

 Performance1 or Performance71 - per table - Specification Data — Allows you to import 
data into the SPEC_SHEET_DATA table. 

 Performance1 or Performance71 - per table - Add Spec 1 — Allows you to import data into 
the ADD_SPEC1 table. 
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Import Flowserve Performance! Data 
Use this procedure to import Flowserve Performance! sizing and specification data from the ASCII 
file you previously exported from Flowserve Performance!.  You can use this procedure when 
importing Flowserve Performance! data whether for the first time or after a previous import. 

 
 Before using this procedure, make sure you meet all the prerequisites.  For details, see 

Prerequisites for Importing Flowserve Performance! Data (on page 414). 
 When importing Flowserve Performance! data, you must always use the Flowserve 

Performance! interface to connect to the source data files before you can run the links from the 
Link Explorer.  You cannot create and run links outside of the interface. 

1. Do one of the following: 

 On the Link Explorer menu bar, click . 
 Click Options > Flowserve Performance. 

2. On the Flowserve Performance dialog box, do one of the following: 
 If you want to import data to control valve specifications based on standard form 1 only, 

beside Source file for Spec #1, click Browse and select the .csv ASCII file containing 
the appropriate data exported from Flowserve Performance!. 

 If you want to import data to control valve specifications based on special form 71 
only, Source file for Spec #71, click Browse and select the .csv ASCII file containing the 
appropriate data exported from Flowserve Performance!. 

 If you want to import data to control valve specifications based on forms 1 and 71, specify 
both source files. 
 Spec form 71 is a SmartPlant Instrumentation library form designed for printing out sizing 

data imported from Flowserve Performance! as an ISA specification.  The specification 
printout is identical to the one generated by Flowserve Performance!, yet retains the 
SmartPlant Instrumentation revision system. 

3. Click Open to display the file name and path on the Flowserve Performance dialog box. 
4. Do one of the following: 

 If you are importing Flowserve Performance! data into SmartPlant Instrumentation for the 
very first time, select Insert new data. 

 If you previously imported Flowserve Performance! data into SmartPlant Instrumentation 
and you only need to update the existing sizing data in the target database, clear Insert 
new data. 

5. Do one of the following: 
 Select Run link group automatically to select a particular link group and run all the links 

in it automatically. 
 Clear Run link group automatically if you need to modify any of the links before 

importing the data. 
6. On the Flowserve Performance dialog box, click OK. 
7. Do one of the following: 

 If you selected Run link group automatically, on the Select Link Group dialog box, 
which opens automatically, select the required group of Flowserve Performance! links 
and click OK to start the import process. 
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 If you cleared Run link group automatically, after the Flowserve Performance dialog 
box minimizes, open the appropriate link in the Import Link window and then modify the 

field mapping as you require.  After that, start the import process by clicking  in the 
Import Link window. 

8. If notified that the link requires system codes, click OK in the message box, and then, do the 
following: 
a. On the Source System List dialog box, which opens automatically, select the 

Performance system codes, which the Domain Administrator imported from the 
In_ctlog.db file. 

b. Click OK to continue the import process. 
 When running the first import session, the software prompts you to select the source 

system codes because, for each Flowserve Performance! import link, on the Source tab of 
the Link Properties dialog box, the Use system codes check box is selected. 

9. After performing the data import, open SmartPlant Instrumentation and examine the imported 
data in the Instrument Index, Process Data, and Specification modules. 

 
 

Flowserve Performance Dialog Box 
This dialog box allows you to update the SmartPlant Instrumentation database with data from 
Flowserve Performance files. 
Select source for spec #1 — Type the path and filename of the .csv file containing the spec #1 
source or click Browse to navigate to the .csv file. 
Select source for spec #71 — Type the path and filename of the .csv file containing the spec #71 
source or click Browse to navigate to the .csv file. 
Insert new data — Select this check box to enable new data insertion during the import 
process.  Clearing the check box results in the rejection of all new source tags during the import 
process. 
Run link group automatically — Select this option to run the links in the groups automatically 
without displaying the links in the Import Link window after clicking OK. 
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S E C T I O N  3 4  

SmartPlant integration standardizes and improves the communication among the various 
authoring tools you use in the course of designing, constructing, and operating a 
plant.  SmartPlant integration manages data exchange among these authoring tools, which 
enables sharing and re-use of plant information throughout the plant lifecycle.  SmartPlant 
Foundation acts as a repository for data and a medium through which information is shared 
among other tools, such as SmartPlant Electrical, SmartPlant P&ID, and Aspen . 
Most of the commands that provide access to SmartPlant integration functionality exist in the 
common user interface available on the SmartPlant menu in SmartPlant Instrumentation. 
The following graphic displays what SmartPlant Instrumentation publishes and retrieves and 
shows the flow of data and the different types of data. 

 
SmartPlant Instrumentation interacts with SmartPlant Foundation by correlating items between 
the plant database and the SmartPlant Foundation database, retrieving such documents as 
Cabinets, Electrical Signals, P&IDs, and the like from SmartPlant.  Also, SmartPlant 
Instrumentation creates a set of tasks in the To Do List that you can run to update the plant 
database.  In SmartPlant Instrumentation, you can also use the SmartPlant menu to publish 
documents and retrieve data, access the SmartPlant Foundation Web Portal in order to browse 
data, and subscribe to change notifications and compare documents. 

Working with SmartPlant Integration 
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 You can only use the SmartPlant menu commands after your plant is registered. 

Registering Tools 
Before you can publish and retrieve information from any of the authoring tools, you must register 
each plant in SmartPlant Instrumentation with a SmartPlant Foundation database.  The 
connection allows SmartPlant Instrumentation to use the SmartPlant integration commands.  A 
SmartPlant Instrumentation Domain Administrator typically performs the registration. 
The software maps a plant and all its projects to a single SmartPlant Foundation URL, which 
points to one, and only one, SmartPlant Foundation plant database and its projects.  When you 
use the Register command in any of the authoring tools, you are registering an authoring tool 
plant with a SmartPlant Foundation URL and plant that you specify. 
The Domain Administrator must register each plant in the authoring tool once; this action takes 
place in the Administration module.  After the plant is registered, you can publish and retrieve 
documents. 

 Tool registration information is not upgraded in SmartPlant Foundation; therefore, 
each tool must re-register with SmartPlant Foundation after upgrading SmartPlant 
Foundation.  Since it is not possible to re-register a SmartPlant Instrumentation plant using the 
interface options, if you must re-register a SmartPlant Instrumentation plant, contact Intergraph 
Customer Support. 
 

Access the SmartPlant Foundation Web Client 
 Click SmartPlant > Browser. 

 
 This command is available only if the active plant has been registered.  For more information, 

see Configuring SmartPlant Instrumentation for Integration  in the Administration User's 
Guide, under SmartPlant Integration and Item Registry. 

 From the SmartPlant Foundation Web Client, you can perform a number of tasks, such as 
publishing or retrieving documents, comparing documents, subscribing to document changes, 
and so forth. Many of these tasks can be performed from the authoring tools, such as 
SmartPlant P&ID or SmartPlant Electrical, but the Web Client provides unique access to other 
features such as the Web Client To Do List and search capabilities. 

 

Updating SmartPlant Information in Title Blocks 
Update Title Block is a SmartPlant Foundation add-in that allows you to update published 
SmartPlant Instrumentation reports to the latest revisions and to include issue data in the custom 
title blocks.  Also, the add-in converts the published reports with their title blocks from SmartPlant 
Instrumentation native format (.brw, .ssf, and .spd files) to .pdf files. 
Prior to running the Update Title Block add-in, you need to configure your custom title blocks so 
that they meet the requirements for integration reports.  For more information, see Title Block 
Requirements for Integration Reports (on page 421). 
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After you have configured your custom title blocks, you need to install the Update Title Block 
Component.  This component contains the .dll file that enables the inclusion of issue data in your 
custom title blocks in native SmartPlant Instrumentation format and the conversion of reports to 
.pdf files.  For more information, see Install the Update Title Block Component for SmartPlant 
Instrumentation (on page 423). 

 
 For the .brw, .ssf, and .spd file types, SmartPlant Foundation uses the component address 

(ProgID): SPITitleBlock.TitleBlockInfo 
 These file types are already configured in the delivered database dump files. 

 
 

Title Block Requirements for Integration Reports 
The title blocks in the reports used for integration contain macros that specify issue data.  You can 
generate these reports either in SmartPlant Instrumentation native format (.brw, .ssf. or spd) or 
enhanced report (.sma) format.  For both of these formats, there are shipped files that you can 
use that include the correct formatting and data for the reports.  There are also certain 
requirements that you need to follow if you intend to customize your own reports. 

PowerSoft Reports 
The title block files for the reports in .psr format are in the location <SmartPlant Instrumentation 
installation folder>\PSR\ and the available files are as follows: 
 A3tall_inchunit.psr 
 A3tall_pbunit.psr 
 A3wideborder_inchunit.psr 
 A3wideborder_pbunit.psr 
 A4tall_inch.psr 
 A4tall_pbunit.psr 
 A4tall_pbunit_general.psr 
 A4widerborder_inchunit.psr 
 A4widerborder_pbunit.psr 

If you are creating your own custom reports in .psr format in which you want to include issue data, 
you must create a custom title block and add macros as shown in the following table. 

Section Heading Macro Name 

ISSUE issueno_x 

REV issuedrevision_x 

MATERIAL OR JOB SPEC materialorjobspec_x 

BID (DATE ISSUED FOR) bid_x 

FAB (DATE ISSUED FOR) fabrication_x 

CONST (DATE ISSUED FOR) construction_x 

REF (DATE ISSUED FOR) reference_x 

SITE sitename 

SITE LOCATION sitelocation 
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Section Heading Macro Name 

DIVISION divisionname 

DIVISION LOCATION divisionlocation 
For the macro names, 'x' represents an integer used to specify the sequence, for example, 
issueno_1, issueno_2, and so forth. 

Enhanced Reports 
The title blocks that use the .sma format are designed to be used by all the tools that communicate 
in an integrated environment; however, if you use them in SmartPlant Instrumentation as 
delivered, parts of the drawing may overlap the margins of the drawing area.  For this reason, you 
need to set values of the working area margins for any templates that you intend to use for 
generating reports in an integrated environment.  To prepare the templates, you define the 
settings under Preferences > Enhanced Reports (for all layouts of a particular report type) or for 
a specific layout as desired. 
The template files are installed on the SmartPlant Instrumentation machine.  The default location 
for enhanced report templates for the reports used in an integrated environment is: 
<SmartPlant Instrumentation installation folder>\RAD\Template\Generic\*.sma 
The title block files are installed on the SmartPlant Instrumentation machine.  The default location 
for enhanced report title blocks for the reports used in an integrated environment is: 
<SmartPlant Instrumentation installation folder>\RAD\Template\Generic\TitleBlocks\*.sym 
The following settings represent the minimum values required for the working area margins: 

Title Block Left Right Top Bottom 

D Wide 0.44 0.3 0.3 0 

C Wide 0.7 0.3 0.3 0 

B Wide 0.3 0.3 0.3 0 

A1 Wide 0.7 0.3 0.5 0 

B Tall 0 0 0.3 0 

A3 Tall 0 0 0.3 0 

A Wide 0 0 0.3 0 

A2 Wide 0.7 0.2 0.5 0 

A3 Wide 0 0 0.3 0 

A4 Wide 0 0 0.4 0 
 To place issue data on other title blocks for enhanced reports, use the SmartPlant 

Instrumentation Place Drawing Property Label command in the Enhanced Report Utility.  For 
more information, see Enhanced Report Utility User's Guide > Working with Templates and Title 
Blocks > Place Property Labels on a Drawing Sheet. 
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Associating a Custom Title Block with SmartPlant 
Instrumentation 

After you have finished creating a report title block and customized it in InfoMaker to fit your 
needs, you need to associate it with SmartPlant Instrumentation so that the Domain Administrator 
can assign it to the appropriate reports.  If needed, you can edit the associated title block 
properties by defining the headers for revision custom fields and defining the headers for the 
drawing records. 

 There are title blocks that come shipped with SmartPlant Instrumentation.  For the list of 
available title blocks and their descriptions, see Title Block Descriptions in the Administration 
User's Guide, under Domain and Project Administration, Report Management. 
 

Open a Custom Title Block 
1. In the main SmartPlant Instrumentation window, click Tools > Title Blocks. 
2. On the Title Blocks dialog box, click New to open the Title Block Properties dialog box. 
3. Do one of the following: 

 Navigate to the .psr file that you have created containing the new custom title block, and 
select this file. 

 Navigate to the Default TB with IN Units.psr file, or the Default TB with PB Units.psr 
file. 

4. Click Open. 
5. On the Title Block Properties dialog box, do the following if required: 

a. Under Revision custom field headers, in the Header column, type the name for each 
custom field. 

b. In the Title block name field, type the name that you have selected for the title block. 
c. Under Document custom field headers, in the Header column, type the name for each 

custom field. 
 If you want to modify the number of revisions of custom title blocks, you need to add 

more revision rows and create appropriate macros in InfoMaker.  The Revision rows box 
displays the number of revision rows that you have customized for your title block. 

6. Click OK to save the edited title block and add it to the inventory of title blocks in SmartPlant 
Instrumentation. 

7. On the Title Blocks dialog box, click Close to return to the main window. 
 

Install the Update Title Block Component for SmartPlant 
Instrumentation 
The SmartPlant Instrumentation title block component is only required if you are using SmartPlant 
Instrumentation in an integrated environment.  The SmartPlant Instrumentation title block 
component software must be installed on the same computer as the SmartPlant Foundation Title 
Block component.  These components are usually installed on the SmartPlant Foundation server, 
but may be installed on another server. 
1. Insert the SmartPlant Foundation installation media into the DVD drive.  If the installation 

does not start automatically, double-click setup.exe on the CD. 
2. Click SmartPlant Software in the SmartPlant Foundation Installation window. 
3. Click SmartPlant Instrumentation Title Block Installation. 
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 If you have installed the SmartPlant Instrumentation Title Block component previously, 
the software prompts you to modify, repair, or remove the older version of the 
component.  After you uninstall the older version, click SmartPlant Instrumentation Title 
Block Installation again in the SmartPlant Foundation Installation window. 

4. Click Next. 
5. To accept the default installation location for the SmartPlant Instrumentation Title Block 

component, click Next. 
 If you want to change the installation location, click Browse and navigate to the new 

folder.  Then, click Next. 
6. Click Finish. 

 
 If you are working on a 64-bit computer, to enable PDF generation, create a new local printer 

port with a custom name and then assign the PDF printer (SmartPlant PDF Converter) to the 
port.  For details, see Create a New Local Printer Port (64-bit server only) (on page 424). 

 The driver used for printing the PDF files, SmartPlant PDF Converter 401, is included in the 
SmartPlant  installation. 

 

Configure PDF Generator Settings 
1. Open a command prompt window. 
2. Execute the following command to run Updatectb and set PDF printer configuration settings: 

updatectb.exe /s 
 If necessary, change to or include the full path to Updatectb.exe to ensure you are 

executing the correct version. By default, it is installed at C:\Program 
Files\SmartPlant\Instrumentation\Title Block Component. 

3. On the PDF Generator Settings window, select the correct paper size for PDF output. 

 
4. Click OK. 
 

Create a New Local Printer Port (64-bit server only) 
 If your SmartPlant Foundation server is installed on a 64-bit edition of Windows, perform 

the following procedure. This procedure is not necessary on 32-bit editions of Windows. 
1. Click Start > Printers and Faxes. 
2. Open the properties window for SmartPlant PDF Converter. 

 The printer named SmartPlant PDF Converter is created automatically when 
SmartPlant Instrumentation Title Block Component is installed. 

3. Click the Ports tab. 
4. Click Add Port. 
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5. On the Printer Ports dialog box, select the Local Port, and then click New Port from the list. 
6. Type a port name in the Enter a port name box and click OK. 

 You can enter any descriptive name, such as AmyuniPDF. 
7. On the Printer Ports dialog box, click Close. 
8. On the Ports window, check the new port in the list, if it is not already checked, and click 

Apply. 
9. Click OK to close the printer properties window. 
 

Specify the Full Path to Updatectb.exe 
 To ensure that the PDF generation for the SmartPlant Instrumentation file types (.brw, .ssf, 

.spd) uses the correct version of the Title Block Component, it may be necessary to specify the full 
path to Updatectb.exe on the application server. 
1. Log into SmartPlant Foundation Desktop Client as a user with Engineer and System 

Administration roles. 
2. Click Find > Administration > File Type. 
3. On the Find File Type dialog box, type * into the Enter Name box and click OK. 
4. Select the file type for which you want to enter a full path specification. 
5. Click the right mouse button and select Edit Relationship from the menu. 
6. Click Maintain Attributes for the PDF File object. 

 
7. On the Update dialog box, edit the command-line string in the Alternate rendition 

application box so the value includes the full path.  For example: “C:\Program 
Files\SmartPlant\Instrumentation\Title Block Component\updatectb.exe” obj.Name -dir 
$OUTPUTFILENAME 

 For these file types, the string will already be filled in as updatectb.exe obj.Name 
$OUTPUTFILENAME 
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8. Click OK. 
9. Click OK to close the Edit Relationships dialog box. 
 

Schema Mapping 
This section describes the assumptions, rules, and limitations imposed by the SmartPlant 
Instrumentation adapter on schema mapping. 
This section describes the structure of the tool schema and how it is used by the authoring tool 
SmartPlant integration adapter in support of the publish and retrieve operations.  This topic does 
not provide a list of the classes, properties, or enumerated lists (select lists) that are mapped by 
the delivered SmartPlant Instrumentation tool schema.  You can obtain this information by 
viewing the tool schema directly.  This set of topics does not describe the user interface of the 
Schema Editor. 
Before modifying the mapping for SmartPlant Instrumentation, you must understand: 
 The SmartPlant Instrumentation software 
 The SmartPlant Instrumentation data model 
 The delivered mapping for SmartPlant Instrumentation 
 How the delivered mapping for SmartPlant Instrumentation works 
 SmartPlant schema modeling 
 The Schema Editor 
 The To Do List feature of SmartPlant Instrumentation 

In the topics that describe schema mapping, the following terms are frequently referenced: 
 Tool schema — Defines the SmartPlant Instrumentation objects to be published or retrieved 

and how they map to objects in the SmartPlant schema.  The tool map schema implements 
mapping between the objects in the SmartPlant Instrumentation data model and the objects in 
the SmartPlant schema.  Users who customize either the SmartPlant Instrumentation data 
model or the SmartPlant schema may also need to customize the mapping contained in the 
tool schema. 
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 SmartPlant schema — Defines the SmartPlant integration data model. 
 Adapter — The SmartPlant Instrumentation code module that supports the SmartPlant 

integration commands. 
When you publish SmartPlant Instrumentation data, the SmartPlant integration adapter extracts 
data from the SmartPlant Instrumentation database and converts it into a set of objects and 
relationships that are compatible with the SmartPlant schema.  These objects and relationships 
are defined in an .xml file, which is sent to SmartPlant Foundation for further processing.  For 
SmartPlant Instrumentation, the name of this file is INtoolsMap.xml, and it must be located in the 
folder specified in the Path for SmartPlant XML files box of the Domain Definition window. 

See Also 
Workflow for Extending the Schema (on page 441) 
Define a Schema for SmartPlant Instrumentation (on page 465) 
Export a New Schema Configuration (on page 467) 
 

General Information About Schema Mapping 
This topic provides general information about the mapping in SmartPlant Instrumentation. 

SmartPlant Instrumentation Adapter 
Each authoring tool has an adapter that processes information during the publish and retrieve 
operations.  One of the adapter's functions is to map information between SmartPlant Integration 
and the particular authoring tool.  The SmartPlant Instrumentation adapter is a component that 
belongs to SmartPlant Instrumentation and requires installation of SmartPlant Instrumentation 
Version 2009 on one of the following database platforms: 
 Oracle 10g 
 SQL Server 2005 

Any communication between SmartPlant Foundation and SmartPlant Instrumentation is 
performed via this adapter, which sends information to SmartPlant Integration through the 
Common UI where the user is shown the appropriate user interface and data available. 
The adapter does not handle tool schema files directly, but uses them indirectly. The tool schema 
files are used to define the retrieve map file, which is then used by the adapter. Direct use of the 
schema files would mean that the adapter accessed them directly to do its work.  Both retrieve 
and publish operations only work through map files. 

Mapping Configuration 
The SmartPlant Instrumentation adapter uses the tool schema map file and the Schema Editor, 
delivered with the SmartPlant Schema Component, to perform mapping between the SmartPlant 
Instrumentation object structure and the structure of objects in SmartPlant integration.  The map 
file is installed with SmartPlant Instrumentation Setup.  This file includes all objects that are 
mapped for SmartPlant integration (not the entire set of objects in SmartPlant Instrumentation, nor 
all properties, but only those that are relevant for other applications that use SmartPlant 
Integration). 
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Tool Schema Location 
The name of the SmartPlant Instrumentation tool schema files are: INtoolsMap.xml, 
ContextMap.xml, and NamingConventionMap.xml.  SmartPlant Instrumentation uses these files 
for all types of published and retrieved documents.  They are installed by default in the path 
<SmartPlant Instrumentation home folder>\XML\ and should be treated as installation files.  If you 
move or copy these .xml files to a different folder, the System Administrator can specify the 
location in the Administration module, Domain Definition window, by typing it in the Path for 
SmartPlant XML files box.  This allows you to specify a different tool schema for each domain. 
 

SmartPlant Instrumentation Mapping Examples 
The sections that follow provide mapping examples for SmartPlant Instrumentation. For more 
information and mapping examples, see the SmartPlant Mapping User's Guide. 
 

SmartPlant Instrumentation Example: Mapping New Enumerated 
List Entries Starting in the Tool 
The following topic provides an example of adding and defining mapping for a new enumerated list 
entry for the Instrument Status list starting in the SmartPlant Instrumentation. 

Before You Begin 
1. Make a backup of the SmartPlant Foundation site database and any vaults for the site. 
2. Make a backup of the SmartPlant Instrumentation database and the INtoolsMap.xml file 

located in the SmartPlant resources directory. 

Create the List Entry in the Instrument Status Table 
1. Click Start > All Programs > Intergraph SmartPlant Instrumentation > SmartPlant 

Instrumentation. 
2. Log on to SmartPlant Instrumentation 
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3. In the Open window, click the appropriate plant, then click Unit. 

 
4. Close Domain Explorer. 
5. Click Modules > Instrument Index 
6. In the Instrument Index dialog box, click Tables > Instrument Statuses. 
7. In the Instrument Statuses dialog box, click New to define the new enumerated list item. 
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8. In the Instrument Statuses dialog box, type PRC as the prefix and Preconstruction as the 
description. 

 
9. To verify the new Instrument Status has been added, click Reports > Tables > Instrument 

Statuses. The report appears. 
10. Click Save As to save a copy of the report. 
11. In the Save As dialog box, click Original, then click OK. 
12. Save the file with a .CSV extension. 
13. Open the report in Microsoft Excel. 
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14. Find PRC in column A and Preconstruction in column C. A number appears in column B. 

 
15. Close Microsoft Excel and SmartPlant Instrumentation. 

Load the SmartPlant Instrumentation Tool Map Schema 
1. In the Desktop Client, check out the SmartPlant schema CMF file and launch the Schema 

Editor. 
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2. In the Set Active Configurations dialog box, select the schema version or versions that you 
want your changes to apply to, and click OK. 

 
 

3. In the Schema Editor, click File > SmartPlant > Edit Engineering Tool Options and select 
INtools in the list of authoring tools to load the INtools tool map schema. 

4. Under Startup options, select the Load map schema. 
 Connect to Application Schema is checked by default. 

5. Click Finish. 
6. In the Synchronize dialog box, select the appropriate action in the <Tool> Database or <Tool 

Map Schema Path> row to update inconsistencies between the tool metadata and tool map 
schema, and click OK. Default actions appear in blue in the appropriate column and row for 
each difference. 

 
 Default actions appear in blue in the appropriate column and row for each difference. 
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Add the New Status Entry to the SmartPlant Schema 
1. In the Map Environment, expand SmartPlant Instrumentation > Loaded Map Schemas > 

INtools Tool Schema. 
2. Expand the Map Enumerated Lists node, and right-click Construction Statuses. 

 Construction Statuses is called Instrument Status in SmartPlant Instrumentation. 
3. Click Edit Construction Statuses. 
4. Click the Publish tab. 
5. In the SmartPlant schema tree view on the left side of the Publish tab, click PRC, then on the 

right side, click Preconstruction. 

 
6. Click Map . 
7. Click OK. 

Define the Mapping to Retrieve Construction Statuses 
1. Click the Retrieve tab. 

 
2. In the SmartPlant schema tree view on the left side of the Retrieve tab, click PRC, then on the 

right side, click Preconstruction. 

3. Click Map . 
4. Click OK. 
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Save the Tool Map Schema and Schema Extensions File 
 Click File > Save > All Modified Files to save the SmartPlant schema extensions and the tool 

map schema. For some tools, saving the tool map schema also saves changes to the tool 
metadata database. 

 
 When you close the Schema Editor, the software prompts you to save your connection 

information, user interface options, and loaded tool map schemas to a session file. Click Yes 
in the message box to save the session file. 

 If you extend the SmartPlant schema, you must load the changes into the SmartPlant 
Foundation database. For more information, see the SmartPlant Schema Editor User's Guide. 

 

SmartPlant Instrumentation Example: Mapping a New String 
Property Starting in the Tool 
The following topic provides an example of adding and defining mapping for a simple string 
property called SystemCode for SmartPlant Instrumentation. 

Before You Begin 
1. Make a backup of the SmartPlant Foundation site database and any vaults for the site. 
2. Make a backup of the SmartPlant Instrumentation database and the INtoolsMap.xml file 

located in the SmartPlant resources directory. 

Create the New SystemCode Property in SmartPlant Instrumentation Administration 
1. Click Start > All Programs > Intergraph SmartPlant Instrumentation > Administration. 
2. Log on to SmartPlant Instrumentation Administration. 
3. Click Domain Administrator, and then select the domain name from the list. 

 
4. Click Fields. 
5. In the Custom Fields dialog box, select the appropriate plant and item type. 
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6. In the first blank row, type the information for the SystemCode property, and click Apply. 

 
7. Click OK when the confirmation dialog box appears. 



Working with SmartPlant Integration 
 

 
436 SmartPlant Instrumentation Basic Engineering User's Guide 

 

8. In the Item Type list, select loop, and type the information for another SystemCode property. 

 
9. Click Apply, then click Close. 
10. Click File > Exit. 

Add the New SystemCode Property in SmartPlant Instrumentation 
1. Click Start > All Programs > Intergraph SmartPlant Instrumentation. 
2. Log on to SmartPlant Instrumentation. 

 If the Windows Authentication Login is enabled in SmartPlant Instrumentation 
Administration, you will not be prompted to log on. For more information about enabling 
Windows Authentication Login, see the SmartPlant Instrumentation User's Guide. 

3. Click Modules > Instrument Index. 
4. At the bottom of the Instrument Index Module dialog box, click Browser. 
5. In the Browser dialog box, click Manager. 
6. Under Browser Groups, click Instrument Index Standard Browser > Default View 
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7. Under Default View on the right, double-click Style. 

 
8. Under Browser Groups, expand Instrument Index Standard Browser > Default View, 

then select Style. 
9. In the Style list at the bottom of the dialog box, select SystemCode, then click Edit. 

 
10. For SystemCode, select the View check box. 

 
11. Click Save. 
12. Click Open View. Scroll to the left, SystemCode appears in the dialog box. 
13. Click File > Exit to exit SmartPlant Instrumentation. 

Launch Schema Editor and Load the SmartPlant Instrumentation Tool Map Schema 
1. In the Desktop Client, check out the SmartPlant schema CMF file and launch the Schema 

Editor. 
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2. In the Set Active Configurations dialog box, select the schema version or versions that you 
want your changes to apply to, and click OK. 

 
 

3. In the Schema Editor, click File > SmartPlant > Edit Engineering Tool Options and select 
INtools in the list of authoring tools to load the INtools tool map schema. 

4. Under Startup options, select the Load map schema. 

 
 Connect to Application Schema is checked by default. 
 The new enumerated list entry that you added in the authoring tool appears in the 

Synchronization dialog box to be added to the tool map schema file. 

 
5. Click OK in the Synchronize dialog box to update the tool map schema. 

Map the New Custom Property 
1. In the Map Environment, expand SmartPlant Instrumentation > Loaded Map Schemas > 

INtools Tool Schema. 
2. Expand the Map Classes and TEFPublish nodes. 
3. Right-click TEFRetrieve_PID Drawing_Instrument, and click Edit TEFRetrieve_PID 

Drawing_Instrument on the shortcut menu. 
4. In the Edit Map Class definition dialog box, click Retrieve from 

SmartPlantclass/interface. 
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5. Select IInlineInstrumentOcc and IInstrumentOcc from the list, and click OK. 

 
6. Click the Advanced tab. 
7. Click Realizes. 
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8. Select IInstrumentUDF from the list. Click OK. 

 
9. Click the Retrieve tab. 
10. Under Unmapped application properties, select SystemCode. 
11. Under Unmapped SmartPlant properties, select SystemCode. 

12. Click Map . 
13. Click OK. 

Save the Tool Map Schema and Schema Extensions File 
 Click File > Save > All Modified Files to save the SmartPlant schema extensions and the tool 

map schema. For some tools, saving the tool map schema also saves changes to the tool 
metadata database. 

 
 When you close the Schema Editor, the software prompts you to save your connection 

information, user interface options, and loaded tool map schemas to a session file. Click Yes 
in the message box to save the session file. 

 If you extend the SmartPlant schema, you must load the changes into the SmartPlant 
Foundation database. For more information, see the SmartPlant Schema Editor User's Guide. 
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Upgrading the SmartPlant Instrumentation Tool Schema for a 
New Software Version 

If you have previously customized the SmartPlant Instrumentation tool schema for a previous 
version, you will need to upgrade the latest INtoolsMap.xml file in order to preserve your custom 
changes. 

 Before removing the previous version of SmartPlant Instrumentation, be sure to back 
up your existing INtoolsMap.xml file so that you do not lose your custom changes.  The 
INtoolsMap.xml file is located in the path <SmartPlant Instrumentation home folder>\XML\. 
 

Upgrade the SmartPlant Instrumentation Tool Schema 
With this procedure, the software upgrades the IntoolsMap.xml file, including user customizations, 
with the latest version data from the files in the '<SmartPlant Instrumentation home 
folder>\XML\Backup' folder path and registers the schema version at the beginning of the 
IntoolsMap.xml file. 
1. In the SmartPlant Instrumentation Administration module, log on as Domain Administrator in 

the domain where you are going to work in an integrated environment. 
2. Click File > Domain Definition. 
3. On the Domain Definition window, select the desired domain. 

4. On the Module Toolbar, click Edit . 
5. Beside Path for SmartPlant XML files, click Browse to navigate to the location of the 

IntoolsMap.xml file containing your custom definitions. 
6. Click SmartPlant > Upgrade Schema. 

See Also 
Define a Schema for SmartPlant Instrumentation (on page 465) 
Export a New Schema Configuration (on page 467) 
 

Workflow for Extending the Schema 
When you need to extend the SmartPlant schema, such as when new properties or select list 
entries are added, you or an administrator must take steps to update the data in SmartPlant 
Instrumentation.  The overall steps include: 
1. Generate component schemas using the Schema Editor. 
2. Run the SmartPlant Instrumentation Schema Configuration Wizard to extend the 

configuration of the SmartPlant Instrumentation data model, which provides a view of your 
data. 
The wizard output is a schema hierarchy with the following structure: 
   Schema name 
      Document type 
          Object type (class) 
              Interface 
                  Properties 
The following example illustrates how the hierarchy is organized for two object types, 'Loop' 
and 'Instrument', both belonging to the document type 'InstrumentIndex': 
  TEFPublish(publish) 
     InstrumentIndex 
         Loop 
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             ILoop 
                 LOOP_NAME 
                 LOOP_SERV 
         Instrument 
             IInstrument 
                 CMPNT_NAME 
                 CMPNT_SERV 
For details of the procedure, see Define a Schema for SmartPlant Instrumentation (on 
page 465). 

3. Run the Export Schema Configuration Utility to create a new tool schema map file using the 
classes that you selected with the SmartPlant Instrumentation Schema Configuration 
Wizard.  For details of the procedure, see Export a New Schema Configuration (on 
page 467). 

 
 The tool schema class is identified by a unique name consisting of <schema 

name>_<document name>_<class>. 
 For SmartPlant Instrumentation, the source file is INtoolsMap.xml. 

4. Using the Schema Editor, open the newly-created tool map class and synchronize it with the 
SmartPlant Instrumentation tool schema.  For more information, see Synchronizing Schemas 
(on page 449). 

 To be able to publish data that includes the new classes, you need to rename the 
target .xml file to 'INtoolsMap.xml'. 
 

Modify the Tool Schema for a Custom Plant Hierarchy 
1. Create a hierarchy in SmartPlant Instrumentation that contains the same number of levels as 

the one defined in the SmartPlant Foundation custom hierarchy.  For details, see  Create a 
Plant Hierarchy in the Administration User's Guide, under Domain Administration, Plant 
Design and Structure. 

2. Modify the following information in the delivered INtoolsMap.xml file to map it to the levels in 
the example custom hierarchy. 

 
 The INtoolsMap.xml file is installed by default in the path <SmartPlant Instrumentation 

home folder>\XML\. 

INtoolsMap.xml File Level Mapped To  Custom Hierarchy Level 

TEFRetrieve_PBSDocument_Plant County Top level  

TEFRetrieve_PBSDocument_Area City & District  Intermediate levels 

TEFRetrieve_PBSDocument_Unit  Precinct Lowest level  
 The values in the Mapped To column are for this example only.  You should substitute 

the appropriate values for your hierarchy. 
 You will need to create new map classes ICity, IDistrict, and IPrecinct.  For details of the 

procedure, see Creating New Objects and Relationships in the Schema in the Schema 
Editor User's Guide. 

3. Launch Schema Editor. 
4. On the Workflows dialog box, click the Tool Schema tab. 
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5. Click Open. 

 
6. Navigate to the file path: Program Files > Common Files > Intergraph > EFSchema > 

EFSchema.xml. 
 The file may take some time to open. 
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7. Click Open to select the tool schema file. 

 
8. Navigate to the INtoolsMap.xml file. 
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9. Click View. 

 
10. On the View Tool Schema dialog box, from the Form list, select Tree/Table Horizontal, and 

then click OK. 
11. In the tree view, expand the SPMapClassDef node. 
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12. Scroll down to the TEFRetrieve_PBSDocument_Plant node. 

 
13. Right-click this SPMapClass and on the shortcut menu, click Edit 

INTL_TEFRetrieve_PBSDocument_Plant. 
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14. On the Edit Map Class Definition dialog box, under the Retrieve map section, clear the 
value IPlant and click the ellipsis button as shown: 

 
15. On the dialog box Possible ClassToMapClass\Classes for TEF 

Retrieve_PBSDocument_Plant, in the Search box, type iplant. 
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16. Select IPlant as shown and click OK. 

 
 The top level interface (IPlant in this example) cannot be renamed.  Therefore in the 

custom hierarchy, the top level will always be mapped to IPlant.  Consequently, the IPlant 
interface remains mapped to the IPlant interface (as shown in the graphic) and no mapping 
changes are required. 

17. Click OK to close the Edit Map Class Definition dialog box. 
18. Right-click the TEFRetrieve_PBSDocument_Area node, and on the shortcut menu, click the 

Edit option. 
19. On the Edit Map Class Definition dialog box, under the Retrieve map section, clear the 

value IFunctionalArea and click the ellipsis button. 
20. On the dialog box Possible ClassToMapClass\Classes for TEF 

Retrieve_PBSDocument_Area, map the intermediate level interface to ICity and IDistrict. 
21. Click OK to close the Edit Map Class Definition dialog box. 
22. Right-click the TEFRetrieve_PBSDocument_Unit node, and on the shortcut menu, click the 

Edit option. 
23. On the Edit Map Class Definition dialog box, under the Retrieve map section, clear the 

value IFunctionalUnit and click the ellipsis button. 
24. On the dialog box Possible ClassToMapClass\Classes for TEF 

Retrieve_PBSDocument_Unit, map the lowest level interface to IPrecinct. 
25. Click OK to close the Edit Map Class Definition dialog box. 
26. Click File > Save. 
27. Close the Schema Editor, and at the prompts to save the data and to load the changes to the 

SmartPlant Foundation Server, click Yes. 
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Synchronizing Schemas 
This section describes how to use the Schema Editor to synchronize the tool metadata (stored in 
the tool's database) and the map schema file (INtoolsMap.xml) when you define new properties 
for publishing or retrieving. 
You can begin the update by first adding a new property to the tool metadata and then 
synchronizing the map schema file to it, or you can first modify the map schema file and then 
synchronize the metadata with it. 
There is a special procedure for synchronizing newly-defined enumerated lists (select lists).  For 
details, see Synchronize an Enumerated List (on page 457). 

 For SmartPlant Instrumentation, new properties are created using custom fields. 
 You are not allowed to delete a property that you have already synchronized 

between the tool metadata and the map schema file because the software cannot determine 
whether data values exist for that property. 

See Also 
Workflow for Extending the Schema (on page 441) 
Define a Schema for SmartPlant Instrumentation (on page 465) 
Export a New Schema Configuration (on page 467) 
 

Synchronize the Map Schema File with the Tool Schema 
1. In the SmartPlant Instrumentation Administration module, log on as Domain Administrator in 

the domain defined for an integrated environment. 
2. Click Activities > Custom Fields. 
3. Select the plant that you have registered for integration. 
4. Select the item type appropriate for the property you want to add. 
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5. Add the desired property name in the Definition column of a vacant custom field (with field 
type Char). 

 
6. Click Apply and then click Close. 
7. Click Start > Intergraph SmartPlant Foundation > SmartPlant Schema Component > 

SmartPlant Schema Editor. 
8. In the Workflows window, click the Application Metadata tab. 
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9. Connect to the SmartPlant Foundation database as shown. 

 
10. On the SmartPlant Foundation URL page of the SmartPlant Registration Wizard, type the 

node name and virtual directory of the SmartPlant Foundation database where you registered 
your plant.  Use the following format: http://<SPFServer>/<VirtualDirectory>. 
For example: 
http://<SPFServer>/SPFASP 

 
 Replace <SPFServer> with the name of your SmartPlant Foundation Web server. 
 Replace <VirtualDirectory> with the name of the virtual directory for the SmartPlant 

Foundation Web Client.  By default, the virtual directory for the first instance of the Web 
Client that you install is SPFASP.  However, if you install multiple instances of the Web 
Client to connect to multiple databases, the virtual directory name may be different. 

11. Click Next. 
12. On the SmartPlant Foundation Plant page, select from the Plant name list the SmartPlant 

Foundation plant in which you want to synchronize your data. 
13. Click Next. 
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14. On the Engineering Application Options page, select from the Engineering 
application/map schema list the schema for the tool that you want to synchronize. 

15. Under Startup options, select the Load map schema check box. 
 For SmartPlant Instrumentation, the software automatically selects the Connect to 

application schema check box. 
16. If desired, select the Automatically synchronize schemas check box. 

 You can select more than one schema from the Engineering application/map 
schema list (if available) and specify the startup options.  In this case, the software will load 
the map schema for each application and perform connection and synchronization as 
specified. 

17. Click Finish to complete the connection. 
The Synchronize window opens with all the properties selected by default for synchronizing 
in the map schema file (located in this example in the path C:\Program 
Files\SmartPlant\Instrumentation\XML\INtoolsMap.xml). 

 
18. Do one of the following: 

 Leave the properties selected where you want the software to synchronize the map 
schema file by updating it with the value from the application database. 
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 Select the properties in the SPI Database column where you want the software to update 
the database with the current value from the map schema file. 

 
19. Click OK to synchronize the data and open the Map Environment window. 
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20. Expand the SmartPlant Instrumentation node by clicking the  icons. 

 
 The remainder of this procedure describes an example where you are going to map the 

custom fields that you defined to a map class for retrieving instruments from a SmartPlant 
P&ID drawing.  The actual map class that you select depends on how you want to map the 
fields that you defined, and on whether you choose to publish or retrieve the data. 

21. Under the Map Classes node, scroll down to TEFRetrieve_PIDDrawing_Instrument (the 
map class that defines instrument retrieval from SmartPlant P&ID drawings) and right-click 
the map class. 

22. On the shortcut menu, click the Edit option as shown. 
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23. In the Edit Map Class Definition window, click the Retrieve tab. 

 
24. From the Unmapped application properties pane, scroll down until you find the values that 

you added to the custom field. 
25. Select the field that you want to map, then from the Unmapped SmartPlant properties pane, 

select the property that you want to map to. 
 If you cannot find a suitable property in the SmartPlant Foundation schema to map to, 

you can create a new one. 
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26. Click the Map icon to map the selected properties. 

 
27. Repeat for other property values that you want to map. 
28. Exit the Schema Editor, and click Yes in the message boxes when prompted to save changes. 
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Synchronize an Enumerated List 
1. Log on to SmartPlant Instrumentation. 
2. Open the desired supporting table where you want to synchronize data, for example, if you 

want to add and map a new value for an instrument status, in the Instrument Index module, 
click Tables > Instrument Statuses. 

3. Add a new value and, if desired, a description. 

 
4. Click Start > Intergraph SmartPlant Foundation > SmartPlant Schema Component > 

SmartPlant Schema Editor. 
5. In the Workflows window, click the Application Metadata tab. 
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6. Connect to the SmartPlant Foundation database as shown. 

 
7. On the SmartPlant Foundation URL page of the SmartPlant Registration Wizard, type the 

node name and virtual directory of the SmartPlant Foundation database where you registered 
your plant.  Use the following format: http://<SPFServer>/<VirtualDirectory>. 
For example: 
http://<SPFServer>/SPFASP 

 
 Replace <SPFServer> with the name of your SmartPlant Foundation Web server. 
 Replace <VirtualDirectory> with the name of the virtual directory for the SmartPlant 

Foundation Web Client.  By default, the virtual directory for the first instance of the Web 
Client that you install is SPFASP.  However, if you install multiple instances of the Web 
Client to connect to multiple databases, the virtual directory name may be different. 

8. Click Next. 
9. On the SmartPlant Foundation Plant page, from the Plant name list, select the SmartPlant 

Foundation plant in which you want to synchronize your data. 
10. Click Next. 
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11. On the Engineering Application Options page, select from the Engineering 
application/map schema list the schema for the tool that you want to synchronize. 

12. Under Startup options, select the Load map schema check box. 
 For SmartPlant Instrumentation, the software automatically selects the Connect to 

application schema check box. 
13. If needed, select the Automatically synchronize schemas check box. 

 You can select more than one schema from the Engineering application/map schema 
list and specify the startup options.  This allows you to load the map schema for each 
application and perform connection and synchronization as specified. 

14. Click Finish to complete the connection and open the Synchronize dialog box, which 
displays the property selected by default for synchronizing in the map schema file.  In this 
example, the map schema file name and path is C:\Program 
Files\SmartPlant\Instrumentation\XML\INtoolsMap.xml. 

 
15. Leave the property selected because in this case, you want the software to synchronize the 

map schema file by updating it with the value from the application database. 
16. Click OK to synchronize the data and open the Map Environment window. 
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17. Expand the SmartPlant Instrumentation node by clicking the  icons. 

 
  The remainder of this procedure describes an example where you are going to map the 

new select list value that you defined to a map class for publishing I/O types.  The actual map 
class that you select depends on how you want to map the fields that you defined, and on 
whether you choose to publish or retrieve the data. 
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1. Under the Map Enumerated Lists node, scroll down to the SystemIOTypes select list. 

 
2. Right-click SystemIOTypes, and then, on the shortcut menu, click Edit SystemIOTypes. 
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3. In the Edit Map Enumerated List Definition window, click the Advanced tab to view the new 
select list value that you added. 
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4. Click the Publish tab. 

 
5. Do the following: 

a. In the Unmapped application enumerations pane, select TT. 
b. In the Unmapped SmartPlant enumerations pane, select the enumeration that you want 

to map to (if you cannot find a suitable enumeration in the SmartPlant Foundation schema 
to map to, create a new one). 
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c. Click the Map icon to map the selected enumerations. 

 
The software moves the mapped enumerations to the Mapped application enumerations 
and Mapped SmartPlant enumeration panes. 

 
6. Exit the Schema Editor, and click Yes in the message boxes when prompted to save changes. 
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Define a Schema for SmartPlant Instrumentation 
1. In the Intools.ini file, add a new section, [FRAMEWORK], and type: 

EnableTEFWizard=1 

2. In the SmartPlant Instrumentation home folder, double-click the file spiscw.exe. 
3. On the Logon Information dialog box, type your user name and password. 
4. In the SmartPlant Instrumentation Schema Configuration Wizard, on the Welcome page, 

click Next. 
5. Select a SmartPlant Instrumentation domain and click Next. 
6. On the Schema Options page, select whether to create an entirely new schema definition or 

to modify an existing schema definition. 
7. Do one of the following: 

 For a new schema, on the Define New Schema Configuration page, type a schema 
name and select the appropriate option according to whether the purpose of the schema 
is to publish or retrieve information.  If you select to use the schema for publishing, type 
the name of the target application. 

 For an existing schema, on the Select Schema page, select the desired schema and 
click Next. 
 When selecting an existing schema, the word 'publish' or 'retrieve' in parentheses 

indicates the purpose of the schema. 
8. On the Select Document Type page, select from the list the document type that you want to 

add to the schema and click Next. 
 

 You can select only one document type at a time to add to the schema. 
 Document types that have already been added to the schema are indicated with an 

asterisk. 
9. On the Select Object Types page, select the objects, representing a class of items that you 

want to represent in the schema and click Next. 
 All object types are available for any document type that you have selected, although it is 

recommended that you select related object types for a particular document type, for 
example, Cable, CableSet, Wire. 

10. On the Define Object Levels and Restrictions page, select the level at which to set each 
object for determining parent-child relationships. 

 
 The highest level must always be 0. 
 The software publishes or retrieves data for object types at each successive level 

associated with the object type at the next highest level.  For example: 
  Line (level 0) 
      Instrument (level 1) 
          Piping port (level 2) 
          Loop (level 2) 

11. Select the check boxes as desired beside each object type to specify restrictions according to 
the requirements of the target application. 

12. When done, click Next. 
13. For a publish schema, if desired, on the Define Filter Condition page, specify a filter 

condition for each level 0 object type by selecting the object type and typing an appropriate 
SQL command. 
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14. When done, click Next. 
15. On the Select Object Interfaces page, select for each object type the desired interfaces and 

click Next. 
 Double-click an interface to view its properties. 

16. On the Completing the Schema Configuration Wizard page, select the desired options and 
click Finish. 

17. To prepare for the next stage of the mapping, select the Export to tool schema check box. 
 

Define a Schema for SmartPlant Instrumentation - Custom 
Fields 

1. In the SmartPlant Instrumentation home folder, double-click the file spiscw.exe. 
2. On the Logon Information dialog box, type your user name and password. 
3. In the SmartPlant Instrumentation Schema Configuration Wizard, on the Welcome page, 

click Next. 
4. Select a SmartPlant Instrumentation domain and click Next. 
5. On the Schema Options page, select Change an existing schema definition. 
6. Do one of the following: 

 For a new schema, on the Define New Schema Configuration page, type a schema 
name and select the appropriate option according to whether the purpose of the schema 
is to publish or retrieve information.  If you select to use the schema for publishing, type 
the name of the target application. 

 For an existing schema, on the Select Schema page, select the desired schema and 
click Next. 
 When selecting an existing schema, the word 'publish' or 'retrieve' in parentheses 

indicates the purpose of the schema. 
7. On the Select Document Type page, select from the list, the document type to which you 

want to add a custom field and click Next. 
 

 You can select only one document type at a time. 
 Document types that have already been added to the schema are indicated with an 

asterisk. 
8. On the Select Object Types page, select the objects, representing a class of items, that you 

want to represent in the schema, and click Next. 
 All object types are available for any document type that you have selected, although it is 

recommended that you select object types related to a particular document type, for example, 
Cable, CableSet, Wire. 

9. On the Define Object Levels and Restrictions page, select the level at which to set each 
object for determining parent-child relationships. 

 
 The highest level must always be 0. 
 The software publishes or retrieves data for object types at each successive level 

associated with the object type at the next highest level.  For example: 
  Line (level 0) 
      Instrument (level 1) 
          Piping port (level 2) 
          Loop (level 2) 
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10. Select the check boxes as desired beside each object type to specify restrictions according to 
the requirements of the target application, and click Next. 

11. For a publish schema, if desired, on the Define Filter Condition page, specify a filter 
condition for each level 0 object type by selecting the object type and typing an appropriate 
SQL command, and click Next. 

12. On the Select Object Interfaces page, select for the desired object type, a custom-field 
interface, click Add, and click Next. For example, for the object type Controller, you can 
select IUnitUDF, or IStripUDF. 

 Double-click an interface to view its properties. 
13. On the Object Interfaces Properties page, select the desired interface properties and click 

Add. Once you finished adding all the desired properties, click Next. 
14. On the Completing the Schema Configuration Wizard page, select the desired options and 

click Finish. 
15. To prepare for the next stage of the mapping, select the Export to tool schema check box. 
 

Export a New Schema Configuration 
1. In the SmartPlant Instrumentation home folder, double-click the file SPIscw.exe. 
2. On the Logon Information dialog box, type your user name and password. 
3. In the Export Schema Configuration Utility, beside the Source tool schema field, click the 

ellipsis button  and navigate to the INtoolsMap.xml file. 

4. Beside the Target tool schema field, click the ellipsis button  and specify the name of the 
.xml file that you want to use as the target. 

 After testing the updated schema to ensure that it works correctly, you must 
rename the target file to 'INtoolsMap.xml' to enable the software to publish the data 
successfully. 

5. Click Connect to SmartPlant Instrumentation Domain. 
6. On the Logon dialog box that opens, select the desired domain. 
7. From the Object schema list, select the object schema that you want to export. 
8. To export the object schema to the target tool schema, click Export. 
 

Define and Map DDP Data 
The following procedure is used when you want to publish instruments that have dimensional data 
but where those instruments are not included in the schema.  In an integrated environment, the 
software supports publishing of dimensional data sheets for certain dimensional groups only.  For 
the full list of supported dimensional groups, see List of Publishable Dimensional Groups (see 
"Publishable Dimensional Groups" on page 474). 

 On a Vista operating system with User Access Control turned on, in order to publish a DDP 
document through SmartPlant Foundation, the output document folder cannot be any sub-folder 
under either the 'Program Files' or 'Windows' folders. 
1. The SmartPlant 3D user must define a symbol in the catalog for each instrument that is going 

to be published from SmartPlant Instrumentation. 
2. The SmartPlant 3D user must inform the SmartPlant Instrumentation user which DDP 

attributes for the instrument need to be published. 
3. Add the appropriate DDP attributes to the SmartPlant schema using the Schema Editor. 
4. The SmartPlant 3D user must map the DDP attributes to the SmartPlant schema. 
5. Define the appropriate DDP attributes for the instrument in SmartPlant Instrumentation. 
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6. Define the mapping between SmartPlant Instrumentation and the SmartPlant schema. 
 

Schema Configuration Wizard 
The Schema Configuration Wizard enables you to define, modify, or delete schemas that you use 
to define the data set for publishing or retrieving.  A schema definition consists of the schema 
name and the target application.  You can specify one or more document types for each schema, 
and in the target application, you retrieve or publish data for individual documents based on a 
single document type.  After you generate a schema, you need to map it to the .xml file used for 
publishing or retrieving your data. 
 

Welcome to the SmartPlant Instrumentation Schema 
Configuration Wizard 
This page appears when you open the Wizard.  Click Next to continue. 
 

Select Domain 
Select the SmartPlant Instrumentation domain for which you want to define a new schema for 
publishing or retrieving data, modify an existing schema, or delete an existing schema. 
 

Schema Options 
Select the desired schema option.  If you have System Administrator rights, you can also select 
to change metaschema definitions. 
 

Define New Schema Configuration 
Ensure that the schema name that you enter is unique for the domain.  If the schema is intended 
for publishing data, you must type a target application name that matches the name of a supported 
application in an integrated environment. 
 

Select Schema 
Select the existing schema that you want to modify or delete.  Note that there may be more than 
one schema for a particular application and that separate schemas are defined for publish and 
retrieve operations. 
 

Select Document Type 
Examples of document types are loops, cables, or PBS Documents.  The document type that you 
select is for recognition by the target application.  You may add as many document types to the 
schema as desired, however, you can select only one document type at a time for addition to the 
schema.  To add another document type, run the wizard again after completing the current 
definition. 
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Select Object Types 
All object types are available for selection regardless of the document type that you selected; 
nevertheless it is recommended that you select object types that are appropriate for the specified 
document type. 
 

Define Object Levels and Restrictions 
The options on this page apply to schemas used for retrieving data only.  For objects that you 
want to be at the highest level, you must specify a value of 0 for the level.  The software retrieves 
or publishes data for objects at lower levels based on the appropriate object at the next highest 
level.  Select restrictions for the objects according to the requirements of the target application, for 
example, you may want to specify a restriction that does not allow the creation or deletion of 
instruments.  Specifying a restriction generates a manual task for the restricted activity in the To 
Do List after retrieval. 
 

Define Filter Condition 
Filter conditions apply to schemas used for retrieving data only.  The software retains the filter 
definition that you make for each object.  Click Validate to verify that the syntax of the filter 
condition is correct. 
 

Select Object Interfaces 
On this page, after you select an object type, highlight an object interface under Available 
interfaces and click Add to select it for the object type.  You cannot perform multi- selection of 
interfaces, therefore you must repeat this action for each interface that you want to add.  Each 
interface consists of a group of related engineering properties — these properties are hard-coded. 
 

Select Interface Properties 
On this page, after you select an object type, highlight an object interface under Available 
interfaces and click Add to select it for the object type.  You cannot perform multi- selection of 
interfaces, therefore you must repeat this action for each interface that you want to add.  Each 
interface consists of a group of related engineering properties — these properties are hard-coded. 
 

Completing the Schema Configuration Wizard 
The following options are available: 
 To save the schema definitions to the database, select Save schema definitions and then 

click Finish. 
 To discard the current definitions and start again, select Restart wizard to make another 

modification and then click Finish.  If you select this option with one or both check boxes 
selected, you can still create an SQL file or export the definitions to the tool schema. 

 To perform the mapping directly, select Export to tool schema. 
 To save the definitions in an SQL file that you use to generate the mapping to the XML 

component manually, select Create SQL file.  The software saves the SQL file in the 
SmartPlant Instrumentation home folder. 
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Export Schema Configuration Utility 
The Export Schema Configuration Utility enables you to copy existing map file data into a new 
class definition so that the interfaces belonging to that class are exposed in the tool schema. 
Source tool schema — The name and path of the XML file that you use as the map 

source.  Click the ellipsis button  to navigate to the desired location. 
Target tool schema — The name and path of the XML file that you will obtain as the 

output.  Click the ellipsis button  to navigate to the desired location. 
Connect to Domain — Opens the Logon dialog box where you select the desired SmartPlant 
Instrumentation domain. 
Object schema — Select from the list the object schema that you want to export. 
Export — Exports the selected object schema to the target tool schema. 
 

Publishing Documents in an Integrated Environment 
In an integrated environment, the authoring tools share data and relationships when you publish 
documents containing the data and relationships.  The publishing process involves selecting a 
document to publish, assigning it to a workflow when necessary, and specifying a version and 
revision of the document if specified in SmartPlant Foundation.  For most documents, the 
software also publishes the data that is associated with the document when you publish. 
The authoring tools (SmartPlant P&ID or SmartPlant Instrumentation, for instance) publish data in 
.xml format. All leading and trailing spaces are trimmed from all strings and from all values without 
units.  These spaces will not appear in the published data file.  The software then loads the data 
from the .xml files to the SmartPlant Foundation database.  After the data is loaded into 
SmartPlant Foundation, you can retrieve the data from into other authoring tools. 
When you publish documents, the software does the following things: 
 Creates a new master document and the first revision in SmartPlant Foundation the first time 

that you publish a particular document.  From that point on, the software creates new versions 
and revisions each time that you publish the document.  The software relates revisions to the 
master document.  You can publish subsequent revisions into a workflow, which can be a 
different workflow from the original publish action.  Changes in the document status of a 
related revision change the status of the subsequently published versions and revisions of the 
document. 

 Publishes a visual representation of the document that you can view without the authoring 
tool.  For many applications, this is an Intergraph proprietary file, called a RAD file.  The 
viewable file can also be an Excel workbook or another viewable file type, such as .pdf or 
.doc.  Users can review and edit the visual representation of the document using SmartPlant 
Markup. 

 Publishes associated data, depending on workflow approval.  If the data is approved and 
loaded, it is used for reporting and subsequent retrieval by downstream applications.  The 
software publishes only meaningful engineering data.  The published data is not enough to 
recreate the document in the original authoring tool. 

 The software publishes some document types without the associated data, such as reports 
from authoring tools (for example, line lists in P&ID).  You can submit documents published 
without data to workflows just like documents with data.  The document types and data that 
you can publish depend on the authoring tool that you use. 

For more information about revisions and versions, see the SmartPlant Foundation Web Client 
User's Guide. 
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Reasons to Publish 
You can publish documents and associated data for several reasons: 
 To exchange and enhance data among tools, to avoid creating data multiple times in multiple 

authoring tools 
 To report on common data that originates in multiple tools 
 To provide enterprise-wide accessibility to published documents 
 To manage change, including workflow history and document revision management 

You can also publish documents to share information with users in other tools without going 
through a formal workflow.  To share data, you can publish a document to a For sharing 
workflow that has only a load step so that the data is loaded into SmartPlant Foundation as soon 
as you publish the document. 
You can also publish a document by not assigning the document to a workflow, but rather by using 
the default workflow from SmartPlant Foundation.  When you do not select a workflow for a 
document during publishing, the SmartPlant Loader loads the document into SmartPlant 
Foundation as soon as it reaches the top of the Loader queue. 

Document Types for Publishing 
Each authoring tool publishes different documents and data.  The published PBS document 
contains information about the physical plant with a structure consisting of plants, areas, and 
units.  The default structure is plant/area/unit, but you can define a custom hierarchy in the 
Schema Editor.  When a PBS document is published from SmartPlant Foundation, the authoring 
tools are notified about the plant, areas, and units that need to be created in each authoring tool. 
The project breakdown structure, project definition document, and project list contain information 
about projects and their statuses. 
The project breakdown structure contains a single project and the hierarchy of contracts under 
that project in a plant/project structure.  The project definition document contains information for a 
single project that needs to be created in the authoring tool.  The project list contains a list of all 
projects in a plant, and it is used by those authoring tools that create all projects at one time. 

 The plant breakdown structure and project breakdown structure used in the authoring tools 
must match the structure in SmartPlant Foundation for publishing from the authoring tools and 
object correlation to work correctly. 
In SmartPlant Instrumentation, the following documents can be published out of the box. Your 
administrator can configure other documents for publish. 
 Instrument Indexes (including instruments, loops, equipment components, and control system 

functions) 
 Browsers 
 Electrical Tag Signal Lists 
 Instrumentation Requiring Power Supply 
 Enhanced SmartLoop Reports 
 Instrument Specification Sheets 
 Instrument Process Data Sheets 
 Dimensional Data Sheets (DDP) 
 Select Wiring Reports 
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Publishing Files without Data 
You can also browse to other file types on the file system, such as Microsoft Word or Excel files, or 
SmartSketch® files, in order to publish them.  These documents are always published without 
data.  The primary reasons to publish documents without data are that the SmartPlant Foundation 
Change Management functionality can manage document changes and reviews using workflows 
and that you can view the documents electronically. 

 When you publish data from an authoring tool, you may not be able view all the properties 
that you published in the SmartPlant Foundation client.  You can customize view definitions to 
allow you to see additional properties.  For more information about defining view definitions in the 
SmartPlant schema, see Working with View Definitions and Create a View Definition in the 
Schema Editor User's Guide.  For further assistance with visualizing data in SmartPlant 
Foundation, contact Intergraph Customer Support. 

See Also 
Publish Documents from SmartPlant Instrumentation (on page 477) 
Find Documents to Publish from SmartPlant Instrumentation (on page 481) 
 

Preliminary Settings for Publishing from SmartPlant 
Instrumentation 

To ensure that your documents are published correctly, check that you have specified the 
following settings, where relevant, for the documents you intend to publish: 
 When publishing data from different units, you must specify separate document numbers and 

sets of revisions for each unit.  To do so, open the Intools.ini file, and under the [Index] 
section, type the following line: DrawingPerLevel=Y 

 To specify the published format of graphical reports (native or PDF), on the Preferences 
dialog box, under SmartPlant Integration > General, select one of the following options from 
the Graphical report format list: 

 Native (brw, spd, ssf) — Generates published reports in native format.  Select this 
option if you want to generate reports for which the title block issue data is updated in 
SmartPlant Foundation.  The native format depends on the report type: for Browser, 
Instrument Index, and Wiring reports, the report file extension is .brw; for process data 
sheets, the report file extension is .spd; for spec sheets, the report file extension is .ssf.  
Note that this option does not apply to DDP reports, and if selected, DDP reports will be 
generated as PDF files only. 

 PDF — Generates published reports in .pdf format. 
 Both — Generates published reports in both native and .pdf formats. 
 None — Disables publishing of view files when you publish documents. 

 In order to publish successfully wiring reports where a choice exists for the revision 
management settings, in the Administration module, the Domain Administrator needs to open 
the Report Management dialog box and change the Revision Management settings for 
these reports from Per Item to Per Document.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Define Report Revision 
Management Settings. 
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Publishable SmartPlant Instrumentation Documents 
The following table indicates the types of documents that are available for publishing and the 
characteristics of the published documents. 

Document Accessed From 
Published 
Output 

Graphical Report 
Format Notes 

All types Main SmartPlant 
Instrumentation 
window (no 
modules open) 

Depends on 
document 

Depends on 
document 

Select the desired 
documents using the 
Document Selection 
Wizard (on page 482). 

All Instruments 
and loops in the 
unit 

Instrument Index 
Standard Browser 
view 

Data and view 
file 

Native (brw) or 
PDF 

 

Electrical power 
elements 

Electrical Power 
Element Browser 
(in the Browser 
module) 

Data only –  

Electrical tag 
browser 

Electrical Tag 
Browser (in the 
Browser module) 

Data only –  

View file for 
browser 

All other browser 
views (in the 
Browser module) 

View file only Native (brw) or 
PDF 

 

Specification 
sheet 

Open instrument 
specification sheet

View file only Native (ssf) or PDF  

Process data 
sheet 

Open process data 
sheet 

View file only Native (spd) or 
PDF 

 

Loop drawing Loop View file only Native (sma) or 
PDF 

You must generate the 
drawing as an Enhanced 
SmartLoop report and 
make at least one revision.

Dimensional data 
sheet 

Open dimensional 
data sheet 

Data and view 
file 

PDF only Only dimensional data 
sheets belonging to certain 
groups are publishable.  
For details, see 
Publishable Dimensional 
Groups (on page 474). 

Wiring reports  View file only Native (brw) or 
PDF 

The following wiring 
reports can be published: 
• Panel-Strip With 

Adjacent Connections 
• Panel Strip Without 

Adjacent Connections 
(Style 2) 
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Document Accessed From 
Published 
Output 

Graphical Report 
Format Notes 

• I/O Tag Assignment 
(Wiring) 

• I/O Map 

Wiring Equipment 
Connections 

DCS panel or PLC 
panel 

View file only Native (sma) or 
PDF 

You must generate the 
drawing as an enhanced 
report and make at least 
one revision.  To publish 
the document, use Find 
Documents to Publish. 

 
 You set the graphical report format for view files on the SmartPlant Instrumentation 

Preferences dialog box, under SmartPlant Integration > General. 
 In order to publish successfully the 'Panel-Strip With Adjacent Connections' and 'Panel Strip 

Without Adjacent Connections (Style 2)' wiring reports, in the Administration module, the 
Domain Administrator needs to open the Report Management dialog box and change the 
Revision Management settings for these reports from Per Item to Per Document.  For more 
information, see SmartPlant Instrumentation Administration Help, Domain Administration > 
Define Report Revision Management Settings. 

 The filter conditions that you apply determine the scope of data that is published from 
browsers. 

 Data in custom browsers can be published if the appropriate document types are mapped 
between the tool schema and SmartPlant schema. For information about mapping document 
types, see Schema Configuration Wizard (on page 468). 

 

Publishable Dimensional Groups 
The SmartPlant Instrumentation dimensional groups in the list are those that also appear in the 
SmartPlant schema, in INtoolsMap.xml, and in SmartPlant 3D.  Only dimensional data sheets for 
instruments that use these groups will publish successfully.  Other dimensional groups in 
SmartPlant Instrumentation are currently not supported for publishing. 

Group Description 

IA1 Annubar Type 1 

IA2 Annubar Type 2 

ICM1 Coriolis Flowmeter Type 1 

ICM2 Coriolis Flowmeter Type 2 Liquid 

ICM3 Coriolis Flowmeter Type 2 Gas 

ICM4 Coriolis Flowmeter Type 3 Liquid 

ICM5 Coriolis Flowmeter Type 3 Gas 

IDCO Orifice_Double Chamber Fitting 

IDL1C Valve_Rotary Diaph. Act. Pos C1 

IDL1D Valve_Rotary Diaph. Act. Pos D1 
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Group Description 

IDL4C Valve_Rotary Diaph.Act.Pos C4(Vert.Line) 

IDL4D Valve_Rotary Diaph.Act.Pos D4(Vert.Line) 

IDR1A Valve_Rotary Diaph. Act. Pos A1 

IDR1B Valve_Rotary Diaph. Act. Pos B1 

IDR4A Valve_Rotary Diaph.Act.Pos A4(Vert.Line) 

IDR4B Valve_Rotary Diaph.Act.Pos B4(Vert.Line) 

IEAM1 Valve_Electric Actuator Type 1 

IEAM2 Valve_Electric Actuator Type 2 

IEAM3 Valve_Electric Actuator Type 3 

IEAM4 Valve_Electric Actuator Type 4 

IEAM5 Valve_Electric Actuator Type 5 

IIOL Orifice_Integral Type 2 

IIOR Orifice_Integral Type 1 

IIV Insert Venturi 

IKG1 Knife Gate Valve Typ 1_Piston Actuator 

IKG2 Knife Gate Valve Typ 2_Piston Actuator 

ILSV Long or Short Venturi 

IMFM1 Magnetic Flowmeter Type 1 

IMFM2 Magnetic Flowmeter Type 2 

IMFM3 Magnetic Flowmeter Type 3 

IMFM4 Magnetic Flowmeter Type 4 

IMOP1 Meterrun_Orifice Flanges & Plate 

IMRSV Meterrun_Short Venturi 

IOP Orifice Plate 

IPDA1 Valve_Double Acting Dual Cyl Act. TYP 1 

IPDA2 Valve_Double Acting Sngl Cyl Act. TYP 2 

IPDA3 Valve_Double Acting Piston Act. TYP 3 FC 

IPDA3A Valve_Double Acting/Sprg Rtrn Act. 90 RS 

IPDA4 Valve_Double Acting Sngl. Piston  Act. FO 

IPDA4A Valve_Double Acting/Sprg Rtrn Act. 90 LS 

IPDA5 Valve_Double Acting Dual Cyl  Act TYP 5 

IPL1C Valve_Rotary Piston Act. POS C1 
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Group Description 

IPL1D Valve_Rotary Piston Act. POS D1 

IPL4C Valve_Rotary Piston Act.POS C4(Vert.Line) 

IPL4D Valve_Rotary Piston Act.Pos D4(Vert.Line) 

IPR1A Valve_Rotary Piston Act. POS A1 

IPR1B Valve_Rotary Piston Act. POS B1 

IPR4A Valve_Rotary Piston Act.POS A4(Vert.Line) 

IPR4B Valve_Rotary Piston Act.POS B4(Vert.Line) 

IPSR1 Valve_Spring Return Piston Act. Typ1 FC 

IPSR2 Valve_Spring Return Piston Act. Typ2 FO 

IPSR3 Valve_Spring Return Piston Act. Typ3 FC 

IPSR4 Valve_Spring Return Piston Act. Typ4 FO 

IR1 Rotameter Type 1 

IR2 Rotameter Type 2 

IR3 Rotameter Type 3 

IR4 Rotameter Type 4 

IR5 Rotameter Type 5 

IR6 Rotameter Type 6 

IR7 Rotameter Type 7 

IR8 Rotameter Type 8 

IR9 Rotameter Type 9 

IREG1 Regulator Type 1 

IREG2 Regulator Type 2 

IREG3 Regulator Type 3 

IREG4 Regulator Type 4 

IREG5 Regulator Type 5 

IRVT3 Relief Valve Type 3 (Pilot) 

IRVT4 Relief Valve Type 4 (Pilot) 

IRVT7 Relief Valve Type 7 (Specials) 

IRXPA Valve_Rack & Pinion Actuator 

ISSDA Valve Angle_Linear Diaphragm  Actuator 

ISSDS Valve Linear Diaphragm Actuator 

ISSPS 3 Way Valve_Linear Piston Actuator 
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Group Description 

ITM Turbine Meter 

IVM1 Vortex Flowmeter Type 1 

IVM2 Vortex Flowmeter Type 2 

IVM3 Vortex Flowmeter Type 3 

IVM4 Vortex Flowmeter Type 4_Dual Head 

IWFE Wedge Flow Element 

SDG1 Diaphragm Globe Valve 

SDR1 Diaphragm Rotary Valve 

SMISC1 Miscellaneous Inline Instruments 

SMR1 Meter run 

SOP1 Orifice Plate or Rupture Disc 

SP1 Piston Globe or Rotary Valve 

SPR1 Piston Rotary Valve 

SREG1 Regulator 

SRV1 Relief Valve 
 
 

Publish Documents from SmartPlant Instrumentation 
 

 When publishing documents, select the lowest plant hierarchy level from a plant hierarchy, for 
example, a unit. 

 After you start to publish documents from an Instrument Index Standard Browser view, you 
should not change the default view. Changing the view can result in incorrect revision 
numbers and inconsistencies between the graphical and XML output files. 

 
 Before you can publish SmartPlant Instrumentation engineering documents, you must make a 

revision for each document you want to publish.  The software finds only those documents for 
which you have made revisions.  If you have made several revisions for one document, the 
software finds the document containing the most recent revision. 

 To publish a loop drawing, you must have first generated the drawing as an Enhanced 
SmartLoop report and made at least one revision. 

1. Select a document for publishing.  For more details of suitable documents for publishing, see 
Publishable SmartPlant Instrumentation Documents (on page 473). 

2. Click SmartPlant > Publish. 

 
 This command is available only if you have registered the active plant using the 

SmartPlant Registration Wizard. 
 If you logged onto SmartPlant Instrumentation with a user name that is not defined in the 

integrated environment, you are prompted to log on when you use this command. 
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 The documents that appear in the Selected documents list on the Publish dialog box 
when it first appears are documents that were selected within SmartPlant Instrumentation 
before you accessed the Publish command. 

 
3. Add any additional documents to the Selected documents list by clicking the Engineering 

Tool, File System, or Find toolbar buttons and choosing other documents to publish. 
4. In the Document Selection Wizard, on the Select Document Type page, select the check 

boxes for the types of documents you want to publish. 
5. Click Next. 
6. On the Select Unit page, navigate to the lowest level plant hierarchy item, such as a unit, from 

which you want to publish documents. 

 
 Double-click the icons to expand the plant hierarchy. 
 The Next command is enabled only after you select a unit. 

7. Click Next. 
8. Depending on your document type selection, do the following to select engineering 

documents on each Select page that opens: 
a. Specify search parameters as necessary, and then click Find. 
b. In the Search results data window, select the rows for the documents that you want to 

publish, and then click Next. 
 If you select the Instrument Index check box on the Select Document Type page, 

the software automatically finds the Instrument Index document that exists in the <unit>. 
9. On the Document Selection Summary page, review your selections, and click Finish to exit 

the Document Selection Wizard and return to the Publish dialog box. 
 To redefine your selections, click Back. 
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10. On the Publish dialog box, review the documents that you want to publish and edit 
information as necessary. 

 When multiple documents are selected, only property values shared by all the selected 
documents appear in the table.  Changing a value in the table changes that value for all of the 
selected documents. 

11. From the Operation list, specify the desired method of publishing: 
 Select Publish to immediately start the publishing process as soon as you click OK. 
 Select Background publish to publish the selected documents immediately as a 

separate process, allowing you to perform other tasks at the same time.  When you use 
this feature, an e-mail message alerts you when the process is complete. 

 Select Scheduled publish to indicate that the publish process should be run in batch 
mode, if the authoring tool supports scheduled batch publishing. 

12. Click OK to complete the publish operation. 
 When the publish is complete, a dialog box appears indicating whether the publish 

operation was completed successfully or with errors.  If the View Log button on the dialog box is 
enabled, you can click it to view messages concerning the operation.  These may be errors, 
warnings or informational messages. 

See Also 
Retrieve Documents to SmartPlant Instrumentation (on page 491) 
 

Issue Request Documents from SmartPlant Instrumentation 
1. Select a document.  For more details of suitable documents for publishing, see Publishable 

SmartPlant Instrumentation Documents (on page 473). 
2. Click SmartPlant > Publish. 

 
 If you logged onto SmartPlant Instrumentation with a user name that is not defined in the 

integrated environment, you are prompted to log on when you use this command. 
 The documents that appear in the Selected documents list on the dialog box when it first 

appears are documents that were selected within SmartPlant Instrumentation before you 
accessed the Publish command. 
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3. Click the Issue Request tab. 

 
4. In the Issue to box, select the contract to which you want to assign the document or 

documents. 
5. To add any additional documents to the Selected documents list, click the Engineering 

Tool button. 
6. In the Document Selection Wizard, on the Select Document Type page, select the check 

boxes for the types of documents you want to publish. 
7. Click Next. 
8. On the Select Unit page, navigate to the lowest level plant hierarchy item, such as a unit, from 

which you want to publish documents. 

 
 Double-click the icons to expand the plant hierarchy. 
 The Next command is enabled only after you select a unit. 

9. Click Next. 
10. Depending on your document type selection, select engineering documents on each Select... 

page that opens as follows: 
a. Specify search parameters, as necessary, and then click Find. 
b. In the Search results data window, select the rows for the documents that you want to 

publish, and then click Next. 
 If you select the Instrument Index check box on the Select Document Type page, 

the software automatically finds the Instrument Index document that exists in the unit. 
11. On the Document Selection Summary page, review your selections, and click Finish to exit 

the Document Selection Wizard and return to the Publish dialog box. 
 To redefine your selections, click Back. 
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12. Click OK to publish the issue relation. 

See Also 
Retrieve Documents to SmartPlant Instrumentation (on page 491) 
 

Find Documents to Publish from SmartPlant Instrumentation 
1. Click SmartPlant > Find Documents to Publish. 

 
 This command is available only if you have registered the active plant using the 

SmartPlant Registration Wizard. 

 This feature is also available by clicking Find  on the Publish dialog box. 
 The Find Documents to Publish command determines which documents need to be 

published or re-published and displays the results on the Find Documents to Publish 
dialog box. 

2. From the Select documents to publish list on the Find Documents to Publish dialog box, 
select the check box beside the documents that you want to publish. 

 
 You can quickly select the entire list by clicking Select All, or you can clear the entire list 

by clicking Clear All. 
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3. Click OK to accept the selections. The documents you selected to publish now appear in the 
Documents to Publish list on the Publish dialog box, and are ready to be published. 

 The lists displayed on the Find Documents to Publish dialog box are compiled at the 
time indicated in the Last search performed box. You can update the lists by clicking 
Update, but this process can be time-consuming, depending on whether you are running the 
applications in synchronous or asynchronous mode. 

See Also 
Publish Documents from SmartPlant Instrumentation (on page 477) 
 

Document Selection Wizard 
The Document Selection Wizard allows you to find engineering documents in a specific <unit> of 
the current domain and add them to the list of selected documents to publish. 
 

Select Document Types (Document Selection Wizard) 
Select the check box beside each document type that you want to include for publishing. 
Instrument Index data — A document published as a .pdf file (one .pdf file per <unit>).   Each 
instrument index document contains data about all the instruments and loops existing in a 
SmartPlant Instrumentation database and defined for a specific <unit>. 
Instrument process data sheets — Documents containing detailed information about process 
data values for a specific instrument you have associated with a particular tag number.  You can 
select a tag number and view the corresponding process data sheet for a specific instrument as a 
read-only .pdf file. 
Instrument specification sheets — Documents containing detailed information about 
specification sheet data associated with a particular tag number.  You can select a tag number 
and view the corresponding specification sheet as a read-only .isf file. 
Enhanced SmartLoop reports — Documents containing detailed information about a loop 
drawing that you generated as an Enhanced SmartLoop report using the Enhanced Report 
Utility.  You can select a loop name and view the corresponding Enhanced SmartLoop report as a 
read-only .sma file. 
Instrument dimensional data sheets — Documents containing detailed information about 
dimensional data values for a specific instrument that you have associated with a particular tag 
number.  You can select a tag number and view the corresponding dimensional data sheet for a 
specific instrument as a read-only .pdf file. 

 You can publish a new instrument index document each time you make a revision for that 
document.  The source data for the instrument index document is located in the current 
Instrument Index Standard Browser view. 
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Select Plant Group (Document Selection Wizard) 
Allows you to select the SmartPlant Instrumentation plant group for which you want to publish the 
selected documents. 
Project — Displays 'As-Built' or the name of the SmartPlant Instrumentation project that you 
selected. 
Plant hierarchy — Select a SmartPlant Instrumentation plant group at the lowest plant hierarchy 
level (for example, a unit). 
 

Select Instrument Process Data Sheets (Document Selection 
Wizard) 
This page allows you to select instrument process data sheets for performing revisions and 
publishing.  You can batch generate process data sheets for instruments in the Instrument Index 
Standard Browser by using the shortcut menu command Generate Process Data Sheets.  This 
is important when you use revisions from SmartPlant Foundation and ensures that the appropriate 
instruments appear in the Search results table when you click Find. 
You can use wildcards in the fields where you type values: underscore (_) for single characters 
and percent (%) for multiple characters. 
The following table shows search parameters that you can use to narrow the results of your 
search for process data sheets. 

Search Parameter Explanation Example 

Tag number Type the whole tag number you 
are looking for.  Include any 
prefix, suffix, and separator 
characters.  You can use 
wildcards if needed. 

101-FT –2225/1 

Or use a wildcard: 
101-FT% 

Number Type the numeric segment of a 
tag number to find all the tag 
numbers that contain this 
numeric segment.  You can 
also use wildcards if needed. 

2225 

Instrument type Select an instrument type to 
narrow your search to tags 
belonging to this instrument 
type. 

D/P Type Flow Element (FE), 
Mass Flow Transmitter (FT) 

Pressure (DP) 

Status Select a tag status to narrow 
your search to tags associated 
with this status. 

An existing device, a new 
instrument, a relocated device

Location Select a tag location, such as 
Field, to narrow your search to 
tags for which you have defined 
this location. 

Equipment room, junction box

Process function Select a process function to 
narrow your search to tags 
belonging to this process 
function. 

Flow  
Pressure 
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Click Find to display the process data sheets that exist in the specified <unit> and according to the 
search parameters, if specified. 
In the Search results table, you can view the process data documents to select for 
publishing.  Note that the Revision column displays the number of the latest revision for each 
process data sheet. 
 

Select Instrument Specification Sheets (Document Selection 
Wizard) 
This page allows you to select instrument specification sheets for performing revisions and 
publishing.  You can batch generate specification sheets for instruments in the Instrument Index 
Standard Browser by using the shortcut menu command Apply Profile > Generate 
Specification Sheets.  This is important when you use revisions from SmartPlant Foundation 
and ensures that the appropriate instruments appear in the Search results table when you click 
Find. 
You can use wildcards in the fields where you type values: underscore (_) for single characters 
and percent (%) for multiple characters. 
The following table shows search parameters that you can use to narrow the results of your 
search for specification sheets. 

Search Parameter Explanation Example 

Tag number Type the whole tag number you 
are looking for.  Include any 
prefix, suffix, and separator 
characters.  You can use 
wildcards if needed. 

101-FT –2225/1 

Or use a wildcard: 
101-FT% 

Number Type the numeric segment of a tag 
number to find all the tag numbers 
that contain this numeric 
segment.  You can also use 
wildcards if needed. 

2225 

Instrument type Select an instrument type to 
narrow your search to tags 
belonging to this instrument type. 

D/P Type Flow Element 
(FE), Mass Flow 
Transmitter (FT) 

Pressure (DP) 

Status Select a tag status to narrow your 
search to tags associated with this 
status. 

An existing device, a new 
instrument, a relocated 
device 

Location Select a tag location, such as 
Field, to narrow your search to 
tags for which you have defined 
this location. 

Equipment room, junction 
box 

Form number Select a form number to narrow 
your search to documents that 
have this specification form 
number. 

 

Click Find to display the instrument specification sheets that exist in the specified <unit> and 
according to the search parameters, if specified. 
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In the Search results table, you can view the specification documents to select for 
publishing.  Note that the Revision column displays the number of the latest revision for each 
specification sheet. 
 

Select Enhanced SmartLoop Reports (Document Selection 
Wizard) 
A published loop drawing allows you to view Enhanced SmartLoop reports in .sma format. 
You can use wildcards in the fields where you type values: underscore (_) for single characters 
and percent (%) for multiple characters. 
The following table shows search parameters that you can use to narrow the results of your 
search for Enhanced SmartLoop reports. 

Search Parameter Explanation Example 

Loop number Type the whole loop number you 
are looking for.  Include any  
suffix, and separator characters. 
Use wildcards if needed. 

101F - 2225\A 

101F-% 

Number Type the numeric segment of the 
loop number to find all the loop 
numbers that contain this numeric 
segment.  Use wildcards if 
needed. 

2225 

Measured variable From the list, select a measured 
variable to find all the existing loop 
numbers that have this measured 
variable. 

Density (D) 

Pressure (DP) 

Click Find to generate Enhanced SmartLoop reports for the loops that exist in the specified <unit> 
and according to the search parameters, if specified. 
In the Search results table, you can view the loops to select for publishing the reports.  Note that 
the Revision column displays the number of the latest revision for each loop. 
 

Select Wiring Reports (Document Selection Wizard) 
This page allows you to select wiring reports as .pdf files for performing revisions and 
publishing.  You can use wildcards in the fields where you type values: underscore (_) for single 
characters and percent (%) for multiple characters. 
The following table shows search parameters that you can use to narrow the results of your 
search for wiring reports. 

Search Parameter Explanation Example 

Panel name Type the panel name you are 
looking for.  Include any prefix, 
suffix, and separator 
characters.  Use wildcards if 
needed. 

101 JB -100 

JB-% 

Type From the list, select a panel type to 
narrow your search. 

Measuring Device, 
Monitor, Power Supply 
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Search Parameter Explanation Example 

Manufacturer From the list, select a manufacturer 
to find all the existing panels that 
have this manufacturer. 

 

Model From the list, select a model to 
narrow your search to a specific 
model or group of models for the 
selected manufacturer. 

 

Report style From the list, select the desired 
report style: With Adjacent 
Connections or Without Adjacent 
Connections (Style 2). 

 

Click Find to generate wiring reports for the panels that exist in the specified <unit> and according 
to the search parameters, if specified. 
In the Search results table, you can view the panels to select for publishing the reports.  Note 
that the Revision column displays the number of the latest revision for each panel. 
 

Select Dimensional Data Sheets (Document Selection Wizard) 
This page allows you to select dimensional data sheets as .pdf files for performing revisions and 
publishing.  You can batch generate dimensional data sheets for instruments in the DDP module 
by displaying working data and using the shortcut menu command Regenerate Dimensional 
Data Sheets.  This is important when you use revisions from SmartPlant Foundation and ensures 
that the appropriate instruments appear in the Search results table when you click Find. 
You can use wildcards in the fields where you type values: underscore (_) for single characters 
and percent (%) for multiple characters. 
The following table shows search parameters that you can use to narrow the results of your 
search for dimensional data sheets. 

Search Parameter Explanation Example 

Tag number Type the whole tag number you 
are looking for.  Include any 
prefix, suffix, and separator 
characters.  You can use 
wildcards if needed. 

101-FT –2225/1 

Or use a wildcard: 
101-FT% 

Number Type the numeric segment of a tag 
number to find all the tag numbers 
that contain this numeric 
segment.  You can also use 
wildcards if needed. 

2225 

Instrument type Select an instrument type to 
narrow your search to tags 
belonging to this instrument type. 

D/P Type Flow Element 
(FE), Mass Flow 
Transmitter (FT) 

Pressure (DP) 

Dimensional data 
status 

Select a tag status to narrow your 
search to tags associated with this 
status. 

An existing device, a new 
instrument, a relocated 
device 
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Search Parameter Explanation Example 

Manufacturer Select a manufacturer to narrow 
your search to tags for which you 
have defined this manufacturer. 

Fisher, Honeywell 

Dimensional Group Select a dimensional group to 
narrow your search to tags 
belonging to this dimensional 
group. 

IA1, IA2, ICM1, All Groups 

 The software supports publishing of dimensional data sheets for certain dimensional 
groups only.  For the full list of supported dimensional groups, see List of Publishable 
Dimensional Groups (see "Publishable Dimensional Groups" on page 474). 
Click Find to display the dimensional data sheets that exist in the specified <unit> and according 
to the search parameters, if specified. 
In the Search results table, you can view the dimensional data documents to select for 
publishing.  Note that the Revision column displays the number of the latest revision for each 
dimensional data sheet. 
 

Document Selection Summary (Document Selection Wizard) 
This page allows you to review the number of documents of each type that you have 
selected.  Click Back to review or modify your selections.  Click Finish to accept your selections 
and return to the Publish dialog box. 
 

Revising Documents in an Integrated Environment 
The Revise Documents command, available on the SmartPlant menu, allows you to revise a 
document and save it to the database of the authoring tool without publishing it.  When you 
register a plant, the software implements integrated revisions.  During report publishing, the 
software first checks whether the report has an integrated revision and then assigns the 
appropriate revision scheme automatically. 

Reserving Revision Number 
The Revise functionality also provides an option that allows you to designate revisions numbers to 
the plant or to particular projects.  For each document, you can reserve revision numbers at the 
plant or project level.  Using this feature, you can use the same document in different projects, 
while still allowing the revision numbers to be sequential within each project. 
For each project (or even at the plant level) you can reserve a certain number of revisions that are 
held for that particular project.  If the document is used within a different project and revised, it is 
given either a later revision number or its own set of numbers. 
For more information about reserving revision numbers, see the Online Help for the Revise dialog 
box. 
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Revise a Document 
1. Do one of the following to open the Revise dialog box: 

 From any module that supports publishing and retrieving of documents, on the Revisions 
dialog box, click New. 

 From within SmartPlant Instrumentation, click SmartPlant > Revise Documents. 

  
 

 This option is available only if you have registered the active SmartPlant Instrumentation 
plant. 

 If you are logged on to SmartPlant Instrumentation with a user name that is not defined in 
SmartPlant Foundation for the specific plant, you are prompted to log on to SmartPlant 
Foundation when you use this command. 

 The documents that appear in the Selected documents list on the Revise dialog box 
when it first appears are documents that were selected within the authoring tool before 
you clicked the Revise Documents command. 

2. For a new document, or a document that does not yet have a defined revision scheme, select 
the revision scheme you want to use from the Revision Scheme list. 

 If you selected a document that already has a defined revision scheme, it is displayed 
in the Revision Scheme field and cannot be changed. 

3. In the Revise in Tool section, choose the next available major and minor revision numbers. 
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 Any revision numbers that have been reserved by another project are not available and 
are skipped in the revision scheme, if applicable.  In other words, if the current version of the 
document is B and there are three outstanding revision reservations for that document in 
other projects, the next available revision number will be F. 

4. Click OK. 

 
 When you click OK to revise the document, it is saved to the authoring tool database.  The 

document stored in SmartPlant Foundation is not updated until your publish it from SmartPlant 
Instrumentation. 

 Using the Revise dialog box, you can reserve revision numbers, revise documents, or do both 
at the same time. 

 

Retrieving Documents in an Integrated Environment 
When you retrieve documents into an authoring tool, you are retrieving the document data that 
was published by another authoring tool.  For example, in SmartPlant Instrumentation, you can 
retrieve engineering information from a published P&ID into the SmartPlant Instrumentation 
database. 
The authoring tools provide commands that let you select a document and retrieve it into that 
tool.  You can use either the SmartPlant > Retrieve command to open a wizard that assists you 
in retrieving applicable documents, or with some authoring tools, you can configure an automatic 
retrieval feature. 

 The software trims all leading and trailing spaces from all strings and from all values 
without units of measure.  These spaces do not appear in the retrieved data file. 
Additionally, you can access the Web Client through the SmartPlant > Browser command.  This 
allows you to select the document or documents that you want to retrieve from your Web Client To 
Do List, the tree view, or by using the Web Client search functionality.  After you select the 
documents that you want to retrieve, you can use the Retrieve command on the Web Client 
SmartPlant menu to start the retrieval process. 
The Retrieve command provided in the authoring tools is slightly different from the Retrieve 
command available in the SmartPlant Foundation Web Client.  The Web Client presents a list of 
documents from which you can select those you want to retrieve.  However, when you use the 
command from an authoring tool without first selecting documents, the software searches the 
SmartPlant Foundation project for documents to retrieve, and these are presented in a list on the 
Retrieve dialog box. 
You can retrieve a document in two ways: 
 As published — Retrieves only the data the authoring tool originally published with the 

selected revision and version of the document.  Retrieving as-published data retrieves the 
.xml file the authoring tool published from the appropriate SmartPlant Foundation vault. 

 With the latest data — Retrieves the latest data associated with the selected document in the 
SmartPlant Foundation database.  If another, more-recently published document contains 
updates to objects in the selected document, the software retrieves the most current data in 
the SmartPlant Foundation database for those shared objects.  When you retrieve the latest 
data, SmartPlant Foundation generates an .xml file containing the published data. 
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Document Types for Retrieval 
From the authoring tools, you can retrieve the plant breakdown structure (PBS) and project 
documents. The PBS and project documents, created in SmartPlant Foundation, are retrieved by 
authoring tools to provide information about the plants, areas, units, projects, and contracts that 
need to be created in the authoring tool so that the information is consistent across all authoring 
tools. 
The PBS document published by SmartPlant Foundation contains information about the physical 
plant with a structure consisting of plants, areas, and units.  The default structure is 
plant/area/unit, but you can define a custom hierarchy in the Schema Editor.  The project 
breakdown structure, project list, and project definition document contain information about the 
project or projects and their statuses in a plant/project structure. 

 
 Retrieving the project breakdown documents and the PBS into SmartPlant Engineering 

Manager creates the appropriate structures automatically. 
 When using SmartPlant Instrumentation, you must create the plant hierarchy according to the 

PBS information in SmartPlant Foundation before you retrieve either the PBS or the project 
definition document.  You must create a plant hierarchy with at least three levels with a 
minimum of one PBS item at the lowest level before you can retrieve the PBS and project 
definition document. 

In SmartPlant Instrumentation, the following documents are retrievable out of the box. Your 
administrator can configure other documents for retrieve. 
 Electrical Signal I/O Lists 
 Electrical Power Element Reports 
 Instrument Process Data Sheets 
 Schematics 
 P&IDs (includes instruments, loops, lines, equipment, and control system functions) 

 After you retrieve a P&ID, you can change the unit of measure (UOM) if all conditions 
(minimum, maximum, and normal) are the same in the retrieved document. If you change the 
UOM and the conditions are not the same, the software will warn you. 

Data Handling After Retrieval 
The authoring tool that you use also determines how the system deals with changes in 
downstream data when you retrieve a document.  SmartPlant P&ID, SmartPlant Instrumentation, 
SmartPlant Electrical, and Aspen Basic Engineering analyze the impact of the newly retrieved 
data on the existing database, then place tasks on the authoring tools To Do List that allow you to 
create, delete, or modify items at the appropriate time in the design process. The To Do List gives 
you the opportunity to view and understand potential changes before accepting, deleting, or 
modifying those changes. 

Design Basis 
Objects that tools retrieve from other authoring tool documents can become the design basis for 
objects in downstream documents.  Objects that become the design basis for other objects can 
be specific objects that get richer as they move through the lifecycle or they can be schematic or 
logical objects in one application that evolve into more detailed objects downstream. 
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Design basis is implicit based on retrieval; you do not have to define it.  For example, a pump 
retrieved from a PFD becomes the design basis for a pump in the P&ID.  When you change 
common properties for the pump and retrieve the changes into SmartPlant P&ID, tasks to update 
the pump automatically appear in the To Do List.  The same process works for logical items that 
are a design basis for other items, such as a P&ID tag in SmartPlant P&ID can evolve into a 
control loop with associated tag numbers in SmartPlant Instrumentation. 

See Also 
Using the To Do List (on page 502) 
 

Retrieve Documents to SmartPlant Instrumentation 
1. Display one of the following: 

 The main SmartPlant Instrumentation window with no modules open. 
 The Instrument Index Standard Browser view. 

2. Click SmartPlant > Retrieve. 

 
 If you logged onto SmartPlant Instrumentation with a user name that is not defined in the 

integrated environment, you are prompted to log on when you use this command. 
 The Retrieve command searches the integrated environment for documents that are 

ready to be retrieved into SmartPlant Instrumentation. These documents appear in the 
Documents to retrieve list on the Retrieve dialog box. 

3. On the Retrieve dialog box, in the Document type box, specify the type of document to be 
retrieved. 
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4. In the Show section, select Documents to be retrieved only to include documents that have 
been retrieved previously and have been published again since the last retrieval. Select All 
documents to include all revisions and types of documents. Select New documents only to 
retrieve documents that have not been retrieved yet. 

 
5. In the Documents to retrieve list, select the check box beside each document you want to 

retrieve. To help identify the documents, review the details in the Type, Revision, Version, 
and Last Retrieved columns.  

 To quickly select the entire list, click Select All. To quickly cancel the selections, click 
Clear All. 

6. For each document you checked, use the Retrieve Option column to specify whether you 
want to retrieve the document with the latest data or retrieve it as published. 

7. Click OK to retrieve the specified documents. 

 
 Check the Batch retrieve option if you want the retrieve process to run in batch mode. If you 

select this option, an e-mail message will alert you when the process is complete. Otherwise, 
the retrieval process begins when you click OK. 

 The Deleted and Unclaimed Objects document is retrieved automatically every time you 
retrieve, if there is a newer version of this document since the last retrieval. The document is 
not included in the list, but it is retrieved automatically, when necessary, to ensure that the 
applicable information is updated. 

 When the retrieve is complete, a dialog box appears indicating whether the retrieve operation 
was completed successfully or with errors.  If the View Log button on the dialog box is 
enabled, you can click it to view messages concerning the operation.  These may be errors, 
warnings or informational messages. 
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Retrieving Control Valves with Pipe Runs 
Only pipe runs that have a related instrument are retrieved from SmartPlant P&ID as lines.  The 
instrument receives its preliminary process data from the related line.  For control valves, the line 
that is retrieved in most scenarios corresponds to the pipe run directly connected to the upstream 
end of the valve, except under certain conditions. 
These conditions are: 
1. The flow direction is specified. 
2. A reducer is connected at the upstream end of the valve. 
3. The larger diameter pipe is connected to the far end of the reducer. 
If all of the above conditions are fulfilled, the retrieved pipe run is not the one directly connected to 
the upstream end of the valve, but rather the pipe run at the far end of the reducer. 
The following diagram shows an example of a P&ID involving pipe runs and related control valves. 

 
For this scenario: 
 The flow direction is specified for both valves. 
 Reducer R2 is connected downstream of both valves and therefore has no influence on the 

pipe run retrieval. 
 In relation to valve 101-CV-041, reducer R1 is connected with the smaller diameter pipe at the 

far end of the reducer, so pipe run P-200-4" is retrieved with valve 101-CV-041. 
 In relation to valve 101-CV-042, reducer R1 is connected with the larger diameter pipe at the 

far end of the reducer, so pipe run P-200-4" is retrieved with valve 101-CV-041. 
Therefore SmartPlant Instrumentation retrieves both valves with pipe run P-200-4".  Pipe run 
P-200-3" is not retrieved. 
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Retrieving Relief Valves with Pipe Runs 
When SmartPlant Instrumentation retrieves data from SmartPlant P&ID, it traverses piping 
connectivity from instruments to detect relationships to process lines and process equipment. 
SmartPlant Instrumentation has been enhanced to include special cases for relief valves. The 
following examples describe use cases in which the retrieval creates the process line or process 
equipment that contains the relief valve, and the relationship between these objects. 
 

Connected Directly to Main Line 
1 

 

• No relationship is created between the relief valve 
and pipe run because the pipe run immediately 
connected to the relief valve is unnamed. 

2 

 

• A relationship is created between the relief valve 
and pipe run because the immediately connected 
pipe run is named. 

3 

 

• A relationship to P-1113-2" because the piperun 
immediately connected to the relief valve is 
unnamed. 

4 

 

• A relationship is created between the relief valve 
and piperun P-1114-2" because it is named and 
the immediately connected pipe run. 
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Connected to Main Line through Reducer 
1 

 

• No relationship is created between the relief valve 
and pipe run because the pipe run that is 
immediately connected through the reducer is 
unnamed. 

2 

 

• A relationship is created between the relief valve 
and pipe run because the pipe run that is 
immediately connected through the reducer is 
named. 

3 

 

• A relationship is created to named pipe run 
P-2224-2"  because the pipe run immediately 
connected through the reducer is unnamed. 

4 

 

• A relationship is created between the relief valve 
and pipe run P-2225-2" because it is named and 
the immediately connected reducer. 

 
 

Connected Directly to Nozzle 
1 

 

• No relationship is created because the 
immediately connected pipe run and equipment 
are unnamed. 
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2 

 

• A relationship is created between the relief valve 
and the immediately connected pipe run 
P-3331-2". 

• In this scenario, a named pipe run takes priority if 
the equipment is unnamed. 

3 

 

• No relationship is created because the 
immediately connected pipe run and equipment 
are unnamed. 

4 

 

• A relationship is created between the relief valve 
and equipment because the immediately 
connected equipment P-3331A is named. 

5 

 

• A relationship is created between the relief valve 
and the named pipe run P-3332-2". 
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6 

 

• A relationship is created between the relief valve 
and the immediately connected pipe run 
P-3332-2". 

7 

 

• A relationship is created between the relief valve 
and  the immediately connected pipe run 
P-3334-2". 

Connect to Nozzle through a Reducer 
1 

 

• No relationship is created because the immediately 
connected pipe run and equipment are unnamed. 

2 • A relationship is created between the relief valve and 
the immediately connected pipe run P-4441-2". 
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3 

 

• No relationship is created because the immediately 
connected pipe run and equipment are unnamed. 

4 

 

• A relationship is created between the relief valve and 
equipment because the immediately connected 
equipment P-4441 is named. 

5 • A relationship is created between the relief valve and 
the named pipe run P-4442-2". 

6 

 

• A relationship is created between the relief valve and  
the immediately connected pipe run P-4443-2". 
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7 • A relationship is created between the relief valve and  
the immediately connected pipe run P-4444-2". 

 

 

Branching Connection without Reducers 
1 • No relationship is created between the relief 

valve and the immediately connected 
downstream pipe run because the pipe run 
is unnamed. 

2 • A relationship is created between the relief 
valve and immediately connected 
downstream pipe run P-5551-2" because 
the pipe run is named. 

3 • No relationship is created between the relief 
valve and the immediately connected 
downstream pipe run because the pipe run 
is unnamed. 

• No relationship is created with the named 
pipe run P-5552-2" because the 
relationship cannot jump a branch point. 
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4 • A relationship is created between the relief 
valve and the named pipe run P-5553-2" 
because the immediately connected 
piperun is unnamed. 

5 • A relationship is created between the relief 
valve and immediately connected 
downstream pipe run P-5554-2" because 
the pipe run is named. 

• No relationship is created with the named 
pipe run P-5555-2" because the 
relationship cannot jump a branch point. 

6 • A relationship is created between the relief 
valve and immediately connected 
downstream pipe run P-5556-2" because 
the pipe run is named. 

7 • A relationship is created between the relief 
valve and immediately connected 
downstream pipe run P-5558-2" because 
the pipe run is named. 
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Branching Connection with Reducers 
1 • No relationship is created between the relief 

valve and immediately connected 
downstream pipe run because the pipe run 
connect through the reducer is unnamed. 

2 • A relationship is created between the relief 
valve and immediately connected 
downstream pipe run P-6661-2"because 
the pipe run connected through the reducer 
is named. 

3 • No relationship is created between the relief 
valve and the immediately connected 
downstream pipe run because the pipe run 
connected through the reducer is unnamed. 

• No relationship is created with the named 
pipe run P-6662-2" because the 
relationship cannot jump a branch point. 

4 • A relationship is created between the relief 
valve and the named pipe run P-6663-2" 
because the immediately connected 
downstream pipe run connected through 
the reducer is unnamed. 
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5 • A relationship is created between the relief 
valve and the immediately connected 
downstream pipe run P-6664-2" because 
the pipe run connected through the reducer 
is named. 

• No relationship is created with the named 
pipe run P-6665-2" because the 
relationship cannot jump a branch point. 

6 • A relationship is created between the relief 
valve and the immediately connected 
downstream pipe run P-6666-2" because 
the pipe run connected through the reducer 
is named. 

7 • A relationship is created between the relief 
valve and the immediately connected 
downstream pipe run P-6668-2" because 
the pipe run connected through the reducer 
is named. 

 
 

Using the To Do List 
The To Do List allows you to keep track of tasks required to keep your plant updated with 
information in an integrated environment.  Specifically, this feature aids in retrieving data by 
providing a list of all the things that must be added, deleted, or modified to bring the plant data into 
agreement with the latest retrieved information. 
All the users of a plant database share a single To Do List.  You can view the entire To Do List and 
see the tasks that have been completed and those that are pending.  Some types of tasks have 
associated code and when you run those tasks, the software modifies the database. 
From the To Do List, you can run, defer, or delete tasks, or specify tasks that you want the 
software to ignore in future retrievals.  Additionally, you can view properties for each task in the To 
Do List and, if desired, specify that certain task properties are ignored when the task is 
retrieved.  The information that is available is specific to the type of task that is selected: Create 
tasks and Update tasks, for instance, but certain information is provided for all types.  The 
available task types are: 
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 Create — Creates a new item in the plant 
 Update — Updates the selected properties of the specified item 
 Delete — Deletes the specified item from the plant 
 Manual — Creates and displays a reminder.  You can decide when a manual task is complete 

and set the status accordingly. 
Each task in the To Do List has a status.  Initially, the status is Open. If you successfully run the 
task, the status changes to Completed . If you attempt to run a task, but the process is not 

completed successfully, the status is changed to Error . Error status occurs, for example, if 
you attempt to run an Update task assigned to a drawing that is not currently open.  You can also 

postpone running a task and change its status to Deferred . 

 
 When an Update task is created in the To Do List, the units of measure used in properties are 

automatically converted to the defaults for the plant.  The software converts units of measure 
used for properties in Create tasks to the plant defaults when the task is run. 

 By clicking the To Do List column headings, you sort the list by the values in that column.  You 
can change the order in which these columns appear by selecting a column heading and 
dragging it to the left or right to the desired position. 

See Also 
Update the To Do List Display (on page 508) 
Remove Tasks from the To Do List (on page 506) 
Defer Tasks from the To Do List (on page 506) 
Run Tasks from the To Do List (on page 504) 
 

Set Preferences for the To Do List 
1. Log on to SmartPlant Instrumentation. 
2. Click File > Preferences. 
3. In the Preferences dialog box tree-view pane, click SmartPlant Integration > To Do List. 
4. Under Task execution, click the desired option to determine how the software executes tasks 

in the To Do List when you implement the Run command: 
 Execute — Executes tasks immediately. 
 Submit — Submits tasks for batch execution at a later stage. 

5. Select other options as desired. 
 

Modify To Do List Task Properties 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select the task that you want to edit. 

3. On the To Do List toolbar, click Properties . 
 You can also open the Task Properties dialog box by double-clicking a task in the To Do 

List. 
4. On the Task Properties dialog box, click the Details tab. 

 The properties available for each task depend on the type of task.  For all types, you can 
edit the name and notes for the task.  For Create tasks, you can ignore task properties when 
running a task.  You can also edit the item being created and turn off or on the values assigned to 
different properties for that item.  For Update tasks, you can turn off or on the new values 
assigned to properties for the item. 
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Run Tasks from the To Do List 
You run tasks to create, update, or delete data in the SmartPlant Instrumentation database with 
data from a retrieved document. 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select one or more tasks that you want to run. 

 
 You can configure the Run command to execute tasks immediately or to submit selected 

tasks for batch execution at a later stage.  For details, see Set Preferences for the To Do 
List (on page 503). 

 Before running tasks, you can select a filter to run only tasks that meet certain criteria, for 
example Update tasks only.  For details, see Filter To Do List Tasks (on page 505). 

 You can select specific data columns for which to transfer data values from the Details 
tab on the Task Properties dialog box. 

 You can select all the tasks in the To Do List by pressing Ctrl + A. 

3. On the To Do List toolbar, click Run . 

 
 When creating process data for which minimum, normal, and maximum values of a property 

apply, the software converts the minimum and maximum values to the normal units of 
measure, if different.   If there is no normal value, the software converts to the maximum units 
of measure, and if there are no normal and maximum values, only the minimum value is used.  
For updates, the software converts all values to the existing units of measure in SmartPlant 
Instrumentation. 

 When retrieving loops without equipment and tag numbers with equipment and then running a 
task that creates a relation between the loops and the tag numbers, you must ensure that the 
loop equipment is not set to propagate to the tag numbers by default, otherwise, the empty 
loop equipment value will overwrite the existing equipment values for the tag numbers.  To do 
so, before running the task, open the intools.ini file, and under the [Index] section, type the 
following line:  
LoopNoPropagateCheck=1 

 

Task Dependencies 
When you run tasks, there are some task types that require other tasks to run first.  For example, 
if two tasks exist for an item, one to move it to another <unit>, and the other to update some of the 
item properties, the software cannot run the update task until the Move task is complete.  The 
software analyzes the To Do List for these dependencies to ensure that the tasks run in the 
appropriate sequence.  The following table indicates the dependencies that can exist between 
different task types. 

Master Task Dependent Task 

Claim Move 

Claim Update 

Move Update 
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Task dependencies influence the way in which the result of running a master task affects the 
status of the dependent tasks.  On running a task, the software checks the To Do List for 
prerequisites, and changes the status of relevant tasks from New to Submitted.  If the status of a 
prerequisite task is Deferred, Deleted, or Failed, then the software marks all dependent tasks as 
Failed. 
Another example of task dependencies is where you have related tasks for items in a hierarchical 
relationship; for example Panel - Rack - Slot - I/O card -Terminal.  You can select a particular 
task, such as a Create task for an I/O card, and use the Select Parent Tasks  or Select 
Sub-Tasks  commands to highlight the desired set of related tasks. 
 
 

Complete a Task from the To Do List 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select one or more tasks to complete. 

 You can select all the tasks in the To Do List by pressing Ctrl + A. 

3. On the To Do List toolbar, click Complete . 
 

Sort To Do List Tasks 
This procedure enables you to sort the To Do List tasks by task properties such as Status, Task 
Type, Item Type, and Item Name. 
1. Click SmartPlant > To Do List. 

2. On the To Do List toolbar, click Sort Tasks . 
3. On the Sort dialog box, select a property under the Available columns list. 
4. Do one of the following: 

 Click Add. 
 Drag the selected property to the Sort by pane. 

5. Repeat for other properties that you want to sort by.  
 After selecting the columns, you can change the sort order for the properties by selecting 

a column in the Sort by pane and clicking Move Up or Move Down as needed. 
6. If you want to specify sorting for a particular column by descending order of the values, select 

the Descending check box beside that column.  Clear the check box to sort by that column in 
ascending order. 

 

Filter To Do List Tasks 
This procedure enables you to filter the To Do List tasks by task properties or for tasks with 
specific values.  For example, you may want to filter only those tags with task type Create. 
1. Click SmartPlant > To Do List. 

2. On the To Do List toolbar, click Filter Tasks . 
3. On the Filter dialog box, click Add to specify a new filter condition. 
4. Specify the filter condition by selecting the desired parameters from the Property, Operator, 

and Value columns; for example, you can specify the condition: 
Task Type = Create 

5. If desired, specify additional filter conditions. 
6. For two or more conditions, specify the logic (AND or OR) between each pair of successive 

conditions. 
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Defer Tasks from the To Do List 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select one or more tasks that you want to defer. 

 You can select all the tasks in the To Do List by pressing Ctrl + A. 

3. On the To Do List toolbar, click Defer . 
 If you choose to defer a task that has related sub-tasks, we recommend that you first run 

the Select Sub-Tasks command  and invoke the Defer command on all the selected 
tasks.  Otherwise, if you try to run tasks where only the parent task is deferred, the software 
generates errors. 

 

Remove Tasks from the To Do List 
This procedure enables you to delete tasks that are no longer needed from the To Do 
List.  Permanent deletion of tasks is a two-stage operation.  First, you need to move the task from 
the To Do List to a buffer that displays tasks intended for deletion.  If necessary, you can restore 
tasks in the buffer to the To Do List.  Next, you delete the task from the buffer.  When you delete 
the task from the buffer, the software removes it from the database and it cannot be restored. 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select one or more tasks that you want to remove. 

 You can select all the tasks in the To Do List by pressing Ctrl + A. 

3. On the To Do List toolbar, click Delete . 
 If you choose to remove a task that has related sub-tasks, we recommend that you first 

run the Select Sub-Tasks command  and invoke the Delete command on all the selected 
tasks.  Otherwise, if you try to run tasks where only the parent task is deleted, the software 
generates errors. 

 

Display Deleted To Do List Tasks 
1. Click SmartPlant > To Do List. 

2. On the To Do List toolbar, click View Deleted Tasks . 
 To return to the To Do List, click this command again. 

3. To delete tasks permanently, select the tasks that you want to delete, and on the toolbar, click 
Delete . 
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Ignore To Do List Tasks 
This procedure enables you to set as ignored those tasks that you do not want to run each time 
you retrieve data.  Ignored tasks are moved to a separate buffer.  In contrast to deferred or 
deleted tasks, the software continues not to run ignored tasks even after subsequent retrieval. 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select the Create tasks that you want to be ignored. 

3. On the To Do List toolbar, click Ignore . 
 If you choose to ignore a task that has related sub-tasks, we recommend that you first 

run the Select Sub-Tasks command  and invoke the Ignore command on all the selected 
tasks.  Otherwise, if you try to run tasks where only the parent task is ignored, the software 
generates errors. 

 

Ignore Task Properties 
1. Click SmartPlant > To Do List. 
2. In the To Do List window, select a Create task for which you want to ignore properties. 

3. On the To Do List toolbar, click Properties . 
4. On the Task Properties dialog box, click the Details tab. 
5. Select the Ignore check box beside each property that you want the software to ignore when 

you run the task. 

 
 When you select to ignore a property, the software does not update that property when you 

run the task for the current or for subsequent retrieve sessions.  If the new value of the 
property changes in the published data, on the next retrieve, that property is no longer ignored.  
If you want to ignore the property only for the current retrieve session, clear both the Activate 
and Ignore check boxes beside the property. 

 After running a task that includes ignored properties, that task is copied from the To Do List to 
the ignored tasks list, where only the properties that were selected to be ignored appear on the 
Details tab. 

 

Display Ignored To Do List Tasks 
1. Click SmartPlant > To Do List. 

2. On the To Do List toolbar, click View Ignored Tasks . 
 To return to the To Do List, click this command again. 

3. To delete ignored tasks permanently, select the tasks that you want to delete, and on the 
toolbar, click Delete .  This action makes the task available from the To Do List the next 
time you retrieve the document to which the task belongs. 
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Run a To Do List Report 
1. Click SmartPlant > To Do List. 

2. On the To Do List toolbar, click Report . 
 

Update the To Do List Display 
Updating the To Do List display is useful when several users can access the To Do List, and you 
want to refresh the display with the latest information from the SmartPlant Instrumentation 
database after another user has modified the item specified by the task. 

 On the To Do list toolbar, click Refresh . 
 

SQL Server uses data files which are resized automatically as the data grows, until the disk is 
full.  When this happens, you can add another data file on a different disk.  The following tasks 
are used frequently when you need to perform database maintenance tasks on SQL Server. 

Add a Filegroup 
Filegroups are used as containers for datafiles.  A filegroup can be connected to one database 
only.  Usually, two filegroups are used for each domain: one for data tables and the other for table 
indexes. You can backup and restore data for a filegroup.  A primary filegroup contains stored 
procedures and triggers.  When deleting a domain, the entire filegroup and the datafiles it 
contains are deleted, resulting in cleaner data, without causing damage to the database.  For 
more information, see Add a Filegroup. 

Print Filegroup Information 
This procedure explains how the System Administrator can display the list of all the existing SQL 
Server filegroups and print out the filegroup information.  For more information, see Print 
Filegroup Information. 

Add a Log File 
The database log file is used internally by SQL Server to backtrack aborted user sessions.  This 
way you can resume any previous sessions that you stopped or canceled.  This procedure 
explains how to add a log file.  For more information, see Add a Log File. 

Add a Datafile to the TEMPDB Database 
This procedure enables you to add a datafile to the SQL Server TEMPDB Database.  This 
database is used internally by the SQL Server to make all the required temporary 
operations.  Such operations are needed when SmartPlant Instrumentation brings data in a 
certain order, and the database needs to sort this set of data after retrieving it.  For more 
information, see Add a Datafile to the TEMPDB Database. 

Optimize Indexes 
This procedure enables you to optimize fragmented SQL Server indexes.  The SQL Server 
indexes become fragmented during the domain lifetime and contribute to database 
under-performance.  In this case you can rearrange your SQL Server indexes to optimize 
them.  As you keep storing and deleting domain data, the SQL Extents become disordered thus 
slowing down SQL command execution.  SmartPlant Instrumentation solves this problem by 
reordering the indexes stored in these Extents.  For more information, see Optimize Indexes. 
 



 Working with SmartPlant Integration 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 509 
 

 

1. With the System Administration window open, click DBA > Add Datafiles. 
2. Click the Filegroup tab. 
3. In the System Admin. Password field, type the password to log on as the Database System 

Administrator (this field is empty by default). 
4. In the New file information section, type the datafile name, the datafile location, and the 

initial size (in MB). 
5. Click Add to add the filegroup. 
 

1. Start the Administration module and log on as System Administrator. 
2. With the System Administration window open, click DBA > Filegroup List. 
3. In the Filegroup List dialog box, review the existing filegroup information. 
4. Click Print to print out the information displayed in the data window of the Filegroup List 

dialog box. 
5. Click Close. 
 

 You should exercise caution when adding a log file, as doing so affects the entire SQL 
Server. 
1. With the System Administration window open, click DBA > Add Datafiles. 
2. Click the Log tab. 
3. In the System Admin. Password field, type the password to log on as the Database System 

Administrator (this field is empty by default). 
4. In the New file information section, type the datafile name, the datafile location, and the 

initial size (in MB). 
5. Click Add to add the filegroup. 
 

 On SQL Server, TEMPDB is automatically incremented and depends on a disk 
size.  If TEMPDB reaches the disk limit, you can increase the TEMPDB database size by adding 
a datafile to another disk. 
1. With the System Administration window open, click DBA > Add Datafiles. 
2. Click the Tempdb tab. 
3. In the New file information section, type the datafile name, the datafile location, and the 

initial size (in MB). 
4. Click Add to add the datafile to the TEMPDB database. 
 

 Before starting the optimization process, make sure that no other user is using the 
currently selected domain.  If you attempt to optimize the indexes of a domain which is currently 
being used by another user, the software displays a message warning you that the domain is 
currently in use. 
1. With the System Administration window open, click DBA > Optimize Indexes. 
2. From the Domain list, select the required domain. 
3. Do one of the following to define the tables you want to include in the optimization process: 

 Click All tables to optimize the indexes of all the existing tables in the defined domain. 
 Click Selected tables to display the database indexes in the Table Name data window 

and optimize the indexes of the highlighted tables in the defined domain. 
4. Do one of the following to define the index source on which you base the optimization: 

 Click Current database to optimize indexes using the current database indexes. 
 Click Template database to optimize indexes using the IN_TEMPL.DB template 

database indexes.  Use the Template database option if your current database indexes 
have been deleted or become unusable. 
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5. Click OK. 
 To enable better performance after completing the index optimization process, you need to 

update statistics.  Start the Query Analyzer and run the SP_UPDATESTATS procedure. 
 

The following tasks are used frequently when you need to perform database maintenance tasks 
on Oracle. 

View Tablespace Data 
Tablespaces are database domains where Oracle keeps your SmartPlant Instrumentation 
database information.  The tablespace data is physically stored in one or more files.  This option 
allows you to view a list of tablespaces in which there is still free space to store data.  For more 
information, see View Tablespace Data. 

Add Datafiles to Tablespaces 
If your system reports that you ran out of space in the database tablespaces or if the system fails 
to perform, you can use this option to increase the database tablespace by attaching additional 
datafiles to an existing tablespace.  For more information, see Add Datafiles to Oracle 
Tablespaces. 

Optimize Indexes 
You can use this option to optimize fragmented Oracle database indexes.  Oracle database 
indexes become fragmented during the domain lifetime and contribute to database 
under-performance.  In this case, you can rearrange your database indexes to optimize 
them.  The domain index data is generated during the initialization phase.  The index data is 
grouped into one or more Extents which may account for the index fragmentation level.  As you 
keep storing and deleting domain data, the Oracle Extents become disordered thus slowing down 
SQL command execution.  SmartPlant Instrumentation solves this problem by reordering the 
indexes stored in these Extents.  For more information, see Optimize Indexes. 

Update Statistics 
This option enables you to improve the Oracle SQL command processing performance, especially 
after a large data import or after optimizing indexes, or after initializing a domain on 
Oracle.  During updating the statistics, SmartPlant Instrumentation executes an ANALYZE SQL 
command which retrieves the statistical data for the SmartPlant Instrumentation tables.  That 
statistical information is later used by the Oracle Cost-based Optimizer to optimize SQL command 
execution.  For more information, see Update Statistics. 
 

 With the System Administration window open, click DBA > Tablespaces List to display the 
data for all filegroups that have free space for storing data. 

 To learn about Oracle tablespaces used in SmartPlant Instrumentation, see Oracle 
Database Server Tablespaces for SmartPlant Instrumentation. 
 

 

 This procedure enables you to the add a datafile to a tablespace.  Therefore, make 
sure you have enough free disk space on the drive where the tablespace is stored. 
1. With the System Administration window open, click DBA > Add Datafiles. 
2. From the Tablespace list, select the tablespace you want to resize. 
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3. In the Datafile name box, type the full path and name of a new additional datafile that you 
want to attach to the currently selected tablespace. 

 
 Ensure that you select a datafile which is not currently in use. 
 The datafile format must be .db. 

4. In the Datafile size box, type the size of the additional datafile. 
5. Click OK and make sure the software displays a message notifying you that the selected 

tablespace was increased successfully. 
 

 
 Before optimizing indexes in SmartPlant Instrumentation tables, make sure that in the Oracle 

Instance Configuration file, the OPTIMIZER_MODE parameter value is either CHOOSE 
(default) or COST.  This way, you activate the Oracle Cost-based Optimizer, which 
determines the quality of the SmartPlant Instrumentation database performance. 

 Before starting the optimization process, make sure that no other user is using the currently 
selected domain.  If you attempt to optimize the indexes of a domain which is currently being 
used by another user, the software displays a message warning you that the domain is 
currently in use. 

1. With the System Administration window open, click DBA > Tuning >Optimize Indexes. 
2. From the Domain list, select the domain in which you want to optimize indexes. 

 
 The Fragmentation column displays the number of Extents of each index. 
 It is recommended to optimize all database indexes whose fragmentation level is higher 

than 4. 
3. Do one of the following: 

 Click All tables to optimize the indexes for all the tables in the selected domain. 
 Click Selected tables to display in the data window all the tables in the current domain 

and optimize the indexes for the required tables. 
4. Click OK to start the optimization process. 

 To enable better performance after completing the index optimization process, you need to 
update statistics.  Without updating statistics, the Oracle Cost-based Optimizer cannon use the 
reordered indexes. 
 
 

 With the System Administration window open, click DBA > Tuning > Update Statistics. 
 This option is available to both System and Domain Administrator when using 

SmartPlant Instrumentation on Oracle. 
 

 

The following tasks are used frequently when you need to perform general database maintenance 
tasks. 

Define Databases for Logging On to SmartPlant Instrumentation 
Use this procedure to enable SmartPlant Instrumentation users to select a database when logging 
on to SmartPlant Instrumentation.  After performing this procedure, users can select a database 
from the Database list on the Logon Information dialog box and connect to this database.  All 
the databases that you want to make available for connection must belong to the same database 
platform: Oracle, SQL Server, or Sybase Adaptive Server Anywhere.  For more information, see 
Define Databases for Logging On to SmartPlant Instrumentation. 
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Switch Between Databases 
Use this procedure to switch from one database to another using the Intools.ini file.  In this 
procedure, the following Sybase Adaptive Server Anywhere databases are used as an example: 
 Intools.db — Empty database used as a seed for building databases 
 In_demo.db — Demonstration database used for practice and as a reference 

For more information, see Switch Between Databases. 

Rebuild Default Views in Domains 
Use this procedure to rebuild the default views of all the database objects for a specific 
domain.  You must rebuild the default views after upgrading SmartPlant Instrumentation to 
Version 2009.  This is because during the upgrade, the software makes changes to certain tables, 
and as a result,  the default views associated with these tables might become invalid.  For more 
information, see Rebuild Default Views in Domains. 

Rebuild Stored Procedures and Triggers 
This procedure is used by the System Administrator for the following purposes: 
 To identify abnormal database behavior and solve it by rebuilding the stored procedures and 

triggers in the database if the software displays inappropriate SQL messages when using 
SmartPlant Instrumentation. 

 To enable users who have a full version of Sybase Adaptive Server Anywhere engine 
(dbeng10.exe) to work in a domain backed up to Sybase Adaptive Server Anywhere 
(INtools_Backup.db or its copy). 

You can rebuild stored procedures either for the Admin schema or for a specific Domain 
schema.  For more information, see Rebuild Stored Procedures and Triggers. 

Rebuild Catalog Tables 
Use this procedure to rebuild the catalog tables, which enable users to work with multi- tag 
specifications in the Specifications module.  The software creates the catalog tables during the 
SmartPlant Instrumentation database setup.  If the software encounters a database problem 
when creating the catalog tables, you can try to rebuild them to resolve the problem.  If such a 
problem occurs, the software displays a message notifying you that you cannot work with multi-tag 
specifications due to a problem with the catalog tables.  For more information, see Rebuild 
Catalog Tables. 
  
 

Prerequisites for SQL Server 
 You must define a separate ODBC profile for each database you want to make available for 

selection on the Logon Information dialog box of SmartPlant Instrumentation.  This is 
required because SQL Server uses an ODBC profile to connect to the SmartPlant 
Instrumentation database.  When you install SmartPlant Instrumentation on a client machine, 
in the client Windows registry, the software creates an empty profile.  For SQL Server 2005, 
the default ODBC profile is MSS2005.  After running the DB Setup Utility, the software 
automatically fills in the profile setting in the client Windows Registry and adds a database 
connection string in the [Database] section of the Intools.ini file.  If you run the DB Setup Utility 
again to create another SmartPlant Instrumentation database in SQL Server, the software 
overwrites the previous connection settings in the Intools.ini file.  Therefore, you cannot use 
the same ODBC profile for connection to different databases.  You create a new ODBC profile 
using the Windows Data Sources (ODBC) option and define a unique DSN value, for 
example, MSS2005_1. 
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 Make sure that in the [Database] section of the Intools.ini file, the MSS value of the DBMS 
parameter appears in upper case.  Otherwise, it is not possible to work with specifications in 
SmartPlant Instrumentation. 

Prerequisite for Sybase Adaptive Server Anywhere 
 You must define an ODBC profile for each database you want to make available for selection 

on the Logon Information dialog box of SmartPlant Instrumentation.  You can create ODBC 
profiles using the Internal Setup Utility or Windows Data Sources (ODBC) option. 

Define Databases 
1. In the Intools.ini file, create a [Profiles] section and define the list of databases you want to 

display on the Logon Information dialog box in the Database list: 
[Profiles] 
Database1=My_Database1 
Database2=My_Database2 
Database3=My_Database3 
Default=My_Database1 

 
 The Database<number> parameter does not have to be the actual name of the database 

(or profile names if the database type is SQL Server or Sybase Adaptive Server 
Anywhere).  This value is a display name that appears in the Database list on the Logon 
Information dialog box. 

 The Default parameter value is the database that appears selected by default in the 
Database list on the Logon Information dialog box. 

2. For each database that appears in the [Profiles] section, create a separate section with the 
appropriate profile name and define the connection parameters.  

 Do not delete the original [Database] section.  
The following table shows one example for each database type. 

Example for Oracle Example for SQL Server 2005 Example for Sybase Adaptive 
Server Anywhere 

[My_Database1] 
DBMS=O10 
LogId=IN_DBAMN 
LogPassword=IN_DBAMN 
ServerName=Oracle 
Database=ORC1 
UserId= 
DatabasePassword= 
TableDir=0 
StayConnected=1 
AutoCommit=0 
DBParm='DisableBind=1' 
Prompt=110 
Commit=100 

[My_Database2] 
DBMS=MSS 
LogId=SPI_DBAMN 
LogPassword=SPI_DBA 
ServerName= 
Database= 
UserId= 
DatabasePassword= 
TableDir=0 
StayConnected=1 
AutoCommit=0 
DBParm="ConnectString='DSN=
MSS2005;UID=SPI_DBAMN;PW
D= 
SPI_DBA',DisableBind=1" 
DSN=MSS2005 
Prompt=110 
Commit=100 

[My_Database3] 
DBMS=ODBC 
LogId=IN_DBAMN 
LogPassword=IN_DBAMN 
ServerName= 
Database= 
UserId= 
DatabasePassword= 
TableDir=0 
StayConnected=1 
AutoCommit=0 
DBParm=ConnectString='DSN= 
IN_DEMO;UID=IN_DBAMN;PWD=
IN_DBAMN' 
Prompt=110 
Commit=100 
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 When the database type is SQL Server, the DisableBind=1 is not the only value of the 

DbParm parameter.  Make sure that it is not enclosed by single quotes and is separated 
from other values by a comma, as shown in the example in the table. 

 The LogId parameter value corresponds to the default Admin schema logon 
name.  When your database resides in SQL Server, the default Admin schema logon 
name is SPI_DBAMN.  This setting must be different from the Admin schema logon 
password, which is the value of the LogPassword parameter. 

3. Save and close the Intools.ini file. 
4. Test the software by opening Logon Information dialog box and checking the Database list 

values. 
 The databases that appear in the Logon Information dialog box are specific to the 

platform to which you have connected; databases belonging to other platforms do not appear. 
 The database users select on the Logon Information dialog box becomes the default 

database. 

 
Working with Administration Module 
Domain Administration 
System Administration 
 

In the [Database] section of your Intools.ini file, the following lines appear for logging on to the 
databases: 
 For the demo database: 
dbparm=connectstring='dsn=in_demo;uid=in_dbamn;pwd=in_dbamn' 

 For the empty database: 
dbparm=connectstring='dsn=intools;uid=in_dbamn;pwd=in_dbamn' 

1. If the line representing the database that you want to access begins with a semicolon (;), 
remove it. 

2. Insert a semicolon at the beginning of the line representing the database that you do not want 
to access. 

 

 
 You can only rebuild the default views supplied with the SmartPlant Instrumentation 

database.  You cannot rebuild any user-defined views. 
 Make sure that all users have logged out of the database before starting this procedure. 

1. With the System Administration window open, click DBA > Rebuild Default Views in 
Domains. 

2. From the Domain list, select the domain whose database views you want to rebuild. 
3. In the View-Only Domain schema password box, enter the logon password of the 

View-Only Domain schema.  The password characters appear masked. 
 You can change the password only once, when initializing a new domain.  If you did not 

change the password when initializing the selected domain, enter the default logon password, 
which is <Domain schema logon name>_VIEW. 

4. If working on SQL Server, type the SQL Server System Administrator’s password. 
5. Click OK to start rebuilding the views of the selected domain. 
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 This procedure should only be carried out when you are specifically instructed to do so by 

Intergraph Support. 
 Make sure that all users have logged out of the SmartPlant Instrumentation database before 

starting this procedure.  When you start rebuilding stored procedures and triggers, no users 
should attempt to log on to SmartPlant Instrumentation. 

Create a Batch Rebuild File 
As in batch upgrade, you can create a .bat file that rebuilds stored procedures and triggers for 
multiple domains simultaneously. The following procedure describes how to create a batch rebuild 
file. 
1. In Notepad, create a batch file (for example, BatchRebuild.bat). 
2. Enter a line for each domain you are asked to rebuild stored procedures and triggers for, as 

shown in the example below: 
Upgrade -9999   //rebuild stored procedures and triggers 
for admin schema 
Upgrade -<proj_id>  //rebuild stored procedures and triggers 
for a specific domain 

3. Double-click the batch file to run it and rebuild stored procedures and triggers for the defined 
domains. 

 You can schedule the batch file to run at a convenient time using Windows scheduler (for 
example, during the night or over the weekend). 

Rebuild Stores Procedures and Triggers Manually 
1. With the System Administration window open, click DBA >Rebuild Stored Procedures 

and Triggers. 
2. Do one of the following: 

 Click Admin schema to rebuild stored procedures and triggers of the Admin schema. 
 Click Domain schema and then, under Domain, select a domain for which you can 

rebuild stored procedures and triggers. 
3. Click OK. 

 
 When rebuilding stored procedures and triggers of the Admin schema, the Domain list is 

redundant. 
 If the process stops for any reason, you can restart the process and the process continues 

from where it stopped.  If you get an error that cannot be corrected, contact Intergraph 
Support with the error description.  It is recommended that you have your log file 
available when contacting Intergraph Support. 

4. On the Rebuild Stored Procedures dialog box you can click Browse to specify the log file 
path and filename, if you do not want to use the default Log.txt file.  This file contains 
information of the current session and any errors that may have occurred in previous 
sessions.  The log file is concatenated, if you use the same log file name. 

5. Click OK to start rebuilding the stored procedures and triggers of the selected schema. 
At the end of the process, an appropriate message is displayed and an additional log file 
Logerror.txt is generated in the SmartPlant Instrumentation home folder.  The data in the 
Logerror.txt file is incremented between sessions. Send the Logerror.txt file to Intergraph 
Support after you complete the process. 
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 Make sure that all users have logged out of the SmartPlant Instrumentation database 
before starting this procedure. 
1. With the System Administration window open, click DBA >Rebuild Catalog Tables. 
2. Click OK to start rebuilding all the catalog tables. 
 



 

 

SmartPlant Instrumentation Basic Engineering User's Guide 517 
 

S E C T I O N  3 5  

You use the SmartPlant Instrumentation Explorer to access and manage all the items that exist 
in SmartPlant Instrumentation.  SmartPlant Instrumentation features the Domain Explorer and 
the Reference Explorer. 
 Domain Explorer — this view of the SmartPlant Instrumentation Explorer allows you to 

create and manage your current domain items.  You can perform almost all the actions that 
are possible in the SmartPlant Instrumentation modules.  For example, you can create new 
tag numbers, edit their properties, create and edit wiring items, make wiring connections, 
generate various data sheets, reports, and so forth.  Also, you can copy items from the 
Reference Explorer and this way create items based on reference configurations on the 
fly.  The Domain Explorer displays instrumentation items according to hierarchical 
structure.  You can arrange the hierarchical structure of the data according to the item types, 
the physical location of the items, or the item sequence within their parent item.  For more 
information, see Working with the Domain Explorer (on page 519). 

 Reference Explorer — allows you to create and manage all the available wiring reference 
items that are created by SmartPlant Instrumentation users and that are provided with the 
software.  Note that wiring reference items are typical configurations that facilitate rapid 
creation of various wiring items in your domain.  For more information, see Working with the 
Reference Explorer. 

 When you create an item in the domain explorer, make sure you set the naming convention 
for it in the Administration module.  For details, see Naming Conventions: An Overview in the 
Administration User's Guide, under Domain Administration. 
 
  

SmartPlant Instrumentation Explorer 
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S E C T I O N  3 6  

Working with the Domain Explorer 
You use the Domain Explorer to create and manage your current domain items.  The Domain 
Explorer displays instrumentation items according to hierarchical structure.  You can arrange the 
hierarchical structure of the data according to the item types, the physical location of the items, or 
the item sequence within their parent item . 

 When you create an item in the domain explorer, make sure you set the naming convention 
for it in the Administration module.  For details, see Naming Conventions: An Overview in the 
Administration User's Guide, under Domain and Project Administration. 
The Domain Explorer enables you to perform almost all the actions that are possible in the 
SmartPlant Instrumentation modules.  For example, you can create new tag numbers, edit their 
properties, create and edit wiring items, open the Connection window to make wiring 
connections, generate various data sheets, reports, and so forth.  You can drag items from the 
Reference Explorer to the Domain Explorer and in this way create numerous items based on 
reference configurations on the fly.  Also, you can drag items from the Domain Explorer to the 
Reference Explorer to create reference items based on existing configurations. 
Working with the Domain Explorer is another mode of working with SmartPlant Instrumentation, 
just like working with SmartPlant Instrumentation modules. 
You can open the Domain Explorer from anywhere in SmartPlant Instrumentation.  Press F7 or 
on the Tools menu, click Domain Explorer. 

 
 Depending on the access rights that have been granted to you, the Domain Explorer allows 

you to perform actions with SmartPlant Instrumentation items that belong to all the existing 
<plants> in your domain and not just with the items in the plant that you have currently logged 
in. 

 You can expand the hierarchy of any <unit> and view the item structure.  However, 
specification, process data, or calculation sheets are only accessible from the <unit> you have 
logged on to.  Process data, specification, and calculation sheets of items belonging to 
<units> that you are not logged to are not accessible even for viewing. 

The tree view pane of the Domain Explorer shows instrumentation items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the menus depend on the currently selected item type. 
For a detailed explanation of all the folders and their organization in the Domain Explorer, see 
The Organization of Items in the Domain Explorer Tree View (on page 525). 
Item status indicators — the software uses various icons beside a folder or item to indicate the 
status of a folder or an item , for example access denied, view only, an item that belongs to 
As-Built, and so forth.  For the full list of the item indicators, see Item Status Indicators in the 
Domain Explorer (on page 540). 

 
 You can open several instances of the Domain Explorer by pressing F7. 
 After exiting SmartPlant Instrumentation, and starting a new session, the software retains the 

size and position of all the windows that were open in the previous session. 
Some SmartPlant Instrumentation modules have their own Explorers.  These are just limited 
views of the Domain Explorer and they contain items specific to their modules.  For details, see 
SmartPlant Instrumentation Explorer (on page 517). 
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Domain Explorer Window 
You use the Domain Explorer to create and manage your current domain items.  The Domain 
Explorer displays instrumentation items according to hierarchical structure.  You can arrange the 
hierarchical structure of the data according to the item types, the physical location of the items, or 
the item sequence within their parent item. 
The Domain Explorer enables you to perform almost all the actions that are possible in the 
SmartPlant Instrumentation modules.  For example, you can create new tag numbers, edit their 
properties, create and edit wiring items, open the Connection window make wiring connections, 
generate various data sheets, reports, and so forth.  Also, you can copy items from the 
Reference Explorer and this way create items based on reference configurations on the fly. 
Working with the Domain Explorer is another mode of working with SmartPlant Instrumentation, 
just like working with SmartPlant Instrumentation modules. 
You can open the Domain Explorer from anywhere in SmartPlant Instrumentation.  Press F7 or 
click Tools > Domain Explorer. 

 
 Depending on the access rights that have been granted to you, the Domain Explorer allows 

you to perform actions with SmartPlant Instrumentation items that belong to all the existing 
plants in your domain and not just with the items in the plant that you have currently logged in. 

 You can expand the hierarchy of any <unit> and view the item structure.  However, 
specification, process data, or calculation sheets are only accessible from the <unit> you have 
logged on to.  Process data, specification, and calculation sheets of items belonging to 
<units> that you are not logged to are not accessible even for viewing. 

The main features of the Domain Explorer are as follows. 
(List of Views) — Allows you to select the standard Domain Explorer view or a custom view that 
you have defined.  To add items to a custom view, right-click a folder in the tree view pane or 
multiple folders in the Items pane and then on the shortcut menu click Add to Custom View and 
then click an appropriate custom view command. 

New Custom View  — Opens the Custom View Properties dialog box where you can define 
custom views. 

Toolbar 
Search  — Opens the Search dialog box where you can look for items that you want to work 
with. 

Refresh  — Updates the Domain Explorer display.  This feature is useful where multiple 
users are working on the same set of data. 

Filter  — Allows you to filter the items in the Domain Explorer display.  You can use this 
toolbar command if you do one of the following: 
 Do not select anything in the Explorer tree view — this allows you to filter the entire tree view 

according to a specific item name. 
 Select the root node in the Explorer tree view — this allows you to filter the entire tree view 

according to a specific item name. 
 Select a tree view node whose immediate child items are folders and not plant items — this 

allows you to filter the entire tree view according to a specific item type that you select from the 
Item type list on the Filter Definition dialog box. 

 Select any tree view node or folder that contains child item to filter that node or folder 
according to a specific item type. 
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View  — Toggles through each view of the items in the Items pane.  You can click the 
arrow and select the desired view. 

Find  — Opens the Find Item dialog box where you can look for a specific item in the tree 
view. 

Print  — Prints the browser view that you selected for the current hierarchy node.  This button 
becomes available only after selecting the Show Browser command. 

Tree View Pane 
The tree view pane of the Domain Explorer shows instrumentation items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the menus depend on the selected item type. 
Expand or collapse the hierarchy by clicking the  and  icons respectively or by double-clicking 
a folder.  Expand a folder to display the items.  If you cannot expand a folder, that folder is 
empty.  To perform an action, right-click a folder or an item and then click a command.  Also, to 
move an item to another parent item , drag that item to another folder or a parent item as you 
require. 
After you double-click the top level of your plant hierarchy, the tree view shows the Domain 
Explorer folders and the next level of the plant hierarchy.  The following is a brief description of 
the item arrangement in the folders: 
 Loops and instrument tags are arranged at the lowest level of the plant hierarchy.  You can 

navigate to a loop or an instrument tag by expanding the plant hierarchy.  Continue expanding 
your plant hierarchy to display the Loops and Instruments folders.  The Instruments folder 
contains all the existing instrument tags in the current <unit>.  Instrument tags can be parent 
items of CS tags, specification sheets, process data sheets, and any other documents that are 
associated with the selected tag number.  Also, there are several other folders that contain 
view-only information. 

 Panels are arranged by their locations and categories.  Therefore, you can access a panel 
and its child items by expanding the Panels by Location or Panels by Category 
folder.  Panels, in turn, contain other wiring items such as racks, wiring equipment, terminal 
strips, and so forth. 

 Cables and their child items are arranged in a separate folder.  There is also a separate folder 
for cross cables. 

 Process equipment and lines are arranged in separate folders.  Right-clicking the Process 
Equipment folder allows you to create a new process equipment item .  Right-clicking the 
Lines folder allows you to create a new line. 

 Hook-ups are arranged in a folder at top level of the tree view.  You can expand the 
Hook-Ups folder to access all the existing hook-ups and their child items.  Right-clicking the 
Hook-Ups folder allows you to create a new hook-up types and hook-ups. 

 CAD drawing are arranged in the Drawing Block Types folder at top level of the tree 
view.  You can expand the Drawing Block Types folder to access all the existing block types 
and blocks.  In this folder, you create your current <plant> blocks but you do not make any 
associations.  you can associate blocks with loops or instruments only in the Loops folder or 
using the Loop Drawings module options. 

 There are several other folders at the top level of the tree view.  These folders hold P&IDs, 
Telecom panels, Foundation Fieldbus segments, controllers, and test equipment.  Note that 
some of these folders only display the existing items and do not allow you to create new ones. 

For a detailed explanation of all the folders in the Domain Explorer, see The Organization of 
Items in the Domain Explorer Tree View (on page 525). 
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Item status indicators — the software uses various icons beside a folder or item to indicate the 
status of a folder or an item , for example access denied, view only, an item that belongs to 
As-Built, and so forth.  For the full list of the item indicators, see Item Status Indicators in the 
Domain Explorer (on page 540). 

Items Pane 
The Items pane (list view) pane of the Domain Explorer displays the individual items that 
comprise the hierarchy of the item or the folder that you selected in the tree view.  You can 
choose one of the following three ways to display the items in this pane: 
 List — Displays the individual items that comprise the hierarchy of the item or the folder that 

you selected in the tree view. 
 My List — Allows you to create a special view of the Items pane where you can keep items 

that belong to various folders in the tree view.  The software retains all the items in the My List 
view until you remove them from that list.  The list count displays the number of items 
displayed in the List pane. 

 Show Browser — Allows you to display a browser view in the Items pane for an item type or 
a folder that you select in the Domain Explorer tree view.  This way, instead of displaying 
child items, you can display item properties of the item you selected in the tree view 
pane.  The software allows you to print out the current browser view, however, you cannot edit 
the item properties. 

 List count — Displays the number of individual items that comprise the hierarchy of the item 
or the folder that you selected in the tree view. 

 
 You can open several instances of the Domain Explorer by pressing F7. 
 After exiting SmartPlant Instrumentation, and starting a new session, the software retains the 

size and position of all the windows that were open in the previous session. 
 Some SmartPlant Instrumentation modules have their own Explorers.  These are just limited 

views of the Domain Explorer and they contain items specific to their modules.  For details, 
see SmartPlant Instrumentation Explorer (on page 517). 

 

Domain Explorer Common Tasks 
The following tasks are used frequently when you work with the Domain Explorer. 

Create an Item in the Domain Explorer 
This procedure shows how to create an item in the Domain Explorer.  For more information, see 
Create an Item in the Domain Explorer (on page 540). 

Edit Item Properties 
This procedure explains how to edit the properties of an item that you select in the Domain 
Explorer.  For more information, see Edit Item Properties (on page 541). 
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Duplicate an Item 
You use this action to create a duplicate item within the same parent hierarchy.  That is, the 
software creates another copy of the selected item under the immediate parent item.  For 
example, if you need to insert an apparatus within an existing apparatus group, expand an 
apparatus group and duplicate an apparatus.  You can then change the sequence numbers of the 
apparatuses to re-arrange them on the strip the way you require.  Furthermore, if you are 
duplicating a panel or another item that contains child items, the software duplicates this item in its 
entirety.  That is, SmartPlant Instrumentation creates the new item with exactly the same child 
items as the original panel.  Note that in this case, the software also retains all the existing internal 
connections if you selected Copy internal connections in the wiring preferences.  For more 
information, see Duplicate an Item (on page 541). 

Move an Item in the Domain Explorer 
This feature allows you move an item from one parent item to another within the Domain 
Explorer.  This can be very helpful when, for example, you want to move a terminal strip to 
another panel.  If you are moving an item that contains child items, the software moves the 
selected item together with all its child item. 
Note that the same rules apply when you want to move an item in the Reference Explorer.  If you 
drag an item from the Reference Explorer to the Domain Explorer or vice versa, SmartPlant 
Instrumentation creates a copy of that item and retains the selected one in its original place.  If 
you open another instance of the Domain Explorer and drag an item from one Domain Explorer 
window to another, the same rules apply as when you drag an item within the same Domain 
Explorer window. 
For more information, see Move an Item in the Domain Explorer (on page 541). 

Delete Items 
This procedure shows how to delete the items that you select in the Domain Explorer.  For more 
information, see Delete Items (on page 541). 

Search for Items in SmartPlant Instrumentation Explorer 
You use this feature to find items that you want to work with.  You can search for multiple items in 
the entire domain, the current highest plant hierarchy level, or the current lowest plant hierarchy 
level.  The term "current" refers to the plant hierarchy level that you selected in the Open dialog 
box when you started SmartPlant Instrumentation.  For more information about searching for 
items, see Search for Items in SmartPlant Instrumentation Explorer (on page 542). 

Find an Item in the Tree View of an Explorer Window 
This feature enables you to find an item in the Domain Explorer tree view.  This feature is 
especially useful when you want to find an item in a particular folder that contains numerous 
items.  You can type an item name and click Find or you can let the software look for the item as 
you type the item name.  The feature allows you to set the search delay that determines how long 
the software waits after the last time you press a key on your keyboard. 
For more information, see Find an Item in the Tree View of an Explorer Window (on page 543). 

Filter the Display of Items According to a Specific Item Type 
This option allows you to filter the items according to a specific item type.  You can apply an item 
type filter to the entire tree view of the current view of the current Explorer window or only to a 
particular folder or node that contains child items.  Item type filters override your item name filters. 
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Also, you can filter the items so that the software displays only those items that belong to the 
current lowest plant hierarchy level and only those items that were created by the current user of 
SmartPlant Instrumentation.  You can use these two filtering options on their own or in 
concurrence with another filter definition. 
Filter settings take effect only for the user who defined the filter and only for the current custom 
view of the active Explorer window. 
Note that item type filters override your item name filters. 
For more information, see Filter the Display of Items According to a Specific Item Type (on 
page 544). 

Filter the Display of Items According to a Specific Item Name 
This option allows you to filter the items according to a specific item name.  An item name filter 
affects the entire tree view of the current view of the active Explorer window and not just a 
particular folder or hierarchy node.  You can also instruct the software to override the item type 
filters if needed. 
Also, you can filter the items so that the software displays only those items that belong to the 
current lowest plant hierarchy level and only those items that were created by the current user of 
SmartPlant Instrumentation.  You can use these two filtering options on their own or in 
concurrence with another filter definition. 
You can define an item name filter only if you do one of the following: 

 Without selecting anything in the Explorer window, click  on the toolbar. 
 Right-click the root node in the Explorer tree view and then on the shortcut menu, click Filter. 

Note that filter settings take effect only for the user who defined the filter and only for the current 
custom view of the active Explorer window.  For more information, see Filter the Display of Items 
According to a Specific Item Name (on page 544). 

Filter Cables in an Explorer Window 
Allows you to set additional filter definitions for the Cables and the Cross Cables folders.  You 
can filter cables according to their connections and cables that are connected to a specific 
Foundation Fieldbus or Profibus segment.  For more information, see Filter Cables in an Explorer 
Window (on page 545). 

Filter Loops in an Explorer Window 
Allows you to set additional filter definitions for the Loops folder.  You can filter loops according to 
blocks associated with loop tags.  For more information, see Filter Loops in an Explorer Window 
(on page 546). 

Add Items to My List in the Items Pane 
This procedure explains how to add various items to the My List view of the Items pane.  My List 
allows you to create a special view of the Items pane where you can keep items that belong to 
various folders in the tree view.  The software retains all the items in the My List view until you 
remove them from that list.  Exiting SmartPlant Instrumentation and starting a new session does 
not affect the contents of My List.  For more information, see Add Items to My List in the Items 
Pane (on page 548). 
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Display a Browser View in the Explorer Items Pane 
This option allows you to display a browser view in the Items pane for an item type or a folder that 
you select in the Domain Explorer tree view.  This way, instead of displaying child items, you can 
display item properties of the item you selected in the tree view pane.  The software displays the 
browser view according to the style settings of the selected browser.  You can print out the current 
browser view, however, you cannot edit the item properties.  For more information, see Display a 
Browser View in the Explorer Items Pane (on page 547). 

Perform Various Actions with an Instrument 
This feature allows you to select a tag number and perform various actions.  You can effect I/O 
assignment, associate blocks, create CS tags, create device panels and cables, connect device 
panels, and so forth.  For more information, see Perform Various Actions with an Instrument (on 
page 542). 

Generate a Specification or a Process Data Sheet for an Instrument 
This option allows you to select a tag number and generate a specification and a process data 
sheet.  For more information, see Generate a Specification or a Process Data Sheet for an 
Instrument (on page 542). 

Define and Use a Custom View 
SmartPlant Instrumentation allows you to define custom views for the Domain Explorer and the 
Reference Explorer.  The software lets you select a folder or multiple folders and add these 
folders with their child items to a custom view that you select.  Note that the custom views that you 
define are not available to other users of SmartPlant Instrumentation.  For more information, see 
Define and Use a Custom View (on page 548). 
For the rules that govern the dragging of items in the Domain Explorer, see Association Rules in 
the Domain Explorer (on page 536). 
 

The Organization of Items in the Domain Explorer Tree View 
The tree view pane of the Domain Explorer shows instrumentation items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the menus depend on the currently selected item type. 
After expanding a plant hierarchy, the following folders are displayed: 

Loops 
Loops are arranged at the lowest level of the plant hierarchy.  You can navigate to a loop by 
expanding the plant hierarchy.  Continue expanding your plant hierarchy to display the Loops 
folder that contains all the existing loops in the current <unit>.  Loops, in turn, can contain loop 
blocks used in CAD loop drawing generation, instruments and control system tags.  Instruments 
can contain instrument blocks used in CAD loop drawing generation.  For more information, see 
Items in the Loops Folder (on page 535). 
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Instruments 
Instrument tags are arranged at the lowest level of the plant hierarchy in the Instruments 
folder.  You can navigate to a tag number by expanding the plant hierarchy.  Continue expanding 
your plant hierarchy to display the Instruments folder that contains all the existing tag numbers in 
the current <unit>.  Instrument tags can be parent items of CS tags, maintenance event record, 
specifications, process data sheets, and any other documents that are associated with a selected 
instrument tag. 

Electrical Tags 
This folder holds all the tag numbers that have either been published to SmartPlant 
Instrumentation from SmartPlant Electrical or that you have created for the purpose of 
representing electrical signals.  You can associate these tags with items under the Electrical 
Equipment folder and publish the items with these associations back to SmartPlant Electrical. 

Uncoupled CS Tags 
This folder holds all the CS tags that are not linked to another tag (uncoupled CS tags).  You can 
view the list of existing tags and open the tag number properties for editing.  You can also create 
new tags by right-clicking this folder. 

Functional Requirement Tags 
This folder holds all the existing functional requirement tag numbers.  You can only view the list of 
existing tags and open the tag number properties for editing.  You cannot create new tags by 
right-clicking this folder. 
Wiring items are organized in the following folders: 

Panels by Location 
Panels are arranged according to their location and category.  In this folder, panels are arranged 
according to their location.  You can perform the following actions: 
 Create a new location based on the structure you define in the Location Manager. 
 Move a panel from one location to another by dragging it to another location. 
 Right-click a location and create a new panel and then create the required child items. 
 When right-clicking a location or a wiring item within a location, you can perform various 

actions that are available on the shortcut menu. 
You can create various wiring structures in the Panels by Location folder.  For an example of 
one possible wiring structure, see Panels by Location Hierarchy Example (on page 531). 

Panels by Category 
In this folder, panels are arranged according to their category.  Panels, in turn, contain their child 
items, for example terminal strips, racks, wiring equipment, and so forth.  There is a lot of flexibility 
in creating a panel hierarchy.  There is no rigid structure like "panel - strip - terminal" that limits 
your wiring design.  You can create various wiring structures, as you require.  See Panels by 
Category Hierarchy Examples (on page 529) to examine a few possible structures. 

Cables 
This folder holds all the existing cables.  You can create various child items under cables.  For an 
example, see Cable Hierarchy Example (on page 531). 
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Cross Cables 
This folder holds all the cross wiring cables and wires.  You can create new cross cables and 
cross wires as you require. 
Lines, hook-ups, process equipment, P&IDs, and so forth are organized in separate folders at the 
top hierarchy level of the tree view.: 

Telecom Equipment 
This folder holds all the available telecom equipment cabinets classified by their categories: PA 
Cabinets, PABX Cabinets, Miscellaneous, Hubs, Amplifiers, and Intercoms. Each folder 
displays the existing equipment cabinets belonging to that category.  You cannot create new 
cabinets in the Telecom Equipment folder.  To create a new equipment cabinet, expand the 
following hierarchy: Panels by Category > Telecom Panels > Equipment Cabinets.  Then, 
right-click the Equipment Cabinets folder, point to New and click the command that you require. 

Process Equipment 
This folder displays all the existing equipment that your instruments are installed on.  Equipment 
is also categorized according to different types, such as compressors, burners, pumps, and so 
on.  You can right-click this folder and create new process equipment.  Then, you can create an 
instrument by right-clicking an equipment item. 

Lines 
This folder holds all the existing lines in your <plant>.  After right-clicking a line, you can add a 
new instrument. 

Fieldbus Segments 
This folder contains all the segments, their associated tag numbers and virtual tags that exist in 
your fieldbus system.  All fieldbus items are arranged in a tree-like hierarchy that can be 
expanded and collapsed.  For details, see Fieldbus Segments in the Domain Explorer (on 
page 531). 

Hook-Ups 
This folder holds all the existing hook-up types, hook-ups, and their child items.  For details, see 
Items in the Hook-Ups Folder (on page 533). 

P&IDs 
This folder displays all the existing P&ID document references.  You can right-click a P&ID 
document reference and create a new instrument, loop, and line. 

Controllers 
This folder displays all the existing controllers and their child items.  You cannot create new 
controllers in this folder, but you can select a slot and add a terminal strip, an I/O card, or any other 
wiring equipment item. 

Drawing Block Types 
This folder holds all the existing CAD drawing block types and their blocks, which you use when 
generating CAD loop drawings.  In this folder, you create your blocks but you do not make any 
associations.  You can only associate blocks with loops or instruments using the Loops folder 
actions of the Loop Drawings module options.  For details, see Items in the Drawing Block Types 
Folder (on page 532). 
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Electrical Equipment 
This folder holds all the items of electrical equipment that have been retrieved from SmartPlant 
Electrical.  In this folder, you can view the items and associate them with electrical signals.  For 
details, see Items in the Electrical Equipment Folder (on page 533). 

Test Equipment 
This folder displays all the items of test equipment that have been created in SmartPlant 
Instrumentation. 
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Panels by Category Hierarchy Examples 
The following examples show a number of different structures that you can create in the Panels 
by Category folder. 
Example 1: 

 
Example 2: 

 
Example 3: 
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Example 4: 

 
Example 5: 

 
Example 6: 
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Panels by Location Hierarchy Example 
The following is an example of a panel by location hierarchy structure: 

 
 

Cable Hierarchy Example 

 
 

Fieldbus Segments in the Domain Explorer 
The Fieldbus Segments folder displays all the segments, their associated instrument tags and 
virtual tag. 
All fieldbus items are arranged in a tree-like hierarchy that can be expanded and collapsed: 

Icon Explanation 

 
Foundation Fieldbus segment that contains all the 
associated instruments and virtual tags 

 Profibus DP segment that contains all the associated 
instruments and virtual tags 

 Profibus PA segment that contains all the associated 
instruments and virtual tags 

 Fieldbus instrument associated with a segment 

 Function block associated with a fieldbus instrument 

 Enabled function block associated with a fieldbus 
instrument 
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Icon Explanation 

 Virtual tag associated with a fieldbus instrument 
 
 

Items in the Drawing Block Types Folder 
The Drawing Block Types folder of the Domain Explorer enables you to navigate to a CAD 
drawing block types and a drawing block in a graphical way resembling the Windows 
Explorer.  The Drawing Block Types folder contains all of the blocks defined in the current 
<plant>.  You organize your block in block type folders.  The blocks that you define become 
available for association with instruments, loops, or hook-ups but you do make any associations in 
the Drawing Block Types folder.  CAD drawing blocks appear in the Domain Explorer because 
it is only possible to define blocks at the highest plant hierarchy level. 
You can expand or collapse the levels to view the existing items.  To perform an action, right-click 
the Drawing Block Types folder, a specific block type or a block, and then click a 
command.  The software uses various icons beside a folder or item to indicate the status of a 
folder or an item , for example a view-only item, a claimed item , an item that belongs to As-Built, 
and so forth.  For the full list of the item indicators, see Item Status Indicators in the Domain 
Explorer (on page 540).  For a detailed explanation of the tree view and Items panes, see 
Working with the Domain Explorer: An Overview (see "Working with the Domain Explorer" on 
page 519). 
In the Drawing Block Types folder, the items appear in two levels, based on the relationship 
among them. 

Level 1: Drawing Block Types 
This is the highest level in the Drawing Block Types folder hierarchy.  At this level, the software 
displays all the drawing block types that exist in the current domain and allows you to add general 
and instrument block types and manage block type properties. 
The following drawing block types are available: 
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 Border and Logo  — Shipped general block types that allow you to create logo and 
border blocks for all loop drawings or hook-up drawings.  You cannot delete these block 
types. 

 User-defined general block type  — A block type that allows you to create blocks you can 
use in all loop drawings in addition to the border and logo blocks.   You can create as many 
user-defined general block types as you require by right-clicking the Drawing Block Types 
folder and clicking New > General Block Type.  Blocks belonging to user-defined general 
block types cannot be assigned to hook-up drawings. 

 Loop Block  — A shipped block type that allows you to create blocks that you can 
associate with the loop numbers in the Loops folder of the Domain Explorer.  The Loop 
Block folder is the only folder where you can create loop blocks.  You can only associate one 
loop block per loop.  You cannot delete the Loop Block folder. 

 Instrument block type  — A user-defined block type that allows you to create blocks that 
you can associate with the instrument tag numbers in the Loops folder of the Domain 
Explorer.  You can create as many instrument block types as you require by right-clicking the 
Drawing Block Types folder and clicking New > Instrument Block Type. 

Level 2: Drawing Blocks 
CAD blocks appear under block types.  Blocks do not contain child items.  You can add new 
blocks or delete blocks that are not in use. 
The following block icons are available: 
  — Logo, border, or user-defined general blocks 
  — Loop blocks 
  — Instrument blocks 

 

Items in the Electrical Equipment Folder 
The Electrical Equipment folder of the Domain Explorer enables you to view items of electrical 
equipment that have been retrieved from SmartPlant Electrical. 
There are several sub-folders available for the following categories of electrical equipment: 
 PDBs — for Power Distribution Boards and their associated circuits. 
 Main Equipment — for items such as motors, heaters, and control stations that are 

associated with electrical equipment. 
 Control Stations — for control stations without associations with electrical equipment. 

By expanding the electrical equipment items, you can view signal (electrical tag) associations.  If 
a particular piece of equipment does not have an associated signal, you can make an association 
by dragging an electrical tag from the Electrical Tags folder to the desired electrical equipment 
item. 
 

Items in the Hook-Ups Folder 
The Hook-Ups folder of the Domain Explorer enables you to navigate to a hook-up type, 
hook-up, hook-up item, or instrument in a graphical way resembling the Windows Explorer.  You 
can expand or collapse the levels to view the existing items.  The Hook-Ups folder shows you at 
a glance the graphical representation of the relationships that exist among the hook-up types, 
hook-ups, and hook-up items, instruments, and child items associated with instruments. 
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The Hook-Ups folder employs an expandable/collapsible hierarchy that allows you to navigate to 
relevant items and select them for use.  To perform an action, right-click a folder or an item and 
then click a command.  Note that the software uses various icons beside a folder or item to 
indicate the status of a folder or an item , for example a view-only item , a claimed item , an item 
that belongs to As-Built, and so forth.  For the full list of the item indicators, see Item Status 
Indicators in the Domain Explorer (on page 540).  For a detailed explanation of the tree view and 
Items panes, see Working with the Domain Explorer: An Overview (see "Working with the Domain 
Explorer" on page 519). 
The software arranges the items based on the relationship among them.  The display rules follow 
a rigid structure of the following four levels. 

Level 1: Hook-Up Types and Hook-Ups 
This is the highest level in the Hook-Ups folder hierarchy.  At this level, the software displays both 
all the hook-ups types and hook-ups that exist in the current domain.  Hook-up types are shown 
as  and hook-ups as . 
Hook-up types contain hook-ups for instruments sharing similar features, for example, Control, 
Measure, Flow, and so forth.  For each hook-up type, on the shortcut menu, you can click New to 
add hook-ups.  At this level, you can only create one hook-up at a time.  Also, you can move 
hook-ups from one hook-up type to another, assign instrument tags and hook-up items.  To 
assign tag numbers, on the shortcut menu, click Actions > Associate Tag Numbers with 
Hook-Ups.  To assign hook-up items, on the shortcut menu, click Actions > Associate Items 
with Hook-Ups.  Also, at this level, you can generate various hook-up reports, a Bill of Material, 
and hook-up drawings. 

Level 2: Hook-Ups 
Hook-ups (shown as ) appear under hook-up types.  At this level, you can create hook-ups in 
batch mode by duplicating existing hook-ups you select in the Items pane.  You can move 
hook-ups from one hook-up type to another, assign instrument tags and hook-up items.  To 
assign tag numbers, on the shortcut menu, click Actions > Associate Tag Numbers with 
Hook-Ups.  To assign hook-up items, on the shortcut menu, click Actions > Associate Items 
with Hook-Ups.  Also, at this level, you can generate various hook-up reports, a Bill of Material, 
and hook-up drawings. 

Level 3: Hook-Up Items and Instruments 
Hook-Up Items 

Hook-up items (shown as ) appear under hook-ups.  Hook-up items do not contain child 
items.  To assign hook-up items to hook-ups, use a shortcut menu command available at the level 
of hook-ups or hook-up types.  You cannot create or delete hook-up items in the Domain 
Explorer.  Hook-up item management options are only available in the Hook-Up Item Libraries 
folder of the Reference Explorer. 
Instruments 

Instruments (shown as  ) appear under hook-ups.  Instruments can contain document 
assigned to instrument specs, process data, or calculation sheets.  Also, instruments can contain 
control system tags.  You create documents and control system tags in the appropriate modules 
of SmartPlant Instrumentation.  To assign instrument tag numbers to hook- ups, use the shortcut 
menu command available at the first or second level of the folder hierarchy. 
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Level 4: Control System Tags, Documents, and Instrument Blocks 
Control System Tag 

Control system tags (shown as ) appear under instruments at the lowest level of the Hook-Ups 
folder hierarchy.  It is possible to assign control system tags to instruments when performing I/O 
assignment. 
Documents 

Documents (shown as ) appear under instruments at the lowest level of the folder 
hierarchy.  You define documents when creating specs, process data sheets, or calculation 
sheets.  You can modify or delete document data in the module pertaining to the document 
displayed.  For example, if you delete an instrument specification from the Specifications module, 
the software automatically removes the document from the Hook-Ups folder.  Use the shortcut 
menu command to open documents.  The software opens the document in the module in which 
the document was created. 
Instrument Blocks 

Instrument blocks are represented by icons  and .  In the Hook-Ups folder, instrument 
block options are not in use because they are only used in a CAD loop drawing generation.  You 
manage instrument blocks in the Loops folder. 
 

Items in the Loops Folder 
The Loops folder of the Domain Explorer enables you to navigate to a loop number, tag number, 
or CAD block in a graphical way resembling the Windows Explorer.   You can expand or collapse 
the levels to view the existing loop numbers, tag numbers, and CAD blocks.  The Loops folder 
shows you at a glance the graphical representation of the relationships that exist among the loops, 
instruments, and blocks. 
To perform an action, right-click the Loops folder or an item and then click a command.  Note that 
the software uses various icons beside a folder or item to indicate the status of a folder or an item 
, for example a view-only item , a claimed item , an item that belongs to As-Built, and so forth.  For 
the full list of the item indicators, see Item Status Indicators in the Domain Explorer (on 
page 540).  For a detailed explanation of the tree view and Items panes, see Working with the 
Domain Explorer (on page 519). 
The software arranges the items in three levels based on the relationship among them. 

Level 1: Loops 
This is the highest level in the Loops folder.  This hierarchy level contains all the loop numbers 
existing at the current highest plant hierarchy level.  Loops are indicated with the  icon. 
Loops contain tag numbers, which in turn contain blocks.  For each loop, on the shortcut menu, 
you can click New to add instruments.  Also, you can assign documents to loops.  These 
documents are associated with drawings that you generate for the loop.  Loops can display 
annotations which refer to the generation method you assigned for that loop, for example, C 
indicates a CAD method, M indicates a manual method (intended for generation without using 
SmartPlant Instrumentation options). 

Level 2: Instruments, Loop Blocks, and Documents 
Instruments 
The second hierarchy level contains all the instrument tag numbers that are associated with the 
existing loops.  Instruments are shown as . 



SmartPlant Instrumentation Explorer 
 

 
536 SmartPlant Instrumentation Basic Engineering User's Guide 

 

If you use a CAD application to generate loop drawings, under instrument tags, you can add 
instrument blocks using the following block assignment methods: 
Block-tag assignment — Allows you to assign a block to a tag number manually, using the 
shortcut menu command Associate Blocks with Tag Numbers. 
Block-instrument type assignment — Allows you to assign a block to the instrument type, and, 
thus, assign this block to all the tag numbers that belong to this instrument type.  To perform this 
operation, on the Actions menu of the Loop Drawings Module window, click Block-Instrument 
Type Assignment. 
Loop Blocks 
If you use a CAD application to generate loop drawings, at the second level of the Loops folder 
hierarchy, you can assign CAD drawing blocks to the loop.  Loop blocks are indicated with the  
icon. 
In the Domain Explorer, you create and manage loop blocks in the Drawing Block Types > 
Loop Block folder. 
Documents 
The second hierarchy level contains all the documents that are associated with the loop drawings 
you generated.  Documents are indicated with the  icon. 
The software assigns a document number to a loop on loop creation.  However, in the Loops 
folder, the software only displays a document number after generating a drawing for a loop.  You 
can view and modify document numbers using options of the Loop Drawing List dialog box, 
which you can open using a shortcut menu command. 

Level 3: Instrument Blocks and Control System Tags 
Instrument Blocks 
Instrument blocks, which are used in a CAD loop drawing generation, are the lowest level in the 
Loops folder hierarchy.  The displayed blocks are those blocks that you associated with the 
instrument tag numbers according to the method of association.  The block icons that the 
software displays depend on the block assignment method: 

  — Indicates blocks associated with instrument tags manually.  At the instrument level, on 
the shortcut menu, click Actions > Associate Blocks with Tag Numbers. 

  — Indicates blocks associated with a specific instrument type to which the instruments 
belong.  On the Actions menu of the Loop Drawings Module window, click Block – 
Instrument Type Assignment. 

You create and manage instrument blocks in the Drawing Block Types folder of the Domain 
Explorer, where the instrument blocks are indicated with the  icon. 
Control System Tags 
Control system tags appear at the lowest level of the Loops folder hierarchy, under 
instruments.  You manage control system tags in the I/O Assignment window.  In the Loops 
folder, you can only update the control system tag properties.  Control system tags are shown as 

. 
 

Association Rules in the Domain Explorer 
You can move and create associations among items by dragging them from one parent item to 
another in the Domain Explorer.  The following table summarizes the rules that govern these 
associations. 
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Source Item in the 
Domain Explorer 

Target Folder or Item in the 
Domain Explorer 

Result Pre- conditions 

Loop The Loops folder in another 
<unit> 

The software moves the loop 
to the target <unit>. 

  

Loop P&ID drawing The software associates the 
loop with the target P&ID 
drawing. 

  

Instrument The Instruments folder in 
another <unit> 

The software moves the 
instrument to the target 
<unit>. 

  

Instrument Loop The software associates the 
instrument with the target 
loop. 

  

Instrument Line The software associates the 
instrument with the target 
line. 

  

Instrument Process equipment The software associates the 
instrument with the target 
process equipment. 

  

Instrument P&ID drawing The software associates the 
instrument with the target 
P&ID drawing. 

  

Functional requirement 
tag 

The Loops folder in another 
<unit> 

The software moves the 
functional requirement tag to 
the target <unit>. 

  

Location Location The software moves the 
location to the target location 
in the Panels by Location 
folder (in accordance with the 
location level structure 
defined by the Domain 
Administrator). 

  

Panel (all panel 
categories) 

Location The software associates the 
panel with the target location. 

  

Device panel Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the 
device panel to the target 
panel. 

  

Plug-and- Socket 
junction box 

Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the 
plug-and- socket junction box 
to the target panel. 

  

Rack Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the rack 
to the target panel. 
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Source Item in the 
Domain Explorer 

Target Folder or Item in the 
Domain Explorer 

Result Pre- conditions 

Wiring equipment item 
(for example: I/O card, 
fieldbus brick, and so 
forth) 

Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the 
wiring equipment item to the 
target panel. 

See Note 1. 

Wiring equipment item 
(for example: I/O card, 
fieldbus brick, and so 
forth) 

Rack The software moves the 
wiring equipment item to the 
target rack. 

See Note 1. 

Wiring equipment item 
(for example: I/O card, 
fieldbus brick, and so 
forth) 

Terminal strip The software moves the 
wiring equipment item to the 
target terminal strip. 

See Note 1. 

Wiring equipment item 
(for example: I/O card, 
fieldbus brick, and so 
forth) 

Slot The software moves the loop 
to the target slot. 

See bullet 1 
below. 

Connector Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the 
connector to the target panel. 

See bullets 2 and 
3 bellow. 

Connector Rack The software moves the 
connector to the target rack. 

See bullets 2 and 
3 bellow. 

Connector Wiring equipment item The software moves the 
connector to the target wiring 
equipment item . 

See bullets 2 and 
3 bellow. 

Connector Slot The software moves the 
connector to the target slot. 

See bullets 2 and 
3 bellow. 

Connector Cable The software moves the 
connector to the target cable. 

See bullets 2 and 
3 bellow. 

Terminal strip Panel (apart from device 
panel and plug-and- socket 
junction box) 

The software moves the 
terminal strip to the target 
panel. 

See bullet 4 
below. 

Terminal strip Rack The software moves the 
terminal strip to the target 
rack. 

See bullet 4 
below. 

Terminal strip Wiring equipment item (e.g., 
I/O card, fieldbus brick, etc.) 

The software moves the 
terminal strip to the target 
wiring equipment item. 

See bullet 4 
below. 

Terminal strip Slot The software moves the 
terminal strip to the target 
slot. 

See bullet 4 
below. 
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Source Item in the 
Domain Explorer 

Target Folder or Item in the 
Domain Explorer 

Result Pre- conditions 

Terminal Terminal strip The software moves the 
terminal to the target terminal 
strip. 

  

Terminal Channel The software moves the 
terminal to the target 
channel. 

  

Channel Wiring equipment item (for 
example: I/O card, fieldbus 
brick, and so forth) 

The software moves the 
channel to the target wiring 
equipment item. 

  

Channel Terminal strip The software moves the 
channel to the target wiring 
terminal strip. 

  

Cable set Cable The software moves the 
cable set to the target cable. 

  

Cable set Cross cable The software moves the 
cable set to the target cross 
cable. 

  

Wire Cable set The software moves the wire 
to the target cable set. 

Connected wires 
cannot be moved.

Line P&ID drawing The software associates the 
line with the target P&ID 
drawing. 

  

Hook-Up Hook-up type The software associates the 
hook-up with the target 
hook-up type. 

  

 
 I/O cards cannot be moved if they function as primary or secondary I/O cards. 
 Wiring equipment connectors cannot be moved to cables. 
 Cable connectors can only be moved to other cables.  This is possible only if none of the 

connector pins are associated with wires. 
 Terminal strips cannot be moved if: 

 They are used in instrument type profile definition. 
 They are associated with Auto-Wiring tasks. 
 They are associated with CS tags. 
 They are associated with general or local signals. 

Special Conditions 
 The software does not allow you to drag items to incompatible hierarchies.  For example, you 

cannot drag a rack to device panel or a plug-and-socket junction box. 
 The software does not allow you to move an item that contains a child item that cannot be 

moved.  For example, you cannot move a rack if it contains an I/O card that functions as a 
primary or secondary I/O card for an I/O termination. 
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 In an owner operator domain, you cannot move items that have not been claimed for the 
current project. 

 

Item Status Indicators in the Domain Explorer 
The software uses a number of icons to indicate the status of various folders and items in your 
domain.  The icons appear beside the folders and items in the tree view of the Domain Explorer. 

Icon Description 

 An item that belongs to the current project. 

 An item that belongs to As-Built.  When working in a project with As-Built items displayed, 
As-Built items are view-only.  In the Domain Explorer, you can select an As-Built item 
and display its properties. 

 A dummy item. 

 An item that does not belong to the current project or As-Built.  Also, an item that belongs 
to As-Built and all the projects, for a example, a hook-up type. 

 An item that cannot be deleted, duplicated, and under which no child items can be 
created.  However, you can edit the item properties and move the item to another 
hierarchy level. 

 Access denied. 

 View-only.  The item is marked as view-only if it has not been created using the Domain 
Explorer.  You cannot delete such an item or manage the item properties using the 
Domain Explorer options.  For example, a document, such as a specification is always 
marked as view-only.  However, you can open the spec print preview and make changes 
as you require. 

 An item that cannot be deleted, duplicated, moved to another hierarchy level, and under 
which no child items can be created.  However, you can edit the item properties. 

 An As-Built item that has been claimed for a project. 

 Indicates that a folder or parent hierarchy item has been filtered according to an item type.

 Indicates that a folder or parent hierarchy item has been filtered according to an item type 
name. 

 
 An item without any indicator denotes an item that is not supported by the Domain 

Explorer.  The software allows you to perform actions with such items only from the pertinent 
SmartPlant Instrumentation modules. 

 The software does not use item indicators in the Reference Explorer. 
 

Create an Item in the Domain Explorer 
1. Press F7 to open the Domain Explorer. 
2. In the tree view pane, expand the plant hierarchy to display the folder in which you need to 

create the new item . 
3. Right-click the folder in which you need to create the new item . 
4. On the shortcut menu, point to New and then click the command that you require. 
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 When you create an item in the domain explorer, make sure you set the naming convention 
for it in the Administration module.  For details, see Naming Conventions in the Administration 
User's Guide, under Domain Administration. 
 

Duplicate an Item 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the tree view pane, expand the plant hierarchy. 
3. Do one of the following: 

 In the tree view pane, select an item. 
 In the Items pane, select one or more items. 

4. Right-click the selected items and then on the shortcut menu, click Duplicate. 
5. Modify the properties as you require.  For help with individual properties, click the Help button 

on the dialog box. 
 When you duplicate an item in the domain explorer, the duplicate item inherits the naming 

conventions from the original item.  Make sure you set the naming convention for an item you 
wish to duplicate. 
 

Move an Item in the Domain Explorer 
1. Press F7 to open the Domain Explorer. 
2. In the tree view pane, expand a hierarchy to display the item that you want to move. 
3. Drag your selection to the required destination in the Domain Explorer. 
 

Edit Item Properties 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the tree view pane, expand the plant hierarchy. 
3. Do one of the following: 

 In the tree view pane, select an item . 
 In the Items pane, select one or more items. 

4. Right-click the selected items and then on the shortcut menu, click Properties. 
5. Modify the properties as you require.  For help with individual properties, click the Help button 

on the dialog box. 
 

Delete Items 
1. Press F7 to open the Domain Explorer or F8 to open the Reference Explorer. 
2. In the tree view pane, expand the plant hierarchy. 
3. Do one of the following: 

 In the tree view pane, select an item . 
 In the Items pane, select one or more items. 

4. Right-click the selected items and then on the shortcut menu, click Delete. 
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Perform Various Actions with an Instrument 
1. Press F7 to open the Domain Explorer. 
2. In the tree view pane, expand the plant hierarchy to display the Instruments folder. 
3. Expand the Instruments folder and then right-click a tag number. 
4. On the shortcut menu, point to Actions and then click the command that you require. 
 

Generate a Report for an Instrument 
1. Press F7 to open the Domain Explorer. 
2. In the tree view pane, expand the plant hierarchy to display the Instruments folder. 
3. Expand the Instruments folder and then right-click a tag number. 
4. On the shortcut menu, click Reports and then click the command that you require. 
 

Generate a Specification or a Process Data Sheet for an 
Instrument 

1. Press F7 to open the Domain Explorer. 
2. In the tree view pane, expand the plant hierarchy to display the Instruments folder. 
3. Expand the Instruments folder and then right-click a tag number. 
4. On the shortcut menu,  click Actions and then click the command that you require. 
 

Copy a Reference Item to the Domain Explorer 
1. Press F7 and then F8 to open the Domain Explorer and the Reference Explorer. 
2. In the Reference Explorer, expand a hierarchy level and select a reference item. 
3. Drag your selection to a destination level in the Domain Explorer.  Place both Explorer 

windows side by side on your screen and then drag the required items from one Explorer to 
the other. 

4. In the appropriate properties dialog box, (depending on the reference item that you are 
copying), modify the properties of the new item as you require. 

 

Search for Items in SmartPlant Instrumentation Explorer 
1. Do one of the following 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. On the toolbar, click  to open the Search dialog box. 
3. Select an item type.   

 The Item type list is a required field and without selecting an item type, the software 
cannot proceed with the search. 

4. Under Item name, type a name of an item that you want to find. 
 You can use wildcard characters (* or %) to find items whose names contain part of the 

text that you type.  If you do not know the item name, leave the asterisk * in this field. 
5. Under Search in, select a plant hierarchy level on which the software searches for items: 

 Entire domain — the current domain that you selected in the Open dialog box when you 
started SmartPlant Instrumentation. 
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 Current highest plant hierarchy level — the highest plant hierarchy level that you 
selected in the Open dialog box, for example, your current plant. 

 Current lowest plant hierarchy level — the lowest plant hierarchy level that you 
selected in the Open dialog box, for example, your current unit. 

6. In the Item properties data window, if needed, specify item properties so that the software 
looks for items with those properties only.  Click Add to append a new row if you want to 
specify more than one property. 
 Property — select an existing property from the list. 
 Operator — select an operator from the list to determine how the selected property will 

relate to the expression you type in the Value field. 
 Value — type an appropriate value to determine how the selected property will be 

specified. 
 Logic — select a logic operator (AND or OR) to determine how the next expression will 

relate to the current one.  Leave this field empty if this is the last expression you are 
defining. 

7. Click Search Now. 
8. In the Results data window, select the items that you want to work with and click Add to My 

List. 
 

 After the software finds the items that you were looking for and lists them in the Results data 
window, you can search for more items without losing your current results.  Select another 
item type and click Search Now.  The software adds the newly found items to the previously 
found results. 

 To start a new search and clear the Search results data window. 
 

Find an Item in the Tree View of an Explorer Window 
1. Do one of the following: 

 Press F7 to open the Domain Explorer. 
 Press F8 to open the Reference Explorer. 

2. In the tree view pane, expand the tree view hierarchy and navigate to a folder. 
3. Right-click the folder that you require and then on the shortcut menu, click Find Item . 
4. On the Find Item dialog box, select Match case if you want the software to find items whose 

names match the capitalization of the item name you entered. 
5. Select Find whole name only if you want the software to search for occurrences that are 

whole names and not part of a larger item name. 
6. Do one of the following: 

 Under Item , type a name and click Find. 
 Select As typed and then under Item type a name.  The software looks for the item as 

you type.  You can set the search delay to determine how long the software will wait after 
the last time you press a key on your keyboard. 

7. Click Close. 
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Filter the Display of Items According to a Specific Item Name 
1. In an Explorer window, do one of the following: 

 Without selecting anything in the Explorer window, click  on the toolbar. 
 Right-click the root node in the Explorer tree view and then on the shortcut menu, click 

Filter. 
2. On the Filter Definition dialog box, type a filter name as you require. 
3. On the Item Name tab, under Item name, type a valid name or part of a name.  You can use 

wildcard characters to specify partial strings: asterisk (*) or percent (%) for multiple characters 
and underscore (_) for single characters. 

4. Select the Override all item type filters check box if you want this item name filter the 
software to override all existing item type filters.  Normally, item name filters do not take effect 
if an item type filter exists. 

5. To filter the data of the current lowest plant hierarchy level, select the Current lowest plant 
hierarchy level check box. 

6. To limit the display of items to only those that were created by the current user, select the 
Show items created by the current user only check box. 

7. Click OK. 
 

 To clear the filter, on the Filter Definition dialog box, delete the filter definition. 
 Filter settings take effect only for the user who defined the filter and only for the current custom 

view of the active Explorer window. 
 Item type filters override your item name filters. 

 

Filter the Display of Items According to a Specific Item Type 
1. In an Explorer window, do one of the following: 

 To filter the entire tree view, select a hierarchy node whose immediate child items are 
folders and not plant items.  Then click  on the toolbar. 

 To filter a particular folder or a hierarchy node, select a hierarchy node or a folder 
containing the items that you want to filter and then click . 
Alternatively, you can right-click a folder or a hierarchy node and then on the shortcut 
menu, click Filter. 

2. On the Filter Definition dialog box, type a filter name as you require. 
3. On the Item Type tab, from the Item type list, select an item type appropriate to the folder or 

parent node that you selected in the tree view. 
4. Select one of the following options: 

 If, in the Explorer tree view, you selected a hierarchy node whose immediate child items 
are folders and not plant items, click the All the tree view option button. 

 If you selected a particular folder or hierarchy node, click the Selected folder or parent 
item option button. 

5. From the Item type list, select an item type according to which you want to set the filter. 
 If, in the Explorer tree view, you select a hierarchy node whose immediate child items 

are folders and not plant items, the Item type list contains all the item types of the child items 
that belong to the selected folders. 

6. In the Filter definition group box, define the criteria that you use to filter the items displayed: 
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 Property — select a property to use for filtering the items. 
 Operator — select the required comparison operator to determine how the header 

selected under Property will relate to the expression you select for Value. 
 Value — select or type a required value for the item you selected under Property. The 

available values depend on the specific property that you select. 
 Logic — You use this option when you specify more than one filter condition.  The option 

allows you to select the required logical operator (And or Or) to determine how the next 
filter expression will relate to the current expression.  When you have a mixture of logical 
operators for several conditions, the software performs the expressions on the conditions 
in order, for example: 
(A and B) or C 
(A or B) and C 

7. Click Add if you want to add another item type property to the filter definition. 
8. Click Verify to check the validity of the current filtering condition. 
9. To filter the data of the current lowest plant hierarchy level, select the Current lowest plant 

hierarchy level check box. 
10. To limit the display of items to only those that were created by the current user, select the 

Show items created by the current user only check box. 
11. Click OK. 

 
 Clicking Advanced allows you to define an additional filter for the Cables, Cross Cables, and 

Loops folders.  For details, see Filter Cables in an Explorer Window (on page 545) and Filter 
Loops in an Explorer Window (on page 546). 

 To reset the filter, click Reset. 
 To clear the filter, right-click a hierarchy node and then on the shortcut menu, click Clear 

Filter. 
 When filtering the entire domain or setting a filter without selecting a specific node or folder, 

the Clear Filter command is not available.  In this case, to clear the filter, open the Filter 
Definition dialog box and delete the filter definition. 

 Filter settings take effect only for the user who defined the filter and only for the current custom 
view of the active Explorer window. 

 Item type filters override your item name filters. 
 

Filter Cables in an Explorer Window 
1. In an Explorer window, select the Cables or the Cross Cables folder and do one of the 

following: 
 Right-click the folder, and then click Filter. 

 On the Explorer window toolbar, click . 
2. On the Filter Definition (Cables) dialog box, type a filter name. 
3. Click Advanced. 
4. On the Advanced Filter Definition (Cables) dialog box, do one of the following: 

 Select the Look for connections check box to include and select connection criteria in 
the filter condition. 

 Clear the Look for connections check box if you do not want to include any of the 
connection criteria in the filter condition.  Selecting this option disables the check boxes in 
this group box and in the Connected to group box. 

5. To select a connection criterion, in the Connection group box, click the following: 
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 No connections on either end — Filters for cables that are not connected to anything on 
either wire end. 

 At least one wire connected on one end only — Filters for cables that contain at least 
one wire that is only connected on one of its ends. 

 At least one wire connected on both ends — Filters for cables that contain at least one 
wire that is connected on both wire ends. 

6. In the Connected to group box, select one or more check boxes to define a filter according to 
the type of panel that is connected to the cable.  This selection defines connection criteria for 
cables that have at least one wire connected to one or both ends. 
 Junction boxes — Filter for all the cables that are connected to junction boxes. 
 Marshaling racks — Filter for all the cables that are connected to marshaling racks. 
 Cabinets — Filter for all the cables that are connected to cabinets. 
 Device panels — Filter for all the cables that are connected to device panels. 
 DCS panels — Filter for all the cables that are connected to DCS panels. 
 PLC panels — Filter for all the cables that are connected to DCS panels. 

7. In the Cable associations group box, select an appropriate Foundation Fieldbus or Profibus 
segment if you want to filter for cables that are associated with a specific fieldbus segment. 

8. Select the Display telecom cables check box only if you want to filter the Cables folder so 
that it displays telecom cables only. 

9. Select the Cables without sets check box to filter for cables that were created without sets 
and wires.  This feature is useful when creating a cable block diagram. 

10. Click OK in the Advanced Filter Definition (Cables) dialog box. 
11. Click OK in the Filter Definition dialog box. 
 

Define a Filter for Pre-Assigned Device Cables 
1. In the Domain Explorer, click . 
2. On the Filter Definition (Cables) dialog box, click Advanced. 
3. On the Advanced Filter Definition (Cables) dialog box, select the Display pre-assigned 

device cables only check box. 
4. Select the junction box that you require from the list below. 
 

Filter Loops in an Explorer Window 
1. In an Explorer window, select the Loops folder and do one of the following: 

 Right-click the folder, and then click Filter. 

 On the Explorer window toolbar, click . 
2. To filter according to an item name in the Loops folder, under Item name, type a valid name 

or part of a name.  You can use wildcard characters to specify partial strings: asterisk (*) or 
percent (%) for multiple characters and underscore (_) for single characters. 

 The value that you enter in this box overrides all other filter criteria in this dialog box. 
3. Type a filter name. 
4. Do one of the following: 

 Select Selected node definition to filter the child items that belong to a folder or the 
items at any hierarchy level that you selected in the Explorer tree view. 
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 Select Global definition to define a filter for the entire tree view of the active Explorer. 
The software applies this definition to the item type you selected.  If you defined a filter 
definition for a specific folder, the filter for the folder overrides the settings for the global 
filter definition. 

5. In the Filter definition group box, define the criteria that you use to filter the items displayed: 
 Property — select a property to use for filtering the items. 
 Operator — select the required comparison operator to determine how the header 

selected under Property will relate to the expression you select for Value. 
 Value — select or type a required value for the item you selected under Property. The 

available values depend on the specific property that you select. 
 Logic — You use this option when you specify more than one filter condition.  The option 

allows you to select the required logical operator (And or Or) to determine how the next 
filter expression will relate to the current expression.  When you have a mixture of logical 
operators for several conditions, the software performs the expressions on the conditions 
in order, for example: 
(A and B) or C 
(A or B) and C 

6. Click Verify to check the validity of the current filtering condition. 
7. Click Advanced to define a filter for loops according to loop blocks. 
8. In the dialog box that opens, if needed, under Display level for blocks, click one of the 

following to filter the blocks displayed in the data windows: 
 Highest plant hierarchy level — Displays blocks on the highest level of the plant 

hierarchy defined by the Domain Administrator.  The default level is Plant. 
 Lowest plant hierarchy level — Displays blocks on the lowest level of the plant 

hierarchy defined by the Domain Administrator.  The default level is Unit. 
9. To filter the loops according to blocks, do one of the following: 

 Under Blocks associated with tags, select one or more blocks that are associated with 
loop tags.  After you select these blocks, in the current explorer window, the software only 
displays loops whose blocks are assigned to tags using the block-tag assignment 
method. 

 Under Blocks associated with instrument type, select one or more blocks that are 
associated with the instrument type of the loop tags.  After you select these blocks, in the 
current explorer window, the software only displays loops whose blocks are assigned to 
tags using the block-instrument type assignment method. 
 In the Loops folder, blocks associated with tags using the manual block assignment 

method are marked with the icon .  Blocks associated with tags using the automatic block 
assignment method are marked with the icon . 

10. Click OK in the Advanced Filter Definition (Loops) dialog box. 
11. Click OK in the Filter Definition dialog box. 
 

Display a Browser View in the Explorer Items Pane 
1. Do one of the following 

 In the tree view pane of the Domain Explorer, expand the plant hierarchy and then select 
a folder or an item . 

 In the tree view pane of the Reference Explorer, select a folder or an item . 
2. Right-click the selected folder or item and then on the shortcut menu, click Show Browser. 
3. From the Browser view list, select a Browser view that exists in the Browser module. 
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4.  If there are no Browser views on this list or if the browser view you need is not on 
the list, close the Show Browser dialog box and switch to the Browser module.  In the 
Browser Manager, open the style settings of the browser view that you need.  Select the 
Enable current view in SmartPlant Explorer and in the Find Documents to Publish 
wizard check box and then click Save.  Open the Show Browser dialog box again and select 
the browser view that you need. 

 

Add Items to My List in the Items Pane 
 Press F7 to open the Domain Explorer and do one of the following: 

 In the Domain Explorer tree view, right-click an item and then on the shortcut menu, click 
Add to My List. 

 In the Items pane, click My List and then drag an item from the tree view to My List. 
 

 To remove an item from My List, right-click it and then on the shortcut menu, click Remove 
from My List. 

 To clear the My List view of all the items, right-click an item and then on the shortcut 
menu, click Remove All. 

 

Define and Use a Custom View 
1. Press F7 to open the Domain Explorer or F8 to open the Reference Explorer. 

2. Click  above the toolbar. 
3. On the Custom View Properties dialog box, click New. 
4. Type a custom view name and then click OK. 
5. Do one of the following: 

 Right-click a single folder in the tree view pane. 
 Right-click multiple folders in the Items pane. 

6. On the shortcut menu, click Add to Custom View and then click the command for the 
appropriate custom view. 

 To remove a folder from a custom view, right-click a folder and then on the shortcut menu, 
click Remove from Custom View. 
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Working with the Reference Explorer 
The Reference Explorer allows you to create and manage all the available wiring reference items 
that are created by SmartPlant Instrumentation users and that are provided with the 
software.  Note that wiring reference items are typical configurations that facilitate rapid creation 
of various wiring items in your domain. 
The Reference Explorer displays a graphical representation of the relationships that exist among 
the predefined wiring equipment, panels, terminal strips, and terminals as well as cables, cable 
sets, and wires.  Also, you can manage hook-up libraries and hook-up items. 
You can use predefined configurations as reference items and copy them to the Domain 
Explorer.  For more information about using reference wiring items, see Copy a Reference Item 
to the Domain Explorer (on page 542). 
You can open the Reference Explorer from anywhere in SmartPlant Instrumentation.  Press F8 
or on the Tools menu, click Reference Explorer. 
The tree view pane of the Reference Explorer shows reference items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the shortcut menus depend on the currently selected item type. 
Item status indicators — the software uses various icons beside a folder or item to indicate the 
status of a folder or an item, for example access denied, view only, an item that belongs to 
As-Built, and so forth.  For the full list of the item indicators, see Item Status Indicators in the 
Domain Explorer (on page 540). 

 
 You can create several instances of the Reference Explorer by pressing F8. 
 After exiting SmartPlant Instrumentation, and starting a new session, the software retains the 

size and position of all the windows that were open in the previous session. 
 

Reference Explorer 
The Reference Explorer allows you to create and manage all the available wiring reference items 
that are created by SmartPlant Instrumentation users and that are provided with the 
software.  Note that wiring reference items are typical configurations that facilitate rapid creation 
of various wiring items in your domain. 
The Reference Explorer displays a graphical representation of the relationships that exist among 
the predefined wiring equipment, panels, terminal strips, and terminals as well as cables, cable 
sets, and wires.  Also, you can manage hook-up libraries and hook-up items. 
You can use predefined configurations as reference items and copy them to the Domain 
Explorer.  For more information about using reference items, see Copying Reference Items. 
You can open the Reference Explorer from anywhere in SmartPlant Instrumentation.  Press F8 
or click Tools > Reference Explorer. 
The main features of the Reference Explorer are as follows. 
(List of Views) — Allows you to select the standard Reference Explorer view or a custom view 
that you have defined.  To add items to a custom view, right-click a folder in the tree view pane or 
multiple folders in the Items pane and then on the shortcut menu click Add to Custom View and 
then click an appropriate custom view command. 

New Custom View  — Opens the Custom View Properties dialog box where you can define 
custom views. 
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Toolbar 
Search  — Opens the Search dialog box where you can look for items that you want to work 
with. 

Refresh  — Updates the Reference Explorer display.  This feature is useful where multiple 
users are working on the same set of data. 

Filter  — Allows you to filter the items in the Reference Explorer display.  You can use this 
toolbar command if you do one of the following: 
 Do not select anything in the Explorer tree view — this allows you to filter the entire tree view 

according to a specific item name. 
 Select the root node in the Explorer tree view — this allows you to filter the entire tree view 

according to a specific item name. 
 Select a tree view node whose immediate child items are folders and not plant items — this 

allows you to filter the entire tree view according to a specific item type that you select from the 
Item type list on the Filter Definition dialog box. 

 Select any tree view node or folder that contains child item to filter that node or folder 
according to a specific item type. 

View  — Toggles through each view of the items in the Items pane.  You can click the 
arrow and select the desired view. 

Find  — Opens the Find Item dialog box where you can look for a specific item in the tree 
view. 

Print  — Prints the browser view that you selected for the current hierarchy node.  This button 
becomes available only after selecting the Show Browser command. 

Tree View Pane 
The tree view pane of the Reference Explorer shows reference items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the menus depend on the selected item type. 
Expand or collapse the hierarchy by clicking the  and  icons respectively or by double-clicking 
a folder. 
After double-clicking Reference Explorer, which is the top level in the tree view, you can see the 
Panels, Cables, and Wiring Equipment folders.  These folders contain other folders which in 
turn hold reference items. 
You can navigate to a reference item by expanding a folder and then double-clicking an item to 
display the existing child items.  If you cannot expand a folder, that folder is empty. 
To perform an action, right-click a folder or an item and then click a command.  Also, to move an 
item to another parent item , drag that item to another folder or a parent item as you require. 
For a detailed explanation of all the folders in the Reference Explorer, see The Organization of 
Items in the Reference Explorer Tree View (on page 554). 
Item status indicators — the software uses various icons beside a folder or item to indicate the 
status of a folder or an item , for example access denied, view only, an item that belongs to 
As-Built, and so forth.  For the full list of the item indicators, see Item Status Indicators in the 
Domain Explorer (on page 540). 
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Items Pane 
The Items pane (list view) pane of the Reference Explorer displays the individual items that 
comprise the hierarchy of the item or the folder that you selected in the tree view.  You can 
choose one of the following three ways to display the items in this pane: 
 List — Displays the individual items that comprise the hierarchy of the item or the folder that 

you selected in the tree view. 
 My List — Allows you to create a special view of the Items pane where you can keep items 

that belong to various folders in the tree view.  The software retains all the items in the My List 
view until you remove them from that list.  The list count displays the number of items 
displayed in the List pane. 

 Show Browser — Allows you to display a browser view in the Items pane for an item type or 
a folder that you select in the Reference Explorer tree view.  This way, instead of displaying 
child items, you can display item properties of the item you selected in the tree view 
pane.  The software allows you to print out the current browser view, however, you cannot edit 
the item properties. 

 List count — displays the number of individual items that comprise the hierarchy of the item 
or the folder that you selected in the tree view. 

 
 You can create several instances of the Reference Explorer by pressing F8. 
 After exiting SmartPlant Instrumentation, and starting a new session, the software retains the 

size and position of all the windows that were open in the previous session. 
 

Reference Explorer Common Tasks 
The following tasks are used frequently when you work with the Reference Explorer. 

Create a Reference Item 
This procedure shows how to create an item in the Reference Explorer.  For more information, 
see Create a Reference Item (on page 556). 

Create a Reference I/O Card 
This procedure explains how to create a reference I/O card.  For more information, see Create a 
Reference I/O Card (on page 556). 

Create a Reference I/O Termination 
This procedure explains how to create a reference I/O termination.  For more information, see 
Create a Reference I/O Termination (on page 558). 

Create a Reference Wiring Equipment Item 
This procedure explains how to create a reference wiring equipment item.  For more information, 
see Create a Reference Wiring Equipment Item (on page 558). 
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Copy a Reference Item to the Domain Explorer 
This procedure explains how to copy a reference item from the Reference Explorer to the 
Domain Explorer.  This way you can create numerous plant items based on typical 
configurations on the fly.  Note that SmartPlant Instrumentation allows you to preserve the 
internal connections within a copied item.  This means that the software retains the cables and 
cross wires that connect among the various terminal strips within the item that you are 
copying.  Also, if you are copying a panel or another item that contains child items, the software 
duplicates this item in its entirety, including all the existing child items. 
For more information, see Copy a Reference Item to the Domain Explorer (on page 542). 

Edit Item Properties 
This procedure explains how to edit the properties of an item that you select in the Reference 
Explorer.  For more information, see Edit Item Properties (on page 541). 

Duplicate an Item 
You use this action to create a duplicate item within the same parent hierarchy.  That is, the 
software creates another copy of the selected item under the immediate parent item.  For 
example, if you need to insert an apparatus within an existing apparatus group, expand an 
apparatus group and duplicate an apparatus.  You can then change the sequence numbers of the 
apparatuses to re-arrange them on the strip the way you require.  Furthermore, if you are 
duplicating a panel or another item that contains child items, the software duplicates this item in its 
entirety.  That is, SmartPlant Instrumentation creates the new item with exactly the same child 
items as the original panel.  Note that in this case, the software also retains all the existing internal 
connections if you selected Copy internal connections in the wiring preferences.  For more 
information, see Duplicate an Item (on page 541). 

Delete Items 
This procedure shows how to delete the items that you select in the Reference Explorer.  For 
more information, see Delete Items (on page 541). 

Search for Items in SmartPlant Instrumentation Explorer 
You use this feature to find items that you want to work with.  You can search for multiple items in 
the entire domain, the current highest plant hierarchy level, or the current lowest plant hierarchy 
level.  The term "current" refers to the plant hierarchy level that you selected in the Open dialog 
box when you started SmartPlant Instrumentation.  For more information about searching for 
items, see Search for Items in SmartPlant Instrumentation Explorer (on page 542). 

Find an Item in the Tree View 
This feature enables you to find an item in the Reference Explorer tree view.  This feature is 
especially useful when you want to find an item in a particular folder that contains numerous 
items.  You can type an item name and click Find or you can let the software look for the item as 
you type the item name.  The feature allows you to set the search delay that determines how long 
the software waits after the last time you press a key on your keyboard. 
For more information, see Find an Item in the Tree View of an Explorer Window (on page 543). 

Filter the Display of Items According to a Specific Item Type 
This option allows you to filter the items according to a specific item type.  You can apply an item 
type filter to the entire tree view of the current view of the current Explorer window or only to a 
particular folder or node that contains child items.  Item type filters override your item name filters. 
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Also, you can filter the items so that the software displays only those items that belong to the 
current lowest plant group and only those items that were created by the current user of 
SmartPlant Instrumentation.  You can use these two filtering options on their own or in 
concurrence with another filter definition. 
Filter settings take effect only for the user who defined the filter and only for the current custom 
view of the active Explorer window. 
Note that item type filters override your item name filters. 
For more information, see Filter the Display of Items According to a Specific Item Type (on 
page 544). 

Filter the Display of Items According to a Specific Item Name 
This option allows you to filter the items according to a specific item name.  An item name filter 
affects the entire tree view of the current view of the active Explorer window and not just a 
particular folder or hierarchy node.  You can also instruct the software to override the item type 
filters if needed. 
Also, you can filter the items so that the software displays only those items that belong to the 
current lowest plant group and only those items that were created by the current user of 
SmartPlant Instrumentation.  You can use these two filtering options on their own or in 
concurrence with another filter definition. 
You can define an item name filter only if you do one of the following: 

 Without selecting anything in the Explorer window, click  on the toolbar. 
 Right-click the root node in the Explorer tree view and then on the shortcut menu, click 

Filter. 
Note that filter settings take effect only for the user who defined the filter and only for the current 
custom view of the active Explorer window.  For more information, see Filter the Display of Items 
According to a Specific Item Name (on page 544). 

Filter Cables in an Explorer Window 
Allows you to set additional filter definitions for the Cables and the Cross Cables folders.  You 
can filter cables according to their connections and cables that are connected to a specific 
Foundation Fieldbus or Profibus segment.  For more information, see Filter Cables in an Explorer 
Window (on page 545). 

Filter Loops in an Explorer Window 
Allows you to set additional filter definitions for the Loops folder.  You can filter loops according to 
blocks associated with loop tags.  For more information, see Filter Loops in an Explorer Window 
(on page 546). 

Use My List in the Items Pane 
This procedure explains how to add various items to the My List view of the Items pane.  My List 
allows you to create a special view of the Items pane where you can keep items that belong to 
various folders in the tree view.  The software retains all the items in the My List view until you 
remove them from that list.  Exiting SmartPlant Instrumentation and starting a new session does 
not affect the contents of My List.  For more information, see Add Items to My List in the Items 
Pane (on page 548). 
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Display a Browser View in the Explorer Items Pane 
This option allows you to display a browser view in the Items pane for an item type or a folder that 
you select in the Reference Explorer tree view.  This way, instead of displaying child items, you 
can display item properties of the item you selected in the tree view pane.  The software displays 
the browser view according to the style settings of the selected browser.  You can print out the 
current browser view, however, you cannot edit the item properties.  For more information, see 
Display a Browser View in the Explorer Items Pane (on page 547). 

Define and Use a Custom View 
SmartPlant Instrumentation allows you to define custom views for the Domain Explorer and the 
Reference Explorer.  The software lets you select a folder or multiple folders and add these 
folders with their child items to a custom view that you select.  Note that the custom views that you 
define are not available to other users of SmartPlant Instrumentation.  For more information, see 
Define and Use a Custom View (on page 548). 
 

The Organization of Items in the Reference Explorer Tree 
View 

The tree view pane of the Reference Explorer shows reference items organized by 
folders.  SmartPlant Instrumentation defines standard folders in the database.  You cannot move 
or delete these folders, nor can you add new folders.  Each folder contains a particular item type, 
and the options available on the menus depend on the currently selected item type. 

Panels 
In this folder, reference panels are arranged according to their category.  Panels, in turn, contain 
their child items, for example terminal strips, racks, wiring equipment, and so forth.  There is a lot 
of flexibility in creating a panel hierarchy.  There is no rigid structure like "panel - strip - terminal" 
that limits your wiring design.  You can create various wiring structures, as you require.  For 
details, see Panels by Category Hierarchy Examples (on page 529) to examine a few possible 
structures. 

Cables 
This folder holds all the existing reference cables.  You can create various child items under 
cables.  For an example, see Cable Hierarchy Example (on page 531). 

Wiring Equipment 
This folder holds all the available reference wiring equipment.  The items are organized in 
sub-folders according to the wiring equipment category such as barriers, amplifiers, hubs, I/O 
cards, and so forth. 

Hook-Up Item Libraries 
This folder enables you to create and manage hook-up libraries and sub-libraries, and organize 
hook-up items in sub-libraries as you require.  For details, see Items in the Hook-Up Item 
Libraries Folder (on page 555). 
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Items in the Hook-Up Item Libraries Folder 
The Hook-Up Item Libraries folder of the Reference Explorer enables you to navigate to a 
hook-up item library, hook-up item sub-library, or hook-up item in a graphical way resembling the 
Windows Explorer.  You can expand or collapse the levels to view the existing items.  The 
Hook-Up Item Libraries folder shows you at a glance the graphical representation of the 
relationships that exist among the hook- up item libraries, hook-up item sub-libraries, and hook-up 
items. 
The Reference Explorer employs an expandable/collapsible hierarchy that allows you to 
navigate to relevant items and select them for use.  To perform an action, right-click the Hook-Up 
Item Libraries folder or an item and then click a command.  Note that the software uses various 
icons beside a folder or item to indicate the status of a folder or an item , for example a view-only 
item , a claimed item , an item that belongs to As-Built, and so forth.  For the full list of the item 
indicators, see Item Status Indicators in the Domain Explorer (on page 540).  For a detailed 
explanation of the tree view and Items panes, see Working with the Reference Explorer. 
In the Hook-Up Item Libraries folder, the software arranges the items in three levels, based on 
the relationship among them. 

Level 1: Hook-Up Item Libraries 
This is the highest level in the Hook-Up Item Libraries folder hierarchy.  At this level, the 
software displays all the hook-up libraries that exist in the current domain.  Hook-up libraries are 
indicated with the  icon. 
A hook-up library always contains one default sub-library and can also contain any number of 
user-defined sub-libraries.  For each hook-up library, on the shortcut menu, you can click New to 
add user-defined sub-libraries, or click Properties to update properties of an existing 
sub-library.  You must set a specific library as the active item library, which is indicated with the 

 icon.  To do so, on the shortcut menu, click Actions > Set as Active Item Library.  You 
cannot delete the default sub-library. 

Level 2: Hook-Up Item Sub-Libraries 
Hook-up sub-libraries (indicated with the  icon) appear under hook-up libraries.  At this level, 
you can click New to add items to sub-libraries, or click Properties to update properties of an 
existing sub-library.  You cannot delete the default sub-library. 

Level 3: Hook-Up Items 
Hook-up items (indicated with the  icon) appear under hook-up item sub-libraries.  Hook-up 
items do not contain child items.  The actions that you can perform at this level depend on the 
sub-library to which the items belong. 
In the default sub-library, you can perform the following actions: 
 Add new hook-up items one by one or in batch mode.  To add a single item, right-click the 

default sub-library and on the shortcut menu, click New.  To add items in batch mode, on the 
shortcut menu, click Actions > Batch Item Creation. 

 Update properties of an existing item.  If this item exists in the user-defined sub- libraries, the 
software automatically updates the item properties in the user-defined sub-libraries. 

 Permanently delete a hook-up item.  When deleting an item from the default sub- library, the 
software also deletes this item from all of the sub-libraries that exist in the entire item library. 

 Manually associate an item with a user-defined sub-library by dragging the item from the 
default sub-library to a user-defined sub- library. 
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In a user-defined sub-library, you can perform the following actions: 
 Add new hook-up items.  When you create a new item in a user-defined sub- library, the 

software automatically creates this item in the default sub-library too.  
 Update properties of an existing item.  When you update properties of an item in a 

user-defined sub-library, the software automatically updates the item properties in the default 
sub-library too.  You can only add new hook-up items that do not exist in the default 
sib-library. 

 Associate hook-up items with sub-libraries or remove items from sub-libraries.  To do so, 
select and right-click a user-defined sub-library and then, on the shortcut menu, click Actions 
> Associate Items with Sub-Libraries. 

 Associate pipe specs with sub-libraries.  To do so, select and right-click a user- defined 
sub-library and then, on the shortcut menu, click Actions > Associate Pipe Specs with Sub- 
Libraries.  For more information on implementation of pipe specs in SmartPlant 
Instrumentation, see Pipe Specs: An Overview (see "Pipe Specs" on page 309). 

 

Create a Reference Item 
1. Press F8 to open the Reference Explorer. 
2. Double-click a folder to display the other existing folders or items. 

 If a folder does not contain sub-folders, right-click the main folder. 
3. Right-click a sub-folder and then on the shortcut menu, click New and then click a menu 

command. 
 The software does not check for duplicate names when creating a reference I/O card.  This 

is so because I/O card uniqueness is based on a parent item and there are no parent items for I/O 
cards in the Reference Explorer. 
 

Create a Reference I/O Card 
1. Press F8 to open the Reference Explorer and expand the Panels folder. 
2. In the Reference Explorer, expand the Wiring Equipment folder. 
3. Right-click the I/O Cards folder and then on the shortcut menu, click New > Wiring 

Equipment. 
4. In the New Wiring Equipment dialog box, under Name, type the name of the new I/O card 

and click OK. 
 As a rule, I/O cards reside in rack slots.  However, reference I/O cards do not have 

parent hierarchy items.  As a result, the software does not check the name uniqueness of 
new reference I/O cards.  Therefore, make sure that you name your new reference I/O cards 
appropriately. 

5. On the Wiring Equipment Properties – I/O Card dialog box, on the General tab, do one of 
the following to define the name of the new card: 
 Select the Apply naming convention check box selected if you want the software to 

name the new card automatically according to the naming conventions that are set for this 
type of equipment in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new card.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Name. 

6. Select the Double width check box if the card occupies a double width slot. 
7. In the Details group box do the following as you require: 
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a. Type a description. 
b. Select an I/O card type, model, and manufacturer.  If the required value is not available on 

the list, click  to define a new one. 
c. Enter a sequence if you need to define the sequence of the new card in its parent 

item.  This sequence also determines the order in which wiring items appear under their 
parent item in the Domain Explorer tree view. 

8. Click the Control System tab. 
9. In the Control system details group box, under I/O type, select a I/O type to determine the 

actual function of the new I/O card.  For example, AI, AO, DI, DP, Fieldbus, Profibus, and so 
forth.  You can add more values to this list in the I/O Type supporting table in the Instrument 
Index module.  (See the important notes at the end of this procedure.) 

10. Under Module, type the software address that this card is assigned to. 
 Module, Controller/ Processor, Rack, and Slot are field headers specific to panel 

manufacturers.  Selecting a different manufacturer when editing the panel displays the 
headings used by that panel manufacturer.   For details, see Customize the 
Controller/Processor List Header in I/O Card Properties. 

11. From the Controller/Processor list, select an I/O card controller.  If the required controller is 

not available on the list, click  to define a new one. 
12. To view the list of all I/O terminations associated with the current I/O card, click the I/O 

Terminations button. 
13. Click the Category Properties tab. 
14. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 I/O card is a wiring equipment category that is shipped with SmartPlant 

Instrumentation.  You cannot delete or rename any of the wiring equipment categories that 
have been shipped with the software.  Nor can you delete or rename the properties of the 
shipped categories.  However, when editing I/O card properties, you can add user-defined 
properties which you can rename or delete as you wish.  For details, see Customize and Use 
Wiring Equipment Categories. 

15. Click the Associate Symbols tab to associate a symbol with the current I/O cards.  The 
software will use this symbol when generating a report in the Enhanced Report Utility.  For 
details, see Associate a Symbol with an Item. 

16. Click OK to accept your settings and close the dialog box. 

 
 In a redundant system configuration, an I/O card can function as a primary or secondary I/O 

card and can be associated with several I/O terminations.  Therefore, an I/O termination can 
serve multi-paired redundant I/O cards.  However, in these redundant I/O card configurations, 
the I/O termination can be associated only with one pair of primary and secondary I/O 
cards.  Also, an I/O card cannot function as both a primary and secondary I/O card for the 
same I/O termination. 

 If an I/O card functions as a primary I/O card, the Control System tab of the Wiring 
Equipment Properties – I/O Card dialog box displays the secondary I/O card data and the 
primary I/O card data properties remain blank.  If an I/O card functions as a secondary I/O 
card, the Control System tab displays the primary I/O card data and the secondary I/O card 
data properties remain blank. 
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Create a Reference Wiring Equipment Item 
1. Press F8 to open the Reference Explorer. 
2. In the Reference Explorer, expand the Wiring Equipment folder. 
3. Right-click an appropriate child folder and then on the shortcut menu, click New > Wiring 

Equipment. 
 Since reference wiring equipment items do not have parent hierarchy items, the software 

does not check the name uniqueness of new reference wiring equipment items.  Therefore, 
make sure that you name your new reference items appropriately. 

4. On the New Wiring Equipment dialog box, under Name, type the name of the item and click 
OK. 

5. On the Wiring Equipment Properties dialog box, on the General tab, do one of the following 
to define the name of the new equipment: 
 Select the Apply naming convention check box selected if you want the software to 

name the new equipment automatically according to the naming conventions that are set 
for this type of equipment in the Administration module.  For more information, see 
SmartPlant Instrumentation Administration Help, Domain Administration > Naming 
Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new equipment.  Note that if you do not clear the Apply naming convention check box, 
the software will ignore the name that you type under Name. 

6. Select the Double width check box if the item occupies a double width slot. 
7. In the Details group box do the following as you require: 

 Type a description. 
 Select an item type, model, and manufacturer.  If the required value is not available on 

the list, click  to define a new one. 
 Enter a sequence if you need to define the sequence of the new item in its parent 

item.  This sequence also determines the order in which wiring items appear under their 
parent item in the Domain Explorer tree view. 

8. Click the Category Properties tab. 
 If you are creating a miscellaneous wiring equipment item , the Category Properties tab 

is not available. 
9. Revise and modify category property values as you require.  Click the value for each property 

and modify it as needed. 
 Wiring equipment categories that are shipped with SmartPlant Instrumentation have 

predefined properties.  You cannot delete or rename any of these categories or their 
properties.  You can only edit their values.  However, you can add user-defined properties to 
any category which you can rename or delete as you wish.  For details, see Customize and 
Use Wiring Equipment Categories. 

10. Click the Associate Symbols tab to associate a symbol with the current item .  The software 
will use this symbol when generating a report in the Enhanced Report Utility.  For details, see 
Associate a Symbol with an Item. 

11. Click OK to accept your settings and close the dialog box. 
 

Create a Reference I/O Termination 
1. Press F8 to open the Reference Explorer. 
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2. In the Reference Explorer, expand the Wiring Equipment folder. 
3. Right-click the I/O Terminations folder and then on the shortcut menu, click New > Wiring 

Equipment. 
 Since reference I/O termination items do not have parent hierarchy items, the software 

does not check the name uniqueness of new reference I/O termination items.  Therefore, 
make sure that you name your new reference I/O termination items appropriately. 

4. On the New Wiring Equipment dialog box, from the Category list, select I/O Termination. 
5. Under Name, type the name of the new I/O termination and click OK. 
6. On the Wiring Equipment Properties – I/O Termination dialog box, on the General tab, do 

one of the following to define the name of the new card: 
 Select the Apply naming convention check box selected if you want the software to 

name the new card automatically according to the naming conventions that are set for this 
type of equipment in the Administration module.  For more information, see SmartPlant 
Instrumentation Administration Help, Domain Administration > Naming Conventions. 

 Clear the Apply naming convention check box and under Name, type the name of the 
new card.  Note that if you do not clear the Apply naming convention check box, the 
software will ignore the name that you type under Name. 

7. Select the Double width check box if the card occupies a double width slot. 
8. In the Details group box do the following as you require: 
9. Type a description. 

a. Select an I/O termination type, model, and manufacturer.  If the required value is not 

available on the list, click  to define a new one. 
b. Enter a sequence if you need to define the sequence of the new I/O termination in its 

parent item .  This sequence also determines the order in which wiring items appear 
under their parent item in the Domain Explorer tree view. 

10. Click the Control System tab. 
11. From the I/O type list, select a I/O type to determine the actual function of the new I/O 

termination.  For example, AI, AO, DI, DP, Fieldbus, Profibus, and so forth.  You can add 
more values to this list in the I/O Type supporting table in the Instrument Index module. 

12. To set the new I/O termination in a distant cabinet or to associate the I/O termination with an 
I/O card that resides in another panel, do the following: 
a. Select the Set within a distant cabinet check box. 
b. Select a cabinet in the Primary I/O card group box. 

13. To associate the current I/O termination with an I/O card that does not have a built-in 
termination block, select the required options in the Primary I/O card group box. 

 The I/O card list contains only those I/O cards that have been created under a rack and 
a slot.  For more information, see Associate an I/O card with an I/O Termination. 

14. To define the current I/O termination as an I/O termination that serves two redundant I/O 
cards, do the following: 
a. Select the Define a redundant I/O card check box. 
b. Select the required options in the Secondary I/O card group box. 
c. Click the Category Properties tab. 
d. Revise and modify category property values as you require.  Click the value for each 

property and modify it as needed. 
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 I/O termination is a wiring equipment category that is shipped with SmartPlant 
Instrumentation.  You cannot delete or rename any of the wiring equipment categories 
that have been shipped with the software.  Nor can you delete or rename the properties 
of the shipped categories.  However, when editing I/O termination properties, you can 
add user-defined properties which you can rename or delete as you wish.  For details, 
see Customize and Use Wiring Equipment Categories. 

e. Click the Associate Symbols tab to associate a symbol with the current I/O 
termination.  The software will use this symbol when generating a report in the Enhanced 
Report Utility.  For details, see Associate a Symbol with an Item. 

f. Click OK to accept your settings and close the dialog box. 
 

Copy a Reference Item to the Domain Explorer 
1. Press F7 and then F8 to open the Domain Explorer and the Reference Explorer. 
2. In the Reference Explorer, expand a hierarchy level and select a reference item. 
3. Drag your selection to a destination level in the Domain Explorer.  Place both Explorer 

windows side by side on your screen and then drag the required items from one Explorer to 
the other. 

4. In the appropriate properties dialog box, (depending on the reference item that you are 
copying), modify the properties of the new item as you require. 
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The Browser module provides you with a wide-angle view of your instrument index data and 
allows you to browse through and modify it from a single location in SmartPlant Instrumentation. 
The core of the Browser module is the Browser Manager that contains a number of predefined 
browsers categorized by data type.  Each browser is associated with a particular SmartPlant 
Instrumentation module but in some cases, it is possible to present data from several different 
modules in a single browser view.  In addition to the predefined browsers, you can also create 
custom browsers such as specification form browsers and PowerSoft browsers.  The browsers 
are grouped according to their category.  Such a group is referred to as a browser group.  For 
example, by defining a browser view for the Control Valve browser in the Process Data & 
Calculation group, you can display information for all instrument tags which have the same 
process function, for example, flow meters. 
You access and manipulate module data and various items by creating customized browser views 
for each of the predefined and custom browsers in the Browser Manager.  You customize each 
browser view by defining its style, sorting sequence, and filter.  You can define a number of 
different browser views for each browser to organize your data according to different 
requirements.  Each browser view will have its own style settings, sorting sequence, and filter to 
present your instrument index data in the most efficient and informative manner.  The browser 
view style settings determine which columns and items will be displayed.  The sorting sequence 
organizes the selected fields in a particular order and the filter lets you display the data filtered 
according to the condition you define. 
In addition to the database fields provided to you by default, the Browser Manager also allows 
you to display custom fields, which you can use to complement data attributes not supported by 
the given database fields in a particular module.  You can modify the names of custom fields, as 
you desire.  Depending on your SmartPlant Instrumentation license, you can also import browser 
views into SmartPlant Instrumentation.  The views are available as add-ons, and once added you 
can use them to access the required data. 

  For some browser views, the Browser Manager allows you to compare two report 
revisions or compare the currently previewed report with a report revision.  This option is 
available only for some browser viewers for which this functionality exists and if the Mark 
Changes and History options have not been selected. 
 
  

Browser Views and Browser Manager 
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Browser Manager 
The Browser Manager enables you to define the settings for the Browser View window that 
displays your project data.  You select your data and determine how the software displays it in the 
Browser View window. You define your viewing settings by defining a view for a selected 
Browser that is associated with a particular SmartPlant Instrumentation module.  Once you define 
and then select a view for a particular browser, the Browser View window displays your data 
according to the selected view settings.  You define a view by either creating a new view or 
duplicating an existing one. 
The first step in defining view settings, is to create a browser view profile (viewing template) for a 
browser that you select from the Browser groups list.  Each browser view must be based on a 
view profile that is defined before any other settings can be selected.  A browser view can contain 
style, sorting sequence, and filter settings: 
 Style — Allows you to select the fields to be displayed, define the field layout (that is, the order 

in which these fields will be displayed), define the data field headers which will be used for the 
current style, and set the field length (number of characters) which will be displayed for each 
selected field. 

 Sort — Allows you to determine the sorting sequence of the fields in the Browser View 
window.  You can also select a different sorting sequence when viewing the data in the 
Browser View window. 

 Filter — Allows you to set a filtering condition that is used to filter the selected data rows 
displayed in the Browser View window. The filter conditions that you apply determine the 
scope of data that is published from browsers. 

After you have defined all the view settings that you require, you can open the Browser View 
window, where the current settings are applied to the data with which the selected browser is 
associated. 
 

Browser Manager Hierarchy 
You define the viewing settings for a specific browser hierarchy level as shown below (the 
following example is the hierarchy which is displayed in the Browser Manager Browser Groups 
data window). 
The Browser Groups hierarchy is as follows: 

First level — Browser Group 

    Second level — Browser      
        Third level — View           

            Fourth level — View Settings 

                
 Browser Group — The first level of the hierarchy stands for a Browser Group which 

represents a module or an item category (for example, Control System).  Each group can 
contain one or more browsers. 
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 Browser — Each browser is associated with the data of a particular module (for example, 
Loop and Equipment in the instrument Index module or an item type whose data it 
displays.  A browser contains one or more viewing templates or views that you can select and 
modify to customize the way the corresponding data is displayed in the Browser View 
window. 

 You cannot add or delete any browser group or browser, nor can you change their 
names.  You can only delete a custom browser. 

 View — Each view (a viewing template) contains the viewing settings: viewing style, sorting 
order, and filtering condition.  These settings will be used to display the data that the selected 
view is associated with.  You can add, delete, modify, or duplicate the view profile to 
customize the way the data is displayed in the Browser View window. 

 

Browser Manager Common Tasks 
The following tasks are used frequently when working with the Browser Manager.  

Select a Default Browser 
This procedure shows you how to define a default browser in the Browser Manager.  This 
enables you to open the default browser view whenever starting SmartPlant Instrumentation with 
the Browser module.  If other modules are open, the default browser option is disabled.  For more 
information, see Select a Default Browser (on page 565). 

Define a View Profile 
This option shows you how to define a view profile, the first step in creating a browser view.  A 
browser view profile serves as a basis for a browser view.  After creating a view profile, you can 
define style, sort, and filter settings for the selected browser view.  Once you have defined all the 
view settings, you can open the view and work with the available data.  For more information, see 
Define a View Profile (on page 565). 

Add a New View 
This option shows you how to add a new view to an existing browser, enabling you to create a 
customized display of your data.  SmartPlant Instrumentation displays your data in the Browser 
View window according to the style, sort, and filter settings you chose.  You start by defining a 
view profile.  Then, you define the required style, sort, and filter settings for the new view.  Note 
that you can also duplicate an existing view and then modify some of the settings as 
required.   For more information, see Add a New View (on page 566). 

Duplicate a View 
This procedure shows you how to duplicate an existing view.  Creating several different views for 
the same browser can be very useful when you need to work with the same module data 
organized in a different manner.  Duplicating an existing view within the same browser is a fast 
way to create a new view on the fly.  After duplicating a view, you can modify it as needed.  For 
more information, see Duplicate a View (on page 567). 

Copy a View to Another Plant 
This procedure shows you how to copy a view from one <plant> to another within the same 
SmartPlant Instrumentation domain.  When copying view settings, the software copies style, sort, 
and filter settings defined in the source view.  For more information, see Copy a View to Another 
Plant (on page 567). 
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Modify a View Profile 
This option shows you how to modify the profile of an existing browser view.  This can be 
necessary after duplicating a browser view.  For more information, see Modify a View Profile (on 
page 568). 

Delete a View 
This option shows you how to delete a browser view that is no longer required.  Remember that 
when deleting a browser view you also delete its Style, Sort and Filter settings.  For more 
information, see Delete a View (on page 568). 

Find a Browser or Browser View 
This option shows you how to find a browser or browser view in the Browser Manager.  For more 
information, see Find a Browser or Browser View (on page 569). 
 

Select a Default Browser 
1. Open the Browser Manager and expand the required Browser Group to display its 

browsers. 
2. Highlight the required browser view, and click Edit. 
3. Select the Set as default view check box. 
4. Right-click the browser which you want to set as default and then, on the shortcut menu, click 

Set As Default. 
 

 The default browser that you select must have a default view.  For details, see Add a New 
View (on page 566). 

 

Define a View Profile 
1. Open the Browser Manager and expand the required browser group to display its browsers. 
2. Select the browser to which you want to add a view and do one of the following: 

 Click Actions > Add View. 
 Right-click the highlighted browser and then, on the shortcut menu, click Add View. 

 Click . 
3. In the View Name field, type the name of the new browser view that you are creating. 
4. In the View Description field, type a brief description of the new browser view. 
5. From the Display data at level list, to set the level on which to display the data in the 

Browser View window.  You can select any of the hierarchy levels that you defined for the 
domain , for example, <Plant> , <Area>, <Unit>, or the level of the domain itself. 

 
 For an Instrument Index Standard Browser or Tag Number Browser, you can also select 

Typical to create a browser view profile with only typical tag and typical loop data. 
 For an Instrument Type browser, you can create a browser view profile on the domain 

level only. 
 Select the Set as default check box to make the current view the default view for the 

browser to which this view belongs.  This way, all the settings defined for this view will be 
used to display the data in all the views belonging to the current browser. 



Browser Views and Browser Manager 
 

 
566 SmartPlant Instrumentation Basic Engineering User's Guide 

 

 Selecting this option allows you to switch between plants in a given domain and define a 
default browser view for another plant, while retaining the default browser views that were 
previously defined for plants in the current domain.  By not selecting the Set as default 
view check box, your default browser view is not retained when defining a new default 
browser view in a different plant. 

6. Select the Count per group check box to display in the print preview and the printed view, the 
total number of rows contained in each group, delimited by the group separator in the print 
preview. 

7. Select the Personal view check box to make this view available to the current user 
only.  Other users will not be able to see this view under Browser Groups and therefore will 
not be able to open it. 

8. Click Save. 
9. Define the style settings you require.  For more details, see Style Settings. 
10. Define the sort settings you require.  For more details, see Sort Settings. 
11. Define the filter settings you require.  For more details, see View Filter Settings. 
12. Select another browser to define a View profile, or close the Browser Manager. 
 
 

Add a New View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser Groups data 

window.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Define a view profile for the new browser view.  For more information, see Define a View 
Profile (on page 565). 

5. Define the style settings.  For more details, see Create a View Style (on page 593). 
6. Set a sorting sequence.  For more details, see Create a Sorting Sequence View (on 

page 602). 
7. Define a filtering condition if needed.  For more details, see Define a View Filter (on 

page 609). 

8. Click  to open the new browser view. 
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Duplicate a View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser groups data 

window.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Do one of the following: 
 To duplicate all the view settings, highlight the view that you want to duplicate. 
 To duplicate only a selected view setting, expand the view and select the Style, Sort or 

Filter icon as required. 
5. Do one of the following: 

 Click . 
 Click Actions > Copy. 
 Right-click the view you want to copy and then, on the shortcut menu, click Copy. 

6. Select the target browser and do one of the following: 

 Click . 
 Click Actions > Paste. 
 Right-click the target browser and then, on the shortcut menu, click Paste. 

 
 You can duplicate the view with all its settings or only with the setting ( view, sort, or filter) 

that you select. 
 You can duplicate browser views only if they belong to the same browser. 
 If you close the Browser Manager, the item you copied will be lost. 

 

Copy a View to Another Plant 
1. On the Browser Manager, select a view that you want to copy to another plant. 
2. Do one of the following: 

 Right-click, and from the shortcut menu select Copy to Other Plant. 
 Click Actions > Copy to Other Plants. 

3. On the Copy View Settings dialog box, select a plant, and then click Copy. 
 If the same view name already exists in the target plant browser, the software does not 

overwrite the settings of the target view, but creates another view with the same name. 
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Modify a View Profile 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser groups data 

window.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Click Edit. 
5. Modify the current view profile settings, by doing any of the following: 

 In the View name field — modify the name of the browser view. 
 In the View description field — add or change a brief description of the browser view. 
 From the Display data at level list — change the level on which to display the data in the 

Browser View window. 
 In the Set as default check box — select to make the current view the default view for the 

browser, or clear the check box so the current view is not the default view for the browser. 
 In the Count per group check box — select to display in the print preview and the printed 

view, the total number of rows contained in each group delimited by the group separator in 
the print preview, or clear the check box so this option will not work. 

 In the Select the Personal view check box — select to make this view available to the 
current user only, or clear the check box so this option will not work. 

6. Click Save, to save the view profile with the settings you have just entered. 
 

Delete a View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, select the target browser in the Browser groups data window. 
4. In the Browser groups data window, select the view you want to delete. 
5. Click Style. 
6. Do one of the following: 

 If the Enable current view in SmartPlant Explorer and in the Find Documents to 
Publish is not enabled, proceed to the next step. 

 In the Style pane, if the Enable current view in SmartPlant Explorer and in the Find 
Documents to Publish is enabled do the following: 
i. In the Domain Explorer, select an appropriate folder. 
ii. Right-click, and from the shortcut menu select Show Browser. 
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iii. In the Show Browser dialog box, make sure the Browser View you want to delete is 
not displayed and click OK. 

iv. On the Style pane, click Edit. 
v. Clear the Enable current view in SmartPlant Explorer and in the Find 

Documents to Publish check box. 
vi. Click Save. 

7. Do one of the following: 

 Click  
 Click Actions > Delete. 
 Right-click and on the shortcut menu select Delete. 

 

Find a Browser or Browser View 
1. In the Browser Manager, do one of the following: 

 Click . 
 On the menu bar, click Actions > Find. 

2. Select the Browser or View option button, depending on what you want to find. 
3. In the data field, type the value that you want to find. 
4. To match the retrieved values with the value you are searching for, do one of the following: 

 Select Whole Value to find only occurrences that are whole words (this is the default 
selection). 

 Select String to find occurrences that are either whole words or part of a word. 
5. Click Find. 

 
 During the search, the Find button changes to Stop, allowing you to stop the search, if 

required. 
 When an appropriate occurrence is found, the corresponding row is automatically 

selected. 
6. Click Find to find the next occurrence. 
7. Click Close when finished. 
 

Browser Groups 
The following browser groups are available in the Browser Manager.  It is not possible to add 
new groups. 
 Instrument Index Browser Group (on page 570) 
 Process Data and Calculation Browser Group (on page 572) 
 Specifications Browser Group (on page 573) 
 Wiring Browser Group (on page 574) 
 Hook-Ups Browser Group (on page 575) 
 Loop Drawings Browser Group (on page 575) 
 Control System Browser Group (on page 575) 
 Dimensional Data Browser Group (on page 576) 
 Construction and Commissioning Browser Group (on page 577) 
 Document Binder Browser Group (on page 578) 
 Documents Browser Group (on page 578) 
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 General Browser Group (on page 579) 
 Telecom Browser Group (on page 579) 

 

Instrument Index Browser Group 
The following table lists all the available browsers, and their descriptions, within the Instrument 
Index browser group. 

Browser Description 

Calibration Results Browser Displays instruments and their attributes that include 
instrument calibration results.  After filtering the fields, create a 
calibration result analysis for a certain period, an instrument 
calibration list, and so forth. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog box.) 

Calibration Settings Browser Displays calibration settings (ranges, set points, alarm points, 
and so forth) for a selected instruments. (Can be utilized when 
filtering I/O assignment data in the I/O Assignment Filter 
dialog box.) 

Circuit Related Electrical Tag 
Browser 

Displays data for tag numbers derived from SmartPlant 
Electrical signals for circuits.  If a circuit relates to more than 
one electrical item, a separate data row appears for each item. 
(Can be utilized when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

DDP and Index Browser Displays instruments and their associated dimensional data for 
piping. (Can be utilized when filtering I/O assignment data in 
the I/O Assignment Filter dialog box.) 

Drawing Summary Browser Allows you to generate a document list for selected 
instruments.  A document list may include specifications, 
process data sheets, loop and hook-up drawings. (Can be 
utilized when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

Electrical Power Element 
Browser 

Displays electrical properties owned by SmartPlant 
Instrumentation and SmartPlant Electrical for instruments and 
cabinets. (Can be utilized when filtering I/O assignment data in 
the I/O Assignment Filter dialog box.) 

Electrical Tag Browser Displays data for all tag numbers derived from SmartPlant 
Electrical signals for all items but does not retrieve data values 
of associated attributes for signals created under circuits.  The 
software displays data for the main item and also associated 
circuit data.(Can be utilized when filtering I/O assignment data 
in the I/O Assignment Filter dialog box.)  

Equipment Browser Process equipment list for the current plant, area, or unit. 

Fieldbus Tag Number List 
Browser 

Displays fieldbus instruments and their associated 
segments.  You can create browser views to be used in the 
Fieldbus Tag Numbers browser to associate tags with 
segments. (Can be utilized when filtering I/O assignment data 
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Browser Description 
in the I/O Assignment Filter dialog box.) 

Function Requirement Browser Displays existing function requirement tag numbers and their 
properties.  The browser allows you to view and edit the data. 
(Can be utilized when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

Instrument Connection Pre- 
assignment Browser 

Allows you to pre-assign specific panels to selected device 
panels.  This pre- assignment facilitates faster and more 
efficient wiring design.  The purpose of this pre-assignment is 
to enable you to define an auto-wiring task for the pre-assigned 
panels as well as providing a criterion by which to filter the 
cables so that only pre- assigned device cables are displayed 
for connection with panels. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog box.) 

Instrument Connection Pre- 
assignment (Advanced) 
Browser 

In addition to the options available for the Instrument 
Connection Pre-assignment Browser, you can also display the 
Control System Tag data in the browser view. (Can be utilized 
when filtering I/O assignment data in the I/O Assignment 
Filter dialog box.) 

Instrument Index Standard 
Browser 

Allows you to display and edit tag numbers from the Instrument 
Index module. (Can be utilized when filtering I/O assignment 
data in the I/O Assignment Filter dialog box.) 

Instrument Type Browser Displays a list of instrument types and their default 
profiles.  This browser is especially useful when you need to 
define a default profile for numerous instrument types at the 
start of a project design. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog box.) 

JB – Index Browser Displays existing field devices and their connections to junction 
boxes and terminals.  Note that you can view only those field 
devices that are connected to the junction box whose wiring is 
continued from the other side of the terminal. (Can be utilized 
when filtering I/O assignment data in the I/O Assignment 
Filter dialog box.) 

Line Browser Lists existing lines and their properties (except for process 
data), and allows you to edit the properties. 

Loop Browser Lists existing loop numbers and their properties, and allows 
you to edit the properties.  This browser does not show 
associated tag numbers.   In the Loop Browser view, you can 
select a P&ID drawing number from the P&ID list and have this 
drawing number propagated to all instruments associated with 
a particular loop.  After saving the settings, the new P&ID 
appears selected in both the Loop Browser View window in the 
Browser module and on the Tag Number Properties dialog box 
in the Instrument Index module.  Before using this feature, 
make sure that in the Instrument Index module, on the Loop 
Number Properties dialog box, the Apply P&ID drawing to tags 
check box is selected. 
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Browser Description 

Maintenance Schedule 
Browser 

Lists existing instruments for which work requests or repair 
forms have been issued.  Also, displays the instruments for 
which preventive maintenance has been scheduled. (Can be 
utilized when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

Range Browser Displays the following range values: calibration range, process 
data range, alarm and trip settings. (Can be utilized when 
filtering I/O assignment data in the I/O Assignment Filter 
dialog box.) 

Tag Category Browser Displays existing instrument tag numbers that have been 
associated with a tag category. (Can be utilized when filtering 
I/O assignment data in the I/O Assignment Filter dialog box.)

Tag Number Browser Lists existing instrument tag numbers and their properties, and 
allows you to edit the properties. (Can be utilized when filtering 
I/O assignment data in the I/O Assignment Filter dialog box.)

 
 

Process Data and Calculation Browser Group 
The following table lists all the available browsers, and their descriptions, within the Process Data 
and Calculation browser group. 

 All the browsers in this group can be used to filter I/O assignment data in the I/O 
Assignment window. 

Browser Description 

Analyzer Browser Lists the existing analyzers, and allows you to edit the associated 
data.  You can also include custom fields. 

Control Valve Browser Lists the existing control valves for process and calculation data, and 
allows you to edit the control valve properties.  You can also include 
custom fields. 

Flow Instrument Browser Lists the existing flow instruments for process and calculation data, 
and allows you to edit the flow instrument properties.  You can also 
include custom fields. 

General Process Browser Lists all the General Process Data field records, tag number custom 
field data, as well as specification and process data custom field 
information. 

Level Instrument Browser Lists the existing level instruments for process data, and allows you 
to edit the level instrument properties.  You can also include custom 
fields. 

Line Component Browser Lists existing line measuring components for analyzers and allows 
you to edit the components. 

Line Process Data 
Browser 

Lists the line data for process data and calculation, and allows you to 
edit the line data.  You can also include line custom field data. 



 Browser Views and Browser Manager 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 573 
 

Browser Description 

Pressure Instrument 
Browser 

Lists the existing pressure instruments for process data, and allows 
you to edit the pressure instrument properties.  You can also include 
custom fields. 

Relief Valve Browser Lists the existing relief valves for process data and calculation, and 
allows you to edit the relief valve properties.  You can also include 
custom fields. 

Temperature Instrument 
Browser 

Lists the existing temperature instruments for process data and 
calculation, and allows you to edit the temperature instrument 
properties.  You can also include custom fields. 

 
 

Specifications Browser Group 
The following table lists all the browsers that you can add within the Specifications browser 
group. 

Browser Description 

Specifications 
Browser 

Lists specifications and allows you to edit them.  You can also 
include drawing custom field data.  This browser comes shipped 
with SmartPlant Instrumentation. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog box.) 

Single-Form Browser A custom browser whose format you generate and save in the Spec 
Data Dictionary of the Specifications module.  You add such 
single-form browsers to the Specifications browser group using the 
using the Browser Manager > Browser > Form Browser 
option.  The browser name is user-defined. 

Multi-Form Browser A custom browser that allows you to display field headers and the 
values of field that are assigned to these headers in different 
specification forms.  You generate such browsers using the 
Multi-Form Browser Wizard of the Specifications module.  The 
software adds multi- form browsers automatically to the 
Specifications browser group.  The names of multi-form browsers 
always start with the Multi-Form. 
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Wiring Browser Group 
The following table lists all the available browsers, and their descriptions, within the Wiring 
browser group. 

Browser Description 

Auto-Wiring Routing Task 
Browser 

Allows you to define and execute auto-wiring tasks for selected 
junction boxes and control system panels. 

Cable Browser Lists all the available cables and their attributes. 

Cable Set Browser Displays all the cable sets in the existing cables and allows you to 
edit the cable sets.  Only the cable set data can be edited. 

Device Panel Browser Displays field devices and their connections. (Can be utilized when 
filtering I/O assignment data in the I/O Assignment Filter dialog 
box.)  

General Panel Browser Displays existing panel data and allows you to edit the data. (Can 
be utilized when filtering device panels.) 

I/O Card Browser Displays I/O card data and allows you to edit the data.  This 
browser also includes I/O card custom fields. (Can be utilized when 
filtering device panels.)  

I/O Terminal Browser Displays I/O terminal data and allows you to edit the data.  You can 
also view the panels and I/O cards to which the terminals belong. 
(Can be utilized when filtering device panels.)  

Local Signal Browser Displays the existing local signals. 

Rack Browser Displays the existing hardware racks and allows you to edit 
them.(Can be utilized when filtering device panels.)  

Segment Assignment Allows you to select a segment to be associated with a displayed 
home-run cable and terminator. (Can be utilized when filtering 
device panels.) 

Slot Browser Displays existing slot data and allows you to edit the data. 

Strip Browser Displays all the existing terminals and allows you to edit 
them.  You can also view the appropriate strips and panels. (Can 
be utilized when filtering device panels.) 

Telecom Channel Data 
Browser 

Displays channel data for telecom objects and allows you to edit 
the data. 

Terminal Browser Displays the existing terminals and allows you to edit them. (Can 
be utilized when filtering device panels.) 

Terminal Connection 
Browser 

Displays terminal connection data.  The data includes the 
connection on both sides of the terminals. (Can be utilized when 
filtering device panels.) 

Wire Browser Displays wire data and also displays the cable sets and cables to 
which the wires belong.  You can edit the wire data as you require.

Wire Connection Browser Displays wire connection data.  The data includes the connection 
on both sides of the wires. 
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Browser Description 

Wiring Equipment Browser Displays existing wiring equipment data and allows you to edit the 
data. 

 
 

Hook-Ups Browser Group 
The following table lists all the available browsers, and their descriptions, within the Hook-Ups 
browser group. 

Browser Description 

Hook-Up Browser Display and edit the existing hook-up types, and the 
associated hook-ups. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog box.) 

Item List Browser Lists all the items from the hook-up library. 
 
 

Loop Drawings Browser Group 
The following table lists all the available browsers, and their descriptions, within the Loop 
Drawings browser group. 

Browser Description 

Block Browser Displays all the existing blocks and allows you to edit 
them.  Display the loop and tag numbers to which the blocks 
belong. 

Enhanced Report Utility Browser Displays all loop numbers that are assigned to Enhanced Report 
Utility drawing layouts.  You can reassign loop numbers to any 
available layout. 

Loop Browser Displays all the existing loop drawings with their revisions and 
generation types. 

 
 

Control System Browser Group 
The following table lists all the available browsers, and their descriptions, within the Control 
System browser group. 

Browser Description 

NIM General Browser Displays all the tag numbers that have been assigned to 
channels and associate these tags with appropriate point 
types.  This browser uses Honeywell-specific terminology.

Control System Tag Browser Display all the tag numbers that have been assigned to 
channels and enter custom information for the displayed 
tags. (Can be utilized when filtering I/O assignment data in 
the I/O Assignment Filter dialog box.) 
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Browser Description 

DeltaV Conventional Tag 
Browser 

Displays all the conventional tag numbers available for 
publishing to DeltaV. 

DeltaV Fieldbus Tag Browser Displays all the fieldbus tag numbers available for 
publishing to DeltaV. 

NIM Analog Input Browser Displays all the tag numbers with the point type defined as 
NIM Analog Input.  You can also set the control system tag 
parameters.  This browser uses Honeywell-specific 
terminology. 

NIM Analog Output Browser Displays all the tag numbers with the point type defined as 
NIM Analog Output.  You can also set the control system 
tag parameters.  This browser uses Honeywell-specific 
terminology. 

NIM Digital Input Browser Displays all the tag numbers with the point type defined as 
NIM Digital Input.  You can also set the control system tag 
parameters.  This browser uses Honeywell-specific 
terminology. 

NIM Digital Output Browser Displays all the tag numbers with the point type defined as 
NIM Digital Output.  You can also set the control system 
tag parameters.  This browser uses Honeywell-specific 
terminology. 

Publish Yokogawa CST 
(Conventional) Browser 

Displays Yokogawa conventional control system tags 
intended for publishing. (Can be utilized when filtering 
device panels.) 

Publish Yokogawa CST (FF) 
Browser 

Displays Yokogawa fieldbus control system tags intended 
for publishing. (Can be utilized when filtering device 
panels.) 

 
 The DeltaV and Yokogawa browsers are intended specifically for viewing the DCS data as 

described, and you should not make any customizations to these browsers using InfoMaker. 
 Note that when defining a style for a control system browser, you must always select the 

Control System Tag field header (the CMPNT_SYS_TYPE-ID table column name). 
 

Dimensional Data Browser Group 
The following table lists all the available browsers, and their descriptions, within the Dimensional 
Data browser group. 

Browser Description 

Default Data Browser Displays default dimensional data for piping and allows you to edit the 
data. 

Vendor Data Browser Displays vendor dimensional data for piping and allows you to edit the 
data. 
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Browser Description 

Working Data Browser Displays working dimensional data for piping and allows you to edit the 
data .(Can be utilized when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

 
 

Construction and Commissioning Browser Group 
The following table lists all the available browsers, and their descriptions, within the Construction 
and Commissioning browser group. 

Browser Description 

Cable Schedule Installation 
Index Browser 

Lists all the cables for the current unit or plant where you 
can change the Electrical Installation Index, edit cable 
descriptions, and so forth. 

Cable Schedule Installation 
Index Changes Browser 

Lists all the plant or unit cables, their attributes, 
installation index status and version. 

Instrument Installation Index 
Browser 

Allows you to generate an electrical, instrument, and 
mechanical installation report that includes the 
appropriate drawing references. (Can be utilized when 
filtering I/O assignment data in the I/O Assignment 
Filter dialog box.) 

Instrument Installation Index 
Changes Browser 

Displays electrical, instrument, and mechanical 
installation changes that include the installation status 
and version. (Can be utilized when filtering I/O 
assignment data in the I/O Assignment Filter dialog 
box.) 

Panel Termination Installation 
Index Browser 

Displays the plant or unit device panels and their 
electrical index. (Can be utilized when filtering device 
panels.) 

Panel Termination Installation 
Index Changes Browser 

Displays the plant or unit device panels with their 
electrical installation index and installation changes. 
(Can be utilized when filtering device panels.) 

Terminal Schedule Installation 
Index Browser 

Displays the plant or unit termination schedule and the 
appropriate installation indexes. (Can be utilized when 
filtering device panels.) 

Terminal Schedule Installation 
Index Changes Browser 

Shows the plant or unit termination schedule and the 
installation index changes. (Can be utilized when filtering 
device panels.) 

Wiring Schedule Installation 
Index Browser 

Displays the plant or unit cable, cable set, and wire 
connections and their appropriate installation indexes. 

Wiring Schedule Installation 
Index Changes Browser 

Displays the plant or unit cable, cable set, and wire 
connections and their installation index changes. 
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Document Binder Browser Group 

Browser Description 

Spec Binder Package Browser Allows you to generate a browser that includes tag 
numbers belonging to a Specification Binder 
package, tag number attributes, package item 
number, and specification data. (Can be utilized 
when filtering I/O assignment data in the I/O 
Assignment Filter dialog box.) 

 
 

Documents Browser Group 
The following table lists all the available browsers, and their descriptions, within the Documents 
browser group. 

Browser Description 

Archive Browser Allows you to generate a document list of all archived documents 
associated with the report names that you selected in the Administration 
module for archiving, and then view and compare archived reports. 

Drawing Browser Allows you to generate a document list that shows the document name, 
type (P&ID, process data, calculation, specification, loop, or hook-up 
drawing), and custom field data. 

Revision Browser Allows you to generate a document revision browser that includes all 
drawings in the plant hierarchy and all their revisions. 

Changes Log 
Browsers 

These browsers allow you to generate reports that show when changes 
were made to the item type.  You can generate reports for Cables, Control 
System Tags, Equipment, Instruments, Lines, Loops, Panels, and Wiring 
Equipment. 

 
 The Changes Log Panel browser can be utilized when filtering device 

panels. 
 The Changes Log Instrument browser can be utilized when filtering 

I/O assignment data in the I/O Assignment Filter dialog box. 

 When items are deleted, the Changes Log browsers do not include these deletions as 
changes. 
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General Browser Group 
The following table lists all the available browsers, and their descriptions, within the General 
browser group. 

Browser Description 

Changes Log 
Browser 

Displays changes to property values for items at the 
selected plant hierarchy level.  This browser is only visible 
when the System Administrator selects the Item registry 
check box for the domain. 

Task Browser Displays tasks available in the To Do List (that is, tasks 
generated after you retrieve documents. 

 
 

Telecom Browser Group 
The following table lists all the available browsers, and their descriptions, within the Telecom 
browser group. 

Browser Description 

End Point Amplifier 
Browser 

Displays existing end point amplifier data. (Can be utilized when 
filtering device panels.) 

End Point Hub Browser Displays existing end point hub data. (Can be utilized when filtering 
device panels.) 

End Point Intercom 
Browser 

Displays existing end point intercom data. (Can be utilized when 
filtering device panels.) 

End Point 
Miscellaneous Browser 

Displays existing end point miscellaneous equipment data.(Can be 
utilized when filtering device panels.)  

End Point PABX 
Browser 

Displays existing end point PABX data. (Can be utilized when filtering 
device panels.) 

Hub Cabinet Browser Displays existing hub cabinet data. (Can be utilized when filtering 
device panels.) 

Hub Equipment 
Browser 

Displays existing hub equipment data. 

Intercom Cabinet 
Browser 

Displays existing intercom cabinet data. (Can be utilized when filtering 
device panels.) 

Intercom Equipment 
Browser 

Displays existing end point intercom equipment data. 

Miscellaneous Cabinet 
Browser 

Displays existing miscellaneous cabinet data. (Can be utilized when 
filtering device panels.) 

Miscellaneous 
Equipment Browser 

Displays existing miscellaneous equipment data. (Can be utilized 
when filtering device panels.) 

PA Cabinet Browser Displays existing PA cabinet data. (Can be utilized when filtering 
device panels.) 
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Browser Description 

PABX Cabinet Browser Displays existing PABX cabinet data. (Can be utilized when filtering 
device panels.) 

Port-Data Browser Displays existing port data. (Can be utilized when filtering device 
panels.) 

 
 

Browser Filters for Device Panels 
The following table lists all the available browser filters that can be used when filtering device 
panels in the Filter (Device Panels) dialog box. 

Browser Group Browser 

Control System Publish Yokogawa CST (Conventional) Browser 

Control System Publish Yokogawa CST (FF) Browser 

Construction and 
Commissioning 

Panel Termination Installation Index Browser 

Construction and 
Commissioning 

Panel Termination Installation Index Changes 
Browser 

Construction and 
Commissioning 

Terminal Schedule Installation Index Browser 

Construction and 
Commissioning 

Terminal Schedule Installation Index Changes 
Browser 

Documents Changes Log Panel Browser 

Telecom End Point Amplifier Browser 

Telecom End Point Hub Browser 

Telecom End Point Intercom Browser 

Telecom End Point Miscellaneous Browser 

Telecom End Point PABX Browser 

Telecom Hub Cabinet Browser 

Telecom Intercom Cabinet Browser 

Telecom Miscellaneous Cabinet Browser 

Telecom Miscellaneous Equipment Browser 

Telecom PA Cabinet Browser 

Telecom PABX Cabinet Browser 

Telecom Port-Data Browser 

Wiring General Panel Browser 

Wiring I/O Card Browser 
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Browser Group Browser 

Wiring I/O Terminal Browser 

Wiring Rack Browser 

Wiring Segment Assignment 

Wiring Strip Browser 

Wiring Terminal Browser 

Wiring Terminal Connection Browser 
 
 

Browser Filters for I/O Assignment 
The following table lists all the available browser filters that can be used when filtering instrument 
tags and control system tags in the I/O assignment Filter dialog box. 

Browser Group Browser 

Instrument index Calibration Results Browser 

Instrument index Calibration Settings Browser 

Instrument index Circuit Related Electrical Tag Browser 

Instrument index DDP and Index Browser 

Instrument index Drawing Summary Browser 

Instrument index Electrical Power Element Browser 

Instrument index Electrical Tag Browser 

Instrument index Fieldbus Tag Number List Browser 

Instrument index Function Requirement Browser 

Instrument index Instrument Connection Pre- assignment Browser 

Instrument index Instrument Connection Pre- assignment (Advanced) 
Browser 

Instrument index Instrument Index Standard Browser 

Tag Number Browser Instrument Type Browser 

Tag Number Browser JB – Index Browser 

Tag Number Browser Maintenance Schedule Browser 

Tag Number Browser Range Browser 
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Browser Group Browser 

Tag Number Browser Tag Category Browser 

Tag Number Browser Tag Number Browser 

Process Data and Calculation All the browsers in this group 

Specifications Specifications Browser 

Wiring Device Panel Browser 

Hook-Ups Hook-Up Browser 

Control System Control System Tag Browser 

Dimensional Data Working Data Browser 

Construction and Commissioning Instrument Installation Index Browser 

Construction and Commissioning Instrument Installation Index Changes Browser 

Document Binder Spec Binder Package Browser 

Documents Changes Log Instrument 

 
 

Browser Manager Commands 
Available commands for the Browser Manager.  The available options depend on the level and 
particular item that you select.  Some options may be inactive depending on the item selected in 
the Browser Group data window. 

Icon Command Shortcut Explanation 

None Modules None Contains all the commands for starting 
SmartPlant Instrumentation modules.  You 
can have multiple modules running 
simultaneously. The number of modules 
that you can run at the same time depends 
on your computer resources. 

 Actions > Open 
View 

Right-click Opens the Browser View dialog box that 
displays the data using the settings defined 
in the Browser Manager.  Note that you 
have to select a view before clicking this 
icon. 

 Actions > Add 
View 

Right-click Adds a new view to the browser that you 
selected in the Browser Groups data 
window.  This is active only when you 
select a browser. 
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Icon Command Shortcut Explanation 

 Actions > Delete Right-click Deletes the item you selected in the 
Browser Groups data window.  Remember 
that you can undo only the last action! 

None Actions > Copy 
to other plant 

Right-click Opens a dialog box to select a target plant 
for copying a view selected in the Browser 
Manager. 

None Actions > Set as 
Default 

Right-click Sets the default view of the selected 
browser as the default browser view 
whenever starting SmartPlant 
Instrumentation with the Browser module. 

 Actions > Copy Right-click Copies the item you selected in the 
Browser Groups data window. 

 Actions > Paste Right-click Pastes the copied item into the Browser 
Groups data window.  This icon becomes 
available after clicking Copy. 

 Actions > Undo Right-click Undoes the last action.  Remember that 
you can undo only the last action! If you 
close the Browser Manager, you will not be 
able to undo the last action after you 
reopen the Browser Manager. 

None Actions > Set 
Color for Read- 
Only Fields 

None Opens the Edit Color dialog box that 
enables you to set the background color of 
read-only fields that appear in the Browser 
View window.  The default color is yellow. 

 Actions > Find Right-click Finds a browser or a view in the Browser 
Groups data window.  You can search 
using a whole word or just a part of a word.

None Actions > 
Selection 
Options  

  Contains field selection commands for the 
Style Settings.  (Only available when 
editing the style settings of a browser view.)

None Actions > 
Selection 
Options > Select 
All 

None Selects all the check-boxes of all the 
available fields. 

None Actions > 
Selection 
Options > Clear 
All 

None Clears all the check-boxes of all the 
available fields. 

None Actions > 
Selection 
Options > 
Custom 

None Selects the check boxes of the available 
custom fields 
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Icon Command Shortcut Explanation 

None Actions > 
Selection 
Options > Clear 
Custom 

None Clears all the custom field check- boxes. 

None Actions > 
Selection 
Options > Non- 
custom 

None Selects the check- boxes of fields that are 
not custom fields. 

None Actions > 
Selection 
Options > Clear 
Non- Custom 

None Clears the check- boxes of non- custom 
fields. 

None Browser    The options in this menu let you add 
custom browsers to the Browser Manager.

None Browser > Form 
Browser 

None Opens the Add a Form Browser dialog box, 
where you can add a new specification 
form browser to the Specifications Group in 
the Browser Manager. 

None Browser > 
PowerSoft 
Browser 

None Opens the Add a PowerSoft Browser dialog 
box, where you can add a new custom 
browser created in InfoMaker.  For details 
on how to create a custom browser in 
InfoMaker, see Creating a New Browser for 
SmartPlant Instrumentation. 
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Adding New Browsers 
SmartPlant Instrumentation is supplied with predefined browsers for you to view and manipulate 
your data.  In addition, it is possible to add three kinds of browser that can be customized 
extensively.  You can add the following browsers in the Browser Manager: 
 PowerSoft Browser — a browser you create as a .psr report or a .pbd file using 

InfoMaker.  You add such browsers to any group that you require using the Browser 
Manager > Browser > PowerSoft Browser option. 

 Single-Form Browser — a specification form browser, whose format you generate and save 
in the Spec Data Dictionary of the Specifications module.  You add such single-form 
browsers to the Specifications browser group using the using the Browser Manager > 
Browser > Form Browser option. 

 Multi-Form Browser — a browser that allows you to display field headers and the values of 
field that are assigned to these headers in different specification forms.  You generate such 
browsers using the Multi-Form Browser Wizard of the Specifications module.  The software 
adds multi- form browsers automatically to the Specifications browser group.  The names of 
multi-form browsers always start with the Multi-Form prefix. 

 
 If you created browser views for a multi-form browser, and then, in the Specifications module, 

run the Multi-Form Browser Wizard to make changes to the browser fields, the software 
re-creates this browser and deletes all the existing views. 

 On a multi-user database platform, before re-creating a multi-form browser, you must first 
make sure that other users have no views open for this browser.  Re-creation of an existing 
browser when its view is open on another machine results in unstable software behavior and 
the software might close unexpectedly on the machine where the browser view is open. 

 
 

Adding New Browsers Common Tasks 
The following tasks are used when you add a new specification form or PowerSoft browser in 
SmartPlant Instrumentation.  

Add a Single-Form Browser 
Use this procedure to add single-form browsers to the Specifications browser group.  The basis 
for a single-form browser is a browser format you generated in the Spec Data Dictionary in the 
Specifications module spec form with fields you made available using the Field Properties 
options of the Spec Data Dictionary.  When you generate such a form in the Specifications 
module, the following rules and restrictions apply: 
 A single-form browser only displays those fields that you set as available for the browser in the 

Spec Data Dictionary. 
 A form browser displays the field headers that you set in the Spec Data Dictionary.  The 

header names can differ from the header names in the actual forms and in the specifications 
based on these forms. 

 You can add one form browser for each form. 
For more information, see Add a Single-Form Browser (on page 586). 
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Test a Multi-Form Browser 
Use this procedure to check whether you created a multi-form browser> successfully in the 
Specifications module.  For more information, see Test a Multi-Form Browser (on page 587). 

Create a PowerSoft Browser in InfoMaker 
Use this procedure to create a custom browser using InfoMaker.  InfoMaker gives you complete 
flexibility to specify any number of tables, fields, and database views, as you require.  You can 
create single custom browsers as .psr files or save a group of custom browsers in a .pbl 
library.  Then, in the Browser module, you can import several browsers from a library or import a 
single .psr file. 

 
 You must have a connection to the SmartPlant Instrumentation database to be able to select 

SmartPlant Instrumentation tables and fields. 
 The procedure includes only those steps in InfoMaker that are required for creating a new 

browser for SmartPlant Instrumentation. 
For more information, see Create a PowerSoft Browser in InfoMaker (on page 587). 

Add a PowerSoft Browser 
Use this procedure to add a custom browser created in InfoMaker as a .psr or .pbd file to a 
browser group in the Browser Manager.  For this browser to be fully compatible with the Browser 
module, you must follow specific rules when creating the browser in InfoMaker. 

 
 Only proficient users who have advanced knowledge of the database structure should attempt 

this advanced feature. 
 You cannot perform report comparison for PowerSoft browsers. 

For more information, see Add a PowerSoft Browser (on page 588). 
 
 

Add a Single-Form Browser 
 You must first generate and save a browser format in the Specifications 

module.  For details, see Define Form Browser Fields (on page 230). 
1. Open the Browser Manager. 
2. Click Browser Manager > Browser > Form Browser to open the Add a Form Browser 

dialog box. 
3. On the Add a Form Browser dialog box, select the specification forms for which you want to 

add single-form browsers to the Specifications browser group. 
4. Click Add. 

 
 You can display the Notes field in a view defined in the Specifications browser group and 

modify the contents one line at a time.  To ensure that each new line will be visible in the 
specification itself, press Ctrl + Enter to add a carriage return. 
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Test a Multi-Form Browser 
 You must first create a multi- form browser in the Specifications module.  For details, 

see Define a Multi-Form Browser (on page 231). 
1. Open the Browser Manager. 
2. Under Browser groups, double- click Specifications to display all the browsers in the group. 

 The multi-browser name string starts with Multi-Form. 
3. Create a browser view and define field headers, form number and item numbers in the view 

style. 
 In the browser view style, for each field header you defined for the browser, under Table 

Column Name, the software displays C1, C2, C3, and so forth.  These are not field names 
but field group indicator values in the database.  Since several form fields can be assigned to 
the same header, the software cannot display the field names in the Style section of the 
Browser Manager. 

4. Open the browser view to see the results. 
 In the browser view, the field headers you included in the browser should appears as 

column names and the values of the fields assigned to these headers in various spec forms 
should appear in the column cells. 

 
 

Create a PowerSoft Browser in InfoMaker 
1. In InfoMaker, click File > New. 
2. On the New dialog box, on the Library tab, create a library where you can group 

newly-created browsers.  The library file must be in .pbl format.  For details, see Create an 
InfoMaker Library (on page 616). 

3. Reopen the New dialog box and click the Object tab. 
4. Select Grid for the report layout and click OK. 
5. In the Grid Report Generator Wizard, select SQL Select, and then complete the Wizard 

steps. 
6. On the Select Tables dialog box, select the tables that you require. 
7. In the Select window, do the following: 

 Select fields from the tables. 
 Select a primary key from each table. 

8. Click the Return icon to open the Select Color and Border Settings dialog box, where you 
can set the browser colors.  After setting the browser colors, click Next and then click Finish 
to display the Report preview window. 

9. In the report preview window, click the Data Source icon to reopen the Select window. 
10. In the Select window, do the following: 

a. On the Design menu, click Convert to Syntax to convert the selected fields from the 
graphic mode to the syntax mode. 

b. Remove all the quotation marks (") from the displayed SQL statement. 
The following example shows how the final SQL statement should appear:  
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SELECT    component.cmpnt_name, 
                     component.cmpnt_serv, 
                     loop.loop_name, 
                     loop.loop_serv, component.cmpnt_id, 
                     loop.loop_id  
FROM         component, 
                     loop WHERE      (loop.loop_id=component.loop_id ) 
                     loop 

11. Return to the report preview window and do the following: 
a. Set the header font style to MS Sans Serif, 8 point, Bold. 
b. Protect fields that you want to reserve for internal use (do not protect the primary keys) by 

setting the protected column attribute to 1 (one). 
c. For each header name, use the following naming convention: <column name>_t.  For 

example, cmpnt_name_t. 
d. For each field name, use the following naming convention: <column name>.  For 

example, cmpnt_name. 
e. Delete the flag_color field, and also delete all the columns that contain primary keys (the 

primary keys remain in the SQL statement). 
f. On the General tab, from the Units select list, select Inches. 

 A report you create in InfoMaker is automatically assigned to PBUs 
(PowerBuilder units).  You must change the units from PBUs to inches because the use of 
PBUs causes various display problems: the report print preview and printout may appear 
without a title block; instrument tags may not be grouped correctly on a single page and, 
instead, appear on individual pages. 

12. Save the report data in one of the following ways: 
 Without previewing, click Save As to save the report in the specially created .pbl library. 
 Save the report as a stand- alone .psr file. 

13. If you saved the report in the .pbl library, do the following: 
a. Copy the .pbl file to another location, preferably to the SmartPlant Instrumentation home 

folder, and then change the file extension from .pbl to .pbd. 
b. In the [CUSTOM] section of your Intools.ini file, add the following line (including the full 

pathname of the .pbd file): 
LibraryList=XYZ.pbd. 

 
 

Add a PowerSoft Browser 
 

 You must follow specific rules when creating a new browser in InfoMaker.  For more details, 
see Create a PowerSoft Browser in InfoMaker (on page 587). 

1. Start the Browser Manager. 
2. Click, Browser > PowerSoft Browser. 
3. In the Add a PowerSoft Browser dialog box, click Browse next to the File Name field. 
4. In the Select a PowerSoft File dialog box, do one of the following: 

 Navigate to a desired .psr file. 
 Navigate to a desired .pbd file and then, in the data window of the Add a PowerSoft 

Browser dialog box, select one or more PowerSoft forms belonging to the specified .pbd 
file. 
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 When defining settings for multiple PowerSoft forms belonging to the specified .pbd file, 
use the Previous and Next buttons, or click Form List and then select a PowerSoft form for 
which you want to define browser settings. 

5. Click OK to open the PowerSoft Browser Settings dialog box. 
6. In the Browser field, type the name of the target browser. 
7. In the Description field, type the new browser description. 
8. From the Primary table list, select the primary table for the new browser.  This list contains 

all the tables that you selected when creating the report in InfoMaker. 
9. From the Primary value list, select the value for the primary key name of the new 

browser.  For example, in the COMPONENT table, the primary value is CMPNT_NAME. 
10. From the Browser group list, select a browser group to which you want to assign the new 

browser. 
11. From the Access right item list, select the item for the access rights definition.  For example, 

MODULE ACCESS – INDEX. 
12. From the Default sort list, select the default sort value. 
13. From the Item for enhanced reports list, select an item on which to apply the Enhanced 

Report Utility macro filter. 
 An Enhanced Report Utility macro filter is a filter for which you define conditions 

for displaying macro attributes in Enhanced Report Utility drawings.  After you select an item 
from this list, in the Loop Drawings module, you can set filter conditions for Enhanced Report 
Utility drawings that use this browser data.  For details, see Set Filter Conditions for Item 
Properties . 

 If you want to work with the new browser in the Instrument Index module, select the 
Define as browser for Instrument Index module check box. 
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Browser View Style Settings 
You define style settings as part of the browser view customization.  Style options allow you to 
display or define the style settings for a browser view that you select in the Browser groups 
pane.  SmartPlant Instrumentation then uses these style settings to display your data associated 
with the current browser. 
Style settings include the following options: 
 Determining which fields the software displays in the Browser View window. 
 Setting the order and width of the selected fields and determining how they appear in the 

Browser View window. 
 Customizing the layout of a browser view for printing. 
 Printing out the style setting data. 

 

Style Settings Common Tasks 
The following tasks are used frequently when customizing browser views in SmartPlant 
Instrumentation.  

Display the Current Style Setting 
This option shows you how to display the current style settings of the browser view that you select 
from the Browser groups list in the Browser Manager.  If you have not yet defined a view profile 
for a selected browser, no style settings are available.  For more information, see Display the 
Current Style Setting (on page 592). 

Create a View Style 
You use this option to create new style settings for a selected browser view.  For more 
information, see Create a View Style (on page 593). 

Modify Style Settings 
This option enables you to modify existing style settings for a selected browser view.  For more 
information, see Modify Style Settings (on page 595). 

Define the Structure of a Print Layout 
This option shows you how to structure the print layout of the data when printing out the data 
displayed in a customized Browser View window.  You can select the fields that you want to be 
displayed in the print preview and the printout as well as do the following: 
 Sequence the columns. 
 Set the column width. 
 Define the number of fields per column: a single field per column or multiple (no more than 

five) fields per column. 
 Set the text and header font size. 
 Set the header height. 

For more information, see Structure the Print Layout (see "Define the Structure of a Print Layout" 
on page 596). 
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Clear a Print Layout Structure 
This option shows you how to clear the existing print preview layout structure defined for the 
current browser view without clearing all the style settings for this browser view.  For more 
information, see Clear a Print Layout Structure (on page 597). 

Duplicate a View Style 
This option shows you how to copy view style settings to another existing browser view.  Note that 
this action overwrites the target style settings with the duplicated style settings.  For more 
information, see Duplicate a View Style (on page 598). 

Clear a View Setting 
Use this option to clear all the style settings for a selected browser view.   For more information, 
see Clear a View Setting. (see "Clear a View Setting" on page 594) 

Print the Style Setting Data 
Use this option to print out all the data that appears in the Style settings data window.  You can 
print out the data for all the fields or just for the ones you have selected to view.  For more 
information, see Print the Style Setting Data (on page 599). 
 
 

Display the Current Style Setting 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser groups data 

pane.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Expand the required browser view in the Browser Groups data window and do one of the 
following: 

 In the Browser Groups data window, click . 

 In the upper-right data window, double-click . 
5. The fields currently used in the selected style are listed in Style field list pane, to the right of 

the Browser groups pane.  The current style settings of the selected view are displayed in 
the lower pane. 
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Create a View Style 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, add a new view profile or edit an existing one. 
4. Do one of the following: 

 In the Browser groups data window, click . 

 In the upper-right data window, double-click . 
5. On the lower Style pane, click Edit. 
6. In the Name data field, type the new style name (defaults to Style followed by a number). 
7. Select the Enable current view in SmartPlant Explorer and in the Find Documents to 

Publish wizard check box to make the current browser view available in the Domain 
Explorer, Reference Explorer, and all the other explorer windows in SmartPlant 
Instrumentation.  After selecting this check box and saving the style settings, the current 
browser view becomes available in the Show Browser dialog box that you open from an 
explorer window. 

8. Do one of the following to select the fields to be displayed in the browser view: 
 Select the appropriate View check boxes, by scrolling down the Style settings data 

window and selecting the required fields individually.  Note that the primary value field is 
always selected, and a check mark appears in its View check box by default. 

 Select the All check box in the Select group box, to select all the available fields. 
 Select the Custom check box in the Select group box to select all the custom fields. 
 Select the Non-custom check box in the Select group box to select all the fields that are 

not custom fields. 
9. Click the Data Field Header box to customize the header. 

 
 Data field headers that you customize appear in the browser view column headers when 

using the current style to view the data.  You can customize any data field header. 
 In addition to the database fields provided to you by default, the Browser Manager also 

provides you with custom fields, which you can use to complement data attributes.  A 
user with Domain Administrator rights can make default custom field definitions in the 
Administration module. 

 It is not possible to display an apostrophe in a custom field header.  If your definition 
includes an apostrophe character, this character changes in the header to a double quote 
character ".  If your definition includes a double quite character, it changes in the header 
to a tilde character ~.  Other special characters appear in custom field header as defined. 

10. Click in the Length data field to edit the field's maximum number of characters displayed in 
the Browser View when using the current style to view the data. 

11. If you want to display in the Browser View print preview or print out the sum or average value 
of any numeric field, select its Sum and/or Avg. check box.  For non-numeric fields, the Sum 
and Avg. check boxes are disabled. 
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12. To set the sorting options, do one of the following: 
 Click any header ( Data Field header, Table Column Name, Length, View, Sum, or 

Avg.) to sort the fields that appear in the Style settings section in an ascending order 
(click again on the same header to sort the displayed fields in a descending order.) 

 Select the Default Sort check box when available to revert to the default sorting order 
(the way the fields are arranged in the database).  The Default Sort option is available 
only if you changed the sort order by clicking any header in the Style settings screen 
section. 

13. To set the width and sequence of the selected fields, do the following: 
a. Click Customize to open the Column Layout dialog box. 
b. To change the field sequence, drag the header of the field that you want to move to the left 

or to the right, then release the mouse button to drop the column in the new location. 
c. To resize the column width, point to the right or left edge of the column you want to resize 

so that the mouse pointer changes its shape to a double-headed arrow.  Drag the column 
edge either to the left or to the right until the column matches the required width. 

14. Click OK to close the Column Layout dialog box and save the changes that you made to the 
column layout field and the style settings. 

 Clicking OK in the Column Layout dialog box saves the new column layout field and the 
changes you made to the style settings in the Browser Manager.  Therefore, when you return 
to the Browser Manager the Save button automatically changes to Edit.  Clicking Cancel 
returns you to the Style settings to continue creating your view style. 

15. If changes have been made that have not been saved, the Save button will be visible, click 
Save to save your new style settings. 

 
 In the Style settings data window, red is used to symbolize a selected field.  Yellow is used to 

symbolize a read-only field which cannot be accessed in the browser for data editing.  You 
can set a different color for the read-only fields. 

 
 

Clear a View Setting 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, display the style settings you want to modify.  For more 

information, see Display the Current Style Setting (on page 592). 
4. Do one of the following: 

 If the Enable current view in SmartPlant Explorer and in the Find Documents to 
Publish is not enabled, proceed to the next step. 

 In the Style pane, if the Enable current view in SmartPlant Explorer and in the Find 
Documents to Publish is enabled do the following: 
i. In the Domain Explorer, select an appropriate folder. 
ii. Right-click, and from the shortcut menu select Show Browser. 
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iii. In the Show Browser dialog box, make sure the Browser View you want to delete is 
not displayed and click OK. 

iv. On the Style pane, click Edit. 
v. Clear the Enable current view in SmartPlant Explorer and in the Find 

Documents to Publish check box. 
vi. Click Save. 

5. Click Edit. 
6. Do one of the following: 

 Click . 
 Click Actions > Delete. 

 
 

Modify Style Settings 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager display the style settings you want to modify. 
4. On the lower Style pane, click Edit. 
5. In the Name field, type the new style name (defaults to Style followed by a number). 
6. Do one of the following to select the fields to be displayed in the browser view: 

 Select the appropriate View check boxes, by scrolling down the Style settings data 
window and selecting the required fields individually.   Note that the primary value field is 
always selected, and a check mark appears in its View check box by default. 

 Select the All check box in the Select group box, to select all the available fields. 
 Select the Custom check box in the Select group box to select all the custom fields. 
 Select the Non-custom check box in the Select group box to select all the fields that are 

not custom fields. 
7. Click the Data Field Header box to customize the header name. 

 
 Data Field Headers that you customize appear in the browser view column headers 

when using the current style to view the data.  You can customize any Data Field 
Header. 

 In addition to the database fields provided to you by default, the Browser Manager also 
provides you with custom fields, which you can use to complement data attributes.  A 
user with Domain Administrator rights can make default custom field definitions in the 
Administration module. 

 It is not possible to display an apostrophe in a custom field header.  If your definition 
includes an apostrophe character, this character changes in the header to a double quote 
character ".  If your definition includes a double quite character, it changes in the header 
to a tilde character ~.  Other special characters appear in custom field header as defined. 

8. Click in the Length data field to edit the field's maximum number of characters displayed in 
the Browser View when using the current style to view the data. 
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9. If you want to display in the Browser View print preview or print out the sum or average value 
of any numeric field, select its Sum and/or Avg. check box.  For non-numeric fields, the Sum 
and Avg. check boxes are disabled. 

10. To set the sorting options, do one of the following: 
 Click any header ( Data Field Header, Table Column Name, Length, View, Sum, or 

Avg.) to sort the fields that appear in the Style settings section in an ascending order 
(click again on the same header to sort the displayed fields in a descending order.) 

 Select the Default Sort check box when available to revert to the default sorting order 
(the way the fields are arranged in the database).  The Default Sort option is available 
only if you changed the sort order by clicking any header in the Style settings screen 
section. 

11. To set the width and sequence of the selected fields, do the following: 
a. Click Customize to open the Column Layout dialog box. 
b. To change the field sequence, drag the header of the field that you want to move to the left 

or to the right, then release the mouse button to drop the column in the new location. 
c. To resize the column width, point to the right or left edge of the column you want to resize 

so that the mouse pointer changes its shape to a double-headed arrow.  Drag the column 
edge either to the left or to the right until the column matches the required width. 

12. Click OK to close the Column Layout dialog box and save the changes that you made to the 
field layout and the style settings. 

 Clicking OK in the Column Layout dialog box saves the new field layout and the 
changes you made to the style settings in the Browser Manager .  Therefore, when you 
return to the Browser Manager the Save button automatically changes to Edit.  Clicking 
Cancel returns you to the Style settings to continue creating your view style. 

13. If changes have been made that have not been saved, the Save button will be visible, click 
Save to save your new style settings. 

 In the Style settings data window, red is used to symbolize a selected field.  Yellow is 
used to symbolize a read-only field which cannot be accessed in the browser for data 
editing.  You can set a different color for the read-only fields. 

 
 

Define the Structure of a Print Layout 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager display the style settings you want to modify. 
4. Click Edit. 
5. Click Layout to open the Define Print Layout dialog box. 
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6. Select a field from the Column Header pop-up window and drag it to the field where you want 
it to appear.  Your print layout can take the form of single fields in each column or multiple (no 
more than 5) fields in a column.  Remember that the fields that you do not select from the 
Column Header pop-up window will not show up in the printout even though they exist in the 
current browser.  Note, however, that if you decide to display two or more fields in a column, 
the printed out report will not display the Group Row Count, nor will it show the sum and/or 
average field values even if you have selected these options. 

7. Click Font to open the Customize Font Size dialog box, where you can customize the 
column and header font size as well as the column and header height. 

8. Set the font sizes as required using the spinners: 
a. Use the Column Font Size spinner to define the font size. 
b. Use the Column Height spinner to define the column height.  Note that if you do not 

define the column height before generating the layout, the Define Print Layout dialog box 
does not display any data. 

c. Use the Header Font Size spinner to define the header font size. 
d. Use the Header Height spinner to define header height size. 

9. Click OK to accept your settings and return to the Define Print Layout dialog box. 
10. Click Generate to open the Generate Print Layout dialog box where you customize the 

column sequence and size. 
11. Set the layout structure as follows: 

a. Set the column sequence by dragging the column header to the required position. 
b. Set the column size by dragging the edge of the column either to left or to the right. 
c. Click OK to accept the settings and return to the Define Print Layout dialog box. 

12. Click Save to save all the settings and close to the Define Print Layout dialog box. 
 
 

Clear a Print Layout Structure 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, display the style settings you want to modify.  For more 

information, see Display the Current Style Setting (on page 592). 
4. Click Edit. 
5. Click Print Layout. 
6. In the Print Layout dialog box, click Clear. 
7. Click Save. 
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Duplicate a View Style 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, display the style settings you want to modify.  For more 

information, see Display the Current Style Setting (on page 592). 
4. Select the style that you want to duplicate. 
5. Do one of the following: 

 Click . 
 Click Actions > Copy. 
 Right-click the highlighted style in the Browser groups data window and then, on the 

shortcut menu, click Copy. 
6. Navigate to the target style whose settings you want to replace with ones you copied. 
7. Highlight the selected target style. 

 If you close the Browser Manager at this stage, you cannot paste the duplicated 
style settings. 

8. Do one of the following: 

 Click . 
 Click Actions > Paste. 
 Right-click and on the shortcut menu, click Copy. 
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Print the Style Setting Data 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Click Print to open the Print Preview window. 
4. In the Show Fields group box, do one of the following: 

 Select All to display and print out all the data for all the fields appearing in the Style 
settings screen section. 

 Select Selected to display and print out the data for only those fields that you selected to 
be viewed. 

5. Perform any of the following actions as required: 
 Click Zoom to select your preview magnification level. 
 Click Save As to save the data as an external file. 
 Click Print to start printing. 
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S E C T I O N  4 2  

Browser View Sort Settings 
A browser view sorting sequence determines the sequence in which the selected rows are 
displayed in the Browser View window.  In addition to defining a sorting sequence for the 
Browser View window, you also determine whether the displayed rows will be sorted in an 
ascending or descending order.  Note that you will also be able to sort the selected fields in the 
Browser View window that will override your sort sequence settings.  You can perform the 
following activities: 
 Create and modify a view sorting sequence. 
 Duplicate a view sorting sequence. 
 Clear the existing view sorting sequence settings. 

 
 

Sort Settings Common Tasks 
The following tasks are used frequently when you define the sorting sequence for your browser 
view.  

Display the Current Sorting Sequence 
This option shows you how to display the current sorting sequence for an existing browser view 
that you select from the Browser Groups list in the Browser Manager.  Note that if you have not 
yet defined a view profile for a selected browser, no sorting sequence will be available.  For more 
information, see Display the Current Sorting Sequence (on page 602). 

Create a Sorting Sequence View 
This option shows you how to create a new sorting sequence for a selected browser view.  For 
more information, see Create a Sorting Sequence View (on page 602). 

Modify a Sorting Sequence View 
This option shows you how to modify an existing view sorting sequence.  For more information, 
see Modify a Sorting Sequence View (on page 603). 

Duplicate a Sorting Sequence View 
This procedure shows you how to copy an existing sorting sequence to another existing browser 
view.  This action overwrites the target sorting sequence with the duplicated style settings.  For 
more information, see Duplicate a Sorting Sequence View (see "Modify a Sorting Sequence View" 
on page 603). 

Clear a Sorting Sequence Setting 
This option shows you how to remove an existing sorting sequence.  For more information, see 
Clear a Sorting Sequence Setting (on page 605). 
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Display the Current Sorting Sequence 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, expand the required browser group, to navigate to the browser view 

in the Browser groups data pane.  For more information on how the browsers are organized, 
see Browser Manager Hierarchy (on page 563). 

4. Expand the required browser view in the Browser groups data pane and do one of the 
following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
 The fields currently selected for the sorting sequence are listed in the right data pane 

(with the caption Sort field list) and the current sorting sequence of the selected view is 
displayed in the lower data pane.  You can now modify the sorting sequence as needed. 

 
 

Create a Sorting Sequence View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, add a new view profile or edit an existing one.  For more details, 

see Define a View Profile (on page 565). 
4. Expand the required browser view in the Browser groups data pane and do one of the 

following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
5. Click Edit. 
6. In the Name box, type the required sorting sequence name (defaults to Sort followed by a 

number). 
7. Under Data Field Header, from the list of database fields, select a sort field according to 

which you want the data to be sorted in the browser view. 

 
 For any browser view that supports sorting data by tag numbers, you can sort tag 

numbers according to the numeric segment.  From the Data Field Header list, select Tag 
Trans Name, and define the sort sequence in the Start Char and Length fields. 
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 For any browser view that supports sorting data by loop numbers, you can sort loop 
numbers according to the numeric segment.  From the Data Field header list, select 
Loop Trans Name, and define the sort sequence in the Start Char and Length fields. 

8. In the Start Char. data field, type the starting position of the current segment, that is, the 
selected sorting field leftmost character. 

9. In the Length data field, type the total number of characters (from the starting character) the 
selected sorting field will contain. 

10. Under Order, clear the Ascending check boxes if you want the data to be sorted and 
displayed in the Browser in a descending order.  The default setting is Ascending. 

11. Click Insert to insert a sorting field before the one currently selected in the Sort settings group 
box. 

12. Click Delete to remove the currently selected field from the sorting sequence. 
13. To resize and re-sequence the fields currently displayed in the Sort settings group box, do 

the following: 
a. Drag and drop a field to a new position to change the field sequence. 
b. To change the width of a field, position the cursor on the border between two fields and 

then drag the order to the right or to the left. 
14. Click Save to save the new sorting sequence.  The Sort Field List data window displays the 

sorting sequence you have created. 
 
 

Modify a Sorting Sequence View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Expand the required browser view in the Browser groups data pane and do one of the 

following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
4. Click Edit. 
5. In the Name box, type the required sorting sequence name (defaults to Sort followed by a 

number). 
6. Under Data Field Header, from the list of database fields, select a sort field according to 

which you want the data to be sorted in the browser view. 
7. In the Start Char. data field, type the starting position of the current segment, that is, the 

selected sorting field leftmost character. 
8. In the Length data field, type the total number of characters (from the starting character) the 

selected sorting field will contain. 
9. Under Order, clear the Ascending check boxes if you want the data to be sorted and 

displayed in the Browser in a descending order.  The default setting is Ascending. 
10. Click Insert to insert a sorting field before the one currently selected in the Sort settings group 

box. 
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11. Click Delete to remove the currently selected field from the sorting sequence. 
12. To resize and re-sequence the fields currently displayed in the Sort settings group box, do 

the following: 
a. Drag and drop a field to a new position to change the field sequence. 
b. To change the width of a field, position the cursor on the border between two fields and 

then drag the order to the right or to the left. 
13. Click Save to save the modified sorting sequence.  The Sort Field List data window displays 

the sorting sequence you have created. 
 
 

Duplicate a Sorting Sequence View 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Expand the Browser groups tree to display the sort sequence you want to duplicate. 
4. Highlight the sorting sequence, and do one of the following: 

 Click . 
 Click Actions > Copy. 

5. Navigate to the target sorting sequence whose setting you want to replace with the copied 
settings. 

6. Highlight the sorting sequence, and do one of the following: 

 Click . 
 Click Actions > Paste. 
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Clear a Sorting Sequence Setting 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Expand the required browser view in the Browser groups data pane and do one of the 

following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
4. Click Edit. 
5. Do one of the following: 

 Click . 
 Click Actions > Delete. 
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Browser View Filter Settings 
These settings allow you to define a filtering condition which will be used to filter the data 
associated with the selected browser view. 
A filter consists of: 
 Field name 
 Operator or function 
 Value 
 Logical expressions: And –or– Or (for complex filter conditions) 

 A complex filter condition may take longer to retrieve your data.  For this reason, 
performing an OR operation is more time-consuming than performing an AND operation. 

 The filter conditions that you apply determine the scope of data that is published from 
browsers. 
The following table lists the built-in operators and functions available to you when defining the filter 
settings: 

Operator/Function Description Example 

= Equal to Manufacturer = "Shell" 

> Greater than Tag Number > 101 

< Less than Process Function Name < 'P' 

>= Greater or equal to Velocity >= 10 

<= Less than or equal to Low Alarm <= 30 

<> Not equal to Loop Suffix<> 100 

BETWEEN Select an alphanumeric value that is 
between the stated expression. 

Price between 150 and 250 

LIKE (value) Select a similar value that is similar 
to the one in the '[value]'field. 
You can use the following wildcard 
characters: 
% – any combination of characters.
_ – any single character. 

Tag Number LIKE '%AA%' 
Process Function Name LIKE P__ 

IS NULL Contains an undefined value Service IS NULL 

IS NOT NULL Not equal to NULL Loop Number IS NOT NULL 

AND Include the following expression in 
the filter combination. 

  

OR Accept either the previous or the 
following expression in the filter 
expression. 
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View Filter Settings Common Tasks 
The following tasks are used frequently when working with filter settings in a browser view.  

Display the Current View Filter Condition 
You use this option to display the current filter condition of browser view that you select from the 
Browser groups list in the Browser Manager.  If you have not yet defined a filter condition for a 
selected browser, no filter settings will be available.  For more information, see Display the 
Current View Filter Condition (on page 608). 

Define a View Filter 
This procedure shows you how to define a new filter condition for a selected browser view.  For 
more information, see Define a View Filter (on page 609). 

Modify a View Filter 
This option shows you how to modify an existing filter condition for a selected browser view.  For 
more information, see Modify a View Filter (on page 610). 

Duplicate a View Filter 
This option enables you to copy an existing filter condition to another existing browser view.  This 
action overwrites the target filter condition with the duplicated filter condition.  For more 
information, see Duplicate a View Filter (on page 611). 

Clear View Filter Settings 
This option shows you how to clear the filter condition for a selected browser view.  For more 
information, see Clear View Filter Settings (on page 611). 
 
 

Display the Current View Filter Condition 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser groups data 

pane.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Expand the required browser view in the Browser groups data pane and do one of the 
following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
 The filter condition you define is displayed in the Filter field list in the right data pane. 
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Define a View Filter 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser Manager, highlight the required browser in the Browser groups data 

pane.  For more information on how the browsers are organized, see Browser Manager 
Hierarchy (on page 563). 

4. Expand the required browser view in the Browser groups data pane and do one of the 
following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
5. Click Edit. 
6. In the Name data field, type the required filter condition name. 
7. Click the Data Field Header and select an appropriate item header according to which you 

want to filter the data in the Browser View window, for example, Tag Number. 
 The Data Field Header list contains all the field headers used for the data that the 

current browser is associated with. 
8. Click Operator and select a suitable operator to determine how the tag number attribute 

selected from the Column Name list will relate to the expression in the Value field.  For more 
information on filter operators, see View Filter Settings. 

9. In the Value data field, select or type a suitable value to determine how the tag number 
attribute selected from the Column Name list are specified. 

10. Depending on whether you want to add another filtering condition, in the Logical data field, do 
one of the following: 
 Leave the field empty if the condition is the last one in the list. 
 Click the field and select either And or Or as the logical function from the list if the 

condition is to be followed by another one.  Select And to include the following 
expression in the filter condition.  Select Or to accept either the previous or the following 
expression in the filter condition. 

11. Click Verify to verify the current filtering condition. 
12. Perform any of the following actions as required: 

 Click Insert to append new a data line. 
 Click Delete to delete the currently selected data line. 
 Click Save to save the new filter settings. 

 The Filter field list data pane displays the filter condition you have just defined. 
 The filter conditions that you apply determine the scope of data that is published from 

browsers. 
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Modify a View Filter 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Expand the browser view you want to modify in the Browser groups data pane and do one of 

the following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
4. Click Edit. 
5. In the Name data field, type the required filter condition name (defaults to Filter followed by a 

number). 
6. Click the Data Field Header and select the field from the list. 

 The Data Field Header list contains all the fields that are used for the data that the 
current browser is associated with. 

7. Click the Operator data field and select the required operator from the list. 
8. In the Value data field, select or type a suitable value. 
9. Depending on whether you want to add another filtering condition, in the Logical data field, do 

one of the following: 
 Leave the field empty if the condition is the last one in the list. 
 Click the field and select either And or Or as the logical function from the list if the 

condition is to be followed by another one. 
10. Click Verify to verify the current filtering condition. 
11. Perform any of the following actions as required: 

 Click Insert to append new a data line. 
 Click Delete to delete the currently selected data line. 
 Click Save to save the new filter settings. 

 The Filter field list data pane displays the filter condition you have just defined. 
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Duplicate a View Filter 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. Expand the browser view you want to duplicate in the Browser groups data pane and do one 

of the following: 

 Click . 
 Click Actions > Copy. 

4. Navigate to the target filter condition that you want to replace with the one you copied. 
5. Highlight the selected filter condition, and do one of the following: 

 Click . 
 Click Actions > Paste. 

 
 

Clear View Filter Settings 
1. Start the Browser Manager by doing one of the following: 

 Click File > Browser Manager. 

 Click . 
2. If the Browser View is open, then open the Browser Manager by doing one of the following: 

 Click Actions > Manager. 

 Click . 
3. In the Browser groups pane, expand the browser view you want to clear the view filter 

settings from, and do one of the following: 

 In the Browser groups data pane, click . 

 In the upper-right data pane, double-click . 
4. Do one of the following: 

 Click . 
 Click Actions > Delete. 
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Using InfoMaker, you can define SmartPlant Instrumentation database profiles and customize 
various SmartPlant Instrumentation reports, title blocks, and specification or calibration form 
pages saved as .psr files.  Customization includes emphasizing particular fields or data, inserting 
graphic objects, assigning field background colors, defining expressions for regular and computed 
fields, and so forth.  For complete information on InfoMaker options, see the InfoMaker 
documentation. 

 
 You must have working knowledge of the SmartPlant Instrumentation database table structure 

to be able to customize reports, specification or calibration form pages.  For further 
information, refer to the SmartPlant Instrumentation Data Dictionary, which is available upon 
request. 

 SmartPlant Instrumentation 2009 is only compatible with InfoMaker 11 Service Pack 2.  The 
latest InfoMaker Service Pack is available from the Sybase Web site (accessible via the 
InfoMaker Help menu). 

 

SmartPlant Instrumentation Database Structure 
The following discussion is a very broad explanation of the internal structure of the SmartPlant 
Instrumentation database.  It is not meant to be a database primer, but rather an aid for the user 
to have a better understanding of what tables to select when customizing a report in InfoMaker. 
Two of the important features of the SmartPlant Instrumentation database are its hierarchical and 
relational structure. 

Hierarchical Structure of the Database 
The SmartPlant Instrumentation database consists of a hierarchy, where each level of the 
hierarchy contains tables that are specific to that level.  The highest level of the hierarchy is the 
Admin schema.  On the next level of the hierarchy, there is a Domain schema for each domain 
you initialize in the database.  Schemas include tables.  Tables include table columns, which are 
represented in the interface as data fields. 
Within each domain, there are plant hierarchy levels.  By default, each domain has three default 
levels as follows: <plant>, <area>, and <unit>.  The following table shows most common types of 
data you can define at each level of the hierarchy: 

Level Table Data Included Notes 

Admin schema Users, user groups, naming conventions, 
access rights 

 

Domain schema instrument types and other supporting 
tables, spec forms, reference wiring data

 

<Plant> Wiring data, custom fields  

<Area> None Used as a container only 

<Unit> Loops, instruments The software checks 
uniqueness at the <unit> 
level 
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There is a connection between the data settings at each level of the plant hierarchy, for example, 
an instrument tag includes data from various tables at the following levels: 
 COMPONENT table (contains instruments) at the <unit> level 
 Supporting tables at the domain level 
 PD_GENERAL table (contains process functions, such as pressure, flow, temperature, and so 

forth) at the <unit> level 
 SPEC_SHEET_DATA table (contains specification data) at the <unit> level 

 The schema name always appears prefixed to the table name separated by a period ( 
.).  For example, if your Domain schema logon name is DEMO, and in InfoMaker you select 
CABLE as your table name, the table name in InfoMaker appears are DEMO.CABLE.  For details 
of database schemas and their descriptions, see Internal Setup Utility Online Help, Database 
Structure and Schemas. 

Relational Structure of the Database 
The relational structure of the database is concerned with the associations defined between 
tables and columns.  For example, if you want to create a customized cable report that includes 
only the cable description, color, manufacturer, and model, you need to know that these are 
columns that are associated with their respective tables.  The following is a summary for this 
example, taken from the SmartPlant Instrumentation Data Dictionary. 

Full Table Name Table Description Table Column Name Display Name 

DEMO.CABLE Information stored about 
the existence of a cable 

cable_desc Cable Description 

DEMO.CABLE_COLOR The list of colors 
available for all cables 

cable_color_name Cable Color 

DEMO.CABLE_MFR The data structure for a 
list of cable 
manufacturers 

cable_mfr_name Cable 
Manufacturer 

DEMO.CABLE_MFR_MO
D 

The model of the cable cable_mod_name Cable Model 

 The SmartPlant Instrumentation Data Dictionary, which is available upon request, contains 
complete information about tables and columns. 

See Also 
Working with Libraries and Reports Common Tasks (see "Working with Libraries and Reports" on 
page Drop-Down Data Windows that Retrieve Units of Measure (on page 623) 
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Create a SmartPlant Instrumentation Database Profile 
Use this procedure to create a database profile in InfoMaker so that you automatically connect to 
your database when opening InfoMaker.  InfoMaker automatically creates database profiles for 
various types of data.  However, you may find that your parameter settings do not point to the 
SmartPlant Instrumentation data source.  In such cases, you need to enter the proper profile 
settings to connect to the SmartPlant Instrumentation database. 

1. With the main InfoMaker window open, click . 
2. On the Database Profiles dialog box, select ODB ODBC. 
3. Click New. 
4. In the Database Profile Setup dialog box, on the Connection tab, do the following: 

a. In the Profile Name box, type the profile name. 
b. From the Data source box, select the SmartPlant Instrumentation database you want to 

connect to. 
c. In the User ID box, type the target schema logon name. 
d. In the Password box, type the target schema logon password. 

 
 If you want to connect to the Admin schema of the demo database in Sybase Adaptive 

Server Anywhere, the default value for both the User ID and Password properties is 
IN_DBAMN. 

 If you want to connect to the Domain schema of the demo database, the default value for 
both the User ID and Password properties is demo. 

5. When finished, click OK to reopen the Database Profiles dialog box, where the current 
SmartPlant Instrumentation database profile is selected by default. 

6. Select the database profile and click Connect to make the connection with the profile. 
 

Display SmartPlant Instrumentation Data 
Automatically 

Use this procedure to display all rows or a particular SmartPlant Instrumentation database table. 
1. After connecting to the SmartPlant Instrumentation database, on the main InfoMaker window 

menu bar, click Tools > Database Painter. 
2. In the tree view, double-click the appropriate SmartPlant Instrumentation database profile. 
3. Double-click the Tables folder to display all the tables that exist in SmartPlant 

Instrumentation. 
 If the Domain schema name precedes most of the table names, you are connected to the 

Admin schema. 
4. To display all rows of a particular table, right-click a table, and then, on the shortcut menu, 

click Edit Data > Grid. 
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Display SmartPlant Instrumentation Data by Executing 
an SQL Statement 

Use this procedure to display selected rows or a particular SmartPlant Instrumentation database 
table by executing an SQL statement. 
1. After connecting to the SmartPlant Instrumentation database, on the main InfoMaker window 

menu bar, click Tools > Database Painter. 
2. In the tree view, double-click the appropriate SmartPlant Instrumentation database profile. 
3. To display selected rows of a particular table, in the ISQL Session pane (bottom right pane by 

default), click the ISQL Session tab. 
4. Type a Select statement. 

 If you are connected to the Admin schema of SmartPlant Instrumentation and want to 
select rows from a Domain schema table, you must include the Domain schema name in the 
SQL statement using the following syntax <Domain schema name>.<SQL Statement>; 

5. After typing the SQL statement, do one of the following: 
 Select the statement and press Ctrl+L. 
 Right-click the statement, and then, on the shortcut menu, click Execute. 

 

Define InfoMaker As the Default Report Generator 
After you complete the installation of InfoMaker, you can define InfoMaker as your default report 
generator.  After that, you can open InfoMaker from SmartPlant Instrumentation. 
1. In SmartPlant Instrumentation, on the menu bar, click File > Preferences. 
2. On the Preferences dialog box, in the left pane, click Report Generator. 
3. From the Report generator list, select InfoMaker. 
4. Beside the Report generator program path box, click Browse to navigate to the location of 

the InfoMaker executable file on your computer, and click OK. 
 

Working with Libraries and Reports 
The following tasks deal with creating new libraries in InfoMaker and opening SmartPlant 
Instrumentation reports saved as .psr files.  You might need to create a new library to manage 
reports or save queries.  Also, you can create new browsers for adding in the Browser module of 
SmartPlant Instrumentation. 
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Create an InfoMaker Library 
Use this procedure to create an InfoMaker library for SmartPlant Instrumentation reports.  Also, 
before building a query, you need to create a backup library.  The software automatically puts all 
queries that you save into this library. 

1. With the main InfoMaker window open, click . 
2. On the New dialog box, click the Library tab. 

3. Double-click the Library icon . 
4. On the Specify New Library dialog box, type the desired path and name of the library, which 

must be a .pbl, or click the ellipsis  beside the Library box to navigate to the .pbl file. 
5. Click Finish. 
 

Create an InfoMaker Library and Report for Editing PSR Files 
Use this procedure to create an InfoMaker library and report.  Then, in SmartPlant 
Instrumentation, you can open the report from within the InfoMaker library. 

 Before performing this procedure, make sure that InfoMaker is defined as your default 
report generator.  For details, see Define InfoMaker As the Default Report Generator (on 
page 615). 
1. From any SmartPlant Instrumentation window, click File > Generate Reports to open 

InfoMaker. 
2. In InfoMaker, create a new library.  For details, see Create an InfoMaker Library (on 

page 616). 
3. Define a report as follows: 

a. Click File > New. 
b. On the New dialog box, on the Object tab, select Freeform and click OK. 
c. In the Freeform Report Generator dialog box, select External and click Next. 
d. On the Define Result Set dialog box, in the Name box, type a name for the result 

description, and click Next.  The name cannot contain spaces. 
e. On the Select Color and Border Settings dialog box, click Next. 
f. On the Ready to Create Freeform dialog box, click Finish. 
g. If the Database Profiles dialog box opens, follow the procedure Create a SmartPlant 

Instrumentation Database Profile (on page 614). 
4. In the Report window, do the following to save the report that you just defined: 

a. Click File > Save. 
b. On the Save Report dialog box, under Reports, type a name for the report. 
c. Make sure that under Libraries the correct library is selected and then click OK. 

 To organize your display of .psr files in InfoMaker, create various reports within various 
libraries. 

5. In the Report window, click File > Open File. 
6. On the Select a File Name dialog box, navigate to the .psr file that you want to open, and click 

Open. 
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Open a PSR File from an InfoMaker Library and Report 
Use this procedure to open an existing .psr file with SmartPlant Instrumentation data from the 
pre-defined InfoMaker library and report.  SmartPlant Instrumentation reports can be saved as 
external .psr files, edited in InfoMaker, and then opened in SmartPlant Instrumentation from within 
an InfoMaker library and report. 

 Before performing this procedure, make sure that InfoMaker is defined as your default 
report generator.  For details, see Define InfoMaker As the Default Report Generator (on 
page 615). 
1. From any SmartPlant Instrumentation window, on the menu bar, click File > Generate 

Reports to open InfoMaker. 
2. In InfoMaker, on the menu bar, click File > Open. 
3. On the Open dialog box, do the following: 

a. Under Library, select the appropriate library. 
b. Under Object Type, select Reports. 
c. Under Object, select the desired report from the list. 
d. Click OK. 

4. Click File > Open File. 
5. On the Select a File Name dialog box, navigate to the .psr file that you want to open, and click 

Open. 
 

Build a Query 
This procedure describes how to build a query, which is necessary for exporting SmartPlant 
Instrumentation data to an external file that you can use to generate an InfoMaker report.  The 
customized report created in this procedure is limited to only one data source and presentation 
style with no other adornments.  This example uses information from the Instrument Index 
module to generate a report for the description of a set of instruments, including their service and 
function type. 

1. With the main InfoMaker window open, click . 
2. On the New dialog box, click the Database tab. 

3. Double-click Query  to open the Select Tables dialog box. 
4. Select the desired tables. 
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5. When finished, click Open to display the Query window. 
6. Click View > Table Layout. 
7. Select the desired columns as shown in the following example. 

 
8. Click  to view the available data as shown. 

 
9. Click the close box to close the Preview window and return to the Query window. 

10. If you want to select additional tables, click  to reopen the Select Tables dialog box. 
11. Perform additional steps as needed.  These can include the following: 

 Using the Join function to rebuild links manually between table rows. 
 Defining a sort sequence for the retrieved data. 
 Using a Where condition to filter the retrieved data. 

 Full details of these procedures are beyond the scope of this topic.  For further 
information, see to the InfoMaker documentation. 
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12. To view details of your query, click the Syntax tab.  The following screen shot shows an 
example of a query. 

 
13. When finished, save your query by doing one of the following: 

 Click . 
 Click File > Save Query. 

14. On the Save Query dialog box, in the Queries box, type a name for your query. 

 
 Your query name must not include any spaces. 
 The software saves the query in the backup library that you defined. 

See Also 
Create an InfoMaker Library (on page 616) 
 

Calibration Form Customization 
Customization of calibration form pages requires extensive knowledge of InfoMaker.  The Page 
Editor options of the Specifications module are insufficient to customize a calibration page 
properly.  Therefore, a number of template .psr files come shipped with SmartPlant 
Instrumentation.  These .psr files are designed according to pre-defined calibration types.  You 
can customize these files in InfoMaker as needed and then import them into the Specifications 
module as form pages. 

 It is recommended that you back up the shipped files before customizing. 
When customizing forms, you can do the following: 
 Design the layout of data fields on the form 
 Specify conditions under which data fields on the form are editable, visible, or protected 
 Determine the scope of data values to be used — depending on the form type, these values 

may include instrument data, settings, or calibration data entry values 
 Add expressions used to calculate results and errors 
 Specify conditions for dynamic highlighting and background colors for data fields based on 

particular values of results (for example, depending on whether actual values exceed a 
predefined tolerance limit) 

 Design the correct print layout — this is required because a calibration form, whether shipped 
or user-defined, can only comprise a single data page 

In SmartPlant Instrumentation, expression validation is done directly in the form page in the 
Calibration module.  The standard forms already have all possible expression types, which you 
can use as examples to create your own expressions in InfoMaker.  You must restore these forms 
in the Specifications module and then regenerate the form pages to be able to use them for 
calibration. 
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The standard calibration settings page includes columns from the COMPONENT and 
CALIBRATION_SETTING tables.  The standard calibration data entry page includes columns 
from the COMPONENT, CALIBRATION_RESULT, and CALIBRATION_RESULT_POINTS 
tables.  It is not possible to add columns from other tables in calibration pages. 

 
 

Form Page Customization Procedures 
These procedures deal with customizing spec form or calibration form pages in InfoMaker.  You 
can customize any specification form page in InfoMaker after saving this page as a .psr file in the 
Specifications module.  A number of .psr files containing calibration form pages already come 
shipped with SmartPlant Instrumentation.  After customizing a .psr file, you must retrieve the .psr 
file as a form page back into the Specifications module, where such page is indicated as a custom 
page. 

General Procedures for All Form Page Types 
Open a Form Page in InfoMaker 
Use this procedure to open a form page in InfoMaker.  For details, see Open a Form Page in 
InfoMaker (on page 622). 

Add a Unit of Measure Drop-Down Data Window in a PSR File 
Use this procedure to assign a unit of measure drop-down data window to a custom field of a form 
page saved as a .psr file.  You can use this procedure as a starting point for assigning any 
drop-down data window to a data field.  All the drop-down data windows appear in the shipped 
library file sp_style.pbl, which resides in your SmartPlant Instrumentation home folder.  This 
procedure applies to specifications and calibration forms: 
 After you open a spec page .psr file in SmartPlant Instrumentation, save it as a new page and 

associate it with a spec form, all specifications based on this form are generated with the 
drop-down data window that you added. 

 After you open a calibration page .psr file in SmartPlant Instrumentation, save it as a new page 
and associate it with a Calibration Settings or Calibration Data Entry form, the form that you 
open in the Calibration module contains the drop-down data window that you added. 

For details, see Add a Unit of Measure Drop-Down Data Window in a PSR File (on page 622). 

Add a Select List in a PSR File 
Use this procedure to create a select list and assign it to a custom field of a from page saved as a 
.psr file.  This procedure applies to specifications and calibration forms: 
 After you open a spec page .psr file in SmartPlant Instrumentation, save it as a new page and 

associate it with a spec form, all specifications based of this form are generated with the select 
list that you added. 

 After you open a calibration page .psr file in SmartPlant Instrumentation, save it as a new page 
and associate it with a Calibration Settings or Calibration Data Entry form, the form that you 
open in the Calibration module contains the select list that you added. 

For details, see Add a Select List in a PSR File (on page 623). 
 If you are changing a page that is used as part of a composite spec, and are planning 

to import it into SmartPlant Instrumentation, over-writing the existing page, be sure to maintain 
page dimensions. If you modify page coordinates, verify that the composite spec(s) using this 
page are not compromised. 
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Procedures for Calibration Form Pages 
Add a Single-Use Column in a Calibration Form Page 
Use this procedure to add a single-use column in a form page.  A single-use column is 
represented in the form page by a single data field, for example, Calibration date ( calib_date 
field).  For details, see Add a Single-Use Column in a Calibration Form Page (on page 624). 

Add a Multi-Use Column in a Calibration Form Page 
Use this procedure to add a multi-use column in a form page.  A multi-use column is represented 
in the form page by multiple data fields.  For example, in a tank strapping calibration, you might 
need to obtain and record several result points within a certain period of time.  These result points 
are represented in the database by the same table column.  In the form page, each result point 
data field contains the column name and unique suffix.  For details, see Add a Multi-Use Column 
in a Calibration Form Page (on page 624). 

Add an Expression for Field Protection 
Use this procedure to set the background of a field as protected or editable, depending on the field 
value and calibration type.  For details, see Add an Expression for Field Protection (on page 625). 

Add an Expression for Background Color of Protected or Editable Field 
Use this procedure to specify the Windows Background color value in the expression when the 
field is editable and the Button Face value when the field is protected, depending on the field value 
and calibration type.  For details, see Add an Expression for Background Color of Protected or 
Editable Field (on page 627). 

Add an Expression for Background Color of Result Field 
Use this procedure to set the software to display a colored background when the result field value 
exceeds the specified limit, for example, if the As Found field value exceeds the allowed 
tolerance.  A result field is a field that shows a calculated value based on a calibration 
formula.  For details, see Add an Expression for Background Color of Result Field (on page 628). 

Add an Expression for Field Visibility 
Use this procedure to set a certain field as visible or invisible, depending on the field value.  For 
details, see Add an Expression for Field Visibility (on page 629). 

Enable the Use of Fractions of an Inch 
Use this procedure to display fractions of an inch (sixteenths) for tank strapping calibrations.  You 
must perform this procedure because PowerBuilder, which the programming code basis for the 
Calibration module, does not support the display of fractions in data fields.  You can enable the 
use of fractions of an inch either in a data field that is represented in the database by a specific 
table column or set the software to display fractions of an inch in a computed field you define in 
InfoMaker.  To display fractions of an inch in a computed filed, you must assign an appropriate 
expression to the computed field.  For details, see Enable the Use of Fractions of an Inch (on 
page 630). 

Define a Computed Field for Calibration 
Use this procedure to define a computed field and specify a compute expression.  For details, see 
Define a Computed Field for Calibration. 
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Open a Form Page in InfoMaker 
 When opening a calibration form shipped in .psr format, start the procedure with Step 5. 

1. Open a form page in the Page Editor of the Specifications module.  For details, see Open a 
Page (on page 203). 

2. Do one of the following: 
 On the Page Editor menu bar, click Actions > Save as File. 

 On the Page Editor toolbar, click . 
3. On the Save As dialog box, navigate to the required folder and type the file name of the target 

.psr file. 
4. Click OK to save the file. 
5. In InfoMaker, connect to the target Domain schema of SmartPlant Instrumentation. 
6. In InfoMaker, on the menu bar, click File > New. 
7. On the New dialog box, on the Object tab, select Grid. 
8. In the Grid Report Generator wizard, select SQL Select and click Next. 
9. On the Select Tables dialog box, select any table and click Open. 
10. Under Selection list, click any table column. 
11. On the menu bar, click File > Return to DataWindow Painter. 
12. In the Grid Report Generator wizard, click Next and then Finish. 
13. On the menu bar, click File > Open File. 
14. When prompted to save changes to (Untitled), click No. 
15. On the Select a File Name dialog box, select the .psr file and click Open. 
 

Add a Unit of Measure Drop-Down Data Window in a PSR File 
1. In InfoMaker, to define the sp_style.pbl library as your working library, do the following: 

a. Click Tools > Library Painter. 
b. Right-click sp_style.pbl and then, on the shortcut menu, click Set as working library. 

 The sp_style.pbl file is a shipped library containing all drop-down data windows of 
SmartPlant Instrumentation.  The file resides in your SmartPlant Instrumentation home 
folder. 

2. Open the target form page that you saved as a .psr file.  For details, see Open a Form Page in 
InfoMaker (on page 622). 

3. In the Report window, right-click the target table column that is used as a custom field in the 
spec page, and then, click Properties. 

4. In the Properties window, click the Edit tab, and then, do the following: 
a. From the Style Type list, select DropDownDW. 
b. Select Always Show Arrow to display in the spec page an arrow box inside the field to 

indicate that this field is assigned to a drop- down data window or select list. 
c. Select V ScrollBar to display a vertical scroll bar when the drop-down data window 

contains a long list values. 

d. Beside the DataWindow box, click . 



 PSR File Customization Using InfoMaker 
 

 

SmartPlant Instrumentation Basic Engineering User's Guide 623 
 

e. On the Select Report dialog box, select a unit of measure drop-down data window you 
want to assign to the field.  For details about the available drop-down data windows that 
retrieve units of measure, see Drop-Down Data Windows that Retrieve Units of Measure 
(on page 623). 

f. From the Display Column list, select uom_code. 
g. From the Data Column list, select uom_code. 

5. Save the .psr file. 
6. Test your drop-down data window assignment in SmartPlant Instrumentation, open the .psr 

file in the Page Editor, save it as a new regenerated page, assign to a form, and generate a 
specification based on this form. 

 

Drop-Down Data Windows that Retrieve Units of Measure 
All drop-down data windows in SmartPlant Instrumentation reside in the sp_style.pbl file, which is 
located in the SmartPlant Instrumentation home folder.  The following table lists and describes all 
drop-down data windows containing SQL Select commands that retrieve units of measure from 
the SmartPlant Instrumentation database. 

Drop-Down Data Window Description 

d_dddw_uom Retrieves all units of measure that 
exist in SmartPlant Instrumentation 

dw_uom_dn Retrieves density units of measure 

dw_uom_fl Retrieves flow units of measure 

dw_uom_ln Retrieves length units of measure 

dw_uom_pr Retrieves pressure units of measure 

dw_uom_tm Retrieves temperature units of 
measure 

dw_uom_vs Retrieves viscosity units of measure 
 
 

Add a Select List in a PSR File 
1. In InfoMaker, open the target form page that you saved as a .psr file.  For details, see Open a 

Form Page in InfoMaker (on page 622). 
2. In the Report window, right-click the table column (form page data field) to which you want to 

assign a drop-down data window, and then, click Properties. 
3. In the Properties window, click the Edit tab, and then, do the following: 

a. From the Style Type list, select DropDownListBox. 
b. Select Allow Editing if you want to be able to enter a text string instead of selecting a list 

value when defining specification data in SmartPlant Instrumentation.  This does not 
affect the values on the list box itself. 

c. Select Sorted to displays the values alpha-numerically in descending order (values 
starting with a numeric character will be displayed at the top of the select list). 

d. Select Always Show Arrow to display in the spec page an arrow box inside the field to 
indicate that this field is assigned to a select list or drop-down data window. 

e. Select V ScrollBar to display a vertical scroll bar when the select list is long. 
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f. Under Code Table, in the Display Value column, define unique values.  These values 
will appear in the select list in a generated spec. 

g. In the Data Value column, define unique values to associate with the display 
values.  These values will appear in the database as the table column values. 

 In the Limit box, decrease the displayed value if needed.  This is required to prevent 
value truncation in the generated specification.  Value truncation can occur if the data field 
width in the spec is smaller than the table column length in the database. 

4. Save the .psr file. 
5. Test your select list definition in SmartPlant Instrumentation by opening the .psr file in the 

Page Editor, saving it as a new regenerated page, assigning to a form, and generating a 
specification based on this form. 

 

Add a Single-Use Column in a Calibration Form Page 
1. In InfoMaker, open the target form page saved as a .psr file.  For details, see Open a Form 

Page in InfoMaker (on page 622). 
2. On the Report window, click Insert > Control > Column. 
3. In the Detail section of the Report window, click where you want to place the column. 
4. On the Select Column dialog box, which opens automatically, select the target column from 

the list. 
5. Depending on the calibration form type, do one of the following: 

 If the form type is Calibration Settings, click OK. 
 If the form type is Calibration Data Entry, in the Row in details box, enter a temporary 

numeric suffix and then click OK.  You cannot close the Select Column dialog box until 
you define a suffix. 

  If the form type is Calibration Data Entry, after placing the column in the form, 
you must manually remove the suffix from the column name on the General tab of the 
Properties section. 

 

Add a Multi-Use Column in a Calibration Form Page 
1. In InfoMaker, open the target calibration data entry form page saved as a .psr file.  For 

details, see Open a Form Page in InfoMaker (on page 622). 
2. In the Report window, click Insert > Control > Column. 
3. In the Detail section of the Report window, click where you want to place the column. 
4. On the Select Column dialog box, which opens automatically, do the following: 

a. Select the target column from the list. 
b. In the Row in details box, enter a unique numeric suffix without an underscore. 
c. Click OK. 
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Add an Expression for Field Protection 
This procedure allows you to set the background of a field as protected or editable, depending on 
the field value and calibration type.  For a specific example of such a field and expression, see IF 
Expression for Field Protection (on page 625). 

 
 Tab order value of 0 (zero) overrides field protection expression.  Field tab order is set in the 

Specifications module of SmartPlant Instrumentation.  0 (zero) tab order indicates that the 
field is non-editable.  For details, see Set the Tab Order of the Fields on a Page (on 
page 209). 

 The 0 (zero) tab order value is assigned automatically to every new table column you add in 
the form page in InfoMaker.  If you add new fields in InfoMaker and include these fields in an 
expression for field protection, after completing this procedure, and opening the form page in 
the Specifications module, you must switch to the default tab order.  For details, see Switch to 
the Default Tab Order (on page 209). 

1. Open the target form page saved as a .psr file in InfoMaker.  For details, see Open a Form 
Page in InfoMaker (on page 622). 

2. In the Report window, right-click the target table column, and click Properties. 

3. In the Properties window, on the General tab, beside the Protect box, click . 
4. On the Protect dialog box, do the following: 

a. In the Functions pane, click the if(b, t, f) function, in which b stands for a Boolean 
expression, t for true, and f for false. 

b. Substitute the b argument with the name of the table columns that you want to protect, 
operators, and values. 

c. Substitute the t, f arguments with the protection values, with 0 indicating that the field is 
editable and 1 that the field is protected. 

d. Close the Protect dialog box. 
 On the General tab, the Protect box now displays the expression and the expression 

icon changes to . 
5. If needed, define the field background display conditions.  For details, see Add an Expression 

for Field Background Color (see "Add an Expression for Background Color of Result Field" on 
page 628). 

6. Save the .psr file. 
 

IF Expression for Field Protection 

Syntax 
if( b, t, f ) 
in which b stands for a Boolean expression, t for true and f for false.  You substitute the t and f 
arguments with 0 and 1.  When true, the value of 0 indicates that the field is editable and 1 that the 
field is protected. 

Example 1 
In this example, the expression sets the measuring point field calib_set_single_pnt_level as 
editable in the Tag Calibration Settings window and non-editable (protected) in the Calibration 
Profile Settings window.  The expression does not apply to the Function Check or Switch Set 
Point calibration types. 
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if(calib_set_no_pnt=1 and cmpnt_id<>0 and calib_type_id<>2 and calib_type_id<>3,0,1) 
The following table describes each expression segment individually. 

Expression Segment Description 

calib_set_no_pnt=1 The Number of points field value on the Calibration Settings form is 
defined as 1. 

cmpnt_id<>0 Instrument tag number exists (tag number ID is other than 0). 

calib_type_id<>2 and 
calib_type_id<>3 

Calibration type is not Function Check or Switch Set Point. 

0,1 editable, protected 

 
 The cmpnt_id value determines whether the software opens the Calibration Profile Settings 

window or the Tag Calibration Settings window in the Calibration module.  To open profile 
settings, the software runs an SQL command which includes the following parameter: 
cmpnt_id=0; whereas, to open calibration settings for an instrument, the software runs an SQL 
command which includes the cmpnt_id value of that instrument. 

 For details of calibration type ID numbers, see Calibration Type ID Numbers (on page 627). 

Example 2 
In this example, the expression sets the measuring point field calib_set_single_pnt_level as 
editable in the Calibration Data Entry window and non-editable (protected) in the Calibration 
History window.  The expression does not apply to the Function Check or Switch Set Point 
calibration types. 

if(calib_no_pnt=1 and (isnull(calib_hist_flg) or calib_hist_flg='0') and calib_type_id<>2 and 
calib_type_id<>3,0,1) 

The following table describes each expression segment individually. 

Expression Segment Description 

calib_no_pnt=1 The Number of points field value on the Calibration Data Entry form is 
defined as 1. 

isnull(calib_hist_flg) or 
calib_hist_flg='0' 

The calib_hist_flg value is NULL or 0. 

calib_type_id<>2 and 
calib_type_id<>3 

Calibration type is not Function Check or Switch Set Point 

0,1 editable, protected 
 The calib_hist_flg value determines whether the software opens the Calibration Data 

Entry or Calibration History window.  If the value is '0' or NULL, the software opens the 
Calibration Data Entry window; whereas, if the value is '1', the software opens the Calibration 
History window.  The calib_hist_flg value is character and not integer; therefore, in the 
expression, you must enclose the calib_hist_flg value in single quotes. 
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Calibration Type ID Numbers 
When defining expressions in InfoMaker, you can specify conditions for inclusion or exclusion 
certain calibration types that exist in SmartPlant Instrumentation.  The calibration types are fixed 
in the database.  The CALIB_TYPE_ID column holds the unique ID numbers of the calibration 
types. 

Calibration Type CALIB_TYPE_ID Column Value 

Multiple Point 1 

Function Check 2 

Switch Set Point 3 

Alarm/Trip/Set Point 4 

Fiscal Flow Meter Proving 5 

Tank Strapping 6 
 
 

Add an Expression for Background Color of Protected or 
Editable Field 

You use this procedure to specify the Windows Background color value in the expression when 
the field is editable and the Button Face value when the field is protected, depending on the field 
value and calibration type.  For examples of a field color expression, see IF Expression for Field 
Color (on page 628). 

Prerequisite 
 An expression for settings the appropriate background color always depends on the field 

protection expression.  Therefore, you must also define an expression for field 
protection.  For details, see Add an Expression for Field Protection (on page 625). 

1. Open the target form page saved as a .psr file in InfoMaker.  For details, see Open a Form 
Page in InfoMaker (on page 622). 

2. In the Report window, right-click the target table column, and click Properties. 
3. In the Properties window, click the Fonts tab. 

4. Beside the Background Color box, click . 
5. On the Background Color dialog box, do the following: 

a. In the Functions pane, click the if(b, t, f) function, in which b stands for a Boolean 
expression, t for true, and f for false. 

b. Substitute the b argument with the same Boolean expression you defined in the field 
protection expression on the General tab. 

c. Substitute the t, f arguments with the background color parameters as you require. 
d. Close the Background Color dialog box. 

 On the Font tab, the icon beside the Background Color box changes to .  You can 
ignore the color setting displayed in the box because an expression overrides the specific 
property value defined in the Properties window. 

6. Save the .psr file. 
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IF Expression for Field Color 

Example 1 
In this example, the expression sets the Windows Background color for the measuring point field if 
it is editable and Button Face color if the measuring point field is protected.  This expression is 
used together with the field protection expression.  The expression does not apply to the Function 
Check or Switch Set Point calibration types. 

if(calib_set_no_pnt=1 and cmpnt_id<>0 and calib_type_id<>2 and 
calib_type_id<>3,1073741824,67108864) 

Background Color Value Description 

Windows Background 1073741824 Standard background color 
indicating that the field is enabled 
for editing 

Button Face 67108864 Standard background color 
indicating that the field is disabled 
for editing. 

Example 2 
In this example, the expression sets the red background for the As Found tolerance field if the field 
value exceeds the tolerance value. 

If(as_found > tolerance, rgb(255,0,0),1073741824) 
The following table describes the background color use in the IF expression. 

Background Color Value Description 

RGB Value from 1 to 255 in 
the function rgb(0,0,0)

Colored background indicating that 
the field value exceeds the allowed 
limit 

Windows Background 1073741824 Standard background color 
indicating that the field is enabled for 
editing 

 
 

Add an Expression for Background Color of Result Field 
A result field is a field that shows a calculated value based on a calibration formula.  Use this 
procedure to set the software to display a colored background when the field value exceeds the 
specified limit, for example, if the As Found field value exceeds the allowed tolerance.  For 
examples of a field color expression, see IF Expression for Field Color (on page 628). 
1. Open the target form page saved as a .psr file in InfoMaker.  For details, see Open a Form 

Page in InfoMaker (on page 622). 
2. In the Report window, right-click the target table column, and then, click Properties. 
3. In the Properties window, click the Fonts tab. 

4. Beside the Background Color box, click . 
5. On the Background Color dialog box, do the following: 
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a. In the Functions pane, click the if(b, t, f) function, in which b stands for a Boolean 
expression, t for true, and f for false. 

b. Substitute the b argument with the name of the table column whose background you want 
to mark with a distinct color, and also define the condition. 

c. Substitute the t, f arguments with the background color parameters as you require. 
 You can substitute the t, f arguments with the InfoMaker RGB function rgb(0,0,0) 

and f with 1073741824, which is the standard Windows Background color set for an 
editable field.  In the RGB function, you can enter any number in the range between 1 and 
255, as you require. 

d. Close the Background Color dialog box. 

 On the Font tab, the icon beside the Background Color box changes to .  You 
can ignore the color setting displayed in the box because an expression overrides the 
specific property value defined in the Properties window. 

6. Save the .psr file. 
 

Add an Expression for Field Visibility 
This procedure allows you to set a certain field as visible or invisible, depending on the field 
value.  For a specific example of such a field and expression, see IF Expression for Setting Fields 
as Visible (on page 630). 
1. Open the target form page saved as a .psr file in InfoMaker.  For details, see Open a Form 

Page in InfoMaker (on page 622). 
2. In the Report window, right-click the target table column, and click Properties. 

3. In the Properties window, on the General tab, beside the Visible check box, click . 
4. On the Visible dialog box, do the following: 

a. In the Functions pane, click the if(b, t, f) function, in which b stands for a Boolean 
expression, t for true, and f for false. 

b. Substitute the b argument with the name of the table column, operator, and value. 
c. Substitute the t, f arguments with 1 indicating that the field is visible and 0 that the field is 

invisible. 
d. Close the Visible dialog box. 

 On the General tab, the icon beside the Visible check box changes to green . The 
expression overrides the Visible check box setting. 

5. Save the .psr file. 

See Also 
Customizing Form Pages in InfoMaker Common Tasks (see "Form Page Customization 
Procedures" on page 620) 
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IF Expression for Setting Fields as Visible 

Syntax 
if( b, t, f ) 
in which b stands for a Boolean expression, t for true and f for false.  You substitute the t and f 
arguments with 1 and 0.  When true, the value of 1 indicates that the field is visible and 0 that the 
field is invisible. 

Example 
In this example, the expression sets the expected output field in the Calibration Data Entry and 
Calibration History windows as visible if the As Found result point value is equal to or greater 
than 1; otherwise, the field is invisible. 

if(calib_no_pnt >= 1,1,0) 
 

Enable the Use of Fractions of an Inch 
This procedure allows you to display values in the feet-inch- sixteenths format in tank strapping 
calibrations.  You must perform this procedure because PowerBuilder, which the programming 
code basis for the Calibration module, does not support the display of fractions in data fields.  You 
can enable the use of fractions of an inch either in a data field that is represented in the database 
by a specific table column or set the software to display fractions of an inch in a computed field you 
define in InfoMaker.  To display fractions of an inch in a computed filed, you must assign an 
appropriate expression to the computed field in InfoMaker.  For a specific example of a computed 
field and expression, see Expression for Displaying Fractions of an Inch (on page 631). 

 
 The feet-inch-sixteenths format is not supported outside the Calibration module, that is, in 

browser views or when accessing the field from database tools. 
 It is only possible to display sixteenths of an inch in a calibration form field. 

Prerequisite 
 Make sure that the unit of measure for target field is defined as ft. 

1. Open the target form page saved as a .psr file in InfoMaker.  For details, see Open a Form 
Page in InfoMaker (on page 622). 

2. In the Report window, right-click the target numeric table column, and click Properties. 
3. In the Properties window, on the Edit tab, under Style Type, select EditMask. 
4. In the Mask box, type the following mask: ##-##-##/16 

 In this mask, the pound # symbol stands for a digit.  The left segment is used for foot 
values, the middle for inch values, and the right for a fraction of an inch values. 

5. Click the Format tab and do the following: 
a. Copy the mask into the Format box, so that it displays ##-##-##/16. 
b. Select Use Format. 
c. Do one of the following: 

 Define a computed field.  For details, see Define a Computed Field for Calibration. 
 Select an existing computed field. 

6. On the General tab of the Properties window, under Compute Expression, enter the 
compute expression for displaying fractions of an inch. 
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7. In the Properties window, click the Format tab and copy the mask ##-##-##/16 into the 
Format box. 

 

Expression for Displaying Fractions of an Inch 
In the following example, the compute expression defined for the computed field 
c_af_value_err_1 allows you to display a calibration result in the feet-inch-sixteenths 
format.  This computed field displays a result of the tape reading value of tank height minus gauge 
reading value in a tank strapping calibration.  In the compute expression, the following table 
columns participate: 
 as_found_value — Tape reading value in the feet-inch-sixteenths format with the 

##-##-##/16 mask defined on the Edit and Format tabs of the Properties window 
 as_left_value — Gauge reading value in the feet-inch-sixteenths format with the ##-##-##/16 

mask defined on the Edit and Format tabs of the Properties window 
If you only used decimal values, the c_af_value_err_1 field would only include the following 
expression: 

as_found_value[0] – as_left_value[0] 
The [0] value indicates that this is the first calibration result in the number or runs.  The 
PowerBuilder data window used in the calibration form page contains an array that allows you to 
enter several result points in the same table column.  In the data window, the first occurrence of 
the column in the array is indicated with the [0] value, the second with [1], and so forth.  Therefore, 
in a compute expression, all the fields should be specified the appropriate result point number in 
the array.  Since the expression includes actual table columns, you do not need to specify any 
suffixes of multi-use columns.  In the form page, each occurrence of a multi-use column is 
indicated with a unique numeric suffix.  For example, when inserting the as_left_value column 
into the form page three times, you must specify the _1 suffix for the first occurrence of the 
as_left_value column, _2 for the second occurrence, and _3 for the third occurrence.  In the data 
window, the first occurrence of the column in the array is indicated with the [0] value, the second 
run with [1], and so forth. 
To use the feet-inch-sixteenths format in the c_af_value_err_1 computed field, the compute 
expression must be as follows: 

getmaskedfeetvalue(getdecimalfeetlength(Left(String((as_found_value[
0]), 
abs(5-Len(String(as_found_value[0])))+1), 
Mid(String(as_found_value[0]), 
abs(5-Len(String(as_found_value[0])))+2,2), 
Right(String(as_found_value[0]),2)) 
- getdecimalfeetlength(Left(String(as_left_value[0]), 
abs(5-Len(String(as_left_value[0])))+1), 
Mid(String(as_left_value[0]), 
abs(5-Len(String(as_left_value[0])))+2,2), 
Right(String(as_left_value[0]),2))) 

In the compute expression, the following rules and conditions apply: 
 The table columns must be defined a feet-inch-sixteenths mask ##-##-##/16 on the Edit and 

Format tabs of the Properties window. 
 The computed field that includes these table columns must also have the same 

feet-inch-sixteenths mask on the Format tab of the Properties window. 
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 The compute expression must include the getmaskedfeetvalue and getdecimalfeetlength 
functions.  Without these function, the computed field on the calibration form does not display 
the correct value.  The getdecimalfeetlength function reads the values from each segment 
in the mask and retrieves the decimal value of the feet length.  After that, the 
getmaskedfeetvalue reads the decimal value and displays the value in the 
feet-inch-sixteenths format in the calibration form. 

 
 Although the compute expression seems complex, when defining another expression, you can 

copy the current expression to the target computed field, and then, you only need modify the 
result point occurrence in the array and the field names. 

 getdecimalfeetlength and getmaskedfeetvalue are SmartPlant Instrumentation internal 
functions (not available in InfoMaker). 

 The feet-inch-sixteenths format is not supported outside the Calibration module, that is, in 
browser views or when accessing the field from database tools. 

 It is only possible to display sixteenths of an inch in a calibration form field. 
 

PSR File Viewer 
SmartPlant Instrumentation provides you with a PowerSoft Report (.psr) file viewer that enables 
you to retrieve, view, and manage files saved in the .psr format.  You can create a .psr file when 
you want to save a report or a specification using the Save As command.  You can also view and 
edit .psr files in InfoMaker. 
The .psr format allows you to save a multi-page report and nested reports (reports which contain 
sub-reports or embedded objects).  The .psr file format also enables you to design your own 
reports in InfoMaker and use names of columns from your database.  You can then view the 
reports with the actual data in PBL Viewer. 
 

Open a PSR File From the PSR List 
Use this procedure to select an existing .psr file from the list and view its content.  The .psr file list 
is useful where you have a permanent set of standard .psr files that you want to view frequently. 
1. Within any module, click File > Import PSR. 
2. Do one of the following: 

 Click . 
 Click Actions > List. 

3. In the PSR List window, select the .psr file you want to view in the PSR File Viewer window. 

4. Click . 
 

Retrieve a Previously Saved PSR File 
1. Within any module, click File > Import PSR. 
2. Do one of the following: 

 Click . 
 Click Actions > PSR Viewer. 

3. In the Select Report File dialog box, navigate to the desired .psr file and click OK to display 
the content of the selected .psr file in the PSR File Viewer window. 
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Retrieve a Report from a PBL File 
 Prior to retrieving the reports from the appropriate .pbl file you need to define the .pbl 

file location.  To define the .pbl file location, in the [Custom] section of the Intools.ini file, for the 
LibraryList parameter, type the .pbl file path and one of the .pbl file names in the path. 

1. With the PSR File Viewer window open, click . 
2. In the standard Select Source File dialog box, navigate to the required .pbl file and click OK. 

 Make sure you select an appropriate .pbl file, as the .pbl format is also used for 
purposes other than storing reports. 

3. In the DataWindow List pop-up window, scroll to the required data window and select it. 
4. Click  to retrieve the appropriate column data from the database and display it in the PSR 

File Viewer window. 
 

Manage the PSR File List 
1. In the PSR File Viewer window, click . 
2. In the PSR List window, in the Description data field, type in a description to characterize the 

selected .psr file. 
3. Perform one of the following actions as required: 

Click... ...to do the following:  

Insert Append a new line where you can type in the path statement for an 
existing .psr file. 

File Retrieve a .psr file from a folder and add it to the list. 

Delete Remove a .psr file from the list. 

Path Set a new default path for all the files in the list.  This option is useful 
if you have moved all the .psr files in the list to the same folder and 
you need to show the new location so that the files can be found.  In 
this case, you do not need to change each file path separately.  At 
least one .psr file must already be present in the required path. 

Select Display the data for the highlighted file in the PSR File Viewer 
window. 

 If you click Path and choose a new folder location for the .psr files, the original 
paths that were displayed for the files will be overwritten.  You should therefore only use this 
option where you are certain that all the files in the list are located in the same folder. 

4. On completion of the required action, click Save. 
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Add Custom Fields in a PSR File 
When working with reports, you sometimes need to use extra fields in addition to those currently 
available to you.  A number of custom fields (named Udf C01, Udf C02, and so forth.) are 
appended by default to every .psr file that you import.  After saving a report as a .psr file, you can 
retrieve your custom field values and include them in the header of the desired report. 
1. Start InfoMaker. 
2. Build a query for generating a report.  For details, see Build a Query (on page 617). 
3. For each custom field that you want to add, do the following: 

a. With the main report window open, click Insert > Control > Computed Field. 
b. Click the mouse pointer at the position where you want to place the computed field on the 

report. 
c. On the Modify Expression dialog box, under the Expression section, type an 

expression according to the following syntax: 
ProfileString("<SmartPlant Instrumentation home 
folder>\intools.ini", "External 
Report","<s_udf_name>","<s_udf_value>") 
For example: 
ProfileString("C:\Program 
Files\SmartPlant\Instrumentation\intools.ini", "External 
Report","udf_C01","Not found") 

 The 's_udf_value' parameter is used to specify a default string to display where no 
value exists for the specified custom field. 

d. At the right of the report, using the Position, Font, and Format tabs, make the desired 
definitions for the custom field, for example, alignment, color, style, and so forth. 

4. If you intend to display more than one .psr file in the SmartPlant Instrumentation PSR List 
window, display the SQL data source, and under the where section, type the following 
expression: 
psr_storage.psr_stor_desc='<PSR description>' 

 Without adding this expression to InfoMaker, SmartPlant Instrumentation always 
retrieves from the database the first row of custom fields in the PSR List window, regardless 
of the report you select.  Make sure that the '< PSR description>' has the same value as the 
value in the Description column of the PSR List window. 

5. Save the current report as a .psr file. 
6. Open SmartPlant Instrumentation. 
7. With any main module window open, click File > Import PSR. 

8. In the PSR File Viewer window, click  to open the PSR List window. 
9. Scroll to the right side of the window to view the custom field columns and in the columns Udf 

C01 to Udf C10, type the desired values. 

10. Click Save  to save the changes to the database. 
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Retrieve Custom Field Values from PSR Files 
Use this procedure to retrieve your custom (UDF) field values from existing .psr files and include 
these values in the header of a report in SmartPlant Instrumentation. 

 If more than one .psr file is displayed in the PSR List window, you must open the 
desired report in InfoMaker, and under the Where section, type the following expression: 

psr_storage.psr_stor_desc='<PSR description>' 

Without adding this expression to InfoMaker, SmartPlant Instrumentation always retrieves from 
the database the first row of custom fields in the PSR List window, regardless of the report you 
select.  Make sure that the '< PSR description>' has the same value as the value in the 
Description column of the PSR List window.  When done, save the changes to the report and 
close InfoMaker. 
1. From SmartPlant Instrumentation, do one of the following: 

 Retrieve the desired .psr file — for details, see Retrieve a Previously Saved PSR File (on 
page 632). Then, on the PSR File View window toolbar, click . 

 Open the desired .psr file from the PSR List window.  For details, see Open a PSR File 
From the PSR List (on page 632). 

2. In the data window of the PSR List window, select a .psr file with custom fields. 
3. Do one of the following to open the PSR File Viewer window: 

 Double-click the selected .psr file. 

 Click . 
 Click Actions > Select. 

4. On the PSR File Viewer window toolbar, click . 
 For the selected file, the software copies the values in columns Udf C01 to Udf C10 to the 

[External Report] section of the Intools.ini file so that the appropriate custom field values appear in 
the report. 
 

Customizing Title Blocks for Reports 
Title blocks for reports are templates that SmartPlant Instrumentation uses for the design of its 
reports.  While the standard default title blocks supplied with the software are adequate for many 
reports, you can also create your own custom title blocks that provide you with the required design 
and layout of your reports.  You can, for example, customize report titles and headers, as well as 
the frame size of the title block. 
You first create a title block or duplicate it from an existing one using InfoMaker and save it as a 
.psr file.  You then open the .psr file in SmartPlant Instrumentation and add it to the title block 
inventory.  After that, you need to associate the title block with the required reports and finally, 
generate a report through the relevant module using the created title block. 

 It is usually more convenient to edit an existing title block and save it under a different name 
rather than to create a new one. 
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Requirements for Customized Report Title Blocks 
You can customize a title block for reports in InfoMaker.  In either application, the custom title 
block has to meet several standard requirements. The title block has to be compatible with the 
report it is associated with. Therefore, make sure that the customization process accurately fits the 
SmartPlant Instrumentation customizing conventions as specified in the following topic. 
The following list outlines mandatory and optional InfoMaker requirements: 
Report type — When creating a new report set the report type to be External (mandatory). 
Report style — Set the report style to be Tabular (mandatory). 
Field prompt — When prompted to set the required fields for a title block, type any text in the 
appropriate field.  There is no significance to inserting any particular field name as long as 
something is typed (mandatory). 
Group — The title block customization has to be performed in the Detail group (mandatory). 
Layer — Make sure that you create the title block in the Band layer (the default – mandatory). 
Design — The frame of the title block consists of four lines.  Make sure that each line has its own 
unique name typed in small caps as follows: 

Upper side L_width 

Lower side ln_down 

Left side ln_left 

Right side ln_right 
 When adding other design- related items, such as internal lines, text boxes, and so 

forth, to the title block, make sure that the names of the new items contain the tb segment.  For 
example, if you want to add a new line, name the line as < Line> _tb_< 1>. This is required to 
distinguish between items that belong to the title block and items that belong to the rest of the 
report outside the title block. 
Field type — select any field type other than Column (mandatory). 
Revisions — Make sure that you have a number 1 revision field.  For instance, a title block with 
solely a revision no. 2, would not apply. 
Report measurement units — The units of measure of the customized title block must be 
compatible with the units of measure of the report it is associated with.  All the reports were 
created in inches except for the following, which use PowerBuilder units: 
 All the calculation reports 
 The Segment map report 

Fields — SmartPlant Instrumentation created an inventory of macros available for the custom title 
block fields.  From this inventory you can select the fields that serve your purposes most.  Each 
field and macro has its unique name (this is the name to insert in the name field when creating the 
item in InfoMaker) as shown in the tables below. 

 
 Macros retrieve the data and enter it to the fields.  For these macros to function properly, you 

must insert the macro name accurately according to the macro tables below. 
 You can implement custom title blocks that for macros custom_1 through custom_5 display 

field values without labels, for example, DCS-1 instead of Panel DCS-1.  To enable this 
option, make sure that the [Custom] section of the intools.ini file includes the line 
'RemoveFixedTextFromTB=1'. 

Table includes Text type fields only: 
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Field Name Field Description 

custom_1 Report name 

custom_2 - custom_5 Item names or other data used in reports or drawings.  For 
example, in a panel-strip report, custom_2 is used to display 
the panel name, custom_3 is used to display the strip name, 
and custom_5 is used to display the domain name.  All 
values that the software can retrieve for these macros are 
hard coded.  This means that even if you use all of the 
custom fields, in the title block, fields that do not have any 
associated hard coded data appear empty. 

eproj_name Project name (owner operator domain) 

project_t Project header (owner operator domain) 

proj_name Domain name 

proj_num Project number (owner operator domain) 

city_name City name 

owner_name <Plant> owner. 

location_name Location name 

plant_hierarchy Plant hierarchy defined by the Domain Administrator.  The 
default plant hierarchy is Plant\Area\Unit.  The Domain 
Administrator has rights to change the number of plant 
hierarchy levels and customize the level names. 

hierarchy_item_name_x The name of a specific item in the plant hierarchy, where the 
segment X defines the plant hierarchy level number.  For 
example, suppose that your plant hierarchy is 
Plant\Area\Unit, and on the Unit level, you have an item 
name Crude.  To display Crude in the title block, you need to 
substitute the segment X with the number 3. 

plant_name The name of the item on the highest plant hierarchy level 
(the default highest level is Plant). 

plant_addr1 Address 1 of the highest plant hierarchy level item 

plant_addr2 Address 2 of the highest plant hierarchy level item 

plant_country Country of the highest plant hierarchy level item 

plant_state State of the highest plant hierarchy level item 

plant_zip ZIP code of the highest plant hierarchy level item 

area_name The name of the item on the intermediate level of the plant 
hierarchy (the default intermediate level is Area).  If the plant 
hierarchy has more than three levels, the macro area_name 
retrieves the name of the lowest intermediate level, that is 
one level above the lowest level of the plant hierarchy. 

unit_name The name of the item on the lowest level of the plant 
hierarchy (the default lowest level is Unit). 
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Field Name Field Description 

hierarchy_udf_y_x A custom field value associated with a specific plant 
hierarchy item.  The segment y retrieves the number of the 
custom field (the Domain Administrator can define up to 
twenty custom field values for each plant hierarchy 
item).  The segment x retrieves the number of the level to 
which the plant hierarchy item belongs. 

hierarchy_udf_y_x_t Custom fields associated with a plant hierarchy item are 
regular text fields and behave as any other custom fields that 
are available in SmartPlant Instrumentation for specific 
items. 

hierarchy_udf_y_x_t The header of a custom field associated with a specific plant 
hierarchy item.  The segments y and x correspond to the 
segments in the macro hierarchy_udf_y_x. The segment t 
indicates the header. 

tb_dwg_name_t Document number 

lastrev Last revision 

rev_no_1 - rev_no_9 Revision number 1 (mandatory field) 

rev_udf_cXX_1 - 
rev_udf_cXX_9 

Revision custom fields (for more details, see below) 

create_by_1 - create_by_9 Created by 

date_1 - date_9 The date on which the revision was created 

chk_by_1 - chk_by _9 The name or initials of the person who checked the revision

appr_by_1 - appr_by _9 The name or initials of the person authorized to approve the 
revision 

sign_by_1 - sign_by _9 The name or initials of the person authorized to sign the 
revision.  This macro appears in one of the following title 
block files that come shipped with SmartPlant 
Instrumentation: default tb with in units.psr or default tb with 
pb units.psr. 

desc_1 - desc_9 Revision description 
The following table includes Computed type fields only: 

Field name Field description Expression 

C_page_num Current sheet Page() 

C_page_count Total sheets PageCount() 

comp_1 Logo name bitmap ( ProfileString ( "intools.ini", "Project", 
"LogoPath", " " + "projlogo.bmp" ) 

Revision custom fields — You can define your own fields and related macros in addition to 
those in the inventory of macros (designated for fields) that are supplies with SmartPlant 
Instrumentation.  You can add up to 20 revision custom fields per title block.  Inserting the right 
name in the field name box is necessary for the proper function of the field in the title block.  The 
naming convention for the revision custom fields is as specified in the following table: 
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rev_udf_c01_t Header 

rev_udf_c01_1 Data field 

rev_udf_c01_2 Second data field under the same 
header 

rev_udf_c02_t Header 2 (another UDF) 

rev_udf_c02_1 The data in the field (2) 
Document custom fields — Using these fields you can have a record of the documents that 
were related to a certain report.  These are fields that you define under the following limitation: 
each custom field must have only two fields, one for the header and one for the data.  This is the 
naming convention for these fields: 

dwg_udf_c01_t Header 

dwg_udf_c01 Data field 

dwg_udf_c02_t Header 2 (another custom field) 

dwg_udf_c02 Data field (2) 
 
 

Edit Report Title Block Properties 
You can edit report title block properties under two editing levels.  The first is internal and includes 
changing the revision custom field headers, document headers and the title block name.  The 
second level is external to SmartPlant Instrumentation and includes changes in the design, 
replacing macros, fields, adding and removing fields. 
1. In the main SmartPlant Instrumentation window, click Tools > Title Blocks. 
2. In the Title Block dialog box, select the desired title block and click Properties. 
3. In the Title Block Properties dialog box, do the following: 

a. Under Revision custom field headers, in the Header column, type the name for each 
custom field. 

b. In the Title block name field, type the name that you have selected for the title block. 
c. Under Document custom field headers, in the Header column, type the name for each 

custom field. 

 
 If you want to modify the number of revisions of custom title blocks, you need to add more 

revision rows and create appropriate macros in InfoMaker.  The Revision rows box 
displays the number of revision rows that you have customized for your title block. 

 For the second level of editing you can use an external editing application (for example, 
InfoMaker).  When editing title blocks, you must follow the title block requirements. 
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